[Kernel-packages] [Bug 1688132] Re: Suport IPMI system interface on Cavium ThunderX

2017-05-03 Thread dann frazier
** Summary changed: - IPMI system interface on Cavium ThunderX systems requires manual config + Suport IPMI system interface on Cavium ThunderX -- You received this bug notification because you are a member of Kernel Packages, which is subscribed to linux in Ubuntu.

[Kernel-packages] [Bug 1688132] Re: IPMI system interface on Cavium ThunderX systems requires manual config

2017-05-03 Thread dann frazier
** Description changed: [Impact] Just loading the necessary modules is not enough to get a working IPMI system interface (/dev/ipmi0) on Cavium ThunderX CRBs, and other ThunderX-based Gigabyte servers. You have to do some magic: echo ipmi_ssif 0x12

[Kernel-packages] [Bug 1688132] [NEW] IPMI system interface on Cavium ThunderX systems requires manual config

2017-05-03 Thread dann frazier
-based systems, and is currently not usable w/o the above manual config. ** Affects: linux (Ubuntu) Importance: High Assignee: dann frazier (dannf) Status: In Progress ** Affects: linux (Ubuntu Xenial) Importance: High Assignee: dann frazier (dannf) Status: Con

[Kernel-packages] [Bug 1688114] Re: arm64/ACPI support for SBSA watchdog

2017-05-03 Thread dann frazier
** Also affects: linux (Ubuntu Zesty) Importance: Undecided Status: New ** Changed in: linux (Ubuntu Zesty) Status: New => In Progress ** Changed in: linux (Ubuntu Zesty) Importance: Undecided => High ** Changed in: linux (Ubuntu Zesty) Assignee: (unassigned) =

[Kernel-packages] [Bug 1688114] [NEW] arm64/ACPI support for SBSA watchdog

2017-05-03 Thread dann frazier
. This has been tested on the QDT2400 and HiSilicon D05, and regression tested on an non-ACPI (devicetree) HP m400 and Cavium ThunderX systems. ** Affects: linux (Ubuntu) Importance: High Assignee: dann frazier (dannf) Status: In Progress -- You received this bug notification

[Kernel-packages] [Bug 1673564] Re: ThunderX: soft lockup on 4.8+ kernels when running qemu-efi with vhost=on

2017-04-21 Thread dann frazier
Once the build is complete, you'll be able to install it with: sudo apt-add-repository ppa:yarmouth-team/thunderx sudo apt update sudo apt install linux-image-extra-4.8.0-49-generic=4.8.0-49.52~16.04.1+lp1673564.1 The PPA web page is at:

[Kernel-packages] [Bug 1673564] Re: ThunderX: soft lockup on 4.8+ kernels when running qemu-efi with vhost=on

2017-04-21 Thread dann frazier
I've uploaded a test kernel w/ a potential workaround developed by Cavium to: ppa:yarmouth-team/thunderx The build should complete in ~4 hours. Mind giving that a test? -- You received this bug notification because you are a member of Kernel Packages, which is subscribed to linux in Ubuntu.

[Kernel-packages] [Bug 1677319] Re: Support low-pin-count devices on Hisilicon SoCs

2017-04-20 Thread dann frazier
** Description changed: - The HiSilicon Hip06/Hip07 SoCs include a low-pin-count (LPC) host - controller. The Linux kernel needs support for this interface to use - attached devices, such as a UART and the IPMI system interface. + [Impact] + The HiSilicon Hip06/Hip07 SoCs include a low-pin-count

[Kernel-packages] [Bug 1677319] Re: Support low-pin-count devices on Hisilicon SoCs

2017-04-20 Thread dann frazier
** Also affects: linux (Ubuntu Zesty) Importance: Undecided Status: New ** Changed in: linux (Ubuntu Zesty) Status: New => In Progress ** Changed in: linux (Ubuntu Zesty) Importance: Undecided => High ** Changed in: linux (Ubuntu Zesty) Assignee: (unassigned) =

[Kernel-packages] [Bug 1673564] Re: ThunderX: soft lockup on 4.8+ kernels when running qemu-efi with vhost=on

2017-04-18 Thread dann frazier
Thanks, the patch is working well in our internal testing. I believe this rules out edk2, so I'll drop that task from this bug. ** No longer affects: edk2 (Ubuntu) -- You received this bug notification because you are a member of Kernel Packages, which is subscribed to linux in Ubuntu.

[Kernel-packages] [Bug 1675522] Re: arm64: Synchronous Exception at 0x00000000BBC129BC

2017-04-06 Thread dann frazier
Now that I've found time to get back to this one, I can no longer reproduce it. The machine I originally observed this on has been redeployed, so I no longer have the artifacts necessary for comparison. -- You received this bug notification because you are a member of Kernel Packages, which is

[Kernel-packages] [Bug 1673564] Re: ThunderX: soft lockup on 4.8+ kernels when running qemu-efi with vhost=on

2017-04-05 Thread dann frazier
I bisected this down to the upstream commit below. Now, that's not to say that this commit is necessarily bad - it may just make an existing problem more reproducible. commit 7235acdb1144460d9f520f0d931f3cbb79eb244c Author: Jason Wang Date: Mon Apr 25 22:14:32 2016 -0400

[Kernel-packages] [Bug 1677319] [NEW] Support low-pin-count devices on Hisilicon SoCs

2017-03-29 Thread dann frazier
Public bug reported: The HiSilicon Hip06/Hip07 SoCs include a low-pin-count (LPC) host controller. The Linux kernel needs support for this interface to use attached devices, such as a UART and the IPMI system interface. ** Affects: linux (Ubuntu) Importance: High Assignee: dann frazier

[Kernel-packages] [Bug 1673564] Re: ThunderX: soft lockup on 4.8+ kernels when running qemu-efi with vhost=on

2017-03-27 Thread dann frazier
Thanks for the steps. As you noted, I can reproduce on xenial w/ the 4.8 hwe kernel, but not with the GA 4.4. I'm marking the kernel packages as affected because the host kernel shouldn't hang, even if the guest does something bad (e.g. if edk2 is buggy). -- You received this bug notification

[Kernel-packages] [Bug 1673564] Re: ThunderX: soft lockup on 4.8+ kernels when running qemu-efi with vhost=on

2017-03-27 Thread dann frazier
** Also affects: linux (Ubuntu) Importance: Undecided Status: New ** Changed in: linux (Ubuntu) Status: New => Confirmed -- You received this bug notification because you are a member of Kernel Packages, which is subscribed to linux in Ubuntu.

[Kernel-packages] [Bug 1675951] [NEW] d-i cannot be used on the D05 BMC KVM

2017-03-24 Thread dann frazier
-installer (Ubuntu) Importance: Undecided Assignee: dann frazier (dannf) Status: New ** Affects: linux (Ubuntu) Importance: Medium Assignee: dann frazier (dannf) Status: In Progress ** Affects: debian-installer (Ubuntu Xenial) Importance: Undecided Assignee

Re: [Kernel-packages] [Bug 1675522] Re: arm64: Synchronous Exception at 0x00000000BBC129BC

2017-03-24 Thread dann frazier
On Fri, Mar 24, 2017 at 2:01 AM, ChristianEhrhardt <1675...@bugs.launchpad.net> wrote: > Hi Dann, thanks for your checks already! > Are you intending to break this down if e.g. Yakkety qemu is fixed as well as > zesty seems? > And then once we know if Y is good maybe even down to a bisect of qemu

[Kernel-packages] [Bug 1675509] Re: ARM arch_timer erratum

2017-03-23 Thread dann frazier
** Description changed: - There are a few platforms requiring errata workarounds for their - arch_timer implementations. Specifically, the HiSilicon D05 in ACPI - mode, and Cortex-A73-based systems. + The HiSilicon D05 board and systems based on Cortex-A73 each have errata + for their architected

[Kernel-packages] [Bug 1675522] Re: arm64: Synchronous Exception at 0x00000000BBC129BC

2017-03-23 Thread dann frazier
Upgrading the host from xenial's QEMU to zesty's QEMU seems to fix it. I can do several reboots of zesty w/o a hang. ** Changed in: edk2 (Ubuntu) Status: New => Invalid ** Changed in: linux (Ubuntu) Status: Incomplete => Invalid ** Changed in: grub2 (Ubuntu) Status: New =>

[Kernel-packages] [Bug 1675522] Re: arm64: Synchronous Exception at 0x00000000BBC129BC

2017-03-23 Thread dann frazier
Behavior is the same after reverting to yakkety grub. This issue follows the guest kernel that we are rebooting *from*: kernel running | kernel we | Reboot at reboot | reboot into | Success? 4.10 | 4.10 |

[Kernel-packages] [Bug 1675509] [NEW] ARM arch_timer erratum

2017-03-23 Thread dann frazier
Public bug reported: There are a few platforms requiring errata workarounds for their arch_timer implementations. Specifically, the HiSilicon D05 in ACPI mode, and Cortex-A73-based systems. ** Affects: linux (Ubuntu) Importance: High Assignee: dann frazier (dannf) Status

Re: [Kernel-packages] [Bug 1630038] Re: thunder nic: avoid link delays due to RX_PACKET_DIS

2017-03-21 Thread dann frazier
On Tue, Mar 21, 2017 at 3:41 PM, Alexandru Avadanii wrote: > Hi, > > 1) We tested different models (CRB-1S, CRB-2S) - all behave the same. > 2) Please check the logs "ThunderX 4.11-rc1 console log" in [2] linked above. > I don't think firmware version makes a

[Kernel-packages] [Bug 1672521] Re: ThunderX: soft lockup on 4.8+ kernels

2017-03-21 Thread dann frazier
@Alexandru: do you have a console log of a system hitting the issue w/ the VM use case? Soft lockups are a fairly generic failure mode, and it would not surprise me if stress-ng was triggering a different issue than the VM case, but both emitting soft lockups. -- You received this bug

[Kernel-packages] [Bug 1672502] [NEW] arm64 MSI/PCIe passthrough patches break build of certain configs

2017-03-13 Thread dann frazier
it on Ubuntu source b building the s390x image with CONFIG_PCI=n and CONFIG_IRQ_DOMAIN=n. ** Affects: linux (Ubuntu) Importance: Low Assignee: dann frazier (dannf) Status: In Progress -- You received this bug notification because you are a member of Kernel Packages, which

[Kernel-packages] [Bug 1672504] [NEW] pinctrl: qcom: add get_direction function

2017-03-13 Thread dann frazier
Ubuntu) Importance: Medium Assignee: dann frazier (dannf) Status: In Progress -- You received this bug notification because you are a member of Kernel Packages, which is subscribed to linux in Ubuntu. https://bugs.launchpad.net/bugs/1672504 Title: pinctrl: qcom: add get_direction fu

[Kernel-packages] [Bug 1672486] [NEW] arm64: Workaround QDF2400 erratum 0065

2017-03-13 Thread dann frazier
linux (Ubuntu) Importance: High Assignee: dann frazier (dannf) Status: In Progress -- You received this bug notification because you are a member of Kernel Packages, which is subscribed to linux in Ubuntu. https://bugs.launchpad.net/bugs/1672486 Title: arm64: Workaround Q

[Kernel-packages] [Bug 1671601] Re: QDF2400 PCI ports require ACS quirk

2017-03-09 Thread dann frazier
** Changed in: linux (Ubuntu) Status: Incomplete => In Progress -- You received this bug notification because you are a member of Kernel Packages, which is subscribed to linux in Ubuntu. https://bugs.launchpad.net/bugs/1671601 Title: QDF2400 PCI ports require ACS quirk Status in linux

[Kernel-packages] [Bug 1671246] Re: kexec-tools does not build for armhf

2017-03-09 Thread dann frazier
** Changed in: kexec-tools (Ubuntu Xenial) Assignee: (unassigned) => Manoj Iyer (manjo) ** Changed in: kexec-tools (Ubuntu Yakkety) Assignee: (unassigned) => Manoj Iyer (manjo) ** Changed in: kexec-tools (Ubuntu) Status: Incomplete => Invalid -- You received this bug

[Kernel-packages] [Bug 1671601] [NEW] QDF2400 PCI ports require ACS quirk

2017-03-09 Thread dann frazier
Public bug reported: Features of the QDF2400 PCI root ports are disabled because they do not advertise an ACS capability. A quirk has been merged upstream that re- enable these features on that platform: commit 33be632b8443b6ac74aa293504f430604fb9abeb Author: Sinan Kaya

[Kernel-packages] [Bug 1671602] Re: QDF2400: Fix panic introduced by erratum 1003

2017-03-09 Thread dann frazier
Addressed upstream by: commit ea6eac904f0a5a0c223bcfb133ec880ba9c70ae3 Author: Shanker Donthineni Date: Wed Feb 22 21:10:48 2017 -0600 arm64: Avoid clobbering mm in erratum workaround on QDF2400 -- You received this bug notification because you are a member of

[Kernel-packages] [Bug 1671602] [NEW] QDF2400: Fix panic introduced by erratum 1003

2017-03-09 Thread dann frazier
Public bug reported: zesty's kernel carries a backport of an erratum workaround (Falkor 1003) from 4.11-rc1. This was found to cause a crash on the QDF2400. ** Affects: linux (Ubuntu) Importance: High Assignee: dann frazier (dannf) Status: In Progress -- You received

[Kernel-packages] [Bug 1671599] [NEW] iommu: Fix static checker warning in iommu_insert_device_resv_regions

2017-03-09 Thread dann frazier
be - but it is an obvious correction. ** Affects: linux (Ubuntu) Importance: Medium Assignee: dann frazier (dannf) Status: In Progress -- You received this bug notification because you are a member of Kernel Packages, which is subscribed to linux in Ubuntu. https://bugs.launchpad.net

[Kernel-packages] [Bug 1671598] [NEW] irqchip/gic-v3-its: Enable cacheable attribute Read-allocate hints

2017-03-09 Thread dann frazier
Donthineni <shank...@codeaurora.org> Date: Wed Jan 25 21:51:41 2017 -0600 irqchip/gic-v3-its: Enable cacheable attribute Read-allocate hints ** Affects: linux (Ubuntu) Importance: Medium Assignee: dann frazier (dannf) Status: In Progress -- You received th

[Kernel-packages] [Bug 1671600] [NEW] tty: pl011: Work around QDF2400 E44 stuck BUSY bit

2017-03-09 Thread dann frazier
ff-by: Greg Kroah-Hartman <gre...@linuxfoundation.org> ** Affects: linux (Ubuntu) Importance: High Assignee: dann frazier (dannf) Status: In Progress -- You received this bug notification because you are a member of Kernel Packages, which is subscribed to linux in Ubuntu. https://bugs.laun

[Kernel-packages] [Bug 1671589] [NEW] ehci-platform needed in usb-modules udeb

2017-03-09 Thread dann frazier
. Adding this module to the usb-modules udeb produced by the kernel would be sufficient to do so. ** Affects: linux (Ubuntu) Importance: High Assignee: dann frazier (dannf) Status: In Progress -- You received this bug notification because you are a member of Kernel Packages, which

[Kernel-packages] [Bug 1671246] Re: kexec-tools does not build for armhf

2017-03-08 Thread dann frazier
** Changed in: kexec-tools (Ubuntu Xenial) Status: New => In Progress ** Changed in: kexec-tools (Ubuntu Yakkety) Status: New => In Progress ** Changed in: kexec-tools (Ubuntu Xenial) Importance: Undecided => High ** Changed in: kexec-tools (Ubuntu Yakkety) Importance:

[Kernel-packages] [Bug 1671246] Re: kexec-tools does not build for armhf

2017-03-08 Thread dann frazier
** Also affects: kexec-tools (Ubuntu Xenial) Importance: Undecided Status: New ** Also affects: kexec-tools (Ubuntu Yakkety) Importance: Undecided Status: New -- You received this bug notification because you are a member of Kernel Packages, which is subscribed to

[Kernel-packages] [Bug 1669061] [NEW] arm64: ACPI platform MSI support required for new systems

2017-03-01 Thread dann frazier
Public bug reported: The HiSilicon D05 and Qualcomm QDF2400 systems require ACPI support for platform MSIs. ** Affects: linux (Ubuntu) Importance: Undecided Assignee: dann frazier (dannf) Status: In Progress ** Changed in: linux (Ubuntu) Assignee: (unassigned) => d

[Kernel-packages] [Bug 1663400] Re: [SRU] kexec: Increase the upper limit for RAM segments

2017-02-10 Thread dann frazier
** Also affects: kexec-tools (Ubuntu Xenial) Importance: Undecided Status: New ** Summary changed: - [SRU] kexec: Increase the upper limit for RAM segments + [SRU] kexec: arm64: Increase the upper limit for RAM segments ** Also affects: kexec-tools (Ubuntu Yakkety) Importance:

Re: [Kernel-packages] [Bug 1384955] Re: support compressed kernels on arm64

2017-02-09 Thread dann frazier
On Feb 8, 2017 08:06, "Robie Basak" <1384...@bugs.launchpad.net> wrote: Are there any other systems that use flash-kernel that need to be considered in the test plan and regression potential sections? >From a flash-kernel perspective, based on the patch it seems to me that the decision to use a

[Kernel-packages] [Bug 1384955] Re: support compressed kernels on arm64

2017-02-08 Thread dann frazier
I verified this by: - MAAS deploying an HP ProLiant m400 system w/ xenial - enabling proposed - adding ppa:canonical-kernel-team/unstable (for next step) - installing linux-image-extra-4.8.0-37-generic 4.8.0-37.39~16.04.2 - verified that the previous step caused flash-kernel from proposed to

[Kernel-packages] [Bug 1659618] Re: Enable ARM64 support in kexec-tools

2017-02-08 Thread dann frazier
** Changed in: kexec-tools (Ubuntu Xenial) Importance: Undecided => High ** Changed in: kexec-tools (Ubuntu Yakkety) Importance: Undecided => High -- You received this bug notification because you are a member of Kernel Packages, which is subscribed to kexec-tools in Ubuntu.

[Kernel-packages] [Bug 1659618] Re: Enable ARM64 support in kexec-tools

2017-02-07 Thread dann frazier
** Changed in: kexec-tools (Ubuntu Xenial) Status: Confirmed => In Progress ** Changed in: kexec-tools (Ubuntu Yakkety) Status: Confirmed => In Progress ** Changed in: kexec-tools (Ubuntu Xenial) Assignee: (unassigned) => dann frazier (dannf) ** Changed in: ke

[Kernel-packages] [Bug 1661363] Re: Fails to load compressed kernels on arm64

2017-02-03 Thread dann frazier
** Also affects: kexec-tools (Ubuntu Yakkety) Importance: Undecided Status: New ** Also affects: kexec-tools (Ubuntu Xenial) Importance: Undecided Status: New -- You received this bug notification because you are a member of Kernel Packages, which is subscribed to

[Kernel-packages] [Bug 1661168] Re: In Ubuntu16.10: Kdump stuck in boot for longer time need to force reboot via HMC in 32TB Brazos System

2017-02-03 Thread dann frazier
** Changed in: kexec-tools (Ubuntu) Assignee: Taco Screen team (taco-screen-team) => dann frazier (dannf) ** Changed in: kexec-tools (Ubuntu) Status: New => In Progress -- You received this bug notification because you are a member of Kernel Packages, which is subscribed to

[Kernel-packages] [Bug 1661363] Re: Fails to load compressed kernels on arm64

2017-02-02 Thread dann frazier
As mentioned on IRC, we shouldn't include amd64 in this unless we know that it actually improves amd64 support. My guess is that this doesn't help x86 - IIRC, those images decompress themselves at runtime. -- You received this bug notification because you are a member of Kernel Packages, which

[Kernel-packages] [Bug 1661363] [NEW] Fails to load compressed kernels on arm64

2017-02-02 Thread dann frazier
Public bug reported: [Impact] kexec-tools will not load a compressed kernel on arm64. Ubuntu ships compressed kernel images on arm64 starting with 16.10 (and hwe kernels for 16.04). A workaround is to manually decompress the kernel before loading it, but this is not supported by the

[Kernel-packages] [Bug 1659618] Re: Enable ARM64 support in kexec-tools

2017-02-01 Thread dann frazier
** Changed in: kexec-tools (Ubuntu) Assignee: Louis Bouchard (louis-bouchard) => dann frazier (dannf) -- You received this bug notification because you are a member of Kernel Packages, which is subscribed to kexec-tools in Ubuntu. https://bugs.launchpad.net/bugs/1659618 Title: Ena

[Kernel-packages] [Bug 1384955] Re: support compressed kernels on arm64

2017-02-01 Thread dann frazier
ned) => Andy Whitcroft (apw) ** Changed in: flash-kernel (Ubuntu Xenial) Assignee: (unassigned) => dann frazier (dannf) ** Changed in: flash-kernel (Ubuntu Xenial) Status: Triaged => In Progress ** Description changed: - When building an upstream kernel using "make deb

[Kernel-packages] [Bug 1659618] Re: Enable ARM64 support in kexec-tools

2017-01-26 Thread dann frazier
Thanks Manoj! A few comments on your prepared package. - We need to fix in zesty and yakkety as well as xenial - Version for xenial should be 1:2.0.10-1ubuntu2.1 - Is arm64_build.patch needed? I know we had to add it to Debian for compat w/ sid's toolchain, but I'm not sure we need it for Ubuntu

[Kernel-packages] [Bug 1659618] Re: [SRU] [Xenial] Enable ARM64 support in kexec-tools

2017-01-26 Thread dann frazier
** Changed in: kexec-tools (Ubuntu) Milestone: xenial-updates => None ** Summary changed: - [SRU] [Xenial] Enable ARM64 support in kexec-tools + Enable ARM64 support in kexec-tools ** Bug watch added: Debian Bug tracker #791943 http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=791943 **

[Kernel-packages] [Bug 1649213] Re: Support rootfs on xhci-plat-hcd attached storage

2016-12-12 Thread dann frazier
** Also affects: initramfs-tools (Ubuntu Trusty) Importance: Undecided Status: New ** Also affects: linux (Ubuntu Trusty) Importance: Undecided Status: New ** Also affects: initramfs-tools (Ubuntu Xenial) Importance: Undecided Status: New ** Also affects: linux

[Kernel-packages] [Bug 1643474] Re: sysrq k(kill) always kill the Xorg under Desktop

2016-11-21 Thread dann frazier
** Package changed: procps (Ubuntu) => linux (Ubuntu) -- You received this bug notification because you are a member of Kernel Packages, which is subscribed to linux in Ubuntu. https://bugs.launchpad.net/bugs/1643474 Title: sysrq k(kill) always kill the Xorg under Desktop Status in linux

[Kernel-packages] [Bug 1633629] Re: arm64: KASLR breaks MODVERSIONS

2016-11-17 Thread dann frazier
Repurposing this bug for a yakkety d-i refresh. ** This bug is no longer a duplicate of bug 1637520 Yakkety update to v4.8.5 stable release ** Also affects: debian-installer (Ubuntu) Importance: Undecided Status: New ** No longer affects: linux (Ubuntu Yakkety) ** No longer

[Kernel-packages] [Bug 1633629] Re: arm64: KASLR breaks MODVERSIONS

2016-11-17 Thread dann frazier
*** This bug is a duplicate of bug 1637520 *** https://bugs.launchpad.net/bugs/1637520 ** Also affects: debian-installer (Ubuntu) Importance: Undecided Status: New ** No longer affects: debian-installer (Ubuntu) ** No longer affects: debian-installer (Ubuntu Yakkety) -- You

[Kernel-packages] [Bug 1634271] Re: arm64: kprobes disabled

2016-11-17 Thread dann frazier
** Tags removed: verification-needed-yakkety ** Tags added: verification-done-yakkety -- You received this bug notification because you are a member of Kernel Packages, which is subscribed to linux in Ubuntu. https://bugs.launchpad.net/bugs/1634271 Title: arm64: kprobes disabled Status in

[Kernel-packages] [Bug 1633629] Re: arm64: KASLR breaks MODVERSIONS

2016-10-20 Thread dann frazier
signed) => dann frazier (dannf) -- You received this bug notification because you are a member of Kernel Packages, which is subscribed to linux in Ubuntu. https://bugs.launchpad.net/bugs/1633629 Title: arm64: KASLR breaks MODVERSIONS Status in linux package in Ubuntu: In Progress Status

[Kernel-packages] [Bug 1634585] Re: [REGRESSION] rtc-efi no longer statically linked on arm64

2016-10-19 Thread dann frazier
** Changed in: linux (Ubuntu Trusty) Assignee: dann frazier (dannf) => (unassigned) -- You received this bug notification because you are a member of Kernel Packages, which is subscribed to linux in Ubuntu. https://bugs.launchpad.net/bugs/1634585 Title: [REGRESSION] rtc-efi no lon

[Kernel-packages] [Bug 1630038] Re: thunder nic: avoid link delays due to RX_PACKET_DIS

2016-10-18 Thread dann frazier
** Changed in: linux (Ubuntu) Status: In Progress => Fix Committed -- You received this bug notification because you are a member of Kernel Packages, which is subscribed to linux in Ubuntu. https://bugs.launchpad.net/bugs/1630038 Title: thunder nic: avoid link delays due to

[Kernel-packages] [Bug 1630038] Re: thunder nic: avoid link delays due to RX_PACKET_DIS

2016-10-18 Thread dann frazier
** Tags removed: verification-needed-xenial ** Tags added: verification-done-xenial -- You received this bug notification because you are a member of Kernel Packages, which is subscribed to linux in Ubuntu. https://bugs.launchpad.net/bugs/1630038 Title: thunder nic: avoid link delays due to

[Kernel-packages] [Bug 1630311] Re: arm64: SPCR console not autodetected

2016-10-18 Thread dann frazier
ubuntu@healy:~$ cat /proc/version Linux version 4.8.0-25-generic (buildd@bos01-arm64-050) (gcc version 6.2.0 20161005 (Ubuntu 6.2.0-5ubuntu12) ) #27-Ubuntu SMP Thu Oct 13 03:34:31 UTC 2016 ubuntu@healy:~$ cat /proc/cmdline BOOT_IMAGE=/boot/vmlinuz-4.8.0-25-generic

[Kernel-packages] [Bug 1630038] Re: thunder nic: avoid link delays due to RX_PACKET_DIS

2016-10-18 Thread dann frazier
** Tags removed: verification-needed-yakkety ** Tags added: verification-done-yakkety -- You received this bug notification because you are a member of Kernel Packages, which is subscribed to linux in Ubuntu. https://bugs.launchpad.net/bugs/1630038 Title: thunder nic: avoid link delays due to

[Kernel-packages] [Bug 1634585] Re: [REGRESSION] rtc-efi no longer statically linked on arm64

2016-10-18 Thread dann frazier
** Changed in: linux (Ubuntu Trusty) Assignee: (unassigned) => dann frazier (dannf) ** Changed in: linux (Ubuntu Trusty) Status: Triaged => In Progress -- You received this bug notification because you are a member of Kernel Packages, which is subscribed to linux in Ubuntu.

[Kernel-packages] [Bug 1608854] Re: [arm64] nova instances can't boot with 3.13.0-92

2016-10-18 Thread dann frazier
ubuntu@ubuntu:~$ archdetect arm64/efi ubuntu@ubuntu:~$ cat /proc/version Linux version 3.13.0-99-generic (buildd@bos01-arm64-032) (gcc version 4.8.4 (Ubuntu/Linaro 4.8.4-2ubuntu1~14.04.3) ) #146-Ubuntu SMP Wed Oct 12 20:56:37 UTC 2016 ** Tags removed: verification-needed-trusty ** Tags added:

[Kernel-packages] [Bug 1634585] [NEW] [REGRESSION] rtc-efi no longer statically linked on arm64

2016-10-18 Thread dann frazier
Public bug reported: The current kernel in trusty-proposed has changed rtc-efi to a module on arm64: ubuntu@ubuntu:~$ grep RTC_DRV_EFI /boot/config-3.13.0-9* /boot/config-3.13.0-98-generic:CONFIG_RTC_DRV_EFI=y /boot/config-3.13.0-99-generic:CONFIG_RTC_DRV_EFI=m This breaks setting the clock on

[Kernel-packages] [Bug 1634271] Re: arm64: kprobes disabled

2016-10-17 Thread dann frazier
** Description changed: [Impact] - kprobes are not available on arm64, a useful debug feature available on all other supported Ubuntu architectures. I failed to catch this when I reviewed the yakkety config because I was just looking for regressions vs. enabling new features (arm64/kprobes

[Kernel-packages] [Bug 1634271] [NEW] arm64: kprobes disabled

2016-10-17 Thread dann frazier
code. The notable exception is that arm64's notify_page_fault() will now get code to call kprobe_fault_handler() - but only in the case that this newly enabled feature is being used (if kprobe_running()). ** Affects: linux (Ubuntu) Importance: Medium Assignee: dann frazier (dannf

[Kernel-packages] [Bug 1633629] [NEW] arm64: KASLR breaks MODVERSIONS

2016-10-14 Thread dann frazier
w/ any regressions. ** Affects: linux (Ubuntu) Importance: High Assignee: dann frazier (dannf) Status: In Progress -- You received this bug notification because you are a member of Kernel Packages, which is subscribed to linux in Ubuntu. https://bugs.launchpad.net/bugs/1633629 T

[Kernel-packages] [Bug 1630038] Re: thunder nic: avoid link delays due to RX_PACKET_DIS

2016-10-07 Thread dann frazier
signed) => dann frazier (dannf) -- You received this bug notification because you are a member of Kernel Packages, which is subscribed to linux in Ubuntu. https://bugs.launchpad.net/bugs/1630038 Title: thunder nic: avoid link delays due to RX_PACKET_DIS Status in linux package in Ubuntu: In

[Kernel-packages] [Bug 1630311] Re: arm64: SPCR console not autodetected

2016-10-04 Thread dann frazier
https://lists.ubuntu.com/archives/kernel-team/2016-October/080236.html -- You received this bug notification because you are a member of Kernel Packages, which is subscribed to linux in Ubuntu. https://bugs.launchpad.net/bugs/1630311 Title: arm64: SPCR console not autodetected Status in

[Kernel-packages] [Bug 1630311] [NEW] arm64: SPCR console not autodetected

2016-10-04 Thread dann frazier
: linux (Ubuntu) Importance: High Assignee: dann frazier (dannf) Status: In Progress ** Changed in: linux (Ubuntu) Status: New => In Progress ** Changed in: linux (Ubuntu) Assignee: (unassigned) => dann frazier (dannf) ** Changed in: linux (Ubuntu) Impo

[Kernel-packages] [Bug 1630038] [NEW] thunder nic: avoid link delays due to RX_PACKET_DIS

2016-10-03 Thread dann frazier
the link that can only be resolved by reloading the module. [Regression Risk] Patch is to a specific driver that is only used on Cavium ThunderX systems. The patch is upstream, so will have upstream support for regressions. ** Affects: linux (Ubuntu) Importance: Medium Assignee: dann frazier

[Kernel-packages] [Bug 1623187] Re: initramfs includes qle driver, but not firmware

2016-10-03 Thread dann frazier
ubuntu@ubuntu:/tmp/x$ gunzip < /boot/initrd.img-4.4.0-41-generic | cpio -i -d 197785 blocks ubuntu@ubuntu:/tmp/x$ find | grep qed ./lib/firmware/qed ./lib/firmware/qed/qed_init_values_zipped-8.4.2.0.bin ./lib/modules/4.4.0-41-generic/kernel/drivers/net/ethernet/qlogic/qede

[Kernel-packages] [Bug 1624569] Re: thunder: chip errata w/ multiple CQEs for a TSO packet

2016-09-30 Thread dann frazier
I don't have a reliable way to reproduce this crash, but I have not seen any regressions in my testing. ** Tags removed: verification-needed-xenial ** Tags added: verification-done-xenial -- You received this bug notification because you are a member of Kernel Packages, which is subscribed to

[Kernel-packages] [Bug 1623627] Re: thunder: faulty TSO padding

2016-09-30 Thread dann frazier
** Tags removed: verification-needed-xenial ** Tags added: verification-done-xenial -- You received this bug notification because you are a member of Kernel Packages, which is subscribed to linux in Ubuntu. https://bugs.launchpad.net/bugs/1623627 Title: thunder: faulty TSO padding Status in

[Kernel-packages] [Bug 1626631] [NEW] Support ARM GIC ITS in ACPI mode

2016-09-22 Thread dann frazier
) in the currently certified DTB modes. ** Affects: linux (Ubuntu) Importance: High Assignee: dann frazier (dannf) Status: In Progress -- You received this bug notification because you are a member of Kernel Packages, which is subscribed to linux in Ubuntu. https

[Kernel-packages] [Bug 1623627] Re: thunder: faulty TSO padding

2016-09-16 Thread dann frazier
** Changed in: linux (Ubuntu) Status: Fix Committed => In Progress ** Changed in: linux (Ubuntu) Assignee: (unassigned) => dann frazier (dannf) -- You received this bug notification because you are a member of Kernel Packages, which is subscribed to linux in Ubuntu.

[Kernel-packages] [Bug 1624569] [NEW] thunder: chip errata w/ multiple CQEs for a TSO packet

2016-09-16 Thread dann frazier
: linux (Ubuntu) Importance: High Assignee: dann frazier (dannf) Status: In Progress ** Affects: linux (Ubuntu Xenial) Importance: High Assignee: dann frazier (dannf) Status: In Progress ** Summary changed: - thunder: + thunder: chip errata w/ multiple CQEs

[Kernel-packages] [Bug 1623627] [NEW] thunder: faulty TSO padding

2016-09-14 Thread dann frazier
ressions will have upstream support. Fix is limited to a driver that is only applicable to the Cavium Thunder-X SoC, so risk is negligible to other platforms. ** Affects: linux (Ubuntu) Importance: High Status: Fix Committed ** Affects: linux (Ubuntu Xenial) Importance:

[Kernel-packages] [Bug 1623187] Re: initramfs includes qle driver, but not firmware

2016-09-13 Thread dann frazier
** Changed in: linux (Ubuntu) Status: In Progress => Fix Committed ** Changed in: linux (Ubuntu Xenial) Assignee: (unassigned) => dann frazier (dannf) ** Changed in: linux (Ubuntu) Assignee: dann frazier (dannf) => (unassigned) ** Changed in: linux (Ubuntu Xenial) I

[Kernel-packages] [Bug 1623187] [NEW] initramfs includes qle driver, but not firmware

2016-09-13 Thread dann frazier
-2 [Regression Risk] Fix is upstream and the macro usage is well defined. ** Affects: linux (Ubuntu) Importance: High Assignee: dann frazier (dannf) Status: In Progress ** Affects: linux (Ubuntu Xenial) Importance: Undecided Status: In Progress ** Also affects: li

[Kernel-packages] [Bug 1608854] Re: [arm64] nova instances can't boot with 3.13.0-92

2016-09-06 Thread dann frazier
** Attachment added: "dmesg-verified.out" https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1608854/+attachment/4735728/+files/dmesg-verified.out ** Tags removed: verification-needed-trusty ** Tags added: verification-done-trusty -- You received this bug notification because you are a

[Kernel-packages] [Bug 1574814] Re: ThunderX: soft lockup in cursor_timer_handler()

2016-09-06 Thread dann frazier
@Radha If you are still seeing this bug, can you attach a console log? Here's the commit that was added in xenial to address this: commit 51b7d7350e526bde77f458fb23481e7c5d312d91 Author: David Daney Date: Tue May 24 12:55:54 2016 +0800 UBUNTU: SAUCE: tty: vt: Fix

[Kernel-packages] [Bug 1384955] Re: support compressed kernels on arm64

2016-08-28 Thread dann frazier
: New => Fix Released ** Changed in: flash-kernel (Ubuntu Xenial) Status: New => Confirmed ** Changed in: linux (Ubuntu) Status: New => In Progress ** Changed in: linux (Ubuntu) Assignee: (unassigned) => dann frazier (dannf) ** Changed in: linux (Ubuntu Xenial)

[Kernel-packages] [Bug 1616672] Re: 4.6.0-11.13 from ckt PPA fails to boot on X-Gene

2016-08-25 Thread dann frazier
This isn't an issue w/ current git (4.8-rc3+), so I bisected in hunt for the "fix". I hit this commit: commit d94ba9e7d8d5c821d0442f13b30b0140c1109c38 Merge: 1c88e19 9573e79 Author: Linus Torvalds Date: Thu Jul 28 17:06:51 2016 -0700 Merge tag

[Kernel-packages] [Bug 1616672] Re: 4.6.0-11.13 from ckt PPA fails to boot on X-Gene

2016-08-24 Thread dann frazier
** Patch added: "workaround X-Gene boot by enabling CONFIG_ARCH_ROCKCHIP" https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1616672/+attachment/4727306/+files/arm64-enable-rockchip.patch -- You received this bug notification because you are a member of Kernel Packages, which is subscribed

[Kernel-packages] [Bug 1616672] [NEW] 4.6.0-11.13 from ckt PPA fails to boot on X-Gene

2016-08-24 Thread dann frazier
Public bug reported: The 4.6.0-11.13 kernel currently in the ckt ppa fails to boot on X-Gene systems, such as the Mustang board. Even with earlycon enabled, there is no output from the kernel on the console (see the attached console log). The same kernel boots fine on other arm64 systems - this

[Kernel-packages] [Bug 1608854] Re: [arm64] nova instances can't boot with 3.13.0-92

2016-08-08 Thread dann frazier
Kernel from comment #15 boots fine in EFI mode in QEMU: ubuntu@ubuntu:~$ cat /proc/version Linux version 3.13.0-94-generic (rtg@gloin) (gcc version 4.8.2 20140110 (prerelease) [ibm/gcc-4_8-branch merged from gcc-4_8-branch, revision 205847] (Ubuntu/Linaro 4.8.2-13ubuntu1) ) #141 SMP Mon Aug 8

[Kernel-packages] [Bug 1583738] Re: arm64: statically link rtc-efi

2016-08-02 Thread dann frazier
ubuntu@ubuntu:~$ cat /proc/version Linux version 3.19.0-66-generic (buildd@bos01-arm64-026) (gcc version 4.9.2 (Ubuntu/Linaro 4.9.2-10ubuntu13) ) #74-Ubuntu SMP Tue Jul 19 15:05:47 UTC 2016 ubuntu@ubuntu:~$ dmesg | grep rtc [0.707709] rtc-efi rtc-efi: rtc core: registered rtc-efi as rtc0 [

[Kernel-packages] [Bug 1531768] Re: [arm64] lockups some time after booting

2016-07-21 Thread dann frazier
@cjwatson: Ah, ok. I may have misread the history here. I had gleaned that the xenial kernel (as a host) was more unstable - but for different reasons. Regardless, I have pulled the wily backport build I prepared, because it was frequently triggering a WARN() condition. Looks like my backport

[Kernel-packages] [Bug 1531768] Re: [arm64] lockups some time after booting

2016-07-20 Thread dann frazier
I wonder if this might be a dupe of LP: #1549494? We fixed that in xenial, but haven't backported the fix to wily. I haven't been able to reproduce this issue myself, but I uploaded a wily kernel w/ a backported fix to ppa:dannf/test, in case someone else can test it. It corresponds to the git

[Kernel-packages] [Bug 1603137] Re: libbfd changed name without transition

2016-07-14 Thread dann frazier
** Also affects: linux (Ubuntu) Importance: Undecided Status: New ** Changed in: linux (Ubuntu) Status: New => Confirmed -- You received this bug notification because you are a member of Kernel Packages, which is subscribed to linux in Ubuntu.

[Kernel-packages] [Bug 1583738] Re: arm64: statically link rtc-efi

2016-07-06 Thread dann frazier
** Changed in: linux (Ubuntu Wily) Status: New => In Progress ** Changed in: linux (Ubuntu Wily) Assignee: (unassigned) => dann frazier (dannf) ** Changed in: linux (Ubuntu Vivid) Status: New => In Progress ** Changed in: linux (Ubuntu Vivid) Assignee: (u

[Kernel-packages] [Bug 1599347] Re: [yakkety] d-i does not support (ehci_msm) Qualcomm On-Chip EHCI Host Controller

2016-07-06 Thread dann frazier
*** This bug is a duplicate of bug 1588946 *** https://bugs.launchpad.net/bugs/1588946 ** This bug has been marked a duplicate of bug 1588946 Support root on ehci-msm attached storage -- You received this bug notification because you are a member of Kernel Packages, which is subscribed

[Kernel-packages] [Bug 1597867] [NEW] thunderx nics fail to establish link

2016-06-30 Thread dann frazier
) Importance: High Assignee: dann frazier (dannf) Status: In Progress ** Affects: linux (Ubuntu Xenial) Importance: High Assignee: dann frazier (dannf) Status: In Progress ** Also affects: linux (Ubuntu Xenial) Importance: Undecided Status: New ** Changed

[Kernel-packages] [Bug 1589704] Re: workaround cavium thunderx silicon erratum 23144

2016-06-20 Thread dann frazier
Verification results from partner: I was able to successfully test your kernel on a crb2s pass1.1 system. This was tested: * started correct kernel, * executed on crb2s pass1.1, * 96 cpus detected, * node info in sysfs (indicating that numa was detected), * all pci bridges found (node

[Kernel-packages] [Bug 1589704] Re: workaround cavium thunderx silicon erratum 23144

2016-06-14 Thread dann frazier
I rebuilt d-i against the kernel in proposed and booted it a couple of times. I have not reproduced this issue, so marking it verified. ~ # uname -a Linux cvm3 4.4.0-25-generic #44-Ubuntu SMP Fri Jun 10 18:15:04 UTC 2016 aarch64 GNU/Linux ~ # dmesg | grep -i soft [0.00] Kernel command

[Kernel-packages] [Bug 1574814] Re: ThunderX: soft lockup in cursor_timer_handler()

2016-06-14 Thread dann frazier
I rebuilt d-i against the kernel in proposed and booted it a couple of times. I have not reproduced this issue, so marking it verified. ~ # uname -a Linux cvm3 4.4.0-25-generic #44-Ubuntu SMP Fri Jun 10 18:15:04 UTC 2016 aarch64 GNU/Linux ~ # dmesg | grep -i soft [ 0.00] Kernel command line:

[Kernel-packages] [Bug 1589704] Re: workaround cavium thunderx silicon erratum 23144

2016-06-14 Thread dann frazier
Oops, comment #3 was posted against the wrong bug. This one still requires verification. -- You received this bug notification because you are a member of Kernel Packages, which is subscribed to linux in Ubuntu. https://bugs.launchpad.net/bugs/1589704 Title: workaround cavium thunderx silicon

[Kernel-packages] [Bug 1590168] Re: workaround cavium thunderx silicon erratum 27704

2016-06-09 Thread dann frazier
Though this does impact the SMMU driver in v4.4, the upstream author of the workaround tells me that it isn't possible to trigger this corruption with our v4.4, since it doesn't include the new DMA API or VFIO support. I'll therefore mark this as "won't fix" for xenial. For reference, here's a

<    3   4   5   6   7   8   9   10   11   >