[Kernel-packages] [Bug 1755490] Re: Incorrect information about display shown in gnome/unity-control-center

2018-12-05 Thread Dariusz Gadomski
I have verified the following packages on Trusty: hwdata - 0.249-1ubuntu1 gnome-desktop-3 - 3.8.4-0ubuntu3.3 With the above packages installed from -proposed the labels presented in the 'Displays' panel of u-c-c are correct: when real size is available in EDID data diagonal is displayed,

[Kernel-packages] [Bug 1755490] Re: Incorrect information about display shown in gnome/unity-control-center

2018-11-30 Thread Dariusz Gadomski
I have also verified unity-settings-daemon 15.04.1+16.04.20160701-0ubuntu3 for Xenial. After connecting a faulty-EDID display - I saw the product name. With a display device with correct dimensions in EDID - screen diagonal in inches was displayed. -- You received this bug notification because

[Kernel-packages] [Bug 1755490] Re: Incorrect information about display shown in gnome/unity-control-center

2018-11-30 Thread Dariusz Gadomski
unity-settings-daemon should NOT be nominated for trusty, but I can't fix that. -- You received this bug notification because you are a member of Kernel Packages, which is subscribed to hwdata in Ubuntu. https://bugs.launchpad.net/bugs/1755490 Title: Incorrect information about display shown

[Kernel-packages] [Bug 1755490] Re: Incorrect information about display shown in gnome/unity-control-center

2018-11-30 Thread Dariusz Gadomski
** Also affects: gnome-desktop3 (Ubuntu) Importance: Undecided Status: New -- You received this bug notification because you are a member of Kernel Packages, which is subscribed to hwdata in Ubuntu. https://bugs.launchpad.net/bugs/1755490 Title: Incorrect information about display

[Kernel-packages] [Bug 1755490] Re: Incorrect information about display shown in gnome/unity-control-center

2018-11-30 Thread Dariusz Gadomski
gnome-desktop SRU proposal for trusty ** Patch removed: "trusty_gnome-desktop3_3.8.4-0ubuntu3.3.debdiff" https://bugs.launchpad.net/ubuntu/+source/hwdata/+bug/1755490/+attachment/5217608/+files/trusty_gnome-desktop3_3.8.4-0ubuntu3.3.debdiff ** Patch added:

[Kernel-packages] [Bug 1755490] Re: Incorrect information about display shown in gnome/unity-control-center

2018-11-30 Thread Dariusz Gadomski
hwdata SRU proposal for trusty ** Patch added: "trusty_hwdata_0.249-1ubuntu1.debdiff" https://bugs.launchpad.net/ubuntu/+source/hwdata/+bug/1755490/+attachment/5217607/+files/trusty_hwdata_0.249-1ubuntu1.debdiff -- You received this bug notification because you are a member of Kernel

[Kernel-packages] [Bug 1755490] Re: Incorrect information about display shown in gnome/unity-control-center

2018-11-30 Thread Dariusz Gadomski
gnome-desktop SRU proposal for trusty. ** Patch added: "trusty_gnome-desktop3_3.8.4-0ubuntu3.3.debdiff" https://bugs.launchpad.net/ubuntu/+source/hwdata/+bug/1755490/+attachment/5217608/+files/trusty_gnome-desktop3_3.8.4-0ubuntu3.3.debdiff -- You received this bug notification because you

[Kernel-packages] [Bug 1755490] Re: Incorrect information about display shown in gnome/unity-control-center

2018-11-30 Thread Dariusz Gadomski
It was brought to my attention by Dan that trusty is also worth fixing. The patch to hwdata is identical, however somewhere between trusty and xenial the make_display_name implementation has been moved from gnome- desktop to u-s-d. Hence, despite display-name.c being almost identical in both

[Kernel-packages] [Bug 1755490] Re: Incorrect information about display shown in gnome/unity-control-center

2018-11-29 Thread Dariusz Gadomski
I checked hwdata output in Unity Settings Displays menu with 2 different devices (vendors: LG and Dell) on LiveCDs for xenial, bionic, cosmic with the proposed patch installed (and with ubuntu-unity-desktop installed from universe in case of bionic and comsmic). Worked as expected (i.e. in the

[Kernel-packages] [Bug 1755490] Re: Incorrect information about display shown in gnome/unity-control-center

2018-11-29 Thread Dariusz Gadomski
Run the verifications for: hwdata | 0.267-1ubuntu2 | xenial-proposed hwdata | 0.290-1ubuntu0.18.04.1 | bionic-proposed hwdata | 0.290-1ubuntu0.18.10.1 | cosmic-proposed ** Tags removed: verification-needed-bionic verification-needed-cosmic verification-needed-xenial ** Tags added:

[Kernel-packages] [Bug 1755490] Re: Incorrect information about display shown in gnome/unity-control-center

2018-11-28 Thread Dariusz Gadomski
Looks like the latest hwdata update (0.267-1ubuntu1) doesn't have full debdiff applied. The change to hwdata-0.267/pnp.ids is missing, it contains only changes to hwdata-0.267/pnp.ids.patch. It doesn't fix the issue this way. ** Tags removed: verification-needed-xenial ** Tags added:

[Kernel-packages] [Bug 1755490] Re: Incorrect information about display shown in gnome/unity-control-center

2018-11-28 Thread Dariusz Gadomski
Brian: afaik disco version of hwdata has been synced with latest upstream by Sebastien. Upstream has this change already applied. With the disco package source: grep GSM hwdata-0.317/pnp.ids* hwdata-0.317/pnp.ids:GSMLG Electronics hwdata-0.317/pnp.ids.patch:-GSM Goldstar Company Ltd

[Kernel-packages] [Bug 1755490] Re: Incorrect information about display shown in gnome/unity-control-center

2018-11-27 Thread Dariusz Gadomski
I've just verified it on xenial (15.04.1+16.04.20160701-0ubuntu3). Works as expected. Thanks! ** Tags removed: verification-needed verification-needed-xenial ** Tags added: verification-done verification-done-xenial -- You received this bug notification because you are a member of Kernel

[Kernel-packages] [Bug 1755490] Re: Incorrect information about display shown in gnome/unity-control-center

2018-11-27 Thread Dariusz Gadomski
I have also provided debdiffs for hwdata (disco is already synced with upstream) so that LG devices are not shown under Goldstar label. -- You received this bug notification because you are a member of Kernel Packages, which is subscribed to hwdata in Ubuntu.

[Kernel-packages] [Bug 1755490] Re: Incorrect information about display shown in gnome/unity-control-center

2018-11-27 Thread Dariusz Gadomski
hwdata SRU proposal for bionic. ** Patch added: "bionic_hwdata_0.290-1ubuntu1.debdiff" https://bugs.launchpad.net/ubuntu/+source/hwdata/+bug/1755490/+attachment/5216710/+files/bionic_hwdata_0.290-1ubuntu1.debdiff -- You received this bug notification because you are a member of Kernel

[Kernel-packages] [Bug 1755490] Re: Incorrect information about display shown in gnome/unity-control-center

2018-11-27 Thread Dariusz Gadomski
hwdata SRU proposal for cosmic. ** Patch added: "cosmic_hwdata_0.290-1ubuntu1.debdiff" https://bugs.launchpad.net/ubuntu/+source/hwdata/+bug/1755490/+attachment/5216709/+files/cosmic_hwdata_0.290-1ubuntu1.debdiff -- You received this bug notification because you are a member of Kernel

[Kernel-packages] [Bug 1755490] Re: Incorrect information about display shown in gnome/unity-control-center

2018-11-27 Thread Dariusz Gadomski
hwdata SRU proposal for xenial. ** Patch added: "xenial_hwdata_0.267-1ubuntu1.debdiff" https://bugs.launchpad.net/ubuntu/+source/hwdata/+bug/1755490/+attachment/5216711/+files/xenial_hwdata_0.267-1ubuntu1.debdiff -- You received this bug notification because you are a member of Kernel

[Kernel-packages] [Bug 1755490] Re: Incorrect information about display shown in gnome/unity-control-center

2018-11-23 Thread Dariusz Gadomski
Alright, thanks Seb. It makes it verified then. ** Tags removed: verification-needed-bionic ** Tags added: verification-done-bionic ** Tags removed: verification-needed ** Tags added: verification-done ** Tags removed: verification-needed-cosmic ** Tags added: verification-done-cosmic -- You

[Kernel-packages] [Bug 1755490] Re: Incorrect information about display shown in gnome/unity-control-center

2018-11-22 Thread Dariusz Gadomski
I have just verified both: bionic (15.04.1+18.04.20180413-0ubuntu1.2) and cosmic (15.04.1+18.04.20180413-0ubuntu3) u-s-d packages. In both cases it calculates the diagonal correctly or puts the model name if the real dimensions are not available. However, there is a problem I didn't see coming:

[Kernel-packages] [Bug 1755490] Re: Incorrect information about display shown in unity-control-center

2018-11-21 Thread Dariusz Gadomski
** Description changed: [Impact]  * There is a number of display devices that misuse the width & height field in EDID. Instead of real size in centimeters it contains encoded aspect ratio (e.g. 1600x900, 16x10, 160x90). This leads to incorrect calculation of diagonal for the purpose of

[Kernel-packages] [Bug 1755490] Re: Incorrect information about display shown in unity-control-center

2018-11-21 Thread Dariusz Gadomski
seb128: I checked and sadly none of the releases (including disco) contains the hwdb fix - looks like it hasn't been released yet upstream - latest systemd release (239) has been published before the fix has been comitted. -- You received this bug notification because you are a member of Kernel

[Kernel-packages] [Bug 1755490] Re: Incorrect information about display shown in unity-control-center

2018-11-20 Thread Dariusz Gadomski
seb128: it's also fixed in hwdb upstream (https://github.com/systemd/systemd/pull/10051). I need to check if that's already present in Bionic. -- You received this bug notification because you are a member of Kernel Packages, which is subscribed to hwdata in Ubuntu.

[Kernel-packages] [Bug 1755490] Re: Incorrect information about display shown in unity-control-center

2018-11-20 Thread Dariusz Gadomski
** Description changed: [Impact] - * There is a number of display devices that misuse the width & height field in EDID. Instead of real size in centimeters it contains encoded aspect ratio (e.g. 1600x900, 16x10, 160x90). +  * There is a number of display devices that misuse the width &

[Kernel-packages] [Bug 1755490] Re: Incorrect information about display shown in unity-control-center

2018-11-20 Thread Dariusz Gadomski
** Description changed: + [Impact] + + * There is a number of display devices that misuse the width & height field in EDID. Instead of real size in centimeters it contains encoded aspect ratio (e.g. 1600x900, 16x10, 160x90). + This leads to incorrect calculation of diagonal for the purpose of

[Kernel-packages] [Bug 1755490] Re: Incorrect information about display shown in unity-control-center

2018-11-05 Thread Dariusz Gadomski
It's still valid. hwdata fixed the "vendor name" part of the issue. u-s-d needs to be patched to fix the "nonsense diagonal calculation" part. -- You received this bug notification because you are a member of Kernel Packages, which is subscribed to hwdata in Ubuntu.

[Kernel-packages] [Bug 1721988] Re: Ubuntu 17.10 full disk encryption + Nvidia drivers not booting

2018-07-27 Thread Dariusz Gadomski
** No longer affects: nvidia-graphics-drivers-384 (Ubuntu) -- You received this bug notification because you are a member of Kernel Packages, which is subscribed to nvidia-graphics-drivers-384 in Ubuntu. https://bugs.launchpad.net/bugs/1721988 Title: Ubuntu 17.10 full disk encryption + Nvidia

[Kernel-packages] [Bug 1721988] Re: Ubuntu 17.10 full disk encryption + Nvidia drivers not booting

2018-07-27 Thread Dariusz Gadomski
Thanks @goingwc, I have managed to reproduce it here so I can use my own plymouth log. Turns out I couldn't get even 18.04 working correctly, because I had integrated GPU enabled in my motherboard settings (i7-6700K with HD 530) despite nvidia being set to "primary GPU". I had to disable the

[Kernel-packages] [Bug 1721988] Re: Ubuntu 17.10 full disk encryption + Nvidia drivers not booting

2018-07-24 Thread Dariusz Gadomski
Hi, Could anyone that has it working on 18.04 add plymouth:debug to their kernel cmdline, reboot and share the /var/log/plymouth-debug.log? I'm looking into this, but also experience the issue on 18.04. I'm curious where the difference comes from. Thanks! -- You received this bug notification

[Kernel-packages] [Bug 1755490] Re: Incorrect information about display shown in unity-control-center

2018-05-25 Thread Dariusz Gadomski
** Changed in: unity-settings-daemon (Ubuntu) Status: Invalid => In Progress ** Changed in: hwdata (Ubuntu) Status: New => In Progress -- You received this bug notification because you are a member of Kernel Packages, which is subscribed to hwdata in Ubuntu.

[Kernel-packages] [Bug 1755490] Re: Incorrect information about display shown in unity-control-center

2018-03-15 Thread Dariusz Gadomski
After examining raw EDID data from 2 different LG TVs I can see that both of them set bytes 21 and 22 of the EDID data in a wrong way. They both state that the display size is 160x90 cm which in turn corresponds to a approximately 72" diagonal. So unity-settings-daemon does its job correctly

[Kernel-packages] [Bug 1755490] Re: Incorrect information displayed in unity-control-center

2018-03-13 Thread Dariusz Gadomski
Another thing is the diagonal length calculation. From my quick look this is done based on EDID data in unity-settings-daemon. ** Summary changed: - Incorrect information displayed in unity-control-center + Incorrect information about display shown in unity-control-center -- You received this

[Kernel-packages] [Bug 1755490] Re: Incorrect information displayed in unity-control-center

2018-03-13 Thread Dariusz Gadomski
Goldstar seems to be a former name of LG (before the Lucky-Goldstar merge). I've made a pull request upstream to update it: https://github.com/vcrhonek/hwdata/pull/1 ** Also affects: unity-settings-daemon (Ubuntu) Importance: Undecided Status: New -- You received this bug

[Kernel-packages] [Bug 1755490] [NEW] Incorrect information about display shown in unity-control-center

2018-03-13 Thread Dariusz Gadomski
Public bug reported: After connecting a LG 49UB850T-DA TV the following information is displayed in the unity-control-center: Goldstar Company Ltd 72" It's misleading since neither the company name nor the diagonal matches. ** Affects: hwdata (Ubuntu) Importance: Undecided Status:

[Kernel-packages] [Bug 1746482] Re: mount.cifs stopped working with protocol version>1 and sec=ntlm

2018-02-05 Thread Dariusz Gadomski
After the preliminary analysis my understanding is as follows: since the change found thanks to the bisection the behaviour change in a way that if an unsupported security mode is requested it results in an error (invalid argument in this case). Looks like NTLM was not supported even before the

[Kernel-packages] [Bug 1746482] Re: mount.cifs stopped working with protocol version>1 and sec=ntlm

2018-02-05 Thread Dariusz Gadomski
** Summary changed: - mount.cifs stopped working with protocol version != 1.0 + mount.cifs stopped working with protocol version>1 and sec=ntlm -- You received this bug notification because you are a member of Kernel Packages, which is subscribed to linux in Ubuntu.

[Kernel-packages] [Bug 1746482] Re: mount.cifs stopped working with protocol version != 1.0

2018-02-05 Thread Dariusz Gadomski
Bisecting between v4.10 and v4.11 resulted in finding that this was caused by the following commit: [ef65aaede23f75977af56a8c330bb9be8c6e125c] smb2: Enforce sec= mount option Reverting it on top of v4.11 makes it go away. Looking more into it. -- You received this bug notification because you

[Kernel-packages] [Bug 1746482] Re: mount.cifs stopped working with protocol version != 1.0

2018-02-02 Thread Dariusz Gadomski
** Description changed: On a Xenial installation after upgrading to the HWE 4.13.0-32-generic kernel it is not possible to use mount.cifs with -o vers=x.y different than 1.0. Steps to reproduce: 1. Setup a local Samba share. 2. Run: - mount.cifs -o user=,vers=2.0

[Kernel-packages] [Bug 1746482] Re: mount.cifs stopped working with protocol version != 1.0

2018-02-02 Thread Dariusz Gadomski
Conclusion after correcting the parameters in my test procedure: v4.10 - good v4.11 - bad v4.15 - bad I'm performing a bisect between v4.10 and v4.11. -- You received this bug notification because you are a member of Kernel Packages, which is subscribed to linux in Ubuntu.

[Kernel-packages] [Bug 1746482] Re: mount.cifs stopped working with protocol version != 1.0

2018-02-02 Thread Dariusz Gadomski
Added updated dmesg (with verbose error message). ** Attachment added: "dmesg.log" https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1746482/+attachment/5047511/+files/dmesg_latest.log ** Attachment removed: "dmesg.txt"

[Kernel-packages] [Bug 1746482] Re: mount.cifs stopped working with protocol version != 1.0

2018-02-02 Thread Dariusz Gadomski
Looks like I've been mislead by the man page of mount.cifs and linux/fs/cifs/connect.c which state: man mount.cifs: vers= SMB protocol version. Allowed values are: · 1.0 - The classic CIFS/SMBv1 protocol. This is the default. 4.13 kernel code: pr_warn("No dialect

[Kernel-packages] [Bug 1746482] Re: mount.cifs stopped working with protocol version != 1.0

2018-02-02 Thread Dariusz Gadomski
Added updated dmesg (with verbose error message). ** Attachment added: "dmesg.log" https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1746482/+attachment/5047510/+files/dmesg_latest.log -- You received this bug notification because you are a member of Kernel Packages, which is subscribed

[Kernel-packages] [Bug 1746482] Re: mount.cifs stopped working with protocol version != 1.0

2018-02-01 Thread Dariusz Gadomski
Surprisingly it works perfectly fine for 4.15.0-041500-generic. I have tested vers= parameter from 1.0 to 3.0 - no issues at all. I went forward and tested v4.14 - it is not affected by the issue as well. -- You received this bug notification because you are a member of Kernel Packages, which

[Kernel-packages] [Bug 1746482] Re: mount.cifs stopped working with protocol version != 1.0

2018-01-31 Thread Dariusz Gadomski
dmesg output after reproducing the issue with echo 7 > /proc/fs/cifs/cifsFYI ** Attachment added: "dmesg.txt" https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1746482/+attachment/5046387/+files/dmesg.txt -- You received this bug notification because you are a member of Kernel Packages,

[Kernel-packages] [Bug 1746482] Re: mount.cifs stopped working with protocol version != 1.0

2018-01-31 Thread Dariusz Gadomski
As discussed with cascardo I tested the mainline builds from [1]. After some tests the results were: v4.12.14 - good v4.13 - bad So the regression seems to be introduced in v4.13. [1] http://kernel.ubuntu.com/~kernel-ppa/mainline/ -- You received this bug notification because you are a member

[Kernel-packages] [Bug 1746482] [NEW] mount.cifs stopped working with protocol version != 1.0

2018-01-31 Thread Dariusz Gadomski
Public bug reported: On a Xenial installation after upgrading to the HWE 4.13.0-32-generic kernel it is not possible to use mount.cifs with -o vers=x.y different than 1.0. Steps to reproduce: 1. Setup a local Samba share. 2. Run: mount.cifs -o user=,vers=2.0 //localhost/theshare/ /mnt/theshare

[Kernel-packages] [Bug 1718688] Re: Can't connect to a Cisco AP with Wi-Fi Direct Client Policy enabled

2017-11-07 Thread Dariusz Gadomski
Since I don't have access to the actual Cisco hardware for testing I have been experimenting with hostapd lately. After rebuilding it with CONFIG_P2P_MANAGER=y I was able to reproduce similar behavior as observed with Cisco hw (except for blacklisting) and as described in WiFi P2P spec v1.7

[Kernel-packages] [Bug 1718688] [NEW] Can't connect to a Cisco AP with Wi-Fi Direct Client Policy enabled

2017-09-21 Thread Dariusz Gadomski
Public bug reported: There is a setting available on selected Cisco hardware named "Wi-Fi Direct Client Policy". One of the allowed option there is 'not-allow'. It's intention is to block WiFi P2P capable devices from connecting to it. If a device trying to associate with an AP with this setting

[Kernel-packages] [Bug 1674680] Re: Deprecated rfcomm.conf still mentioned in bluetooth.conf and README

2017-08-07 Thread Dariusz Gadomski
Patch proposal for Artful. ** Patch added: "artful_bluez_5.45-0ubuntu3.debdiff" https://bugs.launchpad.net/ubuntu/+source/bluez/+bug/1674680/+attachment/4928420/+files/artful_bluez_5.45-0ubuntu3.debdiff ** Patch removed: "artful_bluez_5.45-0ubuntu3.debdiff"

[Kernel-packages] [Bug 1674680] Re: Deprecated rfcomm.conf still mentioned in bluetooth.conf and README

2017-08-07 Thread Dariusz Gadomski
Artful patch proposal. ** Patch added: "artful_bluez_5.45-0ubuntu3.debdiff" https://bugs.launchpad.net/ubuntu/+source/bluez/+bug/1674680/+attachment/4928336/+files/artful_bluez_5.45-0ubuntu3.debdiff ** Patch removed: "zesty_bluez_5.43-0ubuntu2.debdiff"

[Kernel-packages] [Bug 1674680] Re: Deprecated rfcomm.conf still mentioned

2017-03-22 Thread Dariusz Gadomski
** Description changed: + [Impact] + + * The package contains misleading documentation mentioning the use of + /etc/bluetooth/rfcomm.conf for rfcomm setup while the support for config + file has been dropped after 14.04 release. I have directly received a + question about it from a user mislead

[Kernel-packages] [Bug 1674680] Re: Deprecated rfcomm.conf still mentioned

2017-03-21 Thread Dariusz Gadomski
Patch proposal for Zesty. ** Tags added: sts sts-sponsor ** Patch added: "zesty_bluez_5.43-0ubuntu2.debdiff" https://bugs.launchpad.net/ubuntu/+source/bluez/+bug/1674680/+attachment/4841667/+files/zesty_bluez_5.43-0ubuntu2.debdiff -- You received this bug notification because you are a

[Kernel-packages] [Bug 1674680] Re: Deprecated rfcomm.conf still mentioned

2017-03-21 Thread Dariusz Gadomski
** Summary changed: - Dropped rfcomm.conf still mentioned + Deprecated rfcomm.conf still mentioned ** Description changed: Support for config files has been dropped upstream in 2012 (however version shipped with Trusty still supports it), but the latest versions (including Xenial and

[Kernel-packages] [Bug 1674680] [NEW] Dropped rfcomm.conf still mentioned

2017-03-21 Thread Dariusz Gadomski
Public bug reported: Support for config files has been dropped upstream in 2012 (however version shipped with Trusty still supports it), but the latest versions (including Xenial and Zesty) still mention it in the docs and in the legacy /etc/init/bluetooth.conf file. ** Affects: bluez (Ubuntu)

[Kernel-packages] [Bug 1124250] Re: Partially incorrect uid mapping with nfs4/idmapd/ldap-auth

2015-05-04 Thread Dariusz Gadomski
Stef, thanks for the update. Can you please confirm that you have upgraded your kernel to version 3.13.0-51.84 or later? This is the first release that has this fix. The version you mentioned earlier (3.13.0.51.44) is expected to be still affected by this bug. Thank you. -- You received this

[Kernel-packages] [Bug 1124250] Re: Partially incorrect uid mapping with nfs4/idmapd/ldap-auth

2015-05-04 Thread Dariusz Gadomski
Thank you Stef. I have verified the fix on trusty with trusty kernel. I will try to set up a precise environment with trusty kernel and reproduce this issue. -- You received this bug notification because you are a member of Kernel Packages, which is subscribed to linux in Ubuntu.

[Kernel-packages] [Bug 1124250] Re: Partially incorrect uid mapping with nfs4/idmapd/ldap-auth

2015-04-28 Thread Dariusz Gadomski
stef: can you please check after you observe the problem if your key quota is not exceeded? You may do this with: $ sudo cat /proc/key-users This fix is known to solve the expired keys problem, but if the cause of the issue you are experiencing is the capacity of the key quota you may have to

[Kernel-packages] [Bug 1124250] Re: Partially incorrect uid mapping with nfs4/idmapd/ldap-auth

2015-04-15 Thread Dariusz Gadomski
The fix has been tagged as: - Ubuntu-3.13.0-50.82 for Trusty - Ubuntu-3.16.0-35.46 for Utopic I don't see those version available in -updates yet, so please give it some more time to be release. Thanks! -- You received this bug notification because you are a member of Kernel Packages, which is

[Kernel-packages] [Bug 1124250] Re: Partially incorrect uid mapping with nfs4/idmapd/ldap-auth

2015-03-26 Thread Dariusz Gadomski
** Description changed: + [Impact] + + * This bug is likely to cause an incorrect UID/GID mapping for NFS + shares in case of large numbers of differend UIDs/GIDs or in case of + expired UID/GID mappings (stored as keys in the kernel). + + [Test Case] + + 1. Setup a nfs4 server exporting

[Kernel-packages] [Bug 1410779] Re: Bluetooth adapter is not working in Ubuntu 14.04

2015-01-14 Thread Dariusz Gadomski
Thanks Victor for your report. I am aware that you were trying: sudo rfkill unblock 3 [sudo] password for vestival: vestival@vestival01:~$ sudo rfkill list 0: tpacpi_wwan_sw: Wireless WAN Soft blocked: no Hard blocked: no 1: phy0: Wireless LAN Soft blocked: no Hard blocked: no 3: hci0:

[Kernel-packages] [Bug 1410779] Re: Bluetooth adapter is not working in Ubuntu 14.04

2015-01-14 Thread Dariusz Gadomski
Adding syslog with enhannced debugging information from bluetoothd. ** Attachment added: Syslog with -d passed to bluetoothd https://bugs.launchpad.net/ubuntu/+source/bluez/+bug/1410779/+attachment/4298384/+files/syslog -- You received this bug notification because you are a member of

[Kernel-packages] [Bug 1124250] Re: Partially incorrect uid mapping with nfs4/idmapd/ldap-auth

2014-12-10 Thread Dariusz Gadomski
Carl, I have backported the fixes to trusty kernel. Could you please give them a try in your environment? The build is available in my PPA (ppa:dgadomski/kernel-nfs). Thanks! -- You received this bug notification because you are a member of Kernel Packages, which is subscribed to linux in

[Kernel-packages] [Bug 1124250] Re: Partially incorrect uid mapping with nfs4/idmapd/ldap-auth

2014-12-09 Thread Dariusz Gadomski
I believe this is the commit in question: https://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/commit/?id=0b0a84154eff56913e91df29de5c3a03a0029e38 Looks like a good canditate for considering a cherry-pick. -- You received this bug notification because you are a member of Kernel

[Kernel-packages] [Bug 1124250] Re: Partially incorrect uid mapping with nfs4/idmapd/ldap-auth

2014-11-06 Thread Dariusz Gadomski
Hello Bryan, The commit that has fixed this was https://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/commit/?id=738c5d190f6540539a04baf36ce21d46b5da04bd I think we can make use of it. -- You received this bug notification because you are a member of Kernel Packages, which is

[Kernel-packages] [Bug 1124250] Re: Partially incorrect uid mapping with nfs4/idmapd/ldap-auth

2014-11-06 Thread Dariusz Gadomski
@Bryan Yes, you're right. It should hit vivid and since it is already configurable by sysctl there is no point in backporting. -- You received this bug notification because you are a member of Kernel Packages, which is subscribed to linux in Ubuntu. https://bugs.launchpad.net/bugs/1124250

[Kernel-packages] [Bug 1386781] [NEW] Failure initializing radeon (as /dev/card1) renderer: unexpectedly disconnected from boot status daemon

2014-10-28 Thread Dariusz Gadomski
/commit/?id=e982dc255c0f471e67eb7bd0858c170d103d39ce) but according to the plymouth debug log (attached) radeon fails to open. ** Affects: plymouth Importance: Unknown Status: Unknown ** Affects: plymouth (Ubuntu) Importance: Undecided Assignee: Dariusz Gadomski (dgadomski