[Kernel-packages] [Bug 1881623] Re: USB support missing in initrd makes booting core with writable on USB impossible

2020-08-07 Thread Oliver Grawert
i'll try over the weekend ... -- You received this bug notification because you are a member of Kernel Packages, which is subscribed to linux-raspi2 in Ubuntu. https://bugs.launchpad.net/bugs/1881623 Title: USB support missing in initrd makes booting core with writable on USB impossible

[Kernel-packages] [Bug 1881623] Re: USB support missing in initrd makes booting core with writable on USB impossible

2020-07-09 Thread Oliver Grawert
in fact it seems like in 5.3 USB is not working at all !!! i verified that today ... my self-built kernel uses the focal 5.4 branch where USB works fine then: https://github.com/ogra1/linux-raspberrypi- org/blob/master/snap/snapcraft.yaml -- You received this bug notification because you are a

[Kernel-packages] [Bug 1881623] Re: USB support missing in initrd makes booting core with writable on USB impossible

2020-07-08 Thread Oliver Grawert
also note that the fabrica appliance you linked uses a re-built kernel -- You received this bug notification because you are a member of Kernel Packages, which is subscribed to linux-raspi2 in Ubuntu. https://bugs.launchpad.net/bugs/1881623 Title: USB support missing in initrd makes booting

[Kernel-packages] [Bug 1881623] Re: USB support missing in initrd makes booting core with writable on USB impossible

2020-07-08 Thread Oliver Grawert
hmm, i wonder why they dont load then ? -- You received this bug notification because you are a member of Kernel Packages, which is subscribed to linux-raspi2 in Ubuntu. https://bugs.launchpad.net/bugs/1881623 Title: USB support missing in initrd makes booting core with writable on USB

[Kernel-packages] [Bug 1881631] Re: arm64 Ubuntu kernel builds missing CONFIG_NLS_ASCII

2020-06-02 Thread Oliver Grawert
this is definitely a regression, mounting partitions should work ... marking as critical. ** Changed in: linux-raspi2 (Ubuntu) Importance: Undecided => Critical -- You received this bug notification because you are a member of Kernel Packages, which is subscribed to linux-raspi2 in Ubuntu.

[Kernel-packages] [Bug 1881623] Re: USB support missing in initrd makes booting core with writable on USB impossible

2020-06-01 Thread Oliver Grawert
** Also affects: linux-raspi (Ubuntu) Importance: Undecided Status: New -- You received this bug notification because you are a member of Kernel Packages, which is subscribed to linux-raspi2 in Ubuntu. https://bugs.launchpad.net/bugs/1881623 Title: USB support missing in initrd

[Kernel-packages] [Bug 1881623] Re: USB support missing in initrd makes booting core with writable on USB impossible

2020-06-01 Thread Oliver Grawert
** Description changed: when using a gadget.yaml like: volumes:   pi4-system-boot: schema: mbr bootloader: u-boot structure:   - type: 0C filesystem: vfat filesystem-label: system-boot size: 512M content:   -

[Kernel-packages] [Bug 1881623] Re: USB support missing in initrd makes booting core with writable on USB impossible

2020-06-01 Thread Oliver Grawert
** Description changed: when using a gadget.yaml like: volumes:   pi4-system-boot: schema: mbr bootloader: u-boot structure:   - type: 0C filesystem: vfat filesystem-label: system-boot size: 512M content:   -

[Kernel-packages] [Bug 1881623] [NEW] USB support missing in initrd makes booting core with writable on USB impossible

2020-06-01 Thread Oliver Grawert
Public bug reported: when using a gadget.yaml like: volumes:   pi4-system-boot: schema: mbr bootloader: u-boot structure:   - type: 0C filesystem: vfat filesystem-label: system-boot size: 512M content:   - source: boot-assets/

[Kernel-packages] [Bug 1876862] Re: Missing v3d driver disables 3D support on RPi4

2020-05-13 Thread Oliver Grawert
adding bionic since we're supposed to fully support the pi4 there too ** Also affects: linux-raspi (Ubuntu Bionic) Importance: Undecided Status: New -- You received this bug notification because you are a member of Kernel Packages, which is subscribed to linux-raspi in Ubuntu.

[Kernel-packages] [Bug 1851233] Re: building a snap from the eoan tree using the raspi2 defconfig results in gigantic snap package

2019-11-06 Thread Oliver Grawert
the included snapcraft.yaml means i need to have the whole tree locally on disk, as someone who maintains a ton of community images for UbuntuCore i prefer to just have the snapcraft.yaml locally so the disk is only cluttered during build. along with that i am trying to build the eoan tree for the

[Kernel-packages] [Bug 1851233] Re: building a snap from the eoan tree using the raspi2 defconfig results in gigantic snap package

2019-11-06 Thread Oliver Grawert
well, as a user/customer building my own kernel i'd kind of expect the defconfig for a flavour to not be a debug config. but indeed you are correct, i should have taken a look at the included snapcraft.yaml which, despite being for the wrong flavour (generic/pc- kernel), indeed contains

[Kernel-packages] [Bug 1851233] Re: building a snap from the eoan tree using the raspi2 defconfig results in gigantic snap package

2019-11-04 Thread Oliver Grawert
ok, this looks a bit more reasonable now ... $ ls -lh pi4-kernel_raspi2-5.3.0-1011.12_armhf.snap -rw-r--r-- 1 ogra ogra 211M Nov 4 17:05 pi4-kernel_raspi2-5.3.0-1011.12_armhf.snap so CONFIG_DEBUG_INFO=y should better be turned off by default for people building snaps from our trees ;) --

[Kernel-packages] [Bug 1851233] Re: building a snap from the eoan tree using the raspi2 defconfig results in gigantic snap package

2019-11-04 Thread Oliver Grawert
yup, seems this is (surprisingly) on by default ... $ grep DEBUG_INFO parts/kernel/build/.config CONFIG_DEBUG_INFO=y # CONFIG_DEBUG_INFO_REDUCED is not set # CONFIG_DEBUG_INFO_SPLIT is not set CONFIG_DEBUG_INFO_DWARF4=y # CONFIG_DEBUG_INFO_BTF is not set i'll try a re-build and override that

[Kernel-packages] [Bug 1851233] Re: building a snap from the eoan tree using the raspi2 defconfig results in gigantic snap package

2019-11-04 Thread Oliver Grawert
i also tried using the "source-branch: raspi2" argument in the snapcraft.yaml instead of using teh master branch and the "source-tag:" option, but this results in the same big size ... additionally i'd like to remark that due to the transactional nature of UbuntuCore we need to keep the kernel

[Kernel-packages] [Bug 1851233] [NEW] building a snap from the eoan tree using the raspi2 defconfig results in gigantic snap package

2019-11-04 Thread Oliver Grawert
Public bug reported: typically a kernel snap built from the kernel.ubuntu.com tree using the raspi2 defconfig results in a snap package that is below 150MB in size: $ ls -lh pi2-kernel_raspi2-4.4.0-1110.snap -rw--- 1 root root 129M Jun 4 15:01 pi2-kernel_raspi2-4.4.0-1110.snap trying to

[Kernel-packages] [Bug 1837209] Re: Splash screen fails to display on recent pi core18 images

2019-07-22 Thread Oliver Grawert
mir-kiosk is currently the only supported way to get grahical (mostly kiosk) applications up and running on ubuntu core, some of our digital- signage customers use it so currently the overlay is a requirement (until the mir team solves it with a pi specific mir backend or the vc4 driver changes in

[Kernel-packages] [Bug 1837209] Re: Splash screen fails to display on recent pi core18 images

2019-07-19 Thread Oliver Grawert
the overlay is needed for mir-kiosk to allow it to work at all (unaccelerated though) to have mir-kiosk fully accelerated one needs to use -kms-v3d instead but this in turn disables all video decoding in the vc4 core. i originally picked -fkms-v3d for the gadget since it is the least evil (makes

[Kernel-packages] [Bug 1783961] Re: CONFIG_KVM is disabled for linux-raspi2 (aarch64)

2019-07-05 Thread Oliver Grawert
just as a followup ... better ignore my comment above ... KVM is indeed not KMS ... sorry for causing confusion here -- You received this bug notification because you are a member of Kernel Packages, which is subscribed to linux-raspi2 in Ubuntu. https://bugs.launchpad.net/bugs/1783961 Title:

[Kernel-packages] [Bug 1834039] [NEW] loading bcm2835-v4l2 causes kernel oops with 4.4 kernel

2019-06-24 Thread Oliver Grawert
Public bug reported: attaching a raspberry pi camera to the pi camera interface (CSI) works fine when capturing video, pictures and streams directly through the picamera python library. when trying to use software that relies on using /dev/videoX with a camera attached to the CSI interface, the

[Kernel-packages] [Bug 1783961] Re: CONFIG_KVM is disabled for linux-raspi2 (aarch64)

2019-06-22 Thread Oliver Grawert
enabling CONFIG_KVM instead of enabling KVM via the dtb overlay will hard-disable all video acceleration of the upstream proprietary driver of the pi and make it completely unusable for any kind of setup that uses any upstram acceleration features from the raspberry pi foundation (i.e. via

[Kernel-packages] [Bug 1647936] Re: Raspberry Pi 3: a small rainbow square on the top right of screen

2017-03-20 Thread Oliver Grawert
@gerald: right, there is no way to protect you from turning the device into a brick if this step goes wrong (unlike kernel or rootfs we can not roll back the bootloader) note that the gadget snap from edge will not have a working dtb for the old kernel which will likely make you end up with an

[Kernel-packages] [Bug 1647936] Re: Raspberry Pi 3: a small rainbow square on the top right of screen

2017-03-13 Thread Oliver Grawert
@anthony ... technically that would be me ... practically the gadget will never update the firmware files (the firmware files as well as the dtb are usually in a dead-lock with the kernel version) i'm waiting for a solution for this from the core team before we can move on ... your best bet is to

[Kernel-packages] [Bug 1647936] Re: Raspberry Pi 3: a small rainbow square on the top right of screen

2017-03-13 Thread Oliver Grawert
@ying-chun the kernel snap only upgrades the kerne, modules and files in /lib/firmware ... the gadget snap only updates the gadget.yaml, snap.yaml and files not in /boot (i.e. it excludes all bootloader bits by default). until there is a solution for potential unbootable systems this will not

[Kernel-packages] [Bug 1647936] Re: Raspberry Pi 3: a small rainbow square on the top right of screen

2017-03-07 Thread Oliver Grawert
https://github.com/snapcore/pi3-gadget/commit/8b88f06ab5681d0ff41704a7813665a0203cbafc for reference -- You received this bug notification because you are a member of Kernel Packages, which is subscribed to linux in Ubuntu. https://bugs.launchpad.net/bugs/1647936 Title: Raspberry Pi 3: a

[Kernel-packages] [Bug 1647936] Re: Raspberry Pi 3: a small rainbow square on the top right of screen

2017-03-07 Thread Oliver Grawert
the gadget snap in edge has this fix since a while already, it just did not make it into a stable image yet. ** Changed in: snappy Status: New => Fix Committed ** Changed in: linux (Ubuntu) Status: Incomplete => Invalid -- You received this bug notification because you are a

[Kernel-packages] [Bug 1655411] Re: Cannot enable VC4 graphics driver on RPi 3

2017-01-11 Thread Oliver Grawert
ogra@pi3:~$ cd /boot/uboot/ ogra@pi3:~$ sudo tar xvf pi2-kernel_22.snap/dtbs/overlays.tgz then adding "dtoverlay=vc4-kms-v3d" and creating /etc/modules- load.d/vc4.conf with just "vc4" in it seems to get me vc4 loaded and i get: [4.952421] vc-cma: Videocore CMA driver [4.956535] vc-cma:

[Kernel-packages] [Bug 1655411] Re: Cannot enable VC4 graphics driver on RPi 3

2017-01-11 Thread Oliver Grawert
where exactly did you add the overlays in the first paragraph ? only overlays in /boot/uboot/overlays are read by the proprietary bootloader (you need to create the dir) -- You received this bug notification because you are a member of Kernel Packages, which is subscribed to linux in Ubuntu.

[Kernel-packages] [Bug 1652504] Re: Recent updates broke Ubuntu on Raspberry Pi 3

2017-01-02 Thread Oliver Grawert
@markus: not sure, i dont know how the non snappy images set the MAC, technically if they use similar uboot scripts the MAC should come from the first dtb snippet that is read from the ROM/closed bootloader, that part should not be related to the actual dtb address at all... -- You received this

[Kernel-packages] [Bug 1652504] Re: Recent updates broke Ubuntu on Raspberry Pi 3

2016-12-25 Thread Oliver Grawert
the newer firmware (start.elf,fixup.dat and bootcode.bin) hard-requires 0x0200 because it initializes the hardware differently in the newer version... looks like linux-firmware-raspi2 was not properly updated alongside with flash-kernel and the kernel itself, there is a hard lockstep between

[Kernel-packages] [Bug 1625177] Re: OOPS on beaglebone on boot of 4.4.0-36-generic under snappy ubuntu core xenial

2016-10-19 Thread Oliver Grawert
** Tags removed: verification-needed-xenial ** Tags added: verification-done-xenial -- You received this bug notification because you are a member of Kernel Packages, which is subscribed to linux in Ubuntu. https://bugs.launchpad.net/bugs/1625177 Title: OOPS on beaglebone on boot of

[Kernel-packages] [Bug 1625805] Re: arm64 kernel panic for l2 mmu with unity8 session snap

2016-09-22 Thread Oliver Grawert
oh, do you ship mesa in the mir server snap ? i didnt think that would be possible -- You received this bug notification because you are a member of Kernel Packages, which is subscribed to linux in Ubuntu. https://bugs.launchpad.net/bugs/1625805 Title: arm64 kernel panic for l2 mmu with

[Kernel-packages] [Bug 1625805] Re: arm64 kernel panic for l2 mmu with unity8 session snap

2016-09-21 Thread Oliver Grawert
i assume this is running a snap on a classic image, not on an ubuntu core one ? (since we have no EGL support in teh core image yet) -- You received this bug notification because you are a member of Kernel Packages, which is subscribed to linux in Ubuntu. https://bugs.launchpad.net/bugs/1625805

[Kernel-packages] [Bug 1625177] Re: OOPS on beaglebone on boot of 4.4.0-36-generic under snappy ubuntu core xenial

2016-09-19 Thread Oliver Grawert
the log is in the pastebin mentioned in the description ... ** Changed in: linux (Ubuntu) Status: Incomplete => Confirmed -- You received this bug notification because you are a member of Kernel Packages, which is subscribed to linux in Ubuntu. https://bugs.launchpad.net/bugs/1625177

[Kernel-packages] [Bug 1625177] [NEW] OOPS on beaglebone on boot of 4.4.0-36-generic under snappy ubuntu core xenial

2016-09-19 Thread Oliver Grawert
Public bug reported: trying to assemble a new series 16 ubuntu core image for the beaglebone black i am constantly running into an OOPS on first boot. seemingly related to the NIC driver since the NIC does not work after the OOPS. syslog can be found at http://paste.ubuntu.com/23202737/ a test

[Kernel-packages] [Bug 1593134] Re: build squashfs into xenial kernels by default

2016-06-17 Thread Oliver Grawert
snapd is seeded in everything but powerpc. images will only be created for i386, amd64, armhf and arm64. we do build generic and module-less initrds at rootfs build time that require hackery to be re-packed when you build a kernel snap, this is what we would like to avoid ... (one expectation is

[Kernel-packages] [Bug 1593134] [NEW] build squashfs into xenial kernels by default

2016-06-16 Thread Oliver Grawert
Public bug reported: snapd is seeded in all images in xenial by default and snaps are squashfs files. the snappy images need squashfs available at boot time and use official kernels. currently squashfs is the only module that forces us to re-pack initrds to add it everywhere for snappy images,

[Kernel-packages] [Bug 1552371] Re: Unexpected display on

2016-05-30 Thread Oliver Grawert
On the MX4 specifically there is also the issue with the "home" button staying active for about 30sec when the display was turned off, when shoving the phone into your pocket it is easy to create a button press event if you do not wait long enough. -- You received this bug notification because

[Kernel-packages] [Bug 1551747] Re: ubuntu-fan causes issues during network configuration

2016-05-24 Thread Oliver Grawert
this looks like wlan0 was brought up just fine seems to mostly be a cosmetic issue that /etc/network/if-up.d/ubuntu-fan doesnt exit quietly -- You received this bug notification because you are a member of Kernel Packages, which is subscribed to ubuntu-fan in Ubuntu.

[Kernel-packages] [Bug 1491094] Re: wifi USB dongle fails to work

2015-09-01 Thread Oliver Grawert
** Also affects: linux (Ubuntu) Importance: Undecided Status: New ** Summary changed: - wifi USB dongle fails to work + wifi USB dongle fails to work with musb-hdrc error -- You received this bug notification because you are a member of Kernel Packages, which is subscribed to linux

[Kernel-packages] [Bug 1460399] Re: ivybridge system gets completely unusable after upgrade to vivid thanks to defaulting to immature intel_pstate driver

2015-08-02 Thread Oliver Grawert
oops, totally forgot this is still open, the problem turned out to be a completely stuck fan wrapped in filth ... cleaning it ave the system proper values so thermald does the right thing now. ** Changed in: linux (Ubuntu) Status: Confirmed = Invalid ** Changed in: linux (Ubuntu Vivid)

[Kernel-packages] [Bug 1460399] Re: ivybridge system gets completely unusable after upgrade to vivid thanks to defaulting to immature intel_pstate driver

2015-06-03 Thread Oliver Grawert
one thing i noticed is that after dropping intel_pstate=disable from teh kernel commandline, thermald does not seem to star/run at all .. starting it manually i captured http://paste.ubuntu.com/11541063/ note that the behavior gets minimally better with thermald running, but switching

[Kernel-packages] [Bug 1460399] [NEW] ivybridge system gets completely unusable after upgrade to vivid thanks to defaulting to immature intel_pstate driver

2015-05-31 Thread Oliver Grawert
Public bug reported: I finally got around to upgrade my work laptop (first gen dell XPS sputnik system (ivy bridge)) yesterday, to find myself with a completely unusable and sluggish desktop, constantly spinning CPU fans and a hot enough laptop case that you can burn your fingers after the first

[Kernel-packages] [Bug 1460399] Re: ivybridge system gets completely unusable after upgrade to vivid thanks to defaulting to immature intel_pstate driver

2015-05-31 Thread Oliver Grawert
just for completeness (in case someone looks for a wrokaround), adding intel_pstate=disable to GRUB_CMDLINE_LINUX_DEFAULT in /etc/default/grub and running sudo update-grub got me the ondemand driver back and got the system back to behave as stable as in 14.10. -- You received this bug

[Kernel-packages] [Bug 1276901] Re: alsa-lib: UCM - hammerhead sound doesn't work

2014-02-26 Thread Oliver Grawert
** Changed in: alsa-lib (Ubuntu) Status: Fix Committed = Fix Released -- You received this bug notification because you are a member of Kernel Packages, which is subscribed to alsa-lib in Ubuntu. https://bugs.launchpad.net/bugs/1276901 Title: alsa-lib: UCM - hammerhead sound doesn't

[Kernel-packages] [Bug 1276901] Re: alsa-lib: UCM - hammerhead sound doesn't work

2014-02-25 Thread Oliver Grawert
I merged this into alsa-lib now so users do not have to apply teh files by hand to teh readonly images, please add further improvements you find here or open a new bug ** Changed in: alsa-lib (Ubuntu) Status: Confirmed = Fix Committed -- You received this bug notification because you are

[Kernel-packages] [Bug 1276901] Re: alsa-lib: UCM - hammerhead sound doesn't work

2014-02-06 Thread Oliver Grawert
** Also affects: alsa-lib (Ubuntu) Importance: Undecided Status: New ** Changed in: alsa-lib (Ubuntu) Importance: Undecided = High -- You received this bug notification because you are a member of Kernel Packages, which is subscribed to alsa-lib in Ubuntu.

[Kernel-packages] [Bug 1234743] Re: omapfb module floods system with udev events on samsung galaxy nexus when playing mp4

2013-10-10 Thread Oliver Grawert
pitti pointed on IRC to https://android.googlesource.com/kernel/msm/+/57195292 ... which doesnt help for our driver, but the problem does not seem to be uniqe -- You received this bug notification because you are a member of Kernel Packages, which is subscribed to linux in Ubuntu.

[Kernel-packages] [Bug 1234743] Re: omapfb module floods system with udev events on samsung galaxy nexus when playing mp4

2013-10-10 Thread Oliver Grawert
adjusting bug description, this is sadly a constant condition, not related to movie playback ** Summary changed: - omapfb module floods system with udev events on samsung galaxy nexus when playing mp4 + omapfb module floods system with udev events on samsung galaxy nexus -- You received this

[Kernel-packages] [Bug 1234743] Re: omapfb module floods system with udev events on samsung galaxy nexus

2013-10-10 Thread Oliver Grawert
h ! look what i found ! http://review.cyanogenmod.org/#/c/28068/ -- You received this bug notification because you are a member of Kernel Packages, which is subscribed to linux in Ubuntu. https://bugs.launchpad.net/bugs/1234743 Title: omapfb module floods system with udev events on

[Kernel-packages] [Bug 1234743] Re: omapfb module floods system with udev events on samsung galaxy nexus

2013-10-10 Thread Oliver Grawert
i cut that down to http://paste.ubuntu.com/6217518/, applied it and built a kernel ... sadly now Mir does not start at all, SurfaceFlinger does, but is very slow and complains: W/SurfaceFlinger( 659): Timed out waiting for hw vsync; faking it so i guess for using this patch some changes on the

[Kernel-packages] [Bug 1235649] Re: uevent spam causes session upstart to consume massive amounts of memory on Ubuntu Touch

2013-10-09 Thread Oliver Grawert
note that touch images do not use unity-panel-service anywhere -- You received this bug notification because you are a member of Kernel Packages, which is subscribed to linux in Ubuntu. https://bugs.launchpad.net/bugs/1235649 Title: uevent spam causes session upstart to consume massive

[Kernel-packages] [Bug 1235649] Re: session upstart leaks massive amounts of memory on Ubuntu Touch

2013-10-07 Thread Oliver Grawert
i can definitely make it stop consuming more ram by stopping the upstart-event-bridge session job. this works on both devices. the ram does not get freed but the consumption does not keep rising either anymore then. -- You received this bug notification because you are a member of Kernel