[Kernel-packages] [Bug 1881319] Re: Touchpad not recognized Lenovo IdeaPad 5 15ARE05 (probably falsely as touch panel)

2020-07-11 Thread Tim Richardson
@olepet I have 14ARE05 too, same symptoms. It seems the hardware is different, we need a new bug. I see no elan modules loaded. -- You received this bug notification because you are a member of Kernel Packages, which is subscribed to linux in Ubuntu. https://bugs.launchpad.net/bugs/1881319

[Kernel-packages] [Bug 1874194] Re: Ubuntu 20.04 HDMI connected, no boot

2020-06-09 Thread Tim Richardson
*** This bug is a duplicate of bug 1872159 *** https://bugs.launchpad.net/bugs/1872159 ** This bug has been marked a duplicate of bug 1872159 booting with splash hangs when external monitors are connected (pure intel 8th gen laptop) -- You received this bug notification because you are

[Kernel-packages] [Bug 1716857] Re: nvidia-drm.modeset=1, gdm3 and optimus laptop results in no external monitors detected by Xorg, Pop!OS fix works.

2020-03-05 Thread Tim Richardson
@Alberto, couldn't prime-select do this when going into hybrid or Optimus mode? Only users with nvidia hybrid graphics would go down this logic path, and they are only ones who need the fix (but only if they are using gdm3, sddm and lightdm continue to be unaffected by this) The set of users who

[Kernel-packages] [Bug 1856653] Re: CVE-2019-0154 caused major power problem, pls backport upstream's fix

2020-02-27 Thread Tim Richardson
not 'a fix', the intel maintainer's 5.4 patch has been applied by the ubuntu devs. -- You received this bug notification because you are a member of Kernel Packages, which is subscribed to linux in Ubuntu. https://bugs.launchpad.net/bugs/1856653 Title: CVE-2019-0154 caused major power

[Kernel-packages] [Bug 1856653] Re: CVE-2019-0154 caused major power problem, pls backport upstream's fix

2020-02-27 Thread Tim Richardson
Confirming that a fix has been backported to 20.04, currently in the proposed kernel. I'm testing it, the power usage is great. -- You received this bug notification because you are a member of Kernel Packages, which is subscribed to linux in Ubuntu. https://bugs.launchpad.net/bugs/1856653

[Kernel-packages] [Bug 1716857] Re: nvidia-drm.modeset=1, gdm3 and optimus laptop results in no external monitors detected by Xorg

2020-02-27 Thread Tim Richardson
This bug persists in 20.04 daily. The one-line Pop!OS solution (https://bugs.launchpad.net/ubuntu/+source/gdm3/+bug/1716857/comments/26) works, just logout and login. Pop!OS has used this for several releases now, just saying. ** Summary changed: - nvidia-drm.modeset=1, gdm3 and optimus

[Kernel-packages] [Bug 1856653] Re: CVE-2019-0154 caused major power problem, pls backport upstream's fix

2020-02-13 Thread Tim Richardson
Also, please note the upstream bug discussion also includes patches for 5.4 It seems that 5.4 is destined for 20.04. So far 5.4 upstream is still using the first release of this patch, which means 5.4 has the i915 RC6 bug. 5.4 is a LTS kernel bug so it strange to me, but please, I hope you can

[Kernel-packages] [Bug 1856653] Re: CVE-2019-0154 caused major power problem, pls backport upstream's fix

2020-02-12 Thread Tim Richardson
Yes, that little patch applies cleanly to every 5.3 hwe build I've done (about five I'd say) To be clear: diff --git a/drivers/gpu/drm/i915/gt/intel_lrc.c b/drivers/gpu/drm/i915/gt/intel_lrc.c index 82b7ace62d97..b18f281d5d12 100644 --- a/drivers/gpu/drm/i915/gt/intel_lrc.c +++

[Kernel-packages] [Bug 1856653] Re: CVE-2019-0154 caused major power problem, pls backport upstream's fix

2020-02-12 Thread Tim Richardson
PS I've been running on hwe 5.3 from Ubuntu's kernel git repository for a few weeks, with the patch linked above, and it is stable on my Thinkpad T480. -- You received this bug notification because you are a member of Kernel Packages, which is subscribed to linux in Ubuntu.

[Kernel-packages] [Bug 1856653] Re: CVE-2019-0154 caused major power problem, pls backport upstream's fix

2020-01-02 Thread Tim Richardson
If the power-saving patch is backported,will this be updated? I'm on own patched kernel so I won't notice. It's an awful problem, by the way, it harms battery life on any laptop with intel graphics from 2016 or later. -- You received this bug notification because you are a member of Kernel

[Kernel-packages] [Bug 1856653] Re: CVE-2019-0154 caused major power problem, pls backport maintainers fix

2019-12-16 Thread Tim Richardson
logs not applicable ** Changed in: linux (Ubuntu) Status: Incomplete => Confirmed ** Summary changed: - CVE-2019-0154 caused major power problem, pls backport maintainers fix + CVE-2019-0154 caused major power problem, pls backport maintainer's fix ** Summary changed: - CVE-2019-0154

[Kernel-packages] [Bug 1856653] Re: CVE-2019-0154 caused major power problem, pls backport maintainers fix

2019-12-16 Thread Tim Richardson
** Description changed: https://gitlab.freedesktop.org/drm/intel/issues/614 the fix released as CVE-2019-0154 increases idle power consumption on intel i915 6th gen and later. - That's because the GPU does not enter RC6 any more. + That's because the GPU does not enter RC6 any more. -

[Kernel-packages] [Bug 1856653] [NEW] CVE-2019-0154 caused major power problem, pls backport maintainers fix

2019-12-16 Thread Tim Richardson
Public bug reported: https://gitlab.freedesktop.org/drm/intel/issues/614 the fix released as CVE-2019-0154 increases idle power consumption on intel i915 6th gen and later. That's because the GPU does not enter RC6 any more. For example, my Thinkpad P50 (6th gen) idles at 9w with current 5.3

[Kernel-packages] [Bug 1722478] Re: Two-finger scrolling and click-and-drag no longer works after resuming from suspend

2019-11-12 Thread Tim Richardson
With my T480 and the 5.0 ubuntu kernel, and the 5.3 in the proposed PPA, two finger scrolling does not work unless I specify psmouse.synaptics_intertouch=0 or =1 either value fixes it. -- You received this bug notification because you are a member of Kernel Packages, which is subscribed to

[Kernel-packages] [Bug 1716857] Re: nvidia-drm.modeset=1, gdm3 and optimus laptop results in no external monitors detected by Xorg

2019-11-02 Thread Tim Richardson
I just installed popOS 19.10 an an Optimus laptop, nvidia option. Out of the box you get gdm3 and tear-free prime-sync; it uses Jeremy Soller's solution (root rights granted in Xwrapper) -- You received this bug notification because you are a member of Kernel Packages, which is subscribed to

[Kernel-packages] [Bug 1716857] Re: nvidia-drm.modeset=1, gdm3 and optimus laptop results in no external monitors detected by Xorg

2019-09-27 Thread Tim Richardson
And PS: workaround continues to be: use lightdm, a five minute fix at worst. https://askubuntu.com/questions/139491/how-to-change-from-gdm-to-lightdm -- You received this bug notification because you are a member of Kernel Packages, which is subscribed to nvidia-graphics-drivers-418 in Ubuntu.

[Kernel-packages] [Bug 1716857] Re: nvidia-drm.modeset=1, gdm3 and optimus laptop results in no external monitors detected by Xorg

2019-09-27 Thread Tim Richardson
19.10 beta and nvidia drivers 430 and 435 have the same problem. I have made the bug title correctly specific. ** Summary changed: - nvidia-drm.modeset=1 results in no monitors detected by Xorg + nvidia-drm.modeset=1, gdm3 and optimus laptop results in no external monitors detected by Xorg --

Re: [Kernel-packages] [Bug 1716857] Re: nvidia-drm.modeset=1 results in no monitors detected by Xorg

2019-06-20 Thread Tim Richardson
vidia-drm.modeset=1 results in no monitors detected by Xorg > > To manage notifications about this bug go to: > https://bugs.launchpad.net/ubuntu/+source/gdm3/+bug/1716857/+subscriptions > -- Tim Richardson -- You received this bug notification because you are a member of Kern

Re: [Kernel-packages] [Bug 1716857] Re: nvidia-drm.modeset=1 results in no monitors detected by Xorg

2019-06-20 Thread Tim Richardson
> nvidia-drm.modeset=1 results in no monitors detected by Xorg > > To manage notifications about this bug go to: > https://bugs.launchpad.net/ubuntu/+source/gdm3/+bug/1716857/+subscriptions > -- Tim Richardson -- You received this bug notification because you are a member of Kern

[Kernel-packages] [Bug 1716857] Re: nvidia-drm.modeset=1 results in no monitors detected by Xorg

2019-06-20 Thread Tim Richardson
"gdm3 compile without wayland", I meant -- You received this bug notification because you are a member of Kernel Packages, which is subscribed to nvidia-graphics-drivers-375 in Ubuntu. https://bugs.launchpad.net/bugs/1716857 Title: nvidia-drm.modeset=1 results in no monitors detected by Xorg

[Kernel-packages] [Bug 1716857] Re: nvidia-drm.modeset=1 results in no monitors detected by Xorg

2019-06-20 Thread Tim Richardson
What we know about this bug is that gdm3, nvidia and modeset=1 is broken under configurations which are not broken when sddm and lightdm are used. we know that gdm3 sessions with external monitors work with root permissions. we know that gdm3 compiled with wayland also works (according to the

[Kernel-packages] [Bug 1706474] Re: gdm3 nvidia modeset=1 is broken, external screens don't work on a Thinkpad p50

2019-06-20 Thread Tim Richardson
I should add that the "fix" I reported is only a narrow fix. The internal display works. But external displays don't work if you have nvidia drivers, gdm3 and if you are using modeset=1 -- You received this bug notification because you are a member of Kernel Packages, which is subscribed to

[Kernel-packages] [Bug 1716857] Re: nvidia-drm.modeset=1 results in no monitors detected by Xorg

2019-06-13 Thread Tim Richardson
I posted here: https://devtalk.nvidia.com/default/topic/1055528/linux/nvidia-driver-in- modeset-1-requires-root-permissions-daniel-van-vugt-canonical-concludes- it-is-an-nvidia-bug/?offset=3#5351122 -- You received this bug notification because you are a member of Kernel Packages, which is

[Kernel-packages] [Bug 1716857] Re: nvidia-drm.modeset=1 results in no monitors detected by Xorg

2019-06-13 Thread Tim Richardson
User generix reports that when gdm3 is compiled without wayland support, this bug is not seen. -- You received this bug notification because you are a member of Kernel Packages, which is subscribed to nvidia-graphics-drivers-375 in Ubuntu. https://bugs.launchpad.net/bugs/1716857 Title:

[Kernel-packages] [Bug 1716857] Re: nvidia-drm.modeset=1 results in no monitors detected by Xorg

2019-06-13 Thread Tim Richardson
I will post your findings to the nvidia developers forum. -- You received this bug notification because you are a member of Kernel Packages, which is subscribed to nvidia-graphics-drivers-418 in Ubuntu. https://bugs.launchpad.net/bugs/1716857 Title: nvidia-drm.modeset=1 results in no monitors

[Kernel-packages] [Bug 1716857] Re: nvidia-drm.modeset=1 results in no monitors detected by Xorg

2019-06-13 Thread Tim Richardson
Hi Daniel, thanks for not forgetting about this, unlike everyone else :) Have you communicated this observation to Nvidia at all? -- You received this bug notification because you are a member of Kernel Packages, which is subscribed to nvidia-graphics-drivers-418 in Ubuntu.

[Kernel-packages] [Bug 1820796] Re: natacpi bug in 4.18.0-16-generic, fixed upstream 5.0.2

2019-03-19 Thread Tim Richardson
already fixed (see https://lists.ubuntu.com/archives/cosmic- changes/2019-March/012430.html) -- You received this bug notification because you are a member of Kernel Packages, which is subscribed to linux in Ubuntu. https://bugs.launchpad.net/bugs/1820796 Title: natacpi bug in

Re: [Kernel-packages] [Bug 1820796] Re: natacpi bug in 4.18.0-16-generic, fixed upstream 5.0.2

2019-03-19 Thread Tim Richardson
Yep. I didn't find that, I filed a new Ubuntu kernel bug which I will now close. On Tue, 19 Mar. 2019, 16:05 Kai-Heng Feng, wrote: > LP: #1812099? > > -- > You received this bug notification because you are subscribed to the bug > report. > https://bugs.launchpad.net/bugs/1820796 > > Title: >

[Kernel-packages] [Bug 1798708] Re: It will load nvidia driver when swith to Intel mode

2019-03-18 Thread Tim Richardson
The external monitor problem is probably a well-known gdm3 bug: gdm3 with nvidia modeset=1 stops the nvidia driver from detecting external monitors (possibly it invokes some wayland features when it shouldn't). It is not a problem with nvidia-prime or with the kernel. You can fix it by using

[Kernel-packages] [Bug 1820796] Re: natacpi bug in 4.18.0-16-generic, fixed upstream 5.0.2

2019-03-18 Thread Tim Richardson
** Attachment added: "lspci-vnvn.log" https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1820796/+attachment/5247477/+files/lspci-vnvn.log -- You received this bug notification because you are a member of Kernel Packages, which is subscribed to linux in Ubuntu.

[Kernel-packages] [Bug 1820796] [NEW] natacpi bug in 4.18.0-16-generic, fixed upstream 5.0.2

2019-03-18 Thread Tim Richardson
Public bug reported: low-impact bug, easy workaround. Thinkpad T480 4.18.0-16-generic Bug: # cd /sys/class/power_supply/BAT1 # # echo 95 > charge_start_threshold bash: echo: write error: No such device but it works for BAT0 It means tlp, latest version installed via PPA, by default can't

[Kernel-packages] [Bug 1687910] Re: [Lenovo W520] Linux Freezing Issue At Boot

2017-10-11 Thread Tim Richardson
exists in 4.12 and 4.13 in the 17.10 repositories. -- You received this bug notification because you are a member of Kernel Packages, which is subscribed to linux in Ubuntu. https://bugs.launchpad.net/bugs/1687910 Title: [Lenovo W520] Linux Freezing Issue At Boot Status in linux package in

Re: [Kernel-packages] [Bug 1169984] Re: 3.8.0-18 HDMI/DisplayPort audio regression: Either oops or opening device fails with -ENODEV

2014-09-07 Thread Tim Richardson
/1169984/+subscriptions -- Tim Richardson -- You received this bug notification because you are a member of Kernel Packages, which is subscribed to linux in Ubuntu. https://bugs.launchpad.net/bugs/1169984 Title: 3.8.0-18 HDMI/DisplayPort audio regression: Either oops or opening device fails

[Kernel-packages] [Bug 1290787] Re: [TOSHIBA Satellite U400] suspend/resume failure

2014-07-07 Thread Tim Richardson
the patch for this has been added to stable kernels 3.15 and 3.14 so I hope it gets picked up by Ubuntu soon. This is a note to let you know that I've just added the patch titled drm/i915: Avoid div-by-zero when pixel_multiplier is zero to the 3.15-stable tree which can be found at:

[Kernel-packages] [Bug 1290787] Re: [TOSHIBA Satellite U400] suspend/resume failure

2014-06-09 Thread Tim Richardson
The good news is that just an hour ago the Intel engineer and I finished testing the fix, so it will go into the kernel soon (I don't know when). Ubuntu kernel developers will pick it up I expect. -- You received this bug notification because you are a member of Kernel Packages, which is

[Kernel-packages] [Bug 1290787] Re: [TOSHIBA Satellite U400] suspend/resume failure

2014-06-02 Thread Tim Richardson
Follow the upstream bug.perhaps you can help with testing. -- You received this bug notification because you are a member of Kernel Packages, which is subscribed to linux-meta in Ubuntu. https://bugs.launchpad.net/bugs/1290787 Title: [TOSHIBA Satellite U400] suspend/resume failure Status in

[Kernel-packages] [Bug 1289721] Re: [TOSHIBA Satellite U400] suspend/resume failure

2014-05-23 Thread Tim Richardson
** Tags added: kernel-bug-reported-upstream -- You received this bug notification because you are a member of Kernel Packages, which is subscribed to linux in Ubuntu. https://bugs.launchpad.net/bugs/1289721 Title: [TOSHIBA Satellite U400] suspend/resume failure Status in “linux” package in

[Kernel-packages] [Bug 1290787] Re: [TOSHIBA Satellite U400] suspend/resume failure

2014-03-29 Thread Tim Richardson
this is a kernel bug ** Package changed: lightdm (Ubuntu) = linux-meta (Ubuntu) -- You received this bug notification because you are a member of Kernel Packages, which is subscribed to linux-meta in Ubuntu. https://bugs.launchpad.net/bugs/1290787 Title: [TOSHIBA Satellite U400]

[Kernel-packages] [Bug 1290787] Re: [TOSHIBA Satellite U400] suspend/resume failure

2014-03-24 Thread Tim Richardson
Note: it is not an upstream bug. I can not reproduce it like so: go to terminal sudo service lightdm stop pm-suspend this always works, with 3.11.10, 3.12.14, 3.13.6 and 3.14 rc7 However, when lightdm is running, does not resume. ** Tags removed: kernel-bug-reported-upstream -- You

[Kernel-packages] [Bug 1290787] Re: [TOSHIBA Satellite U400] suspend/resume failure

2014-03-24 Thread Tim Richardson
testing reveals that the bug is linked to lightdm It is not reproducible when lightdm is not running. When lightdm is running, a wide range of kernels show the resume fail. These kernels do not fail resume when lightdm is not running ** Description changed: does not resume (no backlight on

[Kernel-packages] [Bug 1290787] Re: [TOSHIBA Satellite U400] suspend/resume failure

2014-03-23 Thread Tim Richardson
upstream report https://bugs.freedesktop.org/show_bug.cgi?id=76520 ** Bug watch added: freedesktop.org Bugzilla #76520 https://bugs.freedesktop.org/show_bug.cgi?id=76520 ** Tags added: kernel-bug-reported-upstream -- You received this bug notification because you are a member of Kernel

[Kernel-packages] [Bug 1289721] Re: [TOSHIBA Satellite U400] suspend/resume failure

2014-03-12 Thread Tim Richardson
with 3.13.6-031306-generic the bug still exists. Now I'll check the latest 3.14 -- You received this bug notification because you are a member of Kernel Packages, which is subscribed to linux in Ubuntu. https://bugs.launchpad.net/bugs/1289721 Title: [TOSHIBA Satellite U400] suspend/resume

[Kernel-packages] [Bug 1290787] Re: [TOSHIBA Satellite U400] suspend/resume failure

2014-03-12 Thread Tim Richardson
3.13.6-031306-generic kernel-bug-exists-upstream ** Tags added: kernel-bug-exists-upstream -- You received this bug notification because you are a member of Kernel Packages, which is subscribed to linux in Ubuntu. https://bugs.launchpad.net/bugs/1290787 Title: [TOSHIBA Satellite U400]

[Kernel-packages] [Bug 1289721] Re: [TOSHIBA Satellite U400] suspend/resume failure

2014-03-12 Thread Tim Richardson
bug exists in 3.14.0-031400rc6-generic ** Tags added: kernel-bug-exists-upstream -- You received this bug notification because you are a member of Kernel Packages, which is subscribed to linux in Ubuntu. https://bugs.launchpad.net/bugs/1289721 Title: [TOSHIBA Satellite U400] suspend/resume

[Kernel-packages] [Bug 1290787] [NEW] [TOSHIBA Satellite U400] suspend/resume failure

2014-03-11 Thread Tim Richardson
Public bug reported: does not resume (no backlight on LCD panel, for example) ProblemType: KernelOops DistroRelease: Ubuntu 14.04 Package: linux-image-3.13.0-17-generic 3.13.0-17.37 ProcVersionSignature: Ubuntu 3.13.0-17.37-generic 3.13.6 Uname: Linux 3.13.0-17-generic i686 Annotation: This

[Kernel-packages] [Bug 1289721] [NEW] [TOSHIBA Satellite U400] suspend/resume failure

2014-03-08 Thread Tim Richardson
Public bug reported: suspend fails, does not resume ProblemType: KernelOops DistroRelease: Ubuntu 14.04 Package: linux-image-3.13.0-16-generic 3.13.0-16.36 ProcVersionSignature: Ubuntu 3.13.0-16.36-generic 3.13.5 Uname: Linux 3.13.0-16-generic i686 Annotation: This occured during a previous

[Kernel-packages] [Bug 1288657] [NEW] [TOSHIBA Satellite U400] suspend/resume failure

2014-03-06 Thread Tim Richardson
Public bug reported: After resuming the hard drive and fan flash. But there is no screen. ProblemType: KernelOops DistroRelease: Ubuntu 14.04 Package: linux-image-3.13.0-15-generic 3.13.0-15.35 ProcVersionSignature: Ubuntu 3.13.0-15.35-generic 3.13.5 Uname: Linux 3.13.0-15-generic i686

[Kernel-packages] [Bug 1288652] [NEW] not resuming, Toshiba laptop, intel video

2014-03-06 Thread Tim Richardson
Public bug reported: I run ubuntu-bug linux and I get a message that it is sending the information, but then firefox opens me in a new bug report which again asks me to run ubuntu-bug linux. I don't know what to do. ProblemType: Bug DistroRelease: Ubuntu 14.04 Package:

Re: [Kernel-packages] [Bug 1136110] Re: USB Audio Codec choppy playback

2013-11-09 Thread Tim Richardson
13.04 is ok for me. On 09/11/2013 10:05 pm, Andrejs Hanins ahan...@gmail.com wrote: Hi all, sorry for bothering, but I'm upgraded to latest Ubuntu 13.10 and the bug is still there, despite the fact fix was available few months ago. Is it expected situation? Thanks. -- You received this bug