[Kernel-packages] [Bug 1528047] Re: package linux-image-4.2.0-22-generic (not installed) failed to install/upgrade: subprocess new pre-installation script returned error exit status 1

2016-01-20 Thread Jorma Hytonen
"But would like a more permanent solution" - I agree with that! 
I upgrade XUbuntu 14.10 to 15.10 and then software update kernel 
4.2.0-25-generic and then I got same error.

The problem solved as Derek wrote, but what about next update?

-- 
You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.
https://bugs.launchpad.net/bugs/1528047

Title:
  package linux-image-4.2.0-22-generic (not installed) failed to
  install/upgrade: subprocess new pre-installation script returned error
  exit status 1

Status in linux package in Ubuntu:
  Confirmed

Bug description:
  This machine (I believe) has PAE capabilities (Pentium-M), but 15.10 has 
become very unforgiving of machines that don't report PAE flags in 
/proc/cpuinfo.  
  I had a royal pain in the behind upgrading from 15.04 (where --forcepae just 
did the business) to 15.10 because this package wouldn't install and only 
managed to retrive a completely stuffed machine by hacking /proc/cpuinfo to 
force the PAE flag on there. This is of course temporary.

  It would be useful if whoever maintains the code that does
  /proc/cpuinfo would recognize the exception created by Intel with not
  correctly reporting PAE and fix this flag if future Ubuntu releases
  are going to barf so badly on not seeing it.

  ProblemType: Package
  DistroRelease: Ubuntu 15.10
  Package: linux-image-4.2.0-22-generic (not installed)
  ProcVersionSignature: Ubuntu 4.2.0-21.25-generic 4.2.6
  Uname: Linux 4.2.0-21-generic i686
  ApportVersion: 2.19.1-0ubuntu5
  Architecture: i386
  AudioDevicesInUse:
   USERPID ACCESS COMMAND
   /dev/snd/controlC0:  der1402 F pulseaudio
  Date: Sun Dec 20 20:38:38 2015
  DpkgTerminalLog:
   Preparing to unpack .../linux-image-4.2.0-22-generic_4.2.0-22.27_i386.deb ...
   This kernel does not support a non-PAE CPU.
   dpkg: error processing archive 
/var/cache/apt/archives/linux-image-4.2.0-22-generic_4.2.0-22.27_i386.deb 
(--unpack):
subprocess new pre-installation script returned error exit status 1
  DuplicateSignature: package:linux-image-4.2.0-22-generic:(not 
installed):subprocess new pre-installation script returned error exit status 1
  ErrorMessage: subprocess new pre-installation script returned error exit 
status 1
  HibernationDevice: RESUME=UUID=8c5a77c4-3860-4ef9-8bed-60184472e824
  InstallationDate: Installed on 2015-01-29 (324 days ago)
  InstallationMedia: Lubuntu 14.10 "Utopic Unicorn" - Release i386 (20141022.1)
  Lsusb:
   Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
   Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
   Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
   Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
  MachineType: IBM 2371EG2
  ProcFB: 0 inteldrmfb
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.2.0-21-generic 
root=UUID=332336ad-e4aa-403e-bca9-8c4d9c38a491 ro quiet splash vt.handoff=7
  PulseList: Error: command ['pacmd', 'list'] failed with exit code 1: No 
PulseAudio daemon running, or not running as session daemon.
  RelatedPackageVersions: grub-pc 2.02~beta2-29ubuntu0.2
  RfKill:
   0: phy0: Wireless LAN
Soft blocked: no
Hard blocked: no
  SourcePackage: linux
  Title: package linux-image-4.2.0-22-generic (not installed) failed to 
install/upgrade: subprocess new pre-installation script returned error exit 
status 1
  UpgradeStatus: Upgraded to wily on 2015-12-17 (2 days ago)
  dmi.bios.date: 10/13/2004
  dmi.bios.vendor: IBM
  dmi.bios.version: 1UET93WW (1.43 )
  dmi.board.name: 2371EG2
  dmi.board.vendor: IBM
  dmi.board.version: Not Available
  dmi.chassis.asset.tag: No Asset Information
  dmi.chassis.type: 10
  dmi.chassis.vendor: IBM
  dmi.chassis.version: Not Available
  dmi.modalias: 
dmi:bvnIBM:bvr1UET93WW(1.43):bd10/13/2004:svnIBM:pn2371EG2:pvrThinkPadX40:rvnIBM:rn2371EG2:rvrNotAvailable:cvnIBM:ct10:cvrNotAvailable:
  dmi.product.name: 2371EG2
  dmi.product.version: ThinkPad X40
  dmi.sys.vendor: IBM

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1528047/+subscriptions

-- 
Mailing list: https://launchpad.net/~kernel-packages
Post to : kernel-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~kernel-packages
More help   : https://help.launchpad.net/ListHelp


[Kernel-packages] [Bug 1528047] Re: package linux-image-4.2.0-22-generic (not installed) failed to install/upgrade: subprocess new pre-installation script returned error exit status 1

2015-12-28 Thread Derek Roberts
Working around the problem for now with this:

 cat /proc/cpuinfo | sed 's/flags\t*:/& pae/' > /tmp/cpuinfo_pae
  sudo mount -o bind /tmp/cpuinfo_pae /proc/cpuinfo
  sudo mount -o remount,ro,bind /proc/cpuinfo


But would like a more permanent solution

-- 
You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.
https://bugs.launchpad.net/bugs/1528047

Title:
  package linux-image-4.2.0-22-generic (not installed) failed to
  install/upgrade: subprocess new pre-installation script returned error
  exit status 1

Status in linux package in Ubuntu:
  Confirmed

Bug description:
  This machine (I believe) has PAE capabilities (Pentium-M), but 15.10 has 
become very unforgiving of machines that don't report PAE flags in 
/proc/cpuinfo.  
  I had a royal pain in the behind upgrading from 15.04 (where --forcepae just 
did the business) to 15.10 because this package wouldn't install and only 
managed to retrive a completely stuffed machine by hacking /proc/cpuinfo to 
force the PAE flag on there. This is of course temporary.

  It would be useful if whoever maintains the code that does
  /proc/cpuinfo would recognize the exception created by Intel with not
  correctly reporting PAE and fix this flag if future Ubuntu releases
  are going to barf so badly on not seeing it.

  ProblemType: Package
  DistroRelease: Ubuntu 15.10
  Package: linux-image-4.2.0-22-generic (not installed)
  ProcVersionSignature: Ubuntu 4.2.0-21.25-generic 4.2.6
  Uname: Linux 4.2.0-21-generic i686
  ApportVersion: 2.19.1-0ubuntu5
  Architecture: i386
  AudioDevicesInUse:
   USERPID ACCESS COMMAND
   /dev/snd/controlC0:  der1402 F pulseaudio
  Date: Sun Dec 20 20:38:38 2015
  DpkgTerminalLog:
   Preparing to unpack .../linux-image-4.2.0-22-generic_4.2.0-22.27_i386.deb ...
   This kernel does not support a non-PAE CPU.
   dpkg: error processing archive 
/var/cache/apt/archives/linux-image-4.2.0-22-generic_4.2.0-22.27_i386.deb 
(--unpack):
subprocess new pre-installation script returned error exit status 1
  DuplicateSignature: package:linux-image-4.2.0-22-generic:(not 
installed):subprocess new pre-installation script returned error exit status 1
  ErrorMessage: subprocess new pre-installation script returned error exit 
status 1
  HibernationDevice: RESUME=UUID=8c5a77c4-3860-4ef9-8bed-60184472e824
  InstallationDate: Installed on 2015-01-29 (324 days ago)
  InstallationMedia: Lubuntu 14.10 "Utopic Unicorn" - Release i386 (20141022.1)
  Lsusb:
   Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
   Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
   Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
   Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
  MachineType: IBM 2371EG2
  ProcFB: 0 inteldrmfb
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.2.0-21-generic 
root=UUID=332336ad-e4aa-403e-bca9-8c4d9c38a491 ro quiet splash vt.handoff=7
  PulseList: Error: command ['pacmd', 'list'] failed with exit code 1: No 
PulseAudio daemon running, or not running as session daemon.
  RelatedPackageVersions: grub-pc 2.02~beta2-29ubuntu0.2
  RfKill:
   0: phy0: Wireless LAN
Soft blocked: no
Hard blocked: no
  SourcePackage: linux
  Title: package linux-image-4.2.0-22-generic (not installed) failed to 
install/upgrade: subprocess new pre-installation script returned error exit 
status 1
  UpgradeStatus: Upgraded to wily on 2015-12-17 (2 days ago)
  dmi.bios.date: 10/13/2004
  dmi.bios.vendor: IBM
  dmi.bios.version: 1UET93WW (1.43 )
  dmi.board.name: 2371EG2
  dmi.board.vendor: IBM
  dmi.board.version: Not Available
  dmi.chassis.asset.tag: No Asset Information
  dmi.chassis.type: 10
  dmi.chassis.vendor: IBM
  dmi.chassis.version: Not Available
  dmi.modalias: 
dmi:bvnIBM:bvr1UET93WW(1.43):bd10/13/2004:svnIBM:pn2371EG2:pvrThinkPadX40:rvnIBM:rn2371EG2:rvrNotAvailable:cvnIBM:ct10:cvrNotAvailable:
  dmi.product.name: 2371EG2
  dmi.product.version: ThinkPad X40
  dmi.sys.vendor: IBM

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1528047/+subscriptions

-- 
Mailing list: https://launchpad.net/~kernel-packages
Post to : kernel-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~kernel-packages
More help   : https://help.launchpad.net/ListHelp


[Kernel-packages] [Bug 1528047] Re: package linux-image-4.2.0-22-generic (not installed) failed to install/upgrade: subprocess new pre-installation script returned error exit status 1

2015-12-27 Thread Alberto Salvia Novella
** Changed in: linux (Ubuntu)
   Importance: Undecided => High

-- 
You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.
https://bugs.launchpad.net/bugs/1528047

Title:
  package linux-image-4.2.0-22-generic (not installed) failed to
  install/upgrade: subprocess new pre-installation script returned error
  exit status 1

Status in linux package in Ubuntu:
  Confirmed

Bug description:
  This machine (I believe) has PAE capabilities (Pentium-M), but 15.10 has 
become very unforgiving of machines that don't report PAE flags in 
/proc/cpuinfo.  
  I had a royal pain in the behind upgrading from 15.04 (where --forcepae just 
did the business) to 15.10 because this package wouldn't install and only 
managed to retrive a completely stuffed machine by hacking /proc/cpuinfo to 
force the PAE flag on there. This is of course temporary.

  It would be useful if whoever maintains the code that does
  /proc/cpuinfo would recognize the exception created by Intel with not
  correctly reporting PAE and fix this flag if future Ubuntu releases
  are going to barf so badly on not seeing it.

  ProblemType: Package
  DistroRelease: Ubuntu 15.10
  Package: linux-image-4.2.0-22-generic (not installed)
  ProcVersionSignature: Ubuntu 4.2.0-21.25-generic 4.2.6
  Uname: Linux 4.2.0-21-generic i686
  ApportVersion: 2.19.1-0ubuntu5
  Architecture: i386
  AudioDevicesInUse:
   USERPID ACCESS COMMAND
   /dev/snd/controlC0:  der1402 F pulseaudio
  Date: Sun Dec 20 20:38:38 2015
  DpkgTerminalLog:
   Preparing to unpack .../linux-image-4.2.0-22-generic_4.2.0-22.27_i386.deb ...
   This kernel does not support a non-PAE CPU.
   dpkg: error processing archive 
/var/cache/apt/archives/linux-image-4.2.0-22-generic_4.2.0-22.27_i386.deb 
(--unpack):
subprocess new pre-installation script returned error exit status 1
  DuplicateSignature: package:linux-image-4.2.0-22-generic:(not 
installed):subprocess new pre-installation script returned error exit status 1
  ErrorMessage: subprocess new pre-installation script returned error exit 
status 1
  HibernationDevice: RESUME=UUID=8c5a77c4-3860-4ef9-8bed-60184472e824
  InstallationDate: Installed on 2015-01-29 (324 days ago)
  InstallationMedia: Lubuntu 14.10 "Utopic Unicorn" - Release i386 (20141022.1)
  Lsusb:
   Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
   Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
   Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
   Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
  MachineType: IBM 2371EG2
  ProcFB: 0 inteldrmfb
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.2.0-21-generic 
root=UUID=332336ad-e4aa-403e-bca9-8c4d9c38a491 ro quiet splash vt.handoff=7
  PulseList: Error: command ['pacmd', 'list'] failed with exit code 1: No 
PulseAudio daemon running, or not running as session daemon.
  RelatedPackageVersions: grub-pc 2.02~beta2-29ubuntu0.2
  RfKill:
   0: phy0: Wireless LAN
Soft blocked: no
Hard blocked: no
  SourcePackage: linux
  Title: package linux-image-4.2.0-22-generic (not installed) failed to 
install/upgrade: subprocess new pre-installation script returned error exit 
status 1
  UpgradeStatus: Upgraded to wily on 2015-12-17 (2 days ago)
  dmi.bios.date: 10/13/2004
  dmi.bios.vendor: IBM
  dmi.bios.version: 1UET93WW (1.43 )
  dmi.board.name: 2371EG2
  dmi.board.vendor: IBM
  dmi.board.version: Not Available
  dmi.chassis.asset.tag: No Asset Information
  dmi.chassis.type: 10
  dmi.chassis.vendor: IBM
  dmi.chassis.version: Not Available
  dmi.modalias: 
dmi:bvnIBM:bvr1UET93WW(1.43):bd10/13/2004:svnIBM:pn2371EG2:pvrThinkPadX40:rvnIBM:rn2371EG2:rvrNotAvailable:cvnIBM:ct10:cvrNotAvailable:
  dmi.product.name: 2371EG2
  dmi.product.version: ThinkPad X40
  dmi.sys.vendor: IBM

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1528047/+subscriptions

-- 
Mailing list: https://launchpad.net/~kernel-packages
Post to : kernel-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~kernel-packages
More help   : https://help.launchpad.net/ListHelp


[Kernel-packages] [Bug 1528047] Re: package linux-image-4.2.0-22-generic (not installed) failed to install/upgrade: subprocess new pre-installation script returned error exit status 1

2015-12-20 Thread Apport retracing service
** Tags removed: need-duplicate-check

-- 
You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.
https://bugs.launchpad.net/bugs/1528047

Title:
  package linux-image-4.2.0-22-generic (not installed) failed to
  install/upgrade: subprocess new pre-installation script returned error
  exit status 1

Status in linux package in Ubuntu:
  New

Bug description:
  This machine (I believe) has PAE capabilities (Pentium-M), but 15.10 has 
become very unforgiving of machines that don't report PAE flags in 
/proc/cpuinfo.  
  I had a royal pain in the behind upgrading from 15.04 (where --forcepae just 
did the business) to 15.10 because this package wouldn't install and only 
managed to retrive a completely stuffed machine by hacking /proc/cpuinfo to 
force the PAE flag on there. This is of course temporary.

  It would be useful if whoever maintains the code that does
  /proc/cpuinfo would recognize the exception created by Intel with not
  correctly reporting PAE and fix this flag if future Ubuntu releases
  are going to barf so badly on not seeing it.

  ProblemType: Package
  DistroRelease: Ubuntu 15.10
  Package: linux-image-4.2.0-22-generic (not installed)
  ProcVersionSignature: Ubuntu 4.2.0-21.25-generic 4.2.6
  Uname: Linux 4.2.0-21-generic i686
  ApportVersion: 2.19.1-0ubuntu5
  Architecture: i386
  AudioDevicesInUse:
   USERPID ACCESS COMMAND
   /dev/snd/controlC0:  der1402 F pulseaudio
  Date: Sun Dec 20 20:38:38 2015
  DpkgTerminalLog:
   Preparing to unpack .../linux-image-4.2.0-22-generic_4.2.0-22.27_i386.deb ...
   This kernel does not support a non-PAE CPU.
   dpkg: error processing archive 
/var/cache/apt/archives/linux-image-4.2.0-22-generic_4.2.0-22.27_i386.deb 
(--unpack):
subprocess new pre-installation script returned error exit status 1
  DuplicateSignature: package:linux-image-4.2.0-22-generic:(not 
installed):subprocess new pre-installation script returned error exit status 1
  ErrorMessage: subprocess new pre-installation script returned error exit 
status 1
  HibernationDevice: RESUME=UUID=8c5a77c4-3860-4ef9-8bed-60184472e824
  InstallationDate: Installed on 2015-01-29 (324 days ago)
  InstallationMedia: Lubuntu 14.10 "Utopic Unicorn" - Release i386 (20141022.1)
  Lsusb:
   Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
   Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
   Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
   Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
  MachineType: IBM 2371EG2
  ProcFB: 0 inteldrmfb
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.2.0-21-generic 
root=UUID=332336ad-e4aa-403e-bca9-8c4d9c38a491 ro quiet splash vt.handoff=7
  PulseList: Error: command ['pacmd', 'list'] failed with exit code 1: No 
PulseAudio daemon running, or not running as session daemon.
  RelatedPackageVersions: grub-pc 2.02~beta2-29ubuntu0.2
  RfKill:
   0: phy0: Wireless LAN
Soft blocked: no
Hard blocked: no
  SourcePackage: linux
  Title: package linux-image-4.2.0-22-generic (not installed) failed to 
install/upgrade: subprocess new pre-installation script returned error exit 
status 1
  UpgradeStatus: Upgraded to wily on 2015-12-17 (2 days ago)
  dmi.bios.date: 10/13/2004
  dmi.bios.vendor: IBM
  dmi.bios.version: 1UET93WW (1.43 )
  dmi.board.name: 2371EG2
  dmi.board.vendor: IBM
  dmi.board.version: Not Available
  dmi.chassis.asset.tag: No Asset Information
  dmi.chassis.type: 10
  dmi.chassis.vendor: IBM
  dmi.chassis.version: Not Available
  dmi.modalias: 
dmi:bvnIBM:bvr1UET93WW(1.43):bd10/13/2004:svnIBM:pn2371EG2:pvrThinkPadX40:rvnIBM:rn2371EG2:rvrNotAvailable:cvnIBM:ct10:cvrNotAvailable:
  dmi.product.name: 2371EG2
  dmi.product.version: ThinkPad X40
  dmi.sys.vendor: IBM

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1528047/+subscriptions

-- 
Mailing list: https://launchpad.net/~kernel-packages
Post to : kernel-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~kernel-packages
More help   : https://help.launchpad.net/ListHelp