[Kernel-packages] [Bug 1574982] Re: Cannot use CONFIG_CC_STACKPROTECTOR_STRONG: -fstack-protector-strong not supported by compiler

2018-07-03 Thread Joe Abt
** Changed in: linux (Ubuntu Xenial)
 Assignee: (unassigned) => Joe Abt (neondiscobrn)

-- 
You received this bug notification because you are a member of Kernel
Packages, which is subscribed to dkms in Ubuntu.
https://bugs.launchpad.net/bugs/1574982

Title:
  Cannot use CONFIG_CC_STACKPROTECTOR_STRONG: -fstack-protector-strong
  not supported by compiler

Status in dkms package in Ubuntu:
  Invalid
Status in gcc-defaults package in Ubuntu:
  Invalid
Status in linux package in Ubuntu:
  Fix Released
Status in nvidia-graphics-drivers-340 package in Ubuntu:
  Invalid
Status in nvidia-graphics-drivers-375 package in Ubuntu:
  Invalid
Status in virtualbox package in Ubuntu:
  Invalid
Status in dkms source package in Xenial:
  Invalid
Status in linux source package in Xenial:
  Fix Released

Bug description:
  Installing the latest 4.4.0-22 kernel ends with that error logged into 
dkmsbuildlog
  (only affect yakkety kernel; 4.4.0-22 kernel installation on xenial is fine)

  https://launchpadlibrarian.net/256055415/DKMSBuildLog.txt

  make "CC=cc"  KBUILD_VERBOSE= -C /lib/modules/4.4.0-22-generic/build 
M=/var/lib/dkms/nvidia-361/361.42/build ARCH=x86_64 
NV_KERNEL_SOURCES=/lib/modules/4.4.0-22-generic/build 
NV_KERNEL_OUTPUT=/lib/modules/4.4.0-22-generic/build NV_KERNEL_MODULES="nvidia 
nvidia-uvm nvidia-modeset" INSTALL_MOD_DIR=kernel/drivers/video modules
  make[1]: Entering directory '/usr/src/linux-headers-4.4.0-22-generic'
  arch/x86/Makefile:133: stack-protector enabled but compiler support broken
  Makefile:670: Cannot use CONFIG_CC_STACKPROTECTOR_STRONG: 
-fstack-protector-strong not supported by compiler

  the latest error logged is:

  /var/lib/dkms/nvidia-361/361.42/build/nvidia/nv-frontend.c:1:0: error:
  code model kernel does not support PIC mode

  Looks like it is related to the latest changes updates: gcc-6/gcc-5 
5.3.1-16ubuntu2 (some packages built with gcc-6; gcc-5 disabled for the 
packages built with gcc-6)
  Maybe some alternatives has not been updated to take care of these changes, 
as asked some time ago:
  http://askubuntu.com/questions/26498/choose-gcc-and-g-version

  This has been firstly reported against a nvidia crash:
  
https://bugs.launchpad.net/ubuntu/+source/nvidia-graphics-drivers-361/+bug/1574838

  ProblemType: Bug
  DistroRelease: Ubuntu 16.10
  Package: gcc 4:5.3.1-1ubuntu1
  ProcVersionSignature: Ubuntu 4.4.0-21.37-generic 4.4.6
  Uname: Linux 4.4.0-21-generic x86_64
  NonfreeKernelModules: nvidia_uvm nvidia_modeset nvidia
  ApportVersion: 2.20.1-0ubuntu2
  Architecture: amd64
  CurrentDesktop: GNOME
  Date: Tue Apr 26 08:41:32 2016
  SourcePackage: gcc-defaults
  UpgradeStatus: No upgrade log present (probably fresh install)
  ---
  ApportVersion: 2.20.1-0ubuntu2
  Architecture: amd64
  AudioDevicesInUse:
   USERPID ACCESS COMMAND
   /dev/snd/controlC1:  oem2014 F pulseaudio
   /dev/snd/pcmC0D0p:   oem2014 F...m pulseaudio
   /dev/snd/controlC0:  oem2014 F pulseaudio
  CurrentDesktop: GNOME
  DistroRelease: Ubuntu 16.10
  HibernationDevice: RESUME=UUID=0a9ca7f0-6eeb-4b21-b70f-670fa600de16
  IwConfig:
   eth0  no wireless extensions.

   eth1  no wireless extensions.

   lono wireless extensions.
  Lsusb:
   Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
   Bus 003 Device 002: ID 046d:c062 Logitech, Inc. M-UAS144 [LS1 Laser Mouse]
   Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
   Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
  MachineType: ASUSTEK COMPUTER INC P5W DH Deluxe
  NonfreeKernelModules: nvidia_uvm nvidia_modeset nvidia
  Package: ubuntu
  ProcFB:

  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.4.0-21-generic 
root=UUID=7c755ed6-51cc-4b75-88ac-9c75acf82749 ro
  ProcVersionSignature: Ubuntu 4.4.0-21.37-generic 4.4.6
  RelatedPackageVersions:
   linux-restricted-modules-4.4.0-21-generic N/A
   linux-backports-modules-4.4.0-21-generic  N/A
   linux-firmware1.157
  RfKill:

  Tags:  yakkety
  Uname: Linux 4.4.0-21-generic x86_64
  UpgradeStatus: No upgrade log present (probably fresh install)
  UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
  _MarkForUpload: True
  dmi.bios.date: 07/22/2010
  dmi.bios.vendor: American Megatrends Inc.
  dmi.bios.version: 3002
  dmi.board.asset.tag: To Be Filled By O.E.M.
  dmi.board.name: P5W DH Deluxe
  dmi.board.vendor: ASUSTeK Computer INC.
  dmi.board.version: Rev 1.xx
  dmi.chassis.asset.tag: Asset-1234567890
  dmi.chassis.type: 3
  dmi.chassis.vendor: Chassis Manufacture
  dmi.chassis.version: Chassis Version
  dmi.modalias: 
dmi:bvnAmericanMegatrendsInc.:bvr3002:bd07/22/2010:svnASUSTEKCOMPUTERINC:pnP5WDHDeluxe:pvrSystemVersion:rvnASUSTeKComputerINC.:rnP5WDHDeluxe:rvrRev1.xx:cvnChassisManufacture:ct3:cvrChassisVersion:
  dmi.product.name: P5W DH Deluxe
  dmi.product.version: System Version
  dmi.sys.vendor: ASUSTEK COMPUTER INC

To manage notifications about this bug go to:

[Kernel-packages] [Bug 1574982] Re: Cannot use CONFIG_CC_STACKPROTECTOR_STRONG: -fstack-protector-strong not supported by compiler

2018-02-26 Thread dino99
Looks like everything is ok now in 2018; closing that report.

** Changed in: virtualbox (Ubuntu)
   Status: Confirmed => Invalid

** Changed in: nvidia-graphics-drivers-375 (Ubuntu)
   Status: Confirmed => Invalid

** Changed in: nvidia-graphics-drivers-340 (Ubuntu)
   Status: Confirmed => Invalid

** Changed in: gcc-defaults (Ubuntu)
   Status: Confirmed => Invalid

-- 
You received this bug notification because you are a member of Kernel
Packages, which is subscribed to dkms in Ubuntu.
https://bugs.launchpad.net/bugs/1574982

Title:
  Cannot use CONFIG_CC_STACKPROTECTOR_STRONG: -fstack-protector-strong
  not supported by compiler

Status in dkms package in Ubuntu:
  Invalid
Status in gcc-defaults package in Ubuntu:
  Invalid
Status in linux package in Ubuntu:
  Fix Released
Status in nvidia-graphics-drivers-340 package in Ubuntu:
  Invalid
Status in nvidia-graphics-drivers-375 package in Ubuntu:
  Invalid
Status in virtualbox package in Ubuntu:
  Invalid
Status in dkms source package in Xenial:
  Invalid
Status in linux source package in Xenial:
  Fix Released

Bug description:
  Installing the latest 4.4.0-22 kernel ends with that error logged into 
dkmsbuildlog
  (only affect yakkety kernel; 4.4.0-22 kernel installation on xenial is fine)

  https://launchpadlibrarian.net/256055415/DKMSBuildLog.txt

  make "CC=cc"  KBUILD_VERBOSE= -C /lib/modules/4.4.0-22-generic/build 
M=/var/lib/dkms/nvidia-361/361.42/build ARCH=x86_64 
NV_KERNEL_SOURCES=/lib/modules/4.4.0-22-generic/build 
NV_KERNEL_OUTPUT=/lib/modules/4.4.0-22-generic/build NV_KERNEL_MODULES="nvidia 
nvidia-uvm nvidia-modeset" INSTALL_MOD_DIR=kernel/drivers/video modules
  make[1]: Entering directory '/usr/src/linux-headers-4.4.0-22-generic'
  arch/x86/Makefile:133: stack-protector enabled but compiler support broken
  Makefile:670: Cannot use CONFIG_CC_STACKPROTECTOR_STRONG: 
-fstack-protector-strong not supported by compiler

  the latest error logged is:

  /var/lib/dkms/nvidia-361/361.42/build/nvidia/nv-frontend.c:1:0: error:
  code model kernel does not support PIC mode

  Looks like it is related to the latest changes updates: gcc-6/gcc-5 
5.3.1-16ubuntu2 (some packages built with gcc-6; gcc-5 disabled for the 
packages built with gcc-6)
  Maybe some alternatives has not been updated to take care of these changes, 
as asked some time ago:
  http://askubuntu.com/questions/26498/choose-gcc-and-g-version

  This has been firstly reported against a nvidia crash:
  
https://bugs.launchpad.net/ubuntu/+source/nvidia-graphics-drivers-361/+bug/1574838

  ProblemType: Bug
  DistroRelease: Ubuntu 16.10
  Package: gcc 4:5.3.1-1ubuntu1
  ProcVersionSignature: Ubuntu 4.4.0-21.37-generic 4.4.6
  Uname: Linux 4.4.0-21-generic x86_64
  NonfreeKernelModules: nvidia_uvm nvidia_modeset nvidia
  ApportVersion: 2.20.1-0ubuntu2
  Architecture: amd64
  CurrentDesktop: GNOME
  Date: Tue Apr 26 08:41:32 2016
  SourcePackage: gcc-defaults
  UpgradeStatus: No upgrade log present (probably fresh install)
  ---
  ApportVersion: 2.20.1-0ubuntu2
  Architecture: amd64
  AudioDevicesInUse:
   USERPID ACCESS COMMAND
   /dev/snd/controlC1:  oem2014 F pulseaudio
   /dev/snd/pcmC0D0p:   oem2014 F...m pulseaudio
   /dev/snd/controlC0:  oem2014 F pulseaudio
  CurrentDesktop: GNOME
  DistroRelease: Ubuntu 16.10
  HibernationDevice: RESUME=UUID=0a9ca7f0-6eeb-4b21-b70f-670fa600de16
  IwConfig:
   eth0  no wireless extensions.

   eth1  no wireless extensions.

   lono wireless extensions.
  Lsusb:
   Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
   Bus 003 Device 002: ID 046d:c062 Logitech, Inc. M-UAS144 [LS1 Laser Mouse]
   Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
   Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
  MachineType: ASUSTEK COMPUTER INC P5W DH Deluxe
  NonfreeKernelModules: nvidia_uvm nvidia_modeset nvidia
  Package: ubuntu
  ProcFB:

  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.4.0-21-generic 
root=UUID=7c755ed6-51cc-4b75-88ac-9c75acf82749 ro
  ProcVersionSignature: Ubuntu 4.4.0-21.37-generic 4.4.6
  RelatedPackageVersions:
   linux-restricted-modules-4.4.0-21-generic N/A
   linux-backports-modules-4.4.0-21-generic  N/A
   linux-firmware1.157
  RfKill:

  Tags:  yakkety
  Uname: Linux 4.4.0-21-generic x86_64
  UpgradeStatus: No upgrade log present (probably fresh install)
  UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
  _MarkForUpload: True
  dmi.bios.date: 07/22/2010
  dmi.bios.vendor: American Megatrends Inc.
  dmi.bios.version: 3002
  dmi.board.asset.tag: To Be Filled By O.E.M.
  dmi.board.name: P5W DH Deluxe
  dmi.board.vendor: ASUSTeK Computer INC.
  dmi.board.version: Rev 1.xx
  dmi.chassis.asset.tag: Asset-1234567890
  dmi.chassis.type: 3
  dmi.chassis.vendor: Chassis Manufacture
  dmi.chassis.version: Chassis Version
  dmi.modalias: 

[Kernel-packages] [Bug 1574982] Re: Cannot use CONFIG_CC_STACKPROTECTOR_STRONG: -fstack-protector-strong not supported by compiler

2017-08-03 Thread Launchpad Bug Tracker
Status changed to 'Confirmed' because the bug affects multiple users.

** Changed in: nvidia-graphics-drivers-375 (Ubuntu)
   Status: New => Confirmed

-- 
You received this bug notification because you are a member of Kernel
Packages, which is subscribed to dkms in Ubuntu.
https://bugs.launchpad.net/bugs/1574982

Title:
  Cannot use CONFIG_CC_STACKPROTECTOR_STRONG: -fstack-protector-strong
  not supported by compiler

Status in dkms package in Ubuntu:
  Invalid
Status in gcc-defaults package in Ubuntu:
  Confirmed
Status in linux package in Ubuntu:
  Fix Released
Status in nvidia-graphics-drivers-340 package in Ubuntu:
  Confirmed
Status in nvidia-graphics-drivers-375 package in Ubuntu:
  Confirmed
Status in virtualbox package in Ubuntu:
  Confirmed
Status in dkms source package in Xenial:
  Invalid
Status in linux source package in Xenial:
  Fix Released

Bug description:
  Installing the latest 4.4.0-22 kernel ends with that error logged into 
dkmsbuildlog
  (only affect yakkety kernel; 4.4.0-22 kernel installation on xenial is fine)

  https://launchpadlibrarian.net/256055415/DKMSBuildLog.txt

  make "CC=cc"  KBUILD_VERBOSE= -C /lib/modules/4.4.0-22-generic/build 
M=/var/lib/dkms/nvidia-361/361.42/build ARCH=x86_64 
NV_KERNEL_SOURCES=/lib/modules/4.4.0-22-generic/build 
NV_KERNEL_OUTPUT=/lib/modules/4.4.0-22-generic/build NV_KERNEL_MODULES="nvidia 
nvidia-uvm nvidia-modeset" INSTALL_MOD_DIR=kernel/drivers/video modules
  make[1]: Entering directory '/usr/src/linux-headers-4.4.0-22-generic'
  arch/x86/Makefile:133: stack-protector enabled but compiler support broken
  Makefile:670: Cannot use CONFIG_CC_STACKPROTECTOR_STRONG: 
-fstack-protector-strong not supported by compiler

  the latest error logged is:

  /var/lib/dkms/nvidia-361/361.42/build/nvidia/nv-frontend.c:1:0: error:
  code model kernel does not support PIC mode

  Looks like it is related to the latest changes updates: gcc-6/gcc-5 
5.3.1-16ubuntu2 (some packages built with gcc-6; gcc-5 disabled for the 
packages built with gcc-6)
  Maybe some alternatives has not been updated to take care of these changes, 
as asked some time ago:
  http://askubuntu.com/questions/26498/choose-gcc-and-g-version

  This has been firstly reported against a nvidia crash:
  
https://bugs.launchpad.net/ubuntu/+source/nvidia-graphics-drivers-361/+bug/1574838

  ProblemType: Bug
  DistroRelease: Ubuntu 16.10
  Package: gcc 4:5.3.1-1ubuntu1
  ProcVersionSignature: Ubuntu 4.4.0-21.37-generic 4.4.6
  Uname: Linux 4.4.0-21-generic x86_64
  NonfreeKernelModules: nvidia_uvm nvidia_modeset nvidia
  ApportVersion: 2.20.1-0ubuntu2
  Architecture: amd64
  CurrentDesktop: GNOME
  Date: Tue Apr 26 08:41:32 2016
  SourcePackage: gcc-defaults
  UpgradeStatus: No upgrade log present (probably fresh install)
  ---
  ApportVersion: 2.20.1-0ubuntu2
  Architecture: amd64
  AudioDevicesInUse:
   USERPID ACCESS COMMAND
   /dev/snd/controlC1:  oem2014 F pulseaudio
   /dev/snd/pcmC0D0p:   oem2014 F...m pulseaudio
   /dev/snd/controlC0:  oem2014 F pulseaudio
  CurrentDesktop: GNOME
  DistroRelease: Ubuntu 16.10
  HibernationDevice: RESUME=UUID=0a9ca7f0-6eeb-4b21-b70f-670fa600de16
  IwConfig:
   eth0  no wireless extensions.

   eth1  no wireless extensions.

   lono wireless extensions.
  Lsusb:
   Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
   Bus 003 Device 002: ID 046d:c062 Logitech, Inc. M-UAS144 [LS1 Laser Mouse]
   Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
   Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
  MachineType: ASUSTEK COMPUTER INC P5W DH Deluxe
  NonfreeKernelModules: nvidia_uvm nvidia_modeset nvidia
  Package: ubuntu
  ProcFB:

  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.4.0-21-generic 
root=UUID=7c755ed6-51cc-4b75-88ac-9c75acf82749 ro
  ProcVersionSignature: Ubuntu 4.4.0-21.37-generic 4.4.6
  RelatedPackageVersions:
   linux-restricted-modules-4.4.0-21-generic N/A
   linux-backports-modules-4.4.0-21-generic  N/A
   linux-firmware1.157
  RfKill:

  Tags:  yakkety
  Uname: Linux 4.4.0-21-generic x86_64
  UpgradeStatus: No upgrade log present (probably fresh install)
  UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
  _MarkForUpload: True
  dmi.bios.date: 07/22/2010
  dmi.bios.vendor: American Megatrends Inc.
  dmi.bios.version: 3002
  dmi.board.asset.tag: To Be Filled By O.E.M.
  dmi.board.name: P5W DH Deluxe
  dmi.board.vendor: ASUSTeK Computer INC.
  dmi.board.version: Rev 1.xx
  dmi.chassis.asset.tag: Asset-1234567890
  dmi.chassis.type: 3
  dmi.chassis.vendor: Chassis Manufacture
  dmi.chassis.version: Chassis Version
  dmi.modalias: 
dmi:bvnAmericanMegatrendsInc.:bvr3002:bd07/22/2010:svnASUSTEKCOMPUTERINC:pnP5WDHDeluxe:pvrSystemVersion:rvnASUSTeKComputerINC.:rnP5WDHDeluxe:rvrRev1.xx:cvnChassisManufacture:ct3:cvrChassisVersion:
  dmi.product.name: P5W DH Deluxe
  dmi.product.version: System Version
  

[Kernel-packages] [Bug 1574982] Re: Cannot use CONFIG_CC_STACKPROTECTOR_STRONG: -fstack-protector-strong not supported by compiler

2017-08-03 Thread Launchpad Bug Tracker
Status changed to 'Confirmed' because the bug affects multiple users.

** Changed in: nvidia-graphics-drivers-340 (Ubuntu)
   Status: New => Confirmed

-- 
You received this bug notification because you are a member of Kernel
Packages, which is subscribed to dkms in Ubuntu.
https://bugs.launchpad.net/bugs/1574982

Title:
  Cannot use CONFIG_CC_STACKPROTECTOR_STRONG: -fstack-protector-strong
  not supported by compiler

Status in dkms package in Ubuntu:
  Invalid
Status in gcc-defaults package in Ubuntu:
  Confirmed
Status in linux package in Ubuntu:
  Fix Released
Status in nvidia-graphics-drivers-340 package in Ubuntu:
  Confirmed
Status in nvidia-graphics-drivers-375 package in Ubuntu:
  Confirmed
Status in virtualbox package in Ubuntu:
  Confirmed
Status in dkms source package in Xenial:
  Invalid
Status in linux source package in Xenial:
  Fix Released

Bug description:
  Installing the latest 4.4.0-22 kernel ends with that error logged into 
dkmsbuildlog
  (only affect yakkety kernel; 4.4.0-22 kernel installation on xenial is fine)

  https://launchpadlibrarian.net/256055415/DKMSBuildLog.txt

  make "CC=cc"  KBUILD_VERBOSE= -C /lib/modules/4.4.0-22-generic/build 
M=/var/lib/dkms/nvidia-361/361.42/build ARCH=x86_64 
NV_KERNEL_SOURCES=/lib/modules/4.4.0-22-generic/build 
NV_KERNEL_OUTPUT=/lib/modules/4.4.0-22-generic/build NV_KERNEL_MODULES="nvidia 
nvidia-uvm nvidia-modeset" INSTALL_MOD_DIR=kernel/drivers/video modules
  make[1]: Entering directory '/usr/src/linux-headers-4.4.0-22-generic'
  arch/x86/Makefile:133: stack-protector enabled but compiler support broken
  Makefile:670: Cannot use CONFIG_CC_STACKPROTECTOR_STRONG: 
-fstack-protector-strong not supported by compiler

  the latest error logged is:

  /var/lib/dkms/nvidia-361/361.42/build/nvidia/nv-frontend.c:1:0: error:
  code model kernel does not support PIC mode

  Looks like it is related to the latest changes updates: gcc-6/gcc-5 
5.3.1-16ubuntu2 (some packages built with gcc-6; gcc-5 disabled for the 
packages built with gcc-6)
  Maybe some alternatives has not been updated to take care of these changes, 
as asked some time ago:
  http://askubuntu.com/questions/26498/choose-gcc-and-g-version

  This has been firstly reported against a nvidia crash:
  
https://bugs.launchpad.net/ubuntu/+source/nvidia-graphics-drivers-361/+bug/1574838

  ProblemType: Bug
  DistroRelease: Ubuntu 16.10
  Package: gcc 4:5.3.1-1ubuntu1
  ProcVersionSignature: Ubuntu 4.4.0-21.37-generic 4.4.6
  Uname: Linux 4.4.0-21-generic x86_64
  NonfreeKernelModules: nvidia_uvm nvidia_modeset nvidia
  ApportVersion: 2.20.1-0ubuntu2
  Architecture: amd64
  CurrentDesktop: GNOME
  Date: Tue Apr 26 08:41:32 2016
  SourcePackage: gcc-defaults
  UpgradeStatus: No upgrade log present (probably fresh install)
  ---
  ApportVersion: 2.20.1-0ubuntu2
  Architecture: amd64
  AudioDevicesInUse:
   USERPID ACCESS COMMAND
   /dev/snd/controlC1:  oem2014 F pulseaudio
   /dev/snd/pcmC0D0p:   oem2014 F...m pulseaudio
   /dev/snd/controlC0:  oem2014 F pulseaudio
  CurrentDesktop: GNOME
  DistroRelease: Ubuntu 16.10
  HibernationDevice: RESUME=UUID=0a9ca7f0-6eeb-4b21-b70f-670fa600de16
  IwConfig:
   eth0  no wireless extensions.

   eth1  no wireless extensions.

   lono wireless extensions.
  Lsusb:
   Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
   Bus 003 Device 002: ID 046d:c062 Logitech, Inc. M-UAS144 [LS1 Laser Mouse]
   Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
   Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
  MachineType: ASUSTEK COMPUTER INC P5W DH Deluxe
  NonfreeKernelModules: nvidia_uvm nvidia_modeset nvidia
  Package: ubuntu
  ProcFB:

  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.4.0-21-generic 
root=UUID=7c755ed6-51cc-4b75-88ac-9c75acf82749 ro
  ProcVersionSignature: Ubuntu 4.4.0-21.37-generic 4.4.6
  RelatedPackageVersions:
   linux-restricted-modules-4.4.0-21-generic N/A
   linux-backports-modules-4.4.0-21-generic  N/A
   linux-firmware1.157
  RfKill:

  Tags:  yakkety
  Uname: Linux 4.4.0-21-generic x86_64
  UpgradeStatus: No upgrade log present (probably fresh install)
  UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
  _MarkForUpload: True
  dmi.bios.date: 07/22/2010
  dmi.bios.vendor: American Megatrends Inc.
  dmi.bios.version: 3002
  dmi.board.asset.tag: To Be Filled By O.E.M.
  dmi.board.name: P5W DH Deluxe
  dmi.board.vendor: ASUSTeK Computer INC.
  dmi.board.version: Rev 1.xx
  dmi.chassis.asset.tag: Asset-1234567890
  dmi.chassis.type: 3
  dmi.chassis.vendor: Chassis Manufacture
  dmi.chassis.version: Chassis Version
  dmi.modalias: 
dmi:bvnAmericanMegatrendsInc.:bvr3002:bd07/22/2010:svnASUSTEKCOMPUTERINC:pnP5WDHDeluxe:pvrSystemVersion:rvnASUSTeKComputerINC.:rnP5WDHDeluxe:rvrRev1.xx:cvnChassisManufacture:ct3:cvrChassisVersion:
  dmi.product.name: P5W DH Deluxe
  dmi.product.version: System Version
  

[Kernel-packages] [Bug 1574982] Re: Cannot use CONFIG_CC_STACKPROTECTOR_STRONG: -fstack-protector-strong not supported by compiler

2017-07-10 Thread xylo
** Also affects: nvidia-graphics-drivers-340 (Ubuntu)
   Importance: Undecided
   Status: New

** Also affects: nvidia-graphics-drivers-375 (Ubuntu)
   Importance: Undecided
   Status: New

-- 
You received this bug notification because you are a member of Kernel
Packages, which is subscribed to dkms in Ubuntu.
https://bugs.launchpad.net/bugs/1574982

Title:
  Cannot use CONFIG_CC_STACKPROTECTOR_STRONG: -fstack-protector-strong
  not supported by compiler

Status in dkms package in Ubuntu:
  Invalid
Status in gcc-defaults package in Ubuntu:
  Confirmed
Status in linux package in Ubuntu:
  Fix Released
Status in nvidia-graphics-drivers-340 package in Ubuntu:
  New
Status in nvidia-graphics-drivers-375 package in Ubuntu:
  New
Status in virtualbox package in Ubuntu:
  Confirmed
Status in dkms source package in Xenial:
  Invalid
Status in linux source package in Xenial:
  Fix Released

Bug description:
  Installing the latest 4.4.0-22 kernel ends with that error logged into 
dkmsbuildlog
  (only affect yakkety kernel; 4.4.0-22 kernel installation on xenial is fine)

  https://launchpadlibrarian.net/256055415/DKMSBuildLog.txt

  make "CC=cc"  KBUILD_VERBOSE= -C /lib/modules/4.4.0-22-generic/build 
M=/var/lib/dkms/nvidia-361/361.42/build ARCH=x86_64 
NV_KERNEL_SOURCES=/lib/modules/4.4.0-22-generic/build 
NV_KERNEL_OUTPUT=/lib/modules/4.4.0-22-generic/build NV_KERNEL_MODULES="nvidia 
nvidia-uvm nvidia-modeset" INSTALL_MOD_DIR=kernel/drivers/video modules
  make[1]: Entering directory '/usr/src/linux-headers-4.4.0-22-generic'
  arch/x86/Makefile:133: stack-protector enabled but compiler support broken
  Makefile:670: Cannot use CONFIG_CC_STACKPROTECTOR_STRONG: 
-fstack-protector-strong not supported by compiler

  the latest error logged is:

  /var/lib/dkms/nvidia-361/361.42/build/nvidia/nv-frontend.c:1:0: error:
  code model kernel does not support PIC mode

  Looks like it is related to the latest changes updates: gcc-6/gcc-5 
5.3.1-16ubuntu2 (some packages built with gcc-6; gcc-5 disabled for the 
packages built with gcc-6)
  Maybe some alternatives has not been updated to take care of these changes, 
as asked some time ago:
  http://askubuntu.com/questions/26498/choose-gcc-and-g-version

  This has been firstly reported against a nvidia crash:
  
https://bugs.launchpad.net/ubuntu/+source/nvidia-graphics-drivers-361/+bug/1574838

  ProblemType: Bug
  DistroRelease: Ubuntu 16.10
  Package: gcc 4:5.3.1-1ubuntu1
  ProcVersionSignature: Ubuntu 4.4.0-21.37-generic 4.4.6
  Uname: Linux 4.4.0-21-generic x86_64
  NonfreeKernelModules: nvidia_uvm nvidia_modeset nvidia
  ApportVersion: 2.20.1-0ubuntu2
  Architecture: amd64
  CurrentDesktop: GNOME
  Date: Tue Apr 26 08:41:32 2016
  SourcePackage: gcc-defaults
  UpgradeStatus: No upgrade log present (probably fresh install)
  ---
  ApportVersion: 2.20.1-0ubuntu2
  Architecture: amd64
  AudioDevicesInUse:
   USERPID ACCESS COMMAND
   /dev/snd/controlC1:  oem2014 F pulseaudio
   /dev/snd/pcmC0D0p:   oem2014 F...m pulseaudio
   /dev/snd/controlC0:  oem2014 F pulseaudio
  CurrentDesktop: GNOME
  DistroRelease: Ubuntu 16.10
  HibernationDevice: RESUME=UUID=0a9ca7f0-6eeb-4b21-b70f-670fa600de16
  IwConfig:
   eth0  no wireless extensions.

   eth1  no wireless extensions.

   lono wireless extensions.
  Lsusb:
   Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
   Bus 003 Device 002: ID 046d:c062 Logitech, Inc. M-UAS144 [LS1 Laser Mouse]
   Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
   Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
  MachineType: ASUSTEK COMPUTER INC P5W DH Deluxe
  NonfreeKernelModules: nvidia_uvm nvidia_modeset nvidia
  Package: ubuntu
  ProcFB:

  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.4.0-21-generic 
root=UUID=7c755ed6-51cc-4b75-88ac-9c75acf82749 ro
  ProcVersionSignature: Ubuntu 4.4.0-21.37-generic 4.4.6
  RelatedPackageVersions:
   linux-restricted-modules-4.4.0-21-generic N/A
   linux-backports-modules-4.4.0-21-generic  N/A
   linux-firmware1.157
  RfKill:

  Tags:  yakkety
  Uname: Linux 4.4.0-21-generic x86_64
  UpgradeStatus: No upgrade log present (probably fresh install)
  UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
  _MarkForUpload: True
  dmi.bios.date: 07/22/2010
  dmi.bios.vendor: American Megatrends Inc.
  dmi.bios.version: 3002
  dmi.board.asset.tag: To Be Filled By O.E.M.
  dmi.board.name: P5W DH Deluxe
  dmi.board.vendor: ASUSTeK Computer INC.
  dmi.board.version: Rev 1.xx
  dmi.chassis.asset.tag: Asset-1234567890
  dmi.chassis.type: 3
  dmi.chassis.vendor: Chassis Manufacture
  dmi.chassis.version: Chassis Version
  dmi.modalias: 
dmi:bvnAmericanMegatrendsInc.:bvr3002:bd07/22/2010:svnASUSTEKCOMPUTERINC:pnP5WDHDeluxe:pvrSystemVersion:rvnASUSTeKComputerINC.:rnP5WDHDeluxe:rvrRev1.xx:cvnChassisManufacture:ct3:cvrChassisVersion:
  dmi.product.name: P5W DH Deluxe
  dmi.product.version: 

[Kernel-packages] [Bug 1574982] Re: Cannot use CONFIG_CC_STACKPROTECTOR_STRONG: -fstack-protector-strong not supported by compiler

2017-03-24 Thread Launchpad Bug Tracker
Status changed to 'Confirmed' because the bug affects multiple users.

** Changed in: virtualbox (Ubuntu)
   Status: New => Confirmed

-- 
You received this bug notification because you are a member of Kernel
Packages, which is subscribed to dkms in Ubuntu.
https://bugs.launchpad.net/bugs/1574982

Title:
  Cannot use CONFIG_CC_STACKPROTECTOR_STRONG: -fstack-protector-strong
  not supported by compiler

Status in dkms package in Ubuntu:
  Invalid
Status in gcc-defaults package in Ubuntu:
  Confirmed
Status in linux package in Ubuntu:
  Fix Released
Status in virtualbox package in Ubuntu:
  Confirmed
Status in dkms source package in Xenial:
  Invalid
Status in linux source package in Xenial:
  Fix Released

Bug description:
  Installing the latest 4.4.0-22 kernel ends with that error logged into 
dkmsbuildlog
  (only affect yakkety kernel; 4.4.0-22 kernel installation on xenial is fine)

  https://launchpadlibrarian.net/256055415/DKMSBuildLog.txt

  make "CC=cc"  KBUILD_VERBOSE= -C /lib/modules/4.4.0-22-generic/build 
M=/var/lib/dkms/nvidia-361/361.42/build ARCH=x86_64 
NV_KERNEL_SOURCES=/lib/modules/4.4.0-22-generic/build 
NV_KERNEL_OUTPUT=/lib/modules/4.4.0-22-generic/build NV_KERNEL_MODULES="nvidia 
nvidia-uvm nvidia-modeset" INSTALL_MOD_DIR=kernel/drivers/video modules
  make[1]: Entering directory '/usr/src/linux-headers-4.4.0-22-generic'
  arch/x86/Makefile:133: stack-protector enabled but compiler support broken
  Makefile:670: Cannot use CONFIG_CC_STACKPROTECTOR_STRONG: 
-fstack-protector-strong not supported by compiler

  the latest error logged is:

  /var/lib/dkms/nvidia-361/361.42/build/nvidia/nv-frontend.c:1:0: error:
  code model kernel does not support PIC mode

  Looks like it is related to the latest changes updates: gcc-6/gcc-5 
5.3.1-16ubuntu2 (some packages built with gcc-6; gcc-5 disabled for the 
packages built with gcc-6)
  Maybe some alternatives has not been updated to take care of these changes, 
as asked some time ago:
  http://askubuntu.com/questions/26498/choose-gcc-and-g-version

  This has been firstly reported against a nvidia crash:
  
https://bugs.launchpad.net/ubuntu/+source/nvidia-graphics-drivers-361/+bug/1574838

  ProblemType: Bug
  DistroRelease: Ubuntu 16.10
  Package: gcc 4:5.3.1-1ubuntu1
  ProcVersionSignature: Ubuntu 4.4.0-21.37-generic 4.4.6
  Uname: Linux 4.4.0-21-generic x86_64
  NonfreeKernelModules: nvidia_uvm nvidia_modeset nvidia
  ApportVersion: 2.20.1-0ubuntu2
  Architecture: amd64
  CurrentDesktop: GNOME
  Date: Tue Apr 26 08:41:32 2016
  SourcePackage: gcc-defaults
  UpgradeStatus: No upgrade log present (probably fresh install)
  ---
  ApportVersion: 2.20.1-0ubuntu2
  Architecture: amd64
  AudioDevicesInUse:
   USERPID ACCESS COMMAND
   /dev/snd/controlC1:  oem2014 F pulseaudio
   /dev/snd/pcmC0D0p:   oem2014 F...m pulseaudio
   /dev/snd/controlC0:  oem2014 F pulseaudio
  CurrentDesktop: GNOME
  DistroRelease: Ubuntu 16.10
  HibernationDevice: RESUME=UUID=0a9ca7f0-6eeb-4b21-b70f-670fa600de16
  IwConfig:
   eth0  no wireless extensions.

   eth1  no wireless extensions.

   lono wireless extensions.
  Lsusb:
   Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
   Bus 003 Device 002: ID 046d:c062 Logitech, Inc. M-UAS144 [LS1 Laser Mouse]
   Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
   Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
  MachineType: ASUSTEK COMPUTER INC P5W DH Deluxe
  NonfreeKernelModules: nvidia_uvm nvidia_modeset nvidia
  Package: ubuntu
  ProcFB:

  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.4.0-21-generic 
root=UUID=7c755ed6-51cc-4b75-88ac-9c75acf82749 ro
  ProcVersionSignature: Ubuntu 4.4.0-21.37-generic 4.4.6
  RelatedPackageVersions:
   linux-restricted-modules-4.4.0-21-generic N/A
   linux-backports-modules-4.4.0-21-generic  N/A
   linux-firmware1.157
  RfKill:

  Tags:  yakkety
  Uname: Linux 4.4.0-21-generic x86_64
  UpgradeStatus: No upgrade log present (probably fresh install)
  UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
  _MarkForUpload: True
  dmi.bios.date: 07/22/2010
  dmi.bios.vendor: American Megatrends Inc.
  dmi.bios.version: 3002
  dmi.board.asset.tag: To Be Filled By O.E.M.
  dmi.board.name: P5W DH Deluxe
  dmi.board.vendor: ASUSTeK Computer INC.
  dmi.board.version: Rev 1.xx
  dmi.chassis.asset.tag: Asset-1234567890
  dmi.chassis.type: 3
  dmi.chassis.vendor: Chassis Manufacture
  dmi.chassis.version: Chassis Version
  dmi.modalias: 
dmi:bvnAmericanMegatrendsInc.:bvr3002:bd07/22/2010:svnASUSTEKCOMPUTERINC:pnP5WDHDeluxe:pvrSystemVersion:rvnASUSTeKComputerINC.:rnP5WDHDeluxe:rvrRev1.xx:cvnChassisManufacture:ct3:cvrChassisVersion:
  dmi.product.name: P5W DH Deluxe
  dmi.product.version: System Version
  dmi.sys.vendor: ASUSTEK COMPUTER INC

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/dkms/+bug/1574982/+subscriptions

-- 

[Kernel-packages] [Bug 1574982] Re: Cannot use CONFIG_CC_STACKPROTECTOR_STRONG: -fstack-protector-strong not supported by compiler

2017-03-24 Thread LocutusOfBorg
** Also affects: virtualbox (Ubuntu)
   Importance: Undecided
   Status: New

-- 
You received this bug notification because you are a member of Kernel
Packages, which is subscribed to dkms in Ubuntu.
https://bugs.launchpad.net/bugs/1574982

Title:
  Cannot use CONFIG_CC_STACKPROTECTOR_STRONG: -fstack-protector-strong
  not supported by compiler

Status in dkms package in Ubuntu:
  Invalid
Status in gcc-defaults package in Ubuntu:
  Confirmed
Status in linux package in Ubuntu:
  Fix Released
Status in virtualbox package in Ubuntu:
  New
Status in dkms source package in Xenial:
  Invalid
Status in linux source package in Xenial:
  Fix Released

Bug description:
  Installing the latest 4.4.0-22 kernel ends with that error logged into 
dkmsbuildlog
  (only affect yakkety kernel; 4.4.0-22 kernel installation on xenial is fine)

  https://launchpadlibrarian.net/256055415/DKMSBuildLog.txt

  make "CC=cc"  KBUILD_VERBOSE= -C /lib/modules/4.4.0-22-generic/build 
M=/var/lib/dkms/nvidia-361/361.42/build ARCH=x86_64 
NV_KERNEL_SOURCES=/lib/modules/4.4.0-22-generic/build 
NV_KERNEL_OUTPUT=/lib/modules/4.4.0-22-generic/build NV_KERNEL_MODULES="nvidia 
nvidia-uvm nvidia-modeset" INSTALL_MOD_DIR=kernel/drivers/video modules
  make[1]: Entering directory '/usr/src/linux-headers-4.4.0-22-generic'
  arch/x86/Makefile:133: stack-protector enabled but compiler support broken
  Makefile:670: Cannot use CONFIG_CC_STACKPROTECTOR_STRONG: 
-fstack-protector-strong not supported by compiler

  the latest error logged is:

  /var/lib/dkms/nvidia-361/361.42/build/nvidia/nv-frontend.c:1:0: error:
  code model kernel does not support PIC mode

  Looks like it is related to the latest changes updates: gcc-6/gcc-5 
5.3.1-16ubuntu2 (some packages built with gcc-6; gcc-5 disabled for the 
packages built with gcc-6)
  Maybe some alternatives has not been updated to take care of these changes, 
as asked some time ago:
  http://askubuntu.com/questions/26498/choose-gcc-and-g-version

  This has been firstly reported against a nvidia crash:
  
https://bugs.launchpad.net/ubuntu/+source/nvidia-graphics-drivers-361/+bug/1574838

  ProblemType: Bug
  DistroRelease: Ubuntu 16.10
  Package: gcc 4:5.3.1-1ubuntu1
  ProcVersionSignature: Ubuntu 4.4.0-21.37-generic 4.4.6
  Uname: Linux 4.4.0-21-generic x86_64
  NonfreeKernelModules: nvidia_uvm nvidia_modeset nvidia
  ApportVersion: 2.20.1-0ubuntu2
  Architecture: amd64
  CurrentDesktop: GNOME
  Date: Tue Apr 26 08:41:32 2016
  SourcePackage: gcc-defaults
  UpgradeStatus: No upgrade log present (probably fresh install)
  ---
  ApportVersion: 2.20.1-0ubuntu2
  Architecture: amd64
  AudioDevicesInUse:
   USERPID ACCESS COMMAND
   /dev/snd/controlC1:  oem2014 F pulseaudio
   /dev/snd/pcmC0D0p:   oem2014 F...m pulseaudio
   /dev/snd/controlC0:  oem2014 F pulseaudio
  CurrentDesktop: GNOME
  DistroRelease: Ubuntu 16.10
  HibernationDevice: RESUME=UUID=0a9ca7f0-6eeb-4b21-b70f-670fa600de16
  IwConfig:
   eth0  no wireless extensions.

   eth1  no wireless extensions.

   lono wireless extensions.
  Lsusb:
   Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
   Bus 003 Device 002: ID 046d:c062 Logitech, Inc. M-UAS144 [LS1 Laser Mouse]
   Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
   Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
  MachineType: ASUSTEK COMPUTER INC P5W DH Deluxe
  NonfreeKernelModules: nvidia_uvm nvidia_modeset nvidia
  Package: ubuntu
  ProcFB:

  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.4.0-21-generic 
root=UUID=7c755ed6-51cc-4b75-88ac-9c75acf82749 ro
  ProcVersionSignature: Ubuntu 4.4.0-21.37-generic 4.4.6
  RelatedPackageVersions:
   linux-restricted-modules-4.4.0-21-generic N/A
   linux-backports-modules-4.4.0-21-generic  N/A
   linux-firmware1.157
  RfKill:

  Tags:  yakkety
  Uname: Linux 4.4.0-21-generic x86_64
  UpgradeStatus: No upgrade log present (probably fresh install)
  UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
  _MarkForUpload: True
  dmi.bios.date: 07/22/2010
  dmi.bios.vendor: American Megatrends Inc.
  dmi.bios.version: 3002
  dmi.board.asset.tag: To Be Filled By O.E.M.
  dmi.board.name: P5W DH Deluxe
  dmi.board.vendor: ASUSTeK Computer INC.
  dmi.board.version: Rev 1.xx
  dmi.chassis.asset.tag: Asset-1234567890
  dmi.chassis.type: 3
  dmi.chassis.vendor: Chassis Manufacture
  dmi.chassis.version: Chassis Version
  dmi.modalias: 
dmi:bvnAmericanMegatrendsInc.:bvr3002:bd07/22/2010:svnASUSTEKCOMPUTERINC:pnP5WDHDeluxe:pvrSystemVersion:rvnASUSTeKComputerINC.:rnP5WDHDeluxe:rvrRev1.xx:cvnChassisManufacture:ct3:cvrChassisVersion:
  dmi.product.name: P5W DH Deluxe
  dmi.product.version: System Version
  dmi.sys.vendor: ASUSTEK COMPUTER INC

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/dkms/+bug/1574982/+subscriptions

-- 
Mailing list: https://launchpad.net/~kernel-packages
Post to : 

[Kernel-packages] [Bug 1574982] Re: Cannot use CONFIG_CC_STACKPROTECTOR_STRONG: -fstack-protector-strong not supported by compiler

2016-11-25 Thread iLogin
-fno-PIE builds (Sebastian Siewior and Borislav Petkov). This is
 not a kernel regression, but one of the Debian gcc package.
 Nevertheless, it's quite annoying, so I think it should go into
 mainline and stable now"


http://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/commit/?id=04e36857d6747e4525e68c4292c081b795b48366

-- 
You received this bug notification because you are a member of Kernel
Packages, which is subscribed to dkms in Ubuntu.
https://bugs.launchpad.net/bugs/1574982

Title:
  Cannot use CONFIG_CC_STACKPROTECTOR_STRONG: -fstack-protector-strong
  not supported by compiler

Status in dkms package in Ubuntu:
  Invalid
Status in gcc-defaults package in Ubuntu:
  Confirmed
Status in linux package in Ubuntu:
  Fix Released
Status in dkms source package in Xenial:
  Invalid
Status in linux source package in Xenial:
  Fix Released

Bug description:
  Installing the latest 4.4.0-22 kernel ends with that error logged into 
dkmsbuildlog
  (only affect yakkety kernel; 4.4.0-22 kernel installation on xenial is fine)

  https://launchpadlibrarian.net/256055415/DKMSBuildLog.txt

  make "CC=cc"  KBUILD_VERBOSE= -C /lib/modules/4.4.0-22-generic/build 
M=/var/lib/dkms/nvidia-361/361.42/build ARCH=x86_64 
NV_KERNEL_SOURCES=/lib/modules/4.4.0-22-generic/build 
NV_KERNEL_OUTPUT=/lib/modules/4.4.0-22-generic/build NV_KERNEL_MODULES="nvidia 
nvidia-uvm nvidia-modeset" INSTALL_MOD_DIR=kernel/drivers/video modules
  make[1]: Entering directory '/usr/src/linux-headers-4.4.0-22-generic'
  arch/x86/Makefile:133: stack-protector enabled but compiler support broken
  Makefile:670: Cannot use CONFIG_CC_STACKPROTECTOR_STRONG: 
-fstack-protector-strong not supported by compiler

  the latest error logged is:

  /var/lib/dkms/nvidia-361/361.42/build/nvidia/nv-frontend.c:1:0: error:
  code model kernel does not support PIC mode

  Looks like it is related to the latest changes updates: gcc-6/gcc-5 
5.3.1-16ubuntu2 (some packages built with gcc-6; gcc-5 disabled for the 
packages built with gcc-6)
  Maybe some alternatives has not been updated to take care of these changes, 
as asked some time ago:
  http://askubuntu.com/questions/26498/choose-gcc-and-g-version

  This has been firstly reported against a nvidia crash:
  
https://bugs.launchpad.net/ubuntu/+source/nvidia-graphics-drivers-361/+bug/1574838

  ProblemType: Bug
  DistroRelease: Ubuntu 16.10
  Package: gcc 4:5.3.1-1ubuntu1
  ProcVersionSignature: Ubuntu 4.4.0-21.37-generic 4.4.6
  Uname: Linux 4.4.0-21-generic x86_64
  NonfreeKernelModules: nvidia_uvm nvidia_modeset nvidia
  ApportVersion: 2.20.1-0ubuntu2
  Architecture: amd64
  CurrentDesktop: GNOME
  Date: Tue Apr 26 08:41:32 2016
  SourcePackage: gcc-defaults
  UpgradeStatus: No upgrade log present (probably fresh install)
  ---
  ApportVersion: 2.20.1-0ubuntu2
  Architecture: amd64
  AudioDevicesInUse:
   USERPID ACCESS COMMAND
   /dev/snd/controlC1:  oem2014 F pulseaudio
   /dev/snd/pcmC0D0p:   oem2014 F...m pulseaudio
   /dev/snd/controlC0:  oem2014 F pulseaudio
  CurrentDesktop: GNOME
  DistroRelease: Ubuntu 16.10
  HibernationDevice: RESUME=UUID=0a9ca7f0-6eeb-4b21-b70f-670fa600de16
  IwConfig:
   eth0  no wireless extensions.

   eth1  no wireless extensions.

   lono wireless extensions.
  Lsusb:
   Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
   Bus 003 Device 002: ID 046d:c062 Logitech, Inc. M-UAS144 [LS1 Laser Mouse]
   Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
   Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
  MachineType: ASUSTEK COMPUTER INC P5W DH Deluxe
  NonfreeKernelModules: nvidia_uvm nvidia_modeset nvidia
  Package: ubuntu
  ProcFB:

  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.4.0-21-generic 
root=UUID=7c755ed6-51cc-4b75-88ac-9c75acf82749 ro
  ProcVersionSignature: Ubuntu 4.4.0-21.37-generic 4.4.6
  RelatedPackageVersions:
   linux-restricted-modules-4.4.0-21-generic N/A
   linux-backports-modules-4.4.0-21-generic  N/A
   linux-firmware1.157
  RfKill:

  Tags:  yakkety
  Uname: Linux 4.4.0-21-generic x86_64
  UpgradeStatus: No upgrade log present (probably fresh install)
  UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
  _MarkForUpload: True
  dmi.bios.date: 07/22/2010
  dmi.bios.vendor: American Megatrends Inc.
  dmi.bios.version: 3002
  dmi.board.asset.tag: To Be Filled By O.E.M.
  dmi.board.name: P5W DH Deluxe
  dmi.board.vendor: ASUSTeK Computer INC.
  dmi.board.version: Rev 1.xx
  dmi.chassis.asset.tag: Asset-1234567890
  dmi.chassis.type: 3
  dmi.chassis.vendor: Chassis Manufacture
  dmi.chassis.version: Chassis Version
  dmi.modalias: 
dmi:bvnAmericanMegatrendsInc.:bvr3002:bd07/22/2010:svnASUSTEKCOMPUTERINC:pnP5WDHDeluxe:pvrSystemVersion:rvnASUSTeKComputerINC.:rnP5WDHDeluxe:rvrRev1.xx:cvnChassisManufacture:ct3:cvrChassisVersion:
  dmi.product.name: P5W DH Deluxe
  dmi.product.version: System Version
  

[Kernel-packages] [Bug 1574982] Re: Cannot use CONFIG_CC_STACKPROTECTOR_STRONG: -fstack-protector-strong not supported by compiler

2016-11-19 Thread Dese Narfa Firmansyah
** Changed in: gcc-defaults (Ubuntu)
   Status: Invalid => Confirmed

-- 
You received this bug notification because you are a member of Kernel
Packages, which is subscribed to dkms in Ubuntu.
https://bugs.launchpad.net/bugs/1574982

Title:
  Cannot use CONFIG_CC_STACKPROTECTOR_STRONG: -fstack-protector-strong
  not supported by compiler

Status in dkms package in Ubuntu:
  Invalid
Status in gcc-defaults package in Ubuntu:
  Confirmed
Status in linux package in Ubuntu:
  Fix Released
Status in dkms source package in Xenial:
  Invalid
Status in linux source package in Xenial:
  Fix Released

Bug description:
  Installing the latest 4.4.0-22 kernel ends with that error logged into 
dkmsbuildlog
  (only affect yakkety kernel; 4.4.0-22 kernel installation on xenial is fine)

  https://launchpadlibrarian.net/256055415/DKMSBuildLog.txt

  make "CC=cc"  KBUILD_VERBOSE= -C /lib/modules/4.4.0-22-generic/build 
M=/var/lib/dkms/nvidia-361/361.42/build ARCH=x86_64 
NV_KERNEL_SOURCES=/lib/modules/4.4.0-22-generic/build 
NV_KERNEL_OUTPUT=/lib/modules/4.4.0-22-generic/build NV_KERNEL_MODULES="nvidia 
nvidia-uvm nvidia-modeset" INSTALL_MOD_DIR=kernel/drivers/video modules
  make[1]: Entering directory '/usr/src/linux-headers-4.4.0-22-generic'
  arch/x86/Makefile:133: stack-protector enabled but compiler support broken
  Makefile:670: Cannot use CONFIG_CC_STACKPROTECTOR_STRONG: 
-fstack-protector-strong not supported by compiler

  the latest error logged is:

  /var/lib/dkms/nvidia-361/361.42/build/nvidia/nv-frontend.c:1:0: error:
  code model kernel does not support PIC mode

  Looks like it is related to the latest changes updates: gcc-6/gcc-5 
5.3.1-16ubuntu2 (some packages built with gcc-6; gcc-5 disabled for the 
packages built with gcc-6)
  Maybe some alternatives has not been updated to take care of these changes, 
as asked some time ago:
  http://askubuntu.com/questions/26498/choose-gcc-and-g-version

  This has been firstly reported against a nvidia crash:
  
https://bugs.launchpad.net/ubuntu/+source/nvidia-graphics-drivers-361/+bug/1574838

  ProblemType: Bug
  DistroRelease: Ubuntu 16.10
  Package: gcc 4:5.3.1-1ubuntu1
  ProcVersionSignature: Ubuntu 4.4.0-21.37-generic 4.4.6
  Uname: Linux 4.4.0-21-generic x86_64
  NonfreeKernelModules: nvidia_uvm nvidia_modeset nvidia
  ApportVersion: 2.20.1-0ubuntu2
  Architecture: amd64
  CurrentDesktop: GNOME
  Date: Tue Apr 26 08:41:32 2016
  SourcePackage: gcc-defaults
  UpgradeStatus: No upgrade log present (probably fresh install)
  ---
  ApportVersion: 2.20.1-0ubuntu2
  Architecture: amd64
  AudioDevicesInUse:
   USERPID ACCESS COMMAND
   /dev/snd/controlC1:  oem2014 F pulseaudio
   /dev/snd/pcmC0D0p:   oem2014 F...m pulseaudio
   /dev/snd/controlC0:  oem2014 F pulseaudio
  CurrentDesktop: GNOME
  DistroRelease: Ubuntu 16.10
  HibernationDevice: RESUME=UUID=0a9ca7f0-6eeb-4b21-b70f-670fa600de16
  IwConfig:
   eth0  no wireless extensions.

   eth1  no wireless extensions.

   lono wireless extensions.
  Lsusb:
   Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
   Bus 003 Device 002: ID 046d:c062 Logitech, Inc. M-UAS144 [LS1 Laser Mouse]
   Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
   Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
  MachineType: ASUSTEK COMPUTER INC P5W DH Deluxe
  NonfreeKernelModules: nvidia_uvm nvidia_modeset nvidia
  Package: ubuntu
  ProcFB:

  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.4.0-21-generic 
root=UUID=7c755ed6-51cc-4b75-88ac-9c75acf82749 ro
  ProcVersionSignature: Ubuntu 4.4.0-21.37-generic 4.4.6
  RelatedPackageVersions:
   linux-restricted-modules-4.4.0-21-generic N/A
   linux-backports-modules-4.4.0-21-generic  N/A
   linux-firmware1.157
  RfKill:

  Tags:  yakkety
  Uname: Linux 4.4.0-21-generic x86_64
  UpgradeStatus: No upgrade log present (probably fresh install)
  UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
  _MarkForUpload: True
  dmi.bios.date: 07/22/2010
  dmi.bios.vendor: American Megatrends Inc.
  dmi.bios.version: 3002
  dmi.board.asset.tag: To Be Filled By O.E.M.
  dmi.board.name: P5W DH Deluxe
  dmi.board.vendor: ASUSTeK Computer INC.
  dmi.board.version: Rev 1.xx
  dmi.chassis.asset.tag: Asset-1234567890
  dmi.chassis.type: 3
  dmi.chassis.vendor: Chassis Manufacture
  dmi.chassis.version: Chassis Version
  dmi.modalias: 
dmi:bvnAmericanMegatrendsInc.:bvr3002:bd07/22/2010:svnASUSTEKCOMPUTERINC:pnP5WDHDeluxe:pvrSystemVersion:rvnASUSTeKComputerINC.:rnP5WDHDeluxe:rvrRev1.xx:cvnChassisManufacture:ct3:cvrChassisVersion:
  dmi.product.name: P5W DH Deluxe
  dmi.product.version: System Version
  dmi.sys.vendor: ASUSTEK COMPUTER INC

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/dkms/+bug/1574982/+subscriptions

-- 
Mailing list: https://launchpad.net/~kernel-packages
Post to : kernel-packages@lists.launchpad.net
Unsubscribe : 

[Kernel-packages] [Bug 1574982] Re: Cannot use CONFIG_CC_STACKPROTECTOR_STRONG: -fstack-protector-strong not supported by compiler

2016-10-17 Thread Nick Desaulniers
The patch in comment #39 or the env var in comment #38 both work for me.
Thank you!

-- 
You received this bug notification because you are a member of Kernel
Packages, which is subscribed to dkms in Ubuntu.
https://bugs.launchpad.net/bugs/1574982

Title:
  Cannot use CONFIG_CC_STACKPROTECTOR_STRONG: -fstack-protector-strong
  not supported by compiler

Status in dkms package in Ubuntu:
  Invalid
Status in gcc-defaults package in Ubuntu:
  Invalid
Status in linux package in Ubuntu:
  Fix Released
Status in dkms source package in Xenial:
  Invalid
Status in linux source package in Xenial:
  Fix Released

Bug description:
  Installing the latest 4.4.0-22 kernel ends with that error logged into 
dkmsbuildlog
  (only affect yakkety kernel; 4.4.0-22 kernel installation on xenial is fine)

  https://launchpadlibrarian.net/256055415/DKMSBuildLog.txt

  make "CC=cc"  KBUILD_VERBOSE= -C /lib/modules/4.4.0-22-generic/build 
M=/var/lib/dkms/nvidia-361/361.42/build ARCH=x86_64 
NV_KERNEL_SOURCES=/lib/modules/4.4.0-22-generic/build 
NV_KERNEL_OUTPUT=/lib/modules/4.4.0-22-generic/build NV_KERNEL_MODULES="nvidia 
nvidia-uvm nvidia-modeset" INSTALL_MOD_DIR=kernel/drivers/video modules
  make[1]: Entering directory '/usr/src/linux-headers-4.4.0-22-generic'
  arch/x86/Makefile:133: stack-protector enabled but compiler support broken
  Makefile:670: Cannot use CONFIG_CC_STACKPROTECTOR_STRONG: 
-fstack-protector-strong not supported by compiler

  the latest error logged is:

  /var/lib/dkms/nvidia-361/361.42/build/nvidia/nv-frontend.c:1:0: error:
  code model kernel does not support PIC mode

  Looks like it is related to the latest changes updates: gcc-6/gcc-5 
5.3.1-16ubuntu2 (some packages built with gcc-6; gcc-5 disabled for the 
packages built with gcc-6)
  Maybe some alternatives has not been updated to take care of these changes, 
as asked some time ago:
  http://askubuntu.com/questions/26498/choose-gcc-and-g-version

  This has been firstly reported against a nvidia crash:
  
https://bugs.launchpad.net/ubuntu/+source/nvidia-graphics-drivers-361/+bug/1574838

  ProblemType: Bug
  DistroRelease: Ubuntu 16.10
  Package: gcc 4:5.3.1-1ubuntu1
  ProcVersionSignature: Ubuntu 4.4.0-21.37-generic 4.4.6
  Uname: Linux 4.4.0-21-generic x86_64
  NonfreeKernelModules: nvidia_uvm nvidia_modeset nvidia
  ApportVersion: 2.20.1-0ubuntu2
  Architecture: amd64
  CurrentDesktop: GNOME
  Date: Tue Apr 26 08:41:32 2016
  SourcePackage: gcc-defaults
  UpgradeStatus: No upgrade log present (probably fresh install)
  ---
  ApportVersion: 2.20.1-0ubuntu2
  Architecture: amd64
  AudioDevicesInUse:
   USERPID ACCESS COMMAND
   /dev/snd/controlC1:  oem2014 F pulseaudio
   /dev/snd/pcmC0D0p:   oem2014 F...m pulseaudio
   /dev/snd/controlC0:  oem2014 F pulseaudio
  CurrentDesktop: GNOME
  DistroRelease: Ubuntu 16.10
  HibernationDevice: RESUME=UUID=0a9ca7f0-6eeb-4b21-b70f-670fa600de16
  IwConfig:
   eth0  no wireless extensions.

   eth1  no wireless extensions.

   lono wireless extensions.
  Lsusb:
   Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
   Bus 003 Device 002: ID 046d:c062 Logitech, Inc. M-UAS144 [LS1 Laser Mouse]
   Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
   Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
  MachineType: ASUSTEK COMPUTER INC P5W DH Deluxe
  NonfreeKernelModules: nvidia_uvm nvidia_modeset nvidia
  Package: ubuntu
  ProcFB:

  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.4.0-21-generic 
root=UUID=7c755ed6-51cc-4b75-88ac-9c75acf82749 ro
  ProcVersionSignature: Ubuntu 4.4.0-21.37-generic 4.4.6
  RelatedPackageVersions:
   linux-restricted-modules-4.4.0-21-generic N/A
   linux-backports-modules-4.4.0-21-generic  N/A
   linux-firmware1.157
  RfKill:

  Tags:  yakkety
  Uname: Linux 4.4.0-21-generic x86_64
  UpgradeStatus: No upgrade log present (probably fresh install)
  UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
  _MarkForUpload: True
  dmi.bios.date: 07/22/2010
  dmi.bios.vendor: American Megatrends Inc.
  dmi.bios.version: 3002
  dmi.board.asset.tag: To Be Filled By O.E.M.
  dmi.board.name: P5W DH Deluxe
  dmi.board.vendor: ASUSTeK Computer INC.
  dmi.board.version: Rev 1.xx
  dmi.chassis.asset.tag: Asset-1234567890
  dmi.chassis.type: 3
  dmi.chassis.vendor: Chassis Manufacture
  dmi.chassis.version: Chassis Version
  dmi.modalias: 
dmi:bvnAmericanMegatrendsInc.:bvr3002:bd07/22/2010:svnASUSTEKCOMPUTERINC:pnP5WDHDeluxe:pvrSystemVersion:rvnASUSTeKComputerINC.:rnP5WDHDeluxe:rvrRev1.xx:cvnChassisManufacture:ct3:cvrChassisVersion:
  dmi.product.name: P5W DH Deluxe
  dmi.product.version: System Version
  dmi.sys.vendor: ASUSTEK COMPUTER INC

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/dkms/+bug/1574982/+subscriptions

-- 
Mailing list: https://launchpad.net/~kernel-packages
Post to : kernel-packages@lists.launchpad.net

[Kernel-packages] [Bug 1574982] Re: Cannot use CONFIG_CC_STACKPROTECTOR_STRONG: -fstack-protector-strong not supported by compiler

2016-10-17 Thread LocutusOfBorg
>this is not a gcc bug. this is an ubuntu management specific arrogance
(and perhaps some cash from redmond with love) - of course it is
completely wrong to patch the kernel makefile because they decided to
ship a gcc unable to build the kernel itself (with wrong
defaults/specs). but like they said repeatedly, they are not a
democracy. also just like linus said repeatedly, fuck unubuntu!

ok thanks for you really nice and well proven point.

AFAICT also Fedora and other major linux distros are starting enabling pie by 
default, and probably more will come.
https://fedoraproject.org/wiki/Changes/Modernise_GCC_Flags

Unfortunately I don't want to answer why you are wrong, because I don't
want to feed the troll, and you didn't say anything worth an answer in
your post.

So, the answer will be generic to other people (who probably have more clues 
than you on the reasons).
pie is a security flag that is really important for an OS. Unfortunately asking 
maintainers to enable it resulted in not many adaptions, and many critical 
pieces of software without such hardening flag enabled.
Enabling by default in gcc sounded a better idea, and the side effect has been 
that virtualbox/kernel had to disable it manually to still build.

For this reason -f-no-pie has been created, and it should work with no issues.
And this bug/flag has been injected and the kernel is now fixed, so please move 
on.
thanks

-- 
You received this bug notification because you are a member of Kernel
Packages, which is subscribed to dkms in Ubuntu.
https://bugs.launchpad.net/bugs/1574982

Title:
  Cannot use CONFIG_CC_STACKPROTECTOR_STRONG: -fstack-protector-strong
  not supported by compiler

Status in dkms package in Ubuntu:
  Invalid
Status in gcc-defaults package in Ubuntu:
  Invalid
Status in linux package in Ubuntu:
  Fix Released
Status in dkms source package in Xenial:
  Invalid
Status in linux source package in Xenial:
  Fix Released

Bug description:
  Installing the latest 4.4.0-22 kernel ends with that error logged into 
dkmsbuildlog
  (only affect yakkety kernel; 4.4.0-22 kernel installation on xenial is fine)

  https://launchpadlibrarian.net/256055415/DKMSBuildLog.txt

  make "CC=cc"  KBUILD_VERBOSE= -C /lib/modules/4.4.0-22-generic/build 
M=/var/lib/dkms/nvidia-361/361.42/build ARCH=x86_64 
NV_KERNEL_SOURCES=/lib/modules/4.4.0-22-generic/build 
NV_KERNEL_OUTPUT=/lib/modules/4.4.0-22-generic/build NV_KERNEL_MODULES="nvidia 
nvidia-uvm nvidia-modeset" INSTALL_MOD_DIR=kernel/drivers/video modules
  make[1]: Entering directory '/usr/src/linux-headers-4.4.0-22-generic'
  arch/x86/Makefile:133: stack-protector enabled but compiler support broken
  Makefile:670: Cannot use CONFIG_CC_STACKPROTECTOR_STRONG: 
-fstack-protector-strong not supported by compiler

  the latest error logged is:

  /var/lib/dkms/nvidia-361/361.42/build/nvidia/nv-frontend.c:1:0: error:
  code model kernel does not support PIC mode

  Looks like it is related to the latest changes updates: gcc-6/gcc-5 
5.3.1-16ubuntu2 (some packages built with gcc-6; gcc-5 disabled for the 
packages built with gcc-6)
  Maybe some alternatives has not been updated to take care of these changes, 
as asked some time ago:
  http://askubuntu.com/questions/26498/choose-gcc-and-g-version

  This has been firstly reported against a nvidia crash:
  
https://bugs.launchpad.net/ubuntu/+source/nvidia-graphics-drivers-361/+bug/1574838

  ProblemType: Bug
  DistroRelease: Ubuntu 16.10
  Package: gcc 4:5.3.1-1ubuntu1
  ProcVersionSignature: Ubuntu 4.4.0-21.37-generic 4.4.6
  Uname: Linux 4.4.0-21-generic x86_64
  NonfreeKernelModules: nvidia_uvm nvidia_modeset nvidia
  ApportVersion: 2.20.1-0ubuntu2
  Architecture: amd64
  CurrentDesktop: GNOME
  Date: Tue Apr 26 08:41:32 2016
  SourcePackage: gcc-defaults
  UpgradeStatus: No upgrade log present (probably fresh install)
  ---
  ApportVersion: 2.20.1-0ubuntu2
  Architecture: amd64
  AudioDevicesInUse:
   USERPID ACCESS COMMAND
   /dev/snd/controlC1:  oem2014 F pulseaudio
   /dev/snd/pcmC0D0p:   oem2014 F...m pulseaudio
   /dev/snd/controlC0:  oem2014 F pulseaudio
  CurrentDesktop: GNOME
  DistroRelease: Ubuntu 16.10
  HibernationDevice: RESUME=UUID=0a9ca7f0-6eeb-4b21-b70f-670fa600de16
  IwConfig:
   eth0  no wireless extensions.

   eth1  no wireless extensions.

   lono wireless extensions.
  Lsusb:
   Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
   Bus 003 Device 002: ID 046d:c062 Logitech, Inc. M-UAS144 [LS1 Laser Mouse]
   Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
   Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
  MachineType: ASUSTEK COMPUTER INC P5W DH Deluxe
  NonfreeKernelModules: nvidia_uvm nvidia_modeset nvidia
  Package: ubuntu
  ProcFB:

  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.4.0-21-generic 
root=UUID=7c755ed6-51cc-4b75-88ac-9c75acf82749 ro
  ProcVersionSignature: Ubuntu 4.4.0-21.37-generic 4.4.6
  

[Kernel-packages] [Bug 1574982] Re: Cannot use CONFIG_CC_STACKPROTECTOR_STRONG: -fstack-protector-strong not supported by compiler

2016-10-16 Thread Dan Marinescu
this is not a gcc bug. this is an ubuntu management specific arrogance
(and perhaps some cash from redmond with love) - of course it is
completely wrong to patch the kernel makefile because they decided to
ship a gcc unable to build the kernel itself (with wrong
defaults/specs). but like they said repeatedly, they are not a
democracy. also just like linus said repeatedly, fuck unubuntu!


>Why isn't this a bug in gcc 6? It doesn't seem right that we have to patch the 
>kernel makefile to get it to build.

-- 
You received this bug notification because you are a member of Kernel
Packages, which is subscribed to dkms in Ubuntu.
https://bugs.launchpad.net/bugs/1574982

Title:
  Cannot use CONFIG_CC_STACKPROTECTOR_STRONG: -fstack-protector-strong
  not supported by compiler

Status in dkms package in Ubuntu:
  Invalid
Status in gcc-defaults package in Ubuntu:
  Invalid
Status in linux package in Ubuntu:
  Fix Released
Status in dkms source package in Xenial:
  Invalid
Status in linux source package in Xenial:
  Fix Released

Bug description:
  Installing the latest 4.4.0-22 kernel ends with that error logged into 
dkmsbuildlog
  (only affect yakkety kernel; 4.4.0-22 kernel installation on xenial is fine)

  https://launchpadlibrarian.net/256055415/DKMSBuildLog.txt

  make "CC=cc"  KBUILD_VERBOSE= -C /lib/modules/4.4.0-22-generic/build 
M=/var/lib/dkms/nvidia-361/361.42/build ARCH=x86_64 
NV_KERNEL_SOURCES=/lib/modules/4.4.0-22-generic/build 
NV_KERNEL_OUTPUT=/lib/modules/4.4.0-22-generic/build NV_KERNEL_MODULES="nvidia 
nvidia-uvm nvidia-modeset" INSTALL_MOD_DIR=kernel/drivers/video modules
  make[1]: Entering directory '/usr/src/linux-headers-4.4.0-22-generic'
  arch/x86/Makefile:133: stack-protector enabled but compiler support broken
  Makefile:670: Cannot use CONFIG_CC_STACKPROTECTOR_STRONG: 
-fstack-protector-strong not supported by compiler

  the latest error logged is:

  /var/lib/dkms/nvidia-361/361.42/build/nvidia/nv-frontend.c:1:0: error:
  code model kernel does not support PIC mode

  Looks like it is related to the latest changes updates: gcc-6/gcc-5 
5.3.1-16ubuntu2 (some packages built with gcc-6; gcc-5 disabled for the 
packages built with gcc-6)
  Maybe some alternatives has not been updated to take care of these changes, 
as asked some time ago:
  http://askubuntu.com/questions/26498/choose-gcc-and-g-version

  This has been firstly reported against a nvidia crash:
  
https://bugs.launchpad.net/ubuntu/+source/nvidia-graphics-drivers-361/+bug/1574838

  ProblemType: Bug
  DistroRelease: Ubuntu 16.10
  Package: gcc 4:5.3.1-1ubuntu1
  ProcVersionSignature: Ubuntu 4.4.0-21.37-generic 4.4.6
  Uname: Linux 4.4.0-21-generic x86_64
  NonfreeKernelModules: nvidia_uvm nvidia_modeset nvidia
  ApportVersion: 2.20.1-0ubuntu2
  Architecture: amd64
  CurrentDesktop: GNOME
  Date: Tue Apr 26 08:41:32 2016
  SourcePackage: gcc-defaults
  UpgradeStatus: No upgrade log present (probably fresh install)
  ---
  ApportVersion: 2.20.1-0ubuntu2
  Architecture: amd64
  AudioDevicesInUse:
   USERPID ACCESS COMMAND
   /dev/snd/controlC1:  oem2014 F pulseaudio
   /dev/snd/pcmC0D0p:   oem2014 F...m pulseaudio
   /dev/snd/controlC0:  oem2014 F pulseaudio
  CurrentDesktop: GNOME
  DistroRelease: Ubuntu 16.10
  HibernationDevice: RESUME=UUID=0a9ca7f0-6eeb-4b21-b70f-670fa600de16
  IwConfig:
   eth0  no wireless extensions.

   eth1  no wireless extensions.

   lono wireless extensions.
  Lsusb:
   Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
   Bus 003 Device 002: ID 046d:c062 Logitech, Inc. M-UAS144 [LS1 Laser Mouse]
   Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
   Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
  MachineType: ASUSTEK COMPUTER INC P5W DH Deluxe
  NonfreeKernelModules: nvidia_uvm nvidia_modeset nvidia
  Package: ubuntu
  ProcFB:

  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.4.0-21-generic 
root=UUID=7c755ed6-51cc-4b75-88ac-9c75acf82749 ro
  ProcVersionSignature: Ubuntu 4.4.0-21.37-generic 4.4.6
  RelatedPackageVersions:
   linux-restricted-modules-4.4.0-21-generic N/A
   linux-backports-modules-4.4.0-21-generic  N/A
   linux-firmware1.157
  RfKill:

  Tags:  yakkety
  Uname: Linux 4.4.0-21-generic x86_64
  UpgradeStatus: No upgrade log present (probably fresh install)
  UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
  _MarkForUpload: True
  dmi.bios.date: 07/22/2010
  dmi.bios.vendor: American Megatrends Inc.
  dmi.bios.version: 3002
  dmi.board.asset.tag: To Be Filled By O.E.M.
  dmi.board.name: P5W DH Deluxe
  dmi.board.vendor: ASUSTeK Computer INC.
  dmi.board.version: Rev 1.xx
  dmi.chassis.asset.tag: Asset-1234567890
  dmi.chassis.type: 3
  dmi.chassis.vendor: Chassis Manufacture
  dmi.chassis.version: Chassis Version
  dmi.modalias: 

[Kernel-packages] [Bug 1574982] Re: Cannot use CONFIG_CC_STACKPROTECTOR_STRONG: -fstack-protector-strong not supported by compiler

2016-10-16 Thread Nazar Mokrynskyi
cerebellum-ukr, is there any place to track for upstreaming necessary
patches? Quite boring to do this every time I want to build kernel.

-- 
You received this bug notification because you are a member of Kernel
Packages, which is subscribed to dkms in Ubuntu.
https://bugs.launchpad.net/bugs/1574982

Title:
  Cannot use CONFIG_CC_STACKPROTECTOR_STRONG: -fstack-protector-strong
  not supported by compiler

Status in dkms package in Ubuntu:
  Invalid
Status in gcc-defaults package in Ubuntu:
  Invalid
Status in linux package in Ubuntu:
  Fix Released
Status in dkms source package in Xenial:
  Invalid
Status in linux source package in Xenial:
  Fix Released

Bug description:
  Installing the latest 4.4.0-22 kernel ends with that error logged into 
dkmsbuildlog
  (only affect yakkety kernel; 4.4.0-22 kernel installation on xenial is fine)

  https://launchpadlibrarian.net/256055415/DKMSBuildLog.txt

  make "CC=cc"  KBUILD_VERBOSE= -C /lib/modules/4.4.0-22-generic/build 
M=/var/lib/dkms/nvidia-361/361.42/build ARCH=x86_64 
NV_KERNEL_SOURCES=/lib/modules/4.4.0-22-generic/build 
NV_KERNEL_OUTPUT=/lib/modules/4.4.0-22-generic/build NV_KERNEL_MODULES="nvidia 
nvidia-uvm nvidia-modeset" INSTALL_MOD_DIR=kernel/drivers/video modules
  make[1]: Entering directory '/usr/src/linux-headers-4.4.0-22-generic'
  arch/x86/Makefile:133: stack-protector enabled but compiler support broken
  Makefile:670: Cannot use CONFIG_CC_STACKPROTECTOR_STRONG: 
-fstack-protector-strong not supported by compiler

  the latest error logged is:

  /var/lib/dkms/nvidia-361/361.42/build/nvidia/nv-frontend.c:1:0: error:
  code model kernel does not support PIC mode

  Looks like it is related to the latest changes updates: gcc-6/gcc-5 
5.3.1-16ubuntu2 (some packages built with gcc-6; gcc-5 disabled for the 
packages built with gcc-6)
  Maybe some alternatives has not been updated to take care of these changes, 
as asked some time ago:
  http://askubuntu.com/questions/26498/choose-gcc-and-g-version

  This has been firstly reported against a nvidia crash:
  
https://bugs.launchpad.net/ubuntu/+source/nvidia-graphics-drivers-361/+bug/1574838

  ProblemType: Bug
  DistroRelease: Ubuntu 16.10
  Package: gcc 4:5.3.1-1ubuntu1
  ProcVersionSignature: Ubuntu 4.4.0-21.37-generic 4.4.6
  Uname: Linux 4.4.0-21-generic x86_64
  NonfreeKernelModules: nvidia_uvm nvidia_modeset nvidia
  ApportVersion: 2.20.1-0ubuntu2
  Architecture: amd64
  CurrentDesktop: GNOME
  Date: Tue Apr 26 08:41:32 2016
  SourcePackage: gcc-defaults
  UpgradeStatus: No upgrade log present (probably fresh install)
  ---
  ApportVersion: 2.20.1-0ubuntu2
  Architecture: amd64
  AudioDevicesInUse:
   USERPID ACCESS COMMAND
   /dev/snd/controlC1:  oem2014 F pulseaudio
   /dev/snd/pcmC0D0p:   oem2014 F...m pulseaudio
   /dev/snd/controlC0:  oem2014 F pulseaudio
  CurrentDesktop: GNOME
  DistroRelease: Ubuntu 16.10
  HibernationDevice: RESUME=UUID=0a9ca7f0-6eeb-4b21-b70f-670fa600de16
  IwConfig:
   eth0  no wireless extensions.

   eth1  no wireless extensions.

   lono wireless extensions.
  Lsusb:
   Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
   Bus 003 Device 002: ID 046d:c062 Logitech, Inc. M-UAS144 [LS1 Laser Mouse]
   Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
   Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
  MachineType: ASUSTEK COMPUTER INC P5W DH Deluxe
  NonfreeKernelModules: nvidia_uvm nvidia_modeset nvidia
  Package: ubuntu
  ProcFB:

  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.4.0-21-generic 
root=UUID=7c755ed6-51cc-4b75-88ac-9c75acf82749 ro
  ProcVersionSignature: Ubuntu 4.4.0-21.37-generic 4.4.6
  RelatedPackageVersions:
   linux-restricted-modules-4.4.0-21-generic N/A
   linux-backports-modules-4.4.0-21-generic  N/A
   linux-firmware1.157
  RfKill:

  Tags:  yakkety
  Uname: Linux 4.4.0-21-generic x86_64
  UpgradeStatus: No upgrade log present (probably fresh install)
  UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
  _MarkForUpload: True
  dmi.bios.date: 07/22/2010
  dmi.bios.vendor: American Megatrends Inc.
  dmi.bios.version: 3002
  dmi.board.asset.tag: To Be Filled By O.E.M.
  dmi.board.name: P5W DH Deluxe
  dmi.board.vendor: ASUSTeK Computer INC.
  dmi.board.version: Rev 1.xx
  dmi.chassis.asset.tag: Asset-1234567890
  dmi.chassis.type: 3
  dmi.chassis.vendor: Chassis Manufacture
  dmi.chassis.version: Chassis Version
  dmi.modalias: 
dmi:bvnAmericanMegatrendsInc.:bvr3002:bd07/22/2010:svnASUSTEKCOMPUTERINC:pnP5WDHDeluxe:pvrSystemVersion:rvnASUSTeKComputerINC.:rnP5WDHDeluxe:rvrRev1.xx:cvnChassisManufacture:ct3:cvrChassisVersion:
  dmi.product.name: P5W DH Deluxe
  dmi.product.version: System Version
  dmi.sys.vendor: ASUSTEK COMPUTER INC

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/dkms/+bug/1574982/+subscriptions

-- 
Mailing list: https://launchpad.net/~kernel-packages
Post 

[Kernel-packages] [Bug 1574982] Re: Cannot use CONFIG_CC_STACKPROTECTOR_STRONG: -fstack-protector-strong not supported by compiler

2016-09-28 Thread Rocko
Why isn't this a bug in gcc 6? It doesn't seem right that we have to
patch the kernel makefile to get it to build.

-- 
You received this bug notification because you are a member of Kernel
Packages, which is subscribed to dkms in Ubuntu.
https://bugs.launchpad.net/bugs/1574982

Title:
  Cannot use CONFIG_CC_STACKPROTECTOR_STRONG: -fstack-protector-strong
  not supported by compiler

Status in dkms package in Ubuntu:
  Invalid
Status in gcc-defaults package in Ubuntu:
  Invalid
Status in linux package in Ubuntu:
  Fix Released
Status in dkms source package in Xenial:
  Invalid
Status in linux source package in Xenial:
  Fix Released

Bug description:
  Installing the latest 4.4.0-22 kernel ends with that error logged into 
dkmsbuildlog
  (only affect yakkety kernel; 4.4.0-22 kernel installation on xenial is fine)

  https://launchpadlibrarian.net/256055415/DKMSBuildLog.txt

  make "CC=cc"  KBUILD_VERBOSE= -C /lib/modules/4.4.0-22-generic/build 
M=/var/lib/dkms/nvidia-361/361.42/build ARCH=x86_64 
NV_KERNEL_SOURCES=/lib/modules/4.4.0-22-generic/build 
NV_KERNEL_OUTPUT=/lib/modules/4.4.0-22-generic/build NV_KERNEL_MODULES="nvidia 
nvidia-uvm nvidia-modeset" INSTALL_MOD_DIR=kernel/drivers/video modules
  make[1]: Entering directory '/usr/src/linux-headers-4.4.0-22-generic'
  arch/x86/Makefile:133: stack-protector enabled but compiler support broken
  Makefile:670: Cannot use CONFIG_CC_STACKPROTECTOR_STRONG: 
-fstack-protector-strong not supported by compiler

  the latest error logged is:

  /var/lib/dkms/nvidia-361/361.42/build/nvidia/nv-frontend.c:1:0: error:
  code model kernel does not support PIC mode

  Looks like it is related to the latest changes updates: gcc-6/gcc-5 
5.3.1-16ubuntu2 (some packages built with gcc-6; gcc-5 disabled for the 
packages built with gcc-6)
  Maybe some alternatives has not been updated to take care of these changes, 
as asked some time ago:
  http://askubuntu.com/questions/26498/choose-gcc-and-g-version

  This has been firstly reported against a nvidia crash:
  
https://bugs.launchpad.net/ubuntu/+source/nvidia-graphics-drivers-361/+bug/1574838

  ProblemType: Bug
  DistroRelease: Ubuntu 16.10
  Package: gcc 4:5.3.1-1ubuntu1
  ProcVersionSignature: Ubuntu 4.4.0-21.37-generic 4.4.6
  Uname: Linux 4.4.0-21-generic x86_64
  NonfreeKernelModules: nvidia_uvm nvidia_modeset nvidia
  ApportVersion: 2.20.1-0ubuntu2
  Architecture: amd64
  CurrentDesktop: GNOME
  Date: Tue Apr 26 08:41:32 2016
  SourcePackage: gcc-defaults
  UpgradeStatus: No upgrade log present (probably fresh install)
  ---
  ApportVersion: 2.20.1-0ubuntu2
  Architecture: amd64
  AudioDevicesInUse:
   USERPID ACCESS COMMAND
   /dev/snd/controlC1:  oem2014 F pulseaudio
   /dev/snd/pcmC0D0p:   oem2014 F...m pulseaudio
   /dev/snd/controlC0:  oem2014 F pulseaudio
  CurrentDesktop: GNOME
  DistroRelease: Ubuntu 16.10
  HibernationDevice: RESUME=UUID=0a9ca7f0-6eeb-4b21-b70f-670fa600de16
  IwConfig:
   eth0  no wireless extensions.

   eth1  no wireless extensions.

   lono wireless extensions.
  Lsusb:
   Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
   Bus 003 Device 002: ID 046d:c062 Logitech, Inc. M-UAS144 [LS1 Laser Mouse]
   Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
   Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
  MachineType: ASUSTEK COMPUTER INC P5W DH Deluxe
  NonfreeKernelModules: nvidia_uvm nvidia_modeset nvidia
  Package: ubuntu
  ProcFB:

  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.4.0-21-generic 
root=UUID=7c755ed6-51cc-4b75-88ac-9c75acf82749 ro
  ProcVersionSignature: Ubuntu 4.4.0-21.37-generic 4.4.6
  RelatedPackageVersions:
   linux-restricted-modules-4.4.0-21-generic N/A
   linux-backports-modules-4.4.0-21-generic  N/A
   linux-firmware1.157
  RfKill:

  Tags:  yakkety
  Uname: Linux 4.4.0-21-generic x86_64
  UpgradeStatus: No upgrade log present (probably fresh install)
  UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
  _MarkForUpload: True
  dmi.bios.date: 07/22/2010
  dmi.bios.vendor: American Megatrends Inc.
  dmi.bios.version: 3002
  dmi.board.asset.tag: To Be Filled By O.E.M.
  dmi.board.name: P5W DH Deluxe
  dmi.board.vendor: ASUSTeK Computer INC.
  dmi.board.version: Rev 1.xx
  dmi.chassis.asset.tag: Asset-1234567890
  dmi.chassis.type: 3
  dmi.chassis.vendor: Chassis Manufacture
  dmi.chassis.version: Chassis Version
  dmi.modalias: 
dmi:bvnAmericanMegatrendsInc.:bvr3002:bd07/22/2010:svnASUSTEKCOMPUTERINC:pnP5WDHDeluxe:pvrSystemVersion:rvnASUSTeKComputerINC.:rnP5WDHDeluxe:rvrRev1.xx:cvnChassisManufacture:ct3:cvrChassisVersion:
  dmi.product.name: P5W DH Deluxe
  dmi.product.version: System Version
  dmi.sys.vendor: ASUSTEK COMPUTER INC

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/dkms/+bug/1574982/+subscriptions

-- 
Mailing list: https://launchpad.net/~kernel-packages
Post to : 

[Kernel-packages] [Bug 1574982] Re: Cannot use CONFIG_CC_STACKPROTECTOR_STRONG: -fstack-protector-strong not supported by compiler

2016-08-16 Thread Nazar Mokrynskyi
Thank you, works for me on upstream 4.8-rc2

-- 
You received this bug notification because you are a member of Kernel
Packages, which is subscribed to dkms in Ubuntu.
https://bugs.launchpad.net/bugs/1574982

Title:
  Cannot use CONFIG_CC_STACKPROTECTOR_STRONG: -fstack-protector-strong
  not supported by compiler

Status in dkms package in Ubuntu:
  Invalid
Status in gcc-defaults package in Ubuntu:
  Invalid
Status in linux package in Ubuntu:
  Fix Released
Status in dkms source package in Xenial:
  Invalid
Status in linux source package in Xenial:
  Fix Released

Bug description:
  Installing the latest 4.4.0-22 kernel ends with that error logged into 
dkmsbuildlog
  (only affect yakkety kernel; 4.4.0-22 kernel installation on xenial is fine)

  https://launchpadlibrarian.net/256055415/DKMSBuildLog.txt

  make "CC=cc"  KBUILD_VERBOSE= -C /lib/modules/4.4.0-22-generic/build 
M=/var/lib/dkms/nvidia-361/361.42/build ARCH=x86_64 
NV_KERNEL_SOURCES=/lib/modules/4.4.0-22-generic/build 
NV_KERNEL_OUTPUT=/lib/modules/4.4.0-22-generic/build NV_KERNEL_MODULES="nvidia 
nvidia-uvm nvidia-modeset" INSTALL_MOD_DIR=kernel/drivers/video modules
  make[1]: Entering directory '/usr/src/linux-headers-4.4.0-22-generic'
  arch/x86/Makefile:133: stack-protector enabled but compiler support broken
  Makefile:670: Cannot use CONFIG_CC_STACKPROTECTOR_STRONG: 
-fstack-protector-strong not supported by compiler

  the latest error logged is:

  /var/lib/dkms/nvidia-361/361.42/build/nvidia/nv-frontend.c:1:0: error:
  code model kernel does not support PIC mode

  Looks like it is related to the latest changes updates: gcc-6/gcc-5 
5.3.1-16ubuntu2 (some packages built with gcc-6; gcc-5 disabled for the 
packages built with gcc-6)
  Maybe some alternatives has not been updated to take care of these changes, 
as asked some time ago:
  http://askubuntu.com/questions/26498/choose-gcc-and-g-version

  This has been firstly reported against a nvidia crash:
  
https://bugs.launchpad.net/ubuntu/+source/nvidia-graphics-drivers-361/+bug/1574838

  ProblemType: Bug
  DistroRelease: Ubuntu 16.10
  Package: gcc 4:5.3.1-1ubuntu1
  ProcVersionSignature: Ubuntu 4.4.0-21.37-generic 4.4.6
  Uname: Linux 4.4.0-21-generic x86_64
  NonfreeKernelModules: nvidia_uvm nvidia_modeset nvidia
  ApportVersion: 2.20.1-0ubuntu2
  Architecture: amd64
  CurrentDesktop: GNOME
  Date: Tue Apr 26 08:41:32 2016
  SourcePackage: gcc-defaults
  UpgradeStatus: No upgrade log present (probably fresh install)
  ---
  ApportVersion: 2.20.1-0ubuntu2
  Architecture: amd64
  AudioDevicesInUse:
   USERPID ACCESS COMMAND
   /dev/snd/controlC1:  oem2014 F pulseaudio
   /dev/snd/pcmC0D0p:   oem2014 F...m pulseaudio
   /dev/snd/controlC0:  oem2014 F pulseaudio
  CurrentDesktop: GNOME
  DistroRelease: Ubuntu 16.10
  HibernationDevice: RESUME=UUID=0a9ca7f0-6eeb-4b21-b70f-670fa600de16
  IwConfig:
   eth0  no wireless extensions.

   eth1  no wireless extensions.

   lono wireless extensions.
  Lsusb:
   Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
   Bus 003 Device 002: ID 046d:c062 Logitech, Inc. M-UAS144 [LS1 Laser Mouse]
   Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
   Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
  MachineType: ASUSTEK COMPUTER INC P5W DH Deluxe
  NonfreeKernelModules: nvidia_uvm nvidia_modeset nvidia
  Package: ubuntu
  ProcFB:

  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.4.0-21-generic 
root=UUID=7c755ed6-51cc-4b75-88ac-9c75acf82749 ro
  ProcVersionSignature: Ubuntu 4.4.0-21.37-generic 4.4.6
  RelatedPackageVersions:
   linux-restricted-modules-4.4.0-21-generic N/A
   linux-backports-modules-4.4.0-21-generic  N/A
   linux-firmware1.157
  RfKill:

  Tags:  yakkety
  Uname: Linux 4.4.0-21-generic x86_64
  UpgradeStatus: No upgrade log present (probably fresh install)
  UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
  _MarkForUpload: True
  dmi.bios.date: 07/22/2010
  dmi.bios.vendor: American Megatrends Inc.
  dmi.bios.version: 3002
  dmi.board.asset.tag: To Be Filled By O.E.M.
  dmi.board.name: P5W DH Deluxe
  dmi.board.vendor: ASUSTeK Computer INC.
  dmi.board.version: Rev 1.xx
  dmi.chassis.asset.tag: Asset-1234567890
  dmi.chassis.type: 3
  dmi.chassis.vendor: Chassis Manufacture
  dmi.chassis.version: Chassis Version
  dmi.modalias: 
dmi:bvnAmericanMegatrendsInc.:bvr3002:bd07/22/2010:svnASUSTEKCOMPUTERINC:pnP5WDHDeluxe:pvrSystemVersion:rvnASUSTeKComputerINC.:rnP5WDHDeluxe:rvrRev1.xx:cvnChassisManufacture:ct3:cvrChassisVersion:
  dmi.product.name: P5W DH Deluxe
  dmi.product.version: System Version
  dmi.sys.vendor: ASUSTEK COMPUTER INC

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/dkms/+bug/1574982/+subscriptions

-- 
Mailing list: https://launchpad.net/~kernel-packages
Post to : kernel-packages@lists.launchpad.net
Unsubscribe : 

[Kernel-packages] [Bug 1574982] Re: Cannot use CONFIG_CC_STACKPROTECTOR_STRONG: -fstack-protector-strong not supported by compiler

2016-08-16 Thread iLogin
Nazar Mokrynskyi
http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.8-rc2/
this patch what you need
http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.8-rc2/0002-UBUNTU-SAUCE-no-up-disable-pie-when-gcc-has-it-enabl.patch

-- 
You received this bug notification because you are a member of Kernel
Packages, which is subscribed to dkms in Ubuntu.
https://bugs.launchpad.net/bugs/1574982

Title:
  Cannot use CONFIG_CC_STACKPROTECTOR_STRONG: -fstack-protector-strong
  not supported by compiler

Status in dkms package in Ubuntu:
  Invalid
Status in gcc-defaults package in Ubuntu:
  Invalid
Status in linux package in Ubuntu:
  Fix Released
Status in dkms source package in Xenial:
  Invalid
Status in linux source package in Xenial:
  Fix Released

Bug description:
  Installing the latest 4.4.0-22 kernel ends with that error logged into 
dkmsbuildlog
  (only affect yakkety kernel; 4.4.0-22 kernel installation on xenial is fine)

  https://launchpadlibrarian.net/256055415/DKMSBuildLog.txt

  make "CC=cc"  KBUILD_VERBOSE= -C /lib/modules/4.4.0-22-generic/build 
M=/var/lib/dkms/nvidia-361/361.42/build ARCH=x86_64 
NV_KERNEL_SOURCES=/lib/modules/4.4.0-22-generic/build 
NV_KERNEL_OUTPUT=/lib/modules/4.4.0-22-generic/build NV_KERNEL_MODULES="nvidia 
nvidia-uvm nvidia-modeset" INSTALL_MOD_DIR=kernel/drivers/video modules
  make[1]: Entering directory '/usr/src/linux-headers-4.4.0-22-generic'
  arch/x86/Makefile:133: stack-protector enabled but compiler support broken
  Makefile:670: Cannot use CONFIG_CC_STACKPROTECTOR_STRONG: 
-fstack-protector-strong not supported by compiler

  the latest error logged is:

  /var/lib/dkms/nvidia-361/361.42/build/nvidia/nv-frontend.c:1:0: error:
  code model kernel does not support PIC mode

  Looks like it is related to the latest changes updates: gcc-6/gcc-5 
5.3.1-16ubuntu2 (some packages built with gcc-6; gcc-5 disabled for the 
packages built with gcc-6)
  Maybe some alternatives has not been updated to take care of these changes, 
as asked some time ago:
  http://askubuntu.com/questions/26498/choose-gcc-and-g-version

  This has been firstly reported against a nvidia crash:
  
https://bugs.launchpad.net/ubuntu/+source/nvidia-graphics-drivers-361/+bug/1574838

  ProblemType: Bug
  DistroRelease: Ubuntu 16.10
  Package: gcc 4:5.3.1-1ubuntu1
  ProcVersionSignature: Ubuntu 4.4.0-21.37-generic 4.4.6
  Uname: Linux 4.4.0-21-generic x86_64
  NonfreeKernelModules: nvidia_uvm nvidia_modeset nvidia
  ApportVersion: 2.20.1-0ubuntu2
  Architecture: amd64
  CurrentDesktop: GNOME
  Date: Tue Apr 26 08:41:32 2016
  SourcePackage: gcc-defaults
  UpgradeStatus: No upgrade log present (probably fresh install)
  ---
  ApportVersion: 2.20.1-0ubuntu2
  Architecture: amd64
  AudioDevicesInUse:
   USERPID ACCESS COMMAND
   /dev/snd/controlC1:  oem2014 F pulseaudio
   /dev/snd/pcmC0D0p:   oem2014 F...m pulseaudio
   /dev/snd/controlC0:  oem2014 F pulseaudio
  CurrentDesktop: GNOME
  DistroRelease: Ubuntu 16.10
  HibernationDevice: RESUME=UUID=0a9ca7f0-6eeb-4b21-b70f-670fa600de16
  IwConfig:
   eth0  no wireless extensions.

   eth1  no wireless extensions.

   lono wireless extensions.
  Lsusb:
   Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
   Bus 003 Device 002: ID 046d:c062 Logitech, Inc. M-UAS144 [LS1 Laser Mouse]
   Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
   Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
  MachineType: ASUSTEK COMPUTER INC P5W DH Deluxe
  NonfreeKernelModules: nvidia_uvm nvidia_modeset nvidia
  Package: ubuntu
  ProcFB:

  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.4.0-21-generic 
root=UUID=7c755ed6-51cc-4b75-88ac-9c75acf82749 ro
  ProcVersionSignature: Ubuntu 4.4.0-21.37-generic 4.4.6
  RelatedPackageVersions:
   linux-restricted-modules-4.4.0-21-generic N/A
   linux-backports-modules-4.4.0-21-generic  N/A
   linux-firmware1.157
  RfKill:

  Tags:  yakkety
  Uname: Linux 4.4.0-21-generic x86_64
  UpgradeStatus: No upgrade log present (probably fresh install)
  UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
  _MarkForUpload: True
  dmi.bios.date: 07/22/2010
  dmi.bios.vendor: American Megatrends Inc.
  dmi.bios.version: 3002
  dmi.board.asset.tag: To Be Filled By O.E.M.
  dmi.board.name: P5W DH Deluxe
  dmi.board.vendor: ASUSTeK Computer INC.
  dmi.board.version: Rev 1.xx
  dmi.chassis.asset.tag: Asset-1234567890
  dmi.chassis.type: 3
  dmi.chassis.vendor: Chassis Manufacture
  dmi.chassis.version: Chassis Version
  dmi.modalias: 
dmi:bvnAmericanMegatrendsInc.:bvr3002:bd07/22/2010:svnASUSTEKCOMPUTERINC:pnP5WDHDeluxe:pvrSystemVersion:rvnASUSTeKComputerINC.:rnP5WDHDeluxe:rvrRev1.xx:cvnChassisManufacture:ct3:cvrChassisVersion:
  dmi.product.name: P5W DH Deluxe
  dmi.product.version: System Version
  dmi.sys.vendor: ASUSTEK COMPUTER INC

To manage notifications about this bug go to:

[Kernel-packages] [Bug 1574982] Re: Cannot use CONFIG_CC_STACKPROTECTOR_STRONG: -fstack-protector-strong not supported by compiler

2016-08-16 Thread Nazar Mokrynskyi
I'm having this issue again after upgrade to GCC 6 from GCC 5 recently. I've 
being able to compile custom kernel with just `KCFLAGS="-fno-pie"`, now it 
fails with error mentioned in this bug report.
Any ideas why? Am I alone here?

-- 
You received this bug notification because you are a member of Kernel
Packages, which is subscribed to dkms in Ubuntu.
https://bugs.launchpad.net/bugs/1574982

Title:
  Cannot use CONFIG_CC_STACKPROTECTOR_STRONG: -fstack-protector-strong
  not supported by compiler

Status in dkms package in Ubuntu:
  Invalid
Status in gcc-defaults package in Ubuntu:
  Invalid
Status in linux package in Ubuntu:
  Fix Released
Status in dkms source package in Xenial:
  Invalid
Status in linux source package in Xenial:
  Fix Released

Bug description:
  Installing the latest 4.4.0-22 kernel ends with that error logged into 
dkmsbuildlog
  (only affect yakkety kernel; 4.4.0-22 kernel installation on xenial is fine)

  https://launchpadlibrarian.net/256055415/DKMSBuildLog.txt

  make "CC=cc"  KBUILD_VERBOSE= -C /lib/modules/4.4.0-22-generic/build 
M=/var/lib/dkms/nvidia-361/361.42/build ARCH=x86_64 
NV_KERNEL_SOURCES=/lib/modules/4.4.0-22-generic/build 
NV_KERNEL_OUTPUT=/lib/modules/4.4.0-22-generic/build NV_KERNEL_MODULES="nvidia 
nvidia-uvm nvidia-modeset" INSTALL_MOD_DIR=kernel/drivers/video modules
  make[1]: Entering directory '/usr/src/linux-headers-4.4.0-22-generic'
  arch/x86/Makefile:133: stack-protector enabled but compiler support broken
  Makefile:670: Cannot use CONFIG_CC_STACKPROTECTOR_STRONG: 
-fstack-protector-strong not supported by compiler

  the latest error logged is:

  /var/lib/dkms/nvidia-361/361.42/build/nvidia/nv-frontend.c:1:0: error:
  code model kernel does not support PIC mode

  Looks like it is related to the latest changes updates: gcc-6/gcc-5 
5.3.1-16ubuntu2 (some packages built with gcc-6; gcc-5 disabled for the 
packages built with gcc-6)
  Maybe some alternatives has not been updated to take care of these changes, 
as asked some time ago:
  http://askubuntu.com/questions/26498/choose-gcc-and-g-version

  This has been firstly reported against a nvidia crash:
  
https://bugs.launchpad.net/ubuntu/+source/nvidia-graphics-drivers-361/+bug/1574838

  ProblemType: Bug
  DistroRelease: Ubuntu 16.10
  Package: gcc 4:5.3.1-1ubuntu1
  ProcVersionSignature: Ubuntu 4.4.0-21.37-generic 4.4.6
  Uname: Linux 4.4.0-21-generic x86_64
  NonfreeKernelModules: nvidia_uvm nvidia_modeset nvidia
  ApportVersion: 2.20.1-0ubuntu2
  Architecture: amd64
  CurrentDesktop: GNOME
  Date: Tue Apr 26 08:41:32 2016
  SourcePackage: gcc-defaults
  UpgradeStatus: No upgrade log present (probably fresh install)
  ---
  ApportVersion: 2.20.1-0ubuntu2
  Architecture: amd64
  AudioDevicesInUse:
   USERPID ACCESS COMMAND
   /dev/snd/controlC1:  oem2014 F pulseaudio
   /dev/snd/pcmC0D0p:   oem2014 F...m pulseaudio
   /dev/snd/controlC0:  oem2014 F pulseaudio
  CurrentDesktop: GNOME
  DistroRelease: Ubuntu 16.10
  HibernationDevice: RESUME=UUID=0a9ca7f0-6eeb-4b21-b70f-670fa600de16
  IwConfig:
   eth0  no wireless extensions.

   eth1  no wireless extensions.

   lono wireless extensions.
  Lsusb:
   Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
   Bus 003 Device 002: ID 046d:c062 Logitech, Inc. M-UAS144 [LS1 Laser Mouse]
   Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
   Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
  MachineType: ASUSTEK COMPUTER INC P5W DH Deluxe
  NonfreeKernelModules: nvidia_uvm nvidia_modeset nvidia
  Package: ubuntu
  ProcFB:

  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.4.0-21-generic 
root=UUID=7c755ed6-51cc-4b75-88ac-9c75acf82749 ro
  ProcVersionSignature: Ubuntu 4.4.0-21.37-generic 4.4.6
  RelatedPackageVersions:
   linux-restricted-modules-4.4.0-21-generic N/A
   linux-backports-modules-4.4.0-21-generic  N/A
   linux-firmware1.157
  RfKill:

  Tags:  yakkety
  Uname: Linux 4.4.0-21-generic x86_64
  UpgradeStatus: No upgrade log present (probably fresh install)
  UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
  _MarkForUpload: True
  dmi.bios.date: 07/22/2010
  dmi.bios.vendor: American Megatrends Inc.
  dmi.bios.version: 3002
  dmi.board.asset.tag: To Be Filled By O.E.M.
  dmi.board.name: P5W DH Deluxe
  dmi.board.vendor: ASUSTeK Computer INC.
  dmi.board.version: Rev 1.xx
  dmi.chassis.asset.tag: Asset-1234567890
  dmi.chassis.type: 3
  dmi.chassis.vendor: Chassis Manufacture
  dmi.chassis.version: Chassis Version
  dmi.modalias: 
dmi:bvnAmericanMegatrendsInc.:bvr3002:bd07/22/2010:svnASUSTEKCOMPUTERINC:pnP5WDHDeluxe:pvrSystemVersion:rvnASUSTeKComputerINC.:rnP5WDHDeluxe:rvrRev1.xx:cvnChassisManufacture:ct3:cvrChassisVersion:
  dmi.product.name: P5W DH Deluxe
  dmi.product.version: System Version
  dmi.sys.vendor: ASUSTEK COMPUTER INC

To manage notifications about this bug go to:

[Kernel-packages] [Bug 1574982] Re: Cannot use CONFIG_CC_STACKPROTECTOR_STRONG: -fstack-protector-strong not supported by compiler

2016-07-14 Thread InfleXion Point
I've come across this bug on linux 4.4.0-28-generic on Ubuntu 16.04 when
trying to install a network card called Netis AD1103 with Realtek 8168.

-- 
You received this bug notification because you are a member of Kernel
Packages, which is subscribed to dkms in Ubuntu.
https://bugs.launchpad.net/bugs/1574982

Title:
  Cannot use CONFIG_CC_STACKPROTECTOR_STRONG: -fstack-protector-strong
  not supported by compiler

Status in dkms package in Ubuntu:
  Invalid
Status in gcc-defaults package in Ubuntu:
  Invalid
Status in linux package in Ubuntu:
  Fix Released
Status in dkms source package in Xenial:
  Invalid
Status in linux source package in Xenial:
  Fix Released

Bug description:
  Installing the latest 4.4.0-22 kernel ends with that error logged into 
dkmsbuildlog
  (only affect yakkety kernel; 4.4.0-22 kernel installation on xenial is fine)

  https://launchpadlibrarian.net/256055415/DKMSBuildLog.txt

  make "CC=cc"  KBUILD_VERBOSE= -C /lib/modules/4.4.0-22-generic/build 
M=/var/lib/dkms/nvidia-361/361.42/build ARCH=x86_64 
NV_KERNEL_SOURCES=/lib/modules/4.4.0-22-generic/build 
NV_KERNEL_OUTPUT=/lib/modules/4.4.0-22-generic/build NV_KERNEL_MODULES="nvidia 
nvidia-uvm nvidia-modeset" INSTALL_MOD_DIR=kernel/drivers/video modules
  make[1]: Entering directory '/usr/src/linux-headers-4.4.0-22-generic'
  arch/x86/Makefile:133: stack-protector enabled but compiler support broken
  Makefile:670: Cannot use CONFIG_CC_STACKPROTECTOR_STRONG: 
-fstack-protector-strong not supported by compiler

  the latest error logged is:

  /var/lib/dkms/nvidia-361/361.42/build/nvidia/nv-frontend.c:1:0: error:
  code model kernel does not support PIC mode

  Looks like it is related to the latest changes updates: gcc-6/gcc-5 
5.3.1-16ubuntu2 (some packages built with gcc-6; gcc-5 disabled for the 
packages built with gcc-6)
  Maybe some alternatives has not been updated to take care of these changes, 
as asked some time ago:
  http://askubuntu.com/questions/26498/choose-gcc-and-g-version

  This has been firstly reported against a nvidia crash:
  
https://bugs.launchpad.net/ubuntu/+source/nvidia-graphics-drivers-361/+bug/1574838

  ProblemType: Bug
  DistroRelease: Ubuntu 16.10
  Package: gcc 4:5.3.1-1ubuntu1
  ProcVersionSignature: Ubuntu 4.4.0-21.37-generic 4.4.6
  Uname: Linux 4.4.0-21-generic x86_64
  NonfreeKernelModules: nvidia_uvm nvidia_modeset nvidia
  ApportVersion: 2.20.1-0ubuntu2
  Architecture: amd64
  CurrentDesktop: GNOME
  Date: Tue Apr 26 08:41:32 2016
  SourcePackage: gcc-defaults
  UpgradeStatus: No upgrade log present (probably fresh install)
  ---
  ApportVersion: 2.20.1-0ubuntu2
  Architecture: amd64
  AudioDevicesInUse:
   USERPID ACCESS COMMAND
   /dev/snd/controlC1:  oem2014 F pulseaudio
   /dev/snd/pcmC0D0p:   oem2014 F...m pulseaudio
   /dev/snd/controlC0:  oem2014 F pulseaudio
  CurrentDesktop: GNOME
  DistroRelease: Ubuntu 16.10
  HibernationDevice: RESUME=UUID=0a9ca7f0-6eeb-4b21-b70f-670fa600de16
  IwConfig:
   eth0  no wireless extensions.

   eth1  no wireless extensions.

   lono wireless extensions.
  Lsusb:
   Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
   Bus 003 Device 002: ID 046d:c062 Logitech, Inc. M-UAS144 [LS1 Laser Mouse]
   Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
   Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
  MachineType: ASUSTEK COMPUTER INC P5W DH Deluxe
  NonfreeKernelModules: nvidia_uvm nvidia_modeset nvidia
  Package: ubuntu
  ProcFB:

  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.4.0-21-generic 
root=UUID=7c755ed6-51cc-4b75-88ac-9c75acf82749 ro
  ProcVersionSignature: Ubuntu 4.4.0-21.37-generic 4.4.6
  RelatedPackageVersions:
   linux-restricted-modules-4.4.0-21-generic N/A
   linux-backports-modules-4.4.0-21-generic  N/A
   linux-firmware1.157
  RfKill:

  Tags:  yakkety
  Uname: Linux 4.4.0-21-generic x86_64
  UpgradeStatus: No upgrade log present (probably fresh install)
  UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
  _MarkForUpload: True
  dmi.bios.date: 07/22/2010
  dmi.bios.vendor: American Megatrends Inc.
  dmi.bios.version: 3002
  dmi.board.asset.tag: To Be Filled By O.E.M.
  dmi.board.name: P5W DH Deluxe
  dmi.board.vendor: ASUSTeK Computer INC.
  dmi.board.version: Rev 1.xx
  dmi.chassis.asset.tag: Asset-1234567890
  dmi.chassis.type: 3
  dmi.chassis.vendor: Chassis Manufacture
  dmi.chassis.version: Chassis Version
  dmi.modalias: 
dmi:bvnAmericanMegatrendsInc.:bvr3002:bd07/22/2010:svnASUSTEKCOMPUTERINC:pnP5WDHDeluxe:pvrSystemVersion:rvnASUSTeKComputerINC.:rnP5WDHDeluxe:rvrRev1.xx:cvnChassisManufacture:ct3:cvrChassisVersion:
  dmi.product.name: P5W DH Deluxe
  dmi.product.version: System Version
  dmi.sys.vendor: ASUSTEK COMPUTER INC

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/dkms/+bug/1574982/+subscriptions

-- 
Mailing list: 

[Kernel-packages] [Bug 1574982] Re: Cannot use CONFIG_CC_STACKPROTECTOR_STRONG: -fstack-protector-strong not supported by compiler

2016-06-09 Thread Launchpad Bug Tracker
This bug was fixed in the package linux - 4.4.0-24.43

---
linux (4.4.0-24.43) xenial; urgency=low

  [ Kamal Mostafa ]

  * CVE-2016-1583 (LP: #1588871)
- ecryptfs: fix handling of directory opening
- SAUCE: proc: prevent stacking filesystems on top
- SAUCE: ecryptfs: forbid opening files without mmap handler
- SAUCE: sched: panic on corrupted stack end

  * arm64: statically link rtc-efi (LP: #1583738)
- [Config] Link rtc-efi statically on arm64

 -- Kamal Mostafa   Fri, 03 Jun 2016 10:02:16 -0700

** Changed in: linux (Ubuntu Xenial)
   Status: Fix Committed => Fix Released

** CVE added: http://www.cve.mitre.org/cgi-
bin/cvename.cgi?name=2016-1583

-- 
You received this bug notification because you are a member of Kernel
Packages, which is subscribed to dkms in Ubuntu.
https://bugs.launchpad.net/bugs/1574982

Title:
  Cannot use CONFIG_CC_STACKPROTECTOR_STRONG: -fstack-protector-strong
  not supported by compiler

Status in dkms package in Ubuntu:
  Invalid
Status in gcc-defaults package in Ubuntu:
  Invalid
Status in linux package in Ubuntu:
  Fix Released
Status in dkms source package in Xenial:
  Invalid
Status in linux source package in Xenial:
  Fix Released

Bug description:
  Installing the latest 4.4.0-22 kernel ends with that error logged into 
dkmsbuildlog
  (only affect yakkety kernel; 4.4.0-22 kernel installation on xenial is fine)

  https://launchpadlibrarian.net/256055415/DKMSBuildLog.txt

  make "CC=cc"  KBUILD_VERBOSE= -C /lib/modules/4.4.0-22-generic/build 
M=/var/lib/dkms/nvidia-361/361.42/build ARCH=x86_64 
NV_KERNEL_SOURCES=/lib/modules/4.4.0-22-generic/build 
NV_KERNEL_OUTPUT=/lib/modules/4.4.0-22-generic/build NV_KERNEL_MODULES="nvidia 
nvidia-uvm nvidia-modeset" INSTALL_MOD_DIR=kernel/drivers/video modules
  make[1]: Entering directory '/usr/src/linux-headers-4.4.0-22-generic'
  arch/x86/Makefile:133: stack-protector enabled but compiler support broken
  Makefile:670: Cannot use CONFIG_CC_STACKPROTECTOR_STRONG: 
-fstack-protector-strong not supported by compiler

  the latest error logged is:

  /var/lib/dkms/nvidia-361/361.42/build/nvidia/nv-frontend.c:1:0: error:
  code model kernel does not support PIC mode

  Looks like it is related to the latest changes updates: gcc-6/gcc-5 
5.3.1-16ubuntu2 (some packages built with gcc-6; gcc-5 disabled for the 
packages built with gcc-6)
  Maybe some alternatives has not been updated to take care of these changes, 
as asked some time ago:
  http://askubuntu.com/questions/26498/choose-gcc-and-g-version

  This has been firstly reported against a nvidia crash:
  
https://bugs.launchpad.net/ubuntu/+source/nvidia-graphics-drivers-361/+bug/1574838

  ProblemType: Bug
  DistroRelease: Ubuntu 16.10
  Package: gcc 4:5.3.1-1ubuntu1
  ProcVersionSignature: Ubuntu 4.4.0-21.37-generic 4.4.6
  Uname: Linux 4.4.0-21-generic x86_64
  NonfreeKernelModules: nvidia_uvm nvidia_modeset nvidia
  ApportVersion: 2.20.1-0ubuntu2
  Architecture: amd64
  CurrentDesktop: GNOME
  Date: Tue Apr 26 08:41:32 2016
  SourcePackage: gcc-defaults
  UpgradeStatus: No upgrade log present (probably fresh install)
  ---
  ApportVersion: 2.20.1-0ubuntu2
  Architecture: amd64
  AudioDevicesInUse:
   USERPID ACCESS COMMAND
   /dev/snd/controlC1:  oem2014 F pulseaudio
   /dev/snd/pcmC0D0p:   oem2014 F...m pulseaudio
   /dev/snd/controlC0:  oem2014 F pulseaudio
  CurrentDesktop: GNOME
  DistroRelease: Ubuntu 16.10
  HibernationDevice: RESUME=UUID=0a9ca7f0-6eeb-4b21-b70f-670fa600de16
  IwConfig:
   eth0  no wireless extensions.

   eth1  no wireless extensions.

   lono wireless extensions.
  Lsusb:
   Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
   Bus 003 Device 002: ID 046d:c062 Logitech, Inc. M-UAS144 [LS1 Laser Mouse]
   Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
   Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
  MachineType: ASUSTEK COMPUTER INC P5W DH Deluxe
  NonfreeKernelModules: nvidia_uvm nvidia_modeset nvidia
  Package: ubuntu
  ProcFB:

  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.4.0-21-generic 
root=UUID=7c755ed6-51cc-4b75-88ac-9c75acf82749 ro
  ProcVersionSignature: Ubuntu 4.4.0-21.37-generic 4.4.6
  RelatedPackageVersions:
   linux-restricted-modules-4.4.0-21-generic N/A
   linux-backports-modules-4.4.0-21-generic  N/A
   linux-firmware1.157
  RfKill:

  Tags:  yakkety
  Uname: Linux 4.4.0-21-generic x86_64
  UpgradeStatus: No upgrade log present (probably fresh install)
  UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
  _MarkForUpload: True
  dmi.bios.date: 07/22/2010
  dmi.bios.vendor: American Megatrends Inc.
  dmi.bios.version: 3002
  dmi.board.asset.tag: To Be Filled By O.E.M.
  dmi.board.name: P5W DH Deluxe
  dmi.board.vendor: ASUSTeK Computer INC.
  dmi.board.version: Rev 1.xx
  dmi.chassis.asset.tag: Asset-1234567890
  dmi.chassis.type: 3
  

[Kernel-packages] [Bug 1574982] Re: Cannot use CONFIG_CC_STACKPROTECTOR_STRONG: -fstack-protector-strong not supported by compiler

2016-05-19 Thread LocutusOfBorg
looks good to me!

** Tags removed: verification-needed-xenial
** Tags added: verification-done-xenial

-- 
You received this bug notification because you are a member of Kernel
Packages, which is subscribed to dkms in Ubuntu.
https://bugs.launchpad.net/bugs/1574982

Title:
  Cannot use CONFIG_CC_STACKPROTECTOR_STRONG: -fstack-protector-strong
  not supported by compiler

Status in dkms package in Ubuntu:
  Invalid
Status in gcc-defaults package in Ubuntu:
  Invalid
Status in linux package in Ubuntu:
  Fix Released
Status in dkms source package in Xenial:
  Invalid
Status in linux source package in Xenial:
  Fix Committed

Bug description:
  Installing the latest 4.4.0-22 kernel ends with that error logged into 
dkmsbuildlog
  (only affect yakkety kernel; 4.4.0-22 kernel installation on xenial is fine)

  https://launchpadlibrarian.net/256055415/DKMSBuildLog.txt

  make "CC=cc"  KBUILD_VERBOSE= -C /lib/modules/4.4.0-22-generic/build 
M=/var/lib/dkms/nvidia-361/361.42/build ARCH=x86_64 
NV_KERNEL_SOURCES=/lib/modules/4.4.0-22-generic/build 
NV_KERNEL_OUTPUT=/lib/modules/4.4.0-22-generic/build NV_KERNEL_MODULES="nvidia 
nvidia-uvm nvidia-modeset" INSTALL_MOD_DIR=kernel/drivers/video modules
  make[1]: Entering directory '/usr/src/linux-headers-4.4.0-22-generic'
  arch/x86/Makefile:133: stack-protector enabled but compiler support broken
  Makefile:670: Cannot use CONFIG_CC_STACKPROTECTOR_STRONG: 
-fstack-protector-strong not supported by compiler

  the latest error logged is:

  /var/lib/dkms/nvidia-361/361.42/build/nvidia/nv-frontend.c:1:0: error:
  code model kernel does not support PIC mode

  Looks like it is related to the latest changes updates: gcc-6/gcc-5 
5.3.1-16ubuntu2 (some packages built with gcc-6; gcc-5 disabled for the 
packages built with gcc-6)
  Maybe some alternatives has not been updated to take care of these changes, 
as asked some time ago:
  http://askubuntu.com/questions/26498/choose-gcc-and-g-version

  This has been firstly reported against a nvidia crash:
  
https://bugs.launchpad.net/ubuntu/+source/nvidia-graphics-drivers-361/+bug/1574838

  ProblemType: Bug
  DistroRelease: Ubuntu 16.10
  Package: gcc 4:5.3.1-1ubuntu1
  ProcVersionSignature: Ubuntu 4.4.0-21.37-generic 4.4.6
  Uname: Linux 4.4.0-21-generic x86_64
  NonfreeKernelModules: nvidia_uvm nvidia_modeset nvidia
  ApportVersion: 2.20.1-0ubuntu2
  Architecture: amd64
  CurrentDesktop: GNOME
  Date: Tue Apr 26 08:41:32 2016
  SourcePackage: gcc-defaults
  UpgradeStatus: No upgrade log present (probably fresh install)
  ---
  ApportVersion: 2.20.1-0ubuntu2
  Architecture: amd64
  AudioDevicesInUse:
   USERPID ACCESS COMMAND
   /dev/snd/controlC1:  oem2014 F pulseaudio
   /dev/snd/pcmC0D0p:   oem2014 F...m pulseaudio
   /dev/snd/controlC0:  oem2014 F pulseaudio
  CurrentDesktop: GNOME
  DistroRelease: Ubuntu 16.10
  HibernationDevice: RESUME=UUID=0a9ca7f0-6eeb-4b21-b70f-670fa600de16
  IwConfig:
   eth0  no wireless extensions.

   eth1  no wireless extensions.

   lono wireless extensions.
  Lsusb:
   Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
   Bus 003 Device 002: ID 046d:c062 Logitech, Inc. M-UAS144 [LS1 Laser Mouse]
   Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
   Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
  MachineType: ASUSTEK COMPUTER INC P5W DH Deluxe
  NonfreeKernelModules: nvidia_uvm nvidia_modeset nvidia
  Package: ubuntu
  ProcFB:

  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.4.0-21-generic 
root=UUID=7c755ed6-51cc-4b75-88ac-9c75acf82749 ro
  ProcVersionSignature: Ubuntu 4.4.0-21.37-generic 4.4.6
  RelatedPackageVersions:
   linux-restricted-modules-4.4.0-21-generic N/A
   linux-backports-modules-4.4.0-21-generic  N/A
   linux-firmware1.157
  RfKill:

  Tags:  yakkety
  Uname: Linux 4.4.0-21-generic x86_64
  UpgradeStatus: No upgrade log present (probably fresh install)
  UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
  _MarkForUpload: True
  dmi.bios.date: 07/22/2010
  dmi.bios.vendor: American Megatrends Inc.
  dmi.bios.version: 3002
  dmi.board.asset.tag: To Be Filled By O.E.M.
  dmi.board.name: P5W DH Deluxe
  dmi.board.vendor: ASUSTeK Computer INC.
  dmi.board.version: Rev 1.xx
  dmi.chassis.asset.tag: Asset-1234567890
  dmi.chassis.type: 3
  dmi.chassis.vendor: Chassis Manufacture
  dmi.chassis.version: Chassis Version
  dmi.modalias: 
dmi:bvnAmericanMegatrendsInc.:bvr3002:bd07/22/2010:svnASUSTEKCOMPUTERINC:pnP5WDHDeluxe:pvrSystemVersion:rvnASUSTeKComputerINC.:rnP5WDHDeluxe:rvrRev1.xx:cvnChassisManufacture:ct3:cvrChassisVersion:
  dmi.product.name: P5W DH Deluxe
  dmi.product.version: System Version
  dmi.sys.vendor: ASUSTEK COMPUTER INC

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/dkms/+bug/1574982/+subscriptions

-- 
Mailing list: https://launchpad.net/~kernel-packages
Post to : 

[Kernel-packages] [Bug 1574982] Re: Cannot use CONFIG_CC_STACKPROTECTOR_STRONG: -fstack-protector-strong not supported by compiler

2016-05-19 Thread Kamal Mostafa
This bug is awaiting verification that the kernel in -proposed solves
the problem. Please test the kernel and update this bug with the
results. If the problem is solved, change the tag 'verification-needed-
xenial' to 'verification-done-xenial'.

If verification is not done by 5 working days from today, this fix will
be dropped from the source code, and this bug will be closed.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how
to enable and use -proposed. Thank you!


** Tags added: verification-needed-xenial

-- 
You received this bug notification because you are a member of Kernel
Packages, which is subscribed to dkms in Ubuntu.
https://bugs.launchpad.net/bugs/1574982

Title:
  Cannot use CONFIG_CC_STACKPROTECTOR_STRONG: -fstack-protector-strong
  not supported by compiler

Status in dkms package in Ubuntu:
  Invalid
Status in gcc-defaults package in Ubuntu:
  Invalid
Status in linux package in Ubuntu:
  Fix Released
Status in dkms source package in Xenial:
  Invalid
Status in linux source package in Xenial:
  Fix Committed

Bug description:
  Installing the latest 4.4.0-22 kernel ends with that error logged into 
dkmsbuildlog
  (only affect yakkety kernel; 4.4.0-22 kernel installation on xenial is fine)

  https://launchpadlibrarian.net/256055415/DKMSBuildLog.txt

  make "CC=cc"  KBUILD_VERBOSE= -C /lib/modules/4.4.0-22-generic/build 
M=/var/lib/dkms/nvidia-361/361.42/build ARCH=x86_64 
NV_KERNEL_SOURCES=/lib/modules/4.4.0-22-generic/build 
NV_KERNEL_OUTPUT=/lib/modules/4.4.0-22-generic/build NV_KERNEL_MODULES="nvidia 
nvidia-uvm nvidia-modeset" INSTALL_MOD_DIR=kernel/drivers/video modules
  make[1]: Entering directory '/usr/src/linux-headers-4.4.0-22-generic'
  arch/x86/Makefile:133: stack-protector enabled but compiler support broken
  Makefile:670: Cannot use CONFIG_CC_STACKPROTECTOR_STRONG: 
-fstack-protector-strong not supported by compiler

  the latest error logged is:

  /var/lib/dkms/nvidia-361/361.42/build/nvidia/nv-frontend.c:1:0: error:
  code model kernel does not support PIC mode

  Looks like it is related to the latest changes updates: gcc-6/gcc-5 
5.3.1-16ubuntu2 (some packages built with gcc-6; gcc-5 disabled for the 
packages built with gcc-6)
  Maybe some alternatives has not been updated to take care of these changes, 
as asked some time ago:
  http://askubuntu.com/questions/26498/choose-gcc-and-g-version

  This has been firstly reported against a nvidia crash:
  
https://bugs.launchpad.net/ubuntu/+source/nvidia-graphics-drivers-361/+bug/1574838

  ProblemType: Bug
  DistroRelease: Ubuntu 16.10
  Package: gcc 4:5.3.1-1ubuntu1
  ProcVersionSignature: Ubuntu 4.4.0-21.37-generic 4.4.6
  Uname: Linux 4.4.0-21-generic x86_64
  NonfreeKernelModules: nvidia_uvm nvidia_modeset nvidia
  ApportVersion: 2.20.1-0ubuntu2
  Architecture: amd64
  CurrentDesktop: GNOME
  Date: Tue Apr 26 08:41:32 2016
  SourcePackage: gcc-defaults
  UpgradeStatus: No upgrade log present (probably fresh install)
  ---
  ApportVersion: 2.20.1-0ubuntu2
  Architecture: amd64
  AudioDevicesInUse:
   USERPID ACCESS COMMAND
   /dev/snd/controlC1:  oem2014 F pulseaudio
   /dev/snd/pcmC0D0p:   oem2014 F...m pulseaudio
   /dev/snd/controlC0:  oem2014 F pulseaudio
  CurrentDesktop: GNOME
  DistroRelease: Ubuntu 16.10
  HibernationDevice: RESUME=UUID=0a9ca7f0-6eeb-4b21-b70f-670fa600de16
  IwConfig:
   eth0  no wireless extensions.

   eth1  no wireless extensions.

   lono wireless extensions.
  Lsusb:
   Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
   Bus 003 Device 002: ID 046d:c062 Logitech, Inc. M-UAS144 [LS1 Laser Mouse]
   Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
   Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
  MachineType: ASUSTEK COMPUTER INC P5W DH Deluxe
  NonfreeKernelModules: nvidia_uvm nvidia_modeset nvidia
  Package: ubuntu
  ProcFB:

  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.4.0-21-generic 
root=UUID=7c755ed6-51cc-4b75-88ac-9c75acf82749 ro
  ProcVersionSignature: Ubuntu 4.4.0-21.37-generic 4.4.6
  RelatedPackageVersions:
   linux-restricted-modules-4.4.0-21-generic N/A
   linux-backports-modules-4.4.0-21-generic  N/A
   linux-firmware1.157
  RfKill:

  Tags:  yakkety
  Uname: Linux 4.4.0-21-generic x86_64
  UpgradeStatus: No upgrade log present (probably fresh install)
  UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
  _MarkForUpload: True
  dmi.bios.date: 07/22/2010
  dmi.bios.vendor: American Megatrends Inc.
  dmi.bios.version: 3002
  dmi.board.asset.tag: To Be Filled By O.E.M.
  dmi.board.name: P5W DH Deluxe
  dmi.board.vendor: ASUSTeK Computer INC.
  dmi.board.version: Rev 1.xx
  dmi.chassis.asset.tag: Asset-1234567890
  dmi.chassis.type: 3
  dmi.chassis.vendor: Chassis Manufacture
  dmi.chassis.version: Chassis Version
  dmi.modalias: 

[Kernel-packages] [Bug 1574982] Re: Cannot use CONFIG_CC_STACKPROTECTOR_STRONG: -fstack-protector-strong not supported by compiler

2016-05-18 Thread dino99
Feedback: installing kernel 4.4.0−23 (without other kbuild∕makefile tweak)
- no crasher at installation
- reboot with no black screen

 * Cannot use CONFIG_CC_STACKPROTECTOR_STRONG: -fstack-protector-strong not
supported by compiler (LP: #1574982)
- SAUCE: (no-up) disable -pie when gcc has it enabled by default

Good job done 
So the other 'affected' packages can be closed now, as the kernel build config 
takes care of that issue

** Changed in: dkms (Ubuntu)
   Status: Confirmed => Invalid

** Changed in: dkms (Ubuntu Xenial)
   Status: Confirmed => Invalid

** Changed in: linux (Ubuntu)
   Status: Confirmed => Fix Released

-- 
You received this bug notification because you are a member of Kernel
Packages, which is subscribed to dkms in Ubuntu.
https://bugs.launchpad.net/bugs/1574982

Title:
  Cannot use CONFIG_CC_STACKPROTECTOR_STRONG: -fstack-protector-strong
  not supported by compiler

Status in dkms package in Ubuntu:
  Invalid
Status in gcc-defaults package in Ubuntu:
  Invalid
Status in linux package in Ubuntu:
  Fix Released
Status in dkms source package in Xenial:
  Invalid
Status in linux source package in Xenial:
  Fix Committed

Bug description:
  Installing the latest 4.4.0-22 kernel ends with that error logged into 
dkmsbuildlog
  (only affect yakkety kernel; 4.4.0-22 kernel installation on xenial is fine)

  https://launchpadlibrarian.net/256055415/DKMSBuildLog.txt

  make "CC=cc"  KBUILD_VERBOSE= -C /lib/modules/4.4.0-22-generic/build 
M=/var/lib/dkms/nvidia-361/361.42/build ARCH=x86_64 
NV_KERNEL_SOURCES=/lib/modules/4.4.0-22-generic/build 
NV_KERNEL_OUTPUT=/lib/modules/4.4.0-22-generic/build NV_KERNEL_MODULES="nvidia 
nvidia-uvm nvidia-modeset" INSTALL_MOD_DIR=kernel/drivers/video modules
  make[1]: Entering directory '/usr/src/linux-headers-4.4.0-22-generic'
  arch/x86/Makefile:133: stack-protector enabled but compiler support broken
  Makefile:670: Cannot use CONFIG_CC_STACKPROTECTOR_STRONG: 
-fstack-protector-strong not supported by compiler

  the latest error logged is:

  /var/lib/dkms/nvidia-361/361.42/build/nvidia/nv-frontend.c:1:0: error:
  code model kernel does not support PIC mode

  Looks like it is related to the latest changes updates: gcc-6/gcc-5 
5.3.1-16ubuntu2 (some packages built with gcc-6; gcc-5 disabled for the 
packages built with gcc-6)
  Maybe some alternatives has not been updated to take care of these changes, 
as asked some time ago:
  http://askubuntu.com/questions/26498/choose-gcc-and-g-version

  This has been firstly reported against a nvidia crash:
  
https://bugs.launchpad.net/ubuntu/+source/nvidia-graphics-drivers-361/+bug/1574838

  ProblemType: Bug
  DistroRelease: Ubuntu 16.10
  Package: gcc 4:5.3.1-1ubuntu1
  ProcVersionSignature: Ubuntu 4.4.0-21.37-generic 4.4.6
  Uname: Linux 4.4.0-21-generic x86_64
  NonfreeKernelModules: nvidia_uvm nvidia_modeset nvidia
  ApportVersion: 2.20.1-0ubuntu2
  Architecture: amd64
  CurrentDesktop: GNOME
  Date: Tue Apr 26 08:41:32 2016
  SourcePackage: gcc-defaults
  UpgradeStatus: No upgrade log present (probably fresh install)
  ---
  ApportVersion: 2.20.1-0ubuntu2
  Architecture: amd64
  AudioDevicesInUse:
   USERPID ACCESS COMMAND
   /dev/snd/controlC1:  oem2014 F pulseaudio
   /dev/snd/pcmC0D0p:   oem2014 F...m pulseaudio
   /dev/snd/controlC0:  oem2014 F pulseaudio
  CurrentDesktop: GNOME
  DistroRelease: Ubuntu 16.10
  HibernationDevice: RESUME=UUID=0a9ca7f0-6eeb-4b21-b70f-670fa600de16
  IwConfig:
   eth0  no wireless extensions.

   eth1  no wireless extensions.

   lono wireless extensions.
  Lsusb:
   Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
   Bus 003 Device 002: ID 046d:c062 Logitech, Inc. M-UAS144 [LS1 Laser Mouse]
   Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
   Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
  MachineType: ASUSTEK COMPUTER INC P5W DH Deluxe
  NonfreeKernelModules: nvidia_uvm nvidia_modeset nvidia
  Package: ubuntu
  ProcFB:

  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.4.0-21-generic 
root=UUID=7c755ed6-51cc-4b75-88ac-9c75acf82749 ro
  ProcVersionSignature: Ubuntu 4.4.0-21.37-generic 4.4.6
  RelatedPackageVersions:
   linux-restricted-modules-4.4.0-21-generic N/A
   linux-backports-modules-4.4.0-21-generic  N/A
   linux-firmware1.157
  RfKill:

  Tags:  yakkety
  Uname: Linux 4.4.0-21-generic x86_64
  UpgradeStatus: No upgrade log present (probably fresh install)
  UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
  _MarkForUpload: True
  dmi.bios.date: 07/22/2010
  dmi.bios.vendor: American Megatrends Inc.
  dmi.bios.version: 3002
  dmi.board.asset.tag: To Be Filled By O.E.M.
  dmi.board.name: P5W DH Deluxe
  dmi.board.vendor: ASUSTeK Computer INC.
  dmi.board.version: Rev 1.xx
  dmi.chassis.asset.tag: Asset-1234567890
  dmi.chassis.type: 3
  dmi.chassis.vendor: Chassis Manufacture
  dmi.chassis.version: 

[Kernel-packages] [Bug 1574982] Re: Cannot use CONFIG_CC_STACKPROTECTOR_STRONG: -fstack-protector-strong not supported by compiler

2016-05-17 Thread twicejr
Already mentioned, of course, but to sum it up ^

-- 
You received this bug notification because you are a member of Kernel
Packages, which is subscribed to dkms in Ubuntu.
https://bugs.launchpad.net/bugs/1574982

Title:
  Cannot use CONFIG_CC_STACKPROTECTOR_STRONG: -fstack-protector-strong
  not supported by compiler

Status in dkms package in Ubuntu:
  Confirmed
Status in gcc-defaults package in Ubuntu:
  Invalid
Status in linux package in Ubuntu:
  Confirmed
Status in dkms source package in Xenial:
  Confirmed
Status in linux source package in Xenial:
  Fix Committed

Bug description:
  Installing the latest 4.4.0-22 kernel ends with that error logged into 
dkmsbuildlog
  (only affect yakkety kernel; 4.4.0-22 kernel installation on xenial is fine)

  https://launchpadlibrarian.net/256055415/DKMSBuildLog.txt

  make "CC=cc"  KBUILD_VERBOSE= -C /lib/modules/4.4.0-22-generic/build 
M=/var/lib/dkms/nvidia-361/361.42/build ARCH=x86_64 
NV_KERNEL_SOURCES=/lib/modules/4.4.0-22-generic/build 
NV_KERNEL_OUTPUT=/lib/modules/4.4.0-22-generic/build NV_KERNEL_MODULES="nvidia 
nvidia-uvm nvidia-modeset" INSTALL_MOD_DIR=kernel/drivers/video modules
  make[1]: Entering directory '/usr/src/linux-headers-4.4.0-22-generic'
  arch/x86/Makefile:133: stack-protector enabled but compiler support broken
  Makefile:670: Cannot use CONFIG_CC_STACKPROTECTOR_STRONG: 
-fstack-protector-strong not supported by compiler

  the latest error logged is:

  /var/lib/dkms/nvidia-361/361.42/build/nvidia/nv-frontend.c:1:0: error:
  code model kernel does not support PIC mode

  Looks like it is related to the latest changes updates: gcc-6/gcc-5 
5.3.1-16ubuntu2 (some packages built with gcc-6; gcc-5 disabled for the 
packages built with gcc-6)
  Maybe some alternatives has not been updated to take care of these changes, 
as asked some time ago:
  http://askubuntu.com/questions/26498/choose-gcc-and-g-version

  This has been firstly reported against a nvidia crash:
  
https://bugs.launchpad.net/ubuntu/+source/nvidia-graphics-drivers-361/+bug/1574838

  ProblemType: Bug
  DistroRelease: Ubuntu 16.10
  Package: gcc 4:5.3.1-1ubuntu1
  ProcVersionSignature: Ubuntu 4.4.0-21.37-generic 4.4.6
  Uname: Linux 4.4.0-21-generic x86_64
  NonfreeKernelModules: nvidia_uvm nvidia_modeset nvidia
  ApportVersion: 2.20.1-0ubuntu2
  Architecture: amd64
  CurrentDesktop: GNOME
  Date: Tue Apr 26 08:41:32 2016
  SourcePackage: gcc-defaults
  UpgradeStatus: No upgrade log present (probably fresh install)
  ---
  ApportVersion: 2.20.1-0ubuntu2
  Architecture: amd64
  AudioDevicesInUse:
   USERPID ACCESS COMMAND
   /dev/snd/controlC1:  oem2014 F pulseaudio
   /dev/snd/pcmC0D0p:   oem2014 F...m pulseaudio
   /dev/snd/controlC0:  oem2014 F pulseaudio
  CurrentDesktop: GNOME
  DistroRelease: Ubuntu 16.10
  HibernationDevice: RESUME=UUID=0a9ca7f0-6eeb-4b21-b70f-670fa600de16
  IwConfig:
   eth0  no wireless extensions.

   eth1  no wireless extensions.

   lono wireless extensions.
  Lsusb:
   Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
   Bus 003 Device 002: ID 046d:c062 Logitech, Inc. M-UAS144 [LS1 Laser Mouse]
   Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
   Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
  MachineType: ASUSTEK COMPUTER INC P5W DH Deluxe
  NonfreeKernelModules: nvidia_uvm nvidia_modeset nvidia
  Package: ubuntu
  ProcFB:

  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.4.0-21-generic 
root=UUID=7c755ed6-51cc-4b75-88ac-9c75acf82749 ro
  ProcVersionSignature: Ubuntu 4.4.0-21.37-generic 4.4.6
  RelatedPackageVersions:
   linux-restricted-modules-4.4.0-21-generic N/A
   linux-backports-modules-4.4.0-21-generic  N/A
   linux-firmware1.157
  RfKill:

  Tags:  yakkety
  Uname: Linux 4.4.0-21-generic x86_64
  UpgradeStatus: No upgrade log present (probably fresh install)
  UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
  _MarkForUpload: True
  dmi.bios.date: 07/22/2010
  dmi.bios.vendor: American Megatrends Inc.
  dmi.bios.version: 3002
  dmi.board.asset.tag: To Be Filled By O.E.M.
  dmi.board.name: P5W DH Deluxe
  dmi.board.vendor: ASUSTeK Computer INC.
  dmi.board.version: Rev 1.xx
  dmi.chassis.asset.tag: Asset-1234567890
  dmi.chassis.type: 3
  dmi.chassis.vendor: Chassis Manufacture
  dmi.chassis.version: Chassis Version
  dmi.modalias: 
dmi:bvnAmericanMegatrendsInc.:bvr3002:bd07/22/2010:svnASUSTEKCOMPUTERINC:pnP5WDHDeluxe:pvrSystemVersion:rvnASUSTeKComputerINC.:rnP5WDHDeluxe:rvrRev1.xx:cvnChassisManufacture:ct3:cvrChassisVersion:
  dmi.product.name: P5W DH Deluxe
  dmi.product.version: System Version
  dmi.sys.vendor: ASUSTEK COMPUTER INC

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/dkms/+bug/1574982/+subscriptions

-- 
Mailing list: https://launchpad.net/~kernel-packages
Post to : kernel-packages@lists.launchpad.net
Unsubscribe : 

[Kernel-packages] [Bug 1574982] Re: Cannot use CONFIG_CC_STACKPROTECTOR_STRONG: -fstack-protector-strong not supported by compiler

2016-05-17 Thread twicejr
Fix:

Needed to add in
EXTRA_CFLAGS += -fno-pie -fno-stack-protector
to /usr/src/nvidia-364-364.19/Kbuild

And to top /usr/src/bbswitch-0.8/Makefile
EXTRA_CFLAGS := -fno-pie -fno-stack-protector

Then issue a command:
ls /usr/src/linux-headers-* -d | sed -e 's/.*linux-headers-//' | sort -V | tac 
| sudo xargs -n1 /usr/lib/dkms/dkms_autoinstaller start

EXTRA_CFLAGS := -fno-pie -fno-stack-protector

-- 
You received this bug notification because you are a member of Kernel
Packages, which is subscribed to dkms in Ubuntu.
https://bugs.launchpad.net/bugs/1574982

Title:
  Cannot use CONFIG_CC_STACKPROTECTOR_STRONG: -fstack-protector-strong
  not supported by compiler

Status in dkms package in Ubuntu:
  Confirmed
Status in gcc-defaults package in Ubuntu:
  Invalid
Status in linux package in Ubuntu:
  Confirmed
Status in dkms source package in Xenial:
  Confirmed
Status in linux source package in Xenial:
  Fix Committed

Bug description:
  Installing the latest 4.4.0-22 kernel ends with that error logged into 
dkmsbuildlog
  (only affect yakkety kernel; 4.4.0-22 kernel installation on xenial is fine)

  https://launchpadlibrarian.net/256055415/DKMSBuildLog.txt

  make "CC=cc"  KBUILD_VERBOSE= -C /lib/modules/4.4.0-22-generic/build 
M=/var/lib/dkms/nvidia-361/361.42/build ARCH=x86_64 
NV_KERNEL_SOURCES=/lib/modules/4.4.0-22-generic/build 
NV_KERNEL_OUTPUT=/lib/modules/4.4.0-22-generic/build NV_KERNEL_MODULES="nvidia 
nvidia-uvm nvidia-modeset" INSTALL_MOD_DIR=kernel/drivers/video modules
  make[1]: Entering directory '/usr/src/linux-headers-4.4.0-22-generic'
  arch/x86/Makefile:133: stack-protector enabled but compiler support broken
  Makefile:670: Cannot use CONFIG_CC_STACKPROTECTOR_STRONG: 
-fstack-protector-strong not supported by compiler

  the latest error logged is:

  /var/lib/dkms/nvidia-361/361.42/build/nvidia/nv-frontend.c:1:0: error:
  code model kernel does not support PIC mode

  Looks like it is related to the latest changes updates: gcc-6/gcc-5 
5.3.1-16ubuntu2 (some packages built with gcc-6; gcc-5 disabled for the 
packages built with gcc-6)
  Maybe some alternatives has not been updated to take care of these changes, 
as asked some time ago:
  http://askubuntu.com/questions/26498/choose-gcc-and-g-version

  This has been firstly reported against a nvidia crash:
  
https://bugs.launchpad.net/ubuntu/+source/nvidia-graphics-drivers-361/+bug/1574838

  ProblemType: Bug
  DistroRelease: Ubuntu 16.10
  Package: gcc 4:5.3.1-1ubuntu1
  ProcVersionSignature: Ubuntu 4.4.0-21.37-generic 4.4.6
  Uname: Linux 4.4.0-21-generic x86_64
  NonfreeKernelModules: nvidia_uvm nvidia_modeset nvidia
  ApportVersion: 2.20.1-0ubuntu2
  Architecture: amd64
  CurrentDesktop: GNOME
  Date: Tue Apr 26 08:41:32 2016
  SourcePackage: gcc-defaults
  UpgradeStatus: No upgrade log present (probably fresh install)
  ---
  ApportVersion: 2.20.1-0ubuntu2
  Architecture: amd64
  AudioDevicesInUse:
   USERPID ACCESS COMMAND
   /dev/snd/controlC1:  oem2014 F pulseaudio
   /dev/snd/pcmC0D0p:   oem2014 F...m pulseaudio
   /dev/snd/controlC0:  oem2014 F pulseaudio
  CurrentDesktop: GNOME
  DistroRelease: Ubuntu 16.10
  HibernationDevice: RESUME=UUID=0a9ca7f0-6eeb-4b21-b70f-670fa600de16
  IwConfig:
   eth0  no wireless extensions.

   eth1  no wireless extensions.

   lono wireless extensions.
  Lsusb:
   Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
   Bus 003 Device 002: ID 046d:c062 Logitech, Inc. M-UAS144 [LS1 Laser Mouse]
   Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
   Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
  MachineType: ASUSTEK COMPUTER INC P5W DH Deluxe
  NonfreeKernelModules: nvidia_uvm nvidia_modeset nvidia
  Package: ubuntu
  ProcFB:

  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.4.0-21-generic 
root=UUID=7c755ed6-51cc-4b75-88ac-9c75acf82749 ro
  ProcVersionSignature: Ubuntu 4.4.0-21.37-generic 4.4.6
  RelatedPackageVersions:
   linux-restricted-modules-4.4.0-21-generic N/A
   linux-backports-modules-4.4.0-21-generic  N/A
   linux-firmware1.157
  RfKill:

  Tags:  yakkety
  Uname: Linux 4.4.0-21-generic x86_64
  UpgradeStatus: No upgrade log present (probably fresh install)
  UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
  _MarkForUpload: True
  dmi.bios.date: 07/22/2010
  dmi.bios.vendor: American Megatrends Inc.
  dmi.bios.version: 3002
  dmi.board.asset.tag: To Be Filled By O.E.M.
  dmi.board.name: P5W DH Deluxe
  dmi.board.vendor: ASUSTeK Computer INC.
  dmi.board.version: Rev 1.xx
  dmi.chassis.asset.tag: Asset-1234567890
  dmi.chassis.type: 3
  dmi.chassis.vendor: Chassis Manufacture
  dmi.chassis.version: Chassis Version
  dmi.modalias: 
dmi:bvnAmericanMegatrendsInc.:bvr3002:bd07/22/2010:svnASUSTEKCOMPUTERINC:pnP5WDHDeluxe:pvrSystemVersion:rvnASUSTeKComputerINC.:rnP5WDHDeluxe:rvrRev1.xx:cvnChassisManufacture:ct3:cvrChassisVersion:
  dmi.product.name: P5W DH 

[Kernel-packages] [Bug 1574982] Re: Cannot use CONFIG_CC_STACKPROTECTOR_STRONG: -fstack-protector-strong not supported by compiler

2016-05-17 Thread dino99
Debian answer & possible solution:
https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=823869#10

its an Ubuntu problem, and Debian will probably change nothing to their
dkms version.

** Bug watch added: Debian Bug tracker #823869
   http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=823869

-- 
You received this bug notification because you are a member of Kernel
Packages, which is subscribed to dkms in Ubuntu.
https://bugs.launchpad.net/bugs/1574982

Title:
  Cannot use CONFIG_CC_STACKPROTECTOR_STRONG: -fstack-protector-strong
  not supported by compiler

Status in dkms package in Ubuntu:
  Confirmed
Status in gcc-defaults package in Ubuntu:
  Invalid
Status in linux package in Ubuntu:
  Confirmed
Status in dkms source package in Xenial:
  Confirmed
Status in linux source package in Xenial:
  Fix Committed

Bug description:
  Installing the latest 4.4.0-22 kernel ends with that error logged into 
dkmsbuildlog
  (only affect yakkety kernel; 4.4.0-22 kernel installation on xenial is fine)

  https://launchpadlibrarian.net/256055415/DKMSBuildLog.txt

  make "CC=cc"  KBUILD_VERBOSE= -C /lib/modules/4.4.0-22-generic/build 
M=/var/lib/dkms/nvidia-361/361.42/build ARCH=x86_64 
NV_KERNEL_SOURCES=/lib/modules/4.4.0-22-generic/build 
NV_KERNEL_OUTPUT=/lib/modules/4.4.0-22-generic/build NV_KERNEL_MODULES="nvidia 
nvidia-uvm nvidia-modeset" INSTALL_MOD_DIR=kernel/drivers/video modules
  make[1]: Entering directory '/usr/src/linux-headers-4.4.0-22-generic'
  arch/x86/Makefile:133: stack-protector enabled but compiler support broken
  Makefile:670: Cannot use CONFIG_CC_STACKPROTECTOR_STRONG: 
-fstack-protector-strong not supported by compiler

  the latest error logged is:

  /var/lib/dkms/nvidia-361/361.42/build/nvidia/nv-frontend.c:1:0: error:
  code model kernel does not support PIC mode

  Looks like it is related to the latest changes updates: gcc-6/gcc-5 
5.3.1-16ubuntu2 (some packages built with gcc-6; gcc-5 disabled for the 
packages built with gcc-6)
  Maybe some alternatives has not been updated to take care of these changes, 
as asked some time ago:
  http://askubuntu.com/questions/26498/choose-gcc-and-g-version

  This has been firstly reported against a nvidia crash:
  
https://bugs.launchpad.net/ubuntu/+source/nvidia-graphics-drivers-361/+bug/1574838

  ProblemType: Bug
  DistroRelease: Ubuntu 16.10
  Package: gcc 4:5.3.1-1ubuntu1
  ProcVersionSignature: Ubuntu 4.4.0-21.37-generic 4.4.6
  Uname: Linux 4.4.0-21-generic x86_64
  NonfreeKernelModules: nvidia_uvm nvidia_modeset nvidia
  ApportVersion: 2.20.1-0ubuntu2
  Architecture: amd64
  CurrentDesktop: GNOME
  Date: Tue Apr 26 08:41:32 2016
  SourcePackage: gcc-defaults
  UpgradeStatus: No upgrade log present (probably fresh install)
  ---
  ApportVersion: 2.20.1-0ubuntu2
  Architecture: amd64
  AudioDevicesInUse:
   USERPID ACCESS COMMAND
   /dev/snd/controlC1:  oem2014 F pulseaudio
   /dev/snd/pcmC0D0p:   oem2014 F...m pulseaudio
   /dev/snd/controlC0:  oem2014 F pulseaudio
  CurrentDesktop: GNOME
  DistroRelease: Ubuntu 16.10
  HibernationDevice: RESUME=UUID=0a9ca7f0-6eeb-4b21-b70f-670fa600de16
  IwConfig:
   eth0  no wireless extensions.

   eth1  no wireless extensions.

   lono wireless extensions.
  Lsusb:
   Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
   Bus 003 Device 002: ID 046d:c062 Logitech, Inc. M-UAS144 [LS1 Laser Mouse]
   Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
   Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
  MachineType: ASUSTEK COMPUTER INC P5W DH Deluxe
  NonfreeKernelModules: nvidia_uvm nvidia_modeset nvidia
  Package: ubuntu
  ProcFB:

  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.4.0-21-generic 
root=UUID=7c755ed6-51cc-4b75-88ac-9c75acf82749 ro
  ProcVersionSignature: Ubuntu 4.4.0-21.37-generic 4.4.6
  RelatedPackageVersions:
   linux-restricted-modules-4.4.0-21-generic N/A
   linux-backports-modules-4.4.0-21-generic  N/A
   linux-firmware1.157
  RfKill:

  Tags:  yakkety
  Uname: Linux 4.4.0-21-generic x86_64
  UpgradeStatus: No upgrade log present (probably fresh install)
  UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
  _MarkForUpload: True
  dmi.bios.date: 07/22/2010
  dmi.bios.vendor: American Megatrends Inc.
  dmi.bios.version: 3002
  dmi.board.asset.tag: To Be Filled By O.E.M.
  dmi.board.name: P5W DH Deluxe
  dmi.board.vendor: ASUSTeK Computer INC.
  dmi.board.version: Rev 1.xx
  dmi.chassis.asset.tag: Asset-1234567890
  dmi.chassis.type: 3
  dmi.chassis.vendor: Chassis Manufacture
  dmi.chassis.version: Chassis Version
  dmi.modalias: 
dmi:bvnAmericanMegatrendsInc.:bvr3002:bd07/22/2010:svnASUSTEKCOMPUTERINC:pnP5WDHDeluxe:pvrSystemVersion:rvnASUSTeKComputerINC.:rnP5WDHDeluxe:rvrRev1.xx:cvnChassisManufacture:ct3:cvrChassisVersion:
  dmi.product.name: P5W DH Deluxe
  dmi.product.version: System Version
  dmi.sys.vendor: ASUSTEK COMPUTER INC

To manage notifications about 

[Kernel-packages] [Bug 1574982] Re: Cannot use CONFIG_CC_STACKPROTECTOR_STRONG: -fstack-protector-strong not supported by compiler

2016-05-11 Thread Launchpad Bug Tracker
Status changed to 'Confirmed' because the bug affects multiple users.

** Changed in: dkms (Ubuntu Xenial)
   Status: New => Confirmed

-- 
You received this bug notification because you are a member of Kernel
Packages, which is subscribed to dkms in Ubuntu.
https://bugs.launchpad.net/bugs/1574982

Title:
  Cannot use CONFIG_CC_STACKPROTECTOR_STRONG: -fstack-protector-strong
  not supported by compiler

Status in dkms package in Ubuntu:
  Confirmed
Status in gcc-defaults package in Ubuntu:
  Invalid
Status in linux package in Ubuntu:
  Confirmed
Status in dkms source package in Xenial:
  Confirmed
Status in linux source package in Xenial:
  Fix Committed

Bug description:
  Installing the latest 4.4.0-22 kernel ends with that error logged into 
dkmsbuildlog
  (only affect yakkety kernel; 4.4.0-22 kernel installation on xenial is fine)

  https://launchpadlibrarian.net/256055415/DKMSBuildLog.txt

  make "CC=cc"  KBUILD_VERBOSE= -C /lib/modules/4.4.0-22-generic/build 
M=/var/lib/dkms/nvidia-361/361.42/build ARCH=x86_64 
NV_KERNEL_SOURCES=/lib/modules/4.4.0-22-generic/build 
NV_KERNEL_OUTPUT=/lib/modules/4.4.0-22-generic/build NV_KERNEL_MODULES="nvidia 
nvidia-uvm nvidia-modeset" INSTALL_MOD_DIR=kernel/drivers/video modules
  make[1]: Entering directory '/usr/src/linux-headers-4.4.0-22-generic'
  arch/x86/Makefile:133: stack-protector enabled but compiler support broken
  Makefile:670: Cannot use CONFIG_CC_STACKPROTECTOR_STRONG: 
-fstack-protector-strong not supported by compiler

  the latest error logged is:

  /var/lib/dkms/nvidia-361/361.42/build/nvidia/nv-frontend.c:1:0: error:
  code model kernel does not support PIC mode

  Looks like it is related to the latest changes updates: gcc-6/gcc-5 
5.3.1-16ubuntu2 (some packages built with gcc-6; gcc-5 disabled for the 
packages built with gcc-6)
  Maybe some alternatives has not been updated to take care of these changes, 
as asked some time ago:
  http://askubuntu.com/questions/26498/choose-gcc-and-g-version

  This has been firstly reported against a nvidia crash:
  
https://bugs.launchpad.net/ubuntu/+source/nvidia-graphics-drivers-361/+bug/1574838

  ProblemType: Bug
  DistroRelease: Ubuntu 16.10
  Package: gcc 4:5.3.1-1ubuntu1
  ProcVersionSignature: Ubuntu 4.4.0-21.37-generic 4.4.6
  Uname: Linux 4.4.0-21-generic x86_64
  NonfreeKernelModules: nvidia_uvm nvidia_modeset nvidia
  ApportVersion: 2.20.1-0ubuntu2
  Architecture: amd64
  CurrentDesktop: GNOME
  Date: Tue Apr 26 08:41:32 2016
  SourcePackage: gcc-defaults
  UpgradeStatus: No upgrade log present (probably fresh install)
  ---
  ApportVersion: 2.20.1-0ubuntu2
  Architecture: amd64
  AudioDevicesInUse:
   USERPID ACCESS COMMAND
   /dev/snd/controlC1:  oem2014 F pulseaudio
   /dev/snd/pcmC0D0p:   oem2014 F...m pulseaudio
   /dev/snd/controlC0:  oem2014 F pulseaudio
  CurrentDesktop: GNOME
  DistroRelease: Ubuntu 16.10
  HibernationDevice: RESUME=UUID=0a9ca7f0-6eeb-4b21-b70f-670fa600de16
  IwConfig:
   eth0  no wireless extensions.

   eth1  no wireless extensions.

   lono wireless extensions.
  Lsusb:
   Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
   Bus 003 Device 002: ID 046d:c062 Logitech, Inc. M-UAS144 [LS1 Laser Mouse]
   Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
   Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
  MachineType: ASUSTEK COMPUTER INC P5W DH Deluxe
  NonfreeKernelModules: nvidia_uvm nvidia_modeset nvidia
  Package: ubuntu
  ProcFB:

  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.4.0-21-generic 
root=UUID=7c755ed6-51cc-4b75-88ac-9c75acf82749 ro
  ProcVersionSignature: Ubuntu 4.4.0-21.37-generic 4.4.6
  RelatedPackageVersions:
   linux-restricted-modules-4.4.0-21-generic N/A
   linux-backports-modules-4.4.0-21-generic  N/A
   linux-firmware1.157
  RfKill:

  Tags:  yakkety
  Uname: Linux 4.4.0-21-generic x86_64
  UpgradeStatus: No upgrade log present (probably fresh install)
  UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
  _MarkForUpload: True
  dmi.bios.date: 07/22/2010
  dmi.bios.vendor: American Megatrends Inc.
  dmi.bios.version: 3002
  dmi.board.asset.tag: To Be Filled By O.E.M.
  dmi.board.name: P5W DH Deluxe
  dmi.board.vendor: ASUSTeK Computer INC.
  dmi.board.version: Rev 1.xx
  dmi.chassis.asset.tag: Asset-1234567890
  dmi.chassis.type: 3
  dmi.chassis.vendor: Chassis Manufacture
  dmi.chassis.version: Chassis Version
  dmi.modalias: 
dmi:bvnAmericanMegatrendsInc.:bvr3002:bd07/22/2010:svnASUSTEKCOMPUTERINC:pnP5WDHDeluxe:pvrSystemVersion:rvnASUSTeKComputerINC.:rnP5WDHDeluxe:rvrRev1.xx:cvnChassisManufacture:ct3:cvrChassisVersion:
  dmi.product.name: P5W DH Deluxe
  dmi.product.version: System Version
  dmi.sys.vendor: ASUSTEK COMPUTER INC

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/dkms/+bug/1574982/+subscriptions

-- 
Mailing list: https://launchpad.net/~kernel-packages

[Kernel-packages] [Bug 1574982] Re: Cannot use CONFIG_CC_STACKPROTECTOR_STRONG: -fstack-protector-strong not supported by compiler

2016-05-10 Thread Matthias Klose
** Changed in: gcc-defaults (Ubuntu)
   Status: Confirmed => Invalid

-- 
You received this bug notification because you are a member of Kernel
Packages, which is subscribed to dkms in Ubuntu.
https://bugs.launchpad.net/bugs/1574982

Title:
  Cannot use CONFIG_CC_STACKPROTECTOR_STRONG: -fstack-protector-strong
  not supported by compiler

Status in dkms package in Ubuntu:
  Confirmed
Status in gcc-defaults package in Ubuntu:
  Invalid
Status in linux package in Ubuntu:
  Confirmed
Status in dkms source package in Xenial:
  New
Status in linux source package in Xenial:
  Fix Committed

Bug description:
  Installing the latest 4.4.0-22 kernel ends with that error logged into 
dkmsbuildlog
  (only affect yakkety kernel; 4.4.0-22 kernel installation on xenial is fine)

  https://launchpadlibrarian.net/256055415/DKMSBuildLog.txt

  make "CC=cc"  KBUILD_VERBOSE= -C /lib/modules/4.4.0-22-generic/build 
M=/var/lib/dkms/nvidia-361/361.42/build ARCH=x86_64 
NV_KERNEL_SOURCES=/lib/modules/4.4.0-22-generic/build 
NV_KERNEL_OUTPUT=/lib/modules/4.4.0-22-generic/build NV_KERNEL_MODULES="nvidia 
nvidia-uvm nvidia-modeset" INSTALL_MOD_DIR=kernel/drivers/video modules
  make[1]: Entering directory '/usr/src/linux-headers-4.4.0-22-generic'
  arch/x86/Makefile:133: stack-protector enabled but compiler support broken
  Makefile:670: Cannot use CONFIG_CC_STACKPROTECTOR_STRONG: 
-fstack-protector-strong not supported by compiler

  the latest error logged is:

  /var/lib/dkms/nvidia-361/361.42/build/nvidia/nv-frontend.c:1:0: error:
  code model kernel does not support PIC mode

  Looks like it is related to the latest changes updates: gcc-6/gcc-5 
5.3.1-16ubuntu2 (some packages built with gcc-6; gcc-5 disabled for the 
packages built with gcc-6)
  Maybe some alternatives has not been updated to take care of these changes, 
as asked some time ago:
  http://askubuntu.com/questions/26498/choose-gcc-and-g-version

  This has been firstly reported against a nvidia crash:
  
https://bugs.launchpad.net/ubuntu/+source/nvidia-graphics-drivers-361/+bug/1574838

  ProblemType: Bug
  DistroRelease: Ubuntu 16.10
  Package: gcc 4:5.3.1-1ubuntu1
  ProcVersionSignature: Ubuntu 4.4.0-21.37-generic 4.4.6
  Uname: Linux 4.4.0-21-generic x86_64
  NonfreeKernelModules: nvidia_uvm nvidia_modeset nvidia
  ApportVersion: 2.20.1-0ubuntu2
  Architecture: amd64
  CurrentDesktop: GNOME
  Date: Tue Apr 26 08:41:32 2016
  SourcePackage: gcc-defaults
  UpgradeStatus: No upgrade log present (probably fresh install)
  ---
  ApportVersion: 2.20.1-0ubuntu2
  Architecture: amd64
  AudioDevicesInUse:
   USERPID ACCESS COMMAND
   /dev/snd/controlC1:  oem2014 F pulseaudio
   /dev/snd/pcmC0D0p:   oem2014 F...m pulseaudio
   /dev/snd/controlC0:  oem2014 F pulseaudio
  CurrentDesktop: GNOME
  DistroRelease: Ubuntu 16.10
  HibernationDevice: RESUME=UUID=0a9ca7f0-6eeb-4b21-b70f-670fa600de16
  IwConfig:
   eth0  no wireless extensions.

   eth1  no wireless extensions.

   lono wireless extensions.
  Lsusb:
   Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
   Bus 003 Device 002: ID 046d:c062 Logitech, Inc. M-UAS144 [LS1 Laser Mouse]
   Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
   Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
  MachineType: ASUSTEK COMPUTER INC P5W DH Deluxe
  NonfreeKernelModules: nvidia_uvm nvidia_modeset nvidia
  Package: ubuntu
  ProcFB:

  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.4.0-21-generic 
root=UUID=7c755ed6-51cc-4b75-88ac-9c75acf82749 ro
  ProcVersionSignature: Ubuntu 4.4.0-21.37-generic 4.4.6
  RelatedPackageVersions:
   linux-restricted-modules-4.4.0-21-generic N/A
   linux-backports-modules-4.4.0-21-generic  N/A
   linux-firmware1.157
  RfKill:

  Tags:  yakkety
  Uname: Linux 4.4.0-21-generic x86_64
  UpgradeStatus: No upgrade log present (probably fresh install)
  UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
  _MarkForUpload: True
  dmi.bios.date: 07/22/2010
  dmi.bios.vendor: American Megatrends Inc.
  dmi.bios.version: 3002
  dmi.board.asset.tag: To Be Filled By O.E.M.
  dmi.board.name: P5W DH Deluxe
  dmi.board.vendor: ASUSTeK Computer INC.
  dmi.board.version: Rev 1.xx
  dmi.chassis.asset.tag: Asset-1234567890
  dmi.chassis.type: 3
  dmi.chassis.vendor: Chassis Manufacture
  dmi.chassis.version: Chassis Version
  dmi.modalias: 
dmi:bvnAmericanMegatrendsInc.:bvr3002:bd07/22/2010:svnASUSTEKCOMPUTERINC:pnP5WDHDeluxe:pvrSystemVersion:rvnASUSTeKComputerINC.:rnP5WDHDeluxe:rvrRev1.xx:cvnChassisManufacture:ct3:cvrChassisVersion:
  dmi.product.name: P5W DH Deluxe
  dmi.product.version: System Version
  dmi.sys.vendor: ASUSTEK COMPUTER INC

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/dkms/+bug/1574982/+subscriptions

-- 
Mailing list: https://launchpad.net/~kernel-packages
Post to : kernel-packages@lists.launchpad.net
Unsubscribe : 

[Kernel-packages] [Bug 1574982] Re: Cannot use CONFIG_CC_STACKPROTECTOR_STRONG: -fstack-protector-strong not supported by compiler

2016-05-10 Thread Kamal Mostafa
** Also affects: gcc-defaults (Ubuntu Xenial)
   Importance: Undecided
   Status: New

** Also affects: dkms (Ubuntu Xenial)
   Importance: Undecided
   Status: New

** Also affects: linux (Ubuntu Xenial)
   Importance: Undecided
   Status: New

** Changed in: linux (Ubuntu Xenial)
   Status: New => Fix Committed

** No longer affects: gcc-defaults (Ubuntu Xenial)

** Changed in: gcc-defaults (Ubuntu)
   Status: Invalid => New

** Changed in: gcc-defaults (Ubuntu)
   Status: New => Confirmed

-- 
You received this bug notification because you are a member of Kernel
Packages, which is subscribed to dkms in Ubuntu.
https://bugs.launchpad.net/bugs/1574982

Title:
  Cannot use CONFIG_CC_STACKPROTECTOR_STRONG: -fstack-protector-strong
  not supported by compiler

Status in dkms package in Ubuntu:
  Confirmed
Status in gcc-defaults package in Ubuntu:
  Confirmed
Status in linux package in Ubuntu:
  Confirmed
Status in dkms source package in Xenial:
  New
Status in linux source package in Xenial:
  Fix Committed

Bug description:
  Installing the latest 4.4.0-22 kernel ends with that error logged into 
dkmsbuildlog
  (only affect yakkety kernel; 4.4.0-22 kernel installation on xenial is fine)

  https://launchpadlibrarian.net/256055415/DKMSBuildLog.txt

  make "CC=cc"  KBUILD_VERBOSE= -C /lib/modules/4.4.0-22-generic/build 
M=/var/lib/dkms/nvidia-361/361.42/build ARCH=x86_64 
NV_KERNEL_SOURCES=/lib/modules/4.4.0-22-generic/build 
NV_KERNEL_OUTPUT=/lib/modules/4.4.0-22-generic/build NV_KERNEL_MODULES="nvidia 
nvidia-uvm nvidia-modeset" INSTALL_MOD_DIR=kernel/drivers/video modules
  make[1]: Entering directory '/usr/src/linux-headers-4.4.0-22-generic'
  arch/x86/Makefile:133: stack-protector enabled but compiler support broken
  Makefile:670: Cannot use CONFIG_CC_STACKPROTECTOR_STRONG: 
-fstack-protector-strong not supported by compiler

  the latest error logged is:

  /var/lib/dkms/nvidia-361/361.42/build/nvidia/nv-frontend.c:1:0: error:
  code model kernel does not support PIC mode

  Looks like it is related to the latest changes updates: gcc-6/gcc-5 
5.3.1-16ubuntu2 (some packages built with gcc-6; gcc-5 disabled for the 
packages built with gcc-6)
  Maybe some alternatives has not been updated to take care of these changes, 
as asked some time ago:
  http://askubuntu.com/questions/26498/choose-gcc-and-g-version

  This has been firstly reported against a nvidia crash:
  
https://bugs.launchpad.net/ubuntu/+source/nvidia-graphics-drivers-361/+bug/1574838

  ProblemType: Bug
  DistroRelease: Ubuntu 16.10
  Package: gcc 4:5.3.1-1ubuntu1
  ProcVersionSignature: Ubuntu 4.4.0-21.37-generic 4.4.6
  Uname: Linux 4.4.0-21-generic x86_64
  NonfreeKernelModules: nvidia_uvm nvidia_modeset nvidia
  ApportVersion: 2.20.1-0ubuntu2
  Architecture: amd64
  CurrentDesktop: GNOME
  Date: Tue Apr 26 08:41:32 2016
  SourcePackage: gcc-defaults
  UpgradeStatus: No upgrade log present (probably fresh install)
  ---
  ApportVersion: 2.20.1-0ubuntu2
  Architecture: amd64
  AudioDevicesInUse:
   USERPID ACCESS COMMAND
   /dev/snd/controlC1:  oem2014 F pulseaudio
   /dev/snd/pcmC0D0p:   oem2014 F...m pulseaudio
   /dev/snd/controlC0:  oem2014 F pulseaudio
  CurrentDesktop: GNOME
  DistroRelease: Ubuntu 16.10
  HibernationDevice: RESUME=UUID=0a9ca7f0-6eeb-4b21-b70f-670fa600de16
  IwConfig:
   eth0  no wireless extensions.

   eth1  no wireless extensions.

   lono wireless extensions.
  Lsusb:
   Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
   Bus 003 Device 002: ID 046d:c062 Logitech, Inc. M-UAS144 [LS1 Laser Mouse]
   Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
   Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
  MachineType: ASUSTEK COMPUTER INC P5W DH Deluxe
  NonfreeKernelModules: nvidia_uvm nvidia_modeset nvidia
  Package: ubuntu
  ProcFB:

  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.4.0-21-generic 
root=UUID=7c755ed6-51cc-4b75-88ac-9c75acf82749 ro
  ProcVersionSignature: Ubuntu 4.4.0-21.37-generic 4.4.6
  RelatedPackageVersions:
   linux-restricted-modules-4.4.0-21-generic N/A
   linux-backports-modules-4.4.0-21-generic  N/A
   linux-firmware1.157
  RfKill:

  Tags:  yakkety
  Uname: Linux 4.4.0-21-generic x86_64
  UpgradeStatus: No upgrade log present (probably fresh install)
  UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
  _MarkForUpload: True
  dmi.bios.date: 07/22/2010
  dmi.bios.vendor: American Megatrends Inc.
  dmi.bios.version: 3002
  dmi.board.asset.tag: To Be Filled By O.E.M.
  dmi.board.name: P5W DH Deluxe
  dmi.board.vendor: ASUSTeK Computer INC.
  dmi.board.version: Rev 1.xx
  dmi.chassis.asset.tag: Asset-1234567890
  dmi.chassis.type: 3
  dmi.chassis.vendor: Chassis Manufacture
  dmi.chassis.version: Chassis Version
  dmi.modalias: 

[Kernel-packages] [Bug 1574982] Re: Cannot use CONFIG_CC_STACKPROTECTOR_STRONG: -fstack-protector-strong not supported by compiler

2016-05-10 Thread Nazar Mokrynskyi
Will mentioned patch have potential to go upstream?

-- 
You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.
https://bugs.launchpad.net/bugs/1574982

Title:
  Cannot use CONFIG_CC_STACKPROTECTOR_STRONG: -fstack-protector-strong
  not supported by compiler

Status in dkms package in Ubuntu:
  Confirmed
Status in gcc-defaults package in Ubuntu:
  Invalid
Status in linux package in Ubuntu:
  Confirmed

Bug description:
  Installing the latest 4.4.0-22 kernel ends with that error logged into 
dkmsbuildlog
  (only affect yakkety kernel; 4.4.0-22 kernel installation on xenial is fine)

  https://launchpadlibrarian.net/256055415/DKMSBuildLog.txt

  make "CC=cc"  KBUILD_VERBOSE= -C /lib/modules/4.4.0-22-generic/build 
M=/var/lib/dkms/nvidia-361/361.42/build ARCH=x86_64 
NV_KERNEL_SOURCES=/lib/modules/4.4.0-22-generic/build 
NV_KERNEL_OUTPUT=/lib/modules/4.4.0-22-generic/build NV_KERNEL_MODULES="nvidia 
nvidia-uvm nvidia-modeset" INSTALL_MOD_DIR=kernel/drivers/video modules
  make[1]: Entering directory '/usr/src/linux-headers-4.4.0-22-generic'
  arch/x86/Makefile:133: stack-protector enabled but compiler support broken
  Makefile:670: Cannot use CONFIG_CC_STACKPROTECTOR_STRONG: 
-fstack-protector-strong not supported by compiler

  the latest error logged is:

  /var/lib/dkms/nvidia-361/361.42/build/nvidia/nv-frontend.c:1:0: error:
  code model kernel does not support PIC mode

  Looks like it is related to the latest changes updates: gcc-6/gcc-5 
5.3.1-16ubuntu2 (some packages built with gcc-6; gcc-5 disabled for the 
packages built with gcc-6)
  Maybe some alternatives has not been updated to take care of these changes, 
as asked some time ago:
  http://askubuntu.com/questions/26498/choose-gcc-and-g-version

  This has been firstly reported against a nvidia crash:
  
https://bugs.launchpad.net/ubuntu/+source/nvidia-graphics-drivers-361/+bug/1574838

  ProblemType: Bug
  DistroRelease: Ubuntu 16.10
  Package: gcc 4:5.3.1-1ubuntu1
  ProcVersionSignature: Ubuntu 4.4.0-21.37-generic 4.4.6
  Uname: Linux 4.4.0-21-generic x86_64
  NonfreeKernelModules: nvidia_uvm nvidia_modeset nvidia
  ApportVersion: 2.20.1-0ubuntu2
  Architecture: amd64
  CurrentDesktop: GNOME
  Date: Tue Apr 26 08:41:32 2016
  SourcePackage: gcc-defaults
  UpgradeStatus: No upgrade log present (probably fresh install)
  ---
  ApportVersion: 2.20.1-0ubuntu2
  Architecture: amd64
  AudioDevicesInUse:
   USERPID ACCESS COMMAND
   /dev/snd/controlC1:  oem2014 F pulseaudio
   /dev/snd/pcmC0D0p:   oem2014 F...m pulseaudio
   /dev/snd/controlC0:  oem2014 F pulseaudio
  CurrentDesktop: GNOME
  DistroRelease: Ubuntu 16.10
  HibernationDevice: RESUME=UUID=0a9ca7f0-6eeb-4b21-b70f-670fa600de16
  IwConfig:
   eth0  no wireless extensions.

   eth1  no wireless extensions.

   lono wireless extensions.
  Lsusb:
   Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
   Bus 003 Device 002: ID 046d:c062 Logitech, Inc. M-UAS144 [LS1 Laser Mouse]
   Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
   Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
  MachineType: ASUSTEK COMPUTER INC P5W DH Deluxe
  NonfreeKernelModules: nvidia_uvm nvidia_modeset nvidia
  Package: ubuntu
  ProcFB:

  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.4.0-21-generic 
root=UUID=7c755ed6-51cc-4b75-88ac-9c75acf82749 ro
  ProcVersionSignature: Ubuntu 4.4.0-21.37-generic 4.4.6
  RelatedPackageVersions:
   linux-restricted-modules-4.4.0-21-generic N/A
   linux-backports-modules-4.4.0-21-generic  N/A
   linux-firmware1.157
  RfKill:

  Tags:  yakkety
  Uname: Linux 4.4.0-21-generic x86_64
  UpgradeStatus: No upgrade log present (probably fresh install)
  UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
  _MarkForUpload: True
  dmi.bios.date: 07/22/2010
  dmi.bios.vendor: American Megatrends Inc.
  dmi.bios.version: 3002
  dmi.board.asset.tag: To Be Filled By O.E.M.
  dmi.board.name: P5W DH Deluxe
  dmi.board.vendor: ASUSTeK Computer INC.
  dmi.board.version: Rev 1.xx
  dmi.chassis.asset.tag: Asset-1234567890
  dmi.chassis.type: 3
  dmi.chassis.vendor: Chassis Manufacture
  dmi.chassis.version: Chassis Version
  dmi.modalias: 
dmi:bvnAmericanMegatrendsInc.:bvr3002:bd07/22/2010:svnASUSTEKCOMPUTERINC:pnP5WDHDeluxe:pvrSystemVersion:rvnASUSTeKComputerINC.:rnP5WDHDeluxe:rvrRev1.xx:cvnChassisManufacture:ct3:cvrChassisVersion:
  dmi.product.name: P5W DH Deluxe
  dmi.product.version: System Version
  dmi.sys.vendor: ASUSTEK COMPUTER INC

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/dkms/+bug/1574982/+subscriptions

-- 
Mailing list: https://launchpad.net/~kernel-packages
Post to : kernel-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~kernel-packages
More help   : https://help.launchpad.net/ListHelp


[Kernel-packages] [Bug 1574982] Re: Cannot use CONFIG_CC_STACKPROTECTOR_STRONG: -fstack-protector-strong not supported by compiler

2016-05-10 Thread Andy Whitcroft
Ok, we now have a minimal patch for the kernel to disable PIE. This
reflects into the headers packages so that DKMS packages building
against those will also have PIE disabled.  Will send to kernel-team@
for review once it passes final testing.

-- 
You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.
https://bugs.launchpad.net/bugs/1574982

Title:
  Cannot use CONFIG_CC_STACKPROTECTOR_STRONG: -fstack-protector-strong
  not supported by compiler

Status in dkms package in Ubuntu:
  Confirmed
Status in gcc-defaults package in Ubuntu:
  Invalid
Status in linux package in Ubuntu:
  Confirmed

Bug description:
  Installing the latest 4.4.0-22 kernel ends with that error logged into 
dkmsbuildlog
  (only affect yakkety kernel; 4.4.0-22 kernel installation on xenial is fine)

  https://launchpadlibrarian.net/256055415/DKMSBuildLog.txt

  make "CC=cc"  KBUILD_VERBOSE= -C /lib/modules/4.4.0-22-generic/build 
M=/var/lib/dkms/nvidia-361/361.42/build ARCH=x86_64 
NV_KERNEL_SOURCES=/lib/modules/4.4.0-22-generic/build 
NV_KERNEL_OUTPUT=/lib/modules/4.4.0-22-generic/build NV_KERNEL_MODULES="nvidia 
nvidia-uvm nvidia-modeset" INSTALL_MOD_DIR=kernel/drivers/video modules
  make[1]: Entering directory '/usr/src/linux-headers-4.4.0-22-generic'
  arch/x86/Makefile:133: stack-protector enabled but compiler support broken
  Makefile:670: Cannot use CONFIG_CC_STACKPROTECTOR_STRONG: 
-fstack-protector-strong not supported by compiler

  the latest error logged is:

  /var/lib/dkms/nvidia-361/361.42/build/nvidia/nv-frontend.c:1:0: error:
  code model kernel does not support PIC mode

  Looks like it is related to the latest changes updates: gcc-6/gcc-5 
5.3.1-16ubuntu2 (some packages built with gcc-6; gcc-5 disabled for the 
packages built with gcc-6)
  Maybe some alternatives has not been updated to take care of these changes, 
as asked some time ago:
  http://askubuntu.com/questions/26498/choose-gcc-and-g-version

  This has been firstly reported against a nvidia crash:
  
https://bugs.launchpad.net/ubuntu/+source/nvidia-graphics-drivers-361/+bug/1574838

  ProblemType: Bug
  DistroRelease: Ubuntu 16.10
  Package: gcc 4:5.3.1-1ubuntu1
  ProcVersionSignature: Ubuntu 4.4.0-21.37-generic 4.4.6
  Uname: Linux 4.4.0-21-generic x86_64
  NonfreeKernelModules: nvidia_uvm nvidia_modeset nvidia
  ApportVersion: 2.20.1-0ubuntu2
  Architecture: amd64
  CurrentDesktop: GNOME
  Date: Tue Apr 26 08:41:32 2016
  SourcePackage: gcc-defaults
  UpgradeStatus: No upgrade log present (probably fresh install)
  ---
  ApportVersion: 2.20.1-0ubuntu2
  Architecture: amd64
  AudioDevicesInUse:
   USERPID ACCESS COMMAND
   /dev/snd/controlC1:  oem2014 F pulseaudio
   /dev/snd/pcmC0D0p:   oem2014 F...m pulseaudio
   /dev/snd/controlC0:  oem2014 F pulseaudio
  CurrentDesktop: GNOME
  DistroRelease: Ubuntu 16.10
  HibernationDevice: RESUME=UUID=0a9ca7f0-6eeb-4b21-b70f-670fa600de16
  IwConfig:
   eth0  no wireless extensions.

   eth1  no wireless extensions.

   lono wireless extensions.
  Lsusb:
   Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
   Bus 003 Device 002: ID 046d:c062 Logitech, Inc. M-UAS144 [LS1 Laser Mouse]
   Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
   Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
  MachineType: ASUSTEK COMPUTER INC P5W DH Deluxe
  NonfreeKernelModules: nvidia_uvm nvidia_modeset nvidia
  Package: ubuntu
  ProcFB:

  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.4.0-21-generic 
root=UUID=7c755ed6-51cc-4b75-88ac-9c75acf82749 ro
  ProcVersionSignature: Ubuntu 4.4.0-21.37-generic 4.4.6
  RelatedPackageVersions:
   linux-restricted-modules-4.4.0-21-generic N/A
   linux-backports-modules-4.4.0-21-generic  N/A
   linux-firmware1.157
  RfKill:

  Tags:  yakkety
  Uname: Linux 4.4.0-21-generic x86_64
  UpgradeStatus: No upgrade log present (probably fresh install)
  UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
  _MarkForUpload: True
  dmi.bios.date: 07/22/2010
  dmi.bios.vendor: American Megatrends Inc.
  dmi.bios.version: 3002
  dmi.board.asset.tag: To Be Filled By O.E.M.
  dmi.board.name: P5W DH Deluxe
  dmi.board.vendor: ASUSTeK Computer INC.
  dmi.board.version: Rev 1.xx
  dmi.chassis.asset.tag: Asset-1234567890
  dmi.chassis.type: 3
  dmi.chassis.vendor: Chassis Manufacture
  dmi.chassis.version: Chassis Version
  dmi.modalias: 
dmi:bvnAmericanMegatrendsInc.:bvr3002:bd07/22/2010:svnASUSTEKCOMPUTERINC:pnP5WDHDeluxe:pvrSystemVersion:rvnASUSTeKComputerINC.:rnP5WDHDeluxe:rvrRev1.xx:cvnChassisManufacture:ct3:cvrChassisVersion:
  dmi.product.name: P5W DH Deluxe
  dmi.product.version: System Version
  dmi.sys.vendor: ASUSTEK COMPUTER INC

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/dkms/+bug/1574982/+subscriptions

-- 
Mailing list: https://launchpad.net/~kernel-packages
Post 

[Kernel-packages] [Bug 1574982] Re: Cannot use CONFIG_CC_STACKPROTECTOR_STRONG: -fstack-protector-strong not supported by compiler

2016-05-10 Thread LocutusOfBorg
You need to build the whole virtualbox, not only the host drivers.
I suspect you took the virtualbox-source package and did some module-assistant 
tricks.

-- 
You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.
https://bugs.launchpad.net/bugs/1574982

Title:
  Cannot use CONFIG_CC_STACKPROTECTOR_STRONG: -fstack-protector-strong
  not supported by compiler

Status in dkms package in Ubuntu:
  Confirmed
Status in gcc-defaults package in Ubuntu:
  Invalid
Status in linux package in Ubuntu:
  Confirmed

Bug description:
  Installing the latest 4.4.0-22 kernel ends with that error logged into 
dkmsbuildlog
  (only affect yakkety kernel; 4.4.0-22 kernel installation on xenial is fine)

  https://launchpadlibrarian.net/256055415/DKMSBuildLog.txt

  make "CC=cc"  KBUILD_VERBOSE= -C /lib/modules/4.4.0-22-generic/build 
M=/var/lib/dkms/nvidia-361/361.42/build ARCH=x86_64 
NV_KERNEL_SOURCES=/lib/modules/4.4.0-22-generic/build 
NV_KERNEL_OUTPUT=/lib/modules/4.4.0-22-generic/build NV_KERNEL_MODULES="nvidia 
nvidia-uvm nvidia-modeset" INSTALL_MOD_DIR=kernel/drivers/video modules
  make[1]: Entering directory '/usr/src/linux-headers-4.4.0-22-generic'
  arch/x86/Makefile:133: stack-protector enabled but compiler support broken
  Makefile:670: Cannot use CONFIG_CC_STACKPROTECTOR_STRONG: 
-fstack-protector-strong not supported by compiler

  the latest error logged is:

  /var/lib/dkms/nvidia-361/361.42/build/nvidia/nv-frontend.c:1:0: error:
  code model kernel does not support PIC mode

  Looks like it is related to the latest changes updates: gcc-6/gcc-5 
5.3.1-16ubuntu2 (some packages built with gcc-6; gcc-5 disabled for the 
packages built with gcc-6)
  Maybe some alternatives has not been updated to take care of these changes, 
as asked some time ago:
  http://askubuntu.com/questions/26498/choose-gcc-and-g-version

  This has been firstly reported against a nvidia crash:
  
https://bugs.launchpad.net/ubuntu/+source/nvidia-graphics-drivers-361/+bug/1574838

  ProblemType: Bug
  DistroRelease: Ubuntu 16.10
  Package: gcc 4:5.3.1-1ubuntu1
  ProcVersionSignature: Ubuntu 4.4.0-21.37-generic 4.4.6
  Uname: Linux 4.4.0-21-generic x86_64
  NonfreeKernelModules: nvidia_uvm nvidia_modeset nvidia
  ApportVersion: 2.20.1-0ubuntu2
  Architecture: amd64
  CurrentDesktop: GNOME
  Date: Tue Apr 26 08:41:32 2016
  SourcePackage: gcc-defaults
  UpgradeStatus: No upgrade log present (probably fresh install)
  ---
  ApportVersion: 2.20.1-0ubuntu2
  Architecture: amd64
  AudioDevicesInUse:
   USERPID ACCESS COMMAND
   /dev/snd/controlC1:  oem2014 F pulseaudio
   /dev/snd/pcmC0D0p:   oem2014 F...m pulseaudio
   /dev/snd/controlC0:  oem2014 F pulseaudio
  CurrentDesktop: GNOME
  DistroRelease: Ubuntu 16.10
  HibernationDevice: RESUME=UUID=0a9ca7f0-6eeb-4b21-b70f-670fa600de16
  IwConfig:
   eth0  no wireless extensions.

   eth1  no wireless extensions.

   lono wireless extensions.
  Lsusb:
   Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
   Bus 003 Device 002: ID 046d:c062 Logitech, Inc. M-UAS144 [LS1 Laser Mouse]
   Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
   Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
  MachineType: ASUSTEK COMPUTER INC P5W DH Deluxe
  NonfreeKernelModules: nvidia_uvm nvidia_modeset nvidia
  Package: ubuntu
  ProcFB:

  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.4.0-21-generic 
root=UUID=7c755ed6-51cc-4b75-88ac-9c75acf82749 ro
  ProcVersionSignature: Ubuntu 4.4.0-21.37-generic 4.4.6
  RelatedPackageVersions:
   linux-restricted-modules-4.4.0-21-generic N/A
   linux-backports-modules-4.4.0-21-generic  N/A
   linux-firmware1.157
  RfKill:

  Tags:  yakkety
  Uname: Linux 4.4.0-21-generic x86_64
  UpgradeStatus: No upgrade log present (probably fresh install)
  UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
  _MarkForUpload: True
  dmi.bios.date: 07/22/2010
  dmi.bios.vendor: American Megatrends Inc.
  dmi.bios.version: 3002
  dmi.board.asset.tag: To Be Filled By O.E.M.
  dmi.board.name: P5W DH Deluxe
  dmi.board.vendor: ASUSTeK Computer INC.
  dmi.board.version: Rev 1.xx
  dmi.chassis.asset.tag: Asset-1234567890
  dmi.chassis.type: 3
  dmi.chassis.vendor: Chassis Manufacture
  dmi.chassis.version: Chassis Version
  dmi.modalias: 
dmi:bvnAmericanMegatrendsInc.:bvr3002:bd07/22/2010:svnASUSTEKCOMPUTERINC:pnP5WDHDeluxe:pvrSystemVersion:rvnASUSTeKComputerINC.:rnP5WDHDeluxe:rvrRev1.xx:cvnChassisManufacture:ct3:cvrChassisVersion:
  dmi.product.name: P5W DH Deluxe
  dmi.product.version: System Version
  dmi.sys.vendor: ASUSTEK COMPUTER INC

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/dkms/+bug/1574982/+subscriptions

-- 
Mailing list: https://launchpad.net/~kernel-packages
Post to : kernel-packages@lists.launchpad.net
Unsubscribe : 

[Kernel-packages] [Bug 1574982] Re: Cannot use CONFIG_CC_STACKPROTECTOR_STRONG: -fstack-protector-strong not supported by compiler

2016-05-09 Thread Nazar Mokrynskyi
For virtualbox you should modify Makefile under following subdirectories
only: boxdrv, vboxnetapd, vboxnetflt and vboxpci.

The fix in #19 should be complete, since I'm currently on vanilla kernel
4.6.0-rc7 compiled with similar tweak and all modules compiled with
mentioned patches and Nvidia, VirtualBox and other stuff work
wonderfully.

If you've compiled Nvidia with incomplete patch first, try `dkms remove
...` for that module and then `dkms install ...` again to force it
recompile sources instead of using cached version.

-- 
You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.
https://bugs.launchpad.net/bugs/1574982

Title:
  Cannot use CONFIG_CC_STACKPROTECTOR_STRONG: -fstack-protector-strong
  not supported by compiler

Status in dkms package in Ubuntu:
  Confirmed
Status in gcc-defaults package in Ubuntu:
  Invalid
Status in linux package in Ubuntu:
  Confirmed

Bug description:
  Installing the latest 4.4.0-22 kernel ends with that error logged into 
dkmsbuildlog
  (only affect yakkety kernel; 4.4.0-22 kernel installation on xenial is fine)

  https://launchpadlibrarian.net/256055415/DKMSBuildLog.txt

  make "CC=cc"  KBUILD_VERBOSE= -C /lib/modules/4.4.0-22-generic/build 
M=/var/lib/dkms/nvidia-361/361.42/build ARCH=x86_64 
NV_KERNEL_SOURCES=/lib/modules/4.4.0-22-generic/build 
NV_KERNEL_OUTPUT=/lib/modules/4.4.0-22-generic/build NV_KERNEL_MODULES="nvidia 
nvidia-uvm nvidia-modeset" INSTALL_MOD_DIR=kernel/drivers/video modules
  make[1]: Entering directory '/usr/src/linux-headers-4.4.0-22-generic'
  arch/x86/Makefile:133: stack-protector enabled but compiler support broken
  Makefile:670: Cannot use CONFIG_CC_STACKPROTECTOR_STRONG: 
-fstack-protector-strong not supported by compiler

  the latest error logged is:

  /var/lib/dkms/nvidia-361/361.42/build/nvidia/nv-frontend.c:1:0: error:
  code model kernel does not support PIC mode

  Looks like it is related to the latest changes updates: gcc-6/gcc-5 
5.3.1-16ubuntu2 (some packages built with gcc-6; gcc-5 disabled for the 
packages built with gcc-6)
  Maybe some alternatives has not been updated to take care of these changes, 
as asked some time ago:
  http://askubuntu.com/questions/26498/choose-gcc-and-g-version

  This has been firstly reported against a nvidia crash:
  
https://bugs.launchpad.net/ubuntu/+source/nvidia-graphics-drivers-361/+bug/1574838

  ProblemType: Bug
  DistroRelease: Ubuntu 16.10
  Package: gcc 4:5.3.1-1ubuntu1
  ProcVersionSignature: Ubuntu 4.4.0-21.37-generic 4.4.6
  Uname: Linux 4.4.0-21-generic x86_64
  NonfreeKernelModules: nvidia_uvm nvidia_modeset nvidia
  ApportVersion: 2.20.1-0ubuntu2
  Architecture: amd64
  CurrentDesktop: GNOME
  Date: Tue Apr 26 08:41:32 2016
  SourcePackage: gcc-defaults
  UpgradeStatus: No upgrade log present (probably fresh install)
  ---
  ApportVersion: 2.20.1-0ubuntu2
  Architecture: amd64
  AudioDevicesInUse:
   USERPID ACCESS COMMAND
   /dev/snd/controlC1:  oem2014 F pulseaudio
   /dev/snd/pcmC0D0p:   oem2014 F...m pulseaudio
   /dev/snd/controlC0:  oem2014 F pulseaudio
  CurrentDesktop: GNOME
  DistroRelease: Ubuntu 16.10
  HibernationDevice: RESUME=UUID=0a9ca7f0-6eeb-4b21-b70f-670fa600de16
  IwConfig:
   eth0  no wireless extensions.

   eth1  no wireless extensions.

   lono wireless extensions.
  Lsusb:
   Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
   Bus 003 Device 002: ID 046d:c062 Logitech, Inc. M-UAS144 [LS1 Laser Mouse]
   Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
   Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
  MachineType: ASUSTEK COMPUTER INC P5W DH Deluxe
  NonfreeKernelModules: nvidia_uvm nvidia_modeset nvidia
  Package: ubuntu
  ProcFB:

  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.4.0-21-generic 
root=UUID=7c755ed6-51cc-4b75-88ac-9c75acf82749 ro
  ProcVersionSignature: Ubuntu 4.4.0-21.37-generic 4.4.6
  RelatedPackageVersions:
   linux-restricted-modules-4.4.0-21-generic N/A
   linux-backports-modules-4.4.0-21-generic  N/A
   linux-firmware1.157
  RfKill:

  Tags:  yakkety
  Uname: Linux 4.4.0-21-generic x86_64
  UpgradeStatus: No upgrade log present (probably fresh install)
  UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
  _MarkForUpload: True
  dmi.bios.date: 07/22/2010
  dmi.bios.vendor: American Megatrends Inc.
  dmi.bios.version: 3002
  dmi.board.asset.tag: To Be Filled By O.E.M.
  dmi.board.name: P5W DH Deluxe
  dmi.board.vendor: ASUSTeK Computer INC.
  dmi.board.version: Rev 1.xx
  dmi.chassis.asset.tag: Asset-1234567890
  dmi.chassis.type: 3
  dmi.chassis.vendor: Chassis Manufacture
  dmi.chassis.version: Chassis Version
  dmi.modalias: 
dmi:bvnAmericanMegatrendsInc.:bvr3002:bd07/22/2010:svnASUSTEKCOMPUTERINC:pnP5WDHDeluxe:pvrSystemVersion:rvnASUSTeKComputerINC.:rnP5WDHDeluxe:rvrRev1.xx:cvnChassisManufacture:ct3:cvrChassisVersion:
  

[Kernel-packages] [Bug 1574982] Re: Cannot use CONFIG_CC_STACKPROTECTOR_STRONG: -fstack-protector-strong not supported by compiler

2016-05-09 Thread dino99
Feedback_2

Try to boot with the 4.4.0-22 kernel: as the nvidia-361 module has been well 
compiled, i've made a cold boot.
The process goes well until the lightdm login screen: the password validation 
fails to load the nvidia graphic process, and bounce back to the login screen.

So the changes made (#19) is good enough to get a clean compilation, but
the fix is not complete

-- 
You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.
https://bugs.launchpad.net/bugs/1574982

Title:
  Cannot use CONFIG_CC_STACKPROTECTOR_STRONG: -fstack-protector-strong
  not supported by compiler

Status in dkms package in Ubuntu:
  Confirmed
Status in gcc-defaults package in Ubuntu:
  Invalid
Status in linux package in Ubuntu:
  Confirmed

Bug description:
  Installing the latest 4.4.0-22 kernel ends with that error logged into 
dkmsbuildlog
  (only affect yakkety kernel; 4.4.0-22 kernel installation on xenial is fine)

  https://launchpadlibrarian.net/256055415/DKMSBuildLog.txt

  make "CC=cc"  KBUILD_VERBOSE= -C /lib/modules/4.4.0-22-generic/build 
M=/var/lib/dkms/nvidia-361/361.42/build ARCH=x86_64 
NV_KERNEL_SOURCES=/lib/modules/4.4.0-22-generic/build 
NV_KERNEL_OUTPUT=/lib/modules/4.4.0-22-generic/build NV_KERNEL_MODULES="nvidia 
nvidia-uvm nvidia-modeset" INSTALL_MOD_DIR=kernel/drivers/video modules
  make[1]: Entering directory '/usr/src/linux-headers-4.4.0-22-generic'
  arch/x86/Makefile:133: stack-protector enabled but compiler support broken
  Makefile:670: Cannot use CONFIG_CC_STACKPROTECTOR_STRONG: 
-fstack-protector-strong not supported by compiler

  the latest error logged is:

  /var/lib/dkms/nvidia-361/361.42/build/nvidia/nv-frontend.c:1:0: error:
  code model kernel does not support PIC mode

  Looks like it is related to the latest changes updates: gcc-6/gcc-5 
5.3.1-16ubuntu2 (some packages built with gcc-6; gcc-5 disabled for the 
packages built with gcc-6)
  Maybe some alternatives has not been updated to take care of these changes, 
as asked some time ago:
  http://askubuntu.com/questions/26498/choose-gcc-and-g-version

  This has been firstly reported against a nvidia crash:
  
https://bugs.launchpad.net/ubuntu/+source/nvidia-graphics-drivers-361/+bug/1574838

  ProblemType: Bug
  DistroRelease: Ubuntu 16.10
  Package: gcc 4:5.3.1-1ubuntu1
  ProcVersionSignature: Ubuntu 4.4.0-21.37-generic 4.4.6
  Uname: Linux 4.4.0-21-generic x86_64
  NonfreeKernelModules: nvidia_uvm nvidia_modeset nvidia
  ApportVersion: 2.20.1-0ubuntu2
  Architecture: amd64
  CurrentDesktop: GNOME
  Date: Tue Apr 26 08:41:32 2016
  SourcePackage: gcc-defaults
  UpgradeStatus: No upgrade log present (probably fresh install)
  ---
  ApportVersion: 2.20.1-0ubuntu2
  Architecture: amd64
  AudioDevicesInUse:
   USERPID ACCESS COMMAND
   /dev/snd/controlC1:  oem2014 F pulseaudio
   /dev/snd/pcmC0D0p:   oem2014 F...m pulseaudio
   /dev/snd/controlC0:  oem2014 F pulseaudio
  CurrentDesktop: GNOME
  DistroRelease: Ubuntu 16.10
  HibernationDevice: RESUME=UUID=0a9ca7f0-6eeb-4b21-b70f-670fa600de16
  IwConfig:
   eth0  no wireless extensions.

   eth1  no wireless extensions.

   lono wireless extensions.
  Lsusb:
   Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
   Bus 003 Device 002: ID 046d:c062 Logitech, Inc. M-UAS144 [LS1 Laser Mouse]
   Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
   Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
  MachineType: ASUSTEK COMPUTER INC P5W DH Deluxe
  NonfreeKernelModules: nvidia_uvm nvidia_modeset nvidia
  Package: ubuntu
  ProcFB:

  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.4.0-21-generic 
root=UUID=7c755ed6-51cc-4b75-88ac-9c75acf82749 ro
  ProcVersionSignature: Ubuntu 4.4.0-21.37-generic 4.4.6
  RelatedPackageVersions:
   linux-restricted-modules-4.4.0-21-generic N/A
   linux-backports-modules-4.4.0-21-generic  N/A
   linux-firmware1.157
  RfKill:

  Tags:  yakkety
  Uname: Linux 4.4.0-21-generic x86_64
  UpgradeStatus: No upgrade log present (probably fresh install)
  UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
  _MarkForUpload: True
  dmi.bios.date: 07/22/2010
  dmi.bios.vendor: American Megatrends Inc.
  dmi.bios.version: 3002
  dmi.board.asset.tag: To Be Filled By O.E.M.
  dmi.board.name: P5W DH Deluxe
  dmi.board.vendor: ASUSTeK Computer INC.
  dmi.board.version: Rev 1.xx
  dmi.chassis.asset.tag: Asset-1234567890
  dmi.chassis.type: 3
  dmi.chassis.vendor: Chassis Manufacture
  dmi.chassis.version: Chassis Version
  dmi.modalias: 
dmi:bvnAmericanMegatrendsInc.:bvr3002:bd07/22/2010:svnASUSTEKCOMPUTERINC:pnP5WDHDeluxe:pvrSystemVersion:rvnASUSTeKComputerINC.:rnP5WDHDeluxe:rvrRev1.xx:cvnChassisManufacture:ct3:cvrChassisVersion:
  dmi.product.name: P5W DH Deluxe
  dmi.product.version: System Version
  dmi.sys.vendor: ASUSTEK COMPUTER INC

To manage notifications about this bug go to:

[Kernel-packages] [Bug 1574982] Re: Cannot use CONFIG_CC_STACKPROTECTOR_STRONG: -fstack-protector-strong not supported by compiler

2016-05-09 Thread dino99
Feedback

Following the #19 comment above, both nvidia-xxx and bbswitch compile as 
expected. But virtualbox (from oracle, as the ubuntu one is unistallable) fails:
- inserted "EXTRA_CFLAGS := -fno-pie -fno-stack-protector" into the many 
'Makefile' from /usr/src/... and /var/lib/dkms/  ; they are well saved
- but reinstalling virtualbox ends with a crash, and all the modified 
'Makefile' are reverted to their original status.

I may have miss something somewhere i suppose.

-- 
You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.
https://bugs.launchpad.net/bugs/1574982

Title:
  Cannot use CONFIG_CC_STACKPROTECTOR_STRONG: -fstack-protector-strong
  not supported by compiler

Status in dkms package in Ubuntu:
  Confirmed
Status in gcc-defaults package in Ubuntu:
  Invalid
Status in linux package in Ubuntu:
  Confirmed

Bug description:
  Installing the latest 4.4.0-22 kernel ends with that error logged into 
dkmsbuildlog
  (only affect yakkety kernel; 4.4.0-22 kernel installation on xenial is fine)

  https://launchpadlibrarian.net/256055415/DKMSBuildLog.txt

  make "CC=cc"  KBUILD_VERBOSE= -C /lib/modules/4.4.0-22-generic/build 
M=/var/lib/dkms/nvidia-361/361.42/build ARCH=x86_64 
NV_KERNEL_SOURCES=/lib/modules/4.4.0-22-generic/build 
NV_KERNEL_OUTPUT=/lib/modules/4.4.0-22-generic/build NV_KERNEL_MODULES="nvidia 
nvidia-uvm nvidia-modeset" INSTALL_MOD_DIR=kernel/drivers/video modules
  make[1]: Entering directory '/usr/src/linux-headers-4.4.0-22-generic'
  arch/x86/Makefile:133: stack-protector enabled but compiler support broken
  Makefile:670: Cannot use CONFIG_CC_STACKPROTECTOR_STRONG: 
-fstack-protector-strong not supported by compiler

  the latest error logged is:

  /var/lib/dkms/nvidia-361/361.42/build/nvidia/nv-frontend.c:1:0: error:
  code model kernel does not support PIC mode

  Looks like it is related to the latest changes updates: gcc-6/gcc-5 
5.3.1-16ubuntu2 (some packages built with gcc-6; gcc-5 disabled for the 
packages built with gcc-6)
  Maybe some alternatives has not been updated to take care of these changes, 
as asked some time ago:
  http://askubuntu.com/questions/26498/choose-gcc-and-g-version

  This has been firstly reported against a nvidia crash:
  
https://bugs.launchpad.net/ubuntu/+source/nvidia-graphics-drivers-361/+bug/1574838

  ProblemType: Bug
  DistroRelease: Ubuntu 16.10
  Package: gcc 4:5.3.1-1ubuntu1
  ProcVersionSignature: Ubuntu 4.4.0-21.37-generic 4.4.6
  Uname: Linux 4.4.0-21-generic x86_64
  NonfreeKernelModules: nvidia_uvm nvidia_modeset nvidia
  ApportVersion: 2.20.1-0ubuntu2
  Architecture: amd64
  CurrentDesktop: GNOME
  Date: Tue Apr 26 08:41:32 2016
  SourcePackage: gcc-defaults
  UpgradeStatus: No upgrade log present (probably fresh install)
  ---
  ApportVersion: 2.20.1-0ubuntu2
  Architecture: amd64
  AudioDevicesInUse:
   USERPID ACCESS COMMAND
   /dev/snd/controlC1:  oem2014 F pulseaudio
   /dev/snd/pcmC0D0p:   oem2014 F...m pulseaudio
   /dev/snd/controlC0:  oem2014 F pulseaudio
  CurrentDesktop: GNOME
  DistroRelease: Ubuntu 16.10
  HibernationDevice: RESUME=UUID=0a9ca7f0-6eeb-4b21-b70f-670fa600de16
  IwConfig:
   eth0  no wireless extensions.

   eth1  no wireless extensions.

   lono wireless extensions.
  Lsusb:
   Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
   Bus 003 Device 002: ID 046d:c062 Logitech, Inc. M-UAS144 [LS1 Laser Mouse]
   Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
   Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
  MachineType: ASUSTEK COMPUTER INC P5W DH Deluxe
  NonfreeKernelModules: nvidia_uvm nvidia_modeset nvidia
  Package: ubuntu
  ProcFB:

  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.4.0-21-generic 
root=UUID=7c755ed6-51cc-4b75-88ac-9c75acf82749 ro
  ProcVersionSignature: Ubuntu 4.4.0-21.37-generic 4.4.6
  RelatedPackageVersions:
   linux-restricted-modules-4.4.0-21-generic N/A
   linux-backports-modules-4.4.0-21-generic  N/A
   linux-firmware1.157
  RfKill:

  Tags:  yakkety
  Uname: Linux 4.4.0-21-generic x86_64
  UpgradeStatus: No upgrade log present (probably fresh install)
  UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
  _MarkForUpload: True
  dmi.bios.date: 07/22/2010
  dmi.bios.vendor: American Megatrends Inc.
  dmi.bios.version: 3002
  dmi.board.asset.tag: To Be Filled By O.E.M.
  dmi.board.name: P5W DH Deluxe
  dmi.board.vendor: ASUSTeK Computer INC.
  dmi.board.version: Rev 1.xx
  dmi.chassis.asset.tag: Asset-1234567890
  dmi.chassis.type: 3
  dmi.chassis.vendor: Chassis Manufacture
  dmi.chassis.version: Chassis Version
  dmi.modalias: 
dmi:bvnAmericanMegatrendsInc.:bvr3002:bd07/22/2010:svnASUSTEKCOMPUTERINC:pnP5WDHDeluxe:pvrSystemVersion:rvnASUSTeKComputerINC.:rnP5WDHDeluxe:rvrRev1.xx:cvnChassisManufacture:ct3:cvrChassisVersion:
  dmi.product.name: P5W DH Deluxe
  dmi.product.version: 

[Kernel-packages] [Bug 1574982] Re: Cannot use CONFIG_CC_STACKPROTECTOR_STRONG: -fstack-protector-strong not supported by compiler

2016-05-09 Thread LocutusOfBorg
Hi Nazar, I failed to make a vbox patch.
it fails now with some
"error: Missing # define g_kLdrRdrFileOps"

can you please share your patch?
thanks

-- 
You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.
https://bugs.launchpad.net/bugs/1574982

Title:
  Cannot use CONFIG_CC_STACKPROTECTOR_STRONG: -fstack-protector-strong
  not supported by compiler

Status in dkms package in Ubuntu:
  Confirmed
Status in gcc-defaults package in Ubuntu:
  Invalid
Status in linux package in Ubuntu:
  Confirmed

Bug description:
  Installing the latest 4.4.0-22 kernel ends with that error logged into 
dkmsbuildlog
  (only affect yakkety kernel; 4.4.0-22 kernel installation on xenial is fine)

  https://launchpadlibrarian.net/256055415/DKMSBuildLog.txt

  make "CC=cc"  KBUILD_VERBOSE= -C /lib/modules/4.4.0-22-generic/build 
M=/var/lib/dkms/nvidia-361/361.42/build ARCH=x86_64 
NV_KERNEL_SOURCES=/lib/modules/4.4.0-22-generic/build 
NV_KERNEL_OUTPUT=/lib/modules/4.4.0-22-generic/build NV_KERNEL_MODULES="nvidia 
nvidia-uvm nvidia-modeset" INSTALL_MOD_DIR=kernel/drivers/video modules
  make[1]: Entering directory '/usr/src/linux-headers-4.4.0-22-generic'
  arch/x86/Makefile:133: stack-protector enabled but compiler support broken
  Makefile:670: Cannot use CONFIG_CC_STACKPROTECTOR_STRONG: 
-fstack-protector-strong not supported by compiler

  the latest error logged is:

  /var/lib/dkms/nvidia-361/361.42/build/nvidia/nv-frontend.c:1:0: error:
  code model kernel does not support PIC mode

  Looks like it is related to the latest changes updates: gcc-6/gcc-5 
5.3.1-16ubuntu2 (some packages built with gcc-6; gcc-5 disabled for the 
packages built with gcc-6)
  Maybe some alternatives has not been updated to take care of these changes, 
as asked some time ago:
  http://askubuntu.com/questions/26498/choose-gcc-and-g-version

  This has been firstly reported against a nvidia crash:
  
https://bugs.launchpad.net/ubuntu/+source/nvidia-graphics-drivers-361/+bug/1574838

  ProblemType: Bug
  DistroRelease: Ubuntu 16.10
  Package: gcc 4:5.3.1-1ubuntu1
  ProcVersionSignature: Ubuntu 4.4.0-21.37-generic 4.4.6
  Uname: Linux 4.4.0-21-generic x86_64
  NonfreeKernelModules: nvidia_uvm nvidia_modeset nvidia
  ApportVersion: 2.20.1-0ubuntu2
  Architecture: amd64
  CurrentDesktop: GNOME
  Date: Tue Apr 26 08:41:32 2016
  SourcePackage: gcc-defaults
  UpgradeStatus: No upgrade log present (probably fresh install)
  ---
  ApportVersion: 2.20.1-0ubuntu2
  Architecture: amd64
  AudioDevicesInUse:
   USERPID ACCESS COMMAND
   /dev/snd/controlC1:  oem2014 F pulseaudio
   /dev/snd/pcmC0D0p:   oem2014 F...m pulseaudio
   /dev/snd/controlC0:  oem2014 F pulseaudio
  CurrentDesktop: GNOME
  DistroRelease: Ubuntu 16.10
  HibernationDevice: RESUME=UUID=0a9ca7f0-6eeb-4b21-b70f-670fa600de16
  IwConfig:
   eth0  no wireless extensions.

   eth1  no wireless extensions.

   lono wireless extensions.
  Lsusb:
   Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
   Bus 003 Device 002: ID 046d:c062 Logitech, Inc. M-UAS144 [LS1 Laser Mouse]
   Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
   Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
  MachineType: ASUSTEK COMPUTER INC P5W DH Deluxe
  NonfreeKernelModules: nvidia_uvm nvidia_modeset nvidia
  Package: ubuntu
  ProcFB:

  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.4.0-21-generic 
root=UUID=7c755ed6-51cc-4b75-88ac-9c75acf82749 ro
  ProcVersionSignature: Ubuntu 4.4.0-21.37-generic 4.4.6
  RelatedPackageVersions:
   linux-restricted-modules-4.4.0-21-generic N/A
   linux-backports-modules-4.4.0-21-generic  N/A
   linux-firmware1.157
  RfKill:

  Tags:  yakkety
  Uname: Linux 4.4.0-21-generic x86_64
  UpgradeStatus: No upgrade log present (probably fresh install)
  UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
  _MarkForUpload: True
  dmi.bios.date: 07/22/2010
  dmi.bios.vendor: American Megatrends Inc.
  dmi.bios.version: 3002
  dmi.board.asset.tag: To Be Filled By O.E.M.
  dmi.board.name: P5W DH Deluxe
  dmi.board.vendor: ASUSTeK Computer INC.
  dmi.board.version: Rev 1.xx
  dmi.chassis.asset.tag: Asset-1234567890
  dmi.chassis.type: 3
  dmi.chassis.vendor: Chassis Manufacture
  dmi.chassis.version: Chassis Version
  dmi.modalias: 
dmi:bvnAmericanMegatrendsInc.:bvr3002:bd07/22/2010:svnASUSTEKCOMPUTERINC:pnP5WDHDeluxe:pvrSystemVersion:rvnASUSTeKComputerINC.:rnP5WDHDeluxe:rvrRev1.xx:cvnChassisManufacture:ct3:cvrChassisVersion:
  dmi.product.name: P5W DH Deluxe
  dmi.product.version: System Version
  dmi.sys.vendor: ASUSTEK COMPUTER INC

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/dkms/+bug/1574982/+subscriptions

-- 
Mailing list: https://launchpad.net/~kernel-packages
Post to : kernel-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~kernel-packages

[Kernel-packages] [Bug 1574982] Re: Cannot use CONFIG_CC_STACKPROTECTOR_STRONG: -fstack-protector-strong not supported by compiler

2016-05-09 Thread iLogin
This error is somehow associated with this bug?

Additonal test failures with --enable-default-pie
https://gcc.gnu.org/bugzilla/show_bug.cgi?id=70150

11 test regressions when building GCC 6 with --enable-default-ssp
https://gcc.gnu.org/bugzilla/show_bug.cgi?id=70230

** Bug watch added: GCC Bugzilla #70150
   https://gcc.gnu.org/bugzilla/show_bug.cgi?id=70150

** Bug watch added: GCC Bugzilla #70230
   https://gcc.gnu.org/bugzilla/show_bug.cgi?id=70230

-- 
You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.
https://bugs.launchpad.net/bugs/1574982

Title:
  Cannot use CONFIG_CC_STACKPROTECTOR_STRONG: -fstack-protector-strong
  not supported by compiler

Status in dkms package in Ubuntu:
  Confirmed
Status in gcc-defaults package in Ubuntu:
  Invalid
Status in linux package in Ubuntu:
  Confirmed

Bug description:
  Installing the latest 4.4.0-22 kernel ends with that error logged into 
dkmsbuildlog
  (only affect yakkety kernel; 4.4.0-22 kernel installation on xenial is fine)

  https://launchpadlibrarian.net/256055415/DKMSBuildLog.txt

  make "CC=cc"  KBUILD_VERBOSE= -C /lib/modules/4.4.0-22-generic/build 
M=/var/lib/dkms/nvidia-361/361.42/build ARCH=x86_64 
NV_KERNEL_SOURCES=/lib/modules/4.4.0-22-generic/build 
NV_KERNEL_OUTPUT=/lib/modules/4.4.0-22-generic/build NV_KERNEL_MODULES="nvidia 
nvidia-uvm nvidia-modeset" INSTALL_MOD_DIR=kernel/drivers/video modules
  make[1]: Entering directory '/usr/src/linux-headers-4.4.0-22-generic'
  arch/x86/Makefile:133: stack-protector enabled but compiler support broken
  Makefile:670: Cannot use CONFIG_CC_STACKPROTECTOR_STRONG: 
-fstack-protector-strong not supported by compiler

  the latest error logged is:

  /var/lib/dkms/nvidia-361/361.42/build/nvidia/nv-frontend.c:1:0: error:
  code model kernel does not support PIC mode

  Looks like it is related to the latest changes updates: gcc-6/gcc-5 
5.3.1-16ubuntu2 (some packages built with gcc-6; gcc-5 disabled for the 
packages built with gcc-6)
  Maybe some alternatives has not been updated to take care of these changes, 
as asked some time ago:
  http://askubuntu.com/questions/26498/choose-gcc-and-g-version

  This has been firstly reported against a nvidia crash:
  
https://bugs.launchpad.net/ubuntu/+source/nvidia-graphics-drivers-361/+bug/1574838

  ProblemType: Bug
  DistroRelease: Ubuntu 16.10
  Package: gcc 4:5.3.1-1ubuntu1
  ProcVersionSignature: Ubuntu 4.4.0-21.37-generic 4.4.6
  Uname: Linux 4.4.0-21-generic x86_64
  NonfreeKernelModules: nvidia_uvm nvidia_modeset nvidia
  ApportVersion: 2.20.1-0ubuntu2
  Architecture: amd64
  CurrentDesktop: GNOME
  Date: Tue Apr 26 08:41:32 2016
  SourcePackage: gcc-defaults
  UpgradeStatus: No upgrade log present (probably fresh install)
  ---
  ApportVersion: 2.20.1-0ubuntu2
  Architecture: amd64
  AudioDevicesInUse:
   USERPID ACCESS COMMAND
   /dev/snd/controlC1:  oem2014 F pulseaudio
   /dev/snd/pcmC0D0p:   oem2014 F...m pulseaudio
   /dev/snd/controlC0:  oem2014 F pulseaudio
  CurrentDesktop: GNOME
  DistroRelease: Ubuntu 16.10
  HibernationDevice: RESUME=UUID=0a9ca7f0-6eeb-4b21-b70f-670fa600de16
  IwConfig:
   eth0  no wireless extensions.

   eth1  no wireless extensions.

   lono wireless extensions.
  Lsusb:
   Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
   Bus 003 Device 002: ID 046d:c062 Logitech, Inc. M-UAS144 [LS1 Laser Mouse]
   Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
   Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
  MachineType: ASUSTEK COMPUTER INC P5W DH Deluxe
  NonfreeKernelModules: nvidia_uvm nvidia_modeset nvidia
  Package: ubuntu
  ProcFB:

  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.4.0-21-generic 
root=UUID=7c755ed6-51cc-4b75-88ac-9c75acf82749 ro
  ProcVersionSignature: Ubuntu 4.4.0-21.37-generic 4.4.6
  RelatedPackageVersions:
   linux-restricted-modules-4.4.0-21-generic N/A
   linux-backports-modules-4.4.0-21-generic  N/A
   linux-firmware1.157
  RfKill:

  Tags:  yakkety
  Uname: Linux 4.4.0-21-generic x86_64
  UpgradeStatus: No upgrade log present (probably fresh install)
  UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
  _MarkForUpload: True
  dmi.bios.date: 07/22/2010
  dmi.bios.vendor: American Megatrends Inc.
  dmi.bios.version: 3002
  dmi.board.asset.tag: To Be Filled By O.E.M.
  dmi.board.name: P5W DH Deluxe
  dmi.board.vendor: ASUSTeK Computer INC.
  dmi.board.version: Rev 1.xx
  dmi.chassis.asset.tag: Asset-1234567890
  dmi.chassis.type: 3
  dmi.chassis.vendor: Chassis Manufacture
  dmi.chassis.version: Chassis Version
  dmi.modalias: 
dmi:bvnAmericanMegatrendsInc.:bvr3002:bd07/22/2010:svnASUSTEKCOMPUTERINC:pnP5WDHDeluxe:pvrSystemVersion:rvnASUSTeKComputerINC.:rnP5WDHDeluxe:rvrRev1.xx:cvnChassisManufacture:ct3:cvrChassisVersion:
  dmi.product.name: P5W DH Deluxe
  dmi.product.version: System Version
  

[Kernel-packages] [Bug 1574982] Re: Cannot use CONFIG_CC_STACKPROTECTOR_STRONG: -fstack-protector-strong not supported by compiler

2016-05-09 Thread Nazar Mokrynskyi
No, solution was incomplete.
Correct is following:
EXTRA_CFLAGS += -fno-pie -fno-stack-protector

Otherwise it compiles, but afterwards doesn't work and complains with
"Unknown symbol __stack_chk_fail (err 0)"

For all other modules (tried with bbswitch-0.8, tuxedo-wmo-1.5.1, 
virtualbox-5.0.18) just find corresponding Makefile (there are few of them in 
virtualbox directory) and add following at the beginning of the file:
EXTRA_CFLAGS := -fno-pie -fno-stack-protector

And it will also compile and work fine.

-- 
You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.
https://bugs.launchpad.net/bugs/1574982

Title:
  Cannot use CONFIG_CC_STACKPROTECTOR_STRONG: -fstack-protector-strong
  not supported by compiler

Status in dkms package in Ubuntu:
  Confirmed
Status in gcc-defaults package in Ubuntu:
  Invalid
Status in linux package in Ubuntu:
  Confirmed

Bug description:
  Installing the latest 4.4.0-22 kernel ends with that error logged into 
dkmsbuildlog
  (only affect yakkety kernel; 4.4.0-22 kernel installation on xenial is fine)

  https://launchpadlibrarian.net/256055415/DKMSBuildLog.txt

  make "CC=cc"  KBUILD_VERBOSE= -C /lib/modules/4.4.0-22-generic/build 
M=/var/lib/dkms/nvidia-361/361.42/build ARCH=x86_64 
NV_KERNEL_SOURCES=/lib/modules/4.4.0-22-generic/build 
NV_KERNEL_OUTPUT=/lib/modules/4.4.0-22-generic/build NV_KERNEL_MODULES="nvidia 
nvidia-uvm nvidia-modeset" INSTALL_MOD_DIR=kernel/drivers/video modules
  make[1]: Entering directory '/usr/src/linux-headers-4.4.0-22-generic'
  arch/x86/Makefile:133: stack-protector enabled but compiler support broken
  Makefile:670: Cannot use CONFIG_CC_STACKPROTECTOR_STRONG: 
-fstack-protector-strong not supported by compiler

  the latest error logged is:

  /var/lib/dkms/nvidia-361/361.42/build/nvidia/nv-frontend.c:1:0: error:
  code model kernel does not support PIC mode

  Looks like it is related to the latest changes updates: gcc-6/gcc-5 
5.3.1-16ubuntu2 (some packages built with gcc-6; gcc-5 disabled for the 
packages built with gcc-6)
  Maybe some alternatives has not been updated to take care of these changes, 
as asked some time ago:
  http://askubuntu.com/questions/26498/choose-gcc-and-g-version

  This has been firstly reported against a nvidia crash:
  
https://bugs.launchpad.net/ubuntu/+source/nvidia-graphics-drivers-361/+bug/1574838

  ProblemType: Bug
  DistroRelease: Ubuntu 16.10
  Package: gcc 4:5.3.1-1ubuntu1
  ProcVersionSignature: Ubuntu 4.4.0-21.37-generic 4.4.6
  Uname: Linux 4.4.0-21-generic x86_64
  NonfreeKernelModules: nvidia_uvm nvidia_modeset nvidia
  ApportVersion: 2.20.1-0ubuntu2
  Architecture: amd64
  CurrentDesktop: GNOME
  Date: Tue Apr 26 08:41:32 2016
  SourcePackage: gcc-defaults
  UpgradeStatus: No upgrade log present (probably fresh install)
  ---
  ApportVersion: 2.20.1-0ubuntu2
  Architecture: amd64
  AudioDevicesInUse:
   USERPID ACCESS COMMAND
   /dev/snd/controlC1:  oem2014 F pulseaudio
   /dev/snd/pcmC0D0p:   oem2014 F...m pulseaudio
   /dev/snd/controlC0:  oem2014 F pulseaudio
  CurrentDesktop: GNOME
  DistroRelease: Ubuntu 16.10
  HibernationDevice: RESUME=UUID=0a9ca7f0-6eeb-4b21-b70f-670fa600de16
  IwConfig:
   eth0  no wireless extensions.

   eth1  no wireless extensions.

   lono wireless extensions.
  Lsusb:
   Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
   Bus 003 Device 002: ID 046d:c062 Logitech, Inc. M-UAS144 [LS1 Laser Mouse]
   Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
   Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
  MachineType: ASUSTEK COMPUTER INC P5W DH Deluxe
  NonfreeKernelModules: nvidia_uvm nvidia_modeset nvidia
  Package: ubuntu
  ProcFB:

  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.4.0-21-generic 
root=UUID=7c755ed6-51cc-4b75-88ac-9c75acf82749 ro
  ProcVersionSignature: Ubuntu 4.4.0-21.37-generic 4.4.6
  RelatedPackageVersions:
   linux-restricted-modules-4.4.0-21-generic N/A
   linux-backports-modules-4.4.0-21-generic  N/A
   linux-firmware1.157
  RfKill:

  Tags:  yakkety
  Uname: Linux 4.4.0-21-generic x86_64
  UpgradeStatus: No upgrade log present (probably fresh install)
  UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
  _MarkForUpload: True
  dmi.bios.date: 07/22/2010
  dmi.bios.vendor: American Megatrends Inc.
  dmi.bios.version: 3002
  dmi.board.asset.tag: To Be Filled By O.E.M.
  dmi.board.name: P5W DH Deluxe
  dmi.board.vendor: ASUSTeK Computer INC.
  dmi.board.version: Rev 1.xx
  dmi.chassis.asset.tag: Asset-1234567890
  dmi.chassis.type: 3
  dmi.chassis.vendor: Chassis Manufacture
  dmi.chassis.version: Chassis Version
  dmi.modalias: 
dmi:bvnAmericanMegatrendsInc.:bvr3002:bd07/22/2010:svnASUSTEKCOMPUTERINC:pnP5WDHDeluxe:pvrSystemVersion:rvnASUSTeKComputerINC.:rnP5WDHDeluxe:rvrRev1.xx:cvnChassisManufacture:ct3:cvrChassisVersion:
  dmi.product.name: P5W DH 

[Kernel-packages] [Bug 1574982] Re: Cannot use CONFIG_CC_STACKPROTECTOR_STRONG: -fstack-protector-strong not supported by compiler

2016-05-08 Thread dino99
Thanks Nazar, your solution works fine. Still need a solution for the
bbswitch-dkms é virtualbox  crashes

-- 
You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.
https://bugs.launchpad.net/bugs/1574982

Title:
  Cannot use CONFIG_CC_STACKPROTECTOR_STRONG: -fstack-protector-strong
  not supported by compiler

Status in dkms package in Ubuntu:
  Confirmed
Status in gcc-defaults package in Ubuntu:
  Invalid
Status in linux package in Ubuntu:
  Confirmed

Bug description:
  Installing the latest 4.4.0-22 kernel ends with that error logged into 
dkmsbuildlog
  (only affect yakkety kernel; 4.4.0-22 kernel installation on xenial is fine)

  https://launchpadlibrarian.net/256055415/DKMSBuildLog.txt

  make "CC=cc"  KBUILD_VERBOSE= -C /lib/modules/4.4.0-22-generic/build 
M=/var/lib/dkms/nvidia-361/361.42/build ARCH=x86_64 
NV_KERNEL_SOURCES=/lib/modules/4.4.0-22-generic/build 
NV_KERNEL_OUTPUT=/lib/modules/4.4.0-22-generic/build NV_KERNEL_MODULES="nvidia 
nvidia-uvm nvidia-modeset" INSTALL_MOD_DIR=kernel/drivers/video modules
  make[1]: Entering directory '/usr/src/linux-headers-4.4.0-22-generic'
  arch/x86/Makefile:133: stack-protector enabled but compiler support broken
  Makefile:670: Cannot use CONFIG_CC_STACKPROTECTOR_STRONG: 
-fstack-protector-strong not supported by compiler

  the latest error logged is:

  /var/lib/dkms/nvidia-361/361.42/build/nvidia/nv-frontend.c:1:0: error:
  code model kernel does not support PIC mode

  Looks like it is related to the latest changes updates: gcc-6/gcc-5 
5.3.1-16ubuntu2 (some packages built with gcc-6; gcc-5 disabled for the 
packages built with gcc-6)
  Maybe some alternatives has not been updated to take care of these changes, 
as asked some time ago:
  http://askubuntu.com/questions/26498/choose-gcc-and-g-version

  This has been firstly reported against a nvidia crash:
  
https://bugs.launchpad.net/ubuntu/+source/nvidia-graphics-drivers-361/+bug/1574838

  ProblemType: Bug
  DistroRelease: Ubuntu 16.10
  Package: gcc 4:5.3.1-1ubuntu1
  ProcVersionSignature: Ubuntu 4.4.0-21.37-generic 4.4.6
  Uname: Linux 4.4.0-21-generic x86_64
  NonfreeKernelModules: nvidia_uvm nvidia_modeset nvidia
  ApportVersion: 2.20.1-0ubuntu2
  Architecture: amd64
  CurrentDesktop: GNOME
  Date: Tue Apr 26 08:41:32 2016
  SourcePackage: gcc-defaults
  UpgradeStatus: No upgrade log present (probably fresh install)
  ---
  ApportVersion: 2.20.1-0ubuntu2
  Architecture: amd64
  AudioDevicesInUse:
   USERPID ACCESS COMMAND
   /dev/snd/controlC1:  oem2014 F pulseaudio
   /dev/snd/pcmC0D0p:   oem2014 F...m pulseaudio
   /dev/snd/controlC0:  oem2014 F pulseaudio
  CurrentDesktop: GNOME
  DistroRelease: Ubuntu 16.10
  HibernationDevice: RESUME=UUID=0a9ca7f0-6eeb-4b21-b70f-670fa600de16
  IwConfig:
   eth0  no wireless extensions.

   eth1  no wireless extensions.

   lono wireless extensions.
  Lsusb:
   Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
   Bus 003 Device 002: ID 046d:c062 Logitech, Inc. M-UAS144 [LS1 Laser Mouse]
   Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
   Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
  MachineType: ASUSTEK COMPUTER INC P5W DH Deluxe
  NonfreeKernelModules: nvidia_uvm nvidia_modeset nvidia
  Package: ubuntu
  ProcFB:

  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.4.0-21-generic 
root=UUID=7c755ed6-51cc-4b75-88ac-9c75acf82749 ro
  ProcVersionSignature: Ubuntu 4.4.0-21.37-generic 4.4.6
  RelatedPackageVersions:
   linux-restricted-modules-4.4.0-21-generic N/A
   linux-backports-modules-4.4.0-21-generic  N/A
   linux-firmware1.157
  RfKill:

  Tags:  yakkety
  Uname: Linux 4.4.0-21-generic x86_64
  UpgradeStatus: No upgrade log present (probably fresh install)
  UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
  _MarkForUpload: True
  dmi.bios.date: 07/22/2010
  dmi.bios.vendor: American Megatrends Inc.
  dmi.bios.version: 3002
  dmi.board.asset.tag: To Be Filled By O.E.M.
  dmi.board.name: P5W DH Deluxe
  dmi.board.vendor: ASUSTeK Computer INC.
  dmi.board.version: Rev 1.xx
  dmi.chassis.asset.tag: Asset-1234567890
  dmi.chassis.type: 3
  dmi.chassis.vendor: Chassis Manufacture
  dmi.chassis.version: Chassis Version
  dmi.modalias: 
dmi:bvnAmericanMegatrendsInc.:bvr3002:bd07/22/2010:svnASUSTEKCOMPUTERINC:pnP5WDHDeluxe:pvrSystemVersion:rvnASUSTeKComputerINC.:rnP5WDHDeluxe:rvrRev1.xx:cvnChassisManufacture:ct3:cvrChassisVersion:
  dmi.product.name: P5W DH Deluxe
  dmi.product.version: System Version
  dmi.sys.vendor: ASUSTEK COMPUTER INC

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/dkms/+bug/1574982/+subscriptions

-- 
Mailing list: https://launchpad.net/~kernel-packages
Post to : kernel-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~kernel-packages
More help   : 

[Kernel-packages] [Bug 1574982] Re: Cannot use CONFIG_CC_STACKPROTECTOR_STRONG: -fstack-protector-strong not supported by compiler

2016-05-08 Thread Nazar Mokrynskyi
I've added:
EXTRA_CFLAGS += -fno-pie

In /usr/src/nvidia-364-364.19/Kbuild before line 59 and compilation of
Nvidia module using dkms succeeded.

-- 
You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.
https://bugs.launchpad.net/bugs/1574982

Title:
  Cannot use CONFIG_CC_STACKPROTECTOR_STRONG: -fstack-protector-strong
  not supported by compiler

Status in dkms package in Ubuntu:
  Confirmed
Status in gcc-defaults package in Ubuntu:
  Invalid
Status in linux package in Ubuntu:
  Confirmed

Bug description:
  Installing the latest 4.4.0-22 kernel ends with that error logged into 
dkmsbuildlog
  (only affect yakkety kernel; 4.4.0-22 kernel installation on xenial is fine)

  https://launchpadlibrarian.net/256055415/DKMSBuildLog.txt

  make "CC=cc"  KBUILD_VERBOSE= -C /lib/modules/4.4.0-22-generic/build 
M=/var/lib/dkms/nvidia-361/361.42/build ARCH=x86_64 
NV_KERNEL_SOURCES=/lib/modules/4.4.0-22-generic/build 
NV_KERNEL_OUTPUT=/lib/modules/4.4.0-22-generic/build NV_KERNEL_MODULES="nvidia 
nvidia-uvm nvidia-modeset" INSTALL_MOD_DIR=kernel/drivers/video modules
  make[1]: Entering directory '/usr/src/linux-headers-4.4.0-22-generic'
  arch/x86/Makefile:133: stack-protector enabled but compiler support broken
  Makefile:670: Cannot use CONFIG_CC_STACKPROTECTOR_STRONG: 
-fstack-protector-strong not supported by compiler

  the latest error logged is:

  /var/lib/dkms/nvidia-361/361.42/build/nvidia/nv-frontend.c:1:0: error:
  code model kernel does not support PIC mode

  Looks like it is related to the latest changes updates: gcc-6/gcc-5 
5.3.1-16ubuntu2 (some packages built with gcc-6; gcc-5 disabled for the 
packages built with gcc-6)
  Maybe some alternatives has not been updated to take care of these changes, 
as asked some time ago:
  http://askubuntu.com/questions/26498/choose-gcc-and-g-version

  This has been firstly reported against a nvidia crash:
  
https://bugs.launchpad.net/ubuntu/+source/nvidia-graphics-drivers-361/+bug/1574838

  ProblemType: Bug
  DistroRelease: Ubuntu 16.10
  Package: gcc 4:5.3.1-1ubuntu1
  ProcVersionSignature: Ubuntu 4.4.0-21.37-generic 4.4.6
  Uname: Linux 4.4.0-21-generic x86_64
  NonfreeKernelModules: nvidia_uvm nvidia_modeset nvidia
  ApportVersion: 2.20.1-0ubuntu2
  Architecture: amd64
  CurrentDesktop: GNOME
  Date: Tue Apr 26 08:41:32 2016
  SourcePackage: gcc-defaults
  UpgradeStatus: No upgrade log present (probably fresh install)
  ---
  ApportVersion: 2.20.1-0ubuntu2
  Architecture: amd64
  AudioDevicesInUse:
   USERPID ACCESS COMMAND
   /dev/snd/controlC1:  oem2014 F pulseaudio
   /dev/snd/pcmC0D0p:   oem2014 F...m pulseaudio
   /dev/snd/controlC0:  oem2014 F pulseaudio
  CurrentDesktop: GNOME
  DistroRelease: Ubuntu 16.10
  HibernationDevice: RESUME=UUID=0a9ca7f0-6eeb-4b21-b70f-670fa600de16
  IwConfig:
   eth0  no wireless extensions.

   eth1  no wireless extensions.

   lono wireless extensions.
  Lsusb:
   Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
   Bus 003 Device 002: ID 046d:c062 Logitech, Inc. M-UAS144 [LS1 Laser Mouse]
   Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
   Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
  MachineType: ASUSTEK COMPUTER INC P5W DH Deluxe
  NonfreeKernelModules: nvidia_uvm nvidia_modeset nvidia
  Package: ubuntu
  ProcFB:

  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.4.0-21-generic 
root=UUID=7c755ed6-51cc-4b75-88ac-9c75acf82749 ro
  ProcVersionSignature: Ubuntu 4.4.0-21.37-generic 4.4.6
  RelatedPackageVersions:
   linux-restricted-modules-4.4.0-21-generic N/A
   linux-backports-modules-4.4.0-21-generic  N/A
   linux-firmware1.157
  RfKill:

  Tags:  yakkety
  Uname: Linux 4.4.0-21-generic x86_64
  UpgradeStatus: No upgrade log present (probably fresh install)
  UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
  _MarkForUpload: True
  dmi.bios.date: 07/22/2010
  dmi.bios.vendor: American Megatrends Inc.
  dmi.bios.version: 3002
  dmi.board.asset.tag: To Be Filled By O.E.M.
  dmi.board.name: P5W DH Deluxe
  dmi.board.vendor: ASUSTeK Computer INC.
  dmi.board.version: Rev 1.xx
  dmi.chassis.asset.tag: Asset-1234567890
  dmi.chassis.type: 3
  dmi.chassis.vendor: Chassis Manufacture
  dmi.chassis.version: Chassis Version
  dmi.modalias: 
dmi:bvnAmericanMegatrendsInc.:bvr3002:bd07/22/2010:svnASUSTEKCOMPUTERINC:pnP5WDHDeluxe:pvrSystemVersion:rvnASUSTeKComputerINC.:rnP5WDHDeluxe:rvrRev1.xx:cvnChassisManufacture:ct3:cvrChassisVersion:
  dmi.product.name: P5W DH Deluxe
  dmi.product.version: System Version
  dmi.sys.vendor: ASUSTEK COMPUTER INC

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/dkms/+bug/1574982/+subscriptions

-- 
Mailing list: https://launchpad.net/~kernel-packages
Post to : kernel-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~kernel-packages

[Kernel-packages] [Bug 1574982] Re: Cannot use CONFIG_CC_STACKPROTECTOR_STRONG: -fstack-protector-strong not supported by compiler

2016-05-08 Thread Nazar Mokrynskyi
I was able to compile HHVM and Nvidia binary driver by reverting GCC
package to older version, now Xenial uses newer packages by default,
which makes compilation out of the box impossible.

This doesn't feel like dkms-specific issue, since HHVM is very different
thing and suffers from the same issue.

-- 
You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.
https://bugs.launchpad.net/bugs/1574982

Title:
  Cannot use CONFIG_CC_STACKPROTECTOR_STRONG: -fstack-protector-strong
  not supported by compiler

Status in dkms package in Ubuntu:
  Confirmed
Status in gcc-defaults package in Ubuntu:
  Invalid
Status in linux package in Ubuntu:
  Confirmed

Bug description:
  Installing the latest 4.4.0-22 kernel ends with that error logged into 
dkmsbuildlog
  (only affect yakkety kernel; 4.4.0-22 kernel installation on xenial is fine)

  https://launchpadlibrarian.net/256055415/DKMSBuildLog.txt

  make "CC=cc"  KBUILD_VERBOSE= -C /lib/modules/4.4.0-22-generic/build 
M=/var/lib/dkms/nvidia-361/361.42/build ARCH=x86_64 
NV_KERNEL_SOURCES=/lib/modules/4.4.0-22-generic/build 
NV_KERNEL_OUTPUT=/lib/modules/4.4.0-22-generic/build NV_KERNEL_MODULES="nvidia 
nvidia-uvm nvidia-modeset" INSTALL_MOD_DIR=kernel/drivers/video modules
  make[1]: Entering directory '/usr/src/linux-headers-4.4.0-22-generic'
  arch/x86/Makefile:133: stack-protector enabled but compiler support broken
  Makefile:670: Cannot use CONFIG_CC_STACKPROTECTOR_STRONG: 
-fstack-protector-strong not supported by compiler

  the latest error logged is:

  /var/lib/dkms/nvidia-361/361.42/build/nvidia/nv-frontend.c:1:0: error:
  code model kernel does not support PIC mode

  Looks like it is related to the latest changes updates: gcc-6/gcc-5 
5.3.1-16ubuntu2 (some packages built with gcc-6; gcc-5 disabled for the 
packages built with gcc-6)
  Maybe some alternatives has not been updated to take care of these changes, 
as asked some time ago:
  http://askubuntu.com/questions/26498/choose-gcc-and-g-version

  This has been firstly reported against a nvidia crash:
  
https://bugs.launchpad.net/ubuntu/+source/nvidia-graphics-drivers-361/+bug/1574838

  ProblemType: Bug
  DistroRelease: Ubuntu 16.10
  Package: gcc 4:5.3.1-1ubuntu1
  ProcVersionSignature: Ubuntu 4.4.0-21.37-generic 4.4.6
  Uname: Linux 4.4.0-21-generic x86_64
  NonfreeKernelModules: nvidia_uvm nvidia_modeset nvidia
  ApportVersion: 2.20.1-0ubuntu2
  Architecture: amd64
  CurrentDesktop: GNOME
  Date: Tue Apr 26 08:41:32 2016
  SourcePackage: gcc-defaults
  UpgradeStatus: No upgrade log present (probably fresh install)
  ---
  ApportVersion: 2.20.1-0ubuntu2
  Architecture: amd64
  AudioDevicesInUse:
   USERPID ACCESS COMMAND
   /dev/snd/controlC1:  oem2014 F pulseaudio
   /dev/snd/pcmC0D0p:   oem2014 F...m pulseaudio
   /dev/snd/controlC0:  oem2014 F pulseaudio
  CurrentDesktop: GNOME
  DistroRelease: Ubuntu 16.10
  HibernationDevice: RESUME=UUID=0a9ca7f0-6eeb-4b21-b70f-670fa600de16
  IwConfig:
   eth0  no wireless extensions.

   eth1  no wireless extensions.

   lono wireless extensions.
  Lsusb:
   Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
   Bus 003 Device 002: ID 046d:c062 Logitech, Inc. M-UAS144 [LS1 Laser Mouse]
   Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
   Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
  MachineType: ASUSTEK COMPUTER INC P5W DH Deluxe
  NonfreeKernelModules: nvidia_uvm nvidia_modeset nvidia
  Package: ubuntu
  ProcFB:

  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.4.0-21-generic 
root=UUID=7c755ed6-51cc-4b75-88ac-9c75acf82749 ro
  ProcVersionSignature: Ubuntu 4.4.0-21.37-generic 4.4.6
  RelatedPackageVersions:
   linux-restricted-modules-4.4.0-21-generic N/A
   linux-backports-modules-4.4.0-21-generic  N/A
   linux-firmware1.157
  RfKill:

  Tags:  yakkety
  Uname: Linux 4.4.0-21-generic x86_64
  UpgradeStatus: No upgrade log present (probably fresh install)
  UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
  _MarkForUpload: True
  dmi.bios.date: 07/22/2010
  dmi.bios.vendor: American Megatrends Inc.
  dmi.bios.version: 3002
  dmi.board.asset.tag: To Be Filled By O.E.M.
  dmi.board.name: P5W DH Deluxe
  dmi.board.vendor: ASUSTeK Computer INC.
  dmi.board.version: Rev 1.xx
  dmi.chassis.asset.tag: Asset-1234567890
  dmi.chassis.type: 3
  dmi.chassis.vendor: Chassis Manufacture
  dmi.chassis.version: Chassis Version
  dmi.modalias: 
dmi:bvnAmericanMegatrendsInc.:bvr3002:bd07/22/2010:svnASUSTEKCOMPUTERINC:pnP5WDHDeluxe:pvrSystemVersion:rvnASUSTeKComputerINC.:rnP5WDHDeluxe:rvrRev1.xx:cvnChassisManufacture:ct3:cvrChassisVersion:
  dmi.product.name: P5W DH Deluxe
  dmi.product.version: System Version
  dmi.sys.vendor: ASUSTEK COMPUTER INC

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/dkms/+bug/1574982/+subscriptions

-- 

[Kernel-packages] [Bug 1574982] Re: Cannot use CONFIG_CC_STACKPROTECTOR_STRONG: -fstack-protector-strong not supported by compiler

2016-05-08 Thread iLogin
https://launchpad.net/~canonical-kernel-team/+archive/ubuntu/ppa

linux - 4.6.0-2.3

in Makefile

# force no-pie for distro compilers that enable pie by default
KBUILD_CFLAGS += $(call cc-option, -fno-pie)
KBUILD_CFLAGS += $(call cc-option, -no-pie)
KBUILD_AFLAGS += $(call cc-option, -fno-pie)



-- 
You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.
https://bugs.launchpad.net/bugs/1574982

Title:
  Cannot use CONFIG_CC_STACKPROTECTOR_STRONG: -fstack-protector-strong
  not supported by compiler

Status in dkms package in Ubuntu:
  Confirmed
Status in gcc-defaults package in Ubuntu:
  Invalid
Status in linux package in Ubuntu:
  Confirmed

Bug description:
  Installing the latest 4.4.0-22 kernel ends with that error logged into 
dkmsbuildlog
  (only affect yakkety kernel; 4.4.0-22 kernel installation on xenial is fine)

  https://launchpadlibrarian.net/256055415/DKMSBuildLog.txt

  make "CC=cc"  KBUILD_VERBOSE= -C /lib/modules/4.4.0-22-generic/build 
M=/var/lib/dkms/nvidia-361/361.42/build ARCH=x86_64 
NV_KERNEL_SOURCES=/lib/modules/4.4.0-22-generic/build 
NV_KERNEL_OUTPUT=/lib/modules/4.4.0-22-generic/build NV_KERNEL_MODULES="nvidia 
nvidia-uvm nvidia-modeset" INSTALL_MOD_DIR=kernel/drivers/video modules
  make[1]: Entering directory '/usr/src/linux-headers-4.4.0-22-generic'
  arch/x86/Makefile:133: stack-protector enabled but compiler support broken
  Makefile:670: Cannot use CONFIG_CC_STACKPROTECTOR_STRONG: 
-fstack-protector-strong not supported by compiler

  the latest error logged is:

  /var/lib/dkms/nvidia-361/361.42/build/nvidia/nv-frontend.c:1:0: error:
  code model kernel does not support PIC mode

  Looks like it is related to the latest changes updates: gcc-6/gcc-5 
5.3.1-16ubuntu2 (some packages built with gcc-6; gcc-5 disabled for the 
packages built with gcc-6)
  Maybe some alternatives has not been updated to take care of these changes, 
as asked some time ago:
  http://askubuntu.com/questions/26498/choose-gcc-and-g-version

  This has been firstly reported against a nvidia crash:
  
https://bugs.launchpad.net/ubuntu/+source/nvidia-graphics-drivers-361/+bug/1574838

  ProblemType: Bug
  DistroRelease: Ubuntu 16.10
  Package: gcc 4:5.3.1-1ubuntu1
  ProcVersionSignature: Ubuntu 4.4.0-21.37-generic 4.4.6
  Uname: Linux 4.4.0-21-generic x86_64
  NonfreeKernelModules: nvidia_uvm nvidia_modeset nvidia
  ApportVersion: 2.20.1-0ubuntu2
  Architecture: amd64
  CurrentDesktop: GNOME
  Date: Tue Apr 26 08:41:32 2016
  SourcePackage: gcc-defaults
  UpgradeStatus: No upgrade log present (probably fresh install)
  ---
  ApportVersion: 2.20.1-0ubuntu2
  Architecture: amd64
  AudioDevicesInUse:
   USERPID ACCESS COMMAND
   /dev/snd/controlC1:  oem2014 F pulseaudio
   /dev/snd/pcmC0D0p:   oem2014 F...m pulseaudio
   /dev/snd/controlC0:  oem2014 F pulseaudio
  CurrentDesktop: GNOME
  DistroRelease: Ubuntu 16.10
  HibernationDevice: RESUME=UUID=0a9ca7f0-6eeb-4b21-b70f-670fa600de16
  IwConfig:
   eth0  no wireless extensions.

   eth1  no wireless extensions.

   lono wireless extensions.
  Lsusb:
   Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
   Bus 003 Device 002: ID 046d:c062 Logitech, Inc. M-UAS144 [LS1 Laser Mouse]
   Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
   Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
  MachineType: ASUSTEK COMPUTER INC P5W DH Deluxe
  NonfreeKernelModules: nvidia_uvm nvidia_modeset nvidia
  Package: ubuntu
  ProcFB:

  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.4.0-21-generic 
root=UUID=7c755ed6-51cc-4b75-88ac-9c75acf82749 ro
  ProcVersionSignature: Ubuntu 4.4.0-21.37-generic 4.4.6
  RelatedPackageVersions:
   linux-restricted-modules-4.4.0-21-generic N/A
   linux-backports-modules-4.4.0-21-generic  N/A
   linux-firmware1.157
  RfKill:

  Tags:  yakkety
  Uname: Linux 4.4.0-21-generic x86_64
  UpgradeStatus: No upgrade log present (probably fresh install)
  UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
  _MarkForUpload: True
  dmi.bios.date: 07/22/2010
  dmi.bios.vendor: American Megatrends Inc.
  dmi.bios.version: 3002
  dmi.board.asset.tag: To Be Filled By O.E.M.
  dmi.board.name: P5W DH Deluxe
  dmi.board.vendor: ASUSTeK Computer INC.
  dmi.board.version: Rev 1.xx
  dmi.chassis.asset.tag: Asset-1234567890
  dmi.chassis.type: 3
  dmi.chassis.vendor: Chassis Manufacture
  dmi.chassis.version: Chassis Version
  dmi.modalias: 
dmi:bvnAmericanMegatrendsInc.:bvr3002:bd07/22/2010:svnASUSTEKCOMPUTERINC:pnP5WDHDeluxe:pvrSystemVersion:rvnASUSTeKComputerINC.:rnP5WDHDeluxe:rvrRev1.xx:cvnChassisManufacture:ct3:cvrChassisVersion:
  dmi.product.name: P5W DH Deluxe
  dmi.product.version: System Version
  dmi.sys.vendor: ASUSTEK COMPUTER INC

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/dkms/+bug/1574982/+subscriptions

-- 

[Kernel-packages] [Bug 1574982] Re: Cannot use CONFIG_CC_STACKPROTECTOR_STRONG: -fstack-protector-strong not supported by compiler

2016-05-08 Thread dino99
@David
Matthias have set gcc-defaults to 'invalid' (#7); maybe needs to set gcc-6 
instead (or gcc-5; does not know which one is used in that case)

-- 
You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.
https://bugs.launchpad.net/bugs/1574982

Title:
  Cannot use CONFIG_CC_STACKPROTECTOR_STRONG: -fstack-protector-strong
  not supported by compiler

Status in dkms package in Ubuntu:
  Confirmed
Status in gcc-defaults package in Ubuntu:
  Invalid
Status in linux package in Ubuntu:
  Confirmed

Bug description:
  Installing the latest 4.4.0-22 kernel ends with that error logged into 
dkmsbuildlog
  (only affect yakkety kernel; 4.4.0-22 kernel installation on xenial is fine)

  https://launchpadlibrarian.net/256055415/DKMSBuildLog.txt

  make "CC=cc"  KBUILD_VERBOSE= -C /lib/modules/4.4.0-22-generic/build 
M=/var/lib/dkms/nvidia-361/361.42/build ARCH=x86_64 
NV_KERNEL_SOURCES=/lib/modules/4.4.0-22-generic/build 
NV_KERNEL_OUTPUT=/lib/modules/4.4.0-22-generic/build NV_KERNEL_MODULES="nvidia 
nvidia-uvm nvidia-modeset" INSTALL_MOD_DIR=kernel/drivers/video modules
  make[1]: Entering directory '/usr/src/linux-headers-4.4.0-22-generic'
  arch/x86/Makefile:133: stack-protector enabled but compiler support broken
  Makefile:670: Cannot use CONFIG_CC_STACKPROTECTOR_STRONG: 
-fstack-protector-strong not supported by compiler

  the latest error logged is:

  /var/lib/dkms/nvidia-361/361.42/build/nvidia/nv-frontend.c:1:0: error:
  code model kernel does not support PIC mode

  Looks like it is related to the latest changes updates: gcc-6/gcc-5 
5.3.1-16ubuntu2 (some packages built with gcc-6; gcc-5 disabled for the 
packages built with gcc-6)
  Maybe some alternatives has not been updated to take care of these changes, 
as asked some time ago:
  http://askubuntu.com/questions/26498/choose-gcc-and-g-version

  This has been firstly reported against a nvidia crash:
  
https://bugs.launchpad.net/ubuntu/+source/nvidia-graphics-drivers-361/+bug/1574838

  ProblemType: Bug
  DistroRelease: Ubuntu 16.10
  Package: gcc 4:5.3.1-1ubuntu1
  ProcVersionSignature: Ubuntu 4.4.0-21.37-generic 4.4.6
  Uname: Linux 4.4.0-21-generic x86_64
  NonfreeKernelModules: nvidia_uvm nvidia_modeset nvidia
  ApportVersion: 2.20.1-0ubuntu2
  Architecture: amd64
  CurrentDesktop: GNOME
  Date: Tue Apr 26 08:41:32 2016
  SourcePackage: gcc-defaults
  UpgradeStatus: No upgrade log present (probably fresh install)
  ---
  ApportVersion: 2.20.1-0ubuntu2
  Architecture: amd64
  AudioDevicesInUse:
   USERPID ACCESS COMMAND
   /dev/snd/controlC1:  oem2014 F pulseaudio
   /dev/snd/pcmC0D0p:   oem2014 F...m pulseaudio
   /dev/snd/controlC0:  oem2014 F pulseaudio
  CurrentDesktop: GNOME
  DistroRelease: Ubuntu 16.10
  HibernationDevice: RESUME=UUID=0a9ca7f0-6eeb-4b21-b70f-670fa600de16
  IwConfig:
   eth0  no wireless extensions.

   eth1  no wireless extensions.

   lono wireless extensions.
  Lsusb:
   Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
   Bus 003 Device 002: ID 046d:c062 Logitech, Inc. M-UAS144 [LS1 Laser Mouse]
   Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
   Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
  MachineType: ASUSTEK COMPUTER INC P5W DH Deluxe
  NonfreeKernelModules: nvidia_uvm nvidia_modeset nvidia
  Package: ubuntu
  ProcFB:

  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.4.0-21-generic 
root=UUID=7c755ed6-51cc-4b75-88ac-9c75acf82749 ro
  ProcVersionSignature: Ubuntu 4.4.0-21.37-generic 4.4.6
  RelatedPackageVersions:
   linux-restricted-modules-4.4.0-21-generic N/A
   linux-backports-modules-4.4.0-21-generic  N/A
   linux-firmware1.157
  RfKill:

  Tags:  yakkety
  Uname: Linux 4.4.0-21-generic x86_64
  UpgradeStatus: No upgrade log present (probably fresh install)
  UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
  _MarkForUpload: True
  dmi.bios.date: 07/22/2010
  dmi.bios.vendor: American Megatrends Inc.
  dmi.bios.version: 3002
  dmi.board.asset.tag: To Be Filled By O.E.M.
  dmi.board.name: P5W DH Deluxe
  dmi.board.vendor: ASUSTeK Computer INC.
  dmi.board.version: Rev 1.xx
  dmi.chassis.asset.tag: Asset-1234567890
  dmi.chassis.type: 3
  dmi.chassis.vendor: Chassis Manufacture
  dmi.chassis.version: Chassis Version
  dmi.modalias: 
dmi:bvnAmericanMegatrendsInc.:bvr3002:bd07/22/2010:svnASUSTEKCOMPUTERINC:pnP5WDHDeluxe:pvrSystemVersion:rvnASUSTeKComputerINC.:rnP5WDHDeluxe:rvrRev1.xx:cvnChassisManufacture:ct3:cvrChassisVersion:
  dmi.product.name: P5W DH Deluxe
  dmi.product.version: System Version
  dmi.sys.vendor: ASUSTEK COMPUTER INC

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/dkms/+bug/1574982/+subscriptions

-- 
Mailing list: https://launchpad.net/~kernel-packages
Post to : kernel-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~kernel-packages

[Kernel-packages] [Bug 1574982] Re: Cannot use CONFIG_CC_STACKPROTECTOR_STRONG: -fstack-protector-strong not supported by compiler

2016-05-08 Thread David Daynard
This seems to be a bug in gcc itself. It should automatically disable
PIE when -mcmodel=kernel or when __KERNEL__ is passed in a header.
Attempts to compile using no PIE command line flags don't work either.
It's as if it's not allowing it to be turned back off.

-- 
You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.
https://bugs.launchpad.net/bugs/1574982

Title:
  Cannot use CONFIG_CC_STACKPROTECTOR_STRONG: -fstack-protector-strong
  not supported by compiler

Status in dkms package in Ubuntu:
  Confirmed
Status in gcc-defaults package in Ubuntu:
  Invalid
Status in linux package in Ubuntu:
  Confirmed

Bug description:
  Installing the latest 4.4.0-22 kernel ends with that error logged into 
dkmsbuildlog
  (only affect yakkety kernel; 4.4.0-22 kernel installation on xenial is fine)

  https://launchpadlibrarian.net/256055415/DKMSBuildLog.txt

  make "CC=cc"  KBUILD_VERBOSE= -C /lib/modules/4.4.0-22-generic/build 
M=/var/lib/dkms/nvidia-361/361.42/build ARCH=x86_64 
NV_KERNEL_SOURCES=/lib/modules/4.4.0-22-generic/build 
NV_KERNEL_OUTPUT=/lib/modules/4.4.0-22-generic/build NV_KERNEL_MODULES="nvidia 
nvidia-uvm nvidia-modeset" INSTALL_MOD_DIR=kernel/drivers/video modules
  make[1]: Entering directory '/usr/src/linux-headers-4.4.0-22-generic'
  arch/x86/Makefile:133: stack-protector enabled but compiler support broken
  Makefile:670: Cannot use CONFIG_CC_STACKPROTECTOR_STRONG: 
-fstack-protector-strong not supported by compiler

  the latest error logged is:

  /var/lib/dkms/nvidia-361/361.42/build/nvidia/nv-frontend.c:1:0: error:
  code model kernel does not support PIC mode

  Looks like it is related to the latest changes updates: gcc-6/gcc-5 
5.3.1-16ubuntu2 (some packages built with gcc-6; gcc-5 disabled for the 
packages built with gcc-6)
  Maybe some alternatives has not been updated to take care of these changes, 
as asked some time ago:
  http://askubuntu.com/questions/26498/choose-gcc-and-g-version

  This has been firstly reported against a nvidia crash:
  
https://bugs.launchpad.net/ubuntu/+source/nvidia-graphics-drivers-361/+bug/1574838

  ProblemType: Bug
  DistroRelease: Ubuntu 16.10
  Package: gcc 4:5.3.1-1ubuntu1
  ProcVersionSignature: Ubuntu 4.4.0-21.37-generic 4.4.6
  Uname: Linux 4.4.0-21-generic x86_64
  NonfreeKernelModules: nvidia_uvm nvidia_modeset nvidia
  ApportVersion: 2.20.1-0ubuntu2
  Architecture: amd64
  CurrentDesktop: GNOME
  Date: Tue Apr 26 08:41:32 2016
  SourcePackage: gcc-defaults
  UpgradeStatus: No upgrade log present (probably fresh install)
  ---
  ApportVersion: 2.20.1-0ubuntu2
  Architecture: amd64
  AudioDevicesInUse:
   USERPID ACCESS COMMAND
   /dev/snd/controlC1:  oem2014 F pulseaudio
   /dev/snd/pcmC0D0p:   oem2014 F...m pulseaudio
   /dev/snd/controlC0:  oem2014 F pulseaudio
  CurrentDesktop: GNOME
  DistroRelease: Ubuntu 16.10
  HibernationDevice: RESUME=UUID=0a9ca7f0-6eeb-4b21-b70f-670fa600de16
  IwConfig:
   eth0  no wireless extensions.

   eth1  no wireless extensions.

   lono wireless extensions.
  Lsusb:
   Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
   Bus 003 Device 002: ID 046d:c062 Logitech, Inc. M-UAS144 [LS1 Laser Mouse]
   Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
   Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
  MachineType: ASUSTEK COMPUTER INC P5W DH Deluxe
  NonfreeKernelModules: nvidia_uvm nvidia_modeset nvidia
  Package: ubuntu
  ProcFB:

  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.4.0-21-generic 
root=UUID=7c755ed6-51cc-4b75-88ac-9c75acf82749 ro
  ProcVersionSignature: Ubuntu 4.4.0-21.37-generic 4.4.6
  RelatedPackageVersions:
   linux-restricted-modules-4.4.0-21-generic N/A
   linux-backports-modules-4.4.0-21-generic  N/A
   linux-firmware1.157
  RfKill:

  Tags:  yakkety
  Uname: Linux 4.4.0-21-generic x86_64
  UpgradeStatus: No upgrade log present (probably fresh install)
  UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
  _MarkForUpload: True
  dmi.bios.date: 07/22/2010
  dmi.bios.vendor: American Megatrends Inc.
  dmi.bios.version: 3002
  dmi.board.asset.tag: To Be Filled By O.E.M.
  dmi.board.name: P5W DH Deluxe
  dmi.board.vendor: ASUSTeK Computer INC.
  dmi.board.version: Rev 1.xx
  dmi.chassis.asset.tag: Asset-1234567890
  dmi.chassis.type: 3
  dmi.chassis.vendor: Chassis Manufacture
  dmi.chassis.version: Chassis Version
  dmi.modalias: 
dmi:bvnAmericanMegatrendsInc.:bvr3002:bd07/22/2010:svnASUSTEKCOMPUTERINC:pnP5WDHDeluxe:pvrSystemVersion:rvnASUSTeKComputerINC.:rnP5WDHDeluxe:rvrRev1.xx:cvnChassisManufacture:ct3:cvrChassisVersion:
  dmi.product.name: P5W DH Deluxe
  dmi.product.version: System Version
  dmi.sys.vendor: ASUSTEK COMPUTER INC

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/dkms/+bug/1574982/+subscriptions

-- 
Mailing list: 

[Kernel-packages] [Bug 1574982] Re: Cannot use CONFIG_CC_STACKPROTECTOR_STRONG: -fstack-protector-strong not supported by compiler

2016-04-29 Thread dino99
dpkg still needs to be used with the good flags  Bug #1576915

-- 
You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.
https://bugs.launchpad.net/bugs/1574982

Title:
  Cannot use CONFIG_CC_STACKPROTECTOR_STRONG: -fstack-protector-strong
  not supported by compiler

Status in dkms package in Ubuntu:
  Confirmed
Status in gcc-defaults package in Ubuntu:
  Invalid
Status in linux package in Ubuntu:
  Confirmed

Bug description:
  Installing the latest 4.4.0-22 kernel ends with that error logged into 
dkmsbuildlog
  (only affect yakkety kernel; 4.4.0-22 kernel installation on xenial is fine)

  https://launchpadlibrarian.net/256055415/DKMSBuildLog.txt

  make "CC=cc"  KBUILD_VERBOSE= -C /lib/modules/4.4.0-22-generic/build 
M=/var/lib/dkms/nvidia-361/361.42/build ARCH=x86_64 
NV_KERNEL_SOURCES=/lib/modules/4.4.0-22-generic/build 
NV_KERNEL_OUTPUT=/lib/modules/4.4.0-22-generic/build NV_KERNEL_MODULES="nvidia 
nvidia-uvm nvidia-modeset" INSTALL_MOD_DIR=kernel/drivers/video modules
  make[1]: Entering directory '/usr/src/linux-headers-4.4.0-22-generic'
  arch/x86/Makefile:133: stack-protector enabled but compiler support broken
  Makefile:670: Cannot use CONFIG_CC_STACKPROTECTOR_STRONG: 
-fstack-protector-strong not supported by compiler

  the latest error logged is:

  /var/lib/dkms/nvidia-361/361.42/build/nvidia/nv-frontend.c:1:0: error:
  code model kernel does not support PIC mode

  Looks like it is related to the latest changes updates: gcc-6/gcc-5 
5.3.1-16ubuntu2 (some packages built with gcc-6; gcc-5 disabled for the 
packages built with gcc-6)
  Maybe some alternatives has not been updated to take care of these changes, 
as asked some time ago:
  http://askubuntu.com/questions/26498/choose-gcc-and-g-version

  This has been firstly reported against a nvidia crash:
  
https://bugs.launchpad.net/ubuntu/+source/nvidia-graphics-drivers-361/+bug/1574838

  ProblemType: Bug
  DistroRelease: Ubuntu 16.10
  Package: gcc 4:5.3.1-1ubuntu1
  ProcVersionSignature: Ubuntu 4.4.0-21.37-generic 4.4.6
  Uname: Linux 4.4.0-21-generic x86_64
  NonfreeKernelModules: nvidia_uvm nvidia_modeset nvidia
  ApportVersion: 2.20.1-0ubuntu2
  Architecture: amd64
  CurrentDesktop: GNOME
  Date: Tue Apr 26 08:41:32 2016
  SourcePackage: gcc-defaults
  UpgradeStatus: No upgrade log present (probably fresh install)
  ---
  ApportVersion: 2.20.1-0ubuntu2
  Architecture: amd64
  AudioDevicesInUse:
   USERPID ACCESS COMMAND
   /dev/snd/controlC1:  oem2014 F pulseaudio
   /dev/snd/pcmC0D0p:   oem2014 F...m pulseaudio
   /dev/snd/controlC0:  oem2014 F pulseaudio
  CurrentDesktop: GNOME
  DistroRelease: Ubuntu 16.10
  HibernationDevice: RESUME=UUID=0a9ca7f0-6eeb-4b21-b70f-670fa600de16
  IwConfig:
   eth0  no wireless extensions.

   eth1  no wireless extensions.

   lono wireless extensions.
  Lsusb:
   Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
   Bus 003 Device 002: ID 046d:c062 Logitech, Inc. M-UAS144 [LS1 Laser Mouse]
   Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
   Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
  MachineType: ASUSTEK COMPUTER INC P5W DH Deluxe
  NonfreeKernelModules: nvidia_uvm nvidia_modeset nvidia
  Package: ubuntu
  ProcFB:

  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.4.0-21-generic 
root=UUID=7c755ed6-51cc-4b75-88ac-9c75acf82749 ro
  ProcVersionSignature: Ubuntu 4.4.0-21.37-generic 4.4.6
  RelatedPackageVersions:
   linux-restricted-modules-4.4.0-21-generic N/A
   linux-backports-modules-4.4.0-21-generic  N/A
   linux-firmware1.157
  RfKill:

  Tags:  yakkety
  Uname: Linux 4.4.0-21-generic x86_64
  UpgradeStatus: No upgrade log present (probably fresh install)
  UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
  _MarkForUpload: True
  dmi.bios.date: 07/22/2010
  dmi.bios.vendor: American Megatrends Inc.
  dmi.bios.version: 3002
  dmi.board.asset.tag: To Be Filled By O.E.M.
  dmi.board.name: P5W DH Deluxe
  dmi.board.vendor: ASUSTeK Computer INC.
  dmi.board.version: Rev 1.xx
  dmi.chassis.asset.tag: Asset-1234567890
  dmi.chassis.type: 3
  dmi.chassis.vendor: Chassis Manufacture
  dmi.chassis.version: Chassis Version
  dmi.modalias: 
dmi:bvnAmericanMegatrendsInc.:bvr3002:bd07/22/2010:svnASUSTEKCOMPUTERINC:pnP5WDHDeluxe:pvrSystemVersion:rvnASUSTeKComputerINC.:rnP5WDHDeluxe:rvrRev1.xx:cvnChassisManufacture:ct3:cvrChassisVersion:
  dmi.product.name: P5W DH Deluxe
  dmi.product.version: System Version
  dmi.sys.vendor: ASUSTEK COMPUTER INC

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/dkms/+bug/1574982/+subscriptions

-- 
Mailing list: https://launchpad.net/~kernel-packages
Post to : kernel-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~kernel-packages
More help   : https://help.launchpad.net/ListHelp


[Kernel-packages] [Bug 1574982] Re: Cannot use CONFIG_CC_STACKPROTECTOR_STRONG: -fstack-protector-strong not supported by compiler

2016-04-29 Thread dino99
Got a new dpkg that should help resolving that issue:

dpkg (1.18.4ubuntu2) yakkety; urgency=medium

  * No-change rebuild to pick up -fPIE on amd64 and ppc64el.

 -- Matthias Klose   Fri, 29 Apr 2016 13:53:32
+0200


then i ran a kernel 4.4.0-22 reinstallation: but still got the same crashes 
(nvidia-364, bbswitch & virtualbox). So the kernel compilation itself might 
need some tweaks too

-- 
You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.
https://bugs.launchpad.net/bugs/1574982

Title:
  Cannot use CONFIG_CC_STACKPROTECTOR_STRONG: -fstack-protector-strong
  not supported by compiler

Status in dkms package in Ubuntu:
  Confirmed
Status in gcc-defaults package in Ubuntu:
  Invalid
Status in linux package in Ubuntu:
  Confirmed

Bug description:
  Installing the latest 4.4.0-22 kernel ends with that error logged into 
dkmsbuildlog
  (only affect yakkety kernel; 4.4.0-22 kernel installation on xenial is fine)

  https://launchpadlibrarian.net/256055415/DKMSBuildLog.txt

  make "CC=cc"  KBUILD_VERBOSE= -C /lib/modules/4.4.0-22-generic/build 
M=/var/lib/dkms/nvidia-361/361.42/build ARCH=x86_64 
NV_KERNEL_SOURCES=/lib/modules/4.4.0-22-generic/build 
NV_KERNEL_OUTPUT=/lib/modules/4.4.0-22-generic/build NV_KERNEL_MODULES="nvidia 
nvidia-uvm nvidia-modeset" INSTALL_MOD_DIR=kernel/drivers/video modules
  make[1]: Entering directory '/usr/src/linux-headers-4.4.0-22-generic'
  arch/x86/Makefile:133: stack-protector enabled but compiler support broken
  Makefile:670: Cannot use CONFIG_CC_STACKPROTECTOR_STRONG: 
-fstack-protector-strong not supported by compiler

  the latest error logged is:

  /var/lib/dkms/nvidia-361/361.42/build/nvidia/nv-frontend.c:1:0: error:
  code model kernel does not support PIC mode

  Looks like it is related to the latest changes updates: gcc-6/gcc-5 
5.3.1-16ubuntu2 (some packages built with gcc-6; gcc-5 disabled for the 
packages built with gcc-6)
  Maybe some alternatives has not been updated to take care of these changes, 
as asked some time ago:
  http://askubuntu.com/questions/26498/choose-gcc-and-g-version

  This has been firstly reported against a nvidia crash:
  
https://bugs.launchpad.net/ubuntu/+source/nvidia-graphics-drivers-361/+bug/1574838

  ProblemType: Bug
  DistroRelease: Ubuntu 16.10
  Package: gcc 4:5.3.1-1ubuntu1
  ProcVersionSignature: Ubuntu 4.4.0-21.37-generic 4.4.6
  Uname: Linux 4.4.0-21-generic x86_64
  NonfreeKernelModules: nvidia_uvm nvidia_modeset nvidia
  ApportVersion: 2.20.1-0ubuntu2
  Architecture: amd64
  CurrentDesktop: GNOME
  Date: Tue Apr 26 08:41:32 2016
  SourcePackage: gcc-defaults
  UpgradeStatus: No upgrade log present (probably fresh install)
  ---
  ApportVersion: 2.20.1-0ubuntu2
  Architecture: amd64
  AudioDevicesInUse:
   USERPID ACCESS COMMAND
   /dev/snd/controlC1:  oem2014 F pulseaudio
   /dev/snd/pcmC0D0p:   oem2014 F...m pulseaudio
   /dev/snd/controlC0:  oem2014 F pulseaudio
  CurrentDesktop: GNOME
  DistroRelease: Ubuntu 16.10
  HibernationDevice: RESUME=UUID=0a9ca7f0-6eeb-4b21-b70f-670fa600de16
  IwConfig:
   eth0  no wireless extensions.

   eth1  no wireless extensions.

   lono wireless extensions.
  Lsusb:
   Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
   Bus 003 Device 002: ID 046d:c062 Logitech, Inc. M-UAS144 [LS1 Laser Mouse]
   Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
   Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
  MachineType: ASUSTEK COMPUTER INC P5W DH Deluxe
  NonfreeKernelModules: nvidia_uvm nvidia_modeset nvidia
  Package: ubuntu
  ProcFB:

  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.4.0-21-generic 
root=UUID=7c755ed6-51cc-4b75-88ac-9c75acf82749 ro
  ProcVersionSignature: Ubuntu 4.4.0-21.37-generic 4.4.6
  RelatedPackageVersions:
   linux-restricted-modules-4.4.0-21-generic N/A
   linux-backports-modules-4.4.0-21-generic  N/A
   linux-firmware1.157
  RfKill:

  Tags:  yakkety
  Uname: Linux 4.4.0-21-generic x86_64
  UpgradeStatus: No upgrade log present (probably fresh install)
  UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
  _MarkForUpload: True
  dmi.bios.date: 07/22/2010
  dmi.bios.vendor: American Megatrends Inc.
  dmi.bios.version: 3002
  dmi.board.asset.tag: To Be Filled By O.E.M.
  dmi.board.name: P5W DH Deluxe
  dmi.board.vendor: ASUSTeK Computer INC.
  dmi.board.version: Rev 1.xx
  dmi.chassis.asset.tag: Asset-1234567890
  dmi.chassis.type: 3
  dmi.chassis.vendor: Chassis Manufacture
  dmi.chassis.version: Chassis Version
  dmi.modalias: 
dmi:bvnAmericanMegatrendsInc.:bvr3002:bd07/22/2010:svnASUSTEKCOMPUTERINC:pnP5WDHDeluxe:pvrSystemVersion:rvnASUSTeKComputerINC.:rnP5WDHDeluxe:rvrRev1.xx:cvnChassisManufacture:ct3:cvrChassisVersion:
  dmi.product.name: P5W DH Deluxe
  dmi.product.version: System Version
  dmi.sys.vendor: ASUSTEK COMPUTER INC

To manage notifications about this 

[Kernel-packages] [Bug 1574982] Re: Cannot use CONFIG_CC_STACKPROTECTOR_STRONG: -fstack-protector-strong not supported by compiler

2016-04-28 Thread LocutusOfBorg
** Changed in: dkms (Ubuntu)
   Importance: Undecided => High

-- 
You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.
https://bugs.launchpad.net/bugs/1574982

Title:
  Cannot use CONFIG_CC_STACKPROTECTOR_STRONG: -fstack-protector-strong
  not supported by compiler

Status in dkms package in Ubuntu:
  Confirmed
Status in gcc-defaults package in Ubuntu:
  Invalid
Status in linux package in Ubuntu:
  Confirmed

Bug description:
  Installing the latest 4.4.0-22 kernel ends with that error logged into 
dkmsbuildlog
  (only affect yakkety kernel; 4.4.0-22 kernel installation on xenial is fine)

  https://launchpadlibrarian.net/256055415/DKMSBuildLog.txt

  make "CC=cc"  KBUILD_VERBOSE= -C /lib/modules/4.4.0-22-generic/build 
M=/var/lib/dkms/nvidia-361/361.42/build ARCH=x86_64 
NV_KERNEL_SOURCES=/lib/modules/4.4.0-22-generic/build 
NV_KERNEL_OUTPUT=/lib/modules/4.4.0-22-generic/build NV_KERNEL_MODULES="nvidia 
nvidia-uvm nvidia-modeset" INSTALL_MOD_DIR=kernel/drivers/video modules
  make[1]: Entering directory '/usr/src/linux-headers-4.4.0-22-generic'
  arch/x86/Makefile:133: stack-protector enabled but compiler support broken
  Makefile:670: Cannot use CONFIG_CC_STACKPROTECTOR_STRONG: 
-fstack-protector-strong not supported by compiler

  the latest error logged is:

  /var/lib/dkms/nvidia-361/361.42/build/nvidia/nv-frontend.c:1:0: error:
  code model kernel does not support PIC mode

  Looks like it is related to the latest changes updates: gcc-6/gcc-5 
5.3.1-16ubuntu2 (some packages built with gcc-6; gcc-5 disabled for the 
packages built with gcc-6)
  Maybe some alternatives has not been updated to take care of these changes, 
as asked some time ago:
  http://askubuntu.com/questions/26498/choose-gcc-and-g-version

  This has been firstly reported against a nvidia crash:
  
https://bugs.launchpad.net/ubuntu/+source/nvidia-graphics-drivers-361/+bug/1574838

  ProblemType: Bug
  DistroRelease: Ubuntu 16.10
  Package: gcc 4:5.3.1-1ubuntu1
  ProcVersionSignature: Ubuntu 4.4.0-21.37-generic 4.4.6
  Uname: Linux 4.4.0-21-generic x86_64
  NonfreeKernelModules: nvidia_uvm nvidia_modeset nvidia
  ApportVersion: 2.20.1-0ubuntu2
  Architecture: amd64
  CurrentDesktop: GNOME
  Date: Tue Apr 26 08:41:32 2016
  SourcePackage: gcc-defaults
  UpgradeStatus: No upgrade log present (probably fresh install)
  ---
  ApportVersion: 2.20.1-0ubuntu2
  Architecture: amd64
  AudioDevicesInUse:
   USERPID ACCESS COMMAND
   /dev/snd/controlC1:  oem2014 F pulseaudio
   /dev/snd/pcmC0D0p:   oem2014 F...m pulseaudio
   /dev/snd/controlC0:  oem2014 F pulseaudio
  CurrentDesktop: GNOME
  DistroRelease: Ubuntu 16.10
  HibernationDevice: RESUME=UUID=0a9ca7f0-6eeb-4b21-b70f-670fa600de16
  IwConfig:
   eth0  no wireless extensions.

   eth1  no wireless extensions.

   lono wireless extensions.
  Lsusb:
   Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
   Bus 003 Device 002: ID 046d:c062 Logitech, Inc. M-UAS144 [LS1 Laser Mouse]
   Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
   Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
  MachineType: ASUSTEK COMPUTER INC P5W DH Deluxe
  NonfreeKernelModules: nvidia_uvm nvidia_modeset nvidia
  Package: ubuntu
  ProcFB:

  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.4.0-21-generic 
root=UUID=7c755ed6-51cc-4b75-88ac-9c75acf82749 ro
  ProcVersionSignature: Ubuntu 4.4.0-21.37-generic 4.4.6
  RelatedPackageVersions:
   linux-restricted-modules-4.4.0-21-generic N/A
   linux-backports-modules-4.4.0-21-generic  N/A
   linux-firmware1.157
  RfKill:

  Tags:  yakkety
  Uname: Linux 4.4.0-21-generic x86_64
  UpgradeStatus: No upgrade log present (probably fresh install)
  UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
  _MarkForUpload: True
  dmi.bios.date: 07/22/2010
  dmi.bios.vendor: American Megatrends Inc.
  dmi.bios.version: 3002
  dmi.board.asset.tag: To Be Filled By O.E.M.
  dmi.board.name: P5W DH Deluxe
  dmi.board.vendor: ASUSTeK Computer INC.
  dmi.board.version: Rev 1.xx
  dmi.chassis.asset.tag: Asset-1234567890
  dmi.chassis.type: 3
  dmi.chassis.vendor: Chassis Manufacture
  dmi.chassis.version: Chassis Version
  dmi.modalias: 
dmi:bvnAmericanMegatrendsInc.:bvr3002:bd07/22/2010:svnASUSTEKCOMPUTERINC:pnP5WDHDeluxe:pvrSystemVersion:rvnASUSTeKComputerINC.:rnP5WDHDeluxe:rvrRev1.xx:cvnChassisManufacture:ct3:cvrChassisVersion:
  dmi.product.name: P5W DH Deluxe
  dmi.product.version: System Version
  dmi.sys.vendor: ASUSTEK COMPUTER INC

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/dkms/+bug/1574982/+subscriptions

-- 
Mailing list: https://launchpad.net/~kernel-packages
Post to : kernel-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~kernel-packages
More help   : https://help.launchpad.net/ListHelp


[Kernel-packages] [Bug 1574982] Re: Cannot use CONFIG_CC_STACKPROTECTOR_STRONG: -fstack-protector-strong not supported by compiler

2016-04-27 Thread Matthias Klose
** Package changed: ubuntu (Ubuntu) => dkms (Ubuntu)

-- 
You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.
https://bugs.launchpad.net/bugs/1574982

Title:
  Cannot use CONFIG_CC_STACKPROTECTOR_STRONG: -fstack-protector-strong
  not supported by compiler

Status in dkms package in Ubuntu:
  Confirmed
Status in gcc-defaults package in Ubuntu:
  Invalid
Status in linux package in Ubuntu:
  Confirmed

Bug description:
  Installing the latest 4.4.0-22 kernel ends with that error logged into 
dkmsbuildlog
  (only affect yakkety kernel; 4.4.0-22 kernel installation on xenial is fine)

  https://launchpadlibrarian.net/256055415/DKMSBuildLog.txt

  make "CC=cc"  KBUILD_VERBOSE= -C /lib/modules/4.4.0-22-generic/build 
M=/var/lib/dkms/nvidia-361/361.42/build ARCH=x86_64 
NV_KERNEL_SOURCES=/lib/modules/4.4.0-22-generic/build 
NV_KERNEL_OUTPUT=/lib/modules/4.4.0-22-generic/build NV_KERNEL_MODULES="nvidia 
nvidia-uvm nvidia-modeset" INSTALL_MOD_DIR=kernel/drivers/video modules
  make[1]: Entering directory '/usr/src/linux-headers-4.4.0-22-generic'
  arch/x86/Makefile:133: stack-protector enabled but compiler support broken
  Makefile:670: Cannot use CONFIG_CC_STACKPROTECTOR_STRONG: 
-fstack-protector-strong not supported by compiler

  the latest error logged is:

  /var/lib/dkms/nvidia-361/361.42/build/nvidia/nv-frontend.c:1:0: error:
  code model kernel does not support PIC mode

  Looks like it is related to the latest changes updates: gcc-6/gcc-5 
5.3.1-16ubuntu2 (some packages built with gcc-6; gcc-5 disabled for the 
packages built with gcc-6)
  Maybe some alternatives has not been updated to take care of these changes, 
as asked some time ago:
  http://askubuntu.com/questions/26498/choose-gcc-and-g-version

  This has been firstly reported against a nvidia crash:
  
https://bugs.launchpad.net/ubuntu/+source/nvidia-graphics-drivers-361/+bug/1574838

  ProblemType: Bug
  DistroRelease: Ubuntu 16.10
  Package: gcc 4:5.3.1-1ubuntu1
  ProcVersionSignature: Ubuntu 4.4.0-21.37-generic 4.4.6
  Uname: Linux 4.4.0-21-generic x86_64
  NonfreeKernelModules: nvidia_uvm nvidia_modeset nvidia
  ApportVersion: 2.20.1-0ubuntu2
  Architecture: amd64
  CurrentDesktop: GNOME
  Date: Tue Apr 26 08:41:32 2016
  SourcePackage: gcc-defaults
  UpgradeStatus: No upgrade log present (probably fresh install)
  ---
  ApportVersion: 2.20.1-0ubuntu2
  Architecture: amd64
  AudioDevicesInUse:
   USERPID ACCESS COMMAND
   /dev/snd/controlC1:  oem2014 F pulseaudio
   /dev/snd/pcmC0D0p:   oem2014 F...m pulseaudio
   /dev/snd/controlC0:  oem2014 F pulseaudio
  CurrentDesktop: GNOME
  DistroRelease: Ubuntu 16.10
  HibernationDevice: RESUME=UUID=0a9ca7f0-6eeb-4b21-b70f-670fa600de16
  IwConfig:
   eth0  no wireless extensions.

   eth1  no wireless extensions.

   lono wireless extensions.
  Lsusb:
   Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
   Bus 003 Device 002: ID 046d:c062 Logitech, Inc. M-UAS144 [LS1 Laser Mouse]
   Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
   Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
  MachineType: ASUSTEK COMPUTER INC P5W DH Deluxe
  NonfreeKernelModules: nvidia_uvm nvidia_modeset nvidia
  Package: ubuntu
  ProcFB:

  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.4.0-21-generic 
root=UUID=7c755ed6-51cc-4b75-88ac-9c75acf82749 ro
  ProcVersionSignature: Ubuntu 4.4.0-21.37-generic 4.4.6
  RelatedPackageVersions:
   linux-restricted-modules-4.4.0-21-generic N/A
   linux-backports-modules-4.4.0-21-generic  N/A
   linux-firmware1.157
  RfKill:

  Tags:  yakkety
  Uname: Linux 4.4.0-21-generic x86_64
  UpgradeStatus: No upgrade log present (probably fresh install)
  UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
  _MarkForUpload: True
  dmi.bios.date: 07/22/2010
  dmi.bios.vendor: American Megatrends Inc.
  dmi.bios.version: 3002
  dmi.board.asset.tag: To Be Filled By O.E.M.
  dmi.board.name: P5W DH Deluxe
  dmi.board.vendor: ASUSTeK Computer INC.
  dmi.board.version: Rev 1.xx
  dmi.chassis.asset.tag: Asset-1234567890
  dmi.chassis.type: 3
  dmi.chassis.vendor: Chassis Manufacture
  dmi.chassis.version: Chassis Version
  dmi.modalias: 
dmi:bvnAmericanMegatrendsInc.:bvr3002:bd07/22/2010:svnASUSTEKCOMPUTERINC:pnP5WDHDeluxe:pvrSystemVersion:rvnASUSTeKComputerINC.:rnP5WDHDeluxe:rvrRev1.xx:cvnChassisManufacture:ct3:cvrChassisVersion:
  dmi.product.name: P5W DH Deluxe
  dmi.product.version: System Version
  dmi.sys.vendor: ASUSTEK COMPUTER INC

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/dkms/+bug/1574982/+subscriptions

-- 
Mailing list: https://launchpad.net/~kernel-packages
Post to : kernel-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~kernel-packages
More help   : https://help.launchpad.net/ListHelp


[Kernel-packages] [Bug 1574982] Re: Cannot use CONFIG_CC_STACKPROTECTOR_STRONG: -fstack-protector-strong not supported by compiler

2016-04-27 Thread David Daynard
My comment was sarcastic. The build flags for dkms packages are
invisible to the end user and there is no easy way to change them. This
is either a packaging error with the kernel module or the gcc default
flags are erroneous. In either case this is not something the end user
solves by changing build flags.

-- 
You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.
https://bugs.launchpad.net/bugs/1574982

Title:
  Cannot use CONFIG_CC_STACKPROTECTOR_STRONG: -fstack-protector-strong
  not supported by compiler

Status in gcc-defaults package in Ubuntu:
  Invalid
Status in linux package in Ubuntu:
  Confirmed
Status in ubuntu package in Ubuntu:
  Confirmed

Bug description:
  Installing the latest 4.4.0-22 kernel ends with that error logged into 
dkmsbuildlog
  (only affect yakkety kernel; 4.4.0-22 kernel installation on xenial is fine)

  https://launchpadlibrarian.net/256055415/DKMSBuildLog.txt

  make "CC=cc"  KBUILD_VERBOSE= -C /lib/modules/4.4.0-22-generic/build 
M=/var/lib/dkms/nvidia-361/361.42/build ARCH=x86_64 
NV_KERNEL_SOURCES=/lib/modules/4.4.0-22-generic/build 
NV_KERNEL_OUTPUT=/lib/modules/4.4.0-22-generic/build NV_KERNEL_MODULES="nvidia 
nvidia-uvm nvidia-modeset" INSTALL_MOD_DIR=kernel/drivers/video modules
  make[1]: Entering directory '/usr/src/linux-headers-4.4.0-22-generic'
  arch/x86/Makefile:133: stack-protector enabled but compiler support broken
  Makefile:670: Cannot use CONFIG_CC_STACKPROTECTOR_STRONG: 
-fstack-protector-strong not supported by compiler

  the latest error logged is:

  /var/lib/dkms/nvidia-361/361.42/build/nvidia/nv-frontend.c:1:0: error:
  code model kernel does not support PIC mode

  Looks like it is related to the latest changes updates: gcc-6/gcc-5 
5.3.1-16ubuntu2 (some packages built with gcc-6; gcc-5 disabled for the 
packages built with gcc-6)
  Maybe some alternatives has not been updated to take care of these changes, 
as asked some time ago:
  http://askubuntu.com/questions/26498/choose-gcc-and-g-version

  This has been firstly reported against a nvidia crash:
  
https://bugs.launchpad.net/ubuntu/+source/nvidia-graphics-drivers-361/+bug/1574838

  ProblemType: Bug
  DistroRelease: Ubuntu 16.10
  Package: gcc 4:5.3.1-1ubuntu1
  ProcVersionSignature: Ubuntu 4.4.0-21.37-generic 4.4.6
  Uname: Linux 4.4.0-21-generic x86_64
  NonfreeKernelModules: nvidia_uvm nvidia_modeset nvidia
  ApportVersion: 2.20.1-0ubuntu2
  Architecture: amd64
  CurrentDesktop: GNOME
  Date: Tue Apr 26 08:41:32 2016
  SourcePackage: gcc-defaults
  UpgradeStatus: No upgrade log present (probably fresh install)
  ---
  ApportVersion: 2.20.1-0ubuntu2
  Architecture: amd64
  AudioDevicesInUse:
   USERPID ACCESS COMMAND
   /dev/snd/controlC1:  oem2014 F pulseaudio
   /dev/snd/pcmC0D0p:   oem2014 F...m pulseaudio
   /dev/snd/controlC0:  oem2014 F pulseaudio
  CurrentDesktop: GNOME
  DistroRelease: Ubuntu 16.10
  HibernationDevice: RESUME=UUID=0a9ca7f0-6eeb-4b21-b70f-670fa600de16
  IwConfig:
   eth0  no wireless extensions.

   eth1  no wireless extensions.

   lono wireless extensions.
  Lsusb:
   Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
   Bus 003 Device 002: ID 046d:c062 Logitech, Inc. M-UAS144 [LS1 Laser Mouse]
   Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
   Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
  MachineType: ASUSTEK COMPUTER INC P5W DH Deluxe
  NonfreeKernelModules: nvidia_uvm nvidia_modeset nvidia
  Package: ubuntu
  ProcFB:

  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.4.0-21-generic 
root=UUID=7c755ed6-51cc-4b75-88ac-9c75acf82749 ro
  ProcVersionSignature: Ubuntu 4.4.0-21.37-generic 4.4.6
  RelatedPackageVersions:
   linux-restricted-modules-4.4.0-21-generic N/A
   linux-backports-modules-4.4.0-21-generic  N/A
   linux-firmware1.157
  RfKill:

  Tags:  yakkety
  Uname: Linux 4.4.0-21-generic x86_64
  UpgradeStatus: No upgrade log present (probably fresh install)
  UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
  _MarkForUpload: True
  dmi.bios.date: 07/22/2010
  dmi.bios.vendor: American Megatrends Inc.
  dmi.bios.version: 3002
  dmi.board.asset.tag: To Be Filled By O.E.M.
  dmi.board.name: P5W DH Deluxe
  dmi.board.vendor: ASUSTeK Computer INC.
  dmi.board.version: Rev 1.xx
  dmi.chassis.asset.tag: Asset-1234567890
  dmi.chassis.type: 3
  dmi.chassis.vendor: Chassis Manufacture
  dmi.chassis.version: Chassis Version
  dmi.modalias: 
dmi:bvnAmericanMegatrendsInc.:bvr3002:bd07/22/2010:svnASUSTEKCOMPUTERINC:pnP5WDHDeluxe:pvrSystemVersion:rvnASUSTeKComputerINC.:rnP5WDHDeluxe:rvrRev1.xx:cvnChassisManufacture:ct3:cvrChassisVersion:
  dmi.product.name: P5W DH Deluxe
  dmi.product.version: System Version
  dmi.sys.vendor: ASUSTEK COMPUTER INC

To manage notifications about this bug go to:

[Kernel-packages] [Bug 1574982] Re: Cannot use CONFIG_CC_STACKPROTECTOR_STRONG: -fstack-protector-strong not supported by compiler

2016-04-27 Thread dino99
@David

Please ask on askubuntu to get a dev answer; here it is only for report,
not asking. Thanks

-- 
You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.
https://bugs.launchpad.net/bugs/1574982

Title:
  Cannot use CONFIG_CC_STACKPROTECTOR_STRONG: -fstack-protector-strong
  not supported by compiler

Status in gcc-defaults package in Ubuntu:
  Invalid
Status in linux package in Ubuntu:
  Confirmed
Status in ubuntu package in Ubuntu:
  Confirmed

Bug description:
  Installing the latest 4.4.0-22 kernel ends with that error logged into 
dkmsbuildlog
  (only affect yakkety kernel; 4.4.0-22 kernel installation on xenial is fine)

  https://launchpadlibrarian.net/256055415/DKMSBuildLog.txt

  make "CC=cc"  KBUILD_VERBOSE= -C /lib/modules/4.4.0-22-generic/build 
M=/var/lib/dkms/nvidia-361/361.42/build ARCH=x86_64 
NV_KERNEL_SOURCES=/lib/modules/4.4.0-22-generic/build 
NV_KERNEL_OUTPUT=/lib/modules/4.4.0-22-generic/build NV_KERNEL_MODULES="nvidia 
nvidia-uvm nvidia-modeset" INSTALL_MOD_DIR=kernel/drivers/video modules
  make[1]: Entering directory '/usr/src/linux-headers-4.4.0-22-generic'
  arch/x86/Makefile:133: stack-protector enabled but compiler support broken
  Makefile:670: Cannot use CONFIG_CC_STACKPROTECTOR_STRONG: 
-fstack-protector-strong not supported by compiler

  the latest error logged is:

  /var/lib/dkms/nvidia-361/361.42/build/nvidia/nv-frontend.c:1:0: error:
  code model kernel does not support PIC mode

  Looks like it is related to the latest changes updates: gcc-6/gcc-5 
5.3.1-16ubuntu2 (some packages built with gcc-6; gcc-5 disabled for the 
packages built with gcc-6)
  Maybe some alternatives has not been updated to take care of these changes, 
as asked some time ago:
  http://askubuntu.com/questions/26498/choose-gcc-and-g-version

  This has been firstly reported against a nvidia crash:
  
https://bugs.launchpad.net/ubuntu/+source/nvidia-graphics-drivers-361/+bug/1574838

  ProblemType: Bug
  DistroRelease: Ubuntu 16.10
  Package: gcc 4:5.3.1-1ubuntu1
  ProcVersionSignature: Ubuntu 4.4.0-21.37-generic 4.4.6
  Uname: Linux 4.4.0-21-generic x86_64
  NonfreeKernelModules: nvidia_uvm nvidia_modeset nvidia
  ApportVersion: 2.20.1-0ubuntu2
  Architecture: amd64
  CurrentDesktop: GNOME
  Date: Tue Apr 26 08:41:32 2016
  SourcePackage: gcc-defaults
  UpgradeStatus: No upgrade log present (probably fresh install)
  ---
  ApportVersion: 2.20.1-0ubuntu2
  Architecture: amd64
  AudioDevicesInUse:
   USERPID ACCESS COMMAND
   /dev/snd/controlC1:  oem2014 F pulseaudio
   /dev/snd/pcmC0D0p:   oem2014 F...m pulseaudio
   /dev/snd/controlC0:  oem2014 F pulseaudio
  CurrentDesktop: GNOME
  DistroRelease: Ubuntu 16.10
  HibernationDevice: RESUME=UUID=0a9ca7f0-6eeb-4b21-b70f-670fa600de16
  IwConfig:
   eth0  no wireless extensions.

   eth1  no wireless extensions.

   lono wireless extensions.
  Lsusb:
   Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
   Bus 003 Device 002: ID 046d:c062 Logitech, Inc. M-UAS144 [LS1 Laser Mouse]
   Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
   Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
  MachineType: ASUSTEK COMPUTER INC P5W DH Deluxe
  NonfreeKernelModules: nvidia_uvm nvidia_modeset nvidia
  Package: ubuntu
  ProcFB:

  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.4.0-21-generic 
root=UUID=7c755ed6-51cc-4b75-88ac-9c75acf82749 ro
  ProcVersionSignature: Ubuntu 4.4.0-21.37-generic 4.4.6
  RelatedPackageVersions:
   linux-restricted-modules-4.4.0-21-generic N/A
   linux-backports-modules-4.4.0-21-generic  N/A
   linux-firmware1.157
  RfKill:

  Tags:  yakkety
  Uname: Linux 4.4.0-21-generic x86_64
  UpgradeStatus: No upgrade log present (probably fresh install)
  UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
  _MarkForUpload: True
  dmi.bios.date: 07/22/2010
  dmi.bios.vendor: American Megatrends Inc.
  dmi.bios.version: 3002
  dmi.board.asset.tag: To Be Filled By O.E.M.
  dmi.board.name: P5W DH Deluxe
  dmi.board.vendor: ASUSTeK Computer INC.
  dmi.board.version: Rev 1.xx
  dmi.chassis.asset.tag: Asset-1234567890
  dmi.chassis.type: 3
  dmi.chassis.vendor: Chassis Manufacture
  dmi.chassis.version: Chassis Version
  dmi.modalias: 
dmi:bvnAmericanMegatrendsInc.:bvr3002:bd07/22/2010:svnASUSTEKCOMPUTERINC:pnP5WDHDeluxe:pvrSystemVersion:rvnASUSTeKComputerINC.:rnP5WDHDeluxe:rvrRev1.xx:cvnChassisManufacture:ct3:cvrChassisVersion:
  dmi.product.name: P5W DH Deluxe
  dmi.product.version: System Version
  dmi.sys.vendor: ASUSTEK COMPUTER INC

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/gcc-defaults/+bug/1574982/+subscriptions

-- 
Mailing list: https://launchpad.net/~kernel-packages
Post to : kernel-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~kernel-packages
More help   : 

[Kernel-packages] [Bug 1574982] Re: Cannot use CONFIG_CC_STACKPROTECTOR_STRONG: -fstack-protector-strong not supported by compiler

2016-04-27 Thread David Daynard
Please explain how I am going to build with -no-pie when apt-get and
dkms automates the entire process here.

-- 
You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.
https://bugs.launchpad.net/bugs/1574982

Title:
  Cannot use CONFIG_CC_STACKPROTECTOR_STRONG: -fstack-protector-strong
  not supported by compiler

Status in gcc-defaults package in Ubuntu:
  Invalid
Status in linux package in Ubuntu:
  Confirmed
Status in ubuntu package in Ubuntu:
  Confirmed

Bug description:
  Installing the latest 4.4.0-22 kernel ends with that error logged into 
dkmsbuildlog
  (only affect yakkety kernel; 4.4.0-22 kernel installation on xenial is fine)

  https://launchpadlibrarian.net/256055415/DKMSBuildLog.txt

  make "CC=cc"  KBUILD_VERBOSE= -C /lib/modules/4.4.0-22-generic/build 
M=/var/lib/dkms/nvidia-361/361.42/build ARCH=x86_64 
NV_KERNEL_SOURCES=/lib/modules/4.4.0-22-generic/build 
NV_KERNEL_OUTPUT=/lib/modules/4.4.0-22-generic/build NV_KERNEL_MODULES="nvidia 
nvidia-uvm nvidia-modeset" INSTALL_MOD_DIR=kernel/drivers/video modules
  make[1]: Entering directory '/usr/src/linux-headers-4.4.0-22-generic'
  arch/x86/Makefile:133: stack-protector enabled but compiler support broken
  Makefile:670: Cannot use CONFIG_CC_STACKPROTECTOR_STRONG: 
-fstack-protector-strong not supported by compiler

  the latest error logged is:

  /var/lib/dkms/nvidia-361/361.42/build/nvidia/nv-frontend.c:1:0: error:
  code model kernel does not support PIC mode

  Looks like it is related to the latest changes updates: gcc-6/gcc-5 
5.3.1-16ubuntu2 (some packages built with gcc-6; gcc-5 disabled for the 
packages built with gcc-6)
  Maybe some alternatives has not been updated to take care of these changes, 
as asked some time ago:
  http://askubuntu.com/questions/26498/choose-gcc-and-g-version

  This has been firstly reported against a nvidia crash:
  
https://bugs.launchpad.net/ubuntu/+source/nvidia-graphics-drivers-361/+bug/1574838

  ProblemType: Bug
  DistroRelease: Ubuntu 16.10
  Package: gcc 4:5.3.1-1ubuntu1
  ProcVersionSignature: Ubuntu 4.4.0-21.37-generic 4.4.6
  Uname: Linux 4.4.0-21-generic x86_64
  NonfreeKernelModules: nvidia_uvm nvidia_modeset nvidia
  ApportVersion: 2.20.1-0ubuntu2
  Architecture: amd64
  CurrentDesktop: GNOME
  Date: Tue Apr 26 08:41:32 2016
  SourcePackage: gcc-defaults
  UpgradeStatus: No upgrade log present (probably fresh install)
  ---
  ApportVersion: 2.20.1-0ubuntu2
  Architecture: amd64
  AudioDevicesInUse:
   USERPID ACCESS COMMAND
   /dev/snd/controlC1:  oem2014 F pulseaudio
   /dev/snd/pcmC0D0p:   oem2014 F...m pulseaudio
   /dev/snd/controlC0:  oem2014 F pulseaudio
  CurrentDesktop: GNOME
  DistroRelease: Ubuntu 16.10
  HibernationDevice: RESUME=UUID=0a9ca7f0-6eeb-4b21-b70f-670fa600de16
  IwConfig:
   eth0  no wireless extensions.

   eth1  no wireless extensions.

   lono wireless extensions.
  Lsusb:
   Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
   Bus 003 Device 002: ID 046d:c062 Logitech, Inc. M-UAS144 [LS1 Laser Mouse]
   Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
   Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
  MachineType: ASUSTEK COMPUTER INC P5W DH Deluxe
  NonfreeKernelModules: nvidia_uvm nvidia_modeset nvidia
  Package: ubuntu
  ProcFB:

  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.4.0-21-generic 
root=UUID=7c755ed6-51cc-4b75-88ac-9c75acf82749 ro
  ProcVersionSignature: Ubuntu 4.4.0-21.37-generic 4.4.6
  RelatedPackageVersions:
   linux-restricted-modules-4.4.0-21-generic N/A
   linux-backports-modules-4.4.0-21-generic  N/A
   linux-firmware1.157
  RfKill:

  Tags:  yakkety
  Uname: Linux 4.4.0-21-generic x86_64
  UpgradeStatus: No upgrade log present (probably fresh install)
  UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
  _MarkForUpload: True
  dmi.bios.date: 07/22/2010
  dmi.bios.vendor: American Megatrends Inc.
  dmi.bios.version: 3002
  dmi.board.asset.tag: To Be Filled By O.E.M.
  dmi.board.name: P5W DH Deluxe
  dmi.board.vendor: ASUSTeK Computer INC.
  dmi.board.version: Rev 1.xx
  dmi.chassis.asset.tag: Asset-1234567890
  dmi.chassis.type: 3
  dmi.chassis.vendor: Chassis Manufacture
  dmi.chassis.version: Chassis Version
  dmi.modalias: 
dmi:bvnAmericanMegatrendsInc.:bvr3002:bd07/22/2010:svnASUSTEKCOMPUTERINC:pnP5WDHDeluxe:pvrSystemVersion:rvnASUSTeKComputerINC.:rnP5WDHDeluxe:rvrRev1.xx:cvnChassisManufacture:ct3:cvrChassisVersion:
  dmi.product.name: P5W DH Deluxe
  dmi.product.version: System Version
  dmi.sys.vendor: ASUSTEK COMPUTER INC

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/gcc-defaults/+bug/1574982/+subscriptions

-- 
Mailing list: https://launchpad.net/~kernel-packages
Post to : kernel-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~kernel-packages
More help   : 

[Kernel-packages] [Bug 1574982] Re: Cannot use CONFIG_CC_STACKPROTECTOR_STRONG: -fstack-protector-strong not supported by compiler

2016-04-27 Thread Matthias Klose
you have to build with -no-pie. Please read the Yakkety Yak opening
announcement.

** Changed in: gcc-defaults (Ubuntu)
   Status: Confirmed => Invalid

-- 
You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.
https://bugs.launchpad.net/bugs/1574982

Title:
  Cannot use CONFIG_CC_STACKPROTECTOR_STRONG: -fstack-protector-strong
  not supported by compiler

Status in gcc-defaults package in Ubuntu:
  Invalid
Status in linux package in Ubuntu:
  Confirmed
Status in ubuntu package in Ubuntu:
  Confirmed

Bug description:
  Installing the latest 4.4.0-22 kernel ends with that error logged into 
dkmsbuildlog
  (only affect yakkety kernel; 4.4.0-22 kernel installation on xenial is fine)

  https://launchpadlibrarian.net/256055415/DKMSBuildLog.txt

  make "CC=cc"  KBUILD_VERBOSE= -C /lib/modules/4.4.0-22-generic/build 
M=/var/lib/dkms/nvidia-361/361.42/build ARCH=x86_64 
NV_KERNEL_SOURCES=/lib/modules/4.4.0-22-generic/build 
NV_KERNEL_OUTPUT=/lib/modules/4.4.0-22-generic/build NV_KERNEL_MODULES="nvidia 
nvidia-uvm nvidia-modeset" INSTALL_MOD_DIR=kernel/drivers/video modules
  make[1]: Entering directory '/usr/src/linux-headers-4.4.0-22-generic'
  arch/x86/Makefile:133: stack-protector enabled but compiler support broken
  Makefile:670: Cannot use CONFIG_CC_STACKPROTECTOR_STRONG: 
-fstack-protector-strong not supported by compiler

  the latest error logged is:

  /var/lib/dkms/nvidia-361/361.42/build/nvidia/nv-frontend.c:1:0: error:
  code model kernel does not support PIC mode

  Looks like it is related to the latest changes updates: gcc-6/gcc-5 
5.3.1-16ubuntu2 (some packages built with gcc-6; gcc-5 disabled for the 
packages built with gcc-6)
  Maybe some alternatives has not been updated to take care of these changes, 
as asked some time ago:
  http://askubuntu.com/questions/26498/choose-gcc-and-g-version

  This has been firstly reported against a nvidia crash:
  
https://bugs.launchpad.net/ubuntu/+source/nvidia-graphics-drivers-361/+bug/1574838

  ProblemType: Bug
  DistroRelease: Ubuntu 16.10
  Package: gcc 4:5.3.1-1ubuntu1
  ProcVersionSignature: Ubuntu 4.4.0-21.37-generic 4.4.6
  Uname: Linux 4.4.0-21-generic x86_64
  NonfreeKernelModules: nvidia_uvm nvidia_modeset nvidia
  ApportVersion: 2.20.1-0ubuntu2
  Architecture: amd64
  CurrentDesktop: GNOME
  Date: Tue Apr 26 08:41:32 2016
  SourcePackage: gcc-defaults
  UpgradeStatus: No upgrade log present (probably fresh install)
  ---
  ApportVersion: 2.20.1-0ubuntu2
  Architecture: amd64
  AudioDevicesInUse:
   USERPID ACCESS COMMAND
   /dev/snd/controlC1:  oem2014 F pulseaudio
   /dev/snd/pcmC0D0p:   oem2014 F...m pulseaudio
   /dev/snd/controlC0:  oem2014 F pulseaudio
  CurrentDesktop: GNOME
  DistroRelease: Ubuntu 16.10
  HibernationDevice: RESUME=UUID=0a9ca7f0-6eeb-4b21-b70f-670fa600de16
  IwConfig:
   eth0  no wireless extensions.

   eth1  no wireless extensions.

   lono wireless extensions.
  Lsusb:
   Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
   Bus 003 Device 002: ID 046d:c062 Logitech, Inc. M-UAS144 [LS1 Laser Mouse]
   Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
   Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
  MachineType: ASUSTEK COMPUTER INC P5W DH Deluxe
  NonfreeKernelModules: nvidia_uvm nvidia_modeset nvidia
  Package: ubuntu
  ProcFB:

  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.4.0-21-generic 
root=UUID=7c755ed6-51cc-4b75-88ac-9c75acf82749 ro
  ProcVersionSignature: Ubuntu 4.4.0-21.37-generic 4.4.6
  RelatedPackageVersions:
   linux-restricted-modules-4.4.0-21-generic N/A
   linux-backports-modules-4.4.0-21-generic  N/A
   linux-firmware1.157
  RfKill:

  Tags:  yakkety
  Uname: Linux 4.4.0-21-generic x86_64
  UpgradeStatus: No upgrade log present (probably fresh install)
  UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
  _MarkForUpload: True
  dmi.bios.date: 07/22/2010
  dmi.bios.vendor: American Megatrends Inc.
  dmi.bios.version: 3002
  dmi.board.asset.tag: To Be Filled By O.E.M.
  dmi.board.name: P5W DH Deluxe
  dmi.board.vendor: ASUSTeK Computer INC.
  dmi.board.version: Rev 1.xx
  dmi.chassis.asset.tag: Asset-1234567890
  dmi.chassis.type: 3
  dmi.chassis.vendor: Chassis Manufacture
  dmi.chassis.version: Chassis Version
  dmi.modalias: 
dmi:bvnAmericanMegatrendsInc.:bvr3002:bd07/22/2010:svnASUSTEKCOMPUTERINC:pnP5WDHDeluxe:pvrSystemVersion:rvnASUSTeKComputerINC.:rnP5WDHDeluxe:rvrRev1.xx:cvnChassisManufacture:ct3:cvrChassisVersion:
  dmi.product.name: P5W DH Deluxe
  dmi.product.version: System Version
  dmi.sys.vendor: ASUSTEK COMPUTER INC

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/gcc-defaults/+bug/1574982/+subscriptions

-- 
Mailing list: https://launchpad.net/~kernel-packages
Post to : kernel-packages@lists.launchpad.net
Unsubscribe : 

[Kernel-packages] [Bug 1574982] Re: Cannot use CONFIG_CC_STACKPROTECTOR_STRONG: -fstack-protector-strong not supported by compiler

2016-04-27 Thread Launchpad Bug Tracker
Status changed to 'Confirmed' because the bug affects multiple users.

** Changed in: gcc-defaults (Ubuntu)
   Status: New => Confirmed

-- 
You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.
https://bugs.launchpad.net/bugs/1574982

Title:
  Cannot use CONFIG_CC_STACKPROTECTOR_STRONG: -fstack-protector-strong
  not supported by compiler

Status in gcc-defaults package in Ubuntu:
  Confirmed
Status in linux package in Ubuntu:
  Confirmed
Status in ubuntu package in Ubuntu:
  Confirmed

Bug description:
  Installing the latest 4.4.0-22 kernel ends with that error logged into 
dkmsbuildlog
  (only affect yakkety kernel; 4.4.0-22 kernel installation on xenial is fine)

  https://launchpadlibrarian.net/256055415/DKMSBuildLog.txt

  make "CC=cc"  KBUILD_VERBOSE= -C /lib/modules/4.4.0-22-generic/build 
M=/var/lib/dkms/nvidia-361/361.42/build ARCH=x86_64 
NV_KERNEL_SOURCES=/lib/modules/4.4.0-22-generic/build 
NV_KERNEL_OUTPUT=/lib/modules/4.4.0-22-generic/build NV_KERNEL_MODULES="nvidia 
nvidia-uvm nvidia-modeset" INSTALL_MOD_DIR=kernel/drivers/video modules
  make[1]: Entering directory '/usr/src/linux-headers-4.4.0-22-generic'
  arch/x86/Makefile:133: stack-protector enabled but compiler support broken
  Makefile:670: Cannot use CONFIG_CC_STACKPROTECTOR_STRONG: 
-fstack-protector-strong not supported by compiler

  the latest error logged is:

  /var/lib/dkms/nvidia-361/361.42/build/nvidia/nv-frontend.c:1:0: error:
  code model kernel does not support PIC mode

  Looks like it is related to the latest changes updates: gcc-6/gcc-5 
5.3.1-16ubuntu2 (some packages built with gcc-6; gcc-5 disabled for the 
packages built with gcc-6)
  Maybe some alternatives has not been updated to take care of these changes, 
as asked some time ago:
  http://askubuntu.com/questions/26498/choose-gcc-and-g-version

  This has been firstly reported against a nvidia crash:
  
https://bugs.launchpad.net/ubuntu/+source/nvidia-graphics-drivers-361/+bug/1574838

  ProblemType: Bug
  DistroRelease: Ubuntu 16.10
  Package: gcc 4:5.3.1-1ubuntu1
  ProcVersionSignature: Ubuntu 4.4.0-21.37-generic 4.4.6
  Uname: Linux 4.4.0-21-generic x86_64
  NonfreeKernelModules: nvidia_uvm nvidia_modeset nvidia
  ApportVersion: 2.20.1-0ubuntu2
  Architecture: amd64
  CurrentDesktop: GNOME
  Date: Tue Apr 26 08:41:32 2016
  SourcePackage: gcc-defaults
  UpgradeStatus: No upgrade log present (probably fresh install)
  ---
  ApportVersion: 2.20.1-0ubuntu2
  Architecture: amd64
  AudioDevicesInUse:
   USERPID ACCESS COMMAND
   /dev/snd/controlC1:  oem2014 F pulseaudio
   /dev/snd/pcmC0D0p:   oem2014 F...m pulseaudio
   /dev/snd/controlC0:  oem2014 F pulseaudio
  CurrentDesktop: GNOME
  DistroRelease: Ubuntu 16.10
  HibernationDevice: RESUME=UUID=0a9ca7f0-6eeb-4b21-b70f-670fa600de16
  IwConfig:
   eth0  no wireless extensions.

   eth1  no wireless extensions.

   lono wireless extensions.
  Lsusb:
   Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
   Bus 003 Device 002: ID 046d:c062 Logitech, Inc. M-UAS144 [LS1 Laser Mouse]
   Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
   Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
  MachineType: ASUSTEK COMPUTER INC P5W DH Deluxe
  NonfreeKernelModules: nvidia_uvm nvidia_modeset nvidia
  Package: ubuntu
  ProcFB:

  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.4.0-21-generic 
root=UUID=7c755ed6-51cc-4b75-88ac-9c75acf82749 ro
  ProcVersionSignature: Ubuntu 4.4.0-21.37-generic 4.4.6
  RelatedPackageVersions:
   linux-restricted-modules-4.4.0-21-generic N/A
   linux-backports-modules-4.4.0-21-generic  N/A
   linux-firmware1.157
  RfKill:

  Tags:  yakkety
  Uname: Linux 4.4.0-21-generic x86_64
  UpgradeStatus: No upgrade log present (probably fresh install)
  UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
  _MarkForUpload: True
  dmi.bios.date: 07/22/2010
  dmi.bios.vendor: American Megatrends Inc.
  dmi.bios.version: 3002
  dmi.board.asset.tag: To Be Filled By O.E.M.
  dmi.board.name: P5W DH Deluxe
  dmi.board.vendor: ASUSTeK Computer INC.
  dmi.board.version: Rev 1.xx
  dmi.chassis.asset.tag: Asset-1234567890
  dmi.chassis.type: 3
  dmi.chassis.vendor: Chassis Manufacture
  dmi.chassis.version: Chassis Version
  dmi.modalias: 
dmi:bvnAmericanMegatrendsInc.:bvr3002:bd07/22/2010:svnASUSTEKCOMPUTERINC:pnP5WDHDeluxe:pvrSystemVersion:rvnASUSTeKComputerINC.:rnP5WDHDeluxe:rvrRev1.xx:cvnChassisManufacture:ct3:cvrChassisVersion:
  dmi.product.name: P5W DH Deluxe
  dmi.product.version: System Version
  dmi.sys.vendor: ASUSTEK COMPUTER INC

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/gcc-defaults/+bug/1574982/+subscriptions

-- 
Mailing list: https://launchpad.net/~kernel-packages
Post to : kernel-packages@lists.launchpad.net
Unsubscribe : 

[Kernel-packages] [Bug 1574982] Re: Cannot use CONFIG_CC_STACKPROTECTOR_STRONG: -fstack-protector-strong not supported by compiler

2016-04-27 Thread Launchpad Bug Tracker
Status changed to 'Confirmed' because the bug affects multiple users.

** Changed in: ubuntu (Ubuntu)
   Status: New => Confirmed

-- 
You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.
https://bugs.launchpad.net/bugs/1574982

Title:
  Cannot use CONFIG_CC_STACKPROTECTOR_STRONG: -fstack-protector-strong
  not supported by compiler

Status in gcc-defaults package in Ubuntu:
  Confirmed
Status in linux package in Ubuntu:
  Confirmed
Status in ubuntu package in Ubuntu:
  Confirmed

Bug description:
  Installing the latest 4.4.0-22 kernel ends with that error logged into 
dkmsbuildlog
  (only affect yakkety kernel; 4.4.0-22 kernel installation on xenial is fine)

  https://launchpadlibrarian.net/256055415/DKMSBuildLog.txt

  make "CC=cc"  KBUILD_VERBOSE= -C /lib/modules/4.4.0-22-generic/build 
M=/var/lib/dkms/nvidia-361/361.42/build ARCH=x86_64 
NV_KERNEL_SOURCES=/lib/modules/4.4.0-22-generic/build 
NV_KERNEL_OUTPUT=/lib/modules/4.4.0-22-generic/build NV_KERNEL_MODULES="nvidia 
nvidia-uvm nvidia-modeset" INSTALL_MOD_DIR=kernel/drivers/video modules
  make[1]: Entering directory '/usr/src/linux-headers-4.4.0-22-generic'
  arch/x86/Makefile:133: stack-protector enabled but compiler support broken
  Makefile:670: Cannot use CONFIG_CC_STACKPROTECTOR_STRONG: 
-fstack-protector-strong not supported by compiler

  the latest error logged is:

  /var/lib/dkms/nvidia-361/361.42/build/nvidia/nv-frontend.c:1:0: error:
  code model kernel does not support PIC mode

  Looks like it is related to the latest changes updates: gcc-6/gcc-5 
5.3.1-16ubuntu2 (some packages built with gcc-6; gcc-5 disabled for the 
packages built with gcc-6)
  Maybe some alternatives has not been updated to take care of these changes, 
as asked some time ago:
  http://askubuntu.com/questions/26498/choose-gcc-and-g-version

  This has been firstly reported against a nvidia crash:
  
https://bugs.launchpad.net/ubuntu/+source/nvidia-graphics-drivers-361/+bug/1574838

  ProblemType: Bug
  DistroRelease: Ubuntu 16.10
  Package: gcc 4:5.3.1-1ubuntu1
  ProcVersionSignature: Ubuntu 4.4.0-21.37-generic 4.4.6
  Uname: Linux 4.4.0-21-generic x86_64
  NonfreeKernelModules: nvidia_uvm nvidia_modeset nvidia
  ApportVersion: 2.20.1-0ubuntu2
  Architecture: amd64
  CurrentDesktop: GNOME
  Date: Tue Apr 26 08:41:32 2016
  SourcePackage: gcc-defaults
  UpgradeStatus: No upgrade log present (probably fresh install)
  ---
  ApportVersion: 2.20.1-0ubuntu2
  Architecture: amd64
  AudioDevicesInUse:
   USERPID ACCESS COMMAND
   /dev/snd/controlC1:  oem2014 F pulseaudio
   /dev/snd/pcmC0D0p:   oem2014 F...m pulseaudio
   /dev/snd/controlC0:  oem2014 F pulseaudio
  CurrentDesktop: GNOME
  DistroRelease: Ubuntu 16.10
  HibernationDevice: RESUME=UUID=0a9ca7f0-6eeb-4b21-b70f-670fa600de16
  IwConfig:
   eth0  no wireless extensions.

   eth1  no wireless extensions.

   lono wireless extensions.
  Lsusb:
   Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
   Bus 003 Device 002: ID 046d:c062 Logitech, Inc. M-UAS144 [LS1 Laser Mouse]
   Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
   Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
  MachineType: ASUSTEK COMPUTER INC P5W DH Deluxe
  NonfreeKernelModules: nvidia_uvm nvidia_modeset nvidia
  Package: ubuntu
  ProcFB:

  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.4.0-21-generic 
root=UUID=7c755ed6-51cc-4b75-88ac-9c75acf82749 ro
  ProcVersionSignature: Ubuntu 4.4.0-21.37-generic 4.4.6
  RelatedPackageVersions:
   linux-restricted-modules-4.4.0-21-generic N/A
   linux-backports-modules-4.4.0-21-generic  N/A
   linux-firmware1.157
  RfKill:

  Tags:  yakkety
  Uname: Linux 4.4.0-21-generic x86_64
  UpgradeStatus: No upgrade log present (probably fresh install)
  UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
  _MarkForUpload: True
  dmi.bios.date: 07/22/2010
  dmi.bios.vendor: American Megatrends Inc.
  dmi.bios.version: 3002
  dmi.board.asset.tag: To Be Filled By O.E.M.
  dmi.board.name: P5W DH Deluxe
  dmi.board.vendor: ASUSTeK Computer INC.
  dmi.board.version: Rev 1.xx
  dmi.chassis.asset.tag: Asset-1234567890
  dmi.chassis.type: 3
  dmi.chassis.vendor: Chassis Manufacture
  dmi.chassis.version: Chassis Version
  dmi.modalias: 
dmi:bvnAmericanMegatrendsInc.:bvr3002:bd07/22/2010:svnASUSTEKCOMPUTERINC:pnP5WDHDeluxe:pvrSystemVersion:rvnASUSTeKComputerINC.:rnP5WDHDeluxe:rvrRev1.xx:cvnChassisManufacture:ct3:cvrChassisVersion:
  dmi.product.name: P5W DH Deluxe
  dmi.product.version: System Version
  dmi.sys.vendor: ASUSTEK COMPUTER INC

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/gcc-defaults/+bug/1574982/+subscriptions

-- 
Mailing list: https://launchpad.net/~kernel-packages
Post to : kernel-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~kernel-packages

[Kernel-packages] [Bug 1574982] Re: Cannot use CONFIG_CC_STACKPROTECTOR_STRONG: -fstack-protector-strong not supported by compiler

2016-04-26 Thread dino99
** Description changed:

- Installing the latest 4.4.0-22 kernel ends with that error logged into
- dkmsbuildlog
+ Installing the latest 4.4.0-22 kernel ends with that error logged into 
dkmsbuildlog
+ (only affect yakkety kernel; 4.4.0-22 kernel installation on xenial is fine)
  
  https://launchpadlibrarian.net/256055415/DKMSBuildLog.txt
  
  make "CC=cc"  KBUILD_VERBOSE= -C /lib/modules/4.4.0-22-generic/build 
M=/var/lib/dkms/nvidia-361/361.42/build ARCH=x86_64 
NV_KERNEL_SOURCES=/lib/modules/4.4.0-22-generic/build 
NV_KERNEL_OUTPUT=/lib/modules/4.4.0-22-generic/build NV_KERNEL_MODULES="nvidia 
nvidia-uvm nvidia-modeset" INSTALL_MOD_DIR=kernel/drivers/video modules
  make[1]: Entering directory '/usr/src/linux-headers-4.4.0-22-generic'
  arch/x86/Makefile:133: stack-protector enabled but compiler support broken
  Makefile:670: Cannot use CONFIG_CC_STACKPROTECTOR_STRONG: 
-fstack-protector-strong not supported by compiler
  
  the latest error logged is:
  
  /var/lib/dkms/nvidia-361/361.42/build/nvidia/nv-frontend.c:1:0: error:
  code model kernel does not support PIC mode
  
  Looks like it is related to the latest changes updates: gcc-6/gcc-5 
5.3.1-16ubuntu2 (some packages built with gcc-6; gcc-5 disabled for the 
packages built with gcc-6)
  Maybe some alternatives has not been updated to take care of these changes, 
as asked some time ago:
  http://askubuntu.com/questions/26498/choose-gcc-and-g-version
  
  This has been firstly reported against a nvidia crash:
  
https://bugs.launchpad.net/ubuntu/+source/nvidia-graphics-drivers-361/+bug/1574838
  
  ProblemType: Bug
  DistroRelease: Ubuntu 16.10
  Package: gcc 4:5.3.1-1ubuntu1
  ProcVersionSignature: Ubuntu 4.4.0-21.37-generic 4.4.6
  Uname: Linux 4.4.0-21-generic x86_64
  NonfreeKernelModules: nvidia_uvm nvidia_modeset nvidia
  ApportVersion: 2.20.1-0ubuntu2
  Architecture: amd64
  CurrentDesktop: GNOME
  Date: Tue Apr 26 08:41:32 2016
  SourcePackage: gcc-defaults
  UpgradeStatus: No upgrade log present (probably fresh install)
  ---
  ApportVersion: 2.20.1-0ubuntu2
  Architecture: amd64
  AudioDevicesInUse:
   USERPID ACCESS COMMAND
   /dev/snd/controlC1:  oem2014 F pulseaudio
   /dev/snd/pcmC0D0p:   oem2014 F...m pulseaudio
   /dev/snd/controlC0:  oem2014 F pulseaudio
  CurrentDesktop: GNOME
  DistroRelease: Ubuntu 16.10
  HibernationDevice: RESUME=UUID=0a9ca7f0-6eeb-4b21-b70f-670fa600de16
  IwConfig:
   eth0  no wireless extensions.
  
   eth1  no wireless extensions.
  
   lono wireless extensions.
  Lsusb:
   Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
   Bus 003 Device 002: ID 046d:c062 Logitech, Inc. M-UAS144 [LS1 Laser Mouse]
   Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
   Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
  MachineType: ASUSTEK COMPUTER INC P5W DH Deluxe
  NonfreeKernelModules: nvidia_uvm nvidia_modeset nvidia
  Package: ubuntu
  ProcFB:
  
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.4.0-21-generic 
root=UUID=7c755ed6-51cc-4b75-88ac-9c75acf82749 ro
  ProcVersionSignature: Ubuntu 4.4.0-21.37-generic 4.4.6
  RelatedPackageVersions:
   linux-restricted-modules-4.4.0-21-generic N/A
   linux-backports-modules-4.4.0-21-generic  N/A
   linux-firmware1.157
  RfKill:
  
  Tags:  yakkety
  Uname: Linux 4.4.0-21-generic x86_64
  UpgradeStatus: No upgrade log present (probably fresh install)
  UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
  _MarkForUpload: True
  dmi.bios.date: 07/22/2010
  dmi.bios.vendor: American Megatrends Inc.
  dmi.bios.version: 3002
  dmi.board.asset.tag: To Be Filled By O.E.M.
  dmi.board.name: P5W DH Deluxe
  dmi.board.vendor: ASUSTeK Computer INC.
  dmi.board.version: Rev 1.xx
  dmi.chassis.asset.tag: Asset-1234567890
  dmi.chassis.type: 3
  dmi.chassis.vendor: Chassis Manufacture
  dmi.chassis.version: Chassis Version
  dmi.modalias: 
dmi:bvnAmericanMegatrendsInc.:bvr3002:bd07/22/2010:svnASUSTEKCOMPUTERINC:pnP5WDHDeluxe:pvrSystemVersion:rvnASUSTeKComputerINC.:rnP5WDHDeluxe:rvrRev1.xx:cvnChassisManufacture:ct3:cvrChassisVersion:
  dmi.product.name: P5W DH Deluxe
  dmi.product.version: System Version
  dmi.sys.vendor: ASUSTEK COMPUTER INC

-- 
You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.
https://bugs.launchpad.net/bugs/1574982

Title:
  Cannot use CONFIG_CC_STACKPROTECTOR_STRONG: -fstack-protector-strong
  not supported by compiler

Status in gcc-defaults package in Ubuntu:
  New
Status in linux package in Ubuntu:
  Confirmed
Status in ubuntu package in Ubuntu:
  New

Bug description:
  Installing the latest 4.4.0-22 kernel ends with that error logged into 
dkmsbuildlog
  (only affect yakkety kernel; 4.4.0-22 kernel installation on xenial is fine)

  https://launchpadlibrarian.net/256055415/DKMSBuildLog.txt

  make "CC=cc"  KBUILD_VERBOSE= -C /lib/modules/4.4.0-22-generic/build 

[Kernel-packages] [Bug 1574982] Re: Cannot use CONFIG_CC_STACKPROTECTOR_STRONG: -fstack-protector-strong not supported by compiler

2016-04-26 Thread dino99
** Tags added: apport-collected

** Description changed:

  Installing the latest 4.4.0-22 kernel ends with that error logged into
  dkmsbuildlog
  
  make "CC=cc"  KBUILD_VERBOSE= -C /lib/modules/4.4.0-22-generic/build 
M=/var/lib/dkms/nvidia-361/361.42/build ARCH=x86_64 
NV_KERNEL_SOURCES=/lib/modules/4.4.0-22-generic/build 
NV_KERNEL_OUTPUT=/lib/modules/4.4.0-22-generic/build NV_KERNEL_MODULES="nvidia 
nvidia-uvm nvidia-modeset" INSTALL_MOD_DIR=kernel/drivers/video modules
  make[1]: Entering directory '/usr/src/linux-headers-4.4.0-22-generic'
  arch/x86/Makefile:133: stack-protector enabled but compiler support broken
  Makefile:670: Cannot use CONFIG_CC_STACKPROTECTOR_STRONG: 
-fstack-protector-strong not supported by compiler
  
  the latest error logged is:
  
  /var/lib/dkms/nvidia-361/361.42/build/nvidia/nv-frontend.c:1:0: error:
  code model kernel does not support PIC mode
  
  Looks like it is related to the latest changes updates: gcc-6/gcc-5 
5.3.1-16ubuntu2 (some packages built with gcc-6; gcc-5 disabled for the 
packages built with gcc-6)
  Maybe some alternatives has not been updated to take care of these changes, 
as asked some time ago:
  http://askubuntu.com/questions/26498/choose-gcc-and-g-version
  
  This has been firstly reported against a nvidia crash:
  
https://bugs.launchpad.net/ubuntu/+source/nvidia-graphics-drivers-361/+bug/1574838
  
  ProblemType: Bug
  DistroRelease: Ubuntu 16.10
  Package: gcc 4:5.3.1-1ubuntu1
  ProcVersionSignature: Ubuntu 4.4.0-21.37-generic 4.4.6
  Uname: Linux 4.4.0-21-generic x86_64
  NonfreeKernelModules: nvidia_uvm nvidia_modeset nvidia
  ApportVersion: 2.20.1-0ubuntu2
  Architecture: amd64
  CurrentDesktop: GNOME
  Date: Tue Apr 26 08:41:32 2016
  SourcePackage: gcc-defaults
  UpgradeStatus: No upgrade log present (probably fresh install)
+ --- 
+ ApportVersion: 2.20.1-0ubuntu2
+ Architecture: amd64
+ AudioDevicesInUse:
+  USERPID ACCESS COMMAND
+  /dev/snd/controlC1:  oem2014 F pulseaudio
+  /dev/snd/pcmC0D0p:   oem2014 F...m pulseaudio
+  /dev/snd/controlC0:  oem2014 F pulseaudio
+ CurrentDesktop: GNOME
+ DistroRelease: Ubuntu 16.10
+ HibernationDevice: RESUME=UUID=0a9ca7f0-6eeb-4b21-b70f-670fa600de16
+ IwConfig:
+  eth0  no wireless extensions.
+  
+  eth1  no wireless extensions.
+  
+  lono wireless extensions.
+ Lsusb:
+  Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
+  Bus 003 Device 002: ID 046d:c062 Logitech, Inc. M-UAS144 [LS1 Laser Mouse]
+  Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
+  Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
+ MachineType: ASUSTEK COMPUTER INC P5W DH Deluxe
+ NonfreeKernelModules: nvidia_uvm nvidia_modeset nvidia
+ Package: ubuntu
+ ProcFB:
+  
+ ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.4.0-21-generic 
root=UUID=7c755ed6-51cc-4b75-88ac-9c75acf82749 ro
+ ProcVersionSignature: Ubuntu 4.4.0-21.37-generic 4.4.6
+ RelatedPackageVersions:
+  linux-restricted-modules-4.4.0-21-generic N/A
+  linux-backports-modules-4.4.0-21-generic  N/A
+  linux-firmware1.157
+ RfKill:
+  
+ Tags:  yakkety
+ Uname: Linux 4.4.0-21-generic x86_64
+ UpgradeStatus: No upgrade log present (probably fresh install)
+ UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
+ _MarkForUpload: True
+ dmi.bios.date: 07/22/2010
+ dmi.bios.vendor: American Megatrends Inc.
+ dmi.bios.version: 3002
+ dmi.board.asset.tag: To Be Filled By O.E.M.
+ dmi.board.name: P5W DH Deluxe
+ dmi.board.vendor: ASUSTeK Computer INC.
+ dmi.board.version: Rev 1.xx
+ dmi.chassis.asset.tag: Asset-1234567890
+ dmi.chassis.type: 3
+ dmi.chassis.vendor: Chassis Manufacture
+ dmi.chassis.version: Chassis Version
+ dmi.modalias: 
dmi:bvnAmericanMegatrendsInc.:bvr3002:bd07/22/2010:svnASUSTEKCOMPUTERINC:pnP5WDHDeluxe:pvrSystemVersion:rvnASUSTeKComputerINC.:rnP5WDHDeluxe:rvrRev1.xx:cvnChassisManufacture:ct3:cvrChassisVersion:
+ dmi.product.name: P5W DH Deluxe
+ dmi.product.version: System Version
+ dmi.sys.vendor: ASUSTEK COMPUTER INC

** Changed in: linux (Ubuntu)
   Status: Incomplete => Confirmed

** Description changed:

  Installing the latest 4.4.0-22 kernel ends with that error logged into
  dkmsbuildlog
+ 
+ https://launchpadlibrarian.net/256055415/DKMSBuildLog.txt
  
  make "CC=cc"  KBUILD_VERBOSE= -C /lib/modules/4.4.0-22-generic/build 
M=/var/lib/dkms/nvidia-361/361.42/build ARCH=x86_64 
NV_KERNEL_SOURCES=/lib/modules/4.4.0-22-generic/build 
NV_KERNEL_OUTPUT=/lib/modules/4.4.0-22-generic/build NV_KERNEL_MODULES="nvidia 
nvidia-uvm nvidia-modeset" INSTALL_MOD_DIR=kernel/drivers/video modules
  make[1]: Entering directory '/usr/src/linux-headers-4.4.0-22-generic'
  arch/x86/Makefile:133: stack-protector enabled but compiler support broken
  Makefile:670: Cannot use CONFIG_CC_STACKPROTECTOR_STRONG: 
-fstack-protector-strong not supported by compiler
  
  the latest error logged is:
  
  

[Kernel-packages] [Bug 1574982] Re: Cannot use CONFIG_CC_STACKPROTECTOR_STRONG: -fstack-protector-strong not supported by compiler

2016-04-26 Thread dino99
** Changed in: linux (Ubuntu)
   Status: Incomplete => New

-- 
You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.
https://bugs.launchpad.net/bugs/1574982

Title:
  Cannot use CONFIG_CC_STACKPROTECTOR_STRONG: -fstack-protector-strong
  not supported by compiler

Status in gcc-defaults package in Ubuntu:
  New
Status in linux package in Ubuntu:
  New
Status in ubuntu package in Ubuntu:
  New

Bug description:
  Installing the latest 4.4.0-22 kernel ends with that error logged into
  dkmsbuildlog

  make "CC=cc"  KBUILD_VERBOSE= -C /lib/modules/4.4.0-22-generic/build 
M=/var/lib/dkms/nvidia-361/361.42/build ARCH=x86_64 
NV_KERNEL_SOURCES=/lib/modules/4.4.0-22-generic/build 
NV_KERNEL_OUTPUT=/lib/modules/4.4.0-22-generic/build NV_KERNEL_MODULES="nvidia 
nvidia-uvm nvidia-modeset" INSTALL_MOD_DIR=kernel/drivers/video modules
  make[1]: Entering directory '/usr/src/linux-headers-4.4.0-22-generic'
  arch/x86/Makefile:133: stack-protector enabled but compiler support broken
  Makefile:670: Cannot use CONFIG_CC_STACKPROTECTOR_STRONG: 
-fstack-protector-strong not supported by compiler

  the latest error logged is:

  /var/lib/dkms/nvidia-361/361.42/build/nvidia/nv-frontend.c:1:0: error:
  code model kernel does not support PIC mode

  Looks like it is related to the latest changes updates: gcc-6/gcc-5 
5.3.1-16ubuntu2 (some packages built with gcc-6; gcc-5 disabled for the 
packages built with gcc-6)
  Maybe some alternatives has not been updated to take care of these changes, 
as asked some time ago:
  http://askubuntu.com/questions/26498/choose-gcc-and-g-version

  This has been firstly reported against a nvidia crash:
  
https://bugs.launchpad.net/ubuntu/+source/nvidia-graphics-drivers-361/+bug/1574838

  ProblemType: Bug
  DistroRelease: Ubuntu 16.10
  Package: gcc 4:5.3.1-1ubuntu1
  ProcVersionSignature: Ubuntu 4.4.0-21.37-generic 4.4.6
  Uname: Linux 4.4.0-21-generic x86_64
  NonfreeKernelModules: nvidia_uvm nvidia_modeset nvidia
  ApportVersion: 2.20.1-0ubuntu2
  Architecture: amd64
  CurrentDesktop: GNOME
  Date: Tue Apr 26 08:41:32 2016
  SourcePackage: gcc-defaults
  UpgradeStatus: No upgrade log present (probably fresh install)

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/gcc-defaults/+bug/1574982/+subscriptions

-- 
Mailing list: https://launchpad.net/~kernel-packages
Post to : kernel-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~kernel-packages
More help   : https://help.launchpad.net/ListHelp


[Kernel-packages] [Bug 1574982] Re: Cannot use CONFIG_CC_STACKPROTECTOR_STRONG: -fstack-protector-strong not supported by compiler

2016-04-26 Thread dino99
That issue has been met also by other distros many times; and nvidia
says its a kernel toolchain problem; so opening a 'linux' issue too.

https://devtalk.nvidia.com/default/topic/902950/linux/-solved-faulty-340
-9x-drivers-with-kernels-4-2-x-and-4-3-x/

** Also affects: ubuntu (Ubuntu)
   Importance: Undecided
   Status: New

** Also affects: linux (Ubuntu)
   Importance: Undecided
   Status: New

-- 
You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.
https://bugs.launchpad.net/bugs/1574982

Title:
  Cannot use CONFIG_CC_STACKPROTECTOR_STRONG: -fstack-protector-strong
  not supported by compiler

Status in gcc-defaults package in Ubuntu:
  New
Status in linux package in Ubuntu:
  Incomplete
Status in ubuntu package in Ubuntu:
  New

Bug description:
  Installing the latest 4.4.0-22 kernel ends with that error logged into
  dkmsbuildlog

  make "CC=cc"  KBUILD_VERBOSE= -C /lib/modules/4.4.0-22-generic/build 
M=/var/lib/dkms/nvidia-361/361.42/build ARCH=x86_64 
NV_KERNEL_SOURCES=/lib/modules/4.4.0-22-generic/build 
NV_KERNEL_OUTPUT=/lib/modules/4.4.0-22-generic/build NV_KERNEL_MODULES="nvidia 
nvidia-uvm nvidia-modeset" INSTALL_MOD_DIR=kernel/drivers/video modules
  make[1]: Entering directory '/usr/src/linux-headers-4.4.0-22-generic'
  arch/x86/Makefile:133: stack-protector enabled but compiler support broken
  Makefile:670: Cannot use CONFIG_CC_STACKPROTECTOR_STRONG: 
-fstack-protector-strong not supported by compiler

  the latest error logged is:

  /var/lib/dkms/nvidia-361/361.42/build/nvidia/nv-frontend.c:1:0: error:
  code model kernel does not support PIC mode

  Looks like it is related to the latest changes updates: gcc-6/gcc-5 
5.3.1-16ubuntu2 (some packages built with gcc-6; gcc-5 disabled for the 
packages built with gcc-6)
  Maybe some alternatives has not been updated to take care of these changes, 
as asked some time ago:
  http://askubuntu.com/questions/26498/choose-gcc-and-g-version

  This has been firstly reported against a nvidia crash:
  
https://bugs.launchpad.net/ubuntu/+source/nvidia-graphics-drivers-361/+bug/1574838

  ProblemType: Bug
  DistroRelease: Ubuntu 16.10
  Package: gcc 4:5.3.1-1ubuntu1
  ProcVersionSignature: Ubuntu 4.4.0-21.37-generic 4.4.6
  Uname: Linux 4.4.0-21-generic x86_64
  NonfreeKernelModules: nvidia_uvm nvidia_modeset nvidia
  ApportVersion: 2.20.1-0ubuntu2
  Architecture: amd64
  CurrentDesktop: GNOME
  Date: Tue Apr 26 08:41:32 2016
  SourcePackage: gcc-defaults
  UpgradeStatus: No upgrade log present (probably fresh install)

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/gcc-defaults/+bug/1574982/+subscriptions

-- 
Mailing list: https://launchpad.net/~kernel-packages
Post to : kernel-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~kernel-packages
More help   : https://help.launchpad.net/ListHelp