[Kernel-packages] [Bug 1769980] Re: Intel WiFi Linux driver update for ETSI 5GHz Adaptivity Requirement

2018-07-22 Thread Yuan-Chen Cheng
** Changed in: oem-priority Status: Triaged => Fix Released -- You received this bug notification because you are a member of Kernel Packages, which is subscribed to wireless-regdb in Ubuntu. https://bugs.launchpad.net/bugs/1769980 Title: Intel WiFi Linux driver update for ETSI 5GHz

[Kernel-packages] [Bug 1769980] Re: Intel WiFi Linux driver update for ETSI 5GHz Adaptivity Requirement

2018-06-15 Thread Launchpad Bug Tracker
This bug was fixed in the package linux-oem - 4.15.0-1008.11 --- linux-oem (4.15.0-1008.11) bionic; urgency=medium * linux-oem: 4.15.0-1008.11 -proposed tracker (LP: #1774764) * [Redpine] Wifi AP does not work (LP: #1774606) - Revert "UBUNTU: SAUCE: rsi: drop RX

[Kernel-packages] [Bug 1769980] Re: Intel WiFi Linux driver update for ETSI 5GHz Adaptivity Requirement

2018-06-14 Thread Anthony Wong
** Changed in: hwe-next Status: In Progress => Fix Released -- You received this bug notification because you are a member of Kernel Packages, which is subscribed to wireless-regdb in Ubuntu. https://bugs.launchpad.net/bugs/1769980 Title: Intel WiFi Linux driver update for ETSI 5GHz

[Kernel-packages] [Bug 1769980] Re: Intel WiFi Linux driver update for ETSI 5GHz Adaptivity Requirement

2018-06-14 Thread Launchpad Bug Tracker
This bug was fixed in the package wireless-regdb - 2018.05.09-0ubuntu1~16.04.1 --- wireless-regdb (2018.05.09-0ubuntu1~16.04.1) xenial; urgency=medium * New upstream release. (LP: #1769980) * debian/patches: - Drop existing patches. -

[Kernel-packages] [Bug 1769980] Re: Intel WiFi Linux driver update for ETSI 5GHz Adaptivity Requirement

2018-06-13 Thread Launchpad Bug Tracker
This bug was fixed in the package wireless-regdb - 2018.05.09-0ubuntu1~18.04.1 --- wireless-regdb (2018.05.09-0ubuntu1~18.04.1) bionic; urgency=medium * New upstream release. (LP: #1769980) * debian/patches: - Drop existing patches. -

[Kernel-packages] [Bug 1769980] Re: Intel WiFi Linux driver update for ETSI 5GHz Adaptivity Requirement

2018-06-13 Thread Anthony Wong
Our QA has tested the packages, all work well. ** Tags removed: verification-needed verification-needed-bionic verification-needed-xenial ** Tags added: verification-done verification-done-bionic verification-done-xenial -- You received this bug notification because you are a member of Kernel

[Kernel-packages] [Bug 1769980] Re: Intel WiFi Linux driver update for ETSI 5GHz Adaptivity Requirement

2018-06-13 Thread Launchpad Bug Tracker
This bug was fixed in the package linux-oem - 4.15.0-1008.11 --- linux-oem (4.15.0-1008.11) bionic; urgency=medium * linux-oem: 4.15.0-1008.11 -proposed tracker (LP: #1774764) * [Redpine] Wifi AP does not work (LP: #1774606) - Revert "UBUNTU: SAUCE: rsi: drop RX

[Kernel-packages] [Bug 1769980] Re: Intel WiFi Linux driver update for ETSI 5GHz Adaptivity Requirement

2018-06-11 Thread Launchpad Bug Tracker
This bug was fixed in the package linux-oem - 4.13.0-1030.33 --- linux-oem (4.13.0-1030.33) xenial; urgency=medium * linux-oem: 4.13.0-1030.33 -proposed tracker (LP: #1774126) * Miscellaneous Ubuntu changes - Rebase to 4.13.0-45.50 [ Ubuntu: 4.13.0-45.50 ] * linux:

[Kernel-packages] [Bug 1769980] Re: Intel WiFi Linux driver update for ETSI 5GHz Adaptivity Requirement

2018-05-29 Thread Timo Aaltonen
** Changed in: linux-oem (Ubuntu Bionic) Status: In Progress => Fix Committed ** Changed in: linux-oem (Ubuntu Xenial) Status: In Progress => Fix Committed ** Changed in: linux-oem (Ubuntu) Status: New => Invalid -- You received this bug notification because you are a

[Kernel-packages] [Bug 1769980] Re: Intel WiFi Linux driver update for ETSI 5GHz Adaptivity Requirement

2018-05-28 Thread Łukasz Zemczak
I have accepted both the xenial and bionic wireless-regdb uploads. One thing that stood out was the __eq__ implementation in the 0001-wireless- regdb-Fix-comparison-of-WmmRule-with-NoneTy.patch patch which seems to look a bit strange (no _as_tuple() before the comparison), but I have been informed

[Kernel-packages] [Bug 1769980] Re: Intel WiFi Linux driver update for ETSI 5GHz Adaptivity Requirement

2018-05-28 Thread Łukasz Zemczak
Hello Anthony, or anyone else affected, Accepted wireless-regdb into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/wireless- regdb/2018.05.09-0ubuntu1~18.04.1 in a few hours, and then in the -proposed repository. Please help us by testing

[Kernel-packages] [Bug 1769980] Re: Intel WiFi Linux driver update for ETSI 5GHz Adaptivity Requirement

2018-05-28 Thread Seth Forshee
** Description changed: Intel wireless driver and firmware require updates in order to meet the new ETSI regulation [1] for OEM machines shipped from factories. Intel provided us the following information for what are required to update: 1. Kernel driver:

[Kernel-packages] [Bug 1769980] Re: Intel WiFi Linux driver update for ETSI 5GHz Adaptivity Requirement

2018-05-28 Thread Launchpad Bug Tracker
This bug was fixed in the package linux-firmware - 1.173.1 --- linux-firmware (1.173.1) bionic; urgency=medium * Redpine: BLE radio lost issue (LP: #1757443) - linux-firmware: rsi: update firmware images for Redpine 9113 chipset * Intel WiFi Linux driver update for ETSI 5GHz

[Kernel-packages] [Bug 1769980] Re: Intel WiFi Linux driver update for ETSI 5GHz Adaptivity Requirement

2018-05-28 Thread Launchpad Bug Tracker
This bug was fixed in the package linux-firmware - 1.157.19 --- linux-firmware (1.157.19) xenial; urgency=medium * Intel WiFi Linux driver update for ETSI 5GHz Adaptivity Requirement (LP: #1769980) - iwlwifi: add some new FW versions and update older ones - iwlwifi:

[Kernel-packages] [Bug 1769980] Re: Intel WiFi Linux driver update for ETSI 5GHz Adaptivity Requirement

2018-05-27 Thread Anthony Wong
** Description changed: Intel wireless driver and firmware require updates in order to meet the new ETSI regulation [1] for OEM machines shipped from factories. Intel provided us the following information for what are required to update: 1. Kernel driver:

[Kernel-packages] [Bug 1769980] Re: Intel WiFi Linux driver update for ETSI 5GHz Adaptivity Requirement

2018-05-25 Thread Anthony Wong
** Changed in: linux-oem (Ubuntu Xenial) Status: New => In Progress ** Changed in: linux-oem (Ubuntu Xenial) Assignee: (unassigned) => Anthony Wong (anthonywong) ** Changed in: linux (Ubuntu Xenial) Status: In Progress => Confirmed ** Changed in: linux (Ubuntu Xenial)

[Kernel-packages] [Bug 1769980] Re: Intel WiFi Linux driver update for ETSI 5GHz Adaptivity Requirement

2018-05-23 Thread Anthony Wong
Revert the verification-* tags as crda has been removed from -proposed. ** Tags removed: verification-failed-xenial verification-needed ** Tags added: verification-done-xenial -- You received this bug notification because you are a member of Kernel Packages, which is subscribed to

[Kernel-packages] [Bug 1769980] Re: Intel WiFi Linux driver update for ETSI 5GHz Adaptivity Requirement

2018-05-23 Thread Steve Langasek
This conflict is causing daily image builds to fail in xenial, so I'm removing the v-failed SRU from xenial-proposed. Removing packages from xenial-proposed: crda 3.13-1ubuntu0.16.04.1 in xenial crda 3.13-1ubuntu0.16.04.1 in xenial amd64 crda

[Kernel-packages] [Bug 1769980] Re: Intel WiFi Linux driver update for ETSI 5GHz Adaptivity Requirement

2018-05-23 Thread Anthony Wong
** Changed in: crda (Ubuntu Xenial) Status: Fix Committed => Invalid -- You received this bug notification because you are a member of Kernel Packages, which is subscribed to wireless-regdb in Ubuntu. https://bugs.launchpad.net/bugs/1769980 Title: Intel WiFi Linux driver update for

[Kernel-packages] [Bug 1769980] Re: Intel WiFi Linux driver update for ETSI 5GHz Adaptivity Requirement

2018-05-23 Thread Seth Forshee
Turns out there's a hiccup with the crda update for xenial, unbeknownst to us wireless-regdb is (incorrectly) already installing my public key. The easiest path forward seems to be just leaving crda as is and making the regdb update continue to install my key. As such I'm marking verification for

[Kernel-packages] [Bug 1769980] Re: Intel WiFi Linux driver update for ETSI 5GHz Adaptivity Requirement

2018-05-23 Thread Timo Aaltonen
Hello Anthony, or anyone else affected, Accepted crda into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/crda/3.13-1ubuntu0.16.04.1 in a few hours, and then in the -proposed repository. Please help us by testing this new package. See

[Kernel-packages] [Bug 1769980] Re: Intel WiFi Linux driver update for ETSI 5GHz Adaptivity Requirement

2018-05-23 Thread Anthony Wong
crda debdiff for Xenial ** Patch added: "crda_3.13-1ubuntu1.debdiff" https://bugs.launchpad.net/ubuntu/bionic/+source/crda/+bug/1769980/+attachment/5143283/+files/crda_3.13-1ubuntu1.debdiff ** Description changed: Intel wireless driver and firmware require updates in order to meet the

[Kernel-packages] [Bug 1769980] Re: Intel WiFi Linux driver update for ETSI 5GHz Adaptivity Requirement

2018-05-23 Thread Anthony Wong
** Also affects: crda (Ubuntu) Importance: Undecided Status: New ** Changed in: crda (Ubuntu) Status: New => Invalid ** Changed in: crda (Ubuntu Bionic) Status: New => Invalid -- You received this bug notification because you are a member of Kernel Packages, which is

[Kernel-packages] [Bug 1769980] Re: Intel WiFi Linux driver update for ETSI 5GHz Adaptivity Requirement

2018-05-22 Thread Anthony Wong
** Tags added: verification-done-bionic verification-done-xenial -- You received this bug notification because you are a member of Kernel Packages, which is subscribed to wireless-regdb in Ubuntu. https://bugs.launchpad.net/bugs/1769980 Title: Intel WiFi Linux driver update for ETSI 5GHz

[Kernel-packages] [Bug 1769980] Re: Intel WiFi Linux driver update for ETSI 5GHz Adaptivity Requirement

2018-05-22 Thread Anthony Wong
Verified the new firmwares in xenial-proposed and xenial-bionic are correct. -- You received this bug notification because you are a member of Kernel Packages, which is subscribed to wireless-regdb in Ubuntu. https://bugs.launchpad.net/bugs/1769980 Title: Intel WiFi Linux driver update for

[Kernel-packages] [Bug 1769980] Re: Intel WiFi Linux driver update for ETSI 5GHz Adaptivity Requirement

2018-05-21 Thread Launchpad Bug Tracker
This bug was fixed in the package wireless-regdb - 2018.05.09-0ubuntu1 --- wireless-regdb (2018.05.09-0ubuntu1) cosmic; urgency=medium * New upstream release. (LP: #1769980) * debian/patches: - Drop existing patches. -

[Kernel-packages] [Bug 1769980] Re: Intel WiFi Linux driver update for ETSI 5GHz Adaptivity Requirement

2018-05-18 Thread Seth Forshee
** Changed in: linux-firmware (Ubuntu) Status: New => Fix Released ** Changed in: linux-firmware (Ubuntu Bionic) Status: In Progress => Fix Committed ** Changed in: linux-firmware (Ubuntu Xenial) Status: In Progress => Fix Committed -- You received this bug notification

[Kernel-packages] [Bug 1769980] Re: Intel WiFi Linux driver update for ETSI 5GHz Adaptivity Requirement

2018-05-17 Thread Anthony Wong
** Description changed: Intel wireless driver and firmware require updates in order to meet the new ETSI regulation [1] for OEM machines shipped from factories. Intel provided us the following information for what are required to update: 1. Kernel driver:

[Kernel-packages] [Bug 1769980] Re: Intel WiFi Linux driver update for ETSI 5GHz Adaptivity Requirement

2018-05-17 Thread Anthony Wong
** Changed in: linux-firmware (Ubuntu Xenial) Status: New => In Progress ** Changed in: linux-firmware (Ubuntu Xenial) Assignee: (unassigned) => Anthony Wong (anthonywong) ** Changed in: linux-firmware (Ubuntu Bionic) Status: New => In Progress ** Changed in: linux-firmware

[Kernel-packages] [Bug 1769980] Re: Intel WiFi Linux driver update for ETSI 5GHz Adaptivity Requirement

2018-05-15 Thread Anthony Wong
Yes, I will send one. -- You received this bug notification because you are a member of Kernel Packages, which is subscribed to wireless-regdb in Ubuntu. https://bugs.launchpad.net/bugs/1769980 Title: Intel WiFi Linux driver update for ETSI 5GHz Adaptivity Requirement Status in HWE Next:

[Kernel-packages] [Bug 1769980] Re: Intel WiFi Linux driver update for ETSI 5GHz Adaptivity Requirement

2018-05-10 Thread Seth Forshee
@Anthony: will someone be sending a pull request for linux-firmware? -- You received this bug notification because you are a member of Kernel Packages, which is subscribed to wireless-regdb in Ubuntu. https://bugs.launchpad.net/bugs/1769980 Title: Intel WiFi Linux driver update for ETSI 5GHz

[Kernel-packages] [Bug 1769980] Re: Intel WiFi Linux driver update for ETSI 5GHz Adaptivity Requirement

2018-05-10 Thread Seth Forshee
I released a new wireless-regdb yesterday with the changes needed for this. I've also prepped an update for cosmic and handed it off to apw for review. Once that's done we can backport to bionic at least. For xenial we will need to confirm that the crda version is new enough to ship with my public

[Kernel-packages] [Bug 1769980] Re: Intel WiFi Linux driver update for ETSI 5GHz Adaptivity Requirement

2018-05-10 Thread Anthony Wong
Not just the changes to support for the new regulatory database format, but also to support the new firmware, as FW API has bumped and may need to pull in more patches. For example, 3165/7265D/8260 NIC in v4.4 supports FW API from 13 to 19, but the new FW for 3165/7265D has bumped to API 29, and

[Kernel-packages] [Bug 1769980] Re: Intel WiFi Linux driver update for ETSI 5GHz Adaptivity Requirement

2018-05-09 Thread Seth Forshee
4.13 will also be missing support for the new regulatory database format, so I'd expect the effort to backport there to be similar to that for 4.4. -- You received this bug notification because you are a member of Kernel Packages, which is subscribed to wireless-regdb in Ubuntu.

[Kernel-packages] [Bug 1769980] Re: Intel WiFi Linux driver update for ETSI 5GHz Adaptivity Requirement

2018-05-09 Thread Anthony Wong
@sforshee We need to provide a solution for Xenial v4.4 kernel for our OEM projects, but since the kernel is too far behind, we will take another approach to provide the driver update instead of patching the kernel. Besides v4.4, we also use 16.04.4 in our projects, so we will need to update

[Kernel-packages] [Bug 1769980] Re: Intel WiFi Linux driver update for ETSI 5GHz Adaptivity Requirement

2018-05-09 Thread Yuan-Chen Cheng
** Also affects: oem-priority Importance: Undecided Status: New ** Changed in: oem-priority Importance: Undecided => Critical ** Changed in: oem-priority Status: New => Triaged -- You received this bug notification because you are a member of Kernel Packages, which is

[Kernel-packages] [Bug 1769980] Re: Intel WiFi Linux driver update for ETSI 5GHz Adaptivity Requirement

2018-05-08 Thread Seth Forshee
I'm not sure here whether the xenial nomination is meant to apply to the linux package. If so ... That list of kernel patches is probably correct for bionic. Xenial however is going to require additional patches. The wmm rules are only available with the newer, extensible regdb format which is