[Kernel-packages] [Bug 1804028] Re: Surface Go - QCA6174 wifi card not correctly recognized and therefore not working

2019-06-20 Thread Stefan Andersson
This bug is still active on linux-firmware-20190514 that I'm running.
I'll help any way I can if help is needed.

-- 
You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux-firmware in Ubuntu.
https://bugs.launchpad.net/bugs/1804028

Title:
  Surface Go - QCA6174 wifi card not correctly recognized and therefore
  not working

Status in linux-firmware package in Ubuntu:
  Confirmed
Status in linux-firmware package in Fedora:
  Fix Released

Bug description:
  Output of dmesg on Surface Go fresh installed Ubuntu 18.10.

  "[ 4.242132] ath10k_pci :01:00.0: qca6174 hw3.2 target 0x0503 chip_id 
0x00340aff sub 168c:3370
  [ 4.242138] ath10k_pci :01:00.0: kconfig debug 0 debugfs 1 tracing 1 dfs 
0 testmode 0
  [ 4.243006] ath10k_pci :01:00.0: firmware ver 
WLAN.RM.4.4.1-00079-QCARMSWPZ-1 api 6 features wowlan,ignore-otp crc32 fd869beb
  [ 4.308059] ath10k_pci :01:00.0: failed to fetch board data for 
bus=pci,vendor=168c,device=003e,subsystem-vendor=168c,subsystem-device=3370 
from ath10k/QCA6174/hw3.0/board-2.bin
  [ 4.309354] ath10k_pci :01:00.0: board_file api 1 bmi_id N/A crc32 
ed5f849a"

  There is a board.bin available directly from the vendor
  http://www.killernetworking.com/support/K1535_Debian/board.bin

  The only thing which is missing is getting this added to
  https://wireless.wiki.kernel.org/en/users/drivers/ath10k/boardfiles so
  the official board-2.bin. My problem is that I dont know how to read
  the board files and modify them because I do not know the encoding
  they use.

  Also there have been some updates in the upstream linux-firmware repo.
  https://git.kernel.org/pub/scm/linux/kernel/git/firmware/linux-
  firmware.git/commit/?id=a87eb5f7bac0f70ade57da57d9126d14eee12336 and
  https://github.com/kvalo/ath10k-firmware/tree/master/QCA6174/hw3.0 but
  they also do not help to get the wifi card working/recognized.

  Any ideas how to get this solved?

  Also there is a guide how to port it to Linux
  https://developer.qualcomm.com/download/qca9377/wlan-bluetooth-linux-
  porting-guide.pdf

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/linux-firmware/+bug/1804028/+subscriptions

-- 
Mailing list: https://launchpad.net/~kernel-packages
Post to : kernel-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~kernel-packages
More help   : https://help.launchpad.net/ListHelp


[Kernel-packages] [Bug 1804028] Re: Surface Go - QCA6174 wifi card not correctly recognized and therefore not working

2019-06-20 Thread Launchpad Bug Tracker
Status changed to 'Confirmed' because the bug affects multiple users.

** Changed in: linux-firmware (Ubuntu)
   Status: New => Confirmed

-- 
You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux-firmware in Ubuntu.
https://bugs.launchpad.net/bugs/1804028

Title:
  Surface Go - QCA6174 wifi card not correctly recognized and therefore
  not working

Status in linux-firmware package in Ubuntu:
  Confirmed
Status in linux-firmware package in Fedora:
  Fix Released

Bug description:
  Output of dmesg on Surface Go fresh installed Ubuntu 18.10.

  "[ 4.242132] ath10k_pci :01:00.0: qca6174 hw3.2 target 0x0503 chip_id 
0x00340aff sub 168c:3370
  [ 4.242138] ath10k_pci :01:00.0: kconfig debug 0 debugfs 1 tracing 1 dfs 
0 testmode 0
  [ 4.243006] ath10k_pci :01:00.0: firmware ver 
WLAN.RM.4.4.1-00079-QCARMSWPZ-1 api 6 features wowlan,ignore-otp crc32 fd869beb
  [ 4.308059] ath10k_pci :01:00.0: failed to fetch board data for 
bus=pci,vendor=168c,device=003e,subsystem-vendor=168c,subsystem-device=3370 
from ath10k/QCA6174/hw3.0/board-2.bin
  [ 4.309354] ath10k_pci :01:00.0: board_file api 1 bmi_id N/A crc32 
ed5f849a"

  There is a board.bin available directly from the vendor
  http://www.killernetworking.com/support/K1535_Debian/board.bin

  The only thing which is missing is getting this added to
  https://wireless.wiki.kernel.org/en/users/drivers/ath10k/boardfiles so
  the official board-2.bin. My problem is that I dont know how to read
  the board files and modify them because I do not know the encoding
  they use.

  Also there have been some updates in the upstream linux-firmware repo.
  https://git.kernel.org/pub/scm/linux/kernel/git/firmware/linux-
  firmware.git/commit/?id=a87eb5f7bac0f70ade57da57d9126d14eee12336 and
  https://github.com/kvalo/ath10k-firmware/tree/master/QCA6174/hw3.0 but
  they also do not help to get the wifi card working/recognized.

  Any ideas how to get this solved?

  Also there is a guide how to port it to Linux
  https://developer.qualcomm.com/download/qca9377/wlan-bluetooth-linux-
  porting-guide.pdf

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/linux-firmware/+bug/1804028/+subscriptions

-- 
Mailing list: https://launchpad.net/~kernel-packages
Post to : kernel-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~kernel-packages
More help   : https://help.launchpad.net/ListHelp


[Kernel-packages] [Bug 1804028] Re: Surface Go - QCA6174 wifi card not correctly recognized and therefore not working

2019-04-09 Thread Bug Watch Updater
** Changed in: linux-firmware (Fedora)
   Status: Fix Committed => Fix Released

-- 
You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux-firmware in Ubuntu.
https://bugs.launchpad.net/bugs/1804028

Title:
  Surface Go - QCA6174 wifi card not correctly recognized and therefore
  not working

Status in linux-firmware package in Ubuntu:
  New
Status in linux-firmware package in Fedora:
  Fix Released

Bug description:
  Output of dmesg on Surface Go fresh installed Ubuntu 18.10.

  "[ 4.242132] ath10k_pci :01:00.0: qca6174 hw3.2 target 0x0503 chip_id 
0x00340aff sub 168c:3370
  [ 4.242138] ath10k_pci :01:00.0: kconfig debug 0 debugfs 1 tracing 1 dfs 
0 testmode 0
  [ 4.243006] ath10k_pci :01:00.0: firmware ver 
WLAN.RM.4.4.1-00079-QCARMSWPZ-1 api 6 features wowlan,ignore-otp crc32 fd869beb
  [ 4.308059] ath10k_pci :01:00.0: failed to fetch board data for 
bus=pci,vendor=168c,device=003e,subsystem-vendor=168c,subsystem-device=3370 
from ath10k/QCA6174/hw3.0/board-2.bin
  [ 4.309354] ath10k_pci :01:00.0: board_file api 1 bmi_id N/A crc32 
ed5f849a"

  There is a board.bin available directly from the vendor
  http://www.killernetworking.com/support/K1535_Debian/board.bin

  The only thing which is missing is getting this added to
  https://wireless.wiki.kernel.org/en/users/drivers/ath10k/boardfiles so
  the official board-2.bin. My problem is that I dont know how to read
  the board files and modify them because I do not know the encoding
  they use.

  Also there have been some updates in the upstream linux-firmware repo.
  https://git.kernel.org/pub/scm/linux/kernel/git/firmware/linux-
  firmware.git/commit/?id=a87eb5f7bac0f70ade57da57d9126d14eee12336 and
  https://github.com/kvalo/ath10k-firmware/tree/master/QCA6174/hw3.0 but
  they also do not help to get the wifi card working/recognized.

  Any ideas how to get this solved?

  Also there is a guide how to port it to Linux
  https://developer.qualcomm.com/download/qca9377/wlan-bluetooth-linux-
  porting-guide.pdf

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/linux-firmware/+bug/1804028/+subscriptions

-- 
Mailing list: https://launchpad.net/~kernel-packages
Post to : kernel-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~kernel-packages
More help   : https://help.launchpad.net/ListHelp


[Kernel-packages] [Bug 1804028] Re: Surface Go - QCA6174 wifi card not correctly recognized and therefore not working

2019-02-16 Thread Bug Watch Updater
Launchpad has imported 8 comments from the remote bug at
https://bugzilla.redhat.com/show_bug.cgi?id=1651779.

If you reply to an imported comment from within Launchpad, your comment
will be sent to the remote bug automatically. Read more about
Launchpad's inter-bugtracker facilities at
https://help.launchpad.net/InterBugTracking.


On 2018-11-20T19:42:11+00:00 fedora_45sg wrote:

Description of problem:

After booting, the wifi card is not properly recognized.

Version-Release number of selected component (if applicable):

firmware version can be seen in dmesg output.

"[ 4.242132] ath10k_pci :01:00.0: qca6174 hw3.2 target 0x0503 chip_id 
0x00340aff sub 168c:3370
[ 4.242138] ath10k_pci :01:00.0: kconfig debug 0 debugfs 1 tracing 1 dfs 0 
testmode 0
[ 4.243006] ath10k_pci :01:00.0: firmware ver 
WLAN.RM.4.4.1-00079-QCARMSWPZ-1 api 6 features wowlan,ignore-otp crc32 fd869beb
[ 4.308059] ath10k_pci :01:00.0: failed to fetch board data for 
bus=pci,vendor=168c,device=003e,subsystem-vendor=168c,subsystem-device=3370 
from ath10k/QCA6174/hw3.0/board-2.bin
[ 4.309354] ath10k_pci :01:00.0: board_file api 1 bmi_id N/A crc32 ed5f849a"

How reproducible:

Insert usb-pen, boot Fedora 29 Workstation, open terminal, get dmesg
output


Steps to Reproduce:
1. Boot
2. get dmesg output

Actual results:

dmesg output:


Wifi/bluetooth card not properly recognized and therefore not working

Expected results:

Wifi/bluetooth working.


Additional info:

I added some more results here:

https://bugs.launchpad.net/ubuntu/+source/linux-firmware/+bug/1804028

Reply at: https://bugs.launchpad.net/ubuntu/+source/linux-
firmware/+bug/1804028/comments/7


On 2018-11-20T22:18:44+00:00 fedora_45sg wrote:

In the .zip from https://www.killernetworking.com/killersupport/item
/killer-drivers-inf in the file ./Killer-Ethernet-
Wireless_INF/Production/Windows10-x64/11AC/netathr10x.inf I finally
found one matching subsystem-device=3370 entry, which leads to:

"
%ATHR.DeviceDesc.6320_3%   = ATHR_DEV_OS63_988x_TX8.ndi,
PCI\VEN_168C_003E_3370168C_32; WiFi Only SKU
"

about this special .ndi there are some entrys later:

"
[ATHR_DEV_OS63_988x_TX8.ndi.NTamd64]
Characteristics = 0x84
BusType = 5
AddReg  = atheros_os63.reg, atheros11n.reg, smpsDynamic.reg, 
qca_utf.reg, D0PC.reg, roam.reg, wmmac.reg, FW_3X.reg, BD_TX8.reg, 
enableTxbfee.reg, wowEnable.reg, ForceWowSleep.reg, fastDlBinary.reg, 
enableSmbios.reg, Ch1213_options_SingleSKU.reg   
CopyFiles   = atheros.CopyFiles, atheros_FW_3X.CopyFiles, 
atheros_BD_TX8.CopyFiles, service.CopyFiles
*IfType = 71; IF_TYPE_IEEE80211
*MediaType  = 16; NdisMediumNative802_11
*PhysicalMediaType = 9  ; NdisPhysicalMediumNative802_11
Include = machine.inf, netvwifibus.inf
Needs   = VWiFiBus.CopyFiles

[ATHR_DEV_OS63_988x_TX8.ndi.NTamd64.Services]
AddService = Qcamain10x64, 2, atheros.Service, atheros.EventLog
Include= netvwifibus.inf
Needs  = VWiFiBus.Services
AddService = QcomWlanSrv, 0x0800, wlanService

[ATHR_DEV_OS63_988x_TX8.ndi.NTamd64.HW]
AddReg  = MSI.reg
Include = netvwifibus.inf
Needs   = PciASPMOptIn.Hw, VWiFiBus.PnPFilterRegistration.Hw, 
PciD3ColdSupported.Hw
"

I am just a bit confused because it just says "Wifi Only SKU" and I know
from the Windows Device Manager that also bluetooth is done with the
same chip, see
https://www.reddit.com/r/Surface/comments/9386l7/surface_go_wifi_qualcomm_qca61x4a/e3bbi1b/
but maybe there are two different build-in, one for wifi and one for
bluetooth?

Anyway, from the quote there is one interesting line:

"
CopyFiles   = atheros.CopyFiles, atheros_FW_3X.CopyFiles, 
atheros_BD_TX8.CopyFiles, service.CopyFiles
"

It seems that there exist just one file with "TX8" in it:
"eeprom_ar6320_3p0_TX8_clpc.bin"

I copied the .bin file as board.bin to
/lib/firmware/ath10k/QCA6174/hw3.0/ and it finally works! Wifi is
directly working and no error messages anymore in dmesg! :-)

So eeprom_ar6320_3p0_TX8_clpc.bin, or the informations of that .bin file
have to be added to
https://wireless.wiki.kernel.org/en/users/drivers/ath10k/boardfiles and
this should be a clean solution, because the subsystem-device=3370 ID is
matching.

Can someone please double check if this is the correct solution which
could go upstream?

Reply at: https://bugs.launchpad.net/ubuntu/+source/linux-
firmware/+bug/1804028/comments/8


On 2018-11-20T22:41:25+00:00 fedora_45sg wrote:

Did some additional tests with "eeprom_ar6320_3p0_TX8_clpc.bin":

The copied and renamed as board.bin file also works with the latest
firmware-6.bin from
https://git.kernel.org/pub/scm/linux/kernel/git/firmware/linux-
firmware.git/plain/ath10k/QCA6174/hw3.0/ and also with the one from

[Kernel-packages] [Bug 1804028] Re: Surface Go - QCA6174 wifi card not correctly recognized and therefore not working

2018-11-20 Thread Waynexyz
Did some additional tests with "eeprom_ar6320_3p0_TX8_clpc.bin":

The copied and renamed as board.bin file also works with the latest
firmware-6.bin from
https://git.kernel.org/pub/scm/linux/kernel/git/firmware/linux-
firmware.git/plain/ath10k/QCA6174/hw3.0/ and also with the one from
https://github.com/kvalo/ath10k-firmware/tree/master/QCA6174/hw3.0 which
was released one week ago. The reception with the seven day old one
firmware is a bit weaker but it is also working fine with no erros in
dmesg!

-- 
You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux-firmware in Ubuntu.
https://bugs.launchpad.net/bugs/1804028

Title:
  Surface Go - QCA6174 wifi card not correctly recognized and therefore
  not working

Status in linux-firmware package in Ubuntu:
  New
Status in linux-firmware package in Fedora:
  Confirmed

Bug description:
  Output of dmesg on Surface Go fresh installed Ubuntu 18.10.

  "[ 4.242132] ath10k_pci :01:00.0: qca6174 hw3.2 target 0x0503 chip_id 
0x00340aff sub 168c:3370
  [ 4.242138] ath10k_pci :01:00.0: kconfig debug 0 debugfs 1 tracing 1 dfs 
0 testmode 0
  [ 4.243006] ath10k_pci :01:00.0: firmware ver 
WLAN.RM.4.4.1-00079-QCARMSWPZ-1 api 6 features wowlan,ignore-otp crc32 fd869beb
  [ 4.308059] ath10k_pci :01:00.0: failed to fetch board data for 
bus=pci,vendor=168c,device=003e,subsystem-vendor=168c,subsystem-device=3370 
from ath10k/QCA6174/hw3.0/board-2.bin
  [ 4.309354] ath10k_pci :01:00.0: board_file api 1 bmi_id N/A crc32 
ed5f849a"

  There is a board.bin available directly from the vendor
  http://www.killernetworking.com/support/K1535_Debian/board.bin

  The only thing which is missing is getting this added to
  https://wireless.wiki.kernel.org/en/users/drivers/ath10k/boardfiles so
  the official board-2.bin. My problem is that I dont know how to read
  the board files and modify them because I do not know the encoding
  they use.

  Also there have been some updates in the upstream linux-firmware repo.
  https://git.kernel.org/pub/scm/linux/kernel/git/firmware/linux-
  firmware.git/commit/?id=a87eb5f7bac0f70ade57da57d9126d14eee12336 and
  https://github.com/kvalo/ath10k-firmware/tree/master/QCA6174/hw3.0 but
  they also do not help to get the wifi card working/recognized.

  Any ideas how to get this solved?

  Also there is a guide how to port it to Linux
  https://developer.qualcomm.com/download/qca9377/wlan-bluetooth-linux-
  porting-guide.pdf

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/linux-firmware/+bug/1804028/+subscriptions

-- 
Mailing list: https://launchpad.net/~kernel-packages
Post to : kernel-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~kernel-packages
More help   : https://help.launchpad.net/ListHelp


[Kernel-packages] [Bug 1804028] Re: Surface Go - QCA6174 wifi card not correctly recognized and therefore not working

2018-11-20 Thread Waynexyz
In the .zip from https://www.killernetworking.com/killersupport/item
/killer-drivers-inf in the file ./Killer-Ethernet-
Wireless_INF/Production/Windows10-x64/11AC/netathr10x.inf I finally
found one matching subsystem-device=3370 entry, which leads to:

"
%ATHR.DeviceDesc.6320_3%   = ATHR_DEV_OS63_988x_TX8.ndi,
PCI\VEN_168C_003E_3370168C_32; WiFi Only SKU
"

about this special .ndi there are some entrys later:

"
[ATHR_DEV_OS63_988x_TX8.ndi.NTamd64]
Characteristics = 0x84
BusType = 5
AddReg  = atheros_os63.reg, atheros11n.reg, smpsDynamic.reg, 
qca_utf.reg, D0PC.reg, roam.reg, wmmac.reg, FW_3X.reg, BD_TX8.reg, 
enableTxbfee.reg, wowEnable.reg, ForceWowSleep.reg, fastDlBinary.reg, 
enableSmbios.reg, Ch1213_options_SingleSKU.reg   
CopyFiles   = atheros.CopyFiles, atheros_FW_3X.CopyFiles, 
atheros_BD_TX8.CopyFiles, service.CopyFiles
*IfType = 71; IF_TYPE_IEEE80211
*MediaType  = 16; NdisMediumNative802_11
*PhysicalMediaType = 9  ; NdisPhysicalMediumNative802_11
Include = machine.inf, netvwifibus.inf
Needs   = VWiFiBus.CopyFiles

[ATHR_DEV_OS63_988x_TX8.ndi.NTamd64.Services]
AddService = Qcamain10x64, 2, atheros.Service, atheros.EventLog
Include= netvwifibus.inf
Needs  = VWiFiBus.Services
AddService = QcomWlanSrv, 0x0800, wlanService

[ATHR_DEV_OS63_988x_TX8.ndi.NTamd64.HW]
AddReg  = MSI.reg
Include = netvwifibus.inf
Needs   = PciASPMOptIn.Hw, VWiFiBus.PnPFilterRegistration.Hw, 
PciD3ColdSupported.Hw
"

I am just a bit confused because it just says "Wifi Only SKU" and I know
from the Windows Device Manager that also bluetooth is done with the
same chip, see
https://www.reddit.com/r/Surface/comments/9386l7/surface_go_wifi_qualcomm_qca61x4a/e3bbi1b/
but maybe there are two different build-in, one for wifi and one for
bluetooth?

Anyway, from the quote there is one interesting line:

"
CopyFiles   = atheros.CopyFiles, atheros_FW_3X.CopyFiles, 
atheros_BD_TX8.CopyFiles, service.CopyFiles
"

It seems that there exist just one file with "TX8" in it:
"eeprom_ar6320_3p0_TX8_clpc.bin"

I copied the .bin file as board.bin to
/lib/firmware/ath10k/QCA6174/hw3.0/ and it finally works! Wifi is
directly working and no error messages anymore in dmesg! :-)

So eeprom_ar6320_3p0_TX8_clpc.bin, or the informations of that .bin file
have to be added to
https://wireless.wiki.kernel.org/en/users/drivers/ath10k/boardfiles and
this should be a clean solution, because the subsystem-device=3370 ID is
matching.

Can someone please double check if this is the correct solution which
could go upstream?

-- 
You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux-firmware in Ubuntu.
https://bugs.launchpad.net/bugs/1804028

Title:
  Surface Go - QCA6174 wifi card not correctly recognized and therefore
  not working

Status in linux-firmware package in Ubuntu:
  New
Status in linux-firmware package in Fedora:
  Confirmed

Bug description:
  Output of dmesg on Surface Go fresh installed Ubuntu 18.10.

  "[ 4.242132] ath10k_pci :01:00.0: qca6174 hw3.2 target 0x0503 chip_id 
0x00340aff sub 168c:3370
  [ 4.242138] ath10k_pci :01:00.0: kconfig debug 0 debugfs 1 tracing 1 dfs 
0 testmode 0
  [ 4.243006] ath10k_pci :01:00.0: firmware ver 
WLAN.RM.4.4.1-00079-QCARMSWPZ-1 api 6 features wowlan,ignore-otp crc32 fd869beb
  [ 4.308059] ath10k_pci :01:00.0: failed to fetch board data for 
bus=pci,vendor=168c,device=003e,subsystem-vendor=168c,subsystem-device=3370 
from ath10k/QCA6174/hw3.0/board-2.bin
  [ 4.309354] ath10k_pci :01:00.0: board_file api 1 bmi_id N/A crc32 
ed5f849a"

  There is a board.bin available directly from the vendor
  http://www.killernetworking.com/support/K1535_Debian/board.bin

  The only thing which is missing is getting this added to
  https://wireless.wiki.kernel.org/en/users/drivers/ath10k/boardfiles so
  the official board-2.bin. My problem is that I dont know how to read
  the board files and modify them because I do not know the encoding
  they use.

  Also there have been some updates in the upstream linux-firmware repo.
  https://git.kernel.org/pub/scm/linux/kernel/git/firmware/linux-
  firmware.git/commit/?id=a87eb5f7bac0f70ade57da57d9126d14eee12336 and
  https://github.com/kvalo/ath10k-firmware/tree/master/QCA6174/hw3.0 but
  they also do not help to get the wifi card working/recognized.

  Any ideas how to get this solved?

  Also there is a guide how to port it to Linux
  https://developer.qualcomm.com/download/qca9377/wlan-bluetooth-linux-
  porting-guide.pdf

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/linux-firmware/+bug/1804028/+subscriptions

-- 
Mailing list: https://launchpad.net/~kernel-packages
Post to : kernel-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~kernel-packages
More help   : https://help.launchpad.net/ListHelp


[Kernel-packages] [Bug 1804028] Re: Surface Go - QCA6174 wifi card not correctly recognized and therefore not working

2018-11-20 Thread Bug Watch Updater
** Changed in: linux-firmware (Fedora)
   Status: Unknown => Confirmed

** Changed in: linux-firmware (Fedora)
   Importance: Unknown => High

-- 
You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux-firmware in Ubuntu.
https://bugs.launchpad.net/bugs/1804028

Title:
  Surface Go - QCA6174 wifi card not correctly recognized and therefore
  not working

Status in linux-firmware package in Ubuntu:
  New
Status in linux-firmware package in Fedora:
  Confirmed

Bug description:
  Output of dmesg on Surface Go fresh installed Ubuntu 18.10.

  "[ 4.242132] ath10k_pci :01:00.0: qca6174 hw3.2 target 0x0503 chip_id 
0x00340aff sub 168c:3370
  [ 4.242138] ath10k_pci :01:00.0: kconfig debug 0 debugfs 1 tracing 1 dfs 
0 testmode 0
  [ 4.243006] ath10k_pci :01:00.0: firmware ver 
WLAN.RM.4.4.1-00079-QCARMSWPZ-1 api 6 features wowlan,ignore-otp crc32 fd869beb
  [ 4.308059] ath10k_pci :01:00.0: failed to fetch board data for 
bus=pci,vendor=168c,device=003e,subsystem-vendor=168c,subsystem-device=3370 
from ath10k/QCA6174/hw3.0/board-2.bin
  [ 4.309354] ath10k_pci :01:00.0: board_file api 1 bmi_id N/A crc32 
ed5f849a"

  There is a board.bin available directly from the vendor
  http://www.killernetworking.com/support/K1535_Debian/board.bin

  The only thing which is missing is getting this added to
  https://wireless.wiki.kernel.org/en/users/drivers/ath10k/boardfiles so
  the official board-2.bin. My problem is that I dont know how to read
  the board files and modify them because I do not know the encoding
  they use.

  Also there have been some updates in the upstream linux-firmware repo.
  https://git.kernel.org/pub/scm/linux/kernel/git/firmware/linux-
  firmware.git/commit/?id=a87eb5f7bac0f70ade57da57d9126d14eee12336 and
  https://github.com/kvalo/ath10k-firmware/tree/master/QCA6174/hw3.0 but
  they also do not help to get the wifi card working/recognized.

  Any ideas how to get this solved?

  Also there is a guide how to port it to Linux
  https://developer.qualcomm.com/download/qca9377/wlan-bluetooth-linux-
  porting-guide.pdf

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/linux-firmware/+bug/1804028/+subscriptions

-- 
Mailing list: https://launchpad.net/~kernel-packages
Post to : kernel-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~kernel-packages
More help   : https://help.launchpad.net/ListHelp