[Kernel-packages] [Bug 1817321] Re: installer does not support iSCSI iBFT

2019-06-17 Thread Mauricio Faria de Oliveira
Verified debian-installer in {disco,cosmic,bionic}-proposed. The verification has been done with the netboot image files for disco/cosmic/bionic (and hwe-netboot for bionic), using regular and lvm partitioning, on VMs for the architectures amd64/i386/arm64/ppc64el and baremetal for amd64. All

[Kernel-packages] [Bug 1817321] Re: installer does not support iSCSI iBFT

2019-06-13 Thread Łukasz Zemczak
Hello Mauricio, or anyone else affected, Accepted debian-installer into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/debian- installer/20101020ubuntu543.8 in a few hours, and then in the -proposed repository. Please help us by testing this

[Kernel-packages] [Bug 1817321] Re: installer does not support iSCSI iBFT

2019-06-13 Thread Łukasz Zemczak
Hello Mauricio, or anyone else affected, Accepted debian-installer into cosmic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/debian- installer/20101020ubuntu557.2 in a few hours, and then in the -proposed repository. Please help us by testing this

[Kernel-packages] [Bug 1817321] Re: installer does not support iSCSI iBFT

2019-06-13 Thread Łukasz Zemczak
Hello Mauricio, or anyone else affected, Accepted debian-installer into disco-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/debian- installer/20101020ubuntu570.1 in a few hours, and then in the -proposed repository. Please help us by testing this

[Kernel-packages] [Bug 1817321] Re: installer does not support iSCSI iBFT

2019-06-13 Thread Launchpad Bug Tracker
This bug was fixed in the package hw-detect - 1.117ubuntu6.19.04.1 --- hw-detect (1.117ubuntu6.19.04.1) disco; urgency=medium * Add iSCSI iBFT support to the installer (LP: #1817321) - disk-detect.templates: add option 'disk-detect/ibft/enable' for preseeding. -

[Kernel-packages] [Bug 1817321] Re: installer does not support iSCSI iBFT

2019-06-13 Thread Launchpad Bug Tracker
This bug was fixed in the package partman-iscsi - 40ubuntu3.18.04.1 --- partman-iscsi (40ubuntu3.18.04.1) bionic; urgency=medium * Add support for different network interfaces and iscsi_auto for iBFT (LP: #1817321) - debian/partman-iscsi.template: add

[Kernel-packages] [Bug 1817321] Re: installer does not support iSCSI iBFT

2019-06-13 Thread Launchpad Bug Tracker
This bug was fixed in the package partman-iscsi - 40ubuntu3.18.10.1 --- partman-iscsi (40ubuntu3.18.10.1) cosmic; urgency=medium * Add support for different network interfaces and iscsi_auto for iBFT. (LP: #1817321) - debian/partman-iscsi.template: add

[Kernel-packages] [Bug 1817321] Re: installer does not support iSCSI iBFT

2019-06-13 Thread Launchpad Bug Tracker
This bug was fixed in the package hw-detect - 1.117ubuntu6.18.04.1 --- hw-detect (1.117ubuntu6.18.04.1) bionic; urgency=medium * Add iSCSI iBFT support to the installer (LP: #1817321) - disk-detect.templates: add option 'disk-detect/ibft/enable' for preseeding. -

[Kernel-packages] [Bug 1817321] Re: installer does not support iSCSI iBFT

2019-06-13 Thread Launchpad Bug Tracker
This bug was fixed in the package hw-detect - 1.117ubuntu6.18.10.1 --- hw-detect (1.117ubuntu6.18.10.1) cosmic; urgency=medium * Add iSCSI iBFT support to the installer (LP: #1817321) - disk-detect.templates: add option 'disk-detect/ibft/enable' for preseeding. -

[Kernel-packages] [Bug 1817321] Re: installer does not support iSCSI iBFT

2019-06-13 Thread Launchpad Bug Tracker
This bug was fixed in the package partman-iscsi - 40ubuntu3.19.04.1 --- partman-iscsi (40ubuntu3.19.04.1) disco; urgency=medium * Add support for different network interfaces and iscsi_auto for iBFT. (LP: #1817321) - debian/partman-iscsi.template: add

[Kernel-packages] [Bug 1817321] Re: installer does not support iSCSI iBFT

2019-06-11 Thread Eric Desrochers
Sponsored for Cosmic 'd-i'. The version used "4.18.0-20" is available in cosmic-updates. rmadison: linux-image-4.18.0-20-generic | 4.18.0-20.21 | cosmic-security | amd64, arm64, armhf, i386, ppc64el, s390x linux-image-4.18.0-20-generic | 4.18.0-20.21 | cosmic-updates |

[Kernel-packages] [Bug 1817321] Re: installer does not support iSCSI iBFT

2019-06-11 Thread Eric Desrochers
** Tags removed: sts-sponsor sts-sponsor-slashd ** Tags added: sts -- You received this bug notification because you are a member of Kernel Packages, which is subscribed to linux in Ubuntu. https://bugs.launchpad.net/bugs/1817321 Title: installer does not support iSCSI iBFT Status in

[Kernel-packages] [Bug 1817321] Re: installer does not support iSCSI iBFT

2019-06-11 Thread Eric Desrochers
Sponsored for Bionic 'd-i'. The new kernel version used "4.18.0-20" (aka HWE) and "4.15.0-50" are both available in the archive for Bionic in -updates. $ rmadison linux-image-4.18.0-20-generic linux-image-4.18.0-20-generic | 4.18.0-20.21~18.04.1 | bionic-security | amd64, arm64, armhf, i386,

[Kernel-packages] [Bug 1817321] Re: installer does not support iSCSI iBFT

2019-06-11 Thread Dan Streetman
** Tags removed: sts-sponsor-ddstreet ** Tags added: sts-sponsor-slashd -- You received this bug notification because you are a member of Kernel Packages, which is subscribed to linux in Ubuntu. https://bugs.launchpad.net/bugs/1817321 Title: installer does not support iSCSI iBFT Status in

[Kernel-packages] [Bug 1817321] Re: installer does not support iSCSI iBFT

2019-06-11 Thread Eric Desrochers
Sponsored for Disco 'd-i'. - No-Change rebuild Will review C/B 'd-i' soon (which involve master kernel change) - Eric -- You received this bug notification because you are a member of Kernel Packages, which is subscribed to linux in Ubuntu. https://bugs.launchpad.net/bugs/1817321 Title:

[Kernel-packages] [Bug 1817321] Re: installer does not support iSCSI iBFT

2019-06-06 Thread Mauricio Faria de Oliveira
verification done for bionic/partman-iscsi. Use of partman-iscsi/iscsi_auto correctly writes /etc/iscsi/iscsi.initramfs with either ISCSI_AUTO=true or iSCSI LUN details with the right MAC address. ~ # grep 'retrieving partman-iscsi' /var/log/syslog Jun 6 15:01:20 anna[1605]:

[Kernel-packages] [Bug 1817321] Re: installer does not support iSCSI iBFT

2019-06-06 Thread Mauricio Faria de Oliveira
verification done for cosmic/partman-iscsi. Use of partman-iscsi/iscsi_auto correctly writes /etc/iscsi/iscsi.initramfs with either ISCSI_AUTO=true or iSCSI LUN details with the right MAC address. ~ # grep 'retrieving partman-iscsi' /var/log/syslog Jun 6 14:20:51 anna[1521]:

[Kernel-packages] [Bug 1817321] Re: installer does not support iSCSI iBFT

2019-06-06 Thread Mauricio Faria de Oliveira
verification done for disco/partman-iscsi. Use of partman-iscsi/iscsi_auto correctly writes /etc/iscsi/iscsi.initramfs with either ISCSI_AUTO=true or iSCSI LUN details with the right MAC address. ~ # grep 'retrieving partman-iscsi' /var/log/syslog Jun 6 14:04:03 anna[1582]:

[Kernel-packages] [Bug 1817321] Re: installer does not support iSCSI iBFT

2019-06-06 Thread Łukasz Zemczak
Hello Mauricio, or anyone else affected, Accepted partman-iscsi into disco-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/partman- iscsi/40ubuntu3.19.04.1 in a few hours, and then in the -proposed repository. Please help us by testing this new

[Kernel-packages] [Bug 1817321] Re: installer does not support iSCSI iBFT

2019-06-05 Thread Mauricio Faria de Oliveira
verification done for bionic/hw-detect. disk-detect found the iscsi target/lun configured in ibft. bionic currently needed the workaround to download/install the iscsi_ibft.ko module, because the d-i changes are not yet in (update to kernel version that includes it in scsi-modules.udeb). $ wget

[Kernel-packages] [Bug 1817321] Re: installer does not support iSCSI iBFT

2019-06-05 Thread Mauricio Faria de Oliveira
verification done for cosmic/hw-detect. disk-detect found the iscsi target/lun configured in ibft. cosmic currently needed the workaround to download/install the iscsi_ibft.ko module, because the d-i changes are not yet in (update to kernel version to includes it in scsi-modules.udeb). $ wget

[Kernel-packages] [Bug 1817321] Re: installer does not support iSCSI iBFT

2019-06-05 Thread Mauricio Faria de Oliveira
verification done for disco/hw-detect. disk-detect found the iscsi target/lun configured in ibft. $ wget http://boot.ipxe.org/ipxe.lkrn $ wget http://archive.ubuntu.com/ubuntu/dists/disco/main/installer-amd64/20101020ubuntu570/images/netboot/ubuntu-installer/amd64/{linux,initrd.gz} $ python3

[Kernel-packages] [Bug 1817321] Re: installer does not support iSCSI iBFT

2019-06-04 Thread Brian Murray
Hello Mauricio, or anyone else affected, Accepted hw-detect into cosmic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/hw- detect/1.117ubuntu6.18.10.1 in a few hours, and then in the -proposed repository. Please help us by testing this new package.

[Kernel-packages] [Bug 1817321] Re: installer does not support iSCSI iBFT

2019-06-04 Thread Brian Murray
Hello Mauricio, or anyone else affected, Accepted hw-detect into disco-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/hw- detect/1.117ubuntu6.19.04.1 in a few hours, and then in the -proposed repository. Please help us by testing this new package.

[Kernel-packages] [Bug 1817321] Re: installer does not support iSCSI iBFT

2019-06-03 Thread Mauricio Faria de Oliveira
Dan, thanks for the review/fixes/upload! -- You received this bug notification because you are a member of Kernel Packages, which is subscribed to linux in Ubuntu. https://bugs.launchpad.net/bugs/1817321 Title: installer does not support iSCSI iBFT Status in debian-installer package in

[Kernel-packages] [Bug 1817321] Re: installer does not support iSCSI iBFT

2019-06-01 Thread Dan Streetman
uploaded hw-detect and partman-iscsi to b/c/d 2 minor changelog tweaks: -some of the lines were long (>80), i wrapped them -the version number added the release suffix but also bumped the version, i corrected that (e.g., 1.117ubuntu6 -> 1.117ubuntu7.18.04.1 is wrong; corrected to

[Kernel-packages] [Bug 1817321] Re: installer does not support iSCSI iBFT

2019-05-31 Thread Dan Streetman
** Tags added: sts-sponsor-ddstreet -- You received this bug notification because you are a member of Kernel Packages, which is subscribed to linux in Ubuntu. https://bugs.launchpad.net/bugs/1817321 Title: installer does not support iSCSI iBFT Status in debian-installer package in Ubuntu:

[Kernel-packages] [Bug 1817321] Re: installer does not support iSCSI iBFT

2019-05-31 Thread Dan Streetman
** Tags added: sts-sponsor ** Tags added: sts-sponsor-ddstreet ** Tags removed: sts-sponsor-ddstreet -- You received this bug notification because you are a member of Kernel Packages, which is subscribed to linux in Ubuntu. https://bugs.launchpad.net/bugs/1817321 Title: installer does not

[Kernel-packages] [Bug 1817321] Re: installer does not support iSCSI iBFT

2019-05-28 Thread Launchpad Bug Tracker
This bug was fixed in the package debian-installer - 20101020ubuntu573 --- debian-installer (20101020ubuntu573) eoan; urgency=medium * No-change rebuild to pick up new hw-detect and partman-iscsi. (LP: #1817321) -- Mauricio Faria de Oliveira Wed, 22 May 2019 10:30:55 -0300

[Kernel-packages] [Bug 1817321] Re: installer does not support iSCSI iBFT

2019-05-28 Thread Mauricio Faria de Oliveira
** Patch added: "eoan_partman-iscsi.debdiff" https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1817321/+attachment/5267258/+files/eoan_partman-iscsi.debdiff -- You received this bug notification because you are a member of Kernel Packages, which is subscribed to linux in Ubuntu.

[Kernel-packages] [Bug 1817321] Re: installer does not support iSCSI iBFT

2019-05-28 Thread Mauricio Faria de Oliveira
Hi Eric, Nice catch. Sorry about that! Sure, just attached the partman-iscsi debdiffs with the LP bug mentioned in changelog. Thanks, Mauricio -- You received this bug notification because you are a member of Kernel Packages, which is subscribed to linux in Ubuntu.

[Kernel-packages] [Bug 1817321] Re: installer does not support iSCSI iBFT

2019-05-28 Thread Mauricio Faria de Oliveira
** Patch added: "disco_partman-iscsi.debdiff" https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1817321/+attachment/5267257/+files/disco_partman-iscsi.debdiff -- You received this bug notification because you are a member of Kernel Packages, which is subscribed to linux in Ubuntu.

[Kernel-packages] [Bug 1817321] Re: installer does not support iSCSI iBFT

2019-05-28 Thread Mauricio Faria de Oliveira
** Patch removed: "bionic_partman-iscsi.debdiff" https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1817321/+attachment/5265733/+files/bionic_partman-iscsi.debdiff ** Patch removed: "cosmic_partman-iscsi.debdiff"

[Kernel-packages] [Bug 1817321] Re: installer does not support iSCSI iBFT

2019-05-28 Thread Mauricio Faria de Oliveira
** Patch added: "cosmic_partman-iscsi.debdiff" https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1817321/+attachment/5267256/+files/cosmic_partman-iscsi.debdiff -- You received this bug notification because you are a member of Kernel Packages, which is subscribed to linux in Ubuntu.

[Kernel-packages] [Bug 1817321] Re: installer does not support iSCSI iBFT

2019-05-28 Thread Eric Desrochers
Sponsored 'd-i' for Eoan, now that both hw-detect and partman-iscsi have been built and land in release. - Eric ** Changed in: debian-installer (Ubuntu Eoan) Status: In Progress => Fix Committed -- You received this bug notification because you are a member of Kernel Packages, which is

[Kernel-packages] [Bug 1817321] Re: installer does not support iSCSI iBFT

2019-05-28 Thread Eric Desrochers
I apologise, I totally miss the fact that the second upload for partman- iscsi didn't have the LP# mentioned in the changelog. We are all human, mistake happens ;) So I did the LP modification manually. @mfo, could you produce a debdiff V2 for 'partman-iscsi' debdiff(s) and make sure it contains

[Kernel-packages] [Bug 1817321] Re: installer does not support iSCSI iBFT

2019-05-28 Thread Eric Desrochers
This bug was fixed in the package partman-iscsi - 40ubuntu4 --- partman-iscsi (40ubuntu4) eoan; urgency=medium * Add support for different network interfaces and iscsi_auto for iBFT. - debian/partman-iscsi.template: add partman-iscsi/iscsi_auto option. -

[Kernel-packages] [Bug 1817321] Re: installer does not support iSCSI iBFT

2019-05-28 Thread Launchpad Bug Tracker
This bug was fixed in the package hw-detect - 1.117ubuntu7 --- hw-detect (1.117ubuntu7) eoan; urgency=medium * Add iSCSI iBFT support to the installer (LP: #1817321) - disk-detect.templates: add option 'disk-detect/ibft/enable' for preseeding. - disk-detect.sh: detect

[Kernel-packages] [Bug 1817321] Re: installer does not support iSCSI iBFT

2019-05-28 Thread Eric Desrochers
Sponsored for Eoan, considering that Mauricio has submitted the patch to Debian already. debbugs are "bug watches" in the LP. Everything looks good me. The only thing missing is the d-i rebuild with no modification but that have to wait until hw-detect/parman-iscsi are both built. - Eric **

[Kernel-packages] [Bug 1817321] Re: installer does not support iSCSI iBFT

2019-05-27 Thread Eric Desrochers
** Changed in: partman-iscsi (Ubuntu Eoan) Status: Confirmed => In Progress ** Changed in: partman-iscsi (Ubuntu Eoan) Importance: Undecided => Medium ** Changed in: hw-detect (Ubuntu Eoan) Importance: Undecided => Medium ** Changed in: hw-detect (Ubuntu Eoan) Status:

[Kernel-packages] [Bug 1817321] Re: installer does not support iSCSI iBFT

2019-05-22 Thread Ubuntu Foundations Team Bug Bot
The attachment "bionic_d-i.debdiff" seems to be a debdiff. The ubuntu- sponsors team has been subscribed to the bug report so that they can review and hopefully sponsor the debdiff. If the attachment isn't a patch, please remove the "patch" flag from the attachment, remove the "patch" tag, and

[Kernel-packages] [Bug 1817321] Re: installer does not support iSCSI iBFT

2019-05-22 Thread Mauricio Faria de Oliveira
** Description changed: [Impact]  * It's not possible to access iBFT (iSCSI Boot Firmware Table) information    (settings for network interface, initiator, and target) in the installer    because the 'iscsi_ibft' module is not present in udeb packages.  * Even if it was, the

[Kernel-packages] [Bug 1817321] Re: installer does not support iSCSI iBFT

2019-05-22 Thread Mauricio Faria de Oliveira
** Patch added: "bionic_partman-iscsi.debdiff" https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1817321/+attachment/5265733/+files/bionic_partman-iscsi.debdiff -- You received this bug notification because you are a member of Kernel Packages, which is subscribed to linux in Ubuntu.

[Kernel-packages] [Bug 1817321] Re: installer does not support iSCSI iBFT

2019-05-22 Thread Mauricio Faria de Oliveira
** Patch added: "disco_partman-iscsi.debdiff" https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1817321/+attachment/5265739/+files/disco_partman-iscsi.debdiff -- You received this bug notification because you are a member of Kernel Packages, which is subscribed to linux in Ubuntu.

[Kernel-packages] [Bug 1817321] Re: installer does not support iSCSI iBFT

2019-05-22 Thread Mauricio Faria de Oliveira
** Patch added: "eoan_hw-detect.debdiff" https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1817321/+attachment/5265741/+files/eoan_hw-detect.debdiff -- You received this bug notification because you are a member of Kernel Packages, which is subscribed to linux in Ubuntu.

[Kernel-packages] [Bug 1817321] Re: installer does not support iSCSI iBFT

2019-05-22 Thread Mauricio Faria de Oliveira
** Patch added: "eoan_d-i.debdiff" https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1817321/+attachment/5265740/+files/eoan_d-i.debdiff -- You received this bug notification because you are a member of Kernel Packages, which is subscribed to linux in Ubuntu.

[Kernel-packages] [Bug 1817321] Re: installer does not support iSCSI iBFT

2019-05-22 Thread Mauricio Faria de Oliveira
** Patch added: "eoan_partman-iscsi.debdiff" https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1817321/+attachment/5265742/+files/eoan_partman-iscsi.debdiff -- You received this bug notification because you are a member of Kernel Packages, which is subscribed to linux in Ubuntu.

[Kernel-packages] [Bug 1817321] Re: installer does not support iSCSI iBFT

2019-05-22 Thread Mauricio Faria de Oliveira
** Patch added: "cosmic_partman-iscsi.debdiff" https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1817321/+attachment/5265736/+files/cosmic_partman-iscsi.debdiff -- You received this bug notification because you are a member of Kernel Packages, which is subscribed to linux in Ubuntu.

[Kernel-packages] [Bug 1817321] Re: installer does not support iSCSI iBFT

2019-05-22 Thread Mauricio Faria de Oliveira
** Patch added: "disco_hw-detect.debdiff" https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1817321/+attachment/5265738/+files/disco_hw-detect.debdiff -- You received this bug notification because you are a member of Kernel Packages, which is subscribed to linux in Ubuntu.

[Kernel-packages] [Bug 1817321] Re: installer does not support iSCSI iBFT

2019-05-22 Thread Mauricio Faria de Oliveira
** Patch added: "cosmic_hw-detect.debdiff" https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1817321/+attachment/5265735/+files/cosmic_hw-detect.debdiff -- You received this bug notification because you are a member of Kernel Packages, which is subscribed to linux in Ubuntu.

[Kernel-packages] [Bug 1817321] Re: installer does not support iSCSI iBFT

2019-05-22 Thread Mauricio Faria de Oliveira
** Patch added: "disco_d-i.debdiff" https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1817321/+attachment/5265737/+files/disco_d-i.debdiff -- You received this bug notification because you are a member of Kernel Packages, which is subscribed to linux in Ubuntu.

[Kernel-packages] [Bug 1817321] Re: installer does not support iSCSI iBFT

2019-05-22 Thread Mauricio Faria de Oliveira
Adding patches and test procedure for the debian-installer userspace part. (disk-detect probes iSCSI iBFT disks; partman-iscsi sets ISCSI_AUTO=true for booting.) The d-i patches should be uploaded/built _after_ hw-detect and partman-iscsi are successfully built and published, so that its new

[Kernel-packages] [Bug 1817321] Re: installer does not support iSCSI iBFT

2019-05-22 Thread Mauricio Faria de Oliveira
** Patch added: "bionic_hw-detect.debdiff" https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1817321/+attachment/5265732/+files/bionic_hw-detect.debdiff -- You received this bug notification because you are a member of Kernel Packages, which is subscribed to linux in Ubuntu.

[Kernel-packages] [Bug 1817321] Re: installer does not support iSCSI iBFT

2019-05-22 Thread Mauricio Faria de Oliveira
** Patch added: "cosmic_d-i.debdiff" https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1817321/+attachment/5265734/+files/cosmic_d-i.debdiff -- You received this bug notification because you are a member of Kernel Packages, which is subscribed to linux in Ubuntu.

[Kernel-packages] [Bug 1817321] Re: installer does not support iSCSI iBFT

2019-05-22 Thread Mauricio Faria de Oliveira
** Patch added: "bionic_d-i.debdiff" https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1817321/+attachment/5265731/+files/bionic_d-i.debdiff -- You received this bug notification because you are a member of Kernel Packages, which is subscribed to linux in Ubuntu.

[Kernel-packages] [Bug 1817321] Re: installer does not support iSCSI iBFT

2019-05-22 Thread Mauricio Faria de Oliveira
Test Procedure with KVM guests + iPXE = - 2 guests: iSCSI target/server and iSCSI initiator/client. - 1 bridge for iSCSI traffic (virbr-iscsi, new), static ip. - 1 bridge for internet access (virbr0, exists), dhcp ip. Host: Configure the iSCSI bridge

[Kernel-packages] [Bug 1817321] Re: installer does not support iSCSI iBFT

2019-05-22 Thread Mauricio Faria de Oliveira
Test procedure for the partman-iscsi changes Based on the previous comment setup. iSCSI initiator: --- ... Note there's no 'iscsi_auto' in the kernel cmdline: iPXE> ifopen net0 iPXE> kernel http://192.168.122.1:8000/vmlinuz

[Kernel-packages] [Bug 1817321] Re: installer does not support iSCSI iBFT

2019-05-14 Thread Mauricio Faria de Oliveira
** Description changed: [Impact] - * It's not possible to access iBFT (iSCSI Boot Firmware Table) information -(settings for network interface, initiator, and target) in the installer -because the 'iscsi_ibft' module is not present in udeb packages. +  * It's not possible to access

[Kernel-packages] [Bug 1817321] Re: installer does not support iSCSI iBFT

2019-04-02 Thread Launchpad Bug Tracker
This bug was fixed in the package linux - 4.15.0-47.50 --- linux (4.15.0-47.50) bionic; urgency=medium * linux: 4.15.0-47.50 -proposed tracker (LP: #1819716) * Packaging resync (LP: #1786013) - [Packaging] resync getabis - [Packaging] update helper scripts -

[Kernel-packages] [Bug 1817321] Re: installer does not support iSCSI iBFT

2019-04-02 Thread Launchpad Bug Tracker
This bug was fixed in the package linux - 4.18.0-17.18 --- linux (4.18.0-17.18) cosmic; urgency=medium * linux: 4.18.0-17.18 -proposed tracker (LP: #1819624) * Packaging resync (LP: #1786013) - [Packaging] resync getabis - [Packaging] update helper scripts * C++

[Kernel-packages] [Bug 1817321] Re: installer does not support iSCSI iBFT

2019-03-18 Thread Mauricio Faria de Oliveira
bionic-proposed verification done; iscsi_ibft.ko is present in udeb and loads correctly. --- $ uname -rv 4.15.0-47-generic #50-Ubuntu SMP Wed Mar 13 10:44:52 UTC 2019 $ apt-get download scsi-modules-4.15.0-47-generic-di $ dpkg-deb -c scsi-modules-4.15.0-47-generic-di_4.15.0-47.50_amd64.udeb |

[Kernel-packages] [Bug 1817321] Re: installer does not support iSCSI iBFT

2019-03-18 Thread Mauricio Faria de Oliveira
cosmic-proposed verification done; iscsi_ibft.ko is present in udeb and loads correctly. --- $ uname -rv 4.18.0-17-generic #18-Ubuntu SMP Wed Mar 13 14:34:40 UTC 2019 $ apt-get download scsi-modules-4.18.0-17-generic-di $ dpkg-deb -c scsi-modules-4.18.0-17-generic-di_4.18.0-17.18_amd64.udeb |

[Kernel-packages] [Bug 1817321] Re: installer does not support iSCSI iBFT

2019-03-15 Thread Brad Figg
This bug is awaiting verification that the kernel in -proposed solves the problem. Please test the kernel and update this bug with the results. If the problem is solved, change the tag 'verification-needed- bionic' to 'verification-done-bionic'. If the problem still exists, change the tag

[Kernel-packages] [Bug 1817321] Re: installer does not support iSCSI iBFT

2019-03-15 Thread Brad Figg
This bug is awaiting verification that the kernel in -proposed solves the problem. Please test the kernel and update this bug with the results. If the problem is solved, change the tag 'verification-needed- cosmic' to 'verification-done-cosmic'. If the problem still exists, change the tag

[Kernel-packages] [Bug 1817321] Re: installer does not support iSCSI iBFT

2019-03-15 Thread Mauricio Faria de Oliveira
Installer (non-kernel) patches submitted to Debian for feedback. - disk-detect: https://bugs.debian.org/924675 - partman-iscsi: https://bugs.debian.org/924680 ** Bug watch added: Debian Bug tracker #924675 https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=924675 ** Bug watch added: Debian Bug

[Kernel-packages] [Bug 1817321] Re: installer does not support iSCSI iBFT

2019-03-11 Thread Launchpad Bug Tracker
This bug was fixed in the package linux - 5.0.0-7.8 --- linux (5.0.0-7.8) disco; urgency=medium * linux: 5.0.0-7.8 -proposed tracker (LP: #1818519) * Packaging resync (LP: #1786013) - [Packaging] update helper scripts * unnecessary request_queue freeze (LP: #1815733)

[Kernel-packages] [Bug 1817321] Re: installer does not support iSCSI iBFT

2019-02-28 Thread Khaled El Mously
** Changed in: linux (Ubuntu Bionic) Status: In Progress => Fix Committed ** Changed in: linux (Ubuntu Cosmic) Status: In Progress => Fix Committed -- You received this bug notification because you are a member of Kernel Packages, which is subscribed to linux in Ubuntu.

[Kernel-packages] [Bug 1817321] Re: installer does not support iSCSI iBFT

2019-02-25 Thread Seth Forshee
** Changed in: linux (Ubuntu Disco) Status: In Progress => Fix Committed -- You received this bug notification because you are a member of Kernel Packages, which is subscribed to linux in Ubuntu. https://bugs.launchpad.net/bugs/1817321 Title: installer does not support iSCSI iBFT

[Kernel-packages] [Bug 1817321] Re: installer does not support iSCSI iBFT

2019-02-25 Thread Kleber Sacilotto de Souza
** Also affects: linux (Ubuntu Disco) Importance: Undecided Assignee: Mauricio Faria de Oliveira (mfo) Status: Confirmed ** Also affects: linux (Ubuntu Bionic) Importance: Undecided Status: New ** Also affects: linux (Ubuntu Cosmic) Importance: Undecided

[Kernel-packages] [Bug 1817321] Re: installer does not support iSCSI iBFT

2019-02-22 Thread Mauricio Faria de Oliveira
Test for scsi-modules udeb in Disco: --- Check the original/modified udeb contents: $ dpkg-deb -c scsi-modules-4.19.0-13-generic-di_4.19.0-13.14_amd64.udeb | grep iscsi_ibft.ko $ $ dpkg-deb -c scsi-modules-4.19.0-13-generic-di_4.19.0-13.14+test20190221b1_amd64.udeb | grep iscsi_ibft.ko

[Kernel-packages] [Bug 1817321] Re: installer does not support iSCSI iBFT

2019-02-22 Thread Mauricio Faria de Oliveira
linux patch posted to the kernel-team mailing list: [B/C/D/Unstable][PATCH] UBUNTU: d-i: add iscsi_ibft to scsi-modules https://lists.ubuntu.com/archives/kernel-team/2019-February/098745.html ** Changed in: linux (Ubuntu) Status: New => Confirmed -- You received this bug notification