[Kernel-packages] [Bug 1723223] Re: linux-lts and linux-hwe autopkgtests fail due to version mismatch

2019-04-15 Thread Dan Streetman
** Changed in: linux (Ubuntu Disco) Status: In Progress => Incomplete -- You received this bug notification because you are a member of Kernel Packages, which is subscribed to linux in Ubuntu. https://bugs.launchpad.net/bugs/1723223 Title: linux-lts and linux-hwe autopkgtests fail due

[Kernel-packages] [Bug 1723223] Re: linux-lts and linux-hwe autopkgtests fail due to version mismatch

2019-03-17 Thread Eric Desrochers
** Changed in: linux (Ubuntu Disco) Assignee: Eric Desrochers (slashd) => (unassigned) -- You received this bug notification because you are a member of Kernel Packages, which is subscribed to linux in Ubuntu. https://bugs.launchpad.net/bugs/1723223 Title: linux-lts and linux-hwe

[Kernel-packages] [Bug 1723223] Re: linux-lts and linux-hwe autopkgtests fail due to version mismatch

2019-02-12 Thread Eric Desrochers
After a discussion with vorlon, his proposal is to blacklist the "special" kernels so they're ignored for autopkgtests. -- You received this bug notification because you are a member of Kernel Packages, which is subscribed to linux in Ubuntu. https://bugs.launchpad.net/bugs/1723223 Title:

[Kernel-packages] [Bug 1723223] Re: linux-lts and linux-hwe autopkgtests fail due to version mismatch

2019-02-12 Thread Eric Desrochers
https://people.debian.org/~mpitt/autopkgtest/README.package-tests.html @builddeps@ will be replaced by the package's Build-Depends:, Build- Depends-Indep:, and build-essential. This is useful if you have many build dependencies which are only necessary for running the test suite and you don't

[Kernel-packages] [Bug 1723223] Re: linux-lts and linux-hwe autopkgtests fail due to version mismatch

2019-02-12 Thread Eric Desrochers
** Changed in: linux (Ubuntu Disco) Status: Incomplete => In Progress ** Changed in: linux (Ubuntu Disco) Assignee: (unassigned) => Eric Desrochers (slashd) ** Tags added: sts -- You received this bug notification because you are a member of Kernel Packages, which is subscribed to

[Kernel-packages] [Bug 1723223] Re: linux-lts and linux-hwe autopkgtests fail due to version mismatch

2019-02-12 Thread Dan Streetman
** Also affects: linux (Ubuntu Bionic) Importance: Undecided Status: New ** Also affects: linux (Ubuntu Disco) Importance: Low Assignee: Dan Streetman (ddstreet) Status: Invalid ** Also affects: linux (Ubuntu Cosmic) Importance: Undecided Status: New **

[Kernel-packages] [Bug 1723223] Re: linux-lts and linux-hwe autopkgtests fail due to version mismatch

2018-02-06 Thread Dan Streetman
This unfortunately is not a simple fix. To start with, the core problem is that the 'ubuntu-regression-suite' assumes that the currently installed kernel == the built kernel, but that is not guaranteed by the test, because it defines 'Depends:' values, but does not include the @ dependency (which

[Kernel-packages] [Bug 1723223] Re: linux-lts and linux-hwe autopkgtests fail due to version mismatch

2017-10-18 Thread Dan Streetman
the failing test was added by bug 1385330 -- You received this bug notification because you are a member of Kernel Packages, which is subscribed to linux in Ubuntu. https://bugs.launchpad.net/bugs/1723223 Title: linux-lts and linux-hwe autopkgtests fail due to version mismatch Status in

[Kernel-packages] [Bug 1723223] Re: linux-lts and linux-hwe autopkgtests fail due to version mismatch

2017-10-16 Thread Eric Desrochers
** Description changed: the autopkgtests for the kernel include 'ubuntu-regression-suite' which contains this test: sver=`dpkg-parsechangelog -SVersion` read x rver x &2 - exit 1 + echo "ERROR: running version does not match source package" 1>&2 + exit 1 fi - -

[Kernel-packages] [Bug 1723223] Re: linux-lts and linux-hwe autopkgtests fail due to version mismatch

2017-10-12 Thread Eric Desrochers
** Also affects: linux (Ubuntu Trusty) Importance: Undecided Status: New ** Also affects: linux (Ubuntu Xenial) Importance: Undecided Status: New -- You received this bug notification because you are a member of Kernel Packages, which is subscribed to linux in Ubuntu.

[Kernel-packages] [Bug 1723223] Re: linux-lts and linux-hwe autopkgtests fail due to version mismatch

2017-10-12 Thread Dan Streetman
** Changed in: linux (Ubuntu Trusty) Status: New => In Progress ** Changed in: linux (Ubuntu Xenial) Status: New => In Progress ** Changed in: linux (Ubuntu Trusty) Importance: Undecided => Low ** Changed in: linux (Ubuntu Xenial) Importance: Undecided => Low ** Changed in:

[Kernel-packages] [Bug 1723223] Re: linux-lts and linux-hwe autopkgtests fail due to version mismatch

2017-10-12 Thread Dan Streetman
For example, here is a autopkgtest failure that was flagged by my update to initramfs-tools package: https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac /autopkgtest-trusty/trusty/ppc64el/l/linux-lts- xenial/20171012_183054_740b6@/log.gz the failure is