[Kernel-packages] [Bug 1320472] [NEW] 3.15.0-1.3 kernel, null pointer dereference

2014-05-17 Thread Dimitri John Ledkov
Public bug reported: I'm running utopic, kernel from proposed and that consistently fails as shown in the picture (null pointer derefence). I'm using UEFI, booted with systemd, with a damaged / not-clean filesystem (dirty bits sets and recovery required). 3.13 kernels boot fine. ProblemType:

[Kernel-packages] [Bug 1320472] Re: 3.15.0-1.3 kernel, null pointer dereference

2014-05-17 Thread Dimitri John Ledkov
https://launchpadlibrarian.net/175780082/2014-05-17.jpg kernel crash picture (first attachment in above pile) -- You received this bug notification because you are a member of Kernel Packages, which is subscribed to linux in Ubuntu. https://bugs.launchpad.net/bugs/1320472 Title:

[Kernel-packages] [Bug 1320239] Re: linux: 3.15.0-1.3 -proposed tracker

2014-05-17 Thread Dimitri John Ledkov
doesn't look good for me bug #1320472 -- You received this bug notification because you are a member of Kernel Packages, which is subscribed to linux in Ubuntu. https://bugs.launchpad.net/bugs/1320239 Title: linux: 3.15.0-1.3 -proposed tracker Status in Kernel Development Workflow: In

[Kernel-packages] [Bug 1276739] Re: partman-crypto uses xts by default, yet xts.ko kernel module is not present in 3.2 (original-point-zero stack) crypto-modules-udeb

2014-03-07 Thread Dimitri John Ledkov
) Assignee: (unassigned) = Dimitri John Ledkov (xnox) -- You received this bug notification because you are a member of Kernel Packages, which is subscribed to linux in Ubuntu. https://bugs.launchpad.net/bugs/1276739 Title: partman-crypto uses xts by default, yet xts.ko kernel module is not present

[Kernel-packages] [Bug 1276739] Re: partman-crypto uses xts by default, yet xts.ko kernel module is not present in 3.2 (original-point-zero stack) crypto-modules-udeb

2014-03-07 Thread Dimitri John Ledkov
debian-installer rebuild against 3.2.0-60 is in precise-proposed unapproved queue. ** Changed in: debian-installer (Ubuntu Precise) Status: Triaged = Fix Committed ** Changed in: debian-installer (Ubuntu Precise) Status: Fix Committed = In Progress ** Changed in: debian-installer

[Kernel-packages] [Bug 1276739] Re: partman-crypto uses xts by default, yet xts.ko kernel module is not present in 3.2 (original-point-zero stack) crypto-modules-udeb

2014-03-12 Thread Dimitri John Ledkov
** Changed in: debian-installer (Ubuntu Precise) Status: In Progress = Fix Committed -- You received this bug notification because you are a member of Kernel Packages, which is subscribed to linux in Ubuntu. https://bugs.launchpad.net/bugs/1276739 Title: partman-crypto uses xts by

[Kernel-packages] [Bug 1307105] Re: Kernel install fails due PAE checks

2014-04-16 Thread Dimitri John Ledkov
so, the post-inst on the kernel checks to see that cpu does not have PAE and then bails the upgrade. However, it could check that even though cpu has no PAE support yet the currently running kernel does have PAE config option enabled and continue with the upgrade. ** Changed in: linux (Ubuntu)

[Kernel-packages] [Bug 1308685] [NEW] Dima finally noticed after a year and a bit that vt_handoff patches were dropped

2014-04-16 Thread Dimitri John Ledkov
Public bug reported: stop trolling me. here is a bug number. ** Affects: linux (Ubuntu) Importance: Undecided Status: New -- You received this bug notification because you are a member of Kernel Packages, which is subscribed to linux in Ubuntu.

[Kernel-packages] [Bug 1308685] Re: Dima finally noticed after a year and a bit that vt_handoff patches were dropped

2014-04-16 Thread Dimitri John Ledkov
and i want a lollipop! and vt_handoff patches back, please =) also please sru this to trusty =) -- You received this bug notification because you are a member of Kernel Packages, which is subscribed to linux in Ubuntu. https://bugs.launchpad.net/bugs/1308685 Title: Dima finally noticed after

[Kernel-packages] [Bug 1308685] Re: vt_handoff patches were dropped, please resurrect them

2014-04-19 Thread Dimitri John Ledkov
Note to self, file descriptive bug reports even after a glass of wine. ** Summary changed: - Dima finally noticed after a year and a bit that vt_handoff patches were dropped + vt_handoff patches were dropped, please resurrect them ** Description changed: - stop trolling me. here is a bug

[Kernel-packages] [Bug 1276739] Re: partman-crypto uses xts by default, yet xts.ko kernel module is not present in 3.2 (original-point-zero stack) crypto-modules-udeb

2014-03-31 Thread Dimitri John Ledkov
to 3.11.0-18. -- Dimitri John Ledkov x...@ubuntu.com Fri, 07 Mar 2014 10:52:20 + ** Changed in: debian-installer (Ubuntu Precise) Status: Fix Committed = Fix Released -- You received this bug notification because you are a member of Kernel Packages, which is subscribed to linux

[Kernel-packages] [Bug 1300247] [NEW] pointless kvm disabled by bios message

2014-03-31 Thread Dimitri John Ledkov
Public bug reported: On boot I see: kvm: disabled by bios message. Can that be hidden by default? On ubuntu, we already have excellent kvm-ok utility that is suppose to detect that. And if a user doesn't know what a VM is and never going to be using kvm, there is no need to print that message

[Kernel-packages] [Bug 1300244] [NEW] pointless nouveau messages printed on boot

2014-03-31 Thread Dimitri John Ledkov
Public bug reported: NV_ERROR(drm, Pointer to TMDS table invalid\n); NV_ERROR(drm, Pointer to flat panel table invalid\n); Are printed on each boot. There was a patch floating around to fix the first one - http://lists.freedesktop.org/archives/nouveau/2013-October/014753.html Can these two

[Kernel-packages] [Bug 1274376] Re: 14.04 ovmf causes oops when running update-grub under kvm

2014-04-07 Thread Dimitri John Ledkov
** Tags added: efibugs -- You received this bug notification because you are a member of Kernel Packages, which is subscribed to linux in Ubuntu. https://bugs.launchpad.net/bugs/1274376 Title: 14.04 ovmf causes oops when running update-grub under kvm Status in “edk2” package in Ubuntu: New

[Kernel-packages] [Bug 1248270] Re: Please set CONFIG_EXT3_FS=n and CONFIG_EXT2_FS=n and CONFIG_EXT4_USE_FOR_EXT23=y

2014-01-03 Thread Dimitri John Ledkov
Andy, despite the #5 #6 comments, this bug report is about the config change requrest to flip CONFIG_EXT2|3_FS to n and set CONFIG_EXT4_USE_FOR_EXT23 to y, which I don't see applied on neither master master-next branches. Is this config change be applied in 3.13 kernels? ** Changed in: linux

[Kernel-packages] [Bug 1173655] Re: Ubuntu 13.04 - ubiquity crash due to the wifi broadcom driver

2014-01-25 Thread Dimitri John Ledkov
** Also affects: ubiquity (Ubuntu Precise) Importance: Undecided Status: New ** Also affects: ubiquity (Ubuntu Trusty) Importance: Undecided Status: Confirmed ** Also affects: bcmwl (Ubuntu) Importance: Undecided Status: New -- You received this bug notification

Re: [Kernel-packages] [Bug 1274376] Re: 14.04 ovmf causes oops when running update-grub under kvm

2014-02-04 Thread Dimitri John Ledkov
On 30 January 2014 22:57, Jamie Strandboge ja...@ubuntu.com wrote: apport information ** Tags added: apport-collected saucy ** Description changed: On up to date 14.04, if I create a vm with: virt-install --connect=qemu:///system --name=sb-saucy-amd64 --arch=x86_64 --ram=768 \

Re: [Kernel-packages] [Bug 1274376] Re: 14.04 ovmf causes oops when running update-grub under kvm

2014-02-04 Thread Dimitri John Ledkov
On 4 February 2014 09:46, Dimitri John Ledkov launch...@surgut.co.uk wrote: On 30 January 2014 22:57, Jamie Strandboge ja...@ubuntu.com wrote: apport information ** Tags added: apport-collected saucy ** Description changed: On up to date 14.04, if I create a vm with: virt-install

[Kernel-packages] [Bug 1276739] Re: kubuntu encrypted lvm install fails

2014-02-05 Thread Dimitri John Ledkov
So it appears that whilst xts.ko is present in the image-modules with the 3.2 kernel, it's not part of the crypto-modules-udeb for 3.2 based kernels and thus is not present on images that use 3.2 crypto-modules- udeb. So the following combinations work: boot hwe stack kernels, yet install 3.2 or

[Kernel-packages] [Bug 1276739] Re: partman-crypto uses xts by default, yet xts.ko kernel module is not present in 3.2 (original-point-zero stack) crypto-modules-udeb

2014-02-05 Thread Dimitri John Ledkov
) Status: New = Confirmed ** Changed in: partman-crypto (Ubuntu Precise) Importance: Undecided = High ** Changed in: partman-crypto (Ubuntu Precise) Assignee: (unassigned) = Dimitri John Ledkov (xnox) ** Changed in: linux (Ubuntu Precise) Importance: Undecided = High ** Changed

[Kernel-packages] [Bug 1276739] Re: partman-crypto uses xts by default, yet xts.ko kernel module is not present in 3.2 (original-point-zero stack) crypto-modules-udeb

2014-02-05 Thread Dimitri John Ledkov
performing manual crypto installation works if one changes IV algorithm to cbc-essiv:sha256 -- You received this bug notification because you are a member of Kernel Packages, which is subscribed to linux in Ubuntu. https://bugs.launchpad.net/bugs/1276739 Title: partman-crypto uses xts by

[Kernel-packages] [Bug 1276739] Re: partman-crypto uses xts by default, yet xts.ko kernel module is not present in 3.2 (original-point-zero stack) crypto-modules-udeb

2014-02-06 Thread Dimitri John Ledkov
** Description changed: [Impact]  * Performing automatic encrypted LVM installation using Kubuntu and Xubuntu 12.04.4 alternate installer images results in a failure to configure encrypted volumes. Please either use manual partitioning to create encrypted volumes with any non-default

[Kernel-packages] [Bug 1276739] Re: partman-crypto uses xts by default, yet xts.ko kernel module is not present in 3.2 (original-point-zero stack) crypto-modules-udeb

2014-02-06 Thread Dimitri John Ledkov
** Description changed: - kubuntu encrypted lvm install fails on 12.04.4 candidate images + [Impact] - http://people.ubuntu.com/~jr/tmp/d-i.png + * Performing automatic encrypted LVM installation using Kubuntu and + Xubuntu 12.04.4 alternate installer images results in a failure to +

[Kernel-packages] [Bug 1276739] Re: partman-crypto uses xts by default, yet xts.ko kernel module is not present in 3.2 (original-point-zero stack) crypto-modules-udeb

2014-02-13 Thread Dimitri John Ledkov
-plain64. (LP: #1263740) (closes: #482092) - Double key size if xts mode is selected. -- Dimitri John Ledkov x...@ubuntu.com Wed, 22 Jan 2014 12:25:11 + ** Changed in: partman-crypto (Ubuntu Precise) Status: Confirmed = Invalid -- You received this bug notification because you

[Kernel-packages] [Bug 1276739] Re: partman-crypto uses xts by default, yet xts.ko kernel module is not present in 3.2 (original-point-zero stack) crypto-modules-udeb

2014-02-13 Thread Dimitri John Ledkov
I believe the relevant commit for this bug report is here: http://kernel.ubuntu.com/git?p=ubuntu/ubuntu-precise.git;a=commitdiff;h=6e04e48078b50cb0ffbdb7a01d9b8c10b0064d1c From 6e04e48078b50cb0ffbdb7a01d9b8c10b0064d1c Mon Sep 17 00:00:00 2001 From: Andy Whitcroft a...@canonical.com Date: Thu, 6

[Kernel-packages] [Bug 1276739] Re: partman-crypto uses xts by default, yet xts.ko kernel module is not present in 3.2 (original-point-zero stack) crypto-modules-udeb

2014-02-13 Thread Dimitri John Ledkov
-plain64. (LP: #1263740) (closes: #482092) - Double key size if xts mode is selected. -- Dimitri John Ledkov x...@ubuntu.com Wed, 22 Jan 2014 12:25:11 + -- You received this bug notification because you are a member of Kernel Packages, which is subscribed to linux in Ubuntu. https

[Kernel-packages] [Bug 1282329] Re: juju requires cpu-checker which is unavailable on arm64/ppc64el

2014-02-19 Thread Dimitri John Ledkov
** Changed in: juju-core Status: New = Invalid -- You received this bug notification because you are a member of Kernel Packages, which is subscribed to cpu-checker in Ubuntu. https://bugs.launchpad.net/bugs/1282329 Title: juju requires cpu-checker which is unavailable on arm64/ppc64el

[Kernel-packages] [Bug 1235649] Re: uevent spam causes libdbus client code in session upstart to consume massive amounts of memory on Ubuntu Touch

2014-07-24 Thread Dimitri John Ledkov
** Changed in: upstart Status: Fix Committed = Fix Released ** Changed in: upstart Status: Fix Released = Confirmed -- You received this bug notification because you are a member of Kernel Packages, which is subscribed to linux in Ubuntu. https://bugs.launchpad.net/bugs/1235649

[Kernel-packages] [Bug 1349252] Re: crypt(3) lacks Blowfish support

2014-07-28 Thread Dimitri John Ledkov
http://www.akkadia.org/drepper/sha-crypt.html Please use SHA-512 or SHA-256, available universally since 2.7. ** Changed in: glibc (Ubuntu) Status: New = Won't Fix ** Changed in: glibc (Ubuntu) Assignee: (unassigned) = Dimitri John Ledkov (xnox) ** Changed in: linux (Ubuntu

Re: [Kernel-packages] [Bug 1349252] Re: crypt(3) lacks Blowfish support

2014-07-28 Thread Dimitri John Ledkov
On 28 July 2014 15:02, Dan Quade 1349...@bugs.launchpad.net wrote: Using sha-crypt is not a solution. Certain apps are built to use crypt(3) only and thus lack Blowfish support. You have 1 day to reopen this bug or I will make a new one. In Ubuntu, we typically do not deviate from our

[Kernel-packages] [Bug 1349252] Re: crypt(3) lacks Blowfish support

2014-07-28 Thread Dimitri John Ledkov
** Changed in: glibc (Ubuntu) Importance: Undecided = Wishlist -- You received this bug notification because you are a member of Kernel Packages, which is subscribed to linux in Ubuntu. https://bugs.launchpad.net/bugs/1349252 Title: crypt(3) lacks Blowfish support Status in “glibc”

[Kernel-packages] [Bug 1351519] [NEW] /sys/class/dmi/id/product_uuid is not world readable

2014-08-01 Thread Dimitri John Ledkov
Public bug reported: As part of (un)stable whoopsie persistent machine identifier generation /sys/class/dmi/id/product_uuid is used. However: $ ls /sys/class/dmi/id/product_uuid -r 1 root root 4096 Aug 2 01:23 /sys/class/dmi/id/product_uuid It's not world-readable. Hence API calls to

[Kernel-packages] [Bug 1353580] [NEW] errors should go to stderr, not stdout

2014-08-06 Thread Dimitri John Ledkov
Public bug reported: 2012 is calling, it wants non-broken future-proof dmidecode that doesn't print two line comment block to stdout and thus killing ubiquity =) thanks, bye. ** Affects: dmidecode (Ubuntu) Importance: Medium Assignee: Dimitri John Ledkov (xnox) Status

[Kernel-packages] [Bug 1362574] Re: hyper-v: Manual partitioning formats /boot with ext2 file-system - Utopic Unicorn

2014-10-28 Thread Dimitri John Ledkov
, please consider this for 14.10 Utopic Unicorn if possible. Dimitri John Ledkov (xnox) wrote on 2014-04-07: #9 Hello Abhishek and Phillip, I've discussed this with a few other engineers and it is to risky to push such change this close to release. There are a few things

[Kernel-packages] [Bug 1396383] [NEW] why signed kernels call update-grub?

2014-11-25 Thread Dimitri John Ledkov
Public bug reported: Looking at the postrm of linux-signed-image-* it looks very different from linux-image-* ones $ cat linux-signed-image-3.16.0-20-generic.postrm #!/bin/sh -e kernel='vmlinuz-3.16.0-20-generic' case $0-$1 in *.postinst-configure) rm -f /boot/$kernel.efi.signed

[Kernel-packages] [Bug 1353580] Re: errors should go to stderr, not stdout

2014-11-25 Thread Dimitri John Ledkov
Fixed upstream http://cvs.savannah.gnu.org/viewvc/dmidecode/dmidecode.c?revision=1.180root=dmidecodeview=markup -- You received this bug notification because you are a member of Kernel Packages, which is subscribed to dmidecode in Ubuntu. https://bugs.launchpad.net/bugs/1353580 Title: errors

[Kernel-packages] [Bug 1353580] Re: errors should go to stderr, not stdout

2014-11-25 Thread Dimitri John Ledkov
** Also affects: ubiquity (Ubuntu) Importance: Undecided Status: New ** Changed in: ubiquity (Ubuntu Precise) Status: New = Won't Fix ** Changed in: ubiquity (Ubuntu Utopic) Status: New = Won't Fix ** Changed in: ubiquity (Ubuntu Trusty) Status: New = Won't Fix

[Kernel-packages] [Bug 1398597] [NEW] ideapad yoga needs psmouse reload

2014-12-02 Thread Dimitri John Ledkov
Public bug reported: So, my often made fun of, lenovo ideapad yoga, since sometime in the 14.10 development cycle needs an extra help to get the trackpad working. On boot the mouse pointer is not visible. If I open terminal and do rmmod psmouse; modprobe psmouse the pointer magically appears on

[Kernel-packages] [Bug 1398597] Re: ideapad yoga needs psmouse reload

2014-12-03 Thread Dimitri John Ledkov
v3.18-rc7-vivid/ - needs psmouse module reload to get mice cursor -- You received this bug notification because you are a member of Kernel Packages, which is subscribed to linux in Ubuntu. https://bugs.launchpad.net/bugs/1398597 Title: ideapad yoga needs psmouse reload Status in linux

[Kernel-packages] [Bug 1398597] Re: ideapad yoga needs psmouse reload

2014-12-03 Thread Dimitri John Ledkov
3.15.0-031500-generic - good no psmouse module reload needed. -- You received this bug notification because you are a member of Kernel Packages, which is subscribed to linux in Ubuntu. https://bugs.launchpad.net/bugs/1398597 Title: ideapad yoga needs psmouse reload Status in linux package

[Kernel-packages] [Bug 1398597] Re: ideapad yoga needs psmouse reload

2014-12-03 Thread Dimitri John Ledkov
3.16.0-031600-generic - bad -- You received this bug notification because you are a member of Kernel Packages, which is subscribed to linux in Ubuntu. https://bugs.launchpad.net/bugs/1398597 Title: ideapad yoga needs psmouse reload Status in linux package in Ubuntu: Triaged Bug

[Kernel-packages] [Bug 1398597] Re: ideapad yoga needs psmouse reload

2014-12-03 Thread Dimitri John Ledkov
3.16.0-031600rc1-generic - bad so just the 3.16 merge window introduced this regression. -- You received this bug notification because you are a member of Kernel Packages, which is subscribed to linux in Ubuntu. https://bugs.launchpad.net/bugs/1398597 Title: ideapad yoga needs psmouse reload

Re: [Kernel-packages] [Bug 1398507] Re: Remove makedumpfile from syncpackage blacklist

2014-12-03 Thread Dimitri John Ledkov
On 3 December 2014 at 08:30, Louis Bouchard louis.bouch...@canonical.com wrote: Please, please, please _DON'T_ remove makedumpfile from the syncpackage blacklist. In order to have a working version of makedumpfile in Debian Jessie, the version in Sid has been deliberately brought back to

[Kernel-packages] [Bug 1398597] Re: ideapad yoga needs psmouse reload

2014-12-04 Thread Dimitri John Ledkov
@ jsalisbury I thought I've narrowed it down already: 3.15 final is good 3.16 rc 1 is bad -- You received this bug notification because you are a member of Kernel Packages, which is subscribed to linux in Ubuntu. https://bugs.launchpad.net/bugs/1398597 Title: ideapad yoga needs psmouse

[Kernel-packages] [Bug 1398597] Re: ideapad yoga needs psmouse reload

2014-12-06 Thread Dimitri John Ledkov
I have updated my firmware, that doesn't change anything wrt this touchpad bug. $ sudo dmidecode -s bios-version sudo dmidecode -s bios-release-date 66CN55WW 02/28/2013 Reading the diff, between the identified changes i'm sure that we will bisect down to the patches that refactor and change

[Kernel-packages] [Bug 1398597] Re: ideapad yoga needs psmouse reload

2014-12-06 Thread Dimitri John Ledkov
$ sha256sum linux-image-3.15.0-031500rc8-generic_3.15.0-031500rc8.201412041841_amd64.deb 6f439a83a76b0a5f7f614ecf2d57879e934ee5448095924266934f8f7e47e3de linux-image-3.15.0-031500rc8-generic_3.15.0-031500rc8.201412041841_amd64.deb is good. -- You received this bug notification because you

[Kernel-packages] [Bug 1398597] Re: ideapad yoga needs psmouse reload

2014-12-11 Thread Dimitri John Ledkov
hm, those are i386 only, and my userspace is amd64. The instructions are interesting, let me see if I can build kernels myself using those instructions to hopefully speed up the feedback / bisection loop here. -- You received this bug notification because you are a member of Kernel Packages,

[Kernel-packages] [Bug 1109029] Re: Depend on linux-initramfs-tools

2015-01-24 Thread Dimitri John Ledkov
why is dracut conflicting with initramfs-tools? shouldn't that conflict be solved in Debian? note there is no intention to support alternative initramfs implementations in Ubuntu main. ** Changed in: ubuntu-meta (Ubuntu) Status: Confirmed = Invalid -- You received this bug notification

[Kernel-packages] [Bug 1380614] Re: IPv6 address marked as 'mngtmpaddr' under utopic

2015-11-17 Thread Dimitri John Ledkov
I'd say this bug report is invalid, and not kernel related at all, and simply utopic probably had newer iproute2 userspace package with proper support for these flags. See: https://patchwork.ozlabs.org/patch/519505/ Specifically address that is derived from MAC should be marked as mngtmpaddr, as

[Kernel-packages] [Bug 1522210] [NEW] linux splits have s390 modules in extras package, rather than main one

2015-12-02 Thread Dimitri John Ledkov
Public bug reported: linux splits have s390 modules in extras package, rather than main one ** Affects: linux (Ubuntu) Importance: Undecided Status: New ** Tags: s390x ** Package changed: ubuntu => linux (Ubuntu) -- You received this bug notification because you are a member

[Kernel-packages] [Bug 1522210] Re: linux splits have s390 modules in extras package, rather than main one

2015-12-03 Thread Dimitri John Ledkov
I believe networking didn't come up, hence e.g.: kernel/drivers/s390/net/qeth.ko, or maybe even all of driver/s390/net should be in the main package. But furthermore, I'm not sure I see any benefit in having any s390x modules split into the estra package. Thus I hope that arch/s390/* &

[Kernel-packages] [Bug 1525297] Re: nic-modules udeb missing s390 modules

2015-12-11 Thread Dimitri John Ledkov
** Description changed: should have things similar to debian: - drwxr-xr-x root/root 0 2015-12-06 07:11 ./lib/modules/4.2.0-1-s390x/kernel/drivers/s390/cio/ - -rw-r--r-- root/root 21656 2015-12-06 06:17 ./lib/modules/4.2.0-1-s390x/kernel/drivers/s390/cio/ccwgroup.ko -

[Kernel-packages] [Bug 1526869] Re: should be able to do live-installer installs from mirrors, and cdrom pool over the network

2015-12-16 Thread Dimitri John Ledkov
Priliminary patches for this posted at http://people.canonical.com/~xnox /live-installer/ ** Description changed: should be able to do live-installer installs from mirrors, and cdrom pool over the network + + with live-installer patches this works. + + however on s390x currently this

[Kernel-packages] [Bug 1526869] Re: should be able to do live-installer installs from mirrors, and cdrom pool over the network

2015-12-16 Thread Dimitri John Ledkov
. -- Dimitri John Ledkov <x...@ubuntu.com> Wed, 16 Dec 2015 18:10:55 + ** Changed in: live-installer (Ubuntu Xenial) Status: New => Fix Released -- You received this bug notification because you are a member of Kernel Packages, which is subscribed to linux in Ubun

[Kernel-packages] [Bug 1525297] [NEW] nic-modules udeb missing s390 modules

2015-12-11 Thread Dimitri John Ledkov
Public bug reported: should have things similar to debian: drwxr-xr-x root/root 0 2015-12-06 07:11 ./lib/modules/4.2.0-1-s390x/kernel/drivers/s390/cio/ -rw-r--r-- root/root 21656 2015-12-06 06:17 ./lib/modules/4.2.0-1-s390x/kernel/drivers/s390/cio/ccwgroup.ko drwxr-xr-x root/root

[Kernel-packages] [Bug 1519814] Re: spl/zfs fails to build on s390x

2015-11-27 Thread Dimitri John Ledkov
** Summary changed: - xenial, linux-master FTBFS on s390x + spl/zfs fails to build on s390x ** Changed in: linux (Ubuntu) Assignee: (unassigned) => Dimitri John Ledkov (xnox) -- You received this bug notification because you are a member of Kernel Packages, which is subscribed to li

[Kernel-packages] [Bug 1519820] Re: xenial linux master-next FTBFS on s390x due to unsupported zfs

2015-11-27 Thread Dimitri John Ledkov
** Summary changed: - xenial linux master-next FTBFS on s390x + xenial linux master-next FTBFS on s390x due to unsupported zfs -- You received this bug notification because you are a member of Kernel Packages, which is subscribed to linux in Ubuntu. https://bugs.launchpad.net/bugs/1519820

[Kernel-packages] [Bug 1519834] Re: xenial s390x zfs modules

2015-11-27 Thread Dimitri John Ledkov
*** This bug is a duplicate of bug 1519814 *** https://bugs.launchpad.net/bugs/1519814 ** This bug has been marked a duplicate of bug 1519814 spl/zfs fails to build on s390x -- You received this bug notification because you are a member of Kernel Packages, which is subscribed to linux in

[Kernel-packages] [Bug 1519833] Re: s390x: xenial master-next needs a different linux-image split and new udebs

2015-11-27 Thread Dimitri John Ledkov
** Changed in: linux (Ubuntu) Status: Triaged => Fix Committed -- You received this bug notification because you are a member of Kernel Packages, which is subscribed to linux in Ubuntu. https://bugs.launchpad.net/bugs/1519833 Title: s390x: xenial master-next needs a different

[Kernel-packages] [Bug 1519814] [NEW] xenial, linux-master FTBFS on s390x

2015-11-25 Thread Dimitri John Ledkov
Public bug reported: make -C /home/xnox/xenial/linux-4.3.0/debian/build/build-generic SUBDIRS=`pwd` O=/home/xnox/xenial/linux-4.3.0/debian/build/build-generic CONFIG_SPL=m modules make[2]: Entering directory '/home/xnox/xenial/linux-4.3.0/debian/build/build-generic' CC [M]

[Kernel-packages] [Bug 1519814] Re: xenial, linux-master FTBFS on s390x

2015-11-25 Thread Dimitri John Ledkov
https://github.com/zfsonlinux/spl/pull/502 -- You received this bug notification because you are a member of Kernel Packages, which is subscribed to linux in Ubuntu. https://bugs.launchpad.net/bugs/1519814 Title: xenial, linux-master FTBFS on s390x Status in linux package in Ubuntu:

[Kernel-packages] [Bug 1519820] Re: xenial linux master-next FTBFS on s390x

2015-11-25 Thread Dimitri John Ledkov
** Patch added: "0001-UBUNTU-Config-zfs-is-not-currently-available-on-s390.patch" https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1519820/+attachment/4525279/+files/0001-UBUNTU-Config-zfs-is-not-currently-available-on-s390.patch ** Changed in: linux (Ubuntu) Status: Incomplete =>

[Kernel-packages] [Bug 1519814] Re: xenial, linux-master FTBFS on s390x

2015-11-25 Thread Dimitri John Ledkov
Not sure if we want to carry this given https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1519820 -- You received this bug notification because you are a member of Kernel Packages, which is subscribed to linux in Ubuntu. https://bugs.launchpad.net/bugs/1519814 Title: xenial, linux-master

[Kernel-packages] [Bug 1519820] [NEW] xenial linux master-next FTBFS on s390x

2015-11-25 Thread Dimitri John Ledkov
Public bug reported: make -C /home/xnox/xenial/linux-4.3.0/debian/build/build-generic SUBDIRS=`pwd` O=/home/xnox/xenial/linux-4.3.0/debian/build/build-generic CONFIG_ZFS=m modules make[2]: Entering directory '/home/xnox/xenial/linux-4.3.0/debian/build/build-generic' CC [M]

[Kernel-packages] [Bug 1519814] Re: xenial, linux-master FTBFS on s390x

2015-11-25 Thread Dimitri John Ledkov
missing #include -- You received this bug notification because you are a member of Kernel Packages, which is subscribed to linux in Ubuntu. https://bugs.launchpad.net/bugs/1519814 Title: xenial, linux-master FTBFS on s390x Status in linux package in Ubuntu: Incomplete Bug description:

[Kernel-packages] [Bug 1519834] [NEW] xenial s390x zfs modules

2015-11-25 Thread Dimitri John Ledkov
Public bug reported: at the moment they fail to build, investigate how much work it will be to get them going. ** Affects: linux (Ubuntu) Importance: Undecided Assignee: Dimitri John Ledkov (xnox) Status: Triaged ** Tags: s390x ** Changed in: linux (Ubuntu) Assignee

[Kernel-packages] [Bug 1519833] [NEW] s390x: xenial master-next needs a different linux-image split and new udebs

2015-11-25 Thread Dimitri John Ledkov
Public bug reported: Currently: -rw-r--r-- root/root 24590 2015-11-25 14:49 ./lib/modules/4.3.0-0-generic/kernel/drivers/s390/block/dasd_fba_mod.ko -rw-r--r-- root/root178446 2015-11-25 14:49 ./lib/modules/4.3.0-0-generic/kernel/drivers/s390/block/dasd_eckd_mod.ko -rw-r--r-- root/root

[Kernel-packages] [Bug 1519814] Re: spl/zfs fails to build on s390x

2015-11-30 Thread Dimitri John Ledkov
@Tim cool. But looking at spl/zfs upstream - that code is not ported to s390x yet, or is it? -- You received this bug notification because you are a member of Kernel Packages, which is subscribed to linux in Ubuntu. https://bugs.launchpad.net/bugs/1519814 Title: spl/zfs fails to build on

[Kernel-packages] [Bug 1533646] [NEW] Could you set vm.allocate_pgste = 1 by default?

2016-01-13 Thread Dimitri John Ledkov
Public bug reported: Hello, to use qemu one needs vm.allocate_pgste = 1, on kernels that support that setting e.g. s390x. I'm now setting it with a sysctl.d snippet in procps package, however I was wondering if it could be set by default. Or not. ** Affects: linux (Ubuntu) Importance:

[Kernel-packages] [Bug 1532886] Re: s390x kernels are inconsistent for cloud stuff

2016-01-12 Thread Dimitri John Ledkov
I can confirm the proposed image works great for VIRTIO_BLK/_NET stuff. Thank you. -- You received this bug notification because you are a member of Kernel Packages, which is subscribed to linux in Ubuntu. https://bugs.launchpad.net/bugs/1532886 Title: s390x kernels are inconsistent for cloud

[Kernel-packages] [Bug 1533382] [NEW] A note on virtio blk and net modules

2016-01-12 Thread Dimitri John Ledkov
Public bug reported: If VIRTIO_BLK and VIRTIO_NET become =m, instead of current =y the following should happen: VIRTIO_NET should be in the nic-modules udeb, and seeded into the d-i builds. VIRTIO_BLK can stay in block-modules-udeb, and in general is not needed in the d-i build, as it can be

[Kernel-packages] [Bug 1533382] Re: A note on virtio blk and net modules

2016-01-12 Thread Dimitri John Ledkov
xnox: Why did you add block-modules to generic/s390x.cfg? xnox: "Add block-modules (depends on virtio-modules) for s390x" seems pointless with the kernel change to make those builtin. I think I'll revert that commit. xnox: Or was there some other reason? * infinity shrugs and leaves it there

[Kernel-packages] [Bug 1567602] Re: FCP devices are not detected correctly nor deterministically

2016-06-08 Thread Dimitri John Ledkov
@Thorsten A large affected userbase is important to us. What I was trying to point out is that even without any added work done (e.g. figuring out where the fix is, and backporting it to v4.4 series) this will be resolved in the 14.04 series via hwe kernel. At this point, this appears to be a

[Kernel-packages] [Bug 1567602] Re: FCP devices are not detected correctly nor deterministically

2016-06-09 Thread Dimitri John Ledkov
@ Thorsten We should be working together, because we do not have the mainframe setup/config which reproduces / exhibits this bug. And possibly neither upstream maintainer. It is common code, but the bug is triggered on hardware config and platform that IBM ships. ** Changed in: linux (Ubuntu)

[Kernel-packages] [Bug 1567602] Re: FCP devices are not detected correctly nor deterministically

2016-06-03 Thread Dimitri John Ledkov
@ Benjamin Thank you for your insights. Is it possible to determine a scope of affected systems out there? So far a specific config is required to trigger this bug it seems, but I'm not sure how common such a configuration is. Extensive back-ports and reworks of the kernel are out of the

[Kernel-packages] [Bug 1557288] Re: zfs support on s390

2016-06-16 Thread Dimitri John Ledkov
*** This bug is a duplicate of bug 1519814 *** https://bugs.launchpad.net/bugs/1519814 On 2016-03-15 10:53:09, this bug report https://bugs.launchpad.net/ubuntu/+source/zfs-linux/+bug/1557288 got marked as a duplicate of https://bugs.launchpad.net/bugs/1519814 which is fix released since

[Kernel-packages] [Bug 1532886] [NEW] s390x kernels are inconsistent for cloud stuff

2016-01-11 Thread Dimitri John Ledkov
Public bug reported: So to do virtual machine / cloudy stuff things in the kernel config, are not how one would expect them to be. Whilst investigating that I've went ahead to compare all our kernel configs. amd64/config.common.amd64:CONFIG_VIRTIO_BLK=y

[Kernel-packages] [Bug 1532886] Re: s390x kernels are inconsistent for cloud stuff

2016-01-14 Thread Dimitri John Ledkov
I'm partially happy about this bug report now: s390x/config.common.s390x:CONFIG_KVM=m Is still a module rather than built-in on s390x. Unlike x86 there is only one implementation and it should be loaded by default. The trouble is, that it doesn't get autoloaded (and/or when libvirt-bin service

[Kernel-packages] [Bug 1534162] Re: symlinks managed by kernel postinst are different from zipl-installer and livefs-rootfs

2016-01-14 Thread Dimitri John Ledkov
** Changed in: linux (Ubuntu) Status: Confirmed => Invalid ** Changed in: linux (Ubuntu) Importance: Critical => Undecided ** Changed in: livecd-rootfs (Ubuntu) Status: New => Invalid ** Changed in: zipl-installer (Ubuntu) Status: New => Invalid -- You received this

[Kernel-packages] [Bug 1534162] Re: symlinks are not updated on s390x

2016-01-14 Thread Dimitri John Ledkov
http://paste.ubuntu.com/14495976/ -- You received this bug notification because you are a member of Kernel Packages, which is subscribed to linux in Ubuntu. https://bugs.launchpad.net/bugs/1534162 Title: symlinks are not updated on s390x Status in linux package in Ubuntu: New Bug

[Kernel-packages] [Bug 1534162] Re: symlinks are not updated on s390x

2016-01-14 Thread Dimitri John Ledkov
Ok, here is a better scenario I have purged -6, and installed -5. Then i have installed -6 and expected for symlinks to change from -5 -> -6, however they did not. http://paste.ubuntu.com/14496011/ ** Changed in: linux (Ubuntu) Importance: Undecided => Critical ** Tags added: s390x --

[Kernel-packages] [Bug 1534162] Re: symlinks are not updated on s390x

2016-01-14 Thread Dimitri John Ledkov
i am an idiot. symlinks are updated in / yet my zipl is using weird symlinks in /boot/ ** Changed in: linux (Ubuntu) Status: New => Invalid ** Summary changed: - symlinks are not updated on s390x + symlinks managed by kernel postinst are different from zipl-installer and livefs-rootfs

[Kernel-packages] [Bug 1534162] [NEW] symlinks are not updated on s390x

2016-01-14 Thread Dimitri John Ledkov
Public bug reported: Symlinks are not managed correctly. Last installed and configured kernel, prior to purging -5- was -6-, yet symlinks were not updated to -6- when that happened. root@devac03:~# apt-get remove --purge linux-headers-4.3.0-5 linux-headers-4.3.0-5-generic

[Kernel-packages] [Bug 1534162] Re: symlinks managed by kernel postinst are different from zipl-installer and livefs-rootfs

2016-01-14 Thread Dimitri John Ledkov
Aha # cat /etc/kernel-img.conf # Kernel image management overrides # See kernel-img.conf(5) for details do_symlinks = yes link_in_boot = yes -- You received this bug notification because you are a member of Kernel Packages, which is subscribed to linux in Ubuntu.

[Kernel-packages] [Bug 1539642] Re: Integrate zfcp HBA API library 2.1.1

2016-02-09 Thread Dimitri John Ledkov
** Package changed: linux (Ubuntu) => ubuntu -- You received this bug notification because you are a member of Kernel Packages, which is subscribed to linux in Ubuntu. https://bugs.launchpad.net/bugs/1539642 Title: Integrate zfcp HBA API library 2.1.1 Status in Ubuntu: New Bug

[Kernel-packages] [Bug 1543636] Re: makedumpfile: Enable s390x builds

2016-02-10 Thread Dimitri John Ledkov
** Changed in: makedumpfile (Ubuntu) Status: Confirmed => Fix Committed ** Changed in: makedumpfile (Ubuntu) Assignee: Skipper Bug Screeners (skipper-screen-team) => Dimitri John Ledkov (xnox) -- You received this bug notification because you are a member of Kernel Packages,

[Kernel-packages] [Bug 1536810] Re: kernel install failed /bin/cp: cannot stat ‘/boot/initrd.img-4.3.0-7-generic’: No such file or directory

2016-01-28 Thread Dimitri John Ledkov
link_in_boot is required as yes for s390x, and currently it seems like cloud-image generation is broken for s390x. Manually, upgrading from an older cloudimage (3.3 -6- version) I had to do a small dpkg remove surgery to drop all the packages, and reinstall new metapackages. What I found

[Kernel-packages] [Bug 1536810] Re: kernel install failed /bin/cp: cannot stat ‘/boot/initrd.img-4.3.0-7-generic’: No such file or directory

2016-01-28 Thread Dimitri John Ledkov
Hm, i don't think update-initramfs does the right thing: linux-image-*) if [ -z "$INITRAMFS_TOOLS_KERNEL_HOOK" ]; then # kernel maintainer script called us directly; ignore # it and let the hook script handle it instead echo

[Kernel-packages] [Bug 1536810] Re: kernel install failed /bin/cp: cannot stat ‘/boot/initrd.img-4.3.0-7-generic’: No such file or directory

2016-01-28 Thread Dimitri John Ledkov
Unpacking linux-generic (4.3.0.7.8) ... Processing triggers for man-db (2.7.5-1) ... Setting up linux-image-4.3.0-7-generic (4.3.0-7.18) ... Running depmod. update-initramfs: deferring update (hook will be called later) /bin/cp: cannot stat '/boot/initrd.img-4.3.0-7-generic': No such file or

[Kernel-packages] [Bug 1540551] [NEW] initramfs-tools post[inst|rm] hooks in kernel should be -extra aware

2016-02-01 Thread Dimitri John Ledkov
should not be called when -$flavor-extra is removed, cause the next action after that would be to remove just generated initramfs. related to http://irclogs.ubuntu.com/2015/06/19/%23ubuntu- devel.html#t18:04 ** Affects: linux (Ubuntu) Importance: Undecided Assignee: Dimitri John Ledkov

[Kernel-packages] [Bug 1536810] Re: kernel install failed /bin/cp: cannot stat ‘/boot/initrd.img-4.3.0-7-generic’: No such file or directory

2016-01-31 Thread Dimitri John Ledkov
Looking at the postinst script, it calls update-initramfs -u and expects it to do somethin, i.e. create the initramfs. However, it can choose to not do so, and deffer the update. And thus not create an initramfs. However, when we are upgrading to a new kernel image, we expect to generate an

[Kernel-packages] [Bug 1536810] Re: kernel install failed /bin/cp: cannot stat ‘/boot/initrd.img-4.3.0-7-generic’: No such file or directory

2016-01-31 Thread Dimitri John Ledkov
** Patch added: "linux-postinst.patch" https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1536810/+attachment/4560470/+files/linux-postinst.patch -- You received this bug notification because you are a member of Kernel Packages, which is subscribed to linux in Ubuntu.

[Kernel-packages] [Bug 1536810] Re: kernel install failed /bin/cp: cannot stat ‘/boot/initrd.img-4.3.0-7-generic’: No such file or directory

2016-01-31 Thread Dimitri John Ledkov
however, as per irc, that will kill the benefit of deffered initramfs generation. Identified to cherrypick https://anonscm.debian.org/cgit/kernel/linux.git/commit/?id=373d086904305699561b1eb505c33b010c24de9b https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=738707 ** Bug watch added: Debian

[Kernel-packages] [Bug 1353580] Re: errors should go to stderr, not stdout

2016-02-23 Thread Dimitri John Ledkov
** Changed in: dmidecode (Ubuntu) Status: Confirmed => Fix Released ** Changed in: dmidecode (Ubuntu Precise) Assignee: Dimitri John Ledkov (xnox) => (unassigned) ** Changed in: dmidecode (Ubuntu Trusty) Assignee: Dimitri John Ledkov (xnox) => (unassigned) *

[Kernel-packages] [Bug 1550468] Re: s390x: correct restore of high gprs on signal return

2016-02-28 Thread Dimitri John Ledkov
s390x is only available in xenial (and later releases). Please do not open bugs for irrelevant series. ** Changed in: linux (Ubuntu Wily) Status: In Progress => Invalid -- You received this bug notification because you are a member of Kernel Packages, which is subscribed to linux in

[Kernel-packages] [Bug 1519814] Re: spl/zfs fails to build on s390x

2016-02-29 Thread Dimitri John Ledkov
Discussing with s390x upstream developers, we should check if zpl/zfs code supports any other 64bit big-endian platforms (e.g. SPARC64) and then check if s390x support can be trivially enabled similarly to e.g. sparc64 port. -- You received this bug notification because you are a member of

[Kernel-packages] [Bug 1274376] Re: 14.04 ovmf causes oops when running update-grub under kvm

2016-02-23 Thread Dimitri John Ledkov
I'm not sure what needs doing here, unassigning myself. ** Changed in: edk2 (Ubuntu) Assignee: Dimitri John Ledkov (xnox) => Steve Langasek (vorlon) -- You received this bug notification because you are a member of Kernel Packages, which is subscribed to linux in Ubuntu. ht

[Kernel-packages] [Bug 1533646] Re: Could you set vm.allocate_pgste = 1 by default?

2016-01-21 Thread Dimitri John Ledkov
** Also affects: procps (Ubuntu) Importance: Undecided Status: New ** Changed in: procps (Ubuntu) Status: New => Fix Released ** Changed in: linux (Ubuntu) Status: Incomplete => Invalid -- You received this bug notification because you are a member of Kernel Packages,

Re: [Kernel-packages] [Bug 1533646] Re: Could you set vm.allocate_pgste = 1 by default?

2016-01-21 Thread Dimitri John Ledkov
On 21 January 2016 at 08:38, Christian Borntraeger wrote: > ok, kvm builtin certainly makes sense if you plan to use it regularly. > So in essence its a question about: do we expect a number of users to use KVM > in Ubuntu or not? > Yes. Last I checked, on all

[Kernel-packages] [Bug 1536245] Re: s390x kernel image needs weightwatchers

2016-01-21 Thread Dimitri John Ledkov
** Tags added: s390x -- You received this bug notification because you are a member of Kernel Packages, which is subscribed to linux in Ubuntu. https://bugs.launchpad.net/bugs/1536245 Title: s390x kernel image needs weightwatchers Status in linux package in Ubuntu: Triaged Status in linux

  1   2   3   4   5   6   7   >