[Kernel-packages] [Bug 1671360] Re: System doesn't boot properly on Gigabyte AM4 motherboards (AMD Ryzen)

2017-04-13 Thread Robert Sandru
@Eric Joslyn: you can do the same with a stable kernel from the 4.10 series, no need to be on the bleeding edge with release candidates. (I see it's been backported to 4.9 too) The key patch you really want to get in is the one that correctly identifies the hyper-threading capabilities of the

[Kernel-packages] [Bug 1671360] Re: System doesn't boot properly on Gigabyte AM4 motherboards (AMD Ryzen)

2017-04-14 Thread Robert Sandru
Some inputs for what it's worth... with a self built 4.10.4 from a few weeks back but same config as yours (AMD pinctrl disabled) - no other changes: - USB works fine on all the ports I tried (several devices) - Network works fine (both ports Intel and Killer Networks) - NVMe drive works fine -

[Kernel-packages] [Bug 1671360] Re: System doesn't boot properly on AMD Ryzen / Gigabyte GA-AB350-gaming-3

2017-03-12 Thread Robert Sandru
Cosmin, when you say you installed 16.04, do you mean Ubuntu Studio 16.04 or the standard distribution? Did you install the OS from scratch using an USB stick of some other media? You were trying to do an update to 17.04 so did 16.04 boot initially correctly? Please provide details, just saying

[Kernel-packages] [Bug 1671360] Re: System doesn't boot properly on AMD Ryzen / Gigabyte GA-AB350-gaming-3

2017-03-12 Thread Robert Sandru
Still no dice. Tried another path: - Installed on a spare HDD using VMware in Windows (assigned full disk to VMware), no additional drivers or anything changed - Updated kernel to 4.11rc1 (using prebuild binaries) - Updated grub parameters: acpi=off quiet loglevel=3 - Rebooted computer with that

[Kernel-packages] [Bug 1671360] Re: System doesn't boot properly on AMD Ryzen / Gigabyte GA-AB350-gaming-3

2017-03-10 Thread Robert Sandru
Maciej, do you have any suggestions if there is no previous OS installed? Any way for to fix the installation image so that I can at least get a base installation going? -- You received this bug notification because you are a member of Kernel Packages, which is subscribed to linux in Ubuntu.

[Kernel-packages] [Bug 1671360] Re: System doesn't boot properly on AMD Ryzen / Gigabyte GA-AB350-gaming-3

2017-03-13 Thread Robert Sandru
Hi Cosmin, thanks a lot for the details. I can see a couple of differences that I need to look into: - Chipset is different B350 vs. X370 - I attempted the fresh 16.04 install from a USB stick instead of a DVD (I've got no optical drive at all, so can't test that) -> IRQ TRAP (same with

[Kernel-packages] [Bug 1671360] Re: System doesn't boot properly on AMD Ryzen / Gigabyte GA-AB350-gaming-3

2017-03-13 Thread Robert Sandru
@Eric: I've managed to boot the system using your custom built kernel! Not usable really now as the nvidia driver installation is failing but much better... So clearly the code around PINCTRL_AMD seems to be related. -- You received this bug notification because you are a member of Kernel

[Kernel-packages] [Bug 1671360] Re: System doesn't boot properly on Gigabyte AM4 motherboards (AMD Ryzen)

2017-04-08 Thread Robert Sandru
In any case if this is confirmed we need to raise the issue with them. In the past they've been "hiding" behind the fact that the motherboard specification page says: Operating System Support for Windows 10 64-bit Support for Windows 7 64-bit * Please download the "Windows USB