[Kernel-packages] [Bug 1882088] Comment bridged from LTC Bugzilla

2020-07-10 Thread bugproxy
--- Comment From stefan.ra...@de.ibm.com 2020-07-10 11:24 EDT---
Here is a proper link:
https://git.kernel.org/pub/scm/linux/kernel/git/netdev/net.git/commit/?id=fb4f79264c0fc6fd5a68ffe3e31bfff97311e1f1

-- 
You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.
https://bugs.launchpad.net/bugs/1882088

Title:
  [UBUNTU 20.04] smc: SMC connections hang with later-level
  implementations

Status in Ubuntu on IBM z Systems:
  Incomplete
Status in linux package in Ubuntu:
  New
Status in linux source package in Focal:
  New
Status in linux source package in Groovy:
  New

Bug description:
  Description:   smc: SMC connections hang with later-level implementations
  Symptom:   Connections from later-level SMC versions to an SMC-enabled
 server on Linux hang.
  Problem:   Later-level versions of SMC present, although backwards-
 compatible, a higher version number, and use larger messages
 during the CLC handshake.
  Solution:  Adjust for tolerating later version numbers, and support CLC
 messages of arbitrary length.
  Reproduction:  Enable a server on Linux for SMC, and connect using a later-
 level version of SMC

  Applicable for: Ubuntu 20.04

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu-z-systems/+bug/1882088/+subscriptions

-- 
Mailing list: https://launchpad.net/~kernel-packages
Post to : kernel-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~kernel-packages
More help   : https://help.launchpad.net/ListHelp


[Kernel-packages] [Bug 1882088] Comment bridged from LTC Bugzilla

2020-07-09 Thread bugproxy
--- Comment From stefan.ra...@de.ibm.com 2020-07-09 07:02 EDT---
The patch was posted upstream, see 
https://www.spinics.net/lists/netdev/msg666808.html, and accepted by Dave 
Miller. I just checked his net-next tree, didn't see it there yet, but I would 
assume it will appear there soon.

-- 
You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.
https://bugs.launchpad.net/bugs/1882088

Title:
  [UBUNTU 20.04] smc: SMC connections hang with later-level
  implementations

Status in Ubuntu on IBM z Systems:
  Incomplete
Status in linux package in Ubuntu:
  New
Status in linux source package in Focal:
  New
Status in linux source package in Groovy:
  New

Bug description:
  Description:   smc: SMC connections hang with later-level implementations
  Symptom:   Connections from later-level SMC versions to an SMC-enabled
 server on Linux hang.
  Problem:   Later-level versions of SMC present, although backwards-
 compatible, a higher version number, and use larger messages
 during the CLC handshake.
  Solution:  Adjust for tolerating later version numbers, and support CLC
 messages of arbitrary length.
  Reproduction:  Enable a server on Linux for SMC, and connect using a later-
 level version of SMC

  Applicable for: Ubuntu 20.04

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu-z-systems/+bug/1882088/+subscriptions

-- 
Mailing list: https://launchpad.net/~kernel-packages
Post to : kernel-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~kernel-packages
More help   : https://help.launchpad.net/ListHelp


[Kernel-packages] [Bug 1882088] Comment bridged from LTC Bugzilla

2020-06-29 Thread bugproxy
--- Comment From stefan.ra...@de.ibm.com 2020-06-29 08:07 EDT---
As I wrote in a previous comment, it's not so much a question 'if' we can post 
it upstream, but rather 'at which time': We assume that we get a lot of 
resistance upstream if we post any code for v2 in absence of an RFC right now, 
plus we cannot talk about v2 yet for legal reasons yet.
Once a new IETF RFC detailing v2 is out, we can post our full implementation of 
v2 upstream, and these patches will be part of that effort.

-- 
You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.
https://bugs.launchpad.net/bugs/1882088

Title:
  [UBUNTU 20.04] smc: SMC connections hang with later-level
  implementations

Status in Ubuntu on IBM z Systems:
  New
Status in linux package in Ubuntu:
  New
Status in linux source package in Focal:
  New

Bug description:
  Description:   smc: SMC connections hang with later-level implementations
  Symptom:   Connections from later-level SMC versions to an SMC-enabled
 server on Linux hang.
  Problem:   Later-level versions of SMC present, although backwards-
 compatible, a higher version number, and use larger messages
 during the CLC handshake.
  Solution:  Adjust for tolerating later version numbers, and support CLC
 messages of arbitrary length.
  Reproduction:  Enable a server on Linux for SMC, and connect using a later-
 level version of SMC

  Applicable for: Ubuntu 20.04

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu-z-systems/+bug/1882088/+subscriptions

-- 
Mailing list: https://launchpad.net/~kernel-packages
Post to : kernel-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~kernel-packages
More help   : https://help.launchpad.net/ListHelp


[Kernel-packages] [Bug 1882088] Comment bridged from LTC Bugzilla

2020-06-04 Thread bugproxy
--- Comment From stefan.ra...@de.ibm.com 2020-06-04 11:02 EDT---
That's a very valid question.
The problem is that we cannot talk about v2 yet for legal reasons. We're 
pending some internal processing and especially a new RFC on v2. We assume that 
we get a lot of resistance upstream if we post any code for v2 in absence of an 
RFC.

-- 
You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.
https://bugs.launchpad.net/bugs/1882088

Title:
  [UBUNTU 20.04] smc: SMC connections hang with later-level
  implementations

Status in Ubuntu on IBM z Systems:
  New
Status in linux package in Ubuntu:
  New
Status in linux source package in Focal:
  New

Bug description:
  Description:   smc: SMC connections hang with later-level implementations
  Symptom:   Connections from later-level SMC versions to an SMC-enabled
 server on Linux hang.
  Problem:   Later-level versions of SMC present, although backwards-
 compatible, a higher version number, and use larger messages
 during the CLC handshake.
  Solution:  Adjust for tolerating later version numbers, and support CLC
 messages of arbitrary length.
  Reproduction:  Enable a server on Linux for SMC, and connect using a later-
 level version of SMC

  Applicable for: Ubuntu 20.04

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu-z-systems/+bug/1882088/+subscriptions

-- 
Mailing list: https://launchpad.net/~kernel-packages
Post to : kernel-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~kernel-packages
More help   : https://help.launchpad.net/ListHelp


[Kernel-packages] [Bug 1882088] Comment bridged from LTC Bugzilla

2020-06-04 Thread bugproxy
--- Comment From stefan.ra...@de.ibm.com 2020-06-04 10:10 EDT---
Note: This patch is currently not upstream. It will be part of the full SMC-D 
v2 implementation (see LP1853291), and was successfully tested with a reference 
implementation. However, we still have some way to go with our SMC-D v2 code, 
yet other providers of SMC-D v2 implementations asked us to ship this 
toleration patch early, so that users have a chance to have their systems up to 
date by the time they deliver their versions.

-- 
You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.
https://bugs.launchpad.net/bugs/1882088

Title:
  [UBUNTU 20.04] smc: SMC connections hang with later-level
  implementations

Status in Ubuntu on IBM z Systems:
  New
Status in linux package in Ubuntu:
  New
Status in linux source package in Focal:
  New

Bug description:
  Description:   smc: SMC connections hang with later-level implementations
  Symptom:   Connections from later-level SMC versions to an SMC-enabled
 server on Linux hang.
  Problem:   Later-level versions of SMC present, although backwards-
 compatible, a higher version number, and use larger messages
 during the CLC handshake.
  Solution:  Adjust for tolerating later version numbers, and support CLC
 messages of arbitrary length.
  Reproduction:  Enable a server on Linux for SMC, and connect using a later-
 level version of SMC

  Applicable for: Ubuntu 20.04

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu-z-systems/+bug/1882088/+subscriptions

-- 
Mailing list: https://launchpad.net/~kernel-packages
Post to : kernel-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~kernel-packages
More help   : https://help.launchpad.net/ListHelp