[Bug 1811214] [NEW] plasmashell stops updating when compositing is disabled

2019-01-10 Thread Yann Salmon
Public bug reported:

I ordinarily run KUbuntu 18.04 with desktop compositing enabled, using
OpenGL 3.1 and this works quite well.

However on some occasions when compositing gets disabled, either because
a game disables it or when I manually disable it in the configuration
panel, Plasmashell's taskbar stops updating and its appearance gets
replaced with an old version.

I can tell because the application taskbar buttons are not correct and
the hour is also not the right one. Reactivating composition restores
normal behaviour. Only the display is affected : even if some
application button is not displayed, I can still click on it if I
remember where it is.

The information displayed during this problem is always the same until I
kill plasmashell and restart it. What is displayed seems to be the state
when plasmashell was last (re)started, or when the computer resumed from
either suspend or hibernation.

** Affects: plasma-workspace (Ubuntu)
 Importance: Undecided
 Status: New

-- 
You received this bug notification because you are a member of Kubuntu
Bugs, which is subscribed to plasma-workspace in Ubuntu.
https://bugs.launchpad.net/bugs/1811214

Title:
  plasmashell stops updating when compositing is disabled

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/plasma-workspace/+bug/1811214/+subscriptions

-- 
kubuntu-bugs mailing list
kubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/kubuntu-bugs


[Bug 1811214] Re: plasmashell stops updating when compositing is disabled

2019-01-10 Thread Yann Salmon
** Bug watch added: KDE Bug Tracking System #361763
   https://bugs.kde.org/show_bug.cgi?id=361763

** Also affects: kde-workspace via
   https://bugs.kde.org/show_bug.cgi?id=361763
   Importance: Unknown
   Status: Unknown

-- 
You received this bug notification because you are a member of Kubuntu
Bugs, which is subscribed to plasma-workspace in Ubuntu.
https://bugs.launchpad.net/bugs/1811214

Title:
  plasmashell stops updating when compositing is disabled

To manage notifications about this bug go to:
https://bugs.launchpad.net/kde-workspace/+bug/1811214/+subscriptions

-- 
kubuntu-bugs mailing list
kubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/kubuntu-bugs


[Bug 1811214] Re: plasmashell stops updating when compositing is disabled

2019-01-10 Thread Bug Watch Updater
Launchpad has imported 1 comments from the remote bug at
https://bugs.kde.org/show_bug.cgi?id=361763.

If you reply to an imported comment from within Launchpad, your comment
will be sent to the remote bug automatically. Read more about
Launchpad's inter-bugtracker facilities at
https://help.launchpad.net/InterBugTracking.


On 2016-04-14T12:53:03+00:00 Jirislaby wrote:

Currently, I use intel_drv with SNA. I have compositing enabled (opengl
3.1).

When I switch to modesetting_drv, plasmashell "locks up" few seconds
after start. The trigger is perhaps hovering over icons in the tray.

The lockup is that X spins with drm_ioctl_wait_vblank and other ioctls on one 
CPU 100%. When I do:
killall plasmashell ; plasmashell
X stops spinning until I hover over the icons again.

So plasmashell has some problem with rendering, I suppose. I tried both
OpenGL and XRender compositing. Note that this also happens without
compositing enabled at all.

Reproducible: Always

Reply at: https://bugs.launchpad.net/ubuntu/+source/plasma-
workspace/+bug/1811214/comments/0


** Changed in: kde-workspace
   Status: Unknown => New

** Changed in: kde-workspace
   Importance: Unknown => High

-- 
You received this bug notification because you are a member of Kubuntu
Bugs, which is subscribed to plasma-workspace in Ubuntu.
https://bugs.launchpad.net/bugs/1811214

Title:
  plasmashell stops updating when compositing is disabled

To manage notifications about this bug go to:
https://bugs.launchpad.net/kde-workspace/+bug/1811214/+subscriptions

-- 
kubuntu-bugs mailing list
kubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/kubuntu-bugs


[Bug 1793876] Re: software-properties-qt/kde does not show in menus

2019-01-10 Thread Sebastien Bacher
Thank you for your work, could you propose the change as a merge request
on https://code.launchpad.net/~ubuntu-core-dev/software-properties/main
? Removing the NoDisplay seems fine but then you should probably add a
ShowOnlyIn=KDE to it (and similar =GNOME to the -gtk one if you want to
have rather the kde one only  listed)

-- 
You received this bug notification because you are a member of Kubuntu
Bugs, which is subscribed to the bug report.
https://bugs.launchpad.net/bugs/1793876

Title:
  software-properties-qt/kde does not show in menus

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/software-properties/+bug/1793876/+subscriptions

-- 
kubuntu-bugs mailing list
kubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/kubuntu-bugs


[Bug 1808508] Re: Valgrind doesn't work in disco [Fatal error at startup: a function redirection which is mandatory for this platform-tool combination cannot be set up.]

2019-01-10 Thread Matthias Klose
dh_strip in debhelper v9 mode doesn't use the filename anymore, so gdb
should not affected.

-- 
You received this bug notification because you are a member of Kubuntu
Bugs, which is subscribed to the bug report.
https://bugs.launchpad.net/bugs/1808508

Title:
  Valgrind doesn't work in disco [Fatal error at startup: a function
  redirection which is mandatory for this platform-tool combination
  cannot be set up.]

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/base-files/+bug/1808508/+subscriptions

-- 
kubuntu-bugs mailing list
kubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/kubuntu-bugs


[Bug 1793876] Re: software-properties-qt/kde does not show in menus

2019-01-10 Thread Sebastien Bacher
** Changed in: software-properties (Ubuntu)
   Importance: Undecided => Low

** Changed in: software-properties (Ubuntu)
   Status: New => Confirmed

-- 
You received this bug notification because you are a member of Kubuntu
Bugs, which is subscribed to the bug report.
https://bugs.launchpad.net/bugs/1793876

Title:
  software-properties-qt/kde does not show in menus

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/software-properties/+bug/1793876/+subscriptions

-- 
kubuntu-bugs mailing list
kubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/kubuntu-bugs


[Bug 1422098] Re: Global keyboard shortcuts settings window starts too small

2019-01-10 Thread Norbert Fabritius
Corresponding KDE bug:
https://bugs.kde.org/show_bug.cgi?id=403080


** Bug watch added: KDE Bug Tracking System #403080
   https://bugs.kde.org/show_bug.cgi?id=403080

-- 
You received this bug notification because you are a member of Kubuntu
Bugs, which is subscribed to kde-cli-tools in Ubuntu.
https://bugs.launchpad.net/bugs/1422098

Title:
  Global keyboard shortcuts settings window starts too small

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/kde-cli-tools/+bug/1422098/+subscriptions

-- 
kubuntu-bugs mailing list
kubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/kubuntu-bugs


[Bug 1778011] Re: SRU: PRIME Power Saving mode draws too much power

2019-01-10 Thread Pe4enko
Should it work on ubuntu 18.10? I try to install 390 driver. After this i run 
command 
sudo prime-select nvidia and restart system. But GUI no work anymore. In kernel 
log i see errors.
My video card is geforce 750M

Jan 11 02:38:17 lblack kernel: [  121.613281] nvidia: loading out-of-tree 
module taints kernel.
Jan 11 02:38:17 lblack kernel: [  121.613290] nvidia: module license 'NVIDIA' 
taints kernel.
Jan 11 02:38:17 lblack kernel: [  121.613290] Disabling lock debugging due to 
kernel taint
Jan 11 02:38:17 lblack kernel: [  121.616641] nvidia: module verification 
failed: signature and/or required key missing - tainting kernel
Jan 11 02:38:17 lblack kernel: [  121.623093] nvidia-nvlink: Nvlink Core is 
being initialized, major device number 238
Jan 11 02:38:17 lblack kernel: [  121.623677] NVRM: loading NVIDIA UNIX x86_64 
Kernel Module  390.87  Tue Aug 21 12:33:05 PDT 2018 (using threaded interrupts)
Jan 11 02:38:17 lblack kernel: [  121.625479] NVRM: API mismatch: the client 
has the version 410.66, but
Jan 11 02:38:17 lblack kernel: [  121.625479] NVRM: this kernel module has the 
version 390.87.  Please
Jan 11 02:38:17 lblack kernel: [  121.625479] NVRM: make sure that this kernel 
module and all NVIDIA driver
Jan 11 02:38:17 lblack kernel: [  121.625479] NVRM: components have the same 
version.

-- 
You received this bug notification because you are a member of Kubuntu
Bugs, which is subscribed to sddm in Ubuntu.
https://bugs.launchpad.net/bugs/1778011

Title:
  SRU: PRIME Power Saving mode draws too much power

To manage notifications about this bug go to:
https://bugs.launchpad.net/hwe-next/+bug/1778011/+subscriptions

-- 
kubuntu-bugs mailing list
kubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/kubuntu-bugs