Merging KVM live migration upstream

2009-05-01 Thread Jan Kiszka
Avi or Uri, could you explain the first and third hunk? Why are they needed in qemu-kvm, and will we also need something comparable upstream? They do not look very beautiful. The second hunk, I guess, should become a kvm hook to cpu_physical_memory_get_dirty - or is this too costly for other

Re: [KVM-AUTOTEST] [PATCH] Iterate over reboot

2009-05-01 Thread Michael Goldish
- supriya kannery supri...@in.ibm.com wrote: Uri Lublin wrote: supriya kannery wrote: A patch for iterating over VM reboot I think adding iterations capability belongs to the infrastructure, not the test itself. Implement it once in the infrastructure, instead of once per

Re: [PATCH 03/04] qemu-kvm: Remove the dependency for phys_ram_base for ipf.c

2009-05-01 Thread Jes Sorensen
Zhang, Xiantao wrote: Jes Sorensen wrote: I still can't see the difference with the patch in Avi's tree except nvram stuff. And I believe the global variable you mentioned should be only used for nvram. So I propose an incremental patch for that. :) Hi, Here is an incremental version of

Re: Merging KVM live migration upstream

2009-05-01 Thread Avi Kivity
Jan Kiszka wrote: Avi or Uri, could you explain the first and third hunk? Why are they needed in qemu-kvm, and will we also need something comparable upstream? They do not look very beautiful. These date from the bad old days where we relied on phys_ram_base. I think this is obsolete.

Re: Merging KVM live migration upstream

2009-05-01 Thread Jan Kiszka
Avi Kivity wrote: Jan Kiszka wrote: Avi or Uri, could you explain the first and third hunk? Why are they needed in qemu-kvm, and will we also need something comparable upstream? They do not look very beautiful. These date from the bad old days where we relied on phys_ram_base. I

Re: [KVM-AUTOTEST] [PATCH] Iterate over reboot

2009-05-01 Thread supriya kannery
Uri Lublin wrote: supriya kannery wrote: A patch for iterating over VM reboot I think adding iterations capability belongs to the infrastructure, not the test itself. Implement it once in the infrastructure, instead of once per test. Also I think autotest has such a capability (adding

Re: [Qemu-devel] Re: [PATCH] virtio-blk: add SGI_IO passthru support

2009-05-01 Thread Jamie Lokier
Christoph Hellwig wrote: On Thu, Apr 30, 2009 at 10:49:19PM +0100, Paul Brook wrote: Only if you emulate a crufty old parallel scsi bus, and that's just silly. One of the nice things about scsi is it separates the command set from the transport layer. cf. USB mass-storage, SAS,

Re: FW: Notification from Qemu to Guest

2009-05-01 Thread Pantelis Koukousoulas
And as a part of handle output for kick in the qemu side I am simply calling virtio_notify static void virtio_sample_handle_output(VirtIODevice *vdev, VirtQueue *vq) {            printf(Function = %s, Line =

Re: Merging KVM live migration upstream

2009-05-01 Thread Anthony Liguori
Jan Kiszka wrote: Avi or Uri, could you explain the first and third hunk? Why are they needed in qemu-kvm, and will we also need something comparable upstream? They do not look very beautiful. This is leftovers from v1 loading. It used to be that we saved the vga buffer independently

[PATCH] Revert Sync idcache after emualted DMA operations for ia64

2009-05-01 Thread Hollis Blanchard
This reverts commit 9dc99a28236161a5a1b4c58f1e9c4ec6179cb976. Aside from the other issues discussed on kvm-devel, this commit breaks the PowerPC build. Signed-off-by: Hollis Blanchard holl...@us.ibm.com --- Bad mailing list address on my previous mail. cache-utils.h | 14 --

Re: qemu-kvm.git now live

2009-05-01 Thread Hollis Blanchard
On Wed, 2009-04-29 at 11:29 +0300, Avi Kivity wrote: * configure completely ignores --kerneldir and only uses kvm/kernel headers instead. That's intentional. Huh? If --kerneldir does nothing, why does it exist? * The headers in kvm/kernel/arch/foo seem to be

Re: qemu-kvm.git now live

2009-05-01 Thread Hollis Blanchard
On Wed, 2009-04-29 at 11:31 +0300, Avi Kivity wrote: Hollis Blanchard wrote: Since PPC is now supported in upstream QEMU, does it really matter if it works in qemu-kvm.git? I was going to take that position too, except Avi asked me specifically if some of the code inside

[PATCH] kvm: trivial format fix in setup_routing_entry()

2009-05-01 Thread Chris Wright
Remove extra tab. Signed-off-by: Chris Wright chr...@redhat.com --- virt/kvm/irq_comm.c |2 +- 1 files changed, 1 insertions(+), 1 deletions(-) diff --git a/virt/kvm/irq_comm.c b/virt/kvm/irq_comm.c index 4fa1f60..a8bd466 100644 --- a/virt/kvm/irq_comm.c +++ b/virt/kvm/irq_comm.c @@ -271,7

[PATCH 1/5] [libkvm] Rename config-powerpc to config-ppc

2009-05-01 Thread Hollis Blanchard
Apparently $(ARCH) now holds the qemu meaning, rather than the KVM meaning. Signed-off-by: Hollis Blanchard holl...@us.ibm.com --- kvm/libkvm/config-powerpc.mak |4 kvm/libkvm/config-ppc.mak |4 2 files changed, 4 insertions(+), 4 deletions(-) delete mode 100644

PPC support for qemu-kvm

2009-05-01 Thread Hollis Blanchard
These patches fix a number of issues with PowerPC builds of qemu-kvm.git. However, even after applying these patches it still doesn't build, due to confusion with KVM_UPSTREAM and CONFIG_KVM. -- To unsubscribe from this list: send the line unsubscribe kvm in the body of a message to

[PATCH 2/5] [qemu-kvm] Fix warning when__ia64__ is not defined.

2009-05-01 Thread Hollis Blanchard
Signed-off-by: Hollis Blanchard holl...@us.ibm.com --- kvm/libkvm/kvm-common.h |2 +- 1 files changed, 1 insertions(+), 1 deletions(-) diff --git a/kvm/libkvm/kvm-common.h b/kvm/libkvm/kvm-common.h index 96361e8..591fb53 100644 --- a/kvm/libkvm/kvm-common.h +++ b/kvm/libkvm/kvm-common.h @@

[PATCH 3/5] [qemu-kvm] Fix missing prototype warning.

2009-05-01 Thread Hollis Blanchard
As far as I can see, kvm_destroy_memory_region_works() has nothing to do with KVM_CAP_DEVICE_ASSIGNMENT, so move the prototype outside that ifdef block. Signed-off-by: Hollis Blanchard holl...@us.ibm.com --- kvm/libkvm/libkvm.h |2 +- 1 files changed, 1 insertions(+), 1 deletions(-) diff

[PATCH 5/5] patch add_powerpc_kvm_headers.diff

2009-05-01 Thread Hollis Blanchard
--- kvm/kernel/arch/powerpc/include/asm/kvm.h | 102 +++ kvm/kernel/arch/powerpc/include/asm/kvm_44x.h | 108 +++ kvm/kernel/arch/powerpc/include/asm/kvm_asm.h | 100 ++ kvm/kernel/arch/powerpc/include/asm/kvm_e500.h | 107 +++

Re: qemu-kvm.git now live

2009-05-01 Thread Anthony Liguori
Hollis Blanchard wrote: On Wed, 2009-04-29 at 11:29 +0300, Avi Kivity wrote: * configure completely ignores --kerneldir and only uses kvm/kernel headers instead. That's intentional. Huh? If --kerneldir does nothing, why does it exist? BTW Avi, if you

Re: qemu-kvm.git now live

2009-05-01 Thread Hollis Blanchard
On Wed, 2009-04-29 at 11:31 +0300, Avi Kivity wrote: Hollis Blanchard wrote: Since PPC is now supported in upstream QEMU, does it really matter if it works in qemu-kvm.git? I was going to take that position too, except Avi asked me specifically if some of the code inside

[PATCH 1/5] [libkvm] Rename config-powerpc to config-ppc

2009-05-01 Thread Hollis Blanchard
Apparently $(ARCH) now holds the qemu meaning, rather than the KVM meaning. Signed-off-by: Hollis Blanchard holl...@us.ibm.com --- kvm/libkvm/config-powerpc.mak |4 kvm/libkvm/config-ppc.mak |4 2 files changed, 4 insertions(+), 4 deletions(-) delete mode 100644

[PATCH 2/5] [qemu-kvm] Fix warning when__ia64__ is not defined.

2009-05-01 Thread Hollis Blanchard
Signed-off-by: Hollis Blanchard holl...@us.ibm.com --- kvm/libkvm/kvm-common.h |2 +- 1 files changed, 1 insertions(+), 1 deletions(-) diff --git a/kvm/libkvm/kvm-common.h b/kvm/libkvm/kvm-common.h index 96361e8..591fb53 100644 --- a/kvm/libkvm/kvm-common.h +++ b/kvm/libkvm/kvm-common.h @@

[PATCH 3/5] [qemu-kvm] Fix missing prototype warning.

2009-05-01 Thread Hollis Blanchard
As far as I can see, kvm_destroy_memory_region_works() has nothing to do with KVM_CAP_DEVICE_ASSIGNMENT, so move the prototype outside that ifdef block. Signed-off-by: Hollis Blanchard holl...@us.ibm.com --- kvm/libkvm/libkvm.h |2 +- 1 files changed, 1 insertions(+), 1 deletions(-) diff

[PATCH 4/5] [qemu-kvm] Use CAP_IRQ_ROUTING in kvm_get_irq_route_gsi()

2009-05-01 Thread Hollis Blanchard
This fixes a build break when KVM_IOAPIC_NUM_PINS is not defined. Signed-off-by: Hollis Blanchard holl...@us.ibm.com --- kvm/libkvm/libkvm.c |4 1 files changed, 4 insertions(+), 0 deletions(-) diff --git a/kvm/libkvm/libkvm.c b/kvm/libkvm/libkvm.c index 0610e3f..ba0a5d1 100644 ---

[PATCH 5/5] patch add_powerpc_kvm_headers.diff

2009-05-01 Thread Hollis Blanchard
--- kvm/kernel/arch/powerpc/include/asm/kvm.h | 102 +++ kvm/kernel/arch/powerpc/include/asm/kvm_44x.h | 108 +++ kvm/kernel/arch/powerpc/include/asm/kvm_asm.h | 100 ++ kvm/kernel/arch/powerpc/include/asm/kvm_e500.h | 107 +++

Re: qemu-kvm.git now live

2009-05-01 Thread Anthony Liguori
Hollis Blanchard wrote: On Wed, 2009-04-29 at 11:29 +0300, Avi Kivity wrote: * configure completely ignores --kerneldir and only uses kvm/kernel headers instead. That's intentional. Huh? If --kerneldir does nothing, why does it exist? BTW Avi, if you