The kvmppc_get_last_inst function recently received a facelift that allowed
us to pass an enum of the type of instruction we want to read into it rather
than an unreadable boolean.

Unfortunately, not all callers ended up passing the enum. This wasn't really
an issue as "true" and "false" happen to match the two enum values we have,
but it's still hard to read.

Update all callers of kvmppc_get_last_inst() to follow the new calling
convention.

Signed-off-by: Alexander Graf <ag...@suse.de>
---
 arch/powerpc/kvm/booke.c             | 4 ++--
 arch/powerpc/kvm/emulate.c           | 2 +-
 arch/powerpc/kvm/emulate_loadstore.c | 2 +-
 arch/powerpc/kvm/powerpc.c           | 2 +-
 4 files changed, 5 insertions(+), 5 deletions(-)

diff --git a/arch/powerpc/kvm/booke.c b/arch/powerpc/kvm/booke.c
index ed5b0dd..9b55dec 100644
--- a/arch/powerpc/kvm/booke.c
+++ b/arch/powerpc/kvm/booke.c
@@ -992,12 +992,12 @@ int kvmppc_handle_exit(struct kvm_run *run, struct 
kvm_vcpu *vcpu,
        case BOOKE_INTERRUPT_DATA_STORAGE:
        case BOOKE_INTERRUPT_DTLB_MISS:
        case BOOKE_INTERRUPT_HV_PRIV:
-               emulated = kvmppc_get_last_inst(vcpu, false, &last_inst);
+               emulated = kvmppc_get_last_inst(vcpu, INST_GENERIC, &last_inst);
                break;
        case BOOKE_INTERRUPT_PROGRAM:
                /* SW breakpoints arrive as illegal instructions on HV */
                if (vcpu->guest_debug & KVM_GUESTDBG_USE_SW_BP)
-                       emulated = kvmppc_get_last_inst(vcpu, false, 
&last_inst);
+                       emulated = kvmppc_get_last_inst(vcpu, INST_GENERIC, 
&last_inst);
                break;
        default:
                break;
diff --git a/arch/powerpc/kvm/emulate.c b/arch/powerpc/kvm/emulate.c
index 005222b..5cc2e7a 100644
--- a/arch/powerpc/kvm/emulate.c
+++ b/arch/powerpc/kvm/emulate.c
@@ -219,7 +219,7 @@ int kvmppc_emulate_instruction(struct kvm_run *run, struct 
kvm_vcpu *vcpu)
        /* this default type might be overwritten by subcategories */
        kvmppc_set_exit_type(vcpu, EMULATED_INST_EXITS);
 
-       emulated = kvmppc_get_last_inst(vcpu, false, &inst);
+       emulated = kvmppc_get_last_inst(vcpu, INST_GENERIC, &inst);
        if (emulated != EMULATE_DONE)
                return emulated;
 
diff --git a/arch/powerpc/kvm/emulate_loadstore.c 
b/arch/powerpc/kvm/emulate_loadstore.c
index 0de4ffa..6d3c0ee 100644
--- a/arch/powerpc/kvm/emulate_loadstore.c
+++ b/arch/powerpc/kvm/emulate_loadstore.c
@@ -58,7 +58,7 @@ int kvmppc_emulate_loadstore(struct kvm_vcpu *vcpu)
        /* this default type might be overwritten by subcategories */
        kvmppc_set_exit_type(vcpu, EMULATED_INST_EXITS);
 
-       emulated = kvmppc_get_last_inst(vcpu, false, &inst);
+       emulated = kvmppc_get_last_inst(vcpu, INST_GENERIC, &inst);
        if (emulated != EMULATE_DONE)
                return emulated;
 
diff --git a/arch/powerpc/kvm/powerpc.c b/arch/powerpc/kvm/powerpc.c
index 02a6e2d..441a79c 100644
--- a/arch/powerpc/kvm/powerpc.c
+++ b/arch/powerpc/kvm/powerpc.c
@@ -294,7 +294,7 @@ int kvmppc_emulate_mmio(struct kvm_run *run, struct 
kvm_vcpu *vcpu)
        {
                u32 last_inst;
 
-               kvmppc_get_last_inst(vcpu, false, &last_inst);
+               kvmppc_get_last_inst(vcpu, INST_GENERIC, &last_inst);
                /* XXX Deliver Program interrupt to guest. */
                pr_emerg("%s: emulation failed (%08x)\n", __func__, last_inst);
                r = RESUME_HOST;
-- 
1.8.1.4

--
To unsubscribe from this list: send the line "unsubscribe kvm-ppc" in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html

Reply via email to