Re: [for-2.6 PATCH 0/3] target-i386: Use C struct for xsave area layout, offsets & sizes
On 28/11/2015 20:56, Eduardo Habkost wrote: > I still need to figure out a way to write unit tests for the new > code. Maybe I will just copy and paste the new and old functions, > and test them locally (checking if they give the same results > when translating blobs of random bytes). Aren't the QEMU_BUILD_BUG_ON enough? No need to delete them in patch 3, though perhaps you can remove the #defines. Paolo -- To unsubscribe from this list: send the line "unsubscribe kvm" in the body of a message to majord...@vger.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.html
Re: [for-2.6 PATCH 0/3] target-i386: Use C struct for xsave area layout, offsets & sizes
On Mon, Nov 30, 2015 at 12:21:23PM +0100, Paolo Bonzini wrote: > > > On 28/11/2015 20:56, Eduardo Habkost wrote: > > I still need to figure out a way to write unit tests for the new > > code. Maybe I will just copy and paste the new and old functions, > > and test them locally (checking if they give the same results > > when translating blobs of random bytes). > > Aren't the QEMU_BUILD_BUG_ON enough? No need to delete them in patch 3, > though perhaps you can remove the #defines. Just wanted to be 100% sure. Even if the offets are all correct, I might have made other mistakes when translating the get/save code. About the QEMU_BUILD_BUG_ON lines, we can keep them if you like. We could translate the uint32_t offsets to byte offsets after ptach 3/3, to make them easier to compare to the Intel docs. -- Eduardo -- To unsubscribe from this list: send the line "unsubscribe kvm" in the body of a message to majord...@vger.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.html
[for-2.6 PATCH 0/3] target-i386: Use C struct for xsave area layout, offsets & sizes
target-i386/cpu.c:ext_save_area uses magic numbers for the xsave area offets and sizes, and target-i386/kvm.c:kvm_{put,get}_xsave() uses offset macros and bit manipulation to access the xsave area. This series changes both to use C structs for the same operations. I still need to figure out a way to write unit tests for the new code. Maybe I will just copy and paste the new and old functions, and test them locally (checking if they give the same results when translating blobs of random bytes). Eduardo Habkost (3): target-i386: Define structs for layout of xsave area target-i386: Use xsave structs for ext_save_area target-i386: kvm: Use X86XSaveArea struct for xsave save/load target-i386/cpu.c | 18 +--- target-i386/cpu.h | 85 ++ target-i386/kvm.c | 121 +++--- 3 files changed, 149 insertions(+), 75 deletions(-) -- 2.1.0 -- To unsubscribe from this list: send the line "unsubscribe kvm" in the body of a message to majord...@vger.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.html