Re: [PATCH V6 04/10] arm64: exception: handle Synchronous External Abort

2017-01-06 Thread Baicar, Tyler
Hi Will, On 1/4/2017 6:54 AM, Will Deacon wrote: On Wed, Dec 07, 2016 at 02:48:17PM -0700, Tyler Baicar wrote: SEA exceptions are often caused by an uncorrected hardware error, and are handled when data abort and instruction abort exception classes have specific values for their Fault Status

Re: [PATCH v2 4/5] arm64: Use __tlbi_dsb() macros in KVM code

2017-01-06 Thread Mark Rutland
On Fri, Jan 06, 2017 at 10:51:53AM -0500, Christopher Covington wrote: > On 01/03/2017 10:57 AM, Mark Rutland wrote: > > On Thu, Dec 29, 2016 at 05:43:34PM -0500, Christopher Covington wrote: > >> Refactor the KVM code to use the newly introduced __tlbi_dsb macros, which > >> will allow an errata

Re: [PATCH v2 2/5] arm64: Work around Falkor erratum 1003

2017-01-06 Thread Timur Tabi
Christopher Covington wrote: > Also, since this can't be changed via the menu, why bother putting it in? I put it in in response to review comments asking for the magic number to be clarified by a #define or variable. I could not find a suitably shared header between the files in question, so I

Re: [PATCH v2 4/5] arm64: Use __tlbi_dsb() macros in KVM code

2017-01-06 Thread Christopher Covington
On 01/03/2017 10:57 AM, Mark Rutland wrote: > On Thu, Dec 29, 2016 at 05:43:34PM -0500, Christopher Covington wrote: >> Refactor the KVM code to use the newly introduced __tlbi_dsb macros, which >> will allow an errata workaround that repeats tlbi dsb sequences to only >> change one location. This

Re: [PATCH v2 2/5] arm64: Work around Falkor erratum 1003

2017-01-06 Thread Timur Tabi
Christopher Covington wrote: > Looks like you've made an unrelated whitespace change that affected the entire table, > not just the line you're adding. I'm making space for "QCOM_FALKOR_ERRATUM_1003". Ok, but you're also shrinking the other columns. I think a better solution is to make the

Re: [PATCH v2 2/5] arm64: Work around Falkor erratum 1003

2017-01-06 Thread Christopher Covington
On 01/03/2017 10:55 AM, Mark Rutland wrote: > Hi, > > On Thu, Dec 29, 2016 at 05:43:32PM -0500, Christopher Covington wrote: >> +config QCOM_FALKOR_E1003_RESERVED_ASID >> +int >> +default 1 >> +depends on QCOM_FALKOR_ERRATUM_1003 >> + > > I don't think this needs to be configurable,

Re: [PATCH v2 2/5] arm64: Work around Falkor erratum 1003

2017-01-06 Thread Christopher Covington
On 12/29/2016 06:08 PM, Timur Tabi wrote: > On 12/29/2016 04:43 PM, Christopher Covington wrote: >> +config QCOM_FALKOR_E1003_RESERVED_ASID >> +int >> +default 1 >> +depends on QCOM_FALKOR_ERRATUM_1003 > > Also, since this can't be changed via the menu, why bother putting it in? I

Re: [PATCH v2 2/5] arm64: Work around Falkor erratum 1003

2017-01-06 Thread Christopher Covington
On 12/29/2016 06:02 PM, Timur Tabi wrote: > On 12/29/2016 04:43 PM, Christopher Covington wrote: >> -| Implementor| Component | Erratum ID | Kconfig >>| >> -++-+-+-+ >> -| ARM|

Re: [RFC PATCH 1/7] arm64: Use physical counter for in-kernel reads

2017-01-06 Thread Marc Zyngier
On 06/01/17 10:53, Christoffer Dall wrote: > On Fri, Jan 06, 2017 at 10:38:49AM +, Marc Zyngier wrote: >> On 06/01/17 10:00, Christoffer Dall wrote: >>> Hi Marc, >>> >>> On Thu, Jan 05, 2017 at 06:11:14PM +, Marc Zyngier wrote: [adding the arm64 maintainers, plus Mark as arch timer

Re: [RFC PATCH 1/7] arm64: Use physical counter for in-kernel reads

2017-01-06 Thread Christoffer Dall
On Fri, Jan 06, 2017 at 10:38:49AM +, Marc Zyngier wrote: > On 06/01/17 10:00, Christoffer Dall wrote: > > Hi Marc, > > > > On Thu, Jan 05, 2017 at 06:11:14PM +, Marc Zyngier wrote: > >> [adding the arm64 maintainers, plus Mark as arch timer maintainer] > > > > Right, sorry, I should

Re: [RFC PATCH 4/7] KVM: arm/arm64: Check that system supports split eoi/deactivate

2017-01-06 Thread Christoffer Dall
On Fri, Jan 06, 2017 at 10:24:04AM +, Marc Zyngier wrote: > On 06/01/17 10:02, Christoffer Dall wrote: > > On Thu, Jan 05, 2017 at 05:40:58PM +, Marc Zyngier wrote: > >> On 10/12/16 20:47, Christoffer Dall wrote: > >>> Some systems without proper firmware and/or hardware description data >

Re: [PATCH V6 05/10] acpi: apei: handle SEA notification type for ARMv8

2017-01-06 Thread James Morse
Hi Tyler, On 05/01/17 22:31, Baicar, Tyler wrote: > On 12/20/2016 8:29 AM, James Morse wrote: >> On 07/12/16 21:48, Tyler Baicar wrote: >>> ARM APEI extension proposal added SEA (Synchrounous External >>> Abort) notification type for ARMv8. >>> Add a new GHES error source handling function for

Re: [RFC PATCH 1/7] arm64: Use physical counter for in-kernel reads

2017-01-06 Thread Marc Zyngier
On 06/01/17 10:00, Christoffer Dall wrote: > Hi Marc, > > On Thu, Jan 05, 2017 at 06:11:14PM +, Marc Zyngier wrote: >> [adding the arm64 maintainers, plus Mark as arch timer maintainer] > > Right, sorry, I should have done that already. > >> >> On 10/12/16 20:47, Christoffer Dall wrote: >>>

Re: [RFC PATCH 4/7] KVM: arm/arm64: Check that system supports split eoi/deactivate

2017-01-06 Thread Marc Zyngier
On 06/01/17 10:02, Christoffer Dall wrote: > On Thu, Jan 05, 2017 at 05:40:58PM +, Marc Zyngier wrote: >> On 10/12/16 20:47, Christoffer Dall wrote: >>> Some systems without proper firmware and/or hardware description data >>> don't support the split EOI and deactivate operation and therefore

Re: [RFC PATCH 4/7] KVM: arm/arm64: Check that system supports split eoi/deactivate

2017-01-06 Thread Christoffer Dall
On Thu, Jan 05, 2017 at 05:40:58PM +, Marc Zyngier wrote: > On 10/12/16 20:47, Christoffer Dall wrote: > > Some systems without proper firmware and/or hardware description data > > don't support the split EOI and deactivate operation and therefore > > don't provide an irq_set_vcpu_affinity

Re: [RFC PATCH 0/7] KVM: arm/arm64: Optimize arch timer register handling

2017-01-06 Thread Christoffer Dall
On Sat, Dec 10, 2016 at 09:47:05PM +0100, Christoffer Dall wrote: > We currently spend around ~400 cycles on each entry/exit to the guest > dealing with arch timer registers, even when the timer is not pending > and not doing anything. > > We can do much better by moving the arch timer

Re: [RFC PATCH 1/7] arm64: Use physical counter for in-kernel reads

2017-01-06 Thread Christoffer Dall
Hi Marc, On Thu, Jan 05, 2017 at 06:11:14PM +, Marc Zyngier wrote: > [adding the arm64 maintainers, plus Mark as arch timer maintainer] Right, sorry, I should have done that already. > > On 10/12/16 20:47, Christoffer Dall wrote: > > Using the physical counter allows KVM to retain the