Re: [Lazarus] C Integer types

2012-07-08 Thread Dave Coventry
Thanks very much, everyone, for the hints and advice. The data[] is indeed an array of bytes read from a file. Thanks again, Dave -- ___ Lazarus mailing list Lazarus@lists.lazarus.freepascal.org http://lists.lazarus.freepascal.org/mailman/listinfo/laz

Re: [Lazarus] httpWebServer does not show images for some users

2012-07-08 Thread leledumbo
> RegisterFileLocation, AllowDefaultModule and AllowDefaultModule are not found in the chm help files I'd be surprised if you can find them in the chm since they're undocumented ATM, I'm planning on writing the docs for them. Please wait, since they're part of fcl-web while I'm currently documenti

Re: [Lazarus] Strings Property Editor dialog newline keystroke reminder

2012-07-08 Thread Hans-Peter Diettrich
Howard Page-Clark schrieb: The object inspector's strings editor has its [OK] button set as the default so pressing [Enter] closes the dialog, which is logical. IMO it's not logical to close an dialog for entering *multiple* lines with Enter. At least D5 adds a new line on Enter. I usually

Re: [Lazarus] C Integer types

2012-07-08 Thread Hans-Peter Diettrich
waldo kitty schrieb: How about defining something more pascalish first, a record type for example: i would agree with this since it is more readable ;) {$modeswitch autoderef} type PDataHeader = ^TDataHeader; TDataHeader = record sequence_crc: QWord; sequence_key: QWord;

Re: [Lazarus] C Integer types

2012-07-08 Thread Hans-Peter Diettrich
Bernd K. schrieb: On 08.07.2012 17:18, Hans-Peter Diettrich wrote: Bernd schrieb: 2012/7/7 Marco van de Voort : IMO all these members should be pointers, of size 64 bit according to the index increment (8 bytes?). Typecasts will be needed for 32 bit pointers, as demonstrated in above code.

Re: [Lazarus] C Integer types

2012-07-08 Thread Hans-Peter Diettrich
Bernd Kreuss schrieb: On 08.07.2012 17:18, Hans-Peter Diettrich wrote: IMO all these members should be pointers, of size 64 bit according to the index increment (8 bytes?). You are right, I didn't look carefully enough. Too much ad-hoc pointer arithmetics and dereferencing around too many cor

Re: [Lazarus] Strings Property Editor dialog newline keystroke reminder

2012-07-08 Thread Bart
On 7/9/12, Howard Page-Clark wrote: > The object inspector's strings editor has its [OK] button set as the > default so pressing [Enter] closes the dialog, which is logical. > I usually forget this when trying to enter several lines of text, and so > close the dialog when trying to enter a new li

[Lazarus] Strings Property Editor dialog newline keystroke reminder

2012-07-08 Thread Howard Page-Clark
The object inspector's strings editor has its [OK] button set as the default so pressing [Enter] closes the dialog, which is logical. I usually forget this when trying to enter several lines of text, and so close the dialog when trying to enter a new line in the strings memo. Could the dialog's

Re: [Lazarus] C Integer types

2012-07-08 Thread Bernd K.
On 08.07.2012 21:39, Bernd K. wrote: > *((int64_t*)&data[8]) are bytes 8..17 of that buffer as int64 typo: *((int64_t*)&data[8]) are bytes 8..15 of that buffer as int64 -- ___ Lazarus mailing list Lazarus@lists.lazarus.freepascal.org http://lists.laza

Re: [Lazarus] C Integer types

2012-07-08 Thread Bernd K.
On 08.07.2012 17:18, Hans-Peter Diettrich wrote: > Bernd schrieb: >> 2012/7/7 Marco van de Voort : > IMO all these members should be pointers, of size 64 bit according to > the index increment (8 bytes?). Typecasts will be needed for 32 bit > pointers, as demonstrated in above code. Wait a monme

Re: [Lazarus] C Integer types

2012-07-08 Thread waldo kitty
On 7/8/2012 06:32, Bernd wrote: 2012/7/7 Marco van de Voort: seqence_crc:=pint64(data)^; seqence_key:=pint64(@data[8])^; compr_crc:=pint64(@data[16])^; compr_len:=pint64(@data[24])^; the above doesn't seem correct... i've been watching and waiting for someone to catch it... i

[Lazarus] Propose: dont try to open TDBLookup* ListSource automatically

2012-07-08 Thread Luiz Americo Pereira Camara
Currently the db lookup controls tries to open the dataset linked to ListSource if is closed at lookup initialization. The initialization occurs after the control is loaded (streamed) or when a related db property is changed in the control. This behavior can leads to opening the dataset at unp

Re: [Lazarus] C Integer types

2012-07-08 Thread Bernd Kreuss
On 08.07.2012 17:18, Hans-Peter Diettrich wrote: > IMO all these members should be pointers, of size 64 bit according to > the index increment (8 bytes?). You are right, I didn't look carefully enough. Too much ad-hoc pointer arithmetics and dereferencing around too many corners within the same

Re: [Lazarus] C Integer types

2012-07-08 Thread Hans-Peter Diettrich
Bernd schrieb: 2012/7/7 Marco van de Voort : seqence_crc:=pint64(data)^; seqence_key:=pint64(@data[8])^; compr_crc:=pint64(@data[16])^; compr_len:=pint64(@data[24])^; How about defining something more pascalish first, a record type for example: {$modeswitch autoderef} type PDa

[Lazarus] httpWebServer does not show images for some users

2012-07-08 Thread John Repucci
(Sorry about that - I forgot to change the Subject line.) On Sun, Jul 8, 2012 at 9:01 AM, John Repucci wrote: >> The file serving module is also a module. >> >> It is 'hidden', as there is no visible data module for you to put components >> on, >> but in the background there is a module nonethel

Re: [Lazarus] Lazarus Digest, Vol 54, Issue 11

2012-07-08 Thread John Repucci
> The file serving module is also a module. > > It is 'hidden', as there is no visible data module for you to put components > on, > but in the background there is a module nonetheless. > >> 'img' is suppose to be the location for my image files. (in this >> case, in the same directory as the app

Re: [Lazarus] C Integer types

2012-07-08 Thread Bernd
2012/7/7 Marco van de Voort : >seqence_crc:=pint64(data)^; >seqence_key:=pint64(@data[8])^; >compr_crc:=pint64(@data[16])^; >compr_len:=pint64(@data[24])^; How about defining something more pascalish first, a record type for example: {$modeswitch autoderef} type PDataHeader =

Re: [Lazarus] Package: Adding httpd.pas link error in linux

2012-07-08 Thread Zaher Dirkey
On Sun, Jul 8, 2012 at 6:17 AM, leledumbo wrote: > > I have one httpd, only httpd22 > /usr/lib/fpc/2.6.0/units/i386-linux/httpd22 > and there is httpd.ppu > > What if you remove it from the package? Since httpd is already in compiler' > search path, there should be no need to add it as part of a p