Re: [LEDE-DEV] [PATCH mountd 0/5] mounted: warnings fixes and refactoring

2017-03-05 Thread Florian Fainelli
On 03/05/2017 04:50 PM, Florian Fainelli wrote: > Hi all, > > This patch series fixed "unused results" warnings, and in the process > refactors how properties from block devices are obtained from sysfs. So this was marked "Not applicable" in patchwork, what was the reason for that? Patch 3

Re: [LEDE-DEV] [PATCH] ar71xx: set status led for the gl-* boards

2017-03-05 Thread John Crispin
On 28/02/2017 14:18, Wojciech Jowsa wrote: > This sets status_led for the gl-ar300m and gl-mifi boards, and fixes led > names > so that they follow correct naming scheme. > It also fixes mangled whitespace in the mach-gl-ar300m.c. > > Signed-off-by: Wojciech Jowsa

Re: [LEDE-DEV] [PATCH] ugps: fix and improve init script

2017-03-05 Thread John Crispin
On 05/03/2017 21:09, Piotr Dymacz wrote: > The ugps tool expects device path in last argument. If it's provided > before other options, they won't be processed at all. > > Additionally, make it possible to use absolute path for gps character > device in related uci configuration. > >

[LEDE-DEV] [PATCH mountd 4/5] mountd: Fix unused result in mount.c for symlink()

2017-03-05 Thread Florian Fainelli
Fixes the following warning: mountd-2016-12-19-dd5799c9/mount.c:454:3: note: each undeclared identifier is reported only once for each function it appears in mountd-2016-12-19-dd5799c9/mount.c: In function 'mount_add_list': mountd-2016-12-19-dd5799c9/mount.c:163:10: error: ignoring return value

[LEDE-DEV] [PATCH mountd 1/5] mountd: Fix unused results warnings in autofs.c for chdir()

2017-03-05 Thread Florian Fainelli
Fixes the following warnings: mountd-2016-12-19-dd5799c9/autofs.c: In function 'autofs_loop': mountd-2016-12-19-dd5799c9/autofs.c:227:7: error: ignoring return value of 'chdir', declared with attribute warn_unused_result [-Werror=unused-result] chdir("/"); ^

[LEDE-DEV] [PATCH mountd 2/5] mountd: Fix unused result in main.c for daemon()

2017-03-05 Thread Florian Fainelli
mountd-2016-12-19-dd5799c9/main.c: In function 'main': mountd-2016-12-19-dd5799c9/main.c:18:9: error: ignoring return value of 'daemon', declared with attribute warn_unused_result [-Werror=unused-result] daemon(0,0); Signed-off-by: Florian Fainelli --- main.c | 9

[LEDE-DEV] [PATCH mountd 5/5] mountd: Fix unused result in mount.c for fgets()

2017-03-05 Thread Florian Fainelli
Fixes the following warning: mountd-2016-12-19-dd5799c9/mount.c: In function 'mount_dev_get_property': mountd-2016-12-19-dd5799c9/mount.c:454:3: error: 'model' undeclared (first use in this function) model[strlen(prop_val) - 1] = '\0'; ^ Signed-off-by: Florian Fainelli

[LEDE-DEV] [PATCH mountd 0/5] mounted: warnings fixes and refactoring

2017-03-05 Thread Florian Fainelli
Hi all, This patch series fixed "unused results" warnings, and in the process refactors how properties from block devices are obtained from sysfs. Thanks Florian Fainelli (5): mountd: Fix unused results warnings in autofs.c for chdir() mountd: Fix unused result in main.c for daemon()

[LEDE-DEV] [PATCH mountd 3/5] mountd: Factor code getting block devices attributes

2017-03-05 Thread Florian Fainelli
Factor the code obtaining a bunch of a block devices attributes: vendor, rev, model, size since this is a repetitive and identical procedure for each of these. This also fixes unused fgets() return values for these parts of the code. Signed-off-by: Florian Fainelli ---

Re: [LEDE-DEV] [PATCH netifd v3] system-linux: add VXLAN support

2017-03-05 Thread Hans Dedecker
On Tuesday, 28 February 2017 10:57:05 CET Matthias Schiffer wrote: > VXLAN shares many attributes with the tunnel devices, so it is implemented > as a new tunnel type. The 'remote' attribute can be used for an unicast > peer or a multicast group. > > The IANA-assigned port 4789 is used by

[LEDE-DEV] [PATCH 2/2] brcm2708: detect Raspberry Pi Zero W

2017-03-05 Thread Stijn Tintel
Signed-off-by: Stijn Tintel --- target/linux/brcm2708/base-files/etc/board.d/02_network | 3 +++ target/linux/brcm2708/base-files/etc/diag.sh| 3 ++- target/linux/brcm2708/base-files/lib/brcm2708.sh| 3 +++ 3 files changed, 8 insertions(+), 1 deletion(-)

[LEDE-DEV] [PATCH 1/2] brcm2708: order boards and models alphabetically

2017-03-05 Thread Stijn Tintel
Signed-off-by: Stijn Tintel --- .../linux/brcm2708/base-files/etc/board.d/02_network | 6 +++--- target/linux/brcm2708/base-files/etc/diag.sh | 8 target/linux/brcm2708/base-files/lib/brcm2708.sh | 20 ++--

[LEDE-DEV] [PATCH] ugps: fix and improve init script

2017-03-05 Thread Piotr Dymacz
The ugps tool expects device path in last argument. If it's provided before other options, they won't be processed at all. Additionally, make it possible to use absolute path for gps character device in related uci configuration. Signed-off-by: Piotr Dymacz ---

Re: [LEDE-DEV] Need fix / advice / idea

2017-03-05 Thread Alberto Bursi
On 03/05/2017 04:25 PM, Denis Periša wrote: > Hi all, > > I have situation where one of my devices (rb435g) has lot of bad > sectors on (NAND) kernel partition. > > First of all, are those partitions physical? Can they be somehow > re-partitioned by kernel cmd line or? I'm left with only under

[LEDE-DEV] [PATCH v3 2/2] Move enablemodem from ramips to new package adb-enablemodem and make it used also by TL-MR6400

2017-03-05 Thread Filip Moc
Signed-off-by: Filip Moc --- Notes: This moves enablemodem from ramips to new package adb-enablemodem. New adb-enablemodem uses modem's id rather than main board's name so it could possibly work even on different boards without need to change anything. Fixes:

[LEDE-DEV] [PATCH v3 1/2] ar71xx: Add support for TP-Link MR6400

2017-03-05 Thread Filip Moc
You can flash via u-boot tftp (serve factory image as /mr6400_tp_recovery.bin on 192.168.0.66/24, connect to any ethernet port and power on device while holding the reset button). Signed-off-by: Filip Moc --- Notes: v1->v2: - Fixed DEVICE_TITLE - Defined flash type

Re: [LEDE-DEV] bug / brcm47xx / mips74l / Netgear WNDR3400 V1

2017-03-05 Thread Rafał Miłecki
On 5 March 2017 at 17:54, Ondřej Pumr wrote: > I have Netgear WNDR3400 V1 running the latest stable version of OpenWrt > 15.05.1 and everything is ok. > > Once I install the latest stable version of LEDE 17.01.0, the item "Wifi" in > "Network" menu is gone and I am unable

[LEDE-DEV] bug / brcm47xx / mips74l / Netgear WNDR3400 V1

2017-03-05 Thread Ondřej Pumr
Hello, I have Netgear WNDR3400 V1 running the latest stable version of OpenWrt 15.05.1 and everything is ok. Once I install the latest stable version of LEDE 17.01.0, the item "Wifi" in "Network" menu is gone and I am unable to configure wireless interfaces via web interface. I have found

[LEDE-DEV] Need fix / advice / idea

2017-03-05 Thread Denis Periša
Hi all, I have situation where one of my devices (rb435g) has lot of bad sectors on (NAND) kernel partition. First of all, are those partitions physical? Can they be somehow re-partitioned by kernel cmd line or? I'm left with only under 1mb of usable space so I need to make kernel that fits that

Re: [LEDE-DEV] [PATCH] Lantiq Amazon-SE SoC / ADSL Modem Allnet All0333CJ Rev.C

2017-03-05 Thread Tino Reichardt
* Bastian Bittorf wrote: > * Tino Reichardt [24.02.2017 16:26]: > > Telnet on Port 23 is also there. I will check, if it can be upgraded via > > telnet or webinterface. > > user: root > pass: admin I found a way of flashing the device with telnet / tftp only.

Re: [LEDE-DEV] [PATCH 00/12] alternatives support

2017-03-05 Thread Matthias Schiffer
On 03/05/2017 10:31 AM, Yousong Zhou wrote: > This patch set tries to make it possible that files serving the same purpose > and installed to different locations can be available under the same name > through a symbolic link > > The idea is from alternatives of debian system [1,2]. "ip" command

[LEDE-DEV] [PATCH 12/12] iproute2: add ip-tiny, ip-full as alternatives of /sbin/ip

2017-03-05 Thread Yousong Zhou
They will not be in conflict anymore ;) Signed-off-by: Yousong Zhou --- package/network/utils/iproute2/Makefile | 28 +--- 1 file changed, 17 insertions(+), 11 deletions(-) diff --git a/package/network/utils/iproute2/Makefile

[LEDE-DEV] [PATCH 10/12] base-files: add update-alternatives call to default_{postinst, prerm}

2017-03-05 Thread Yousong Zhou
Signed-off-by: Yousong Zhou --- package/base-files/Makefile | 2 +- package/base-files/files/lib/functions.sh | 18 ++ 2 files changed, 19 insertions(+), 1 deletion(-) diff --git a/package/base-files/Makefile b/package/base-files/Makefile

[LEDE-DEV] [PATCH 09/12] base-files: enable presence of uci when IPKG_INSTROOT is set

2017-03-05 Thread Yousong Zhou
Signed-off-by: Yousong Zhou --- package/base-files/files/lib/functions.sh | 3 +-- 1 file changed, 1 insertion(+), 2 deletions(-) diff --git a/package/base-files/files/lib/functions.sh b/package/base-files/files/lib/functions.sh index b68db6b..de3fa96 100755 ---

[LEDE-DEV] [PATCH 08/12] base-files: link /var to tmp instead of /tmp

2017-03-05 Thread Yousong Zhou
To de-couple with host /tmp Signed-off-by: Yousong Zhou --- package/base-files/Makefile | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/package/base-files/Makefile b/package/base-files/Makefile index 78c3dc9..99a10ff 100644 ---

[LEDE-DEV] [PATCH 06/12] build: opkg: enable presence of uci

2017-03-05 Thread Yousong Zhou
Signed-off-by: Yousong Zhou --- include/rootfs.mk | 18 +++--- package/Makefile | 1 + 2 files changed, 16 insertions(+), 3 deletions(-) diff --git a/include/rootfs.mk b/include/rootfs.mk index bd9af6a..46ccce4 100644 --- a/include/rootfs.mk +++

[LEDE-DEV] [PATCH 07/12] build: ipkg: new field Alternatives

2017-03-05 Thread Yousong Zhou
It's a list of specs of the following form seprated by commas to describe alternatives provided by this package :: will be a symbolic link to of the highest Signed-off-by: Yousong Zhou --- include/package-ipkg.mk | 1 + 1 file changed, 1 insertion(+) diff --git

[LEDE-DEV] [PATCH 05/12] build: cleanup tmp/ dir of target rootfs

2017-03-05 Thread Yousong Zhou
Signed-off-by: Yousong Zhou --- include/rootfs.mk | 1 + package/Makefile | 2 +- 2 files changed, 2 insertions(+), 1 deletion(-) diff --git a/include/rootfs.mk b/include/rootfs.mk index dc400a0..bd9af6a 100644 --- a/include/rootfs.mk +++ b/include/rootfs.mk @@ -80,6

[LEDE-DEV] [PATCH 03/12] uci: add host build

2017-03-05 Thread Yousong Zhou
Signed-off-by: Yousong Zhou --- package/system/uci/Makefile| 15 ++- package/system/uci/files/lib/config/uci.sh | 31 -- 2 files changed, 31 insertions(+), 15 deletions(-) diff --git a/package/system/uci/Makefile

[LEDE-DEV] [PATCH 04/12] build: prepare_rootfs: preserve prerm script

2017-03-05 Thread Yousong Zhou
They will still be needed at the time when pre-installed packages are to be removed on target device Signed-off-by: Yousong Zhou --- include/rootfs.mk | 1 - 1 file changed, 1 deletion(-) diff --git a/include/rootfs.mk b/include/rootfs.mk index c014b1d..dc400a0 100644

[LEDE-DEV] [PATCH 02/12] uci: patch for static host build

2017-03-05 Thread Yousong Zhou
Signed-off-by: Yousong Zhou --- .../uci/patches/0001-build-fix-BUILD_STATIC.patch | 63 ++ ...-redundant-NULL-check-on-return-value-of-.patch | 29 ++ ...w-setting-confdir-and-savedir-with-enviro.patch | 58 3 files

[LEDE-DEV] [PATCH 00/12] alternatives support

2017-03-05 Thread Yousong Zhou
This patch set tries to make it possible that files serving the same purpose and installed to different locations can be available under the same name through a symbolic link The idea is from alternatives of debian system [1,2]. "ip" command is a good example of the problem it tries to solve

[LEDE-DEV] [PATCH 01/12] opkg: add update-alternatives support

2017-03-05 Thread Yousong Zhou
Signed-off-by: Yousong Zhou --- package/system/opkg/Makefile | 5 +- package/system/opkg/files/update-alternatives | 163 ++ 2 files changed, 167 insertions(+), 1 deletion(-) create mode 100755

Re: [LEDE-DEV] [PATCH] ramips: Add patch to reset SPI flash to 3-byte addressing

2017-03-05 Thread Daniel Golle
Hi, we've previously discussed [1] the patch on the mailing list and I believe that rather switching to 4-byte addressing mode we should rather use 4-byte opcodes instead because that would prevent the whole problem and provide a more reliable way to support large flash chips. This is also how

Re: [LEDE-DEV] Luci/Statistics problem

2017-03-05 Thread e9hack
Hi, the issue depends on the rights of luci_statistics. If read for group and others is not set, Luci/Statistics does fail. If read is set for group and others, it works as expected. I did check my old configuration backups, read for others and group was never set in the past. Regards, Hartmut

[LEDE-DEV] [PATCH] openvpn: move list of params and bools to a separate file

2017-03-05 Thread Yousong Zhou
So that future patches for addition/removal of them can be more readable Signed-off-by: Yousong Zhou --- package/network/services/openvpn/Makefile | 6 +- .../network/services/openvpn/files/openvpn.init| 32 +---

[LEDE-DEV] [PATCH] malta: restore "be" subtarget from being source-only

2017-03-05 Thread Yousong Zhou
The malta "be" and "le" subtargets share the arch with many devices of ar71xx and ramips. They can be handy for testing, debugging, trying both snapshot and release builds. This commit makes the "be" subtarget part of the ci and release builds Signed-off-by: Yousong Zhou