[LEDE-DEV] [PATCH 7/7] ag71xx: support for descriptors in SRAM

2017-12-07 Thread Rosen Penev
A good performance improvement. As I have not tested this, I'm keeping the Qualcomm default to no. Original commit below: From: Ben Menchaca Date: Fri, 7 Jun 2013 15:25:00 -0500 Subject: [ag71xx] support for descriptors in SRAM Adds support to the ag71xx to use

[LEDE-DEV] [PATCH 3/7] ag71xx: optimized iomapped register access

2017-12-07 Thread Rosen Penev
Seems to remove a few instructions. Original message below: From: Ben Menchaca Date: Tue, 11 Jun 2013 15:50:17 -0500 Subject: [ag71xx] optimize iomapped register access Add register accessors that remove the per-register range check that was done previously.

[LEDE-DEV] [PATCH 6/7] ag71xx: Put ring_size in ag71xx_ring struct.

2017-12-07 Thread Rosen Penev
Less verbose code. Should help when porting some of the other patches. Signed-off-by: Rosen Penev --- .../drivers/net/ethernet/atheros/ag71xx/ag71xx.h | 1 + .../net/ethernet/atheros/ag71xx/ag71xx_main.c | 40 +- 2 files changed, 17 insertions(+),

[LEDE-DEV] [PATCH 4/7] ag71xx: Remove unnecessary goto statement.

2017-12-07 Thread Rosen Penev
Tightens up the ag71xx_ring_alloc function and makes it easier to read. Signed-off-by: Rosen Penev --- .../drivers/net/ethernet/atheros/ag71xx/ag71xx_main.c | 17 - 1 file changed, 4 insertions(+), 13 deletions(-) diff --git

[LEDE-DEV] [PATCH 2/7] ag71xx: add method to count ag71xx probes

2017-12-07 Thread Rosen Penev
This patch is preparation for ag71xx usage of external, on-die resources. Since these resources are limited, we need to track how many instances we have probed. Signed-off-by: Ben Menchaca Signed-off-by: Rosen Penev

[LEDE-DEV] [PATCH 5/7] ag71xx: Replace AG71XX_DESC_SIZE macro with a struct member.

2017-12-07 Thread Rosen Penev
Moves the code more in line with QCA code. Also reduces variable to a u16 instead of s32. QCA code has the roundup component behind a Makefile config. Not sure if enabled by default so I opted to keep current behavior. Signed-off-by: Rosen Penev ---

[LEDE-DEV] [PATCH 1/7] ag71xx: Reorder some more structs based on warmth.

2017-12-07 Thread Rosen Penev
Should help slightly. Signed-off-by: Rosen Penev --- .../ar71xx/files/drivers/net/ethernet/atheros/ag71xx/ag71xx.h | 10 +++--- 1 file changed, 7 insertions(+), 3 deletions(-) diff --git a/target/linux/ar71xx/files/drivers/net/ethernet/atheros/ag71xx/ag71xx.h

Re: [LEDE-DEV] [PATCH 2/2] download.mk: introduce a new variable SKIPHASH

2017-12-07 Thread Ted Hess
Ack from me for PKG_HASH=none. Much easier to use. /ted -Original Message- From: Jo-Philipp Wich Sent: Thursday, December 07, 2017 9:56 AM To: lede-dev@lists.infradead.org Subject: Re: [LEDE-DEV] [PATCH 2/2] download.mk: introduce a new variable SKIPHASH Hi Baptiste, we've been

Re: [LEDE-DEV] [PATCH 2/2] download.mk: introduce a new variable SKIPHASH

2017-12-07 Thread Stijn Tintel
On 07-12-17 15:56, Jo-Philipp Wich wrote: > Hi Baptiste, > > we've been discussing this patch again on IRC today and I came up with > an alternate suggestion that does not require a new variable. > > -- 8< -- > diff --git a/scripts/download.pl b/scripts/download.pl > index 775408934a..ad9c480c67

Re: [LEDE-DEV] [PATCH 2/2] download.mk: introduce a new variable SKIPHASH

2017-12-07 Thread Jo-Philipp Wich
Hi Baptiste, we've been discussing this patch again on IRC today and I came up with an alternate suggestion that does not require a new variable. -- 8< -- diff --git a/scripts/download.pl b/scripts/download.pl index 775408934a..ad9c480c67 100755 --- a/scripts/download.pl +++

[LEDE-DEV] [FINAL CALL] Merging the 'OpenWrt merge' patches

2017-12-07 Thread Felix Fietkau
Hi, Are there any remaining concerns about those 'OpenWrt merge' patches that have been sitting in my staging tree for a while now? If not, I plan on pushing them to master this weekend. - Felix ___ Lede-dev mailing list Lede-dev@lists.infradead.org

Re: [LEDE-DEV] [PATCH resend 3/3] hostapd: bump PKG_RELEASE

2017-12-07 Thread Timo Sigurdsson
Hi Stijn, Stijn Tintel schrieb am 07.12.2017 12:05: > On 07-12-17 12:04, Timo Sigurdsson wrote: >> Hi, >> >> Stijn Tintel schrieb am 07.12.2017 01:35: >> >>> On 14-11-17 21:41, Timo Sigurdsson wrote: Increase PKG_RELEASE after latest changes to hostapd, so downstream users can fetch

Re: [LEDE-DEV] [PATCH resend 3/3] hostapd: bump PKG_RELEASE

2017-12-07 Thread Stijn Tintel
On 07-12-17 12:04, Timo Sigurdsson wrote: > Hi, > > Stijn Tintel schrieb am 07.12.2017 01:35: > >> On 14-11-17 21:41, Timo Sigurdsson wrote: >>> Increase PKG_RELEASE after latest changes to hostapd, so downstream >>> users can fetch updates via opkg. >>> >> You should have bumped PKG_RELEASE in

Re: [LEDE-DEV] [PATCH resend 3/3] hostapd: bump PKG_RELEASE

2017-12-07 Thread Timo Sigurdsson
Hi, Stijn Tintel schrieb am 07.12.2017 01:35: > On 14-11-17 21:41, Timo Sigurdsson wrote: >> Increase PKG_RELEASE after latest changes to hostapd, so downstream >> users can fetch updates via opkg. >> > You should have bumped PKG_RELEASE in the previous commit. I've done > that in my staging