FYI: [PATCH] ltmain.sh: append relative path trailing slashes explicitly.

2011-11-14 Thread Gary V. Vaughan
A small refactoring necessary to enable upcoming changesets. Applied as obvious. In addition to being more idiomatic, and hence minimising suprises, seeing the slash written explicity when appending to the result of a relative path calculation is a lot more readable. *

FYI: [PATCH] general.m4sh: relative path to the same directory is `.'.

2011-11-14 Thread Gary V. Vaughan
Another small refactoring to enable upcoming changesets. Applied as obvious. * general.m4sh (func_relative_path): We sometimes want to use the result of this function directly, rather than purely as a prefix, so we need to return `.' when both directories end up at the same location.

FYI: [PATCH] libtoolize: update a bit-rotted comment.

2011-11-14 Thread Gary V. Vaughan
Applied as obvious. * libtoolize (func_copy_cb): Since this comment was written, the function has been changed to timestamp files as it copies. Update the comment to reflect that. Signed-off-by: Gary V. Vaughan g...@gnu.org --- libtoolize.m4sh |7 --- 1 files changed, 4 insertions(+), 3

FYI: [PATCH] libtoolize: refactor $opt_quiet, func_echo and func_echo_once.

2011-11-14 Thread Gary V. Vaughan
This refactoring makes libtoolize more consistent in its handling of --silent, and reduces the size of an upcoming changeset. Applied as obvious. Instead of long sequences checking for setting of $opt_quiet, followed by one or more func_echo variations, add and use a new function func_whisper -

[PATCH 1/4] libtoolize: simplify file-copying and -linking call-graph.

2011-11-14 Thread Gary V. Vaughan
This series of changesets are either necessary for, or at least make the application of the directory move patches coming in the next set as straight forward as possible. It turns out that we haven't needed to fork a tar process for every file-copy for about 4 years now. With that knowledge it's

[PATCH 2/4] libtoolize: simplify copying of files that are edited during install.

2011-11-14 Thread Gary V. Vaughan
In order to accomodate macro_dir and aux_dir being anywhere the user chooses, we'll need to rewrite Makefile.am and configure.ac if those destinations are different to what we put in those files when they were installed to $pkgltdldir. This changeset formalizes the process of editing files with a

[PATCH 3/4] libtoolize: rename require_makefile_am to require_Makefile_am.

2011-11-14 Thread Gary V. Vaughan
I would have applied this as obvious, but I don't want to risk breaking something subtly by re-ordering patches again. A simple refactoring to keep the next change self-contained. * libtoolize.m4sh (require_makefile_am): Renamed from this... (require_Makefile_am): ...to this. Signed-off-by: Gary

[PATCH 4/4] libtoolize: refactor ACLOCAL_AMFLAGS extraction.

2011-11-14 Thread Gary V. Vaughan
Another simple refactor to simplify following changesets. * libtoolize.m4sh (require_Makefile_am, require_aclocal_amflags) (require_am_macro_dir): Generate these functions at runtime. Signed-off-by: Gary V. Vaughan g...@gnu.org --- libtoolize.m4sh | 172

[PATCH 1/6] libtoolize: rename `Makefile.inc' to standard `ltdl.mk'.

2011-11-14 Thread Gary V. Vaughan
This is a rewrite of the rename series I revoked a week or two ago, but with the added feature of fully supporting packages that wish to continue with their legacy libltdl layout. For this first patch only, there's some cruft necessary to probe the parent Makefile.am for `include

[PATCH 3/6] libtoolize: generate require_ltdl_relative_aux_dir definition.

2011-11-14 Thread Gary V. Vaughan
* libtoolize.m4sh (require_ltdl_relative_macro_dir): Change to be generated function... (require_ltdl_relative_aux_dir): ...so that we can easily generate this very similar function from the same code. Signed-off-by: Gary V. Vaughan g...@gnu.org --- libtoolize.m4sh | 61

[PATCH 2/6] libtoolize: rename `libltdl/m4' directory to standard `m4'.

2011-11-14 Thread Gary V. Vaughan
Sorry I wasn't able to break this up into smaller pieces without leaving the tree with failing tests between. In addition to moving the autoconf macro directory into the place expected by GNU developers ($top_srcdir/m4), we also simplify libtoolize somewhat by having libltdl use whatever

[PATCH 5/6] libtoolize: aux scripts go in ltdl dir when parent has no configure.

2011-11-14 Thread Gary V. Vaughan
When using libtoolize to install subproject libltdl into a parent project that does not use autotools, set the default directory for auxiliary scripts inside libltdl rather than littering the parent project with files it doesn't use. * libtoolize.m4sh (func_require_ac_aux_dir): In verbose mode,

[PATCH 4/6] libtoolize: simplify runtime by substituting pkgauxdir.

2011-11-14 Thread Gary V. Vaughan
* Makefile.am (configure_edit): Substitute pkgauxdir. * libtoolize.m4sh (func_install_pkgaux_subproject) (func_install_pkgaux_parent, extract_trace): Use it. Signed-off-by: Gary V. Vaughan g...@gnu.org --- Makefile.am |1 + libtoolize.m4sh | 21 + 2 files changed,

[PATCH 6/6] libtoolize: rename `libltdl/config' directory to standard `build-aux'.

2011-11-14 Thread Gary V. Vaughan
In addition to moving the autoconf auxiliary script directory into the place expected by GNU developers ($top_srcdir/build-aux) we also simplify libtoolize somewhat by having libltdl use whatever directory was specified by the parent project. This is much more flexible, allows libltdl client

Re: FYI: [PATCH] ltmain.sh: append relative path trailing slashes explicitly.

2011-11-14 Thread Peter Rosin
Gary V. Vaughan skrev 2011-11-14 11:44: A small refactoring necessary to enable upcoming changesets. Applied as obvious. In addition to being more idiomatic, and hence minimising minimizing, I think US English is preferred. suprises, seeing the slash written explicity when appending to

FYI: [PATCH] bootstrap: remove consumed options from the list to be processed.

2011-11-14 Thread Gary V. Vaughan
Pushed as obvious. Fix a bug where processed bootstrap options were not removed from the queue, and eventually flagged as unknown in the pluggable option parser driver. * bootstrap (bootstrap_parse_options) (bootstrap_validate_options): Follow the pluggable option parser API correctly, and set