[libvirt] [PATCH] esx: Fix dynamic deep copy

2012-08-05 Thread Matthias Bolte
The static deep copy allocates storage for the copy. The dynamic version injected the dynamic dispatch after the allocation. This triggered the invalid argument check in the dynamically dispatched deep copy call. The deep copy function expects its dest parameter to be a pointer to a NULL-pointer.

[libvirt] [PATCH] esx: Remove redundant checks for esxVI_LookupHostSystemProperties result

2012-08-05 Thread Matthias Bolte
esxVI_LookupHostSystemProperties guarantees that hostSystem is non-NULL. Remove redundant NULL checks from callers. Also prefer esxVI_GetStringValue over open-coding the logic. --- src/esx/esx_driver.c | 82 +--- src/esx/esx_vi.c |4 +-

Re: [libvirt] [PATCH 1/9] util: make return value of virUUIDFormat and virMacAddrFormat useful

2012-08-05 Thread Doug Goldstein
On Aug 5, 2012, at 12:16 AM, Laine Stump la...@laine.org wrote: Both of these functions returned void, but it's convenient for them to return a const char* of the char* that is passed in. This was you can call the function and use the result in the same expression/arg. --- src/util/uuid.c

Re: [libvirt] [PATCH] esx: Remove redundant checks for esxVI_LookupHostSystemProperties result

2012-08-05 Thread Ata Bohra
Date: Sun, 5 Aug 2012 13:48:01 +0200 From: matthias.bo...@googlemail.com To: libvir-list@redhat.com Subject: [libvirt] [PATCH] esx: Remove redundant checks for esxVI_LookupHostSystemProperties result esxVI_LookupHostSystemProperties guarantees that hostSystem is non-NULL. Remove

[libvirt] [PATCH] esx: Implement interface driver

2012-08-05 Thread Matthias Bolte
Lists available PhysicalNic devices. A PhysicalNic is always active and can neither be defined nor undefined. A PhysicalNic is used to bridge a HostVirtualSwitch to the physical network. --- This implementation differs from Ata's. It just lists PhysicalNics instead of listing HostVirtualNics as

[libvirt] [PATCH] esx: Implement network driver

2012-08-05 Thread Matthias Bolte
An ESX server has one or more PhysicalNics that represent the actual hardware NICs. Those can be listed via the interface driver. A libvirt virtual network is mapped to a HostVirtualSwitch. On the physical side a HostVirtualSwitch can be connected to PhysicalNics. On the virtual side a

Re: [libvirt] [PATCH v5] ESX: Add routines to interface driver

2012-08-05 Thread Matthias Bolte
2012/8/2 Ata E Husain Bohra ata.hus...@hotmail.com: Add following routines to esx_interface_driver: esxNumOfInterfaces, esxNumOfDefinedInterfaces, esxListInterfaces, esxListDefinedInterfaces, esxInterfaceLookupByMACString, esxInterfaceGetXMLDesc,

Re: [libvirt] [PATCH v5] ESX: Add routines to interface driver

2012-08-05 Thread Matthias Bolte
2012/8/5 Matthias Bolte matthias.bo...@googlemail.com: 2012/8/2 Ata E Husain Bohra ata.hus...@hotmail.com: Add following routines to esx_interface_driver: esxNumOfInterfaces, esxNumOfDefinedInterfaces, esxListInterfaces, esxListDefinedInterfaces,

Re: [libvirt] Proposal to add iSCSI support to esx storage driver

2012-08-05 Thread Matthias Bolte
2012/8/2 Ata Bohra ata.hus...@hotmail.com: Hi All, I just want to go over the design that I am working on to incorporate iSCSI support to libvirt ESX storage driver. The highlights are: Current Implementation At present esx_storage_driver supports only VMFS type datastore and does not

Re: [libvirt] Proposal to add iSCSI support to esx storage driver

2012-08-05 Thread Ata Bohra
Date: Sun, 5 Aug 2012 23:04:07 +0200 Subject: Re: [libvirt] Proposal to add iSCSI support to esx storage driver From: matthias.bo...@googlemail.com To: ata.hus...@hotmail.com CC: libvir-list@redhat.com 2012/8/2 Ata Bohra ata.hus...@hotmail.com: Hi All, I just want to go over the

Re: [libvirt] [PATCH] qemu_agent: support qemu agent general command

2012-08-05 Thread MATSUDA, Daiki
ACK or do I need to re-write ? Regards MATSUDA Daiki On 07/13/2012 08:02 AM, Michal Privoznik wrote: On 13.07.2012 15:41, Eric Blake wrote: On 07/13/2012 06:25 AM, Michal Privoznik wrote: On 09.07.2012 12:54, Michal Privoznik wrote: [I am pasting your patch here again so I can point out

Re: [libvirt] [PATCH 2/9] util: add openvswitch case to virNetDevVPortProfileEqual

2012-08-05 Thread Doug Goldstein
On Sun, Aug 5, 2012 at 12:16 AM, Laine Stump la...@laine.org wrote: This function was overlooked when openvswitch support was added. Fortunately it's only use for update-device, which is relatively new and seldom-used. --- src/util/virnetdevvportprofile.c | 6 ++ 1 file changed, 6

Re: [libvirt] [test-API][PATCH] Fix xml parser problem when node have both attribute and value

2012-08-05 Thread Guannan Ren
On 08/02/2012 06:25 PM, Wayne Sun wrote: When xml node have both attribute and value at first level, the parser will broke. After fix, the node key will have a dictionary with both value and attr inside. For example, the xml node: capacity unit='bytes'536870912000/capacity will be

Re: [libvirt] [PATCH 12/48] virsh: Use vshPrint instead of printf

2012-08-05 Thread Osier Yang
On 2012年08月04日 00:06, Daniel P. Berrange wrote: On Fri, Aug 03, 2012 at 11:48:15PM +0800, Osier Yang wrote: --- tools/virsh-host.c |2 +- 1 files changed, 1 insertions(+), 1 deletions(-) diff --git a/tools/virsh-host.c b/tools/virsh-host.c index 98d9e62..d9d09b4 100644 ---

Re: [libvirt] [PATCH 1/9] util: make return value of virUUIDFormat and virMacAddrFormat useful

2012-08-05 Thread Laine Stump
On 08/05/2012 12:24 PM, Doug Goldstein wrote: On Aug 5, 2012, at 12:16 AM, Laine Stump la...@laine.org wrote: Both of these functions returned void, but it's convenient for them to return a const char* of the char* that is passed in. This was you can call the function and use the result in