[libvirt] [PATCH 5/6] zfs: Only raw volumes are supported

2016-03-14 Thread Richard Laager
--- src/storage/storage_backend_zfs.c | 6 ++ 1 file changed, 6 insertions(+) diff --git a/src/storage/storage_backend_zfs.c b/src/storage/storage_backend_zfs.c index 4129aae..077543d 100644 --- a/src/storage/storage_backend_zfs.c +++ b/src/storage/storage_backend_zfs.c @@ -301,6 +301,12 @@

[libvirt] [PATCH 2/6] sheepdog: Use a consistent error message

2016-03-14 Thread Richard Laager
This also reduces the number of strings to translate. --- src/storage/storage_backend_sheepdog.c | 5 +++-- 1 file changed, 3 insertions(+), 2 deletions(-) diff --git a/src/storage/storage_backend_sheepdog.c b/src/storage/storage_backend_sheepdog.c index a3bd78a..001d16f 100644 --- a/src/storage

[libvirt] [PATCH 4/6] logical: Only raw volumes are supported

2016-03-14 Thread Richard Laager
--- src/storage/storage_backend_logical.c | 6 ++ 1 file changed, 6 insertions(+) diff --git a/src/storage/storage_backend_logical.c b/src/storage/storage_backend_logical.c index 90a194e..39e8b80 100644 --- a/src/storage/storage_backend_logical.c +++ b/src/storage/storage_backend_logical.c @

[libvirt] [PATCH 6/6] zfs: Only unencrypted volumes are supported

2016-03-14 Thread Richard Laager
--- src/storage/storage_backend_zfs.c | 7 +++ 1 file changed, 7 insertions(+) diff --git a/src/storage/storage_backend_zfs.c b/src/storage/storage_backend_zfs.c index 077543d..5238ecc 100644 --- a/src/storage/storage_backend_zfs.c +++ b/src/storage/storage_backend_zfs.c @@ -307,6 +307,13 @@

[libvirt] [PATCH 3/6] storage: Improve code consistency between backends

2016-03-14 Thread Richard Laager
This improves the code consistency around freeing vol->target.path in createVol implementations. --- src/storage/storage_backend_logical.c | 2 -- src/storage/storage_backend_zfs.c | 6 +- 2 files changed, 1 insertion(+), 7 deletions(-) diff --git a/src/storage/storage_backend_logical.c

[libvirt] [PATCH 1/6] rbd: Use proper error type

2016-03-14 Thread Richard Laager
--- src/storage/storage_backend_rbd.c | 4 ++-- 1 file changed, 2 insertions(+), 2 deletions(-) diff --git a/src/storage/storage_backend_rbd.c b/src/storage/storage_backend_rbd.c index 7d04b39..3e70a42 100644 --- a/src/storage/storage_backend_rbd.c +++ b/src/storage/storage_backend_rbd.c @@ -671

Re: [libvirt] [PATCH] ZFS: Support sparse volumes

2016-03-14 Thread Richard Laager
On 03/05/2016 08:35 AM, Roman Bogorodskiy wrote: What if allocation specified will be much larger than capacity? Neither zfs nor virStorageBackendZFSCreateVol() prevent from creating a volume with: --capacity 2G --allocation 4G Is this necessary to support? I don't see a use case where thi

Re: [libvirt] [PATCH 15/24] hostdev: Remove virHostdevGetActivePCIHostDeviceList()

2016-03-14 Thread John Ferlan
On 03/14/2016 11:42 AM, Andrea Bolognani wrote: > On Fri, 2016-03-11 at 14:01 -0500, John Ferlan wrote: >> Please read my logic in patch 20 before doing anything - I'm in the >> middle of it... scroll down for my short thoughts [1]... > > Your comments to patch 20 are extremely detailed, so it w

[libvirt] [PATCH 0/2] small test additions

2016-03-14 Thread Jim Fehlig
Inspired by Jan's comment from another review https://www.redhat.com/archives/libvir-list/2016-March/msg00570.html Jim Fehlig (2): tests: add xlconfigdata to domainschematests tests: add schema test for default cache mode tests/domainschemadata/default-cache-mode.xml | 26 ++

[libvirt] [PATCH 2/2] tests: add schema test for default cache mode

2016-03-14 Thread Jim Fehlig
None of the existing domXML configs under tests/* specify a default cache mode since default generally means "use the hypervisor default" and is left unset by the various hypervisor drivers. Add a config to tests/domainschemadata that specifies cache='default'. Signed-off-by: Jim Fehlig --- test

[libvirt] [PATCH 1/2] tests: add xlconfigdata to domainschematests

2016-03-14 Thread Jim Fehlig
Include the XML files under tests/xlconfigdata in the domain schema tests Signed-off-by: Jim Fehlig --- tests/domainschematest | 1 + 1 file changed, 1 insertion(+) diff --git a/tests/domainschematest b/tests/domainschematest index 68f7882..3271a28 100755 --- a/tests/domainschematest +++ b/test

[libvirt] [RFC PATCH] hostdev: add support for "managed='detach'"

2016-03-14 Thread Laine Stump
Suggested by Alex Williamson. If you plan to assign a GPU to a virtual machine, but that GPU happens to be the host system console, you likely want it to start out using the host driver (so that boot messages/etc will be displayed), then later have the host driver replaced with vfio-pci for assign

Re: [libvirt] [PATCH 2/8] domain: conf: Export virDomainDefPostParseDevices

2016-03-14 Thread John Ferlan
$SUBJ: "domain: Introduce virDomainDefPostParseDevices" On 03/08/2016 11:36 AM, Cole Robinson wrote: > We will use this in upcoming patches Export the virDomainDefPostParseDevices rather than having it only be callable during virDomainDefPostParse. Future patches will be able to make use of the

Re: [libvirt] [PATCH 3/8] qemu: Assign device addresses in PostParse

2016-03-14 Thread John Ferlan
On 03/08/2016 11:36 AM, Cole Robinson wrote: > In order to make this work, we need to short circuit the normal > virDomainDefPostParse ordering, and manually add stock devices > ourselves, since we need them in the XML before assigning addresses. > > The motivation for this is that upcoming patc

Re: [libvirt] [PATCH 1/8] domain: Add virDomainDefAddImplicitDevices

2016-03-14 Thread John Ferlan
On 03/08/2016 11:36 AM, Cole Robinson wrote: > It's just a combination of AddImplicitControllers, and AddConsoleCompat. > Every caller that wants ImplicitControllers also wants the ConsoleCompat > AFAICT, so lump them together. We also need it for future patches. > --- > src/conf/domain_conf.c

Re: [libvirt] [PATCH 20/24] hostdev: Save netdev configuration of actual device

2016-03-14 Thread Andrea Bolognani
Word of warning, since this is very likely to get extremely verbose: I fully expect to slip, here and there, and refer not to the *current* situation as of this patch, but to the *desired* situation at the end of the series. Such *desired* situation is (not explicitly enough?) laid out in patch 19

[libvirt] current master failed to compile

2016-03-14 Thread Vasiliy Tolstov
libvirt.c:323:15: error: 'gcry_thread_cbs' is deprecated [-Werror=deprecated-declarations] static struct gcry_thread_cbs virTLSThreadImpl = { ^ In file included from libvirt.c:58:0: /usr/x86_64-pc-linux-gnu/include/gcrypt.h:211:8: note: declared here struct gcry_thread_cbs

[libvirt] github and gitlab mirrors are far behind

2016-03-14 Thread Henning Schild
Hey, as the title says the mirrors are pretty far behind, probably something is broken there. Henning -- libvir-list mailing list libvir-list@redhat.com https://www.redhat.com/mailman/listinfo/libvir-list

[libvirt] [PATCH v5 0/6] storage:dir: ploop volumes support

2016-03-14 Thread Olga Krishtal
This series of patches introduces the support of ploop volumes in storage pools (dir, fs, etc). Ploop volume is a disk loopback block device consists of root.hds (it is the image file) and DiskDescriptor.xml: https://openvz.org/Ploop/format. Due to this fact it can't be treated as file or any othe

[libvirt] [PATCH 6/7] storage:dir: adapts .refreshVol .refreshPool for ploop volumes

2016-03-14 Thread Olga Krishtal
Refreshes meta-information such as allocation, capacity, format, etc. Ploop volumes differ from other volume types. Path to volume is the path to directory with image file root.hds and DiskDescriptor.xml. https://openvz.org/Ploop/format Due to this fact, operations of opening the volume have to be

[libvirt] User Behavior Tracking defenses in VMs

2016-03-14 Thread bancfc
Intended for qemu-discuss /cc/ libvir-list, whonix-devel, tor-dev *** Hello. I work on WhonixOS an anonymity distro based on Tor. This feature request is related to the topics of privacy and anonymity. Its a complex topic and probably not in your area of focus but I think it has important imp

[libvirt] [PATCH 5/7] storage:dir: .wipeVol is left unsupported for ploop volume

2016-03-14 Thread Olga Krishtal
Returns error in case of vol-wipe cmd for a ploop volume Signed-off-by: Olga Krishtal --- src/storage/storage_backend.c | 6 ++ 1 file changed, 6 insertions(+) diff --git a/src/storage/storage_backend.c b/src/storage/storage_backend.c index fddec3c..8b936ae 100644 --- a/src/storage/storage_

[libvirt] [PATCH 3/7] storage:dir: .deleteVol callback for ploop volume

2016-03-14 Thread Olga Krishtal
Recursively deletes whole directory of a ploop volume. To delete ploop image it has to be unmounted. Signed-off-by: Olga Krishtal --- src/storage/storage_backend_fs.c | 3 +++ 1 file changed, 3 insertions(+) diff --git a/src/storage/storage_backend_fs.c b/src/storage/storage_backend_fs.c index

[libvirt] [PATCH 4/7] storage:dir: .resizeVol callback for ploop volume

2016-03-14 Thread Olga Krishtal
Changes the size of given ploop volume via ploop resize tool. Signed-off-by: Olga Krishtal --- src/storage/storage_backend.c| 25 + src/storage/storage_backend.h| 2 ++ src/storage/storage_backend_fs.c | 2 ++ 3 files changed, 29 insertions(+) diff --git a/src/

[libvirt] [PATCH 1/7] storage: added ploop volume type

2016-03-14 Thread Olga Krishtal
Ploop image consists of directory with two files: ploop image itself, called root.hds and DiskDescriptor.xml that contains information about ploop device: https://openvz.org/Ploop/format. Such volume are difficult to manipulate in terms of existing volume types because they are neither a single fil

[libvirt] [PATCH 7/7] storage:dir: adapts .uploadVol .dowloadVol for ploop volume

2016-03-14 Thread Olga Krishtal
In case of ploop volume, target path of the volume is the path to the directory that contains image file named root.hds and DiskDescriptor.xml. While using uploadVol and downloadVol callbacks we need to open root.hds itself. Upload or download operations with ploop volume are only allowed when imag

[libvirt] [PATCH 2/7] storage:dir: .buildVol and .buildVolFrom callbacks for ploop

2016-03-14 Thread Olga Krishtal
These callbacks let us to create ploop volumes in dir, fs and etc. pools. If a ploop volume was created via buildVol callback, then this volume is an empty ploop device with DiskDescriptor.xml. If the volume was created via .buildFrom - then its content is similar to input volume content. Signed-o

Re: [libvirt] [PATCH 15/24] hostdev: Remove virHostdevGetActivePCIHostDeviceList()

2016-03-14 Thread Andrea Bolognani
On Fri, 2016-03-11 at 14:01 -0500, John Ferlan wrote: > Please read my logic in patch 20 before doing anything - I'm in the > middle of it... scroll down for my short thoughts [1]... Your comments to patch 20 are extremely detailed, so it will take me a while to go through them and reply properly.

Re: [libvirt] [PATCH 15/24] hostdev: Remove virHostdevGetActivePCIHostDeviceList()

2016-03-14 Thread Andrea Bolognani
On Thu, 2016-03-10 at 14:25 -0500, John Ferlan wrote: >   Should have read patch 18 & 19 first... Looks like I'm getting > confuzzled by all these lists and multitude of ways names were > generated. The comparison being done is against the copy that came from > the activePCIHostdev list which will

Re: [libvirt] [PATCH] schema: support 'default' cache mode

2016-03-14 Thread Jim Fehlig
On 03/14/2016 06:40 AM, Ján Tomko wrote: > On Mon, Feb 29, 2016 at 04:26:25PM -0700, Jim Fehlig wrote: >> The docs claims the cache attribute of the disk >> element supports 'default' as one of its permissible values, >> but such configuration fails virt-xml-validate. Add 'default' >> as one of th

Re: [libvirt] [PATCH 16/24] hostdev: Rename hostdev_mgr -> mgr

2016-03-14 Thread Andrea Bolognani
On Thu, 2016-03-10 at 14:11 -0500, John Ferlan wrote: > > On 03/07/2016 12:24 PM, Andrea Bolognani wrote: > > > > We're in the hostdev module, so mgr is not an ambiguous name, and > > in fact it's already used in some cases. Switch all the code over. > > > > Take the chance to shorten declaratio

Re: [libvirt] Storage Backend - buildVolFrom Semantics

2016-03-14 Thread Ján Tomko
On Tue, Mar 01, 2016 at 09:22:12PM -0600, Richard Laager wrote: > storage_backend_rbd.c uses an RBD clone operation to implement buildVolFrom. > > If I'm understanding the RBD documentation correctly, you cannot delete > the parent until the clone has been deleted: > http://docs.ceph.com/docs/mas

Re: [libvirt] [libvirt-perl][PATCH] Add VIR_ERR_NO_SERVER constant

2016-03-14 Thread Daniel P. Berrange
On Mon, Mar 14, 2016 at 02:25:18PM +0100, Michal Privoznik wrote: > Signed-off-by: Michal Privoznik > --- > Changes | 1 + > Virt.xs | 1 + > lib/Sys/Virt/Error.pm | 4 > 3 files changed, 6 insertions(+) ACK Regards, Daniel -- |: http://berrange.com -o-

[libvirt] [libvirt-perl][PATCH] Add VIR_ERR_NO_SERVER constant

2016-03-14 Thread Michal Privoznik
Signed-off-by: Michal Privoznik --- Changes | 1 + Virt.xs | 1 + lib/Sys/Virt/Error.pm | 4 3 files changed, 6 insertions(+) diff --git a/Changes b/Changes index 4e343d5..aa71a1e 100644 --- a/Changes +++ b/Changes @@ -7,6 +7,7 @@ Revision history for perl module

Re: [libvirt] [PATCH] schema: support 'default' cache mode

2016-03-14 Thread Ján Tomko
On Mon, Feb 29, 2016 at 04:26:25PM -0700, Jim Fehlig wrote: > The docs claims the cache attribute of the disk > element supports 'default' as one of its permissible values, > but such configuration fails virt-xml-validate. Add 'default' > as one of the cache attribute choices in domaincommon.rng.

Re: [libvirt] [PATCH] qemu: Restore error/cleanup logic for qemuBuildNetCommandLine

2016-03-14 Thread Peter Krempa
On Mon, Mar 14, 2016 at 07:28:12 -0400, John Ferlan wrote: > The virDomainConfVMNWFilterTeardown was called in the error path of > qemuBuildCommandLine once network setup was partially or fully completed > using the last_good_net as the basis to determine which filters needed > to be torn down. Co

Re: [libvirt] [PATCH] vz: fix active domain listing

2016-03-14 Thread Maxim Nestratov
14.03.2016 12:26, Nikolay Shirokovskiy пишет: On 11.03.2016 12:05, Maxim Nestratov wrote: Since commit 9c14a9ab we have broken active domain listing because reworked prlsdkLoadDomain doesn't set dom->def->id propely. It just looses it when a new def structure is set. Now we make prlsdkConvertDo

Re: [libvirt] [REPOST PATCH 0/8] Reorganize qemu_command.c in smaller piles (round 3)

2016-03-14 Thread Ján Tomko
On Fri, Mar 11, 2016 at 07:36:21PM -0500, John Ferlan wrote: > Final pile of split. > > Rather than hope for a review of 25 patches or creating some remote > place to place a branch - I'll repost the original: > > http://www.redhat.com/archives/libvir-list/2016-February/msg00975.html > > in smal

[libvirt] [PATCH] qemu: Restore error/cleanup logic for qemuBuildNetCommandLine

2016-03-14 Thread John Ferlan
The virDomainConfVMNWFilterTeardown was called in the error path of qemuBuildCommandLine once network setup was partially or fully completed using the last_good_net as the basis to determine which filters needed to be torn down. Commit id 'ef2ab8fd' moved that inside the new qemuBuildNetCommandLin

[libvirt] [PATCH] storage/rbd: Use correct printf-modifier for uint64

2016-03-14 Thread Christophe Fergeau
%zu is for size_t variables, not uint64 ones. This causes a warning when building on a 32 bit linux. --- src/storage/storage_backend_rbd.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/src/storage/storage_backend_rbd.c b/src/storage/storage_backend_rbd.c index 7d04b39..d895

Re: [libvirt] [PATCH] qemuBuildVideoCommandLine: Don't access def->videos without check

2016-03-14 Thread Christophe Fergeau
On Mon, Mar 14, 2016 at 10:19:18AM +0100, Peter Krempa wrote: > On Mon, Mar 14, 2016 at 09:47:05 +0100, Michal Privoznik wrote: > > This function can be called over a domain definition that has no > > video configured. The > > tests/qemuxml2argvdata/qemuxml2argv-minimal.xml file could serve > > as

Re: [libvirt] [virt-tools-list] Usability Enhancement: Import/Export VMs GUI

2016-03-14 Thread Martin Kletzander
On Fri, Mar 11, 2016 at 10:32:15PM +, ban...@openmailbox.org wrote: On 2016-03-10 15:43, Cole Robinson wrote: On 03/10/2016 02:29 AM, Martin Kletzander wrote: On Fri, Mar 04, 2016 at 04:23:18PM +, ban...@openmailbox.org wrote: The single most important usability feature missed by our l

Re: [libvirt] Enhancement: Random Clock Offset

2016-03-14 Thread Martin Kletzander
On Fri, Mar 11, 2016 at 10:46:24PM +, ban...@openmailbox.org wrote: On 2016-03-02 10:22, Daniel P. Berrange wrote: Agreed, this feature is really a specific usage policy. Libvirt aims to focus on providing mechanism, letting specific policies be implemented by the management applications us

Re: [libvirt] [PATCH REPOST 9/9] qemu: Introduce qemuBuildNetCommandLine

2016-03-14 Thread Ján Tomko
On Tue, Mar 08, 2016 at 02:03:16PM -0500, John Ferlan wrote: > Add new function to manage adding the network device options to the > command line removing that task from the mainline qemuBuildCommandLine. > > Signed-off-by: John Ferlan > --- > src/qemu/qemu_command.c | 133 > +++

Re: [libvirt] [PATCH] vz: fix active domain listing

2016-03-14 Thread Nikolay Shirokovskiy
On 11.03.2016 12:05, Maxim Nestratov wrote: > Since commit 9c14a9ab we have broken active domain listing > because reworked prlsdkLoadDomain doesn't set dom->def->id > propely. It just looses it when a new def structure is set. > Now we make prlsdkConvertDomainState function return void > and mov

Re: [libvirt] [PATCH] qemuBuildVideoCommandLine: Don't access def->videos without check

2016-03-14 Thread Peter Krempa
On Mon, Mar 14, 2016 at 09:47:05 +0100, Michal Privoznik wrote: > This function can be called over a domain definition that has no > video configured. The > tests/qemuxml2argvdata/qemuxml2argv-minimal.xml file could serve > as an example. Problem is, before the check that domain has some > or none

[libvirt] [PATCH] qemuBuildVideoCommandLine: Don't access def->videos without check

2016-03-14 Thread Michal Privoznik
This function can be called over a domain definition that has no video configured. The tests/qemuxml2argvdata/qemuxml2argv-minimal.xml file could serve as an example. Problem is, before the check that domain has some or none video configured, def->videos is dereferenced causing a segmentation fault

Re: [libvirt] [PATCH 2/2] Fix build with clang

2016-03-14 Thread Martin Kletzander
On Fri, Mar 11, 2016 at 05:20:35PM +0100, Andrea Bolognani wrote: On Fri, 2016-03-11 at 16:36 +0100, Martin Kletzander wrote: Even though this is, technically speaking, a build-breaker fix, different version of this was posted before [1] and not accepted (although neither rejected), so I'm sendi

Re: [libvirt] [PATCH 2/3] Introduce readonly without explicit deny-write

2016-03-14 Thread Cedric Bosdonnat
On Fri, 2016-03-11 at 20:07 +, Serge Hallyn wrote: > [Sorry, the Ubuntu package suggests this came from Cèdric, although > I can't quite find this patch on the mailing list. Those patches > which I did see from Cèdric did not have a Signed-off-by, so I didn't > add one for him.] Well, that wa

[libvirt] 答复: any better way to treat device-detach timeout ?

2016-03-14 Thread Zhangbo (Oscar)
> >On Fri, Mar 11, 2016 at 09:26:23 +, Zhangbo (Oscar) wrote: >> After rethinking, I guess there's still a problem: >> >>Suggest that >>1 the device got detached in qemu after 10 secs, >>2 the func virDomainDetachDeviceFlags() has already returned success in >the 5th second. Libvirt