Re: [libvirt] [PATCH v2 06/10] Make qemu attach/detach functions public

2016-07-26 Thread Martin Kletzander
On Wed, Jul 27, 2016 at 01:08:17AM +0200, Tomasz Flendrich wrote: +int qemuDomainAttachDeviceLiveAndConfig(virConnectPtr conn, +virDomainObjPtr vm, +virQEMUDriverPtr driver, +

Re: [libvirt] [PATCH 1/2] util: Introduce virISCSINodeNew

2016-07-26 Thread John Ferlan
On 07/26/2016 12:24 PM, Ján Tomko wrote: > On Mon, Jul 18, 2016 at 07:37:20AM -0400, John Ferlan wrote: >> https://bugzilla.redhat.com/show_bug.cgi?id=1356436 >> >> According to RFC 3721 (https://www.ietf.org/rfc/rfc3721.txt), there are >> two ways to "discover" targets in/for the iSCSI

Re: [libvirt] [PATCH v2 10/10] Add a persistent attachment testcase

2016-07-26 Thread Tomasz Flendrich
> > diff --git a/tests/qemuhotplugtestdomains/qemuhotplug-base-config.xml >> b/tests/qemuhotplugtestdomains/qemuhotplug-base-config.xml >> new file mode 100644 >> index 000..20ad0a5 >> --- /dev/null >> +++ b/tests/qemuhotplugtestdomains/qemuhotplug-base-config.xml >> > > I don't think we need

Re: [libvirt] [PATCH v2 06/10] Make qemu attach/detach functions public

2016-07-26 Thread Tomasz Flendrich
> > +int qemuDomainAttachDeviceLiveAndConfig(virConnectPtr conn, >> +virDomainObjPtr vm, >> +virQEMUDriverPtr driver, >> +const char *xml, >> +

Re: [libvirt] [PATCH v5] libxl: implement virDomainBlockStats

2016-07-26 Thread Joao Martins
On 07/26/2016 10:42 PM, Jim Fehlig wrote: > On 07/25/2016 05:45 PM, Joao Martins wrote: >> Introduce initial support for domainBlockStats API call that >> allow us to query block device statistics. openstack nova > > s/openstack/OpenStack/ > >> uses this API call to query block statistics,

Re: [libvirt] [PATCH] qemu: rename QEMU_CAPS_MLOCK to QEMU_CAPS_REALTIME_MLOCK

2016-07-26 Thread Cole Robinson
On 07/25/2016 08:44 AM, Henning Schild wrote: > Purely cosmetic change to be consistent with the other names. > > Signed-off-by: Henning Schild > --- > Something i found in an old staging queue and that might be considered > useful. Makes sense, if -realtime ever

Re: [libvirt] [PATCH v5] libxl: implement virDomainBlockStats

2016-07-26 Thread Jim Fehlig
On 07/25/2016 05:45 PM, Joao Martins wrote: > Introduce initial support for domainBlockStats API call that > allow us to query block device statistics. openstack nova s/openstack/OpenStack/ > uses this API call to query block statistics, alongside > virDomainMemoryStats and

Re: [libvirt] [PATCH v2 09/10] Make qemuhotplugtest work with persistent domains

2016-07-26 Thread Tomasz Flendrich
> > [...] > > > Indentation is off here. Thank you for noticing that. Indeed, 4 spaces are missing. > > > +goto cleanup; >> +break; >> +case VIR_DOMAIN_AFFECT_CONFIG: >> +if (virAsprintf(_filename, >> + >> "%s/qemuhotplugtestdomains/qemuhotplug-%s+%s+config.xml",

Re: [libvirt] [libvirt RFC PATCH 02/10] util: storage: Add parser for qemu's "json" backing pseudo-protocol

2016-07-26 Thread Eric Blake
On 07/15/2016 07:46 AM, Peter Krempa wrote: > Add a modular parser that will allow to parse 'json' backing definitions > that are supported by qemu. The initial implementation adds support for > the 'file' driver. Might be nice for this commit message to show an actual json: string that it now

Re: [libvirt] [PATCH 1/9] Introduce node device lifecycle event APIs

2016-07-26 Thread Cole Robinson
On 07/26/2016 01:32 PM, Daniel P. Berrange wrote: > On Tue, Jul 26, 2016 at 01:28:34PM -0400, Cole Robinson wrote: >> On 07/20/2016 09:50 AM, Jovanka Gulicoska wrote: >>> Node device lifecycle event API entry points for registering and >>> deregistering >>> node deivce events, as well as types of

Re: [libvirt] [PATCH 9/9] virsh: Introduce nodedev-event command

2016-07-26 Thread Cole Robinson
On 07/20/2016 09:50 AM, Jovanka Gulicoska wrote: > Add nodedev-event support for node device lifecycle events > --- > tools/virsh-nodedev.c | 211 > ++ > tools/virsh-nodedev.h | 10 +++ > tools/virsh.pod | 18 + > 3 files changed, 239

Re: [libvirt] [PATCH 8/9] event-test: support node device lifecycle event APIs

2016-07-26 Thread Cole Robinson
On 07/20/2016 09:50 AM, Jovanka Gulicoska wrote: > --- > examples/object-events/event-test.c | 68 > + > 1 file changed, 68 insertions(+) ACK, looks fine Thanks, Cole -- libvir-list mailing list libvir-list@redhat.com

Re: [libvirt] [PATCH 7/9] node_device: Implement event queue in udev

2016-07-26 Thread Cole Robinson
I'd title this: node_device: udev: implement lifecycle events On 07/20/2016 09:50 AM, Jovanka Gulicoska wrote: > --- > src/node_device/node_device_udev.c | 24 > 1 file changed, 24 insertions(+) > > diff --git a/src/node_device/node_device_udev.c >

Re: [libvirt] [PATCH 6/9] node_device: implement node device lifecycle event APIs

2016-07-26 Thread Cole Robinson
On 07/20/2016 09:50 AM, Jovanka Gulicoska wrote: > --- > src/conf/node_device_conf.h | 4 > src/node_device/node_device_driver.c | 42 > > src/node_device/node_device_driver.h | 10 + > 3 files changed, 56 insertions(+) > > diff --git

Re: [libvirt] [PATCH 5/9] remote: implement node device lifecycle event APIs

2016-07-26 Thread Cole Robinson
On 07/20/2016 09:50 AM, Jovanka Gulicoska wrote: > --- > daemon/libvirtd.h| 2 + > daemon/remote.c | 206 > +++ > src/remote/remote_driver.c | 139 + > src/remote/remote_protocol.x | 43 - >

Re: [libvirt] [PATCH v3 0/2] qemu: expand domain memory statistics

2016-07-26 Thread Maxim Nestratov
26-Jul-16 18:32, Pavel Hrdina пишет: On Sat, Jun 04, 2016 at 06:41:35PM +0300, Maxim Nestratov wrote: 01.06.2016 20:07, Derbyshev Dmitriy пишет: From: Derbyshev Dmitry QEMU reports timestamp and available along with other memory statistics. This information was

Re: [libvirt] [PATCH 4/9] test: implement node device lifecycle event APIs

2016-07-26 Thread Cole Robinson
On 07/20/2016 09:50 AM, Jovanka Gulicoska wrote: > Also includes unittests for node device lifecycle events API > --- > src/test/test_driver.c | 49 + > tests/objecteventtest.c | 72 > + > 2 files changed, 121

Re: [libvirt] [libvirt RFC PATCH 01/10] tests: Add testing of backing store string parser

2016-07-26 Thread Eric Blake
On 07/15/2016 07:46 AM, Peter Krempa wrote: > As we already test that the extraction of the backing store string works > well additional tests for the backing store string parser can be made > simpler. > > Export virStorageSourceNewFromBackingAbsolute and use it to parse the > backing store

[libvirt] [PATCH 2/2] storage: remove "luks" storage volume type

2016-07-26 Thread Daniel P. Berrange
The current LUKS support has a "luks" volume type which has a "luks" encryption format. This partially makes sense if you consider the QEMU shorthand syntax only requires you to specify a format=luks, and it'll automagically uses "raw" as the next level driver. QEMU will however let you override

[libvirt] [PATCH 0/2] Updates for LUKS support

2016-07-26 Thread Daniel P. Berrange
Daniel P. Berrange (2): virstoragefile: refactor virStorageFileMatchesNNN methods storage: remove "luks" storage volume type src/qemu/qemu_command.c| 10 +- src/qemu/qemu_domain.c | 2 +- src/qemu/qemu_hotplug.c

[libvirt] [PATCH 1/2] virstoragefile: refactor virStorageFileMatchesNNN methods

2016-07-26 Thread Daniel P. Berrange
Refactor the virStorageFileMatchesNNN methods so that they don't take a struct FileFormatInfo parameter, but instead get the actual raw dat items they needs. This will facilitate reuse in other contexts. Signed-off-by: Daniel P. Berrange --- src/util/virstoragefile.c | 63

Re: [libvirt] [PATCH 3/9] conf: events: don't crash on NULL uuid

2016-07-26 Thread Cole Robinson
On 07/20/2016 09:50 AM, Jovanka Gulicoska wrote: > nodedev events don't have a uuid value and will pass in NULL > --- > src/conf/object_event.c | 3 ++- > 1 file changed, 2 insertions(+), 1 deletion(-) > > diff --git a/src/conf/object_event.c b/src/conf/object_event.c > index cb984ff..bbef7f6

Re: [libvirt] [PATCH 2/9] conf: add node_device_event handling

2016-07-26 Thread Cole Robinson
On 07/20/2016 09:50 AM, Jovanka Gulicoska wrote: > Add node device event handling infrastructure to node_device_event.[ch] > --- > src/Makefile.am | 5 + > src/conf/node_device_event.c | 234 > +++ > src/conf/node_device_event.h | 59

Re: [libvirt] [PATCH 1/9] Introduce node device lifecycle event APIs

2016-07-26 Thread Daniel P. Berrange
On Tue, Jul 26, 2016 at 01:28:34PM -0400, Cole Robinson wrote: > On 07/20/2016 09:50 AM, Jovanka Gulicoska wrote: > > Node device lifecycle event API entry points for registering and > > deregistering > > node deivce events, as well as types of events associated with node devices. > > * device >

Re: [libvirt] [PATCH 1/9] Introduce node device lifecycle event APIs

2016-07-26 Thread Cole Robinson
On 07/20/2016 09:50 AM, Jovanka Gulicoska wrote: > Node device lifecycle event API entry points for registering and deregistering > node deivce events, as well as types of events associated with node devices. * device > These entry points will be used for implementing asynchronous lifecycle >

Re: [libvirt] [PATCH 0/2] virpci: support driver_override sysfs interface

2016-07-26 Thread Jim Fehlig
Ping. Any comments on this series? Regards, Jim On 07/11/2016 12:23 PM, Jim Fehlig wrote: > This series fixes a regression using Xen's pciback with > kernels >= 3.16 containing > >

Re: [libvirt] [PATCH] qemu: Use legacy USB on ppc64

2016-07-26 Thread Andrea Bolognani
On Thu, 2016-07-21 at 16:31 +0100, Daniel P. Berrange wrote: > > > > It seems that we could solve this by just changing the logic in > > > > qemuDomainAssignDevicePCISlots() so that when it is auto-assigning > > > > addresses, it always uses 00:00.0 for the USB controller when guest > > > > arch

Re: [libvirt] [PATCH] network: Added hook for network modification event

2016-07-26 Thread Cole Robinson
On 07/26/2016 11:50 AM, Laine Stump wrote: > Sorry, I was offline for an extended time (the last week due to a bit of > "political unrest" :-), and just returned yesterday... > > On 07/26/2016 07:18 AM, Anton Khramov wrote: >> Hi Cole, >> >> Any news on this change? >> >> Regards, >> Anton >> >>

Re: [libvirt] [PATCH] qemu: remove panic device with model s390 when migrating

2016-07-26 Thread Ján Tomko
[cc-ing Andrea who auto-added panic for PPC64] Should we do the same for PANIC_MODEL_PSERIES? On Tue, Jul 26, 2016 at 09:52:59AM +0200, Boris Fiuczynski wrote: The panic device with model s390 is autogenerated on domains with S390 architecture since libvirt version 1.3.5. For backwards

Re: [libvirt] [PATCH 0/2] Use static configuration method for iSCSI target discovery

2016-07-26 Thread Ján Tomko
On Mon, Jul 18, 2016 at 07:37:19AM -0400, John Ferlan wrote: https://bugzilla.redhat.com/show_bug.cgi?id=1356436 Details in patches. John Ferlan (2): util: Introduce virISCSINodeNew iscsi: Establish connection to target via static target login src/libvirt_private.syms| 1 +

Re: [libvirt] [PATCH 1/2] util: Introduce virISCSINodeNew

2016-07-26 Thread Ján Tomko
On Mon, Jul 18, 2016 at 07:37:20AM -0400, John Ferlan wrote: https://bugzilla.redhat.com/show_bug.cgi?id=1356436 According to RFC 3721 (https://www.ietf.org/rfc/rfc3721.txt), there are two ways to "discover" targets in/for the iSCSI environment. Discovery is the process which allows the

Re: [libvirt] [PATCH 00/25] Add support for multi-host gluster drives

2016-07-26 Thread Ján Tomko
On Mon, Jul 25, 2016 at 08:11:45PM +0200, Peter Krempa wrote: This is a updated take based on stuff I had laying around and parts from https://www.redhat.com/archives/libvir-list/2016-July/msg00872.html This addresses the backing store parser, adds and improves bits to the JSON->commandline

Re: [libvirt] [PATCH 03/25] util: storage: Add parser for qemu's "json" backing pseudo-protocol

2016-07-26 Thread Ján Tomko
Why the quotes? Jan On Mon, Jul 25, 2016 at 08:11:48PM +0200, Peter Krempa wrote: Add a modular parser that will allow to parse 'json' backing definitions that are supported by qemu. The initial implementation adds support for the 'file' driver. --- src/util/virstoragefile.c | 87

Re: [libvirt] [PATCH 21/25] qemu: command: Refactor code extracted to qemuBuildDriveSourceStr

2016-07-26 Thread Ján Tomko
On Mon, Jul 25, 2016 at 08:12:06PM +0200, Peter Krempa wrote: Avoid a large block by tweaking the condition skipping empty drives and split up the switch containing two branches having different purpose. --- src/qemu/qemu_command.c | 99 +++-- 1 file

Re: [libvirt] [PATCH 0/2] Remove calls that just clear alias

2016-07-26 Thread Ján Tomko
On Wed, Jul 20, 2016 at 06:56:47AM -0400, John Ferlan wrote: Based off review of : http://www.redhat.com/archives/libvir-list/2016-July/msg00672.html Rather than add the ignore_value, just remove the unused / unnecessary code Patch 1 has no callers any more and from inspection patch 2 is

Re: [libvirt] [PATCH] network: Added hook for network modification event

2016-07-26 Thread Laine Stump
Sorry, I was offline for an extended time (the last week due to a bit of "political unrest" :-), and just returned yesterday... On 07/26/2016 07:18 AM, Anton Khramov wrote: Hi Cole, Any news on this change? Regards, Anton On 07/18/2016 11:46 PM, Cole Robinson wrote: On 07/13/2016 07:06 AM,

Re: [libvirt] [PATCH v3 0/2] qemu: expand domain memory statistics

2016-07-26 Thread Pavel Hrdina
On Sat, Jun 04, 2016 at 06:41:35PM +0300, Maxim Nestratov wrote: > 01.06.2016 20:07, Derbyshev Dmitriy пишет: > > > From: Derbyshev Dmitry > > > > QEMU reports timestamp and available along with other memory statistics. > > This information was not saved into domain

Re: [libvirt] [PATCH v2 10/10] Remove unused functions that release addresses

2016-07-26 Thread Cole Robinson
On 07/22/2016 09:47 PM, Tomasz Flendrich wrote: > Since address sets are now recalculated on demand instead of being > cached, there's no need for functions that release addresses. Note there's other bits to clean up here, some functions can be made private to this file. For example

Re: [libvirt] [RFC] Switch to nftables from netfilter

2016-07-26 Thread Daniel P. Berrange
On Tue, Jul 26, 2016 at 04:25:17PM +0200, Michal Privoznik wrote: > Dear list, > > I've came across nftables [1]. They look very promising, more than old > netfilter. It offers new features [2], from which I'd pick: > > - better performance under high traffic workloads > - atomic filter/chain

[libvirt] [RFC] Switch to nftables from netfilter

2016-07-26 Thread Michal Privoznik
Dear list, I've came across nftables [1]. They look very promising, more than old netfilter. It offers new features [2], from which I'd pick: - better performance under high traffic workloads - atomic filter/chain replacements - transactions I haven't investigated how much work will be required

Re: [libvirt] [PATCH 25/25] qemu: command: Add support for multi-host gluster disks

2016-07-26 Thread Peter Krempa
On Tue, Jul 26, 2016 at 17:21:37 +0530, Prasanna Kalever wrote: > On Mon, Jul 25, 2016 at 11:42 PM, Peter Krempa wrote: > > From: Prasanna Kumar Kalever > > > > To allow using failover with gluster it's necessary to specify multiple > > volume

Re: [libvirt] [PATCH 25/25] qemu: command: Add support for multi-host gluster disks

2016-07-26 Thread Prasanna Kalever
On Mon, Jul 25, 2016 at 11:42 PM, Peter Krempa wrote: > From: Prasanna Kumar Kalever > > To allow using failover with gluster it's necessary to specify multiple > volume hosts. Add support for starting qemu with such configurations. > >

Re: [libvirt] [PATCH] network: Added hook for network modification event

2016-07-26 Thread Anton Khramov
Hi Cole, Any news on this change? Regards, Anton On 07/18/2016 11:46 PM, Cole Robinson wrote: > On 07/13/2016 07:06 AM, Khramov Anton wrote: >> From: Anton Khramov >> >> Resolves: https://bugzilla.redhat.com/show_bug.cgi?id=1181539 >> --- >> docs/hooks.html.in | 2

Re: [libvirt] [PATCH v2 07/10] add qemuDomainPCIAddrSetCreateFromDomain

2016-07-26 Thread Martin Kletzander
On Sat, Jul 23, 2016 at 03:47:12AM +0200, Tomasz Flendrich wrote: The address sets (pci, ccw, virtio serial) are currently cached in qemu private data, but all the information required to recreate these sets is in the domain definition. Therefore I am removing the redundant data and adding a way

[libvirt] [PATCH] qemu: remove panic device with model s390 when migrating

2016-07-26 Thread Boris Fiuczynski
The panic device with model s390 is autogenerated on domains with S390 architecture since libvirt version 1.3.5. For backwards compatibility reasons the device is to be removed when migrating. Signed-off-by: Boris Fiuczynski --- src/qemu/qemu_domain.c | 22

Re: [libvirt] [PATCH v3] util: systemd: Define MSG_NOSIGNAL if needed

2016-07-26 Thread Justin Clift
On 26 Jul 2016, at 08:26, Andrea Bolognani wrote: > On Tue, 2016-07-26 at 04:55 +0300, Roman Bogorodskiy wrote: >> I pushed the patch to make sure it won't get lost and get into the >> upcoming release. > > I was away for a few days, thanks for taking care of this :) Thanks

Re: [libvirt] [PATCH] qemu: Fix backwards compatibility of S390 guests

2016-07-26 Thread Boris Fiuczynski
On 07/20/2016 09:39 AM, Jiri Denemark wrote: On Wed, Jul 20, 2016 at 09:13:54 +0200, Boris Fiuczynski wrote: This patch reverts commit 73e4e10e62e4b1aea64b317be96af5e5488007d7 and thereby disabling the panic device autogeneration for S390 guests. In addition tests are patched as well. The

Re: [libvirt] [PATCH v3] util: systemd: Define MSG_NOSIGNAL if needed

2016-07-26 Thread Andrea Bolognani
On Tue, 2016-07-26 at 04:55 +0300, Roman Bogorodskiy wrote: > I pushed the patch to make sure it won't get lost and get into the > upcoming release. I was away for a few days, thanks for taking care of this :) --  Andrea Bolognani / Red Hat / Virtualization -- libvir-list mailing list

Re: [libvirt] Schedule for next release

2016-07-26 Thread Daniel Veillard
On Mon, Jul 25, 2016 at 11:48:38PM +0100, Justin Clift wrote: > On 25 Jul 2016, at 23:13, Daniel Veillard wrote: > > About time to roll that one. > > I think we need to enter freese on Wednesday, then I can make rc2 on Friday, > > and hopefully we can push 2.1.0 on Monday or