Re: [libvirt PATCH v6 1/2] news: mention vdpa support

2020-10-30 Thread Laine Stump
On 10/30/20 4:01 PM, Jonathon Jongsma wrote: Signed-off-by: Jonathon Jongsma --- NEWS.rst | 6 ++ 1 file changed, 6 insertions(+) diff --git a/NEWS.rst b/NEWS.rst index 2fef3f706c..384ee94480 100644 --- a/NEWS.rst +++ b/NEWS.rst @@ -43,6 +43,12 @@ v6.9.0 (unreleased) Implement v

Re: Proposal: drop support for Hyper-V 2008R2

2020-10-30 Thread Matt Coleman
> On Oct 30, 2020, at 11:54 AM, Andrea Bolognani wrote: > > Dropping 2008R2 support is a no-brainer. > > Can we got further? Our policy[1] for Linux is > > The project aims to support the most recent major version at all > times. Support for the previous major version will be dropped 2 > yea

Re: [libvirt PATCH v6 2/2] nodedev: fix resource leak

2020-10-30 Thread Laine Stump
Oh shoot! I wrote/posted a patch for this (because I'd just finished making a long patch series to use g_autoptr for all DIR*, and wanted to update it to take this into account) on Tuesday or Wednesday, it was reviewed, and I pulled it into master of my local tree; I *thought* I had pushed it s

[libvirt PATCH v6 2/2] nodedev: fix resource leak

2020-10-30 Thread Jonathon Jongsma
Ensure that the directory is closed when opening chardev path for a vDPA device. Signed-off-by: Jonathon Jongsma --- src/node_device/node_device_udev.c | 11 --- 1 file changed, 8 insertions(+), 3 deletions(-) diff --git a/src/node_device/node_device_udev.c b/src/node_device/node_devic

[libvirt PATCH v6 1/2] news: mention vdpa support

2020-10-30 Thread Jonathon Jongsma
Signed-off-by: Jonathon Jongsma --- NEWS.rst | 6 ++ 1 file changed, 6 insertions(+) diff --git a/NEWS.rst b/NEWS.rst index 2fef3f706c..384ee94480 100644 --- a/NEWS.rst +++ b/NEWS.rst @@ -43,6 +43,12 @@ v6.9.0 (unreleased) Implement virito-9p shared filesystem using the element.

Re: Proposal: drop support for Hyper-V 2008R2

2020-10-30 Thread Matt Coleman
> On Oct 30, 2020, at 8:09 AM, Alvin Starr wrote: > > Not sure if this is still the case but I found different capabilities between > different license levels of the same product. > This was years ago so the details are vague now but in essence the problem I > ran into was differences between

[PATCH 1/9] qemuxml2xmltest: Remove 'WITH_QEMU' conditional

2020-10-30 Thread Peter Krempa
The test is compiled only when the qemu driver is enabled so we don't need the conditional code. Signed-off-by: Peter Krempa --- tests/qemuxml2xmltest.c | 54 - 1 file changed, 21 insertions(+), 33 deletions(-) diff --git a/tests/qemuxml2xmltest.c b/tests

[PATCH 6/9] qemu_migration_cookie: Make cookie parsing robust against missing domain job

2020-10-30 Thread Peter Krempa
In testing code we don't properly populate the job sometimes. If it isn't populated we should not touch it though in the migration cookie code. Signed-off-by: Peter Krempa --- src/qemu/qemu_migration_cookie.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/src/qemu/qemu_migra

[PATCH 3/9] qemu_migration_cookie: Make header standalone

2020-10-30 Thread Peter Krempa
Include qemu_domain.h and qemu_domainjob.h as the types from those headers are used by this header. Signed-off-by: Peter Krempa --- src/qemu/qemu_migration_cookie.h | 2 ++ 1 file changed, 2 insertions(+) diff --git a/src/qemu/qemu_migration_cookie.h b/src/qemu/qemu_migration_cookie.h index f28

[PATCH 5/9] tests: Add mock library for virGetHostname and virGetHostUUID

2020-10-30 Thread Peter Krempa
The 'qemu_migration_cookie' module uses these. Provide a stable override for tests. Signed-off-by: Peter Krempa --- src/util/virutil.h | 2 +- src/util/viruuid.h | 2 +- tests/hostidmock.c | 36 tests/meson.build | 1 + 4 files changed, 39 insertions(+),

[PATCH 2/9] qemuxml2xmltest: Split out status XML testing to qemustatusxml2xmltest.c

2020-10-30 Thread Peter Krempa
Separate the test files. Signed-off-by: Peter Krempa --- tests/meson.build | 1 + tests/qemustatusxml2xmltest.c | 159 ++ tests/qemuxml2xmltest.c | 84 -- 3 files changed, 160 insertions(+), 84 deletions(-) create mode 100644

[PATCH 9/9] virCPUDefFormatBufFull: Use virXMLFormatElement

2020-10-30 Thread Peter Krempa
The function was basically open-coding it. Signed-off-by: Peter Krempa --- src/conf/cpu_conf.c | 16 +--- 1 file changed, 1 insertion(+), 15 deletions(-) diff --git a/src/conf/cpu_conf.c b/src/conf/cpu_conf.c index 7778e01131..5cf7716b12 100644 --- a/src/conf/cpu_conf.c +++ b/src/co

[PATCH 0/9] tests: Add testing of qemu migration cookie

2020-10-30 Thread Peter Krempa
Note that this series probably depends on the hash table refactor. Add testing of migration cookie as we don't have any schema or examples of it to prevent breakage and help with development. Peter Krempa (9): qemuxml2xmltest: Remove 'WITH_QEMU' conditional qemuxml2xmltest: Split out status X

[PATCH 8/9] qemumigrationcookiexmltest: Add synthetic test case

2020-10-30 Thread Peter Krempa
Add a test case attempting to excercise the most of the cookie XML parsing/formatting infra. Note that the data is not based on any real case. Signed-off-by: Peter Krempa --- .../full-xml2xml-in.xml | 221 ++ .../full-xml2xml-out.xml | 2

[PATCH 7/9] tests: Add testing of qemu migration cookie

2020-10-30 Thread Peter Krempa
Migration cookie transports a lot of information but there are no tests for it. The test supports both xml2xml testing and also testing of the population of the migration cookie data from a domain object, although that option is not very useful as many things are collected from running qemu and th

[PATCH 4/9] qemu_migration_cookie: Export qemuMigrationCookieXMLFormat for tests

2020-10-30 Thread Peter Krempa
Signed-off-by: Peter Krempa --- src/qemu/qemu_migration_cookie.c | 2 +- src/qemu/qemu_migration_cookie.h | 7 +++ 2 files changed, 8 insertions(+), 1 deletion(-) diff --git a/src/qemu/qemu_migration_cookie.c b/src/qemu/qemu_migration_cookie.c index 47674d29d7..be676269b8 100644 --- a/src/qe

Re: Proposal: drop support for Hyper-V 2008R2

2020-10-30 Thread Alvin Starr
On 10/30/20 7:02 AM, Matt Coleman wrote: Hello, I've been getting familiar with Hyper-V recently and have gotten stymied by inconsistencies in its API. While Hyper-V has V1 and V2 APIs, neither one is consistent between Windows versions. For example... * Windows 2012 only supports a subset of t

Re: Proposal: drop support for Hyper-V 2008R2

2020-10-30 Thread Andrea Bolognani
On Fri, 2020-10-30 at 07:02 -0400, Matt Coleman wrote: > Hello, > > I've been getting familiar with Hyper-V recently and have gotten > stymied by inconsistencies in its API. > > While Hyper-V has V1 and V2 APIs, neither one is consistent between > Windows versions. For example... > * Windows 20

Re: [PATCH] docs/system: Deprecate raspi2/raspi3 machine aliases

2020-10-30 Thread Philippe Mathieu-Daudé
On 10/30/20 3:33 PM, Peter Maydell wrote: > On Mon, 19 Oct 2020 at 09:23, Philippe Mathieu-Daudé wrote: >> >> Since commit aa35ec2213b ("hw/arm/raspi: Use more >> specific machine names") the raspi2/raspi3 machines >> have been renamed as raspi2b/raspi3b. >> >> As more Raspberry Pi 2/3 models are

Re: Proposal: drop support for Hyper-V 2008R2

2020-10-30 Thread Daniel P . Berrangé
On Fri, Oct 30, 2020 at 07:02:33AM -0400, Matt Coleman wrote: > Hello, > > I've been getting familiar with Hyper-V recently and have gotten > stymied by inconsistencies in its API. > > While Hyper-V has V1 and V2 APIs, neither one is consistent between > Windows versions. For example... > * Win

[libvirt PATCH 1/2] gitlab: run unit tests in i686 cross build

2020-10-30 Thread Daniel P . Berrangé
In most cross builds we can't run tests since we can't assume QEMU user mode emulators are loaded. i686 is special though because x86_64 can run i686 natively, so we should run unit tests there. The key benefit is that this gives us 32-bit unit test coverage in CI. Signed-off-by: Daniel P. Berran

[libvirt PATCH 2/2] scripts: trim "__attribute__((packed))" in RPC struct diff

2020-10-30 Thread Daniel P . Berrangé
i686 builds on x86_64 host on Debian 10 result in the RPC structs getting "__attribute__((packed))" annotations added to them. This is harmless since we know the XDR protocol aligns and pads struct fields suitably on the wire. Thus we can safely cull the attribute before doing the diff comparison.

[libvirt PATCH 0/2] Run full unit tests on i686 too

2020-10-30 Thread Daniel P . Berrangé
Daniel P. Berrangé (2): gitlab: run unit tests in i686 cross build scripts: trim "__attribute__((packed))" in RPC struct diff .gitlab-ci.yml | 1 + scripts/check-remote-protocol.py | 6 ++ 2 files changed, 7 insertions(+) -- 2.28.0

Proposal: drop support for Hyper-V 2008R2

2020-10-30 Thread Matt Coleman
Hello, I've been getting familiar with Hyper-V recently and have gotten stymied by inconsistencies in its API. While Hyper-V has V1 and V2 APIs, neither one is consistent between Windows versions. For example... * Windows 2012 only supports a subset of the V2 API * Windows 2012 implements some

Re: [PATCH] docs/system: Deprecate raspi2/raspi3 machine aliases

2020-10-30 Thread Peter Maydell
On Mon, 19 Oct 2020 at 09:23, Philippe Mathieu-Daudé wrote: > > Since commit aa35ec2213b ("hw/arm/raspi: Use more > specific machine names") the raspi2/raspi3 machines > have been renamed as raspi2b/raspi3b. > > As more Raspberry Pi 2/3 models are emulated, in order > to avoid confusion deprecate