RE: [libvirt][PATCH v13 3/6] Convert QMP capabilities to domain capabilities

2022-07-25 Thread Yang, Lin A
> BTW: I've discussed with Yang that I'll fix up these patches and resend. > Is that agreement still on? Yes, it's still on. Please go ahead. I just didn't get chance to sync with Haibin after we made agreement last week. Thanks, Lin.

Re: [PATCH v2] coding-style: Allow some use of ternary operators

2022-07-25 Thread Daniel P . Berrangé
On Mon, Jul 25, 2022 at 05:21:37PM +0200, Michal Privoznik wrote: > While we all understand that excessive use of ternary operator > may worsen code readability (e.g. nested, multi-line expression), > there are few cases where using it actually improves code > readability. For instance, when a

[PATCH v2] coding-style: Allow some use of ternary operators

2022-07-25 Thread Michal Privoznik
While we all understand that excessive use of ternary operator may worsen code readability (e.g. nested, multi-line expression), there are few cases where using it actually improves code readability. For instance, when a function takes a long list of arguments out of which one depends on a boolean

Re: [libvirt PATCH 0/3] qemu: Properly reset migration parameters on reconnect

2022-07-25 Thread Michal Prívozník
On 7/22/22 17:08, Jiri Denemark wrote: > https://bugzilla.redhat.com/show_bug.cgi?id=2107892 > > Jiri Denemark (3): > qemu_migration: Store original migration params in status XML > qemu_migration_params: Refactor qemuMigrationParamsApply > qemu_migration_params: Refactor

Re: [PATCH 1/5] qemuMigrationDstFinishFresh: Avoid multi-line ternary operator in function call

2022-07-25 Thread Peter Krempa
On Mon, Jul 25, 2022 at 16:19:38 +0200, Peter Krempa wrote: > On Mon, Jul 25, 2022 at 15:51:28 +0200, Michal Prívozník wrote: > > On 7/25/22 14:45, Peter Krempa wrote: > > > Rewrite the code using a temporary variable. > > > > > > Signed-off-by: Peter Krempa > > > --- > > >

Re: [PATCH 1/5] qemuMigrationDstFinishFresh: Avoid multi-line ternary operator in function call

2022-07-25 Thread Peter Krempa
On Mon, Jul 25, 2022 at 15:51:28 +0200, Michal Prívozník wrote: > On 7/25/22 14:45, Peter Krempa wrote: > > Rewrite the code using a temporary variable. > > > > Signed-off-by: Peter Krempa > > --- > > src/qemu/qemu_migration.c | 11 --- > > 1 file changed, 8 insertions(+), 3

Re: [PATCH] coding-style: Allow some use of ternary operators

2022-07-25 Thread Daniel P . Berrangé
On Mon, Jul 25, 2022 at 03:13:58PM +0200, Michal Privoznik wrote: > While we all understand that excessive use of ternary operator > may worsen code readability (e.g. nested, multi-line expression), > there are few cases where using it actually improves code > readability. For instance, when a

Re: [PATCH] rpc: Pass OPENSSL_CONF through to ssh invocations

2022-07-25 Thread Michal Prívozník
On 7/25/22 15:38, Laszlo Ersek wrote: > On 07/25/22 15:09, Richard W.M. Jones wrote: >> It's no longer possible for libvirt to connect over the ssh transport >> from RHEL 9 to RHEL 5. This is because SHA1 signatures have been >> effectively banned in RHEL 9 at the openssl level. They are

Re: [PATCH 0/5] qemu: Migration code (ternary operator) cleanups

2022-07-25 Thread Michal Prívozník
On 7/25/22 14:45, Peter Krempa wrote: > I've noticed few things that could be improved during review of Jirka's > post copy migration changes but didn't want to interfer with the series > at that point. > > Peter Krempa (5): > qemuMigrationDstFinishFresh: Avoid multi-line ternary operator in >

Re: [PATCH 1/5] qemuMigrationDstFinishFresh: Avoid multi-line ternary operator in function call

2022-07-25 Thread Michal Prívozník
On 7/25/22 14:45, Peter Krempa wrote: > Rewrite the code using a temporary variable. > > Signed-off-by: Peter Krempa > --- > src/qemu/qemu_migration.c | 11 --- > 1 file changed, 8 insertions(+), 3 deletions(-) > > diff --git a/src/qemu/qemu_migration.c b/src/qemu/qemu_migration.c >

Re: [libvirt PATCH 1/2] conf: support stateless UEFI firmware

2022-07-25 Thread Michal Prívozník
On 7/22/22 18:23, Daniel P. Berrangé wrote: > Normally when an UEFI firmware is marked as read-only, an associated > NVRAM file will be created. Some builds of UEFI firmware, however, wish > to remain stateless and so will be read-only, but never have any NVRAM > file. To represent this concept a

Re: [libvirt PATCH 0/2] qemu: support stateless UEFI firmware

2022-07-25 Thread Michal Prívozník
On 7/22/22 18:23, Daniel P. Berrangé wrote: > This is to enable SEV builds of UEFI which provide only a single CODE.fd > file, with not VARS.fd. > > Daniel P. Berrangé (2): > conf: support stateless UEFI firmware > qemu: support use of stateless EFI firmware > > docs/formatdomain.rst

Re: [PATCH] rpc: Pass OPENSSL_CONF through to ssh invocations

2022-07-25 Thread Laszlo Ersek
On 07/25/22 15:09, Richard W.M. Jones wrote: > It's no longer possible for libvirt to connect over the ssh transport > from RHEL 9 to RHEL 5. This is because SHA1 signatures have been > effectively banned in RHEL 9 at the openssl level. They are required > to check the RHEL 5 host key. Note

Re: [PATCH] coding-style: Allow some use of ternary operators

2022-07-25 Thread Claudio Fontana
A common sense improvement. Reviewed-by: Claudio Fontana On 7/25/22 15:13, Michal Privoznik wrote: > While we all understand that excessive use of ternary operator > may worsen code readability (e.g. nested, multi-line expression), > there are few cases where using it actually improves code >

[PATCH] coding-style: Allow some use of ternary operators

2022-07-25 Thread Michal Privoznik
While we all understand that excessive use of ternary operator may worsen code readability (e.g. nested, multi-line expression), there are few cases where using it actually improves code readability. For instance, when a function takes a long list of arguments out of which one depends on a boolean

[PATCH] rpc: Pass OPENSSL_CONF through to ssh invocations

2022-07-25 Thread Richard W.M. Jones
It's no longer possible for libvirt to connect over the ssh transport from RHEL 9 to RHEL 5. This is because SHA1 signatures have been effectively banned in RHEL 9 at the openssl level. They are required to check the RHEL 5 host key. Note this is a separate issue from openssh requiring

[PATCH 5/5] qemu: monitor: Split up enum strings definitions

2022-07-25 Thread Peter Krempa
The VIR_ENUM_IMPL macros directly above them list one string per line. Use the same also for qemuMonitorMigrationStatus and qemuMonitorVMStatus. Signed-off-by: Peter Krempa --- src/qemu/qemu_monitor.c | 35 ++- 1 file changed, 26 insertions(+), 9 deletions(-)

[PATCH 2/5] qemuMigrationDstPersist: Avoid multi-line ternary operator in function call

2022-07-25 Thread Peter Krempa
Signed-off-by: Peter Krempa --- src/qemu/qemu_migration.c | 16 +--- 1 file changed, 9 insertions(+), 7 deletions(-) diff --git a/src/qemu/qemu_migration.c b/src/qemu/qemu_migration.c index 800f66349d..a14b774a22 100644 --- a/src/qemu/qemu_migration.c +++ b/src/qemu/qemu_migration.c

[PATCH 1/5] qemuMigrationDstFinishFresh: Avoid multi-line ternary operator in function call

2022-07-25 Thread Peter Krempa
Rewrite the code using a temporary variable. Signed-off-by: Peter Krempa --- src/qemu/qemu_migration.c | 11 --- 1 file changed, 8 insertions(+), 3 deletions(-) diff --git a/src/qemu/qemu_migration.c b/src/qemu/qemu_migration.c index 20dc91f1ce..800f66349d 100644 ---

[PATCH 4/5] qemuMigrationSrcIOFunc: Avoid unnecessary string construction

2022-07-25 Thread Peter Krempa
Use full strings for better greppability. Signed-off-by: Peter Krempa --- src/qemu/qemu_migration.c | 4 ++-- 1 file changed, 2 insertions(+), 2 deletions(-) diff --git a/src/qemu/qemu_migration.c b/src/qemu/qemu_migration.c index 0d696e1d46..f2ccbe11b9 100644 --- a/src/qemu/qemu_migration.c

[PATCH 3/5] qemu: migration: Overwrite 'dname' only when NULL

2022-07-25 Thread Peter Krempa
Signed-off-by: Peter Krempa --- src/qemu/qemu_migration.c | 6 -- 1 file changed, 4 insertions(+), 2 deletions(-) diff --git a/src/qemu/qemu_migration.c b/src/qemu/qemu_migration.c index a14b774a22..0d696e1d46 100644 --- a/src/qemu/qemu_migration.c +++ b/src/qemu/qemu_migration.c @@ -5422,7

[PATCH 0/5] qemu: Migration code (ternary operator) cleanups

2022-07-25 Thread Peter Krempa
I've noticed few things that could be improved during review of Jirka's post copy migration changes but didn't want to interfer with the series at that point. Peter Krempa (5): qemuMigrationDstFinishFresh: Avoid multi-line ternary operator in function call qemuMigrationDstPersist: Avoid

Re: [libvirt][PATCH v11 1/4] qemu: provide support to query the SGX capability

2022-07-25 Thread Daniel P . Berrangé
On Mon, Jul 25, 2022 at 02:34:33PM +0200, Michal Prívozník wrote: > On 5/11/22 18:05, Peter Krempa wrote: > > On Tue, May 10, 2022 at 23:11:09 -0700, Lin Yang wrote: > >> From: Haibin Huang > >> > >> QEMU version >= 6.2.0 provides support for creating enclave on > >> SGX x86 platform using

Re: [libvirt][PATCH v11 1/4] qemu: provide support to query the SGX capability

2022-07-25 Thread Michal Prívozník
On 5/11/22 18:05, Peter Krempa wrote: > On Tue, May 10, 2022 at 23:11:09 -0700, Lin Yang wrote: >> From: Haibin Huang >> >> QEMU version >= 6.2.0 provides support for creating enclave on >> SGX x86 platform using Software Guard Extensions (SGX) feature. >> This patch adds support to query the SGX

Re: [PATCH] cmdQemuMonitorCommandQMPWrap: Reset ignored errors from JSON parsing

2022-07-25 Thread Peter Krempa
On Wed, Mar 02, 2022 at 09:39:24 +0100, Martin Kletzander wrote: > On Tue, Mar 01, 2022 at 02:33:28PM +0100, Peter Krempa wrote: > > 'cmdQemuMonitorCommandQMPWrap' is checking whether the user provided > > string is not valid JSON to avoid wrapping it. In cases where it's not > > JSON we ignore

Re: [PATCH 3/3] ci: Drop Debian 10

2022-07-25 Thread Andrea Bolognani
On Fri, Jul 22, 2022 at 12:56:00PM +0200, Peter Krempa wrote: > Debian 10 reaches EOL in August of 2022. > > Signed-off-by: Peter Krempa > --- > .../debian-10-cross-aarch64.Dockerfile| 125 -- > .../debian-10-cross-armv6l.Dockerfile | 124 - >

Re: [PATCH 2/3] ci: Move active Debian-10 jobs to Debian-11

2022-07-25 Thread Andrea Bolognani
On Fri, Jul 22, 2022 at 12:55:59PM +0200, Peter Krempa wrote: > Debian 10 will reach EOL in august of 2022 and thus libvirt will no > longer target it. Move CI jobs over to Debian-11. > > Signed-off-by: Peter Krempa > --- > ci/gitlab/builds.yml | 4 ++-- > ci/gitlab/containers.yml | 3 ++- >

Re: [PATCH 1/3] ci: Move builds from alpine-314 to alpine-315

2022-07-25 Thread Andrea Bolognani
On Fri, Jul 22, 2022 at 12:55:58PM +0200, Peter Krempa wrote: > +++ b/ci/manifest.yml > @@ -19,12 +19,9 @@ targets: >RPM: skip >CC: clang > > - alpine-314: x86_64 > - >alpine-315: > jobs: >- arch: x86_64 > -builds: false This makes for a cleaner

Re: [PATCH 3/3] ci: Drop Debian 10

2022-07-25 Thread Andrea Bolognani
On Mon, Jul 25, 2022 at 09:39:03AM +0200, Erik Skultety wrote: > On Fri, Jul 22, 2022 at 12:56:00PM +0200, Peter Krempa wrote: > > Debian 10 reaches EOL in August of 2022. > > While I don't have a serious issue with this patch which also conforms to our > platform policy I don't think we need to

Re: [PATCH 3/3] ci: Drop Debian 10

2022-07-25 Thread Erik Skultety
On Fri, Jul 22, 2022 at 12:56:00PM +0200, Peter Krempa wrote: > Debian 10 reaches EOL in August of 2022. > > Signed-off-by: Peter Krempa While I don't have a serious issue with this patch which also conforms to our platform policy I don't think we need to always be so keen on dropping platforms

Re: [libvirt][PATCH v13 3/6] Convert QMP capabilities to domain capabilities

2022-07-25 Thread Michal Prívozník
On 7/25/22 03:31, Huang, Haibin wrote: > Hi Michal Peter, > > Thank you for your comments. > > Way 1: > virBufferAsprintf(buf, "%s\n", sgx->flc ? "yes" : "no"); > > Way 2: > if (sgx->flc) { > virBufferAsprintf(buf, "yes\n"); > } else { > virBufferAsprintf(buf, "yes\n");

Re: [PATCH v2] virsh: Require --xpath for *dumpxml

2022-07-25 Thread Peter Krempa
On Fri, Jul 08, 2022 at 15:01:50 +0200, Michal Privoznik wrote: > Historically, the dumpxml command reject any unknown arguments, > for instance: > > virsh dumpxml fedora xxx > > However, after v8.5.0-rc1~31 the second argument ('xxx') is > treated as an XPath, but it's not that clearly

Re: [PATCH 1/3] ci: Move builds from alpine-314 to alpine-315

2022-07-25 Thread Erik Skultety
On Fri, Jul 22, 2022 at 12:55:58PM +0200, Peter Krempa wrote: > 'lcitool' dropped alpine-314 > > Signed-off-by: Peter Krempa Reviewed-by: Erik Skultety

Re: [PATCH 2/3] ci: Move active Debian-10 jobs to Debian-11

2022-07-25 Thread Erik Skultety
On Fri, Jul 22, 2022 at 12:55:59PM +0200, Peter Krempa wrote: > Debian 10 will reach EOL in august of 2022 and thus libvirt will no > longer target it. Move CI jobs over to Debian-11. > > Signed-off-by: Peter Krempa Reviewed-by: Erik Skultety

Re: [PATCH v2] virsh: Require --xpath for *dumpxml

2022-07-25 Thread Michal Prívozník
On 7/8/22 15:01, Michal Privoznik wrote: > Ping? Might be worth merging before tomorrow's freeze. Michal