Re: Re: [PATCH v2 0/5] Support crypto device

2023-01-24 Thread zhenwei pi
On 1/25/23 01:08, Michal Prívozník wrote: On 1/17/23 02:46, zhenwei pi wrote: v1 -> v2: - Rebase code against the latest commit: 46aee2a9255adf842ab44a9292acb46189a726f7 - Merge previous 1/7 and 2/7 into a single patch: conf: introduce crypto device - Add missing qemuxml2xmltest. -

Re: Re: [PATCH v2 4/5] qemu: command: support crypto device

2023-01-24 Thread zhenwei pi
On 1/25/23 01:08, Michal Prívozník wrote: On 1/17/23 02:46, zhenwei pi wrote: Support virtio-crypto device, also support cryptodev types: - builtin - lkcf Finally, we can launch a VM(QEMU) with one or more crypto devices by libvirt. Signed-off-by: zhenwei pi --- src/qemu/qemu_command.c |

Re: [PATCH 0/3] update RISC-V QEMU caps for QEMU 8.0.0

2023-01-24 Thread Daniel Henrique Barboza
On 1/24/23 11:03, Michal Prívozník wrote: On 1/10/23 12:31, Daniel Henrique Barboza wrote: Hi, This series updates RISC-V QEMU caps that weren't being updated since QEMU 5.0.0. To do that I had to add a RISC-V stub driver in src/cpu to avoid test failures after the caps update. This is a

Re: [PATCH v2 4/5] qemu: command: support crypto device

2023-01-24 Thread Michal Prívozník
On 1/17/23 02:46, zhenwei pi wrote: > Support virtio-crypto device, also support cryptodev types: > - builtin > - lkcf > > Finally, we can launch a VM(QEMU) with one or more crypto devices by > libvirt. > > Signed-off-by: zhenwei pi > --- > src/qemu/qemu_command.c | 110

Re: [PATCH v2 1/5] conf: introduce crypto device

2023-01-24 Thread Michal Prívozník
On 1/17/23 02:46, zhenwei pi wrote: > Introduce crypto device like: > > > > function='0x0'/> > > > > > function='0x0'/> > > > Currently, crypto model supports virtio only, type supports qemu only > (vhost-user in the plan). For the qemu type, backend supports

Re: [PATCH v2 2/5] capabilities: introduce crypto

2023-01-24 Thread Michal Prívozník
On 1/17/23 02:46, zhenwei pi wrote: > Changes in this commit: > - docs: formatdomaincaps.rst > - conf: crypto related domain caps > - qemu: crypto related > - tests: crypto related test > > Signed-off-by: zhenwei pi > --- > 90 files changed, 774 insertions(+) > > diff --git

Re: [PATCH v2 0/5] Support crypto device

2023-01-24 Thread Michal Prívozník
On 1/17/23 02:46, zhenwei pi wrote: > v1 -> v2: > - Rebase code against the latest commit: > 46aee2a9255adf842ab44a9292acb46189a726f7 > - Merge previous 1/7 and 2/7 into a single patch: > conf: introduce crypto device > - Add missing qemuxml2xmltest. > - Merge previous 3/7 and 4/7 into a

[PATCH v2 7/7] news: Add information about iTCO watchdog changes

2023-01-24 Thread Martin Kletzander
Signed-off-by: Martin Kletzander --- How about this for the release notes, if it is not explicit enough, then let me know, suggestions are welcome. NEWS.rst | 9 + 1 file changed, 9 insertions(+) diff --git a/NEWS.rst b/NEWS.rst index a0fe0d18a0ca..3d3d40d97e9e 100644 --- a/NEWS.rst

Re: [PATCH 0/7] qemu: Fix implicit q35 watchdog

2023-01-24 Thread Michal Prívozník
On 1/23/23 15:57, Martin Kletzander wrote: > More info in commit messages (duh). > > Martin Kletzander (7): > Avoid unnecessary nesting > Support multiple watchdog devices > Add iTCO watchdog support > qemu: Enable iTCO watchdog by disabling its noreboot pin strap > qemu: Add implicit

Re: [PATCH 2/7] Support multiple watchdog devices

2023-01-24 Thread Michal Prívozník
On 1/23/23 15:57, Martin Kletzander wrote: > This is already possible with qemu, and actually already happening with q35 > machines and a specified watchdog since q35 already includes a watchdog we do > not include in the XML. In order to express such posibility multiple > watchdogs > need to be

Re: [PATCH 1/7] Avoid unnecessary nesting

2023-01-24 Thread Michal Prívozník
On 1/23/23 15:57, Martin Kletzander wrote: > Signed-off-by: Martin Kletzander How about prefixing the subject with "qemuDomainAttachWatchdog: "? > --- > src/qemu/qemu_hotplug.c | 10 +- > 1 file changed, 5 insertions(+), 5 deletions(-) > > diff --git a/src/qemu/qemu_hotplug.c

Re: [PATCH 0/3] update RISC-V QEMU caps for QEMU 8.0.0

2023-01-24 Thread Michal Prívozník
On 1/10/23 12:31, Daniel Henrique Barboza wrote: > Hi, > > This series updates RISC-V QEMU caps that weren't being updated since > QEMU 5.0.0. > > To do that I had to add a RISC-V stub driver in src/cpu to avoid test > failures after the caps update. This is a very bare-bone driver that > is

Re: [PATCH] rpc: Fix error message in virNetServerSetClientLimits

2023-01-24 Thread Ján Tomko
On a Tuesday in 2023, Martin Kletzander wrote: Commit f007940cb25a tried to change the error message so that it is unified later in 35afa1d2d6c1, but various rewrites missed this particular error message which does not make sense. Fix it so that it is the same as the other two messages checking

[PATCH] rpc: Fix error message in virNetServerSetClientLimits

2023-01-24 Thread Martin Kletzander
Commit f007940cb25a tried to change the error message so that it is unified later in 35afa1d2d6c1, but various rewrites missed this particular error message which does not make sense. Fix it so that it is the same as the other two messages checking the same thing in this file. Resolves:

Re: [PATCH 0/8] vbox: Report VirtualBox exceptions too

2023-01-24 Thread Martin Kletzander
On Mon, Jan 23, 2023 at 10:35:47AM +0100, Michal Privoznik wrote: See 5/8 for motivation. Michal Prívozník (8): vbox: Introduce VBOX_QUERY_INTERFACE() vbox: Introduce IVirtualBoxErrorInfo interface vbox: Introduce vboxUniformedPFN::GetException() vbox: Introduce

Re: [PATCH 8/8] vbox: Stop reporting RC in error messages

2023-01-24 Thread Martin Kletzander
On Mon, Jan 23, 2023 at 10:35:55AM +0100, Michal Privoznik wrote: As shown in the commit that introduced vboxReportError(), we are appending the retval of a failed VirtualBox API onto our error messages. Well, this is no longer needed because vboxReportError() already appends the VirtualBox

Re: [PATCH 5/8] vbox: Introduce vboxReportError()

2023-01-24 Thread Martin Kletzander
On Mon, Jan 23, 2023 at 10:35:52AM +0100, Michal Privoznik wrote: When a VirtualBox API fails it produced an exception. Until now, we did not have correct APIs wired up to get the exception and its error message. Thus, we were left with plain: virReportError("virtualbox API failed, rc=%08x",

Re: [PATCH 2/8] vbox: Introduce IVirtualBoxErrorInfo interface

2023-01-24 Thread Martin Kletzander
On Mon, Jan 23, 2023 at 10:35:49AM +0100, Michal Privoznik wrote: The IVirtualBoxErrorInfo interface allows us to query error messages from VirtualBox. Since VirtualBox has stacked errors we need the GetNext() method too. The odd one, that sticks out is GetIID() as it is not part of the

Re: [PATCH 0/3] qemu: Fix alias generation for 'dimm' devices

2023-01-24 Thread Martin Kletzander
On Thu, Jan 19, 2023 at 03:27:51PM +0100, Peter Krempa wrote: Peter Krempa (3): qemu: hotplug: Remove legacy quirk for 'dimm' address generation qemu: alias: Remove 'oldAlias' argument of qemuAssignDeviceMemoryAlias qemu: Remove 'memAliasOrderMismatch' field from VM private data

Re: [PATCH 00/15] vbox: Add support for version 7.0 SDK and drop old

2023-01-24 Thread Martin Kletzander
On Mon, Jan 23, 2023 at 10:34:09AM +0100, Michal Privoznik wrote: For full experience you'll need to apply these on top of: https://listman.redhat.com/archives/libvir-list/2023-January/237248.html Michal Prívozník (15): vbox: Drop misleading G_GNUC_UNUSED annotation vbox: Drop

Re: [PATCH] network: Increase max route size when checking IPv6 forwarding

2023-01-24 Thread Michal Prívozník
On 1/21/23 01:58, Brooks Swinnerton wrote: > In d9ee51e, virNetDevIPCheckIPv6Forwarding was updated to walk the > contents of /proc/net/ipv6_route so that it could check to see if the > RTF_ADDRCONF was set on any IPv6 routes to ultimately determine if > enabling forwarding would result in an

Re: [PATCH 03/15] vbox: Drop @iid from UIMachine::LaunchVMProcess()

2023-01-24 Thread Martin Kletzander
On Tue, Jan 24, 2023 at 08:47:19AM +0100, Michal Prívozník wrote: On 1/23/23 11:00, Martin Kletzander wrote: On Mon, Jan 23, 2023 at 10:34:12AM +0100, Michal Privoznik wrote: The @iid argument of UIMachine::LaunchVMProcess() callback is unused. Drop it and also its propagation from parent

Re: [PATCH V2 1/1] qemuProcessEventSubmit : rename vm to event->vm

2023-01-24 Thread Michal Prívozník
On 1/17/23 10:22, Shaleen Bathla wrote: > In error case, free event->vm instead of vm. > This makes it easier for the reader to understand what we should free. > > Signed-off-by: Shaleen Bathla > --- > src/qemu/qemu_process.c | 2 +- > 1 file changed, 1 insertion(+), 1 deletion(-) > I tweaked