Re: [libvirt] [PATCH 1/3] xml: output memory unit for clarity

2012-02-23 Thread Matthias Bolte
2012/2/23 Eric Blake ebl...@redhat.com: Make it obvious to 'dumpxml' readers what unit we are using, since our default of KiB (1024) differs from qemu's default of MiB. diff --git a/tests/xml2vmxdata/xml2vmx-svga.xml b/tests/xml2vmxdata/xml2vmx-svga.xml index b7db4c8..9f93ef9 100644 ---

Re: [libvirt] [PATCH v2 3/3] qemu: Implement virDomainPMWakeup API

2012-02-23 Thread Michal Privoznik
On 15.02.2012 16:04, Michal Privoznik wrote: using 'system-wakeup' monitor command. It is supported only in JSON, as we are enabling it if possible. Moreover, this command is available in qemu-1.1+ which definitely has JSON. --- src/qemu/qemu_driver.c | 55

[libvirt] [Patch v2] vmx: Better Workstation vmx handling

2012-02-23 Thread Jean-Baptiste Rouault
This patch adds support for more network configurations in vmx files. Changes since v1: Adapt virVMXFormatEthernet() to handle empty bridge names and user interface type. Add new test cases to vmx2xmltest and xml2vmxtest. Jean-Baptiste Rouault (1): vmx: Better Workstation vmx handling

[libvirt] [Patch v2] vmx: Better Workstation vmx handling

2012-02-23 Thread Jean-Baptiste Rouault
This patch adds support for vmx files with empty networkName values (which is the case for vmx generated by Workstation). It also adds support for vmx containing NATed network interfaces. Update test suite accordingly --- src/vmx/vmx.c | 39 --

Re: [libvirt] RFC: memory units=... [was: libvirt doesn't boot kVM, hangs, qemu on 100% CPU]

2012-02-23 Thread Christophe Fergeau
Hey, On Wed, Feb 22, 2012 at 04:42:59PM -0700, Eric Blake wrote: There ain't no way on earth you're going to boot a kernel in 2 megabytes of memory! I propose enhancing the XML; on output, libvirt should produce: memory units='k'2048/memory = 2048 * kibibyte the output unit must remain

Re: [libvirt] [PATCH 3/3] xml: allow scaled memory on input

2012-02-23 Thread Christophe Fergeau
On Wed, Feb 22, 2012 at 09:59:47PM -0700, Eric Blake wrote: @@ -424,12 +424,27 @@ dl dtcodememory/code/dt ddThe maximum allocation of memory for the guest at boot time. -The units for this value are kilobytes (i.e. blocks of 1024 bytes)/dd +The units for

Re: [libvirt] [PATCH 1/3] xml: output memory unit for clarity

2012-02-23 Thread Christophe Fergeau
On Thu, Feb 23, 2012 at 08:56:50AM +0100, Matthias Bolte wrote: 2012/2/23 Eric Blake ebl...@redhat.com: Make it obvious to 'dumpxml' readers what unit we are using, since our default of KiB (1024) differs from qemu's default of MiB. diff --git a/tests/xml2vmxdata/xml2vmx-svga.xml

Re: [libvirt] [PATCH 3/3] xml: allow scaled memory on input

2012-02-23 Thread Eric Blake
On 02/22/2012 09:59 PM, Eric Blake wrote: Output is still in kibibytes, but input can now be in different scales for ease of typing. * src/conf/domain_conf.c (virDomainParseMemory): New helper. (virDomainDefParseXML): Use it when parsing. * docs/schemas/domaincommon.rng: Expand XML. *

Re: [libvirt] [PATCH 1/3] xml: output memory unit for clarity

2012-02-23 Thread Eric Blake
On 02/23/2012 02:55 AM, Christophe Fergeau wrote: On Thu, Feb 23, 2012 at 08:56:50AM +0100, Matthias Bolte wrote: 2012/2/23 Eric Blake ebl...@redhat.com: Make it obvious to 'dumpxml' readers what unit we are using, since our default of KiB (1024) differs from qemu's default of MiB. diff

Re: [libvirt] [PATCH v2 4/4] qemu: Forbid migration with cache != none

2012-02-23 Thread Jiri Denemark
On Wed, Feb 22, 2012 at 12:54:35 -0700, Eric Blake wrote: On 02/22/2012 07:51 AM, Jiri Denemark wrote: Migrating domains with disks using cache != none is unsafe unless the disk images are stored on coherent clustered filesystem. Thus we forbid migrating such domains unless

[libvirt] [PATCH v5 0/7] Console corruption patchset

2012-02-23 Thread Peter Krempa
Yet another spin of the console corruption patches. Current state: * 1/7 - pidfile: Make checking binary path in virPidFileRead optional - No changes to v4. - ACKed by Eric * 2/7 - Add flags for virDomainOpenConsole - No changes to v4. - ACKed by Eric * 3/7 -

[libvirt] [PATCH v5 4/7] fdstream: Emit stream abort callback even if poll() doesnt.

2012-02-23 Thread Peter Krempa
This patch causes the fdstream driver to call the stream event callback if virStreamAbort() is called on a stream using this driver. A remote handler for a stream can only detect changes via stream events, so this event callback is necessary in order to enable a daemon to abort a stream in such a

[libvirt] [PATCH v5 2/7] Add flags for virDomainOpenConsole

2012-02-23 Thread Peter Krempa
This patch adds a set of flags to be used with the virDomainOpenConsole API call to specify if the user wishes to interrupt an existing console session or just to try open a new one. VIR_DOMAIN_CONSOLE_SAFE - specifies that the console connection should be opened only if

[libvirt] [PATCH v5 1/7] pidfile: Make checking binary path in virPidFileRead optional

2012-02-23 Thread Peter Krempa
This patch changes behavior of virPidFileRead to enable passing NULL as path to the binary the pid file should be checked against to skip this check. This enables using this function for reading files that have same semantics as pid files, but belong to unknown processes. --- No change.

[libvirt] [PATCH v5 3/7] virsh: add support for VIR_DOMAIN_CONSOLE_* flags

2012-02-23 Thread Peter Krempa
This patch adds support for the newly introduced VIR_DOMAIN_CONSOLE_FORCE and VIR_DOMAIN_CONSOLE_SAFE flags. The console command now has an optional parameter --force that specifies that the user wants to forcibly interrupt an ongoing console session and create a new one. Flag --safe requests that

[libvirt] [PATCH v5 5/7] fdstream: Add internal callback on stream close

2012-02-23 Thread Peter Krempa
This patch adds another callback to a FDstream object. The original callback is used by the daemon stream driver to handle events. This callback is called if and only if the stream is about to be closed. This might be used to handle cleanup steps after a fdstream exits. This will be used later on

[libvirt] [PATCH v5 6/7] util: Add helpers for safe domain console operations

2012-02-23 Thread Peter Krempa
This patch adds a set of functions used in creating console streams for domains using PTYs and ensures mutually exclusive access to the PTYs. If mutualy exclusive access is not used, two clients may open the same console, which results in corruption on both clients as both of them race to read

[libvirt] [PATCH v5 7/7] qemu: Add ability to abort existing console while creating new one

2012-02-23 Thread Peter Krempa
This patch fixes console corruption, that happens if two concurrent sessions are opened for a single console on a domain. Result of this corruption was that each of the console streams recieved just a part of the data written to the pipe so every console rendered unusable. New helper function for

Re: [libvirt] RFC: Post-install behavior of libvirt(-client)

2012-02-23 Thread Martin Kletzander
On 02/20/2012 06:55 PM, Eric Blake wrote: On 02/14/2012 03:17 PM, Eric Blake wrote: On 02/14/2012 01:37 AM, Martin Kletzander wrote: Hello everyone, I have a small bug #786770 [1] assigned and I discussed this with few people from our team but I'm still not sure what should be the proper

Re: [libvirt] libvirt TCK wrapper for autotest review

2012-02-23 Thread Guannan Ren
Hi Lucas, Thanks for your these good modifications. There is one place I noticed where you output each testcase of *.t into a separate file with .tap extension. hence, it has a corresponding log file with little content for each testcase. it seem a little harder

Re: [libvirt] libvirt TCK wrapper for autotest review

2012-02-23 Thread Daniel P. Berrange
On Wed, Feb 22, 2012 at 06:45:58PM -0200, Lucas Meneghel Rodrigues wrote: * Instead of making all tests output to the same DEBUG log, make them output to separate .tap files on the results directory So, the current output of the tests is like this: $ sudo client/bin/autotest run libvirt_tck

Re: [libvirt] RFC: Post-install behavior of libvirt(-client)

2012-02-23 Thread Eric Blake
On 02/23/2012 07:25 AM, Martin Kletzander wrote: To me it seems more reasonable to just don't start anything. I don't want any service on my system started just because I installed it. I think we've reached a state of violent agreement :) I'm not talking about enabling, that's something

Re: [libvirt] [PATCH] qemu: nicer error message on failed graceful destroy

2012-02-23 Thread Eric Blake
On 02/22/2012 06:10 PM, Laine Stump wrote: On 02/22/2012 01:49 PM, Eric Blake wrote: https://bugzilla.redhat.com/show_bug.cgi?id=795656 mentions that a graceful destroy request can time out, meaning that the error message is user-visible and should be more appropriate than just internal

Re: [libvirt] libvirt TCK wrapper for autotest review

2012-02-23 Thread Guannan Ren
On 02/23/2012 11:08 PM, Daniel P. Berrange wrote: On Wed, Feb 22, 2012 at 06:45:58PM -0200, Lucas Meneghel Rodrigues wrote: * Instead of making all tests output to the same DEBUG log, make them output to separate .tap files on the results directory So, the current output of the tests is like

Re: [libvirt] [PATCH] Use the same MAC address that is defined in domain XML for attached-mac field.

2012-02-23 Thread Ansis Atteka
On Tue, Feb 21, 2012 at 11:53 AM, Ansis Atteka aatt...@nicira.com wrote: On Mon, Feb 20, 2012 at 1:46 AM, Daniel P. Berrange berra...@redhat.comwrote: On Sat, Feb 18, 2012 at 10:07:45PM -0500, Laine Stump wrote: On 02/17/2012 02:51 PM, Ansis Atteka wrote: On Fri, Feb 17, 2012 at

[libvirt] Per-guest configurable user/group for QEMU processes

2012-02-23 Thread Marcelo Cerri
Hi, I'm starting working on an improvement for libvirt to be able to support per-guest configurable user and group IDs for QEMU processes. Currently, libvirt uses a configurable pair of user and group, which is defined in qemu.conf, for all qemu processes when running in privileged mode.

Re: [libvirt] Per-guest configurable user/group for QEMU processes

2012-02-23 Thread Daniel P. Berrange
On Thu, Feb 23, 2012 at 05:41:27PM -0200, Marcelo Cerri wrote: Hi, I'm starting working on an improvement for libvirt to be able to support per-guest configurable user and group IDs for QEMU processes. Currently, libvirt uses a configurable pair of user and group, which is defined in

Re: [libvirt] Per-guest configurable user/group for QEMU processes

2012-02-23 Thread Marcelo Cerri
On 02/23/2012 05:47 PM, Daniel P. Berrange wrote: On Thu, Feb 23, 2012 at 05:41:27PM -0200, Marcelo Cerri wrote: Hi, I'm starting working on an improvement for libvirt to be able to support per-guest configurable user and group IDs for QEMU processes. Currently, libvirt uses a configurable

Re: [libvirt] Per-guest configurable user/group for QEMU processes

2012-02-23 Thread Daniel P. Berrange
On Thu, Feb 23, 2012 at 06:38:45PM -0200, Marcelo Cerri wrote: On 02/23/2012 05:47 PM, Daniel P. Berrange wrote: On Thu, Feb 23, 2012 at 05:41:27PM -0200, Marcelo Cerri wrote: Hi, I'm starting working on an improvement for libvirt to be able to support per-guest configurable user and group

[libvirt] [PATCH] Misleading error message when name is missing

2012-02-23 Thread Benjamin Cama
Hi, [forwarding this here from RH bug #796732] When creating a network (virsh net-create) with an erroneous XML containing an empty name element, the error message is misleading: error: Failed to create network from foo.xml error: missing domain name information It took me a bit of time to

Re: [libvirt] [PATCH v5 2/2] Add de-association handling to macvlan code

2012-02-23 Thread Laine Stump
On 02/22/2012 08:17 AM, D. Herrendoerfer wrote: From: D. Herrendoerfer d.herrendoer...@herrendoerfer.name Add de-association handling for 802.1qbg (vepa) via lldpad netlink messages. Also adds the possibility to perform an association request without waiting for a confirmation. The main

Re: [libvirt] [PATCH v5 1/2] util: Add netlink event handling to virnetlink.c

2012-02-23 Thread Laine Stump
On 02/22/2012 08:17 AM, D. Herrendoerfer wrote: From: D. Herrendoerfer d.herrendoer...@herrendoerfer.name This code adds a netlink event interface to libvirt. It is based upon the event_poll code and makes use of it. An event is generated for each netlink message sent to the libvirt pid.

[libvirt] [PATCH 1/1] Update bug reporting page

2012-02-23 Thread Dave Allan
Remove suggestion that people file bugs against RHEL 5 and add a suggestion that people increase the visibility of their bugs by mentioning them on libvir-list. --- docs/bugs.html.in | 83 1 files changed, 57 insertions(+), 26 deletions(-)

Re: [libvirt] [PATCH 1/1] Update bug reporting page

2012-02-23 Thread Eric Blake
On 02/23/2012 03:49 PM, Dave Allan wrote: Remove suggestion that people file bugs against RHEL 5 and add a suggestion that people increase the visibility of their bugs by mentioning them on libvir-list. --- docs/bugs.html.in | 83 1

Re: [libvirt] [PATCH] Misleading error message when name is missing

2012-02-23 Thread Eric Blake
On 02/23/2012 09:37 AM, Benjamin Cama wrote: Hi, [forwarding this here from RH bug #796732] Thanks for taking the time to contribute, and for putting up with our split personality on bug reports to BZ vs. patches to the list :) When creating a network (virsh net-create) with an erroneous

Re: [libvirt] [PATCH] Misleading error message when name is missing

2012-02-23 Thread Benjamin Cama
Le jeudi 23 février 2012 à 16:32 -0700, Eric Blake a écrit : On 02/23/2012 09:37 AM, Benjamin Cama wrote: [forwarding this here from RH bug #796732] Thanks for taking the time to contribute, and for putting up with our split personality on bug reports to BZ vs. patches to the list :)

[libvirt] [PATCH 1/1] Add a few additional comments to bugs.html

2012-02-23 Thread Dave Allan
Clarified that bugs in this context means any change to libvirt, whether called a bug, feature, etc. Noted the existence of the Fedora virt preview repo as a way of trying out newer prebuilt packages. Noted that you don't need to be subscribed to the list to post. --- docs/bugs.html.in | 22

[libvirt] Correct a check for capacity arg of storageVolumeResize()

2012-02-23 Thread Zeeshan Ali (Khattak)
From: Zeeshan Ali (Khattak) zeesha...@gnome.org --- src/storage/storage_driver.c |2 +- 1 files changed, 1 insertions(+), 1 deletions(-) diff --git a/src/storage/storage_driver.c b/src/storage/storage_driver.c index df0e291..641944d 100644 --- a/src/storage/storage_driver.c +++

[libvirt] Virt io blk buffer

2012-02-23 Thread Pankaj Rawat
Hi all Can any one tell what is the default Vitio blk IO Buffer size And can we change it ? if yes how? DISCLAIMER: --- The contents of this e-mail and any attachment(s)