Re: [libvirt] [PATCH] qemu: handle multicast overflow on macvtap for NIC_RX_FILTER_CHANGED

2018-11-21 Thread Michael S. Tsirkin
On Wed, Nov 21, 2018 at 10:04:56AM -0500, Jason Baron wrote: > Guest network devices can set 'overflow' when there are a number of multicast > ips configured. For virtio_net, the limit is only 64. In this case, the list > of mac addresses is empty and the 'overflow' condition is set. Thus, the

Re: [libvirt] [PATCHv2 01/16] qemu: Add KVM CPUs into cache only if KVM is present

2018-11-21 Thread Jiri Denemark
On Wed, Nov 21, 2018 at 20:50:50 +0300, Roman Bolshakov wrote: > On Wed, Nov 21, 2018 at 05:04:07PM +0100, Jiri Denemark wrote: > > On Wed, Nov 21, 2018 at 17:01:44 +0300, Roman Bolshakov wrote: > > > From: Roman Bolshakov > > > > > > virQEMUCapsFormatCache/virQEMUCapsLoadCache adds/reads KVM

Re: [libvirt] [sandbox PATCH 1/2] builder: Use prefix '=> /' to identify lib path

2018-11-21 Thread Daniel P . Berrangé
On Tue, Nov 20, 2018 at 07:10:19PM +, Radostin Stoyanov wrote: > The output of ldd might contain a fully qualified path on the left > hand side of the '=>'. For example: > > (glibc 2.28) > $ ldd /usr/libexec/libvirt-sandbox-init-common | grep ld > /lib64/ld-linux-x86-64.so.2 =>

Re: [libvirt] Reporting of IP detected by network filter

2018-11-21 Thread Marcin Mirecki
Thanks for the comprehensive answer. On Tue, Nov 20, 2018 at 4:49 PM Laine Stump wrote: > On 11/20/18 10:17 AM, Daniel P. Berrangé wrote: > > On Tue, Nov 20, 2018 at 04:05:43PM +0100, Marcin Mirecki wrote: > >> Hello, > >> > >> The network filters feature has an option of automatically

Re: [libvirt] [sandbox PATCH 2/2] Use "/boot/vmlinuz-linux" as default kernel path

2018-11-21 Thread Daniel P . Berrangé
On Tue, Nov 20, 2018 at 07:10:20PM +, Radostin Stoyanov wrote: > On some linux distributions "/boot/vmlinuz-linux" is set as default > kernel path. If this file does not exist we fallback to the value > "/boot/vmlinuz-$KERNEL-VERSION" > > Signed-off-by: Radostin Stoyanov > --- >

Re: [libvirt] [libvirt-go PATCH] Add virDomainSetIOThreadParams binding

2018-11-21 Thread Daniel P . Berrangé
On Tue, Nov 20, 2018 at 01:50:03PM -0500, John Ferlan wrote: > Signed-off-by: John Ferlan > --- > > Well I've given it a "go", hopefully it's (more or less) right. The build > and test at least pass ;-) Code looks good apart from a data type mixup > > domain.go | 52

Re: [libvirt] [PATCHv2 01/16] qemu: Add KVM CPUs into cache only if KVM is present

2018-11-21 Thread Jiri Denemark
On Wed, Nov 21, 2018 at 17:01:44 +0300, Roman Bolshakov wrote: > From: Roman Bolshakov > > virQEMUCapsFormatCache/virQEMUCapsLoadCache adds/reads KVM CPUs to/from > capabilities cache regardless of QEMU_CAPS_KVM. That can cause undesired > side-effects when KVM CPUs are present in the cache on a

[libvirt] [PATCH] qemu: handle multicast overflow on macvtap for NIC_RX_FILTER_CHANGED

2018-11-21 Thread Jason Baron
Guest network devices can set 'overflow' when there are a number of multicast ips configured. For virtio_net, the limit is only 64. In this case, the list of mac addresses is empty and the 'overflow' condition is set. Thus, the guest will currently receive no multicast traffic in this state. When

[libvirt] [PATCHv2 02/16] conf: Add hvf domain type

2018-11-21 Thread Roman Bolshakov
QEMU supports Hypervisor.framework since 2.12 as hvf accel. Hypervisor.framework provides a lightweight interface to run a virtual cpu on macOS without the need to install third-party kernel extensions (KEXTs). It's supported since macOS 10.10 on machines with Intel VT-x feature set that includes

[libvirt] [PATCHv2 00/16] Introduce hvf domain type for Hypevisor.framework

2018-11-21 Thread Roman Bolshakov
Hypervisor.framework provides a lightweight interface to run a virtual cpu on macOS without the need to install third-party kernel extensions (KEXTs). It's supported since macOS 10.10 on machines with Intel VT-x feature set that includes Extended Page Tables (EPT) and Unrestricted Mode. QEMU

[libvirt] [PATCHv2 08/16] qemu: Introduce virQEMUCapsHaveAccel

2018-11-21 Thread Roman Bolshakov
The function should be used to check if qemu capabilities include a hardware acceleration, i.e. accel is not TCG. Signed-off-by: Roman Bolshakov --- src/qemu/qemu_capabilities.c | 12 +--- 1 file changed, 9 insertions(+), 3 deletions(-) diff --git a/src/qemu/qemu_capabilities.c

[libvirt] [PATCHv2 13/16] news: Mention hvf domain type

2018-11-21 Thread Roman Bolshakov
Signed-off-by: Roman Bolshakov --- docs/news.xml | 12 1 file changed, 12 insertions(+) diff --git a/docs/news.xml b/docs/news.xml index 4406aeb775..90e378187d 100644 --- a/docs/news.xml +++ b/docs/news.xml @@ -68,6 +68,18 @@ be viewed via the domain statistics.

[libvirt] [PATCHv2 15/16] docs: Note hvf support for domain elements

2018-11-21 Thread Roman Bolshakov
Many domain elements have "QEMU and KVM only" or "QEMU/KVM since x.y.z" remarks. Most of the elements work for HVF domain, so it makes sense to add respective notices for HVF domain. All the elements have been manually tested. Signed-off-by: Roman Bolshakov --- docs/formatdomain.html.in | 133

[libvirt] [PATCHv2 16/16] docs: Add support page for libvirt on macOS

2018-11-21 Thread Roman Bolshakov
While at it, rename OS-X on index page to macOS. Signed-off-by: Roman Bolshakov --- docs/docs.html.in | 3 + docs/index.html.in | 3 +- docs/macos.html.in | 229 + 3 files changed, 234 insertions(+), 1 deletion(-) create mode 100644

[libvirt] [PATCHv2 04/16] qemu: Query hvf capability on macOS

2018-11-21 Thread Roman Bolshakov
There's no QMP command for querying if hvf is supported, therefore we use sysctl interface that tells if Hypervisor.framwork works/available on the host. Signed-off-by: Roman Bolshakov --- src/qemu/qemu_capabilities.c | 34 ++ 1 file changed, 34 insertions(+)

[libvirt] [PATCHv2 06/16] qemu: Rename kvmCPU to accelCPU

2018-11-21 Thread Roman Bolshakov
QEMU supports a number of accelerators. It'd be good to have more generic name for kvmCPUModels and kvmCPU. Signed-off-by: Roman Bolshakov --- src/qemu/qemu_capabilities.c | 36 ++-- 1 file changed, 18 insertions(+), 18 deletions(-) diff --git

[libvirt] [PATCHv2 01/16] qemu: Add KVM CPUs into cache only if KVM is present

2018-11-21 Thread Roman Bolshakov
From: Roman Bolshakov virQEMUCapsFormatCache/virQEMUCapsLoadCache adds/reads KVM CPUs to/from capabilities cache regardless of QEMU_CAPS_KVM. That can cause undesired side-effects when KVM CPUs are present in the cache on a platform that doesn't support it, e.g. macOS or Linux without KVM

[libvirt] [PATCHv2 12/16] qemu: Correct CPU capabilities probing for hvf

2018-11-21 Thread Roman Bolshakov
With this change virsh domcapabilites shows: Signed-off-by: Roman Bolshakov Reviewed-by: Daniel P. Berrangé --- src/qemu/qemu_capabilities.c | 28 +--- 1 file changed, 25 insertions(+), 3 deletions(-) diff --git a/src/qemu/qemu_capabilities.c

[libvirt] [PATCHv2 03/16] qemu: Define hvf capability

2018-11-21 Thread Roman Bolshakov
Signed-off-by: Roman Bolshakov --- src/qemu/qemu_capabilities.c | 1 + src/qemu/qemu_capabilities.h | 1 + 2 files changed, 2 insertions(+) diff --git a/src/qemu/qemu_capabilities.c b/src/qemu/qemu_capabilities.c index 4ba8369e3a..0bbda80782 100644 --- a/src/qemu/qemu_capabilities.c +++

[libvirt] [PATCHv2 07/16] qemu: Introduce virQEMUCapsTypeIsAccelerated

2018-11-21 Thread Roman Bolshakov
It replaces hardcoded checks that select accelCPU/accelCPUModels (formerly known as kvmCPU/kvmCPUModels) for KVM. It'll be cleaner to use the function when multiple accelerators are supported in qemu driver. Explicit KVM domain checks should be done only when a feature is available only for KVM.

[libvirt] [PATCHv2 09/16] qemu: Introduce virQEMUCapsToVirtType

2018-11-21 Thread Roman Bolshakov
The function is needed to support multiple accelerators without cluttering codebase by conditionals. At the first glance that might cause an issue related to the ordering capabilities being checked on a system with many accelerators but in the current code base it should be just fine because

[libvirt] [PATCHv2 10/16] qemu: Introduce virQEMUCapsAccelStr

2018-11-21 Thread Roman Bolshakov
This makes possible to add more accelerators by touching less code and reduces code duplication. Signed-off-by: Roman Bolshakov --- src/qemu/qemu_capabilities.c | 21 ++--- 1 file changed, 14 insertions(+), 7 deletions(-) diff --git a/src/qemu/qemu_capabilities.c

[libvirt] [PATCHv2 11/16] qemu: Make error message accel-agnostic

2018-11-21 Thread Roman Bolshakov
With more acceleration types, KVM should be used only in error messages related to KVM. Signed-off-by: Roman Bolshakov --- src/qemu/qemu_capabilities.c | 4 ++-- 1 file changed, 2 insertions(+), 2 deletions(-) diff --git a/src/qemu/qemu_capabilities.c b/src/qemu/qemu_capabilities.c index

[libvirt] [PATCHv2 14/16] docs: Add hvf on QEMU driver page

2018-11-21 Thread Roman Bolshakov
It's worth to make the domain type a little bit more visible than a row in news. An example of hvf domain is available on QEMU driver page. While at it, mention Hypervisor.framework on index page. Signed-off-by: Roman Bolshakov --- docs/drvqemu.html.in | 49

[libvirt] [PATCHv2 05/16] qemu: Expose hvf domain type if hvf is supported

2018-11-21 Thread Roman Bolshakov
Signed-off-by: Roman Bolshakov Reviewed-by: Daniel P. Berrangé --- src/qemu/qemu_capabilities.c | 11 +++ 1 file changed, 11 insertions(+) diff --git a/src/qemu/qemu_capabilities.c b/src/qemu/qemu_capabilities.c index 5ebe3f1afe..645ce2c89e 100644 --- a/src/qemu/qemu_capabilities.c +++

Re: [libvirt] [PATCHv2 01/16] qemu: Add KVM CPUs into cache only if KVM is present

2018-11-21 Thread Roman Bolshakov
On Wed, Nov 21, 2018 at 05:04:07PM +0100, Jiri Denemark wrote: > On Wed, Nov 21, 2018 at 17:01:44 +0300, Roman Bolshakov wrote: > > From: Roman Bolshakov > > > > virQEMUCapsFormatCache/virQEMUCapsLoadCache adds/reads KVM CPUs to/from > > capabilities cache regardless of QEMU_CAPS_KVM. That can

Re: [libvirt] [PATCH for-4.0 v2] virtio: Provide version-specific variants of virtio PCI devices

2018-11-21 Thread Andrea Bolognani
On Tue, 2018-11-20 at 14:14 -0500, Michael S. Tsirkin wrote: > On Tue, Nov 20, 2018 at 01:27:05PM +0100, Andrea Bolognani wrote: > > On Mon, 2018-11-19 at 14:14 -0500, Michael S. Tsirkin wrote: > > > Well it works now - connect it to a bus and it figures out whether it > > > should do transitional

[libvirt] [PATCH go] Add back compat constants for iothreads

2018-11-21 Thread Daniel P . Berrangé
Signed-off-by: Daniel P. Berrangé --- domain_compat.h | 16 1 file changed, 16 insertions(+) Pushed as a build break fix for old libvirt diff --git a/domain_compat.h b/domain_compat.h index 371bcc4..19a3e24 100644 --- a/domain_compat.h +++ b/domain_compat.h @@ -917,4 +917,20