Re: [libvirt] [PATCH 1/2] test: match qemu VIR_DOMAIN_DEF_FEATURE* usage

2019-04-30 Thread Cole Robinson
On 4/30/19 12:20 PM, Andrea Bolognani wrote: > On Wed, 2019-04-17 at 10:57 -0400, Cole Robinson wrote: > [...] >> +virDomainDefParserConfig config = { >> +.features = VIR_DOMAIN_DEF_FEATURE_MEMORY_HOTPLUG | >> +VIR_DOMAIN_DEF_FEATURE_OFFLINE_VCPUPIN | >> +

Re: [libvirt] [PATCH 1/2] test: match qemu VIR_DOMAIN_DEF_FEATURE* usage

2019-04-30 Thread Andrea Bolognani
On Wed, 2019-04-17 at 10:57 -0400, Cole Robinson wrote: [...] > +virDomainDefParserConfig config = { > +.features = VIR_DOMAIN_DEF_FEATURE_MEMORY_HOTPLUG | > +VIR_DOMAIN_DEF_FEATURE_OFFLINE_VCPUPIN | > +VIR_DOMAIN_DEF_FEATURE_INDIVIDUAL_VCPUS | >

[libvirt] [PATCH] qemu: Do not override config XML in case of snapshot revert

2019-04-30 Thread Maxiwell S. Garcia
Snapshot create operation saves the live XML and uses it to replace the domain definition in case of revert. But the VM config XML is not saved and the revert operation does not address this issue. This commit prevents the config XML from being overridden by snapshot definition. An active domain

[libvirt] [PATCH] docs: Update drivers page to link to storage.html

2019-04-30 Thread John Ferlan
Rather than duplicate a list of storage pool backends on the drivers.html page, let's just link directly to the storage driver page similar to how the node device driver is done. Signed-off-by: John Ferlan --- docs/drivers.html.in | 16 +--- 1 file changed, 1 insertion(+), 15

Re: [libvirt] [PATCH] spec: fix f28 rpm without firewalld zone

2019-04-30 Thread Laine Stump
On 4/30/19 11:20 AM, Laine Stump wrote: On 4/30/19 11:08 AM, Cole Robinson wrote: Commit 3b71f2e42d added spec handling for with_firewalld_zone. We now call %firewalld_reload if with_firewalld is set. But the matching 'BuildRequires: firewalld-filesystem' is only applied if with_firewalld_zone

Re: [libvirt] [PATCH 1/2] vfio/mdev: add version field as mandatory attribute for mdev device

2019-04-30 Thread Cornelia Huck
On Wed, 24 Apr 2019 04:15:58 -0400 Yan Zhao wrote: > On Wed, Apr 24, 2019 at 03:56:24PM +0800, Cornelia Huck wrote: > > On Tue, 23 Apr 2019 23:10:37 -0400 > > Yan Zhao wrote: > > > > > On Tue, Apr 23, 2019 at 05:59:32PM +0800, Cornelia Huck wrote: > > > > On Fri, 19 Apr 2019 04:35:04 -0400

Re: [libvirt] [PATCH] RFC: use a slirp helper process

2019-04-30 Thread Daniel P . Berrangé
On Thu, Apr 18, 2019 at 03:24:13PM +0200, marcandre.lur...@redhat.com wrote: > From: Marc-André Lureau > > I am throwing this away for discussions, and early feedback. > > With the upcoming release of libslirp[1], we have an opportunity to > run SLIRP networking in a separate process. This will

[libvirt] [PATCH RFC] network: Delay creating private chains until starting network

2019-04-30 Thread Jim Fehlig
Automated performance tests found that network-centric workloads suffered a 20 percent decrease when the host libvirt was updated from 5.0.0 to 5.1.0. On the test hosts libvirtd is enabled to start at boot and the "default" network is defined, but it is not set to autostart. libvirt 5.1.0

[libvirt] [PATCH] qemu: Disable console device detach from live mode.

2019-04-30 Thread Julio Faracco
Console Char devices cannot be attached as qemuDomainChrRemove() function suggests. After moved to async mode, qemuDomainRemoveChrDevice() is not part of the removal process. So, we need to check if device is able to be detached before calling removal procedures. Resolves:

[libvirt] Availability of Release Candidate 2 of libvirt-5.3.0

2019-04-30 Thread Daniel Veillard
As planned, it's tagged in git and I have pushed the signed tarball and rpms to the new usual place :-) https://libvirt.org/sources/ CI is still green except for poor osinfo-db-tools-rpm :-) https://ci.centos.org/view/libvirt/ so that looks fine and I didn't heard any horror story about

[libvirt] [PATCH 1/1] util/virhostdev: consolidate duplicated KVM support code

2019-04-30 Thread Daniel Henrique Barboza
tests/virhostdevtest.c implements a function called 'virHostdevHostSupportsPassthroughKVM', that is equal to 'qemuHostdevHostSupportsPassthroughLegacy' that is declared inside qemu/qemu_hostdev.c. This patch removes the duplicated code from both files and and puts it inside util/virhostdev.c,

Re: [libvirt] [Qemu-devel] QMP; unsigned 64-bit ints; JSON standards compliance

2019-04-30 Thread Dr. David Alan Gilbert
* Daniel P. Berrangé (berra...@redhat.com) wrote: > The QEMU QMP service is based on JSON which is nice because that is a > widely supported "standard" data format. > > except QEMU's implementation (and indeed most impls) are not strictly > standards compliant. > > Specifically the

[libvirt] [PATCH] lib: Preserve error around virDomainNetReleaseActualDevice()

2019-04-30 Thread Michal Privoznik
This function is calling public API virNetworkLookupByName() which resets the error. Therefore, if virDomainNetReleaseActualDevice() is used in cleanup path it actually resets the original error that got us jump into 'cleanup' label. Signed-off-by: Michal Privoznik --- I've found this issue

Re: [libvirt] [PATCH] lib: Preserve error around virDomainNetReleaseActualDevice()

2019-04-30 Thread Peter Krempa
On Tue, Apr 30, 2019 at 16:51:12 +0200, Michal Privoznik wrote: > This function is calling public API virNetworkLookupByName() > which resets the error. Therefore, if > virDomainNetReleaseActualDevice() is used in cleanup path it > actually resets the original error that got us jump into >

Re: [libvirt] [Qemu-devel] QMP; unsigned 64-bit ints; JSON standards compliance

2019-04-30 Thread Daniel P . Berrangé
On Tue, Apr 30, 2019 at 03:45:46PM +0100, Dr. David Alan Gilbert wrote: > * Daniel P. Berrangé (berra...@redhat.com) wrote: > > The QEMU QMP service is based on JSON which is nice because that is a > > widely supported "standard" data format. > > > > except QEMU's implementation (and

[libvirt] [PATCH] spec: fix f28 rpm without firewalld zone

2019-04-30 Thread Cole Robinson
Commit 3b71f2e42d added spec handling for with_firewalld_zone. We now call %firewalld_reload if with_firewalld is set. But the matching 'BuildRequires: firewalld-filesystem' is only applied if with_firewalld_zone is set. Fix the former bit to use with_firewalld_zone Reported-by: Yuval Turgeman

Re: [libvirt] [PATCH] spec: fix f28 rpm without firewalld zone

2019-04-30 Thread Laine Stump
On 4/30/19 11:08 AM, Cole Robinson wrote: Commit 3b71f2e42d added spec handling for with_firewalld_zone. We now call %firewalld_reload if with_firewalld is set. But the matching 'BuildRequires: firewalld-filesystem' is only applied if with_firewalld_zone is set. Fix the former bit to use

Re: [libvirt] [PATCH] storage: escape ipv6 for ceph mon hosts to librados

2019-04-30 Thread Yi Li
>From 4af765cb6ee87eb7a131901057a8b6d0e859ac63 Mon Sep 17 00:00:00 2001 From: Yi Li Date: Sun, 28 Apr 2019 10:29:53 +0800 Subject: [PATCH v2] storage: escape ipv6 for ceph mon hosts to librados Hosts for rbd are ceph monitor daemons. These have fixed IP addresses, so they are often referenced by

Re: [libvirt] [PATCH] storage: escape ipv6 for ceph mon hosts to librados

2019-04-30 Thread Yi Li
> >Hosts for rbd are ceph monitor daemons. These have fixed IP addresses, > >so they are often referenced by IP rather than hostname for > >convenience, or to avoid relying on DNS. Using IPv4 addresses as the > >host name works already, but IPv6 addresses require rbd-specific > > If you include

Re: [libvirt] [PATCH] qemu_command: fix double_close vhostfd in qemuBuildHostdevCommandLine

2019-04-30 Thread Michal Privoznik
On 4/30/19 7:24 AM, Jie Wang wrote: vhostfd passed to cmd->passfd in virCommandPassFD, virCommandFree will always close cmd->passfd when qemuBuildSCSIVHostHostdevDevStr failed. Signed-off-by: Jie Wang --- src/qemu/qemu_command.c | 1 - 1 file changed, 1 deletion(-) diff --git

Re: [libvirt] [PATCH v2] test_driver: provide virDomainGetTime implementation

2019-04-30 Thread Michal Privoznik
On 4/30/19 10:42 AM, Peter Krempa wrote: On Mon, Apr 29, 2019 at 17:13:35 +0200, Michal Privoznik wrote: On 4/24/19 6:57 PM, Ilias Stamatis wrote: Implement testDomainGetTime by returning a fixed timestamp. Signed-off-by: Ilias Stamatis --- src/test/test_driver.c | 13 + 1

[libvirt] [PATCH] lib: Avoid double free when passing FDs with virCommandPassFD()

2019-04-30 Thread Michal Privoznik
If an FD is passed into a child using: virCommandPassFD(cmd, fd, VIR_COMMAND_PASS_FD_CLOSE_PARENT); then the parent should refrain from touching @fd thereafter. This is even documented in virCommandPassFD() comment. The reason is that either at virCommandRun()/virCommandRunAsync() or

[libvirt] [PATCH] qemuConnectOpen: Drop unused @cfg and simplify

2019-04-30 Thread Michal Privoznik
After 65a372d6e0 the @cfg variable is no longer used. This means we can drop it and therefore drop 'cleanup' label with it. Signed-off-by: Michal Privoznik --- src/qemu/qemu_driver.c | 17 + 1 file changed, 5 insertions(+), 12 deletions(-) diff --git a/src/qemu/qemu_driver.c

Re: [libvirt] [PATCH 08/21] qemu: qapi: Separate virQEMUQAPISchemaTraverse into functions by object type

2019-04-30 Thread Peter Krempa
On Thu, Apr 25, 2019 at 15:28:31 +0200, Ján Tomko wrote: > On Mon, Apr 15, 2019 at 06:02:01PM +0200, Peter Krempa wrote: > > Simplify virQEMUQAPISchemaTraverse by separating out the necessary > > operations for given 'meta-type' into separate functions. > > > > Signed-off-by: Peter Krempa > >

Re: [libvirt] [PATCH v2] test_driver: provide virDomainGetTime implementation

2019-04-30 Thread Peter Krempa
On Mon, Apr 29, 2019 at 17:13:35 +0200, Michal Privoznik wrote: > On 4/24/19 6:57 PM, Ilias Stamatis wrote: > > Implement testDomainGetTime by returning a fixed timestamp. > > > > Signed-off-by: Ilias Stamatis > > --- > > src/test/test_driver.c | 13 + > > 1 file changed, 13

[libvirt] [PATCH] qemu_command: fix double_close vhostfd in qemuBuildHostdevCommandLine

2019-04-30 Thread Jie Wang
vhostfd passed to cmd->passfd in virCommandPassFD, virCommandFree will always close cmd->passfd when qemuBuildSCSIVHostHostdevDevStr failed. Signed-off-by: Jie Wang --- src/qemu/qemu_command.c | 1 - 1 file changed, 1 deletion(-) diff --git a/src/qemu/qemu_command.c b/src/qemu/qemu_command.c

Re: [libvirt] [PATCH] util: Fix uninitalized variable to avoid garbage value.

2019-04-30 Thread Michal Privoznik
On 4/30/19 2:29 AM, Julio Faracco wrote: This commit is similar with 692400f4. It fixes an uninitialized variable to avoid garbage value. This case, returns 0 jiffies if an error occurs with virNetDevBridgeGet. Signed-off-by: Julio Faracco --- src/util/virnetdevbridge.c | 2 +- 1 file

Re: [libvirt] [PATCH 0/5] tests: Refresh/add capabilities for QEMU 4.0.0

2019-04-30 Thread Pavel Hrdina
On Mon, Apr 29, 2019 at 06:25:50PM +0200, Andrea Bolognani wrote: > Now that it's officially out, we can refresh existing capabilities > created from git snapshots and introduce them for the architectures > where they were missing altogether. > > This series covers all architectures except for

[libvirt] QMP; unsigned 64-bit ints; JSON standards compliance

2019-04-30 Thread Daniel P . Berrangé
The QEMU QMP service is based on JSON which is nice because that is a widely supported "standard" data format. except QEMU's implementation (and indeed most impls) are not strictly standards compliant. Specifically the problem is around representing 64-bit integers, whether signed or

Re: [libvirt] [PATCH v2] qemu.conf: Make nvram list obsolete

2019-04-30 Thread Andrea Bolognani
On Thu, 2019-04-18 at 16:54 +0200, Michal Privoznik wrote: [...] > # Location of master nvram file > # > +# This configuration option is obsolete. Libvirt will follow the > +# QEMU firmware metadata specification to automatically locate > +# firmware images: > +# > +# >

Re: [libvirt] [PATCH v2] qemu.conf: Make nvram list obsolete

2019-04-30 Thread Michal Privoznik
On 4/30/19 1:34 PM, Andrea Bolognani wrote: On Thu, 2019-04-18 at 16:54 +0200, Michal Privoznik wrote: [...] # Location of master nvram file # +# This configuration option is obsolete. Libvirt will follow the +# QEMU firmware metadata specification to automatically locate +# firmware

Re: [libvirt] [PATCH 0/2] Fix regression with network type handling

2019-04-30 Thread Michal Privoznik
On 4/30/19 2:36 PM, Daniel P. Berrangé wrote: Problems pointed out at https://www.redhat.com/archives/libvir-list/2019-April/msg01412.html It certainly isn't possible to fix these problems in time for release, and probably never. So reverting is best, probably only, option. Daniel P.

Re: [libvirt] [PATCH v4 04/29] network: use 'bridge' as actual type instead of 'network'

2019-04-30 Thread Daniel P . Berrangé
On Fri, Apr 26, 2019 at 11:07:49AM +0200, Michal Privoznik wrote: > On 4/17/19 7:19 PM, Daniel P. Berrangé wrote: > > Ports allocated on virtual networks with type=nat|route|open all get > > given an actual type of 'network'. > > > > Only ports in networks with type=bridge use an actual type of

Re: [libvirt] [PATCH] tests: qemucaps: Bump capability test data for qemu-4.0 release on x86_64

2019-04-30 Thread Pavel Hrdina
On Mon, Apr 29, 2019 at 02:33:43PM +0200, Peter Krempa wrote: > Capture and update the 4.0.0 qemu version replies now that it was > released. I opted to keep the CPU differences as there was a qemu bug > which reported an empty string in CPU caps. > > Signed-off-by: Peter Krempa > --- >

[libvirt] [PATCH 1/2] Revert "virt drivers: don't handle type=network after resolving actual network type"

2019-04-30 Thread Daniel P . Berrangé
This reverts commit 2f5e6502e34d9ddba596fa824b2f2f3504b34a99. --- src/libxl/libxl_conf.c| 21 ++--- src/lxc/lxc_driver.c | 15 --- src/qemu/qemu_command.c | 8 ++-- src/qemu/qemu_hotplug.c | 13 ++--- src/qemu/qemu_interface.c | 12

[libvirt] [PATCH 2/2] Revert "network: use 'bridge' as actual type instead of 'network'"

2019-04-30 Thread Daniel P . Berrangé
This caused the live XML to report the 'bridge' type instead of the 'network' type, which is a behavioural regression. It also breaks 'virsh domif-setlink', 'virsh update-device' and 'virsh domiftune' This reverts commit 518026e15959ab0e19b659a9f2ff502a54946498. --- src/conf/domain_conf.c

[libvirt] [PATCH 0/2] Fix regression with network type handling

2019-04-30 Thread Daniel P . Berrangé
Problems pointed out at https://www.redhat.com/archives/libvir-list/2019-April/msg01412.html It certainly isn't possible to fix these problems in time for release, and probably never. So reverting is best, probably only, option. Daniel P. Berrangé (2): Revert "virt drivers: don't handle

[libvirt] [PATCH for 5.3.0] news: Update for 5.3.0 release

2019-04-30 Thread Michal Privoznik
Some basic features/bugfixes/removed features. Of course we've done a lot more than recoded here. Signed-off-by: Michal Privoznik --- docs/news.xml | 62 +++ 1 file changed, 62 insertions(+) diff --git a/docs/news.xml b/docs/news.xml index

Re: [libvirt] [PATCH 0/5] tests: Refresh/add capabilities for QEMU 4.0.0

2019-04-30 Thread Andrea Bolognani
On Tue, 2019-04-30 at 13:55 +0200, Pavel Hrdina wrote: > On Mon, Apr 29, 2019 at 06:25:50PM +0200, Andrea Bolognani wrote: > > Now that it's officially out, we can refresh existing capabilities > > created from git snapshots and introduce them for the architectures > > where they were missing

Re: [libvirt] [PATCH 0/5] tests: Refresh/add capabilities for QEMU 4.0.0

2019-04-30 Thread Pavel Hrdina
On Tue, Apr 30, 2019 at 02:44:06PM +0200, Andrea Bolognani wrote: > On Tue, 2019-04-30 at 13:55 +0200, Pavel Hrdina wrote: > > On Mon, Apr 29, 2019 at 06:25:50PM +0200, Andrea Bolognani wrote: > > > Now that it's officially out, we can refresh existing capabilities > > > created from git snapshots

Re: [libvirt] [PATCH 0/5] tests: Refresh/add capabilities for QEMU 4.0.0

2019-04-30 Thread Andrea Bolognani
On Tue, 2019-04-30 at 15:02 +0200, Pavel Hrdina wrote: > On Tue, Apr 30, 2019 at 02:44:06PM +0200, Andrea Bolognani wrote: > > On Tue, 2019-04-30 at 13:55 +0200, Pavel Hrdina wrote: > > > Peter sent the same patch for x86_64 as well, there is one difference, > > > you also have all the Xen things

Re: [libvirt] [PATCH 0/5] tests: Refresh/add capabilities for QEMU 4.0.0

2019-04-30 Thread Daniel P . Berrangé
On Tue, Apr 30, 2019 at 03:22:03PM +0200, Andrea Bolognani wrote: > On Tue, 2019-04-30 at 15:02 +0200, Pavel Hrdina wrote: > > On Tue, Apr 30, 2019 at 02:44:06PM +0200, Andrea Bolognani wrote: > > > On Tue, 2019-04-30 at 13:55 +0200, Pavel Hrdina wrote: > > > > Peter sent the same patch for x86_64

Re: [libvirt] [PATCH 0/5] tests: Refresh/add capabilities for QEMU 4.0.0

2019-04-30 Thread Daniel P . Berrangé
On Tue, Apr 30, 2019 at 03:41:18PM +0200, Andrea Bolognani wrote: > On Tue, 2019-04-30 at 14:27 +0100, Daniel P. Berrangé wrote: > > On Tue, Apr 30, 2019 at 03:22:03PM +0200, Andrea Bolognani wrote: > > > Anyway, the rest of the replies were generated from QEMU binaries > > > built on RHEL, and on

Re: [libvirt] [PATCH for 5.3.0] news: Update for 5.3.0 release

2019-04-30 Thread Andrea Bolognani
On Tue, 2019-04-30 at 14:43 +0200, Michal Privoznik wrote: [...] > + > + > + > + Drop support for VirtualBox 4.x releases vbox: Drop support ... [...] > + > + > + Drop yajl-1 support in favour of yajl-2 Just Drop YAJL 1 support will do:

Re: [libvirt] [PATCH 0/5] tests: Refresh/add capabilities for QEMU 4.0.0

2019-04-30 Thread Andrea Bolognani
On Tue, 2019-04-30 at 14:27 +0100, Daniel P. Berrangé wrote: > On Tue, Apr 30, 2019 at 03:22:03PM +0200, Andrea Bolognani wrote: > > Anyway, the rest of the replies were generated from QEMU binaries > > built on RHEL, and on non-x86 architectures too, so we don't have to > > worry about those

Re: [libvirt] [PATCH 0/2] conf: DEF_FEATURE tweaks

2019-04-30 Thread Cole Robinson
On 4/17/19 10:57 AM, Cole Robinson wrote: > After the net model enum patches, the test driver started rejecting > non-enum model strings. It should continue to accept unknown models > and generally act closer to the qemu driver. So let's add all of > qemu's DEF_FEATURE bits to match while we are