[libvirt] [PATCH 1/4] parallels: add isCt parameter to prlsdkGetDiskInfo and prlsdkAddDisk

2015-06-03 Thread Maxim Nestratov
Signed-off-by: Maxim Nestratov mnestra...@parallels.com --- src/parallels/parallels_sdk.c | 16 ++-- 1 file changed, 10 insertions(+), 6 deletions(-) diff --git a/src/parallels/parallels_sdk.c b/src/parallels/parallels_sdk.c index 05f11b0..874638f 100644 ---

[libvirt] [PATCH 2/4] parallels: process '/' mount point correctly for containers

2015-06-03 Thread Maxim Nestratov
Since we are going to add block devices as root disks we have to specify root mount point for boot block devices. But we shouldn't do this if a filesystem disk with such target mount point already exists. Signed-off-by: Maxim Nestratov mnestra...@parallels.com --- src/parallels/parallels_sdk.c |

[libvirt] [PATCH 3/4] parallels: report SATA bus type for container block devices disks

2015-06-03 Thread Maxim Nestratov
As we can add disks based on block devices to containers and bus type doesn't have any meaning here, let us report always SATA for them. Signed-off-by: Maxim Nestratov mnestra...@parallels.com --- src/parallels/parallels_sdk.c | 9 +++-- 1 file changed, 7 insertions(+), 2 deletions(-) diff

[libvirt] [PATCH 4/4] parallels: treat block devices as disks for containers

2015-06-03 Thread Maxim Nestratov
We are going to add block devices as disks for containers not as filesystems. Signed-off-by: Maxim Nestratov mnestra...@parallels.com --- src/parallels/parallels_sdk.c | 8 +++- 1 file changed, 7 insertions(+), 1 deletion(-) diff --git a/src/parallels/parallels_sdk.c

Re: [libvirt] [v2] storage-pool: API to get/set autostart flag

2015-06-03 Thread Zeeshan Ali (Khattak)
Meh, I keep sending without libvirt-glib in subject.. On Wed, Jun 3, 2015 at 11:35 AM, Zeeshan Ali (Khattak) zeesha...@gnome.org wrote: Add binding for virStoragePoolGetAutostart virStoragePoolSetAutostart. --- libvirt-gobject/libvirt-gobject-storage-pool.c | 51 ++

[libvirt] [libvirt-glib v2] storage-pool: API to get/set autostart flag

2015-06-03 Thread Zeeshan Ali (Khattak)
Add binding for virStoragePoolGetAutostart virStoragePoolSetAutostart. --- libvirt-gobject/libvirt-gobject-storage-pool.c | 51 ++ libvirt-gobject/libvirt-gobject-storage-pool.h | 5 +++ libvirt-gobject/libvirt-gobject.sym| 6 +++ 3 files changed, 62

Re: [libvirt] [PATCH v3 0/9] Selective block device migration implementation

2015-06-03 Thread Kashyap Chamarthy
On Wed, Jun 03, 2015 at 11:11:45AM -0600, Eric Blake wrote: On 06/01/2015 02:41 PM, John Ferlan wrote: And, `make` seems to fail here: $ ~/tinker-space/libvirt/./autogen.sh --system $ make -j4 [. . .] /home/kashyapc/tinker-space/libvirt/./src/qemu/qemu_migration.c:

[libvirt] [PATCH 0/4 v2] parallels: better support of volume based disks in containers

2015-06-03 Thread Maxim Nestratov
v1-v2 change: * Single patch was split into smaller pieces * Corrected conflict of / mount point in case both filesystem and block device disks are being added. It is possible to attach volumes to containers but since they are added they are reported erroneously as filesystems. This is fixed

[libvirt] [v2] storage-pool: API to get/set autostart flag

2015-06-03 Thread Zeeshan Ali (Khattak)
Add binding for virStoragePoolGetAutostart virStoragePoolSetAutostart. --- libvirt-gobject/libvirt-gobject-storage-pool.c | 51 ++ libvirt-gobject/libvirt-gobject-storage-pool.h | 5 +++ libvirt-gobject/libvirt-gobject.sym| 6 +++ 3 files changed, 62

[libvirt] [PATCH] util: Clear output broadcast address before filling it in

2015-06-03 Thread Martin Kletzander
Since commit 55ace7c4789c8a7408139460f4b639cee00e5125, the sockettest fails without VIR_TEST_DEBUG set. The problem is found by test number 42 (co-incidence?), which tests range '192.168.122.1' - '192.168.122.255' in network '192.168.122.0/24'. That is supposed to fail because the end address is

[libvirt] [PATCH 2/4] storage: Refactor storage pool type checks

2015-06-03 Thread John Ferlan
Refactor the code for both startPool (*Mount) and stopPool (*Unmount) code paths by introducing virStorageBackendFileSystemValidateFS. Signed-off-by: John Ferlan jfer...@redhat.com --- src/storage/storage_backend_fs.c | 85 ++-- 1 file changed, 39

[libvirt] [PATCH 3/4] storage: FS backend adjust error message on error path

2015-06-03 Thread John Ferlan
https://bugzilla.redhat.com/show_bug.cgi?id=1181087 Currently the assumption on the error message is that there are no source device path's defined when the != 1 check fails, but in reality the value could 0 or 2 or more, so adjust the error message accordingly to make it clearer what the error

[libvirt] [PATCH 1/4] storage: Remove extraneous @conn from function comments

2015-06-03 Thread John Ferlan
Over time the parameters changed, but the comment wasn't updated Signed-off-by: John Ferlan jfer...@redhat.com --- src/storage/storage_backend_fs.c | 3 --- 1 file changed, 3 deletions(-) diff --git a/src/storage/storage_backend_fs.c b/src/storage/storage_backend_fs.c index 337b8d3..b70902a

[libvirt] [PATCH 4/4] storage: Add check for valid FS types in checkPool callback

2015-06-03 Thread John Ferlan
https://bugzilla.redhat.com/show_bug.cgi?id=1181087 The virStorageBackendFileSystemIsMounted is called from three source paths checkPool, startPool, and stopPool. Both start and stop validate the FS fields before calling *IsMounted; however the check path there is no call. This could lead the

[libvirt] [PATCH 0/4] Fix some issues is FS backend

2015-06-03 Thread John Ferlan
https://bugzilla.redhat.com/show_bug.cgi?id=1181087 Patch 1 was just found by inspection Patch 2 sets up for the the eventual fix Patch 3 Adjusts the error message to make it clearer what the problem is Patch 4 Adds a check in the checkPool path for valid FS storage pool config before

Re: [libvirt] [PATCH] virsh: Fix Ctrl-C behavior when watching a job

2015-06-03 Thread Jiri Denemark
On Tue, Jun 02, 2015 at 17:37:35 +0200, Ján Tomko wrote: On Mon, Jun 01, 2015 at 09:05:59PM +0200, Jiri Denemark wrote: When watching a job (save, managedsave, dump, migrate) virsh spawns a thread to call the appropriate API and waits for the result while watching for interruption signals

Re: [libvirt] [PATCH] qemu: monitor: Add memory balloon support for virtio-ccw

2015-06-03 Thread Boris Fiuczynski
On 06/02/2015 05:56 PM, Ján Tomko wrote: On Tue, Jun 02, 2015 at 11:27:35AM +0200, Boris Fiuczynski wrote: The search for the memory ballon driver object is extended by a second known name virtio-ballon-ccw in support for virtio-ccw. Signed-off-by: Boris Fiuczynski fiu...@linux.vnet.ibm.com

Re: [libvirt] [PATCHv3] qemu: fix unsuitable error report when get memory stats

2015-06-03 Thread Martin Kletzander
On Wed, Jun 03, 2015 at 09:07:49AM +0800, Wang Yufei wrote: From: Zhang Bo oscar.zhan...@huawei.com when we run the command 'virsh dommemstat xxx', althrough memballoon's model is set 'none' in vm's XML, it still reports an error in libvirtd.log. error : qemuMonitorFindBalloonObjectPath:1042 :

Re: [libvirt] [PATCH 14/35] qemu: process: Refactor setup of memory ballooning

2015-06-03 Thread Peter Krempa
On Tue, Jun 02, 2015 at 16:12:25 +0200, Ján Tomko wrote: On Fri, May 29, 2015 at 03:33:35PM +0200, Peter Krempa wrote: Since the monitor code now supports ullongs when setting balloon size, drop the legacy code with overflow checking. Additionally the comment mentioning that the job is

Re: [libvirt] [PATCH v3 6/9] util: virTypedParams{Filter, PickStrings}

2015-06-03 Thread Jiri Denemark
On Tue, May 26, 2015 at 15:01:48 +0200, Michal Privoznik wrote: From: Pavel Boldin pbol...@mirantis.com Add multikey API: * virTypedParamsFilter that returns all the parameters with specified name. * virTypedParamsPickStrings that returns a list with all the values for specified name

Re: [libvirt] [PATCH 0/8 v3] parallels: add vz driver

2015-06-03 Thread Dmitry Guryanov
On 05/28/2015 11:05 AM, Dmitry Guryanov wrote: On 05/26/2015 08:12 PM, Maxim Nestratov wrote: v2-v3 change: * Patch parallels: set virtType depending on driver name reworked. Implemented ability to set virtType depending on driver name. v1-v2 change: * Only parallels: accept vz as a

Re: [libvirt] [PATCH 30/35] qemu: Refactor qemuDomainSetBlkioParameters by reusing virDomainObjGetDefs

2015-06-03 Thread Ján Tomko
On Fri, May 29, 2015 at 03:33:51PM +0200, Peter Krempa wrote: --- src/qemu/qemu_driver.c | 22 +++--- 1 file changed, 7 insertions(+), 15 deletions(-) ACK to patches 23-30 Jan signature.asc Description: Digital signature -- libvir-list mailing list libvir-list@redhat.com

Re: [libvirt] [PATCH 35/35] qemu: Refactor qemuDomainSetVcpusFlags by reusing virDomainObjGetDefs

2015-06-03 Thread Ján Tomko
On Fri, May 29, 2015 at 03:33:56PM +0200, Peter Krempa wrote: --- src/qemu/qemu_driver.c | 22 -- 1 file changed, 8 insertions(+), 14 deletions(-) ACK to patches 31-35 Jan signature.asc Description: Digital signature -- libvir-list mailing list libvir-list@redhat.com

[libvirt] Canging bridge names on live migration

2015-06-03 Thread seitan
Hello, i wonder, if there's a possibility to change a name of a shared interface in virtual machine config, while doing migration. The problem is: hypervisor1 (source) uses shared interface name br0. hypervisor2 (target) uses shared interface name br500. Live migration fails, because target

Re: [libvirt] [PATCH] docs: php: remove reference to Red Hat

2015-06-03 Thread Erik Skultety
On 06/03/2015 02:48 PM, Ján Tomko wrote: Also remove the redudant apostrophe from it's. --- docs/php.html.in | 5 ++--- 1 file changed, 2 insertions(+), 3 deletions(-) diff --git a/docs/php.html.in b/docs/php.html.in index d9a3c1b..c10b0aa 100644 --- a/docs/php.html.in +++

Re: [libvirt] [PATCH] util: Clear output broadcast address before filling it in

2015-06-03 Thread Laine Stump
On 06/03/2015 06:54 AM, Martin Kletzander wrote: Since commit 55ace7c4789c8a7408139460f4b639cee00e5125, the sockettest fails without VIR_TEST_DEBUG set. The problem is found by test number 42 (co-incidence?), which tests range '192.168.122.1' - '192.168.122.255' in network '192.168.122.0/24'.

[libvirt] [PATCH] docs: php: remove reference to Red Hat

2015-06-03 Thread Ján Tomko
Also remove the redudant apostrophe from it's. --- docs/php.html.in | 5 ++--- 1 file changed, 2 insertions(+), 3 deletions(-) diff --git a/docs/php.html.in b/docs/php.html.in index d9a3c1b..c10b0aa 100644 --- a/docs/php.html.in +++ b/docs/php.html.in @@ -6,8 +6,7 @@ h2Presentation/h2

Re: [libvirt] [PATCH] parallels: add block device statistics to driver

2015-06-03 Thread Dmitry Guryanov
On 05/22/2015 10:42 AM, Nikolay Shirokovskiy wrote: Statistics provided through PCS SDK. As we have only async interface in SDK we need to be subscribed to statistics in order to get it. Trivial solution on every stat request to subscribe, wait event and then unsubscribe will lead to significant

[libvirt] [PATCH] maint: remove redundant apostrophes from 'its'

2015-06-03 Thread Ján Tomko
--- docs/formatnode.html.in | 2 +- src/conf/storage_conf.c | 2 +- src/esx/esx_driver.c| 2 +- src/esx/esx_network_driver.c| 2 +- src/esx/esx_storage_backend_iscsi.c | 2 +- src/esx/esx_storage_backend_vmfs.c | 2 +- src/libxl/libxl_domain.c

Re: [libvirt] [PATCH 16/35] qemu: Add helper to update domain balloon size and refactor usage places

2015-06-03 Thread Ján Tomko
On Fri, May 29, 2015 at 03:33:37PM +0200, Peter Krempa wrote: When qemu does not support the balloon event the current memory size needs to be queried. Since there are two places that implement the same logic, split it out into a function and reuse. --- src/qemu/qemu_domain.c | 64

Re: [libvirt] [PATCH 17/35] qemu: Refactor qemuDomainGetInfo

2015-06-03 Thread Ján Tomko
On Fri, May 29, 2015 at 03:33:38PM +0200, Peter Krempa wrote: Since the returned structure uses unsigned long for memory sizes add a few overflow checks to notify the user in case we are not able to represent given values. --- src/qemu/qemu_driver.c | 41

Re: [libvirt] [PATCH 22/35] libxl: Don't remove vcpu pin definition in libxlDomainCleanup

2015-06-03 Thread Ján Tomko
On Fri, May 29, 2015 at 03:33:43PM +0200, Peter Krempa wrote: The vCPU pinning definition gets removed when the domain definition is being freed later. If there is no next configuration it would remove the configured pinning. --- src/libxl/libxl_domain.c | 11 --- 1 file changed, 11

Re: [libvirt] [PATCH] maint: remove redundant apostrophes from 'its'

2015-06-03 Thread Andrea Bolognani
On Wed, 2015-06-03 at 14:48 +0200, Ján Tomko wrote: --- docs/formatnode.html.in | 2 +- src/conf/storage_conf.c | 2 +- src/esx/esx_driver.c| 2 +- src/esx/esx_network_driver.c| 2 +- src/esx/esx_storage_backend_iscsi.c | 2 +-

[libvirt] [PATCH] util: process: Refactor and fix virProcessSetAffinity

2015-06-03 Thread Peter Krempa
Refactor the function to return the bitmap instead of an integer and the inner workings so that they make more sense. This patch also fixes possible segfault on old systems that was introduced by commit: commit f1a43a8e4139b028257ef4ed05a81cfb5f8a8741 Author: Hu Tao hu...@cn.fujitsu.com Date:

Re: [libvirt] [PATCH 15/35] qemu: process: Update current balloon state to maximum on vm startup

2015-06-03 Thread Ján Tomko
On Fri, May 29, 2015 at 03:33:36PM +0200, Peter Krempa wrote: After libvirt issues the balloon resize command, the current balloon size needs to be changed to the maximum memory size since the vCPUs were not started and thus the balloon driver could not return the memory. Since GetXMLDesc

Re: [libvirt] [RFC] libvirt support multi-thread compression for live migration

2015-06-03 Thread Feng, Shaohe
Eric, Thank you for reply. Is it necessary to expose these two APIs to user application? + virdomainMigrateSetCapabilities + virdomainMigrateGetCapabilities For qemu , the migration capabilities are xbzrle, rdma-pin-all, auto-converge, zero-blocks and compress. Sorry , I use outlook. Will

Re: [libvirt] [PATCH v2] check if console/channel PTY is null before attempting to open

2015-06-03 Thread Michal Privoznik
On 31.05.2015 17:55, Shivaprasad G Bhat wrote: Console/channel devices have their pty devices assigned when the emulator is actually started. If time is spent in guest preparation, someone attempts to open the console/channel, the libvirt crashes in virChrdevLockFilePath(). The patch attempts

Re: [libvirt] [PATCH v3 3/9] qemuMigrationDriveMirror: Pass disk format to qemu

2015-06-03 Thread Eric Blake
[adding libvirt-security] On 05/29/2015 05:29 AM, John Ferlan wrote: On 05/26/2015 09:01 AM, Michal Privoznik wrote: When playing with disk migration lately, I've noticed this warning in domain logs: WARNING: Image format was not specified for 'nbd://masina:49153/drive-virtio-disk0'

Re: [libvirt] [PATCH] maint: remove redundant apostrophes from 'its'

2015-06-03 Thread Eric Blake
On 06/03/2015 06:48 AM, Ján Tomko wrote: s/redundant/incorrect/ They would only be redundant if having them was correct but optional; but in all cases you touched, they were grammatically wrong: there is no optional ', it is either its (possessive) or it's (short for it is). ---

[libvirt] [PATCH 2/2] storage: Generate correct parameters for CIFS

2015-06-03 Thread John Ferlan
https://bugzilla.redhat.com/show_bug.cgi?id=1186969 When generating the path to the dir for a CIFS/Samba driver, the code would generate a source path for the mount using %s:%s while the mount.cifs expects to see //%s/%s. So check for the cifsfs and format the source path appropriately.

Re: [libvirt] [PATCH] virnetdev: fix moving of 802.11 phys

2015-06-03 Thread Michal Privoznik
On 01.06.2015 20:40, Lubomir Rintel wrote: There was a couple of problems with the style fixes applied to the original patch: 1.) virFileReadAllQuiet comparison was incorrectly parenthesized when moved into a condition, causing the len to be set to the result of comparison. This, together

[libvirt] [PATCH 0/2] Adjust netfs CIFS/Samba formatting

2015-06-03 Thread John Ferlan
https://bugzilla.redhat.com/show_bug.cgi?id=1186969 The first patch follows a previous change to fix/adjust the gluster specific rng formatting The second patch resolves the particular issue ensuring to generate the source path with the //%s/%s instead of %s:%s and with the -o group to connect

Re: [libvirt] [PATCH v3 9/9] virsh: selective block device migration

2015-06-03 Thread Michal Privoznik
On 30.05.2015 17:24, Pavel Boldin wrote: Michal, Should I fix these or will you do it? Pavel I'll fix it and resend. Currently I'm buried in something else, so somewhere next week it's feasible. Michal -- libvir-list mailing list libvir-list@redhat.com

Re: [libvirt] [PATCH v3 0/9] Selective block device migration implementation

2015-06-03 Thread Eric Blake
On 06/01/2015 02:41 PM, John Ferlan wrote: And, `make` seems to fail here: $ ~/tinker-space/libvirt/./autogen.sh --system $ make -j4 [. . .] /home/kashyapc/tinker-space/libvirt/./src/qemu/qemu_migration.c: In function 'qemuMigrationRun':

[libvirt] [PATCH 1/2] storage: Fix the schema and add tests for cifs pool

2015-06-03 Thread John Ferlan
Commit id '887dd362' added support for a netfs pool format type 'cifs' and 'gluster' in order to add rng support for Samba and glusterfs netfs pools. Originally, the CIFS type support was added as part of commit id '61fb6979'. Eventually commit id 'b325be12' fixed the gluster rng definition to