Re: [libvirt] [PATCH 0/2] Couple of coverity fixes

2016-01-09 Thread John Ferlan
On 01/07/2016 05:58 AM, Michal Privoznik wrote: > I went through coverity report and found these. > > Michal Privoznik (2): > virDomainMigrateUnmanagedParams: Don't blindly dereference @dconnuri > virt-host-validate-common: Print warning on missing IOMMU > > src/libvirt-domain.c

Re: [libvirt] ARM KVM GICv3 Support

2016-01-09 Thread Christoffer Dall
On Wed, Jan 06, 2016 at 01:30:16PM +, Peter Maydell wrote: > On 6 January 2016 at 12:49, Andrea Bolognani wrote: > > That's correct, having a QMP command that lists the values gic-version > > can have on the current host would be just great. > > > > If we had that, we

[libvirt] [PATCH v3 13/14] virsh: Create macro for common "network" option

2016-01-09 Thread John Ferlan
Rather than continually cut-n-paste the strings into each command, create a common macro to be used generically. Note that not all '{.name = "network",' entries are replaced, just those that have the common .help string of "network name or uuid". Signed-off-by: John Ferlan

[libvirt] [PATCH v3 14/14] virsh: Create macro for common "interface" option

2016-01-09 Thread John Ferlan
Rather than continually cut-n-paste the strings into each command, create a common macro to be used generically. Note that not all '{.name = "interface",' entries are replaced, just those that have the common .help string of "interface name or MAC address". Signed-off-by: John Ferlan

[libvirt] [PATCH v3 03/14] virsh: Create macro for common "domain" option

2016-01-09 Thread John Ferlan
Rather than continually cut-n-paste the strings into each command, create a common macro to be used generically. Note that not all '{.name = "domain",' entries are replaced, just those that have the common .help string of "domain name, id or uuid" and those that are required. Other instances

[libvirt] [PATCH v3 08/14] virsh: Create macro for common "file" option

2016-01-09 Thread John Ferlan
Rather than continually cut-n-paste the strings into each command, create a common macro to be used generically. Note that not all '{.name = "file",' entries are replaced, just those that use VSH_OT_DATA and VSH_OFLAG_REQ. Replacement of this option is a bit trickier, since the .helpstr changes

[libvirt] [PATCH v3 12/14] virsh: have snapshot use common "domain" option

2016-01-09 Thread John Ferlan
Make use of the common VIRSH_COMMON_OPT_DOMAIN macro for each of the matching '.name = "domain"' command options. Signed-off-by: John Ferlan --- tools/virsh-snapshot.c | 60 +- 1 file changed, 10 insertions(+), 50 deletions(-)

[libvirt] [PATCH v3 09/14] virsh: Create macros for common "pool" options

2016-01-09 Thread John Ferlan
Rather than continually cut-n-paste the strings into each command, create common macros to be used generically. For virsh-volume, there are 3 different types of "pool" options - 2 for create, 2 required for the command, and 10 for string type options. Create 2 new macros for the create and string

[libvirt] [PATCH v3 04/14] virsh: Create macro for common "persistent" option

2016-01-09 Thread John Ferlan
Rather than continually cut-n-paste the strings into each command, create a common macro to be used generically. Note that not all '{.name = "persistent",' entries are replaced, just those that have the common .help string of "make live change persistent". Non replaced instances are unique to

[libvirt] [PATCH v3 02/14] virsh: Move VIRSH_COMMON_OPT_POOL to virsh.h

2016-01-09 Thread John Ferlan
Since it can be used by other virsh*.c modules, move the macro to virsh.h and add virsh.h to POTFILES.in (since there are translatable strings). Signed-off-by: John Ferlan --- po/POTFILES.in | 1 + tools/virsh-pool.c | 7 --- tools/virsh.h | 10 ++ 3

[libvirt] [PATCH v3 11/14] virsh: Have domain-monitor use common "domain" option

2016-01-09 Thread John Ferlan
Make use of the common VIRSH_COMMON_OPT_DOMAIN macro for each of the matching '.name = "domain"' command options. Signed-off-by: John Ferlan --- tools/virsh-domain-monitor.c | 77 1 file changed, 13 insertions(+), 64 deletions(-)

[libvirt] [PATCH v3 01/14] virsh: Covert VSH_POOL_ macro to VIRSH_COMMON_OPT_

2016-01-09 Thread John Ferlan
Commit id's 'cf793b00', 'e178688f', 'f9a6110f', '5372d49', and 'e193735' added new VSH_POOL_ macros; however, it was pointed out after push that commit id '834c5720' preferred use of VIRSH_ for the prefix over VSH_. So this patch just changes the VSH_ to VIRSH_ and it changes the naming format

[libvirt] [PATCH v3 00/14] Use macros for more common virsh command options

2016-01-09 Thread John Ferlan
v2: http://www.redhat.com/archives/libvir-list/2015-December/msg00766.html Changes since v2: Use VIRSH_COMMON_OPT_ for option prefix instead of VIRSH__OPT_COMMON Patches have a few thumbs up already, figured I'd post it one last time for perusal and checks of the naming 'algorithm. John

[libvirt] [PATCH v3 10/14] virsh: Create macros for common "vol" options

2016-01-09 Thread John Ferlan
Rather than continually cut-n-paste the strings into each command, create common macros to be used generically. Replace the more commonly used "vol" option with a macro. This also adjusts 2 commands that didn't have the correct helpstr - 'vol-create-from' and 'vol-clone'. Both are described in

[libvirt] [PATCH v3 06/14] virsh: Create macro for common "live" option

2016-01-09 Thread John Ferlan
Rather than continually cut-n-paste the strings into each command, create a common macro to be used generically. Note that not all '{.name = "live",' entries are replaced, just those that have the common .help string of "affect running domain". Non replaced instances are unique to the command.

[libvirt] [PATCH v3 05/14] virsh: Create macro for common "config" option

2016-01-09 Thread John Ferlan
Rather than continually cut-n-paste the strings into each command, create a common macro to be used generically. Note that not all '{.name = "config",' entries are replaced, just those that have the common .help string of "affect next boot". Non replaced instances are unique to the command.

[libvirt] [PATCH v3 07/14] virsh: Create macro for common "current" option

2016-01-09 Thread John Ferlan
Rather than continually cut-n-paste the strings into each command, create a common macro to be used generically. Note that not all '{.name = "current",' entries are replaced, just those that have the common .help string of "affect current domain". Non replaced instances are unique to the

[libvirt] [PATCH 1/4] qemu: capabilities: s/Pixx/Piix/g

2016-01-09 Thread Cole Robinson
The chipset is called PIIX; the functions are misnamed --- src/qemu/qemu_capabilities.c | 6 +++--- 1 file changed, 3 insertions(+), 3 deletions(-) diff --git a/src/qemu/qemu_capabilities.c b/src/qemu/qemu_capabilities.c index 7b30441..80dd936 100644 --- a/src/qemu/qemu_capabilities.c +++

[libvirt] [PATCH] cfg.mk: Drop period after filename for indent failures

2016-01-09 Thread Cole Robinson
The period makes it more difficult to copy/paste the errant filename for manual fixup --- Pushed as trivial cfg.mk | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/cfg.mk b/cfg.mk index cf3f36c..b009b28 100644 --- a/cfg.mk +++ b/cfg.mk @@ -1095,7 +1095,7 @@ test-wrap-argv:

[libvirt] [PATCH 0/4] qemu: Support disable_s3/s4 for -M q35

2016-01-09 Thread Cole Robinson
q35/ICH9 uses a different qemu option for disabling s3/s4 support. Probe for it and wire it up. Cole Robinson (4): qemu: capabilities: s/Pixx/Piix/g qemu: caps: Rename CAPS_DISABLE_S[34] to CAPS_PIIX_DISABLE_S[34] qemu: caps: check for q35/ICH9 disable S3/S4 qemu: command: wire up usage

Re: [libvirt] [PATCH 3/4] qemu: caps: check for q35/ICH9 disable S3/S4

2016-01-09 Thread Cole Robinson
On 01/09/2016 04:32 PM, Cole Robinson wrote: > Update test data to match > --- > src/qemu/qemu_capabilities.c | 9 +++ > src/qemu/qemu_capabilities.h | 2 + > tests/qemucapabilitiesdata/caps_1.2.2-1.replies | 23 -- >

[libvirt] [PATCH 2/4] qemu: caps: Rename CAPS_DISABLE_S[34] to CAPS_PIIX_DISABLE_S[34]

2016-01-09 Thread Cole Robinson
These settings are specific to PIIX, so clarify it --- src/qemu/qemu_capabilities.c | 4 ++-- src/qemu/qemu_capabilities.h | 4 ++-- src/qemu/qemu_command.c | 4 ++-- tests/qemuxml2argvtest.c | 8 4 files changed, 10 insertions(+), 10 deletions(-) diff --git

[libvirt] [PATCH 3/4] qemu: caps: check for q35/ICH9 disable S3/S4

2016-01-09 Thread Cole Robinson
Update test data to match --- src/qemu/qemu_capabilities.c | 9 +++ src/qemu/qemu_capabilities.h | 2 + tests/qemucapabilitiesdata/caps_1.2.2-1.replies | 23 -- tests/qemucapabilitiesdata/caps_1.3.1-1.replies | 22 --

[libvirt] [PATCH 4/4] qemu: command: wire up usage of q35/ich9 disable s3/s4

2016-01-09 Thread Cole Robinson
If the q35 specific disable s3/s4 setting isn't disabled, fallback to specifying the PIIX setting, which is the previous behavior. It doesn't have any effect, but qemu will just warn about it rather than error: qemu-system-x86_64: Warning: global PIIX4_PM.disable_s3=1 not used qemu-system-x86_64:

Re: [libvirt] [PATCH] Avoid wild securityManager pointer in tests

2016-01-09 Thread Cole Robinson
On 01/09/2016 12:36 PM, Martin Kletzander wrote: > For some reason we are not setting the driver with memset() to zeros. > But since commit 74abc3deac6e14ffa9151e425c6e6cd2b075aac5 > driver->securityManager is being accessed and qemuagenttest started > crashing due to that. > > Signed-off-by:

[libvirt] [PATCH] Avoid wild securityManager pointer in tests

2016-01-09 Thread Martin Kletzander
For some reason we are not setting the driver with memset() to zeros. But since commit 74abc3deac6e14ffa9151e425c6e6cd2b075aac5 driver->securityManager is being accessed and qemuagenttest started crashing due to that. Signed-off-by: Martin Kletzander --- I chose to just

[libvirt] [PATCH] Unify int types handling in protocol files

2016-01-09 Thread Roman Bogorodskiy
From: Jasper Lievisse Adriaanse Some of the protocol files already include handing of the missing int types such as xdr_uint64_t, some don't. To fix it everywhere, move out of the appropriate defines to internal.h and include it whenever needed. Signed-off-by: Roman

[libvirt] Plans for next release

2016-01-09 Thread Daniel Veillard
So we should push 1.3.1 by the middle of this month (with 1.3.2 for end of Feb as decided when we planned 1.3.0) which means we should enter freeze soon. I am suggesting to start the freeze in Tuesday, with rc2 on Thursday and having the release by next week-end, if anybody has an issue with

[libvirt] [PATCH] examples: Use one top level makefile

2016-01-09 Thread Cole Robinson
Using one Makefile per example subdirectory essentially serializes 'make' calls. Convert to one example/Makefile that builds and distributes all the subdir files. This reduces example/ rebuild time from about 5.8 seconds to 1.5 seconds on my machine. One slight difference is that we no longer