Re: [libvirt] [PATCH 4/4] qemu: Escape commas for qemuBuildGrapicsSPICECommandLine

2018-06-18 Thread John Ferlan
On 06/18/2018 01:57 PM, Anya Harter wrote: > Add comma escaping for cfg->spiceTLSx509certdir and > graphics->data.spice.rendernode. > > Signed-off-by: Anya Harter > --- > src/qemu/qemu_command.c | 11 --- > tests/qemuxml2argvdata/name-escape.args | 5 +++-- >

Re: [libvirt] [PATCH 1/4] qemu: Escape commas for qemuBuildChrChardevStr

2018-06-18 Thread John Ferlan
On 06/18/2018 01:57 PM, Anya Harter wrote: > Add comma escaping for dev->data.file.path in cases > VIR_DOMAIN_CHR_TYPE_DEV and VIR_DOMAIN_CHR_TYPE_PIPE. > > Signed-off-by: Anya Harter > --- > src/qemu/qemu_command.c | 9 + > tests/qemuxml2argvdata/name-escape.args | 4

Re: [libvirt] [PATCH 2/4] qemu: Escape commas for qemuBuildChrChardevFileStr

2018-06-18 Thread John Ferlan
On 06/18/2018 01:57 PM, Anya Harter wrote: > Add comma escaping for fileval. > > Signed-off-by: Anya Harter > --- > src/qemu/qemu_command.c | 3 ++- > tests/qemuxml2argvdata/name-escape.args | 2 ++ > tests/qemuxml2argvdata/name-escape.xml | 4 >

Re: [libvirt] [PATCH] tests: add test file for smartcard database

2018-06-18 Thread John Ferlan
On 06/15/2018 10:45 AM, Anya Harter wrote: > Add test case explicitly defining a smartcard host certificates > database via the following xml: > > > /tmp/foo > > > This case is not currently covered in the test suite. > > Signed-off-by: Anya Harter > --- >

Re: [libvirt] [PATCH 3/4] qemu: Escape commas for qemuBuildSmartcardCommandLine

2018-06-18 Thread John Ferlan
On 06/18/2018 01:57 PM, Anya Harter wrote: > Add comma escaping for smartcard->data.cert.file[i] and > smartcard->data.cert.database. > > Signed-off-by: Anya Harter > --- > src/qemu/qemu_command.c | 21 - > tests/qemuxml2argvdata/name-escape.args | 3 +++

Re: [libvirt] [PATCH v2 5/5] virsh: Introduce --nowait to domstats

2018-06-18 Thread John Ferlan
On 06/15/2018 04:18 AM, Michal Privoznik wrote: > This new switch can be used to set > VIR_CONNECT_GET_ALL_DOMAINS_STATS_NOWAIT flag for stats > fetching API. > > Signed-off-by: Michal Privoznik > --- > tools/virsh-domain-monitor.c | 7 +++ > tools/virsh.pod | 16

Re: [libvirt] [PATCH v2 3/5] qemu_domain: Introduce qemuDomainObjBeginJobNowait

2018-06-18 Thread John Ferlan
On 06/15/2018 04:18 AM, Michal Privoznik wrote: > The aim of this API is to allow the caller do best effort. Some s/do/to do/ > functions can work even when acquiring the job fails (e.g. > qemuConnectGetAllDomainStats()). But what they can't bear is > delay if they have to wait up to 30

Re: [libvirt] [PATCH v2 4/5] Introduce VIR_CONNECT_GET_ALL_DOMAINS_STATS_NOWAIT

2018-06-18 Thread John Ferlan
On 06/15/2018 04:18 AM, Michal Privoznik wrote: > https://bugzilla.redhat.com/show_bug.cgi?id=1552092 > > If there's a long running job it might cause us to wait 30 > seconds before we give up acquiring the job. This is problematic > to interactive applications that fetch stats repeatedly

Re: [libvirt] [PATCH v3 20/20] nwfilter: convert virt drivers to use public API for nwfilter bindings

2018-06-18 Thread John Ferlan
On 06/14/2018 08:33 AM, Daniel P. Berrangé wrote: > Remove the callbacks that the nwfilter driver registers with the domain > object config layer. Instead make the current helper methods call into > the public API for creating/deleting nwfilter bindings. > > Signed-off-by: Daniel P. Berrangé >

Re: [libvirt] [PATCH v3 19/20] nwfilter: wire up new APIs for creating and deleting nwfilter bindings

2018-06-18 Thread John Ferlan
On 06/14/2018 08:33 AM, Daniel P. Berrangé wrote: > This allows the virsh commands nwfilter-binding-create and > nwfilter-binding-delete to be used. > > Note using these commands lets you delete filters that were > previously created automatically by the virt drivers, or add > filters for VM

Re: [libvirt] [PATCH v3 17/20] nwfilter: remove virt driver callback layer for rebuilding filters

2018-06-18 Thread John Ferlan
On 06/14/2018 08:33 AM, Daniel P. Berrangé wrote: > Now that the nwfilter driver keeps a list of bindings that it has > created, there is no need for the complex virt driver callbacks. It is > possible to simply iterate of the list of recorded filter bindings. > > This means that rebuilding

Re: [libvirt] [PATCH v3 16/20] nwfilter: keep track of active filter bindings

2018-06-18 Thread John Ferlan
On 06/14/2018 08:33 AM, Daniel P. Berrangé wrote: > Currently the nwfilter driver does not keep any record of what filter > bindings it has active. This means that when it needs to recreate > filters, it has to rely on triggering callbacks provided by the virt > drivers. This introduces a hash

[libvirt] [PATCH 4/4] qemu: Escape commas for qemuBuildGrapicsSPICECommandLine

2018-06-18 Thread Anya Harter
Add comma escaping for cfg->spiceTLSx509certdir and graphics->data.spice.rendernode. Signed-off-by: Anya Harter --- src/qemu/qemu_command.c | 11 --- tests/qemuxml2argvdata/name-escape.args | 5 +++-- tests/qemuxml2argvdata/name-escape.xml | 1 +

[libvirt] [PATCH 1/4] qemu: Escape commas for qemuBuildChrChardevStr

2018-06-18 Thread Anya Harter
Add comma escaping for dev->data.file.path in cases VIR_DOMAIN_CHR_TYPE_DEV and VIR_DOMAIN_CHR_TYPE_PIPE. Signed-off-by: Anya Harter --- src/qemu/qemu_command.c | 9 + tests/qemuxml2argvdata/name-escape.args | 4 tests/qemuxml2argvdata/name-escape.xml | 7 +++

[libvirt] [PATCH 2/4] qemu: Escape commas for qemuBuildChrChardevFileStr

2018-06-18 Thread Anya Harter
Add comma escaping for fileval. Signed-off-by: Anya Harter --- src/qemu/qemu_command.c | 3 ++- tests/qemuxml2argvdata/name-escape.args | 2 ++ tests/qemuxml2argvdata/name-escape.xml | 4 tests/qemuxml2argvtest.c| 3 ++- 4 files changed, 10 insertions(+), 2

[libvirt] [PATCH 0/4] qemu: add comma escaping in qemu_command.c

2018-06-18 Thread Anya Harter
The function virQEMUBuildBufferEscapeComma is used to escape commas in user provided fields for qemu command line processing in the four functions listed below. A corresponding test for each comma escaping instance has been added to tests/qemuxml2argvdata/name-escape.xml. This should complete

[libvirt] [PATCH 3/4] qemu: Escape commas for qemuBuildSmartcardCommandLine

2018-06-18 Thread Anya Harter
Add comma escaping for smartcard->data.cert.file[i] and smartcard->data.cert.database. Signed-off-by: Anya Harter --- src/qemu/qemu_command.c | 21 - tests/qemuxml2argvdata/name-escape.args | 3 +++ tests/qemuxml2argvdata/name-escape.xml | 6 ++

Re: [libvirt] [Qemu-devel] [PATCH RFC] hw/pc: set q35 as the default x86 machine

2018-06-18 Thread Michael S. Tsirkin
On Mon, Jun 18, 2018 at 02:14:31PM -0300, Eduardo Habkost wrote: > > Sure if someone does that, we'll have no choice, but as long as 'pc' is > > shipped we shouldn't gratuitously break apps by changing the default. > > Right. I just want to make sure "omitting the machine-type may > stop working

Re: [libvirt] [Qemu-devel] [PATCH RFC] hw/pc: set q35 as the default x86 machine

2018-06-18 Thread Eduardo Habkost
On Fri, Jun 15, 2018 at 10:03:14AM +0100, Daniel P. Berrangé wrote: > On Thu, Jun 14, 2018 at 11:50:56PM -0300, Eduardo Habkost wrote: > > On Thu, Jun 14, 2018 at 09:09:48AM +0100, Daniel P. Berrangé wrote: > > > On Wed, Jun 13, 2018 at 03:05:08PM -0300, Eduardo Habkost wrote: > > > > Getting back

Re: [libvirt] [PATCH v3 14/20] conf: introduce a virNWFilterBindingObjPtr struct

2018-06-18 Thread John Ferlan
On 06/14/2018 08:33 AM, Daniel P. Berrangé wrote: > Introduce a new struct to act as the stateful owner of the > virNWFilterBindingDefPtr objects. > > Signed-off-by: Daniel P. Berrangé > --- > src/conf/Makefile.inc.am | 2 + > src/conf/virnwfilterbindingobj.c | 299

Re: [libvirt] [PATCH] qemu: Fix qemuMonitorCreateObjectProps

2018-06-18 Thread John Ferlan
On 06/18/2018 08:35 AM, Ján Tomko wrote: > The commit message is one long sentence and a bit hard to read. > True, haha so it is... Still better than nothing and assuming the reader can figure it out ;-) > On Mon, Jun 18, 2018 at 07:56:35AM -0400, John Ferlan wrote: >> Commit id f0a23c0c3

Re: [libvirt] [PATCH] qemu: Fix qemuMonitorCreateObjectProps

2018-06-18 Thread Ján Tomko
The commit message is one long sentence and a bit hard to read. On Mon, Jun 18, 2018 at 07:56:35AM -0400, John Ferlan wrote: Commit id f0a23c0c3 introduced qemuMonitorCreateObjectProps to manage wrapping the object name and alias; however, calling Listing the commit that broke it can be in a

Re: [libvirt] [libvirt-go-xml PATCH v2 2/2] Add support for SEV in domain capabilities XML

2018-06-18 Thread Erik Skultety
On Mon, Jun 18, 2018 at 01:15:54PM +0100, Daniel P. Berrangé wrote: > On Mon, Jun 18, 2018 at 09:06:00AM +0200, Erik Skultety wrote: > > Signed-off-by: Erik Skultety > > Reviewed-by: Daniel P. Berrangé > > Lost my email address here. Oops, fixed. Thanks a lot for your help and guidance

Re: [libvirt] [dockerfiles PATCH] README: Provide information about the images

2018-06-18 Thread Daniel P . Berrangé
On Fri, Jun 15, 2018 at 07:03:47PM +0200, Andrea Bolognani wrote: > Signed-off-by: Andrea Bolognani > --- > Note that this document will be displayed both for the > repository containing the Dockerfiles > > https://github.com/libvirt/libvirt-dockerfiles > > and for the images produced by said

Re: [libvirt] [libvirt-go-xml PATCH v2 2/2] Add support for SEV in domain capabilities XML

2018-06-18 Thread Daniel P . Berrangé
On Mon, Jun 18, 2018 at 09:06:00AM +0200, Erik Skultety wrote: > Signed-off-by: Erik Skultety > Reviewed-by: Daniel P. Berrangé Lost my email address here. Reviewed-by: Daniel P. Berrangé > --- > domain_capabilities.go | 7 +++ > 1 file changed, 7 insertions(+) > > diff --git

Re: [libvirt] [libvirt-go-xml PATCH v2 1/2] Add support for domain launch security

2018-06-18 Thread Daniel P . Berrangé
On Mon, Jun 18, 2018 at 09:05:59AM +0200, Erik Skultety wrote: > Signed-off-by: Erik Skultety > --- > domain.go | 162 > +- > 1 file changed, 161 insertions(+), 1 deletion(-) Reviewed-by: Daniel P. Berrangé Regards, Daniel -- |:

[libvirt] [PATCH] qemu: Fix qemuMonitorCreateObjectProps

2018-06-18 Thread John Ferlan
Commit id f0a23c0c3 introduced qemuMonitorCreateObjectProps to manage wrapping the object name and alias; however, calling virJSONValueObjectCreateVArgs and checking a unary ! return status meant when the CreateVAArgs function returned zero, then rather than generating a @propsret, the jump to

Re: [libvirt] [GSoC] Code design for scalar and external types

2018-06-18 Thread Andrea Bolognani
On Mon, 2018-06-18 at 11:52 +0100, Daniel P. Berrangé wrote: > On Mon, Jun 18, 2018 at 12:24:39PM +0200, Pavel Hrdina wrote: > > # define VIR_DEFINE_AUTOCLEAR_FUNC(type, func) \ > > static inline void VIR_AUTOCLEAR_FUNC_NAME(type)(type *_ptr) \ > > { \ > > (func)(_ptr); \ > > }

[libvirt] [dbus PATCH] README: Drop warning about lack of API/ABI guarantees

2018-06-18 Thread Andrea Bolognani
We have promised not to break compatibility after v1.0.0, which means the warning is no longer accurate and should be dropped. Signed-off-by: Andrea Bolognani --- README.md | 3 --- 1 file changed, 3 deletions(-) diff --git a/README.md b/README.md index 1ce265c..66aa6f6 100644 --- a/README.md

Re: [libvirt] [PATCH 2/2] rpc: Fix segmentation fault when no worker pool is available

2018-06-18 Thread Marc Hartmayer
On Mon, Jun 18, 2018 at 09:47 AM +0200, Erik Skultety wrote: > On Fri, Jun 15, 2018 at 03:31:34PM +0200, Marc Hartmayer wrote: >> On Fri, Jun 15, 2018 at 01:39 PM +0200, Marc Hartmayer >> wrote: >> > If srv->workers is a NULL pointer, as it is the case if there are no >> > workers, then don't

Re: [libvirt] [GSoC] Code design for scalar and external types

2018-06-18 Thread Daniel P . Berrangé
On Mon, Jun 18, 2018 at 12:24:39PM +0200, Pavel Hrdina wrote: > Hi, > > It took me longer to sit down and write this mail but here it goes. > > There was a lot of ideas about the macro design and it's easy to > get lost in all the designs. > > So we agreed on this form: > > > # define

Re: [libvirt] [PATCH 2/2] rpc: Fix segmentation fault when no worker pool is available

2018-06-18 Thread Marc Hartmayer
On Mon, Jun 18, 2018 at 09:47 AM +0200, Erik Skultety wrote: > On Fri, Jun 15, 2018 at 03:31:34PM +0200, Marc Hartmayer wrote: >> On Fri, Jun 15, 2018 at 01:39 PM +0200, Marc Hartmayer >> wrote: >> > If srv->workers is a NULL pointer, as it is the case if there are no >> > workers, then don't

Re: [libvirt] [GSoC] Code design for scalar and external types

2018-06-18 Thread Pavel Hrdina
Hi, It took me longer to sit down and write this mail but here it goes. There was a lot of ideas about the macro design and it's easy to get lost in all the designs. So we agreed on this form: # define VIR_AUTOPTR_FUNC_NAME(type) virAutoPtr##type # define VIR_AUTOCLEAR_FUNC_NAME(type)

[libvirt] [PATCH v2 3/3] qemu: Switch code to use new agent job APIs

2018-06-18 Thread Michal Privoznik
There are two sets of functions here: 1) some functions talk on both monitor and agent monitor, 2) some functions only talk on agent monitor. For functions from set 1) we need to use qemuDomainObjBeginJobWithAgent() and for functions from set 2) we need to use qemuDomainObjBeginAgentJob() only.

[libvirt] [PATCH v2 0/3] qemu: Allow concurrent access to monitor and guest agent

2018-06-18 Thread Michal Privoznik
v2 of: https://www.redhat.com/archives/libvir-list/2018-June/msg00700.html diff to v1: - extended THREADS.txt documentation - added more comments - merged 3/4 to 1/4 in original patch set (I think that's everything that was pointed out in John's review) Michal Privoznik (3): qemu: Introduce

[libvirt] [PATCH v2 2/3] qemu: Introduce APIs for manipulating qemuDomainAgentJob

2018-06-18 Thread Michal Privoznik
The point is to break QEMU_JOB_* into smaller pieces which enables us to achieve higher throughput. For instance, if there are two threads, one is trying to query something on qemu monitor while the other is trying to query something on agent monitor these two threads would serialize. There is not

[libvirt] [PATCH v2 1/3] qemu: Introduce qemuDomainAgentJob

2018-06-18 Thread Michal Privoznik
Introduce guest agent specific job categories to allow threads to run agent monitor specific jobs while normal monitor jobs can also be running. Alter _qemuDomainJobObj in order to duplicate certain fields that will be used for guest agent specific tasks to increase concurrency and throughput and

Re: [libvirt] [PATCH 2/2] rpc: Fix segmentation fault when no worker pool is available

2018-06-18 Thread Erik Skultety
On Fri, Jun 15, 2018 at 03:31:34PM +0200, Marc Hartmayer wrote: > On Fri, Jun 15, 2018 at 01:39 PM +0200, Marc Hartmayer > wrote: > > If srv->workers is a NULL pointer, as it is the case if there are no > > workers, then don't try to dereference it. > > > > Signed-off-by: Marc Hartmayer > >

[libvirt] [PATCH 2/2] qemu: sev: Don't jump to endjob if SEV measurement retrieval fails

2018-06-18 Thread Erik Skultety
If measurement retrieval fails we'd forget to call ExitMonitor to unlock the monitor. Signed-off-by: Erik Skultety Reported-by: Luyao Huang --- src/qemu/qemu_driver.c | 4 +--- 1 file changed, 1 insertion(+), 3 deletions(-) diff --git a/src/qemu/qemu_driver.c b/src/qemu/qemu_driver.c index

[libvirt] [PATCH 1/2] qemu: sev: Use EnterMonitor instead of EnterMonitorAsync

2018-06-18 Thread Erik Skultety
Since it's being called with QEMU_ASYNC_JOB_NONE which is what qemuDomainObjEnterMonitor is going to use with the internal helper, let's use that one instead. Signed-off-by: Erik Skultety --- src/qemu/qemu_driver.c | 4 +--- 1 file changed, 1 insertion(+), 3 deletions(-) diff --git

[libvirt] [PATCH 0/2] A potential deadlock fix for SEV and a tiny cleanup

2018-06-18 Thread Erik Skultety
*** BLURB HERE *** Erik Skultety (2): qemu: sev: Use EnterMonitor instead of EnterMonitorAsync qemu: sev: Don't jump to endjob if SEV measurement retrieval fails src/qemu/qemu_driver.c | 8 ++-- 1 file changed, 2 insertions(+), 6 deletions(-) -- 2.14.4 -- libvir-list mailing list

[libvirt] [libvirt-go-xml PATCH v2 1/2] Add support for domain launch security

2018-06-18 Thread Erik Skultety
Signed-off-by: Erik Skultety --- domain.go | 162 +- 1 file changed, 161 insertions(+), 1 deletion(-) diff --git a/domain.go b/domain.go index aeeb24a..c910962 100644 --- a/domain.go +++ b/domain.go @@ -1863,6 +1863,18 @@ type

[libvirt] [libvirt-go-xml PATCH v2 0/2] Add support for domain launch security

2018-06-18 Thread Erik Skultety
since v1: - added a launch security subtype for SEV to avoid having a 'type' XML attribute Erik Skultety (2): Add support for domain launch security Add support for SEV in domain capabilities XML domain.go | 162 -

[libvirt] [libvirt-go-xml PATCH v2 2/2] Add support for SEV in domain capabilities XML

2018-06-18 Thread Erik Skultety
Signed-off-by: Erik Skultety Reviewed-by: Daniel P. Berrangé --- domain_capabilities.go | 7 +++ 1 file changed, 7 insertions(+) diff --git a/domain_capabilities.go b/domain_capabilities.go index 3f5a752..0faa06a 100644 --- a/domain_capabilities.go +++ b/domain_capabilities.go @@ -106,6

Re: [libvirt] [PATCH] events: Remove ATTRIBUTE_NONNULL for virObjectEventStateQueue[Remote]

2018-06-18 Thread Ján Tomko
On Fri, Jun 15, 2018 at 03:49:51PM -0400, John Ferlan wrote: Commit aad3a0b5f altered virObjectEventStateQueueRemote to move the "if (!event) return" call added in the previous commit 031eb8f6 to virObjectEventStateQueue. Neither commit altered the function prototype which used

Re: [libvirt] [libvirt-go PATCH 2/2] Add support for AMD SEV platform info

2018-06-18 Thread Erik Skultety
On Thu, Jun 14, 2018 at 04:52:04PM +0100, Daniel P. Berrangé wrote: > On Thu, Jun 14, 2018 at 04:30:01PM +0200, Erik Skultety wrote: > > Signed-off-by: Erik Skultety > > --- > > connect.go| 59 > > +++ > > connect_compat.go | 12

Re: [libvirt] [PATCH] qemuDomainDetachDeviceConfig: Don't free device from @dev

2018-06-18 Thread Ján Tomko
On Fri, Jun 15, 2018 at 04:20:41PM +0200, Michal Privoznik wrote: https://bugzilla.redhat.com/show_bug.cgi?id=1591561 For reasons I don't understand my original patch of 75f0fd51124 freed not only the chardev from domain but also the one from passed virDomainDeviceDefPtr. This caused no