[Lift] Re: Lift 1.1 must use Scala 2.8.x ?

2009-10-14 Thread Naftoli Gugenheim

No

On Wed, Oct 14, 2009 at 9:18 PM, Neil.Lv anim...@gmail.com wrote:

 Hi all,

  If i want to use the lift1.1 whether the scala version must greater
 than 2.8 ?

  My lift version is 2.7.4 now, so i must change to 2.8.x ?

  Thanks very much !

 Cheers,
  Neil

 


--~--~-~--~~~---~--~~
You received this message because you are subscribed to the Google Groups 
Lift group.
To post to this group, send email to liftweb@googlegroups.com
To unsubscribe from this group, send email to 
liftweb+unsubscr...@googlegroups.com
For more options, visit this group at 
http://groups.google.com/group/liftweb?hl=en
-~--~~~~--~~--~--~---



[Lift] Re: Lift 1.1 must use Scala 2.8.x ?

2009-10-14 Thread Wilson MacGyver

no, if you are using the current milestone or snapshot, you'll see it's still
using scala 2.7.x series.

I don't think lift will switch to 2.8 anytime soon. too many changes
and too many unknowns. I'm not even sure if scalatest compiles at
this point with 2.8 snapshot.

Or in short, let mvn take care of which scala to use.

On Wed, Oct 14, 2009 at 9:18 PM, Neil.Lv anim...@gmail.com wrote:

 Hi all,

  If i want to use the lift1.1 whether the scala version must greater
 than 2.8 ?

  My lift version is 2.7.4 now, so i must change to 2.8.x ?

  Thanks very much !

 Cheers,
  Neil

 




-- 
Omnem crede diem tibi diluxisse supremum.

--~--~-~--~~~---~--~~
You received this message because you are subscribed to the Google Groups 
Lift group.
To post to this group, send email to liftweb@googlegroups.com
To unsubscribe from this group, send email to 
liftweb+unsubscr...@googlegroups.com
For more options, visit this group at 
http://groups.google.com/group/liftweb?hl=en
-~--~~~~--~~--~--~---



[Lift] Re: Lift 1.1 must use Scala 2.8.x ?

2009-10-14 Thread Atsuhiko Yamanaka

Hi,

On Thu, Oct 15, 2009 at 11:07 AM, David Pollak
feeder.of.the.be...@gmail.com wrote:
 On Wed, Oct 14, 2009 at 6:18 PM, Neil.Lv anim...@gmail.com wrote:
  If i want to use the lift1.1 whether the scala version must greater
 than 2.8 ?

  My lift version is 2.7.4 now, so i must change to 2.8.x ?

 Scala is very brittle and versions of Scala must be exactly the same version
 as libraries compiled against Scala.  Please make sure that you have 2.7.5
 as the version of Scala you run for Lift 1.0.2 or 1.1-M5/6/SNAPSHOT.

 We will run against Scala 2.8 and we're working with the Scala team to make
 sure that Lift works well with 2.8.  Currently, there's a compiler error
 that makes compiling Lift against 2.8 impossible.

Explicitly speaking, does it mean that Lift 1.1 will also run on scala 2.7._ ?
I had guessed that Lift 1.1 will run only on scala 2.8,
because it will require hard work to support scala 2.8 and 2.7._ simultaneously.


Sincerely,
--
Atsuhiko Yamanaka
JCraft,Inc.
1-14-20 HONCHO AOBA-KU,
SENDAI, MIYAGI 980-0014 Japan.
Tel +81-22-723-2150
+1-415-578-3454
Skype callto://jcraft/

--~--~-~--~~~---~--~~
You received this message because you are subscribed to the Google Groups 
Lift group.
To post to this group, send email to liftweb@googlegroups.com
To unsubscribe from this group, send email to 
liftweb+unsubscr...@googlegroups.com
For more options, visit this group at 
http://groups.google.com/group/liftweb?hl=en
-~--~~~~--~~--~--~---



[Lift] Re: Lift 1.1 must use Scala 2.8.x ?

2009-10-14 Thread David Pollak
On Wed, Oct 14, 2009 at 7:50 PM, Atsuhiko Yamanaka 
atsuhiko.yaman...@gmail.com wrote:


 Hi,

 On Thu, Oct 15, 2009 at 11:07 AM, David Pollak
 feeder.of.the.be...@gmail.com wrote:
  On Wed, Oct 14, 2009 at 6:18 PM, Neil.Lv anim...@gmail.com wrote:
   If i want to use the lift1.1 whether the scala version must greater
  than 2.8 ?
 
   My lift version is 2.7.4 now, so i must change to 2.8.x ?
 
  Scala is very brittle and versions of Scala must be exactly the same
 version
  as libraries compiled against Scala.  Please make sure that you have
 2.7.5
  as the version of Scala you run for Lift 1.0.2 or 1.1-M5/6/SNAPSHOT.
 
  We will run against Scala 2.8 and we're working with the Scala team to
 make
  sure that Lift works well with 2.8.  Currently, there's a compiler error
  that makes compiling Lift against 2.8 impossible.

 Explicitly speaking, does it mean that Lift 1.1 will also run on scala
 2.7._ ?


Lift currently *only* runs on Scala 2.7.5.

If we can do multi-target compilation (the SBT guys are working on such a
beast), we will support it.

It will be very difficult, however, to compile against 2.7 and 2.8 with the
same source base.  It's likely that if there's a huge demand, we will have
parallel branches compiling against 2.7.7/8 and 2.8, but only if there's a
really good reason.


 I had guessed that Lift 1.1 will run only on scala 2.8,
 because it will require hard work to support scala 2.8 and 2.7._
 simultaneously.


 Sincerely,
 --
 Atsuhiko Yamanaka
 JCraft,Inc.
 1-14-20 HONCHO AOBA-KU,
 SENDAI, MIYAGI 980-0014 Japan.
 Tel +81-22-723-2150
+1-415-578-3454
 Skype callto://jcraft/

 



-- 
Lift, the simply functional web framework http://liftweb.net
Beginning Scala http://www.apress.com/book/view/1430219890
Follow me: http://twitter.com/dpp
Surf the harmonics

--~--~-~--~~~---~--~~
You received this message because you are subscribed to the Google Groups 
Lift group.
To post to this group, send email to liftweb@googlegroups.com
To unsubscribe from this group, send email to 
liftweb+unsubscr...@googlegroups.com
For more options, visit this group at 
http://groups.google.com/group/liftweb?hl=en
-~--~~~~--~~--~--~---