[Lift] Re: Required goal not found: archetype:generate

2009-03-13 Thread erik.fris...@googlemail.com
No, its not a typo in the PDF. I just got it mixed up when typing the query. Erik On Mar 13, 1:50 pm, Derek Chen-Becker dchenbec...@gmail.com wrote: Is that a typo in the PDF? If so, I'll fix it. Derek On Thu, Mar 12, 2009 at 2:36 PM, Alexander Kellett lypa...@gmail.comwrote: Few

[Lift] Re: Required goal not found: archetype:generate

2009-03-13 Thread David Pollak
On Fri, Mar 13, 2009 at 10:52 AM, erik.fris...@googlemail.com erik.fris...@googlemail.com wrote: No, its not a typo in the PDF. I just got it mixed up when typing the query. Just as a point of order, I'm glad that you stuck with the thread and didn't get too frustrated. I'm glad we could

[Lift] Re: Required goal not found: archetype:generate

2009-03-12 Thread TylerWeir
What do you get from mvn -version ? On Mar 12, 12:30 pm, erik.fris...@googlemail.com erik.fris...@googlemail.com wrote: Hi guys, I am just starting out with lift. I wanted to work my way through the Getting Started Example. But I just can't get maven to work correctly. When I run mvn

[Lift] Re: Required goal not found: archetype:generate

2009-03-12 Thread erik.fris...@googlemail.com
Hi again, I figured this one out. During some fixing I unwittingly overwrote my .bash_profile, reverting maven to the 2.0.6 version. I am running Leopard. I don't get this error anymoreyou guessed it, I get another. Now I get this: The desired archetype does not exist

[Lift] Re: Required goal not found: archetype:generate

2009-03-12 Thread TylerWeir
Oh, by the way, pro-tip: You can poke around in the mvn repo online here: http://scala-tools.org/repo-releases/net/liftweb/ You can see that the older command was looking for version 0.1 of lift-archetype-blank and that's just crazy talk! Ty On Mar 12, 1:09 pm, TylerWeir tyler.w...@gmail.com

[Lift] Re: Required goal not found: archetype:generate

2009-03-12 Thread erik.fris...@googlemail.com
You are indeed right, my PDF was outdated. I have to admit though I have no clue how that happened, I downloaded it today. Anyway, I ran the following command: mvn archetype:generate -U \ -DarchetypeGroupId:net.liftweb \ -DarchetypeArtifactId=lift-archetype-blank \ -DarchetypeVersion=1.0 \

[Lift] Re: Required goal not found: archetype:generate

2009-03-12 Thread Alexander Kellett
Ah. Feel much better.. Thought it was just me and never took the time to look into this. I get the same thing... Looking at mvn -X I see: [DEBUG] (f) remoteArtifactRepositories = [[central] - http://repo1.maven.org/maven2] Googling for a while helps not... any ideas? On Thu, Mar 12, 2009 at

[Lift] Re: Required goal not found: archetype:generate

2009-03-12 Thread TylerWeir
o, k. Since I'm getting the same error and I'm unsure why, try this on: mvn -e archetype:generate then you'll get a list mvn can make for you. lift-blank is # 32. You then fill bits and pieces yourself like this: Choose a number:

[Lift] Re: Required goal not found: archetype:generate

2009-03-12 Thread TylerWeir
Erik, I have sent you some mail. And I used the internet. Tyler On Mar 12, 1:34 pm, TylerWeir tyler.w...@gmail.com wrote: o, k.  Since I'm getting the same error and I'm unsure why, try this on: mvn -e archetype:generate then you'll get a list mvn can make for you.  lift-blank is #

[Lift] Re: Required goal not found: archetype:generate

2009-03-12 Thread Alexander Kellett
Few hours of playing with maven (multiple versions) and getting increasingly annoyed by it... and I suddenly revisited this part of the command: -DarchetypeGroupId:net.liftweb : should be =! Works just fine after that change :) Alex On Thu, Mar 12, 2009 at 6:34 PM, TylerWeir