[Lift] Silly question about Lift project navigation in Netbeans

2009-10-14 Thread GA
of course open them manually (File-Open File) and edit them, but I would like to see them in the project navigation in the side bar. Any ideas on how to do it? Thanks in advance, GA --~--~-~--~~~---~--~~ You received this message because you are subscribed

[Lift] Re: Complex primary key

2009-10-14 Thread GA
in advance, GA -- Lift, the simply functional web framework http://liftweb.net Beginning Scala http://www.apress.com/book/view/1430219890 Follow me: http://twitter.com/dpp Surf the harmonics -- Lift, the simply functional web framework http://liftweb.net Beginning Scala http

[Lift] Re: Silly question about Lift project navigation in Netbeans

2009-10-14 Thread GA
Problem solved. The issue was that I did not have installed the J2EE plugins. I added them and after I restarted the folder Web Pages appeared. GA On Oct 14, 2009, at 10:44 AM, GA wrote: Hello guys, I am working with Netbeans and I like it, but there is a small thing I am not able

[Lift] Re: Complex primary key

2009-10-14 Thread GA
It is only available in Lift 1.1 right? GA On Oct 14, 2009, at 11:47 AM, Peter Robinett wrote: http://scala-tools.org/mvnsites-snapshots/liftweb/lift-mapper/scaladocs/net/liftweb/mapper/ManyToMany.html If you look back in the group there is a thread announcing the addition of the trait

[Lift] Sending a XML message to a Lift server

2009-10-14 Thread GA
, GA --~--~-~--~~~---~--~~ You received this message because you are subscribed to the Google Groups Lift group. To post to this group, send email to liftweb@googlegroups.com To unsubscribe from this group, send email to liftweb+unsubscr...@googlegroups.com

[Lift] Re: Sending a XML message to a Lift server

2009-10-15 Thread GA
).getLines.mkString ^ two errors found !!! discarding script preamble !!! discarding script preamble Any suggestions? Thanks, GA On Oct 14, 2009, at 8:35 PM, jon wrote: oh, if you want to parse directly into xml replace Source.fromInputStream(conn.getInputStream

[Lift] error: not found: type IdPK in Lift 1.1

2009-10-15 Thread GA
Hello guys, I have a Lift project working perfectly in version 1.0, but when I moved it to Lift 1.1 I am having errors with the Modeler with the type IdPK. Any ideas? Thanks, GA --~--~-~--~~~---~--~~ You received this message because you are subscribed

[Lift] Re: error: not found: type IdPK in Lift 1.1

2009-10-15 Thread GA
(a) = a.userName case _ = No Account Name } } } object Person extends Person with LongKeyedMetaMapper[Person] On Oct 15, 2009, at 5:04 PM, David Pollak wrote: Can you post an example (complete file) of something's not working? On Thu, Oct 15, 2009 at 3:21 AM, GA my_li

[Lift] Re: error: not found: type IdPK in Lift 1.1

2009-10-16 Thread GA
Is there any way to reset maven's repository? I think there is something corrupt because the behavior is really strange. I think this is the cause of my error. Thanks, On Oct 15, 2009, at 5:52 PM, GA wrote: It is strange. I do not have the entries that you are saying in the pom.xml

[Lift] Re: error: not found: type IdPK in Lift 1.1

2009-10-16 Thread GA
) net.liftweb:lift-mapper:jar:1.1-SNAPSHOT -- 1 required artifact is missing. It is very strange. It was working before without problems. Any ideas? Thanks, GA On Oct 16, 2009, at 11:09 AM, Timothy Perrett wrote: Just remove ~/.m2 The next time you make a maven call it'll then download all

[Lift] Re: error: not found: type IdPK in Lift 1.1

2009-10-16 Thread GA
-tools.org/id nameScala-Tools Maven2 Repository/name urlhttp://scala-tools.org/repo-releases/url /pluginRepository /pluginRepositories It is ok? Cheers, GA On Oct 16, 2009, at 12:33 PM, Timothy Perrett wrote: You must be missing the correct repository tag. Check that you have

[Lift] Re: error: not found: type IdPK in Lift 1.1

2009-10-16 Thread GA
3 source files to /Users/gacilu/NetBeansProjects/ gaTribesServer/target/classes /Users/gacilu/NetBeansProjects/gaTribesServer/src/main/scala/com/ tribes/ga/model/User.scala:9: error: wrong number of type arguments for net.liftweb.mapper.MetaMegaProtoUser, should be 1 object User extends User

[Lift] Re: error: not found: type IdPK in Lift 1.1

2009-10-16 Thread GA
-2009, LAMP/EPFL Cheers, GA On Oct 16, 2009, at 2:57 PM, Timothy Perrett wrote: Try creating a blank project, not a basic one... Lets see what happens then. Cheers, Tim On 16 Oct 2009, at 13:39, GA wrote: More errors. Shouldn't this be working right after the creation? I am talking

[Lift] Re: error: not found: type IdPK in Lift 1.1

2009-10-16 Thread GA
in your pom.xml file is 2.7.5. On Fri, Oct 16, 2009 at 4:40 AM, GA my_li...@me.com wrote: Ok, now we have an improvement. I did the following: I replaced the following part of my pom.xml: repositories repository idscala-tools.org/id nameScala-Tools Maven2 Repository

[Lift] Re: error: not found: type IdPK in Lift 1.1

2009-10-16 Thread GA
Could you please send me a pom.xml example for lift 1.1? Cheers, GA On Oct 16, 2009, at 4:28 PM, GA wrote: Why is it getting the 2.7.1 version in first place? The pom.xml is created by maven from the archetype and repository right? Is it perhaps some environment setup that I have or I

[Lift] Re: error: not found: type IdPK in Lift 1.1

2009-10-16 Thread GA
You were right. I was making things complicated. the mvn command I was writing was wrong... I stopped and started all over. I retyped it from scratch and I found the errors. Thanks for your help guys. My project works in 1.1-M6 just fine. Cheers, GA On Oct 16, 2009, at 5:04 PM, David

[Lift] Re: Why the liftweb doesn't use mysql as the default database ?

2009-10-21 Thread GA
I absolutely agree with the last statement. We changed from MySQL to PostgreSQL. Most of us here are Oracle DBAs, and we feel at home with PostgreSQL. We have made tests in the three platforms and we have chosen PostgreSQL. PostgreSQL gives us most of the main features of Oracle in an

[Lift] Re: Where is the default.props in the lift1.1-M6 and the Full method ?

2009-10-21 Thread GA
. I do not know about the Full method. I also should ask the silly question. :-) I hope this helps. Cheers, GA On Oct 21, 2009, at 10:24 AM, Neil.Lv wrote: Hi all, Where is the default.props in the lift1.1-M6 whether the file name is defualt.props ? I see this code

[Lift] Problem to process a PUT request in a lift API

2009-10-23 Thread GA
goes through the last case: Request was malformed. I was checking the values to req.view and req.xml.toString and the results are person and empty, respectively. Any ideas about what it could be happening? Thanks in advance, GA --~--~-~--~~~---~--~~ You

[Lift] Re: Problem to process a PUT request in a lift API

2009-10-23 Thread GA
) scala.io.Source.fromInputStream (conn.getInputStream).getLines.mkString } } } Any suggestions? Cheers, GA On Oct 23, 2009, at 5:15 PM, GA wrote: Hello guys, I have created an API to process a PUT request and a GET request. The GET works perfectly fine, but with the PUT the XML seems

[Lift] Re: Problem to process a PUT request in a lift API

2009-10-24 Thread GA
Thanks David. You were right. I added this line: conn.addRequestProperty(content-type, text/xml) and it works perfectly. Thanks again. GA On Oct 23, 2009, at 7:36 PM, David Pollak wrote: In order to trigger XML parsing, you have to set the Content-Type to text/xml On Fri, Oct 23

[Lift] Re: I am not able to save a many-to-many relationship from an API

2009-10-26 Thread GA
must be saved before I save the relationship. Am I right? or I am doing something wrong? Thanks, GA On Oct 26, 2009, at 6:55 PM, GA wrote: Hello guys, I have a many-to-many relationship between two mappers called, Users and Devices. There is also an API that receives and XML message

[Lift] Re: I am not able to save a many-to-many relationship from an API

2009-10-26 Thread GA
of this table? Why am I using IdPK? Couldn't I just remove it? Thanks, GA On Oct 26, 2009, at 7:49 PM, Jim Barrows wrote: On Mon, Oct 26, 2009 at 11:43 AM, GA my_li...@me.com wrote: I have made a test that worked. I have modified my code like

[Lift] How to receive content-type application/json in a Lift API

2009-10-27 Thread GA
) } I want to parse the content using the net.liftweb.jsonParser but the server returns HTTP 500 error. If the content-type is text/xml, the message comes inside of req.xml, where does it come when it is application/json? Thanks in advance, GA

[Lift] Re: How to receive content-type application/json in a Lift API

2009-10-27 Thread GA
) } val json = parse(message) Is there an easier way to write this? I am quite new in scala yet. Thanks, GA On Oct 27, 2009, at 5:09 PM, David Pollak wrote: On Tue, Oct 27, 2009 at 9:05 AM, GA my_li...@me.com wrote: Hello guys, I have a small Lift API that has to receive JSON

[Lift] A better way to create a JSON Response

2009-10-29 Thread GA
that the extraction was ok, and I respond with the very same document as plain text. The client receives the document again without problems. My question is about the response. Is it ok to respond as plain text? Or is it a more direct way to do it? Thanks in advance, GA

[Lift] RSS Library

2009-10-30 Thread GA
Hello guys, is there any standard RSS Library to parse RSS and Atom feeds from a scala client? Thanks in advance, GA --~--~-~--~~~---~--~~ You received this message because you are subscribed to the Google Groups Lift group. To post to this group, send

[Lift] Working with database views

2009-11-08 Thread GA
is expecting a Mapper[SyncVW] object and it is receiving SyncVW. What am I doing wrong? Thanks, GA --~--~-~--~~~---~--~~ You received this message because you are subscribed to the Google Groups Lift group. To post to this group, send email to liftweb@googlegroups.com

[Lift] Re: Working with database views

2009-11-08 Thread GA
Yes, it just did the trick. It compiles now. Why is it working now? Isn't it Mapper also a MetaMapper? On Nov 8, 2009, at 12:27 PM, Jeppe Nejsum Madsen wrote: GA my_li...@me.com writes: Hello guys, I need to create a database view to create a very specific query from an API. I am

[Lift] JsonResponse with non string values

2009-11-09 Thread GA
in advance, GA --~--~-~--~~~---~--~~ You received this message because you are subscribed to the Google Groups Lift group. To post to this group, send email to liftweb@googlegroups.com To unsubscribe from this group, send email to liftweb+unsubscr

[Lift] Re: JsonResponse with non string values

2009-11-09 Thread GA
Thanks for the answer. This line does the trick: newUser.id.asJsExp . It returns a type net.liftweb.http.js.JE.numToJsExp. GA On Nov 9, 2009, at 6:31 PM, Ross Mellgren wrote: Bring the numToJsExp implicit into scope -- import net.liftweb.http.js.JE.numToJsExp -Ross On Nov 9, 2009

[Lift] Concatenate JsObj objects

2009-11-09 Thread GA
a compilation error. I know I need to write it differently but I do not know how. Any suggestions? Thanks in advance, GA --~--~-~--~~~---~--~~ You received this message because you are subscribed to the Google Groups Lift group. To post to this group, send email

[Lift] Content is not allowed in prolog Parsing an XML

2009-11-12 Thread GA
ideas on how to solve this problem? Thanks in advance, GA --~--~-~--~~~---~--~~ You received this message because you are subscribed to the Google Groups Lift group. To post to this group, send email to liftweb@googlegroups.com To unsubscribe from this group, send

[Lift] Re: Content is not allowed in prolog Parsing an XML

2009-11-12 Thread GA
Sorry I've sent this email to the wrong list. On Nov 12, 2009, at 12:24 PM, GA wrote: Hello guys, I have the following scala code line: XML.load(new java.io.InputStreamReader(conn.getInputStream, UTF-8)) I am downloading and parsing RSS feeds. This line parses most of the sites

[Lift] Netbeans 6.8 issues with Lift

2009-12-25 Thread GA
. Does anybody have similar issues with Netbeans 6.8? Thanks in advance, GA -- You received this message because you are subscribed to the Google Groups Lift group. To post to this group, send email to lift...@googlegroups.com. To unsubscribe from this group, send email to liftweb+unsubscr

[Lift] Indentation problem with Eclipse plugin

2009-12-31 Thread GA
, Tribe) I was trying to live with it, but it is kind of annoying in long chunks of code. Any ideas on how to solve it? Thanks in advance and happy 2010 to everybody. Cheers, GA -- You received this message because you are subscribed to the Google Groups Lift group. To post to this group, send

Re: [Lift] Indentation problem with Eclipse plugin

2009-12-31 Thread GA
Thanks for the answers. Good to know that it has been fixed already on trunk. Any idea when the new release of the plugin will be available? Cheers, GA On Dec 31, 2009, at 1:12 PM, Miles Sabin wrote: On Thu, Dec 31, 2009 at 11:11 AM, Timothy Perrett timo...@getintheloop.eu wrote

[Lift] How to remove manyTomany children?

2010-01-05 Thread GA
do not really need an extra field just for the primary key. Could this be the problem? Any suggestions? Thanks in advance, GA -- You received this message because you are subscribed to the Google Groups "Lift" group. To post to this group, send email to lift...@google

Re: [Lift] How to remove manyTomany children?

2010-01-05 Thread GA
suggestions? Thanks in advance, GA -- You received this message because you are subscribed to the Google Groups Lift group. To post to this group, send email to lift...@googlegroups.com. To unsubscribe from this group, send email to liftweb+unsubscr...@googlegroups.com. For more

Re: [Lift] How to remove manyTomany children?

2010-01-05 Thread GA
the ManyToMany table is an extension of Mapper, not LongKeyedMapper. This is because I do not really need an extra field just for the primary key. Could this be the problem? Any suggestions? Thanks in advance, GA -- You received this message because you are subscribed to the Google Groups

[Lift] Show the deprecated messages

2010-01-13 Thread GA
to the mvn command but it does not recognize it. Thanks in advance, GA -- You received this message because you are subscribed to the Google Groups Lift group. To post to this group, send email to lift...@googlegroups.com. To unsubscribe from this group, send email to liftweb+unsubscr

Re: [Lift] Re: Show the deprecated messages

2010-01-13 Thread GA
It worked! Thanks, GA On Jan 13, 2010, at 11:37 AM, Timothy Perrett wrote: Something like: plugin groupIdorg.scala-tools/groupId artifactIdmaven-scala-plugin/artifactId version2.12.2/version configuration jvmArgs jvmArg-Xmx1024m

[Lift] Helpers.bind question

2010-02-09 Thread GA
to get the html content without changes in the tags? Thanks in advance, GA -- You received this message because you are subscribed to the Google Groups Lift group. To post to this group, send email to lift...@googlegroups.com. To unsubscribe from this group, send email to liftweb+unsubscr

Re: [Lift] Helpers.bind question

2010-02-09 Thread GA
, but I wanted to know if we can avoid this change. Thanks in advance, GA On Feb 9, 2010, at 8:31 PM, David Pollak wrote: On Tue, Feb 9, 2010 at 10:00 AM, GA my_li...@me.com wrote: Hello guys, I have a very silly question. I have a snippet that reads a string field from the database

Re: [Lift] Helpers.bind question

2010-02-09 Thread GA
Thanks guys. It works. On Feb 9, 2010, at 10:26 PM, David Pollak wrote: On Tue, Feb 9, 2010 at 12:04 PM, GA my_li...@me.com wrote: What we have here is a iphone native application that has the help screens in HTML. The help screens are in multiple languages and are stored

[Lift] Parsed JSON values do not match with class constructor

2010-02-11 Thread GA
[UpdatedFeeds], filterLogging: List[FilterLogging] ) val json = parse(req.body.map(bytes = new String(bytes, UTF-8)) openOr ) val request: UpdatedSource = json.extract[UpdatedSource] Any ideas? Thanks in advance, GA -- You

Re: [Lift] Re: Parsed JSON values do not match with class constructor

2010-02-11 Thread GA
That's exactly what I've just found out. :-) As a workaround I am forcing the client app to send 0.0. are you saying that the bug is fixed in Lift 2.0-M2? Thanks for the answer, cheers, GA On Feb 11, 2010, at 5:42 PM, Joni Freeman wrote: Hi, I believe this bug is already fixed in trunk

Re: [Lift] Re: Parsed JSON values do not match with class constructor

2010-02-11 Thread GA
Thanks I am gonna try and test it. When is 2.0-M2 going to be released? Cheers, GA On Feb 11, 2010, at 6:00 PM, Joni Freeman wrote: Yes, it is fixed in 2.0-M2. Cheers Joni On Feb 11, 6:54 pm, GA my_li...@me.com wrote: That's exactly what I've just found out. :-) As a workaround I

[Lift] email validation configuration

2010-03-05 Thread GA
. Thanks in advance, GA -- You received this message because you are subscribed to the Google Groups Lift group. To post to this group, send email to lift...@googlegroups.com. To unsubscribe from this group, send email to liftweb+unsubscr...@googlegroups.com. For more options, visit this group