[Lift] Re: directives versus snippets

2009-06-04 Thread Matt Williams
There's a dispatcher in Lift and it checks for user-supplied snippets before dispatching to the hard-coded snippet names. Is this actually the case? I have tried to replace the buiiltin snippet for Msgs in order to embed a span within the list items, but I needed to use a different name for

[Lift] Re: directives versus snippets

2009-06-04 Thread David Pollak
In order to override a built-in snippet, you must do: LiftRules.snippetDispatch.prepend{ case Msgs | msgs = } in Boot. The LiftRules snippet dispatch table is consulted first, before the by convention reflection-based snippet dispatching is invoked. This enhances performance. On Thu,

[Lift] Re: directives versus snippets

2009-06-04 Thread Matt Williams
Thank you David. Hello by the way, and thank you for such a graceful framework. Matt On Jun 4, 5:21 pm, David Pollak feeder.of.the.be...@gmail.com wrote: In order to override a built-in snippet, you must do: LiftRules.snippetDispatch.prepend{   case Msgs | msgs = } in Boot.  The

[Lift] Re: directives versus snippets

2009-04-10 Thread David Pollak
Bob, They are actually the same thing. Lift's processing directives are simply built-in snippets. You can, if you dare, override their functionality. :-) Thanks, David On Fri, Apr 10, 2009 at 11:23 AM, bob rbpas...@gmail.com wrote: if I see lift:/, it could mean one of two things: a

[Lift] Re: directives versus snippets

2009-04-10 Thread bob
ok, Jorge told me on IRC that bind and surround are hard-coded 11:16 bobinator so,if lift:helloWorld.howdy/ maps to Class HelloWorld#howdy,i assume lift:bindand lift:msgs map to Class Bind and Class Msgs, with some special sauce for the method? 11:15 jorgeortiz85 actually, all the directives

[Lift] Re: directives versus snippets

2009-04-10 Thread Jorge Ortiz
Huh? lift: snippet, surround, embed, ignore, comet, children, a, form, loc, and with-param are all built-in in liftTagProcessing. Yes, they're overrideable, but imo it'd be nicer if they were Just A Snippet, like, say, lift:msgs. lift:bind is just bad naming. it's not actually a directive, it's

[Lift] Re: directives versus snippets

2009-04-10 Thread David Pollak
Who you gonna believe? :-) There's a dispatcher in Lift and it checks for user-supplied snippets before dispatching to the hard-coded snippet names. You can override the built-in names and there are a bunch of different snippet dispatch mechanisms (by convention, by partial function, hard-coded)

[Lift] Re: directives versus snippets

2009-04-10 Thread David Pollak
On Fri, Apr 10, 2009 at 11:31 AM, Jorge Ortiz jorge.or...@gmail.com wrote: Huh? lift: snippet, surround, embed, ignore, comet, children, a, form, loc, and with-param are all built-in in liftTagProcessing. Yes, they're overrideable, but imo it'd be nicer if they were Just A Snippet, like,

[Lift] Re: directives versus snippets

2009-04-10 Thread bob
done. thanks guys On Apr 10, 11:36 am, David Pollak feeder.of.the.be...@gmail.com wrote: On Fri, Apr 10, 2009 at 11:31 AM, Jorge Ortiz jorge.or...@gmail.com wrote: Huh? lift: snippet, surround, embed, ignore, comet, children, a, form, loc, and with-param are all built-in in