Re: Lilypond hogging a processor and slowing down

2017-02-16 Thread Peter Toye
Thanks Anders and SoundFromSound for this advice. It worked fine, and the 
simple one-bar file is now down to 0.8 seconds which is far more civilised.

 
All the best,

Peter
mailto:lilyp...@ptoye.com
www.ptoye.com___
lilypond-user mailing list
lilypond-user@gnu.org
https://lists.gnu.org/mailman/listinfo/lilypond-user


Re: Lilypond hogging a processor and slowing down

2017-02-15 Thread SoundsFromSound
Anders Eriksson wrote
> One thing that can take a lot of time is building Font database.
> 
> There seems to be a "bug" in Lilypond on Windows so that the font 
> database is created every time!
*
> A workaround is to delete the directory
> 
> %homepath%\ .lilypond-fonts.cache-2
*
> 
> The first time you Engrave it create the font database, but the next 
> time it's already done...
> 
> // Anders

Anders, that fixed my slow engraving speeds on Windows 10 several times in
the past, great advice!!



-
composer | sound designer | asmr artist 
LilyPond Tutorials (for beginners) --> http://bit.ly/bcl-lilypond
--
View this message in context: 
http://lilypond.1069038.n5.nabble.com/Lilypond-hogging-a-processor-and-slowing-down-tp200149p200158.html
Sent from the User mailing list archive at Nabble.com.

___
lilypond-user mailing list
lilypond-user@gnu.org
https://lists.gnu.org/mailman/listinfo/lilypond-user


Re: Lilypond hogging a processor and slowing down

2017-02-15 Thread SoundsFromSound
ptoye wrote
> 
*
> Windows 7. LP 2.19.52
*
> 
> -
> 
> In the last few days LP has slowed right down when using Frescobaldi -
> engraving a one-bar snippet took 25 seconds! And it was completely hogging
> one processor - 24.9% utilisation on a 4-processor machine.
> 
> Any ideas?
> 
> Peter
> mailto:

> lilypond@

> www.ptoye.com 

Peter,

One core? 25% /usage/? That's really not a problem for any modern /
quad-core system. That's nothing. It shouldn't cause any instability on the
overall computer. Now, are you experiencing slow /engraving/ times? That's a
bit different...

On Windows, I've found that rebuilding the font cache does indeed "fix" the
"slow LilyPond engraving" issue that's crept up from time to time. Not an
issue on GNU/Linux machines in my experience.

It's as simple as clearing the font cache and I've noticed flawless zippy
engraving speeds after that. From as bad as 45 seconds down to 5 seconds in
no time!

Not sure if this applies to Windows 7, but you could try that if you see
engraving speeds slow down (not related to CPU threads, per se).

Hope this helps.

Now, if LilyPond ever maxes out 4 cores + 4 cores of hyper-threading to 98%
CPU, then that's a problem. But that won't be happening anytime soon...   ;)

Have a good one!




-
composer | sound designer | asmr artist 
LilyPond Tutorials (for beginners) --> http://bit.ly/bcl-lilypond
--
View this message in context: 
http://lilypond.1069038.n5.nabble.com/Lilypond-hogging-a-processor-and-slowing-down-tp200149p200157.html
Sent from the User mailing list archive at Nabble.com.

___
lilypond-user mailing list
lilypond-user@gnu.org
https://lists.gnu.org/mailman/listinfo/lilypond-user


Re: Lilypond hogging a processor and slowing down

2017-02-15 Thread Anders Eriksson

One thing that can take a lot of time is building Font database.

There seems to be a "bug" in Lilypond on Windows so that the font 
database is created every time!


A workaround is to delete the directory

%homepath%\ .lilypond-fonts.cache-2

The first time you Engrave it create the font database, but the next 
time it's already done...


NB! If you're using multiple versions of Lilypond you need to do this 
every time you change version:


// Anders


On 2017-02-15 15:38, Peter Toye wrote:

Re: Lilypond hogging a processor and slowing down Phil,

You're right - I should have said.

Windows 7. LP 2.19.52

Best regards,

Peter
mailto:lilyp...@ptoye.com
www.ptoye.com <http://www.ptoye.com>

-
Wednesday, February 15, 2017, 1:15:38 PM, you wrote:


Lilypond version?  Operating system?

--
Phil Holmes


- Original Message -
*From: *Peter Toye <mailto:lilyp...@ptoye.com>
*To: *lilypond-user@gnu.org <mailto:lilypond-user@gnu.org>
*Sent:* Wednesday, February 15, 2017 12:50 PM
*Subject:* Lilypond hogging a processor and slowing down

In the last few days LP has slowed right down when using Frescobaldi - 
engraving a one-bar snippet took 25 seconds! And it was completely 
hogging one processor - 24.9% utilisation on a 4-processor machine.


The only thing that I can think of is that inadvertently I 
double-clicked on the LP icon rather than the Frescobaldi one at some 
stage before the slowup happened, but that just produced the standard 
test file output.


I've tried uninstalling and re-installing LP, but that didn't change 
anything.


Any ideas?

Peter
mailto:lilyp...@ptoye.com
www.ptoye.com <http://www.ptoye.com>

___
lilypond-user mailing list
lilypond-user@gnu.org
https://lists.gnu.org/mailman/listinfo/lilypond-user



___
lilypond-user mailing list
lilypond-user@gnu.org
https://lists.gnu.org/mailman/listinfo/lilypond-user


___
lilypond-user mailing list
lilypond-user@gnu.org
https://lists.gnu.org/mailman/listinfo/lilypond-user


Re: Lilypond hogging a processor and slowing down

2017-02-15 Thread Peter Toye
Phil,

You're right - I should have said.

Windows 7. LP 2.19.52

Best regards,

Peter
mailto:lilyp...@ptoye.com
www.ptoye.com

-
Wednesday, February 15, 2017, 1:15:38 PM, you wrote:


Lilypond version?  Operating system?

--
Phil Holmes
 
 
- Original Message - 
From: Peter Toye
To: lilypond-user@gnu.org
Sent: Wednesday, February 15, 2017 12:50 PM
Subject: Lilypond hogging a processor and slowing down

In the last few days LP has slowed right down when using Frescobaldi - 
engraving a one-bar snippet took 25 seconds! And it was completely hogging one 
processor - 24.9% utilisation on a 4-processor machine.

The only thing that I can think of is that inadvertently I double-clicked on 
the LP icon rather than the Frescobaldi one at some stage before the slowup 
happened, but that just produced the standard test file output.

I've tried uninstalling and re-installing LP, but that didn't change anything.

Any ideas?

Peter
mailto:lilyp...@ptoye.com
www.ptoye.com 

___
lilypond-user mailing list
lilypond-user@gnu.org
https://lists.gnu.org/mailman/listinfo/lilypond-user___
lilypond-user mailing list
lilypond-user@gnu.org
https://lists.gnu.org/mailman/listinfo/lilypond-user


Re: Lilypond hogging a processor and slowing down

2017-02-15 Thread Robin Bannister

Peter Toye wrote:


... it was completely hogging one processor
- 24.9% utilisation on a 4-processor machine.



That's quite normal.
It's hard to spread the load, and Lilypond doesn't try.
Maybe this is the first time you have looked this closely.


Cheers,
Robin

___
lilypond-user mailing list
lilypond-user@gnu.org
https://lists.gnu.org/mailman/listinfo/lilypond-user


Re: Lilypond hogging a processor and slowing down

2017-02-15 Thread Phil Holmes
Lilypond hogging a processor and slowing downLilypond version?  Operating 
system?

--
Phil Holmes


  - Original Message - 
  From: Peter Toye 
  To: lilypond-user@gnu.org 
  Sent: Wednesday, February 15, 2017 12:50 PM
  Subject: Lilypond hogging a processor and slowing down


  In the last few days LP has slowed right down when using Frescobaldi - 
engraving a one-bar snippet took 25 seconds! And it was completely hogging one 
processor - 24.9% utilisation on a 4-processor machine.

  The only thing that I can think of is that inadvertently I double-clicked on 
the LP icon rather than the Frescobaldi one at some stage before the slowup 
happened, but that just produced the standard test file output.

  I've tried uninstalling and re-installing LP, but that didn't change anything.

  Any ideas?

  Peter
  mailto:lilyp...@ptoye.com
  www.ptoye.com


--


  ___
  lilypond-user mailing list
  lilypond-user@gnu.org
  https://lists.gnu.org/mailman/listinfo/lilypond-user
___
lilypond-user mailing list
lilypond-user@gnu.org
https://lists.gnu.org/mailman/listinfo/lilypond-user