Re: [PATCH v1 2/2] scsi: ufs: add support to allow non standard behaviours (quirks)

2015-04-07 Thread Gilad Broner
Some implementation of UFS host controller HW might have some non-standard behaviours (quirks) when compared to behaviour specified by UFSHCI specification. This patch add support to allow specifying all such quirks to standard UFS host controller driver so standard driver takes them into

Re: [PATCH v1 1/2] scsi: ufs-qcom: save controller revision info in internal structure

2015-04-07 Thread Gilad Broner
Sometimes, specific information about the UFS controller revision is required in order to determine certain operations or execute controller dependent quirks. In order to avoid reading the controller revision multiple times, we simply read it once and save this information in internal

Re: [PATCH v3 1/5] mfd: devicetree: bindings: Add Qualcomm RPM regulator subnodes

2015-04-07 Thread Lee Jones
On Mon, 06 Apr 2015, Bjorn Andersson wrote: Add the regulator subnodes to the Qualcomm RPM MFD device tree bindings. Reviewed-by: Stephen Boyd sb...@codeaurora.org Signed-off-by: Bjorn Andersson bjorn.anders...@sonymobile.com --- Changes since v2: - s/notes/nodes from Stephen

Re: [PATCH V2] tty: serial: Add const to struct uart_ops declarations

2015-04-07 Thread Patrice Chotard
Hi On 04/05/2015 08:24 PM, Joe Perches wrote: These structs can be const, so make them const. Miscellanea: o Add static to struct uart_ops declaration in bfin_sport_uart Signed-off-by: Joe Perches j...@perches.com --- [...] for drivers/tty/serial/st-asc.c | 2 +-

Re: [PATCH v3 2/5] regulator: qcom: Don't enable DRMS in driver

2015-04-07 Thread Mark Brown
On Mon, Apr 06, 2015 at 04:33:57PM -0700, Bjorn Andersson wrote: The driver itself should not flag regulators as being DRMS compatible, this should come from board or dt files. I'm missing patch 1, please check and resend. signature.asc Description: Digital signature

Re: [PATCH V2] tty: serial: Add const to struct uart_ops declarations

2015-04-07 Thread Vineet Gupta
On Sunday 05 April 2015 11:55 PM, Joe Perches wrote: These structs can be const, so make them const. Miscellanea: o Add static to struct uart_ops declaration in bfin_sport_uart Signed-off-by: Joe Perches j...@perches.commailto:j...@perches.com --- On Sun, 2015-04-05 at 00:04 +0200, Stefan

Re: [PATCH] pinctrl: Add support for PM8916 GPIO's and MPP's

2015-04-07 Thread Linus Walleij
On Tue, Mar 31, 2015 at 11:37 AM, Ivan T. Ivanov ivan.iva...@linaro.org wrote: Add compatible string definitions and supported pin functions. Signed-off-by: Ivan T. Ivanov ivan.iva...@linaro.org Björn, can you ACK/look at this? Yours, Linus Walleij -- To unsubscribe from this list: send the

[PATCH] tty: serial: msm: Fix mask value of RFR level

2015-04-07 Thread Pramod Gurav
According to documents The RFR_LEVEL1 in UART_DM_MR1 can be programmed in bits 31:8 but the masks only bits 17:8. Correct the same. Signed-off-by: Pramod Gurav gpra...@codeaurora.org --- drivers/tty/serial/msm_serial.h | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git

Re: [PATCH v3 2/5] regulator: qcom: Don't enable DRMS in driver

2015-04-07 Thread Bjorn Andersson
On Tue, Apr 7, 2015 at 4:11 AM, Mark Brown broo...@kernel.org wrote: On Mon, Apr 06, 2015 at 04:33:57PM -0700, Bjorn Andersson wrote: The driver itself should not flag regulators as being DRMS compatible, this should come from board or dt files. I'm missing patch 1, please check and resend.

[PATCH v2] clk: qcom: Fix parent_map translations

2015-04-07 Thread Georgi Djakov
When we introduced the parent_map tables, we missed to update some of the functions where mapping is translated. Fix this. Signed-off-by: Georgi Djakov georgi.dja...@linaro.org --- Changes since v1: * Pass parent map to _freq_tbl_determine_rate() drivers/clk/qcom/clk-rcg.c | 26

Re: [PATCH 2/3] drm:msm: Initial Add Writeback Support

2015-04-07 Thread jilaiw
On Thu, Apr 02, 2015 at 10:29:52AM -0400, Rob Clark wrote: So, from a quick look, it seems like there is a lot of potential to split the v4l part out into some drm helpers.. it looks pretty generic(ish), or at least it could be with some strategically placed vfuncs in drm_v4l2_helper_funcs.

[PATCH] drm/msm: Call drm_prime_gem_destroy to clean up imported GEM object

2015-04-07 Thread Jilai Wang
If the GEM object is imported, drm_prime_gem_destroy needs to be called to clean up dma buffer related information. Signed-off-by: Jilai Wang jil...@codeaurora.org --- drivers/gpu/drm/msm/msm_gem.c | 1 + 1 file changed, 1 insertion(+) diff --git a/drivers/gpu/drm/msm/msm_gem.c

[PATCH 2/3] drm:msm: Initial Add Writeback Support (V2)

2015-04-07 Thread Jilai Wang
Add writeback support in msm kms framework. V1: Initial change V2: Address Rob/Paul/Emil's comments Signed-off-by: Jilai Wang jil...@codeaurora.org --- drivers/gpu/drm/msm/Kconfig | 10 + drivers/gpu/drm/msm/Makefile | 7 +

Re: [PATCH v4 04/10] eeprom: Add a simple EEPROM framework for eeprom consumers

2015-04-07 Thread Stephen Boyd
On 03/30, Srinivas Kandagatla wrote: @@ -130,6 +138,37 @@ static struct class eeprom_class = { .dev_release= eeprom_release, }; +static int of_eeprom_match(struct device *dev, const void *eeprom_np) +{ + return dev-of_node == eeprom_np; +} + +static struct eeprom_device

Re: [PATCH v4 05/10] eeprom: Add bindings for simple eeprom framework

2015-04-07 Thread Mark Brown
On Tue, Apr 07, 2015 at 06:35:49PM +0100, Srinivas Kandagatla wrote: On 06/04/15 16:04, Matt Porter wrote: On Mon, Apr 06, 2015 at 09:11:05AM -0500, Rob Herring wrote: The generic binding could really use a read-only property here as this is a common hardware attribute for many nvmem devices.

Re: [PATCH v4 05/10] eeprom: Add bindings for simple eeprom framework

2015-04-07 Thread Srinivas Kandagatla
On 07/04/15 18:46, Mark Brown wrote: On Tue, Apr 07, 2015 at 06:35:49PM +0100, Srinivas Kandagatla wrote: On 06/04/15 16:04, Matt Porter wrote: On Mon, Apr 06, 2015 at 09:11:05AM -0500, Rob Herring wrote: The generic binding could really use a read-only property here as this is a common

Re: [PATCH v4 05/10] eeprom: Add bindings for simple eeprom framework

2015-04-07 Thread Matt Porter
On Tue, Apr 07, 2015 at 07:03:30PM +0100, Srinivas Kandagatla wrote: On 07/04/15 18:46, Mark Brown wrote: On Tue, Apr 07, 2015 at 06:35:49PM +0100, Srinivas Kandagatla wrote: On 06/04/15 16:04, Matt Porter wrote: On Mon, Apr 06, 2015 at 09:11:05AM -0500, Rob Herring wrote: The generic

Re: [PATCH v4 04/10] eeprom: Add a simple EEPROM framework for eeprom consumers

2015-04-07 Thread Srinivas Kandagatla
Thanks Stephen for review, On 07/04/15 19:45, Stephen Boyd wrote: On 03/30, Srinivas Kandagatla wrote: @@ -130,6 +138,37 @@ static struct class eeprom_class = { .dev_release= eeprom_release, }; +static int of_eeprom_match(struct device *dev, const void *eeprom_np) +{ +

Re: [PATCH] tty: serial: msm: Fix mask value of RFR level

2015-04-07 Thread Stephen Boyd
On 04/07/15 06:47, Pramod Gurav wrote: According to documents The RFR_LEVEL1 in UART_DM_MR1 can be That is UART_DM_MR1 programmed in bits 31:8 but the masks only bits 17:8. Correct the same. Signed-off-by: Pramod Gurav gpra...@codeaurora.org --- drivers/tty/serial/msm_serial.h | 2 +- 1

RE: [PATCH V2 2/6] i2c: qup: Add V2 tags support

2015-04-07 Thread Sricharan
Hi Andy, -Original Message- From: linux-arm-kernel [mailto:linux-arm-kernel- boun...@lists.infradead.org] On Behalf Of Andy Gross Sent: Tuesday, April 07, 2015 10:37 AM To: Sricharan R Cc: srich...@qti.qualcomm.com; devicet...@vger.kernel.org; linux-arm- m...@vger.kernel.org;

Re: [PATCH] pinctrl: Add support for PM8916 GPIO's and MPP's

2015-04-07 Thread Bjorn Andersson
On Tue, Mar 31, 2015 at 2:37 AM, Ivan T. Ivanov ivan.iva...@linaro.org wrote: Add compatible string definitions and supported pin functions. Signed-off-by: Ivan T. Ivanov ivan.iva...@linaro.org --- [..] diff --git a/include/dt-bindings/pinctrl/qcom,pmic-gpio.h