Re: [PATCH v1 1/7] pid: Introduce helper task_is_in_root_ns()

2021-12-06 Thread Leon Romanovsky
On Mon, Dec 06, 2021 at 03:03:58PM +0800, Leo Yan wrote: > Hi Leon, > > On Mon, Dec 06, 2021 at 08:49:01AM +0200, Leon Romanovsky wrote: > > On Sun, Dec 05, 2021 at 10:50:59PM +0800, Leo Yan wrote: > > [...] > > > > +static inline bool task_is_in_root_ns(struct task_struct *tsk) > > > > It is

Re: [PATCH v1 1/7] pid: Introduce helper task_is_in_root_ns()

2021-12-06 Thread Leo Yan
Hi Leon, On Mon, Dec 06, 2021 at 08:49:01AM +0200, Leon Romanovsky wrote: > On Sun, Dec 05, 2021 at 10:50:59PM +0800, Leo Yan wrote: [...] > > +static inline bool task_is_in_root_ns(struct task_struct *tsk) > > It is bad that this name doesn't reflect PID nature of this namespace. > Won't it

Re: [PATCH v1 1/7] pid: Introduce helper task_is_in_root_ns()

2021-12-06 Thread Leon Romanovsky
On Sun, Dec 05, 2021 at 10:50:59PM +0800, Leo Yan wrote: > Currently the kernel uses open code in multiple places to check if a > task is in the root PID namespace with the kind of format: > > if (task_active_pid_ns(current) == _pid_ns) > do_something(); > > This patch creates a new

[PATCH v1 1/7] pid: Introduce helper task_is_in_root_ns()

2021-12-05 Thread Leo Yan
Currently the kernel uses open code in multiple places to check if a task is in the root PID namespace with the kind of format: if (task_active_pid_ns(current) == _pid_ns) do_something(); This patch creates a new helper function, task_is_in_root_ns(), it returns true if a passed task is