Re: [PATCH 4/9] block: Move blk_freeze_queue() and blk_unfreeze_queue() code

2016-09-27 Thread Johannes Thumshirn
On Tue, Sep 27, 2016 at 08:26:19AM +0200, Hannes Reinecke wrote:
> On 09/26/2016 08:27 PM, Bart Van Assche wrote:
> > Move the blk_freeze_queue() and blk_unfreeze_queue() implementations
> > from block/blk-mq.c to block/blk-core.c. Drop "_mq" from the name of
> > the functions that have been moved.
> > 
> > Signed-off-by: Bart Van Assche 
> > ---
> >  block/blk-core.c | 45 +
> >  block/blk-mq.c   | 41 +++--
> >  block/blk.h  |  3 +++
> >  3 files changed, 51 insertions(+), 38 deletions(-)
> > 
> > diff --git a/block/blk-core.c b/block/blk-core.c
> > index b75d688..8cc8006 100644
> > --- a/block/blk-core.c
> > +++ b/block/blk-core.c
> > @@ -682,6 +682,51 @@ static void blk_queue_usage_counter_release(struct 
> > percpu_ref *ref)
> > wake_up_all(>mq_freeze_wq);
> >  }
> >  
> > +void blk_freeze_queue_start(struct request_queue *q)
> > +{
> > +   int freeze_depth;
> > +
> > +   freeze_depth = atomic_inc_return(>mq_freeze_depth);
> > +   if (freeze_depth == 1) {
> > +   percpu_ref_kill(>q_usage_counter);
> > +   blk_mq_run_hw_queues(q, false);
> > +   }
> > +}
> > +
> As you dropped the 'mq_' prefix, maybe you should rename the counter to
> 'freeze_depth', to?

See PATCH 6/9

-- 
Johannes Thumshirn  Storage
jthumsh...@suse.de+49 911 74053 689
SUSE LINUX GmbH, Maxfeldstr. 5, 90409 Nürnberg
GF: Felix Imendörffer, Jane Smithard, Graham Norton
HRB 21284 (AG Nürnberg)
Key fingerprint = EC38 9CAB C2C4 F25D 8600 D0D0 0393 969D 2D76 0850
--
To unsubscribe from this list: send the line "unsubscribe linux-block" in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html


Re: [PATCH 4/9] block: Move blk_freeze_queue() and blk_unfreeze_queue() code

2016-09-27 Thread Hannes Reinecke
On 09/26/2016 08:27 PM, Bart Van Assche wrote:
> Move the blk_freeze_queue() and blk_unfreeze_queue() implementations
> from block/blk-mq.c to block/blk-core.c. Drop "_mq" from the name of
> the functions that have been moved.
> 
> Signed-off-by: Bart Van Assche 
> ---
>  block/blk-core.c | 45 +
>  block/blk-mq.c   | 41 +++--
>  block/blk.h  |  3 +++
>  3 files changed, 51 insertions(+), 38 deletions(-)
> 
> diff --git a/block/blk-core.c b/block/blk-core.c
> index b75d688..8cc8006 100644
> --- a/block/blk-core.c
> +++ b/block/blk-core.c
> @@ -682,6 +682,51 @@ static void blk_queue_usage_counter_release(struct 
> percpu_ref *ref)
>   wake_up_all(>mq_freeze_wq);
>  }
>  
> +void blk_freeze_queue_start(struct request_queue *q)
> +{
> + int freeze_depth;
> +
> + freeze_depth = atomic_inc_return(>mq_freeze_depth);
> + if (freeze_depth == 1) {
> + percpu_ref_kill(>q_usage_counter);
> + blk_mq_run_hw_queues(q, false);
> + }
> +}
> +
As you dropped the 'mq_' prefix, maybe you should rename the counter to
'freeze_depth', to?
And are you sure this works in the !mq case, too?

> +void blk_freeze_queue_wait(struct request_queue *q)
> +{
> + wait_event(q->mq_freeze_wq, percpu_ref_is_zero(>q_usage_counter));
> +}
> +
Same here, rename ->mq_freeze_wq to ->freeze_wq.

Cheers,

Hannes
-- 
Dr. Hannes ReineckeTeamlead Storage & Networking
h...@suse.de   +49 911 74053 688
SUSE LINUX GmbH, Maxfeldstr. 5, 90409 Nürnberg
GF: F. Imendörffer, J. Smithard, J. Guild, D. Upmanyu, G. Norton
HRB 21284 (AG Nürnberg)
--
To unsubscribe from this list: send the line "unsubscribe linux-block" in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html


[PATCH 4/9] block: Move blk_freeze_queue() and blk_unfreeze_queue() code

2016-09-26 Thread Bart Van Assche
Move the blk_freeze_queue() and blk_unfreeze_queue() implementations
from block/blk-mq.c to block/blk-core.c. Drop "_mq" from the name of
the functions that have been moved.

Signed-off-by: Bart Van Assche 
---
 block/blk-core.c | 45 +
 block/blk-mq.c   | 41 +++--
 block/blk.h  |  3 +++
 3 files changed, 51 insertions(+), 38 deletions(-)

diff --git a/block/blk-core.c b/block/blk-core.c
index b75d688..8cc8006 100644
--- a/block/blk-core.c
+++ b/block/blk-core.c
@@ -682,6 +682,51 @@ static void blk_queue_usage_counter_release(struct 
percpu_ref *ref)
wake_up_all(>mq_freeze_wq);
 }
 
+void blk_freeze_queue_start(struct request_queue *q)
+{
+   int freeze_depth;
+
+   freeze_depth = atomic_inc_return(>mq_freeze_depth);
+   if (freeze_depth == 1) {
+   percpu_ref_kill(>q_usage_counter);
+   blk_mq_run_hw_queues(q, false);
+   }
+}
+
+void blk_freeze_queue_wait(struct request_queue *q)
+{
+   wait_event(q->mq_freeze_wq, percpu_ref_is_zero(>q_usage_counter));
+}
+
+/*
+ * Guarantee no request is in use, so we can change any data structure of
+ * the queue afterward.
+ */
+void blk_freeze_queue(struct request_queue *q)
+{
+   /*
+* In the !blk_mq case we are only calling this to kill the
+* q_usage_counter, otherwise this increases the freeze depth
+* and waits for it to return to zero.  For this reason there is
+* no blk_unfreeze_queue(), and blk_freeze_queue() is not
+* exported to drivers as the only user for unfreeze is blk_mq.
+*/
+   blk_freeze_queue_start(q);
+   blk_freeze_queue_wait(q);
+}
+
+void blk_unfreeze_queue(struct request_queue *q)
+{
+   int freeze_depth;
+
+   freeze_depth = atomic_dec_return(>mq_freeze_depth);
+   WARN_ON_ONCE(freeze_depth < 0);
+   if (!freeze_depth) {
+   percpu_ref_reinit(>q_usage_counter);
+   wake_up_all(>mq_freeze_wq);
+   }
+}
+
 static void blk_rq_timed_out_timer(unsigned long data)
 {
struct request_queue *q = (struct request_queue *)data;
diff --git a/block/blk-mq.c b/block/blk-mq.c
index 98d4812..50b26df 100644
--- a/block/blk-mq.c
+++ b/block/blk-mq.c
@@ -60,38 +60,10 @@ static void blk_mq_hctx_clear_pending(struct blk_mq_hw_ctx 
*hctx,
 
 void blk_mq_freeze_queue_start(struct request_queue *q)
 {
-   int freeze_depth;
-
-   freeze_depth = atomic_inc_return(>mq_freeze_depth);
-   if (freeze_depth == 1) {
-   percpu_ref_kill(>q_usage_counter);
-   blk_mq_run_hw_queues(q, false);
-   }
+   blk_freeze_queue_start(q);
 }
 EXPORT_SYMBOL_GPL(blk_mq_freeze_queue_start);
 
-static void blk_mq_freeze_queue_wait(struct request_queue *q)
-{
-   wait_event(q->mq_freeze_wq, percpu_ref_is_zero(>q_usage_counter));
-}
-
-/*
- * Guarantee no request is in use, so we can change any data structure of
- * the queue afterward.
- */
-void blk_freeze_queue(struct request_queue *q)
-{
-   /*
-* In the !blk_mq case we are only calling this to kill the
-* q_usage_counter, otherwise this increases the freeze depth
-* and waits for it to return to zero.  For this reason there is
-* no blk_unfreeze_queue(), and blk_freeze_queue() is not
-* exported to drivers as the only user for unfreeze is blk_mq.
-*/
-   blk_mq_freeze_queue_start(q);
-   blk_mq_freeze_queue_wait(q);
-}
-
 void blk_mq_freeze_queue(struct request_queue *q)
 {
/*
@@ -104,14 +76,7 @@ EXPORT_SYMBOL_GPL(blk_mq_freeze_queue);
 
 void blk_mq_unfreeze_queue(struct request_queue *q)
 {
-   int freeze_depth;
-
-   freeze_depth = atomic_dec_return(>mq_freeze_depth);
-   WARN_ON_ONCE(freeze_depth < 0);
-   if (!freeze_depth) {
-   percpu_ref_reinit(>q_usage_counter);
-   wake_up_all(>mq_freeze_wq);
-   }
+   blk_unfreeze_queue(q);
 }
 EXPORT_SYMBOL_GPL(blk_mq_unfreeze_queue);
 
@@ -2177,7 +2142,7 @@ static int blk_mq_queue_reinit_notify(struct 
notifier_block *nb,
list_for_each_entry(q, _q_list, all_q_node)
blk_mq_freeze_queue_start(q);
list_for_each_entry(q, _q_list, all_q_node) {
-   blk_mq_freeze_queue_wait(q);
+   blk_freeze_queue_wait(q);
 
/*
 * timeout handler can't touch hw queue during the
diff --git a/block/blk.h b/block/blk.h
index c37492f..12f7366 100644
--- a/block/blk.h
+++ b/block/blk.h
@@ -71,6 +71,9 @@ void __blk_queue_free_tags(struct request_queue *q);
 bool __blk_end_bidi_request(struct request *rq, int error,
unsigned int nr_bytes, unsigned int bidi_bytes);
 void blk_freeze_queue(struct request_queue *q);
+void blk_freeze_queue_start(struct request_queue *q);
+void blk_freeze_queue_wait(struct request_queue *q);
+void blk_unfreeze_queue(struct request_queue *q);