Re: [PATCH V5 12/17] blk-throttle: add interface to configure idle time threshold

2017-01-09 Thread Tejun Heo
On Thu, Dec 15, 2016 at 12:33:03PM -0800, Shaohua Li wrote: > @@ -180,6 +180,8 @@ struct throtl_data > unsigned int limit_index; > bool limit_valid[LIMIT_CNT]; > > + u64 dft_idle_ttime_threshold; BTW, wouldn't idle_time be a better name for these? Currently, it's "idle thinktime

[PATCH V5 12/17] blk-throttle: add interface to configure idle time threshold

2016-12-15 Thread Shaohua Li
Add interface to configure the threshold. The io.low interface will like: echo "8:16 rbps=2097152 wbps=max idle=2000" > io.low idle is in microsecond unit. Signed-off-by: Shaohua Li --- block/blk-throttle.c | 27 --- 1 file changed, 24 insertions(+), 3 deletions(-) diff