Re: [PATCH 1/5] blk-throttle: Move three assignments for the variable "ret" in tg_set_max()

2017-01-23 Thread Johannes Thumshirn
On Mon, Jan 23, 2017 at 11:00:15AM +0100, SF Markus Elfring wrote:
> >> @@ -1327,27 +1327,30 @@ static ssize_t tg_set_max(struct kernfs_open_file 
> >> *of,
> >>break;
> >>ctx.body += len;
> >>  
> >> -  ret = -EINVAL;
> >>p = tok;
> >>strsep(, "=");
> >> -  if (!p || (sscanf(p, "%llu", ) != 1 && strcmp(p, "max")))
> >> +  if (!p || (sscanf(p, "%llu", ) != 1 && strcmp(p, "max"))) {
> >> +  ret = -EINVAL;
> >>goto out_finish;
> >> +  }
> > 
> > Sorry, I don't like this patch. We know the next error if we encounter one
> > will be EINVAL until we change it.
> 
> Thanks for your constructive feedback.
> 
> 
> > Your patch doesn't introduce a functual change and doesn't improve 
> > readability,
> > so I don't really see a point for it.
> 
> We have got different preferences for the placement of error code settings.
Yes we do, so what's the point? Both are OK. Please don't go down that road it
opens so much potential for needless bikeshedding and waste all of our
(including your) time.

Thanks,
Johannes

-- 
Johannes Thumshirn  Storage
jthumsh...@suse.de+49 911 74053 689
SUSE LINUX GmbH, Maxfeldstr. 5, 90409 Nürnberg
GF: Felix Imendörffer, Jane Smithard, Graham Norton
HRB 21284 (AG Nürnberg)
Key fingerprint = EC38 9CAB C2C4 F25D 8600 D0D0 0393 969D 2D76 0850
--
To unsubscribe from this list: send the line "unsubscribe linux-block" in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html


Re: [PATCH 1/5] blk-throttle: Move three assignments for the variable "ret" in tg_set_max()

2017-01-23 Thread Johannes Thumshirn
On Sun, Jan 22, 2017 at 09:31:29AM +0100, SF Markus Elfring wrote:
> From: Markus Elfring 
> Date: Sat, 21 Jan 2017 21:23:06 +0100
> 
> A local variable was set to an error code before a concrete error situation
> was detected. Thus move the corresponding assignments into if branches
> to indicate a software failure there.
> 
> Signed-off-by: Markus Elfring 
> ---
>  block/blk-throttle.c | 23 +--
>  1 file changed, 13 insertions(+), 10 deletions(-)
> 
> diff --git a/block/blk-throttle.c b/block/blk-throttle.c
> index 6f4c96e5f86b..51d112deb02e 100644
> --- a/block/blk-throttle.c
> +++ b/block/blk-throttle.c
> @@ -1327,27 +1327,30 @@ static ssize_t tg_set_max(struct kernfs_open_file *of,
>   break;
>   ctx.body += len;
>  
> - ret = -EINVAL;
>   p = tok;
>   strsep(, "=");
> - if (!p || (sscanf(p, "%llu", ) != 1 && strcmp(p, "max")))
> + if (!p || (sscanf(p, "%llu", ) != 1 && strcmp(p, "max"))) {
> + ret = -EINVAL;
>   goto out_finish;
> + }

Sorry, I don't like this patch. We know the next error if we encounter one
will be EINVAL until we change it. Your patch doesn't introduce a functual
change and doesn't improve readability, so I don't really see a point for it.

Byte,
Johannes

-- 
Johannes Thumshirn  Storage
jthumsh...@suse.de+49 911 74053 689
SUSE LINUX GmbH, Maxfeldstr. 5, 90409 Nürnberg
GF: Felix Imendörffer, Jane Smithard, Graham Norton
HRB 21284 (AG Nürnberg)
Key fingerprint = EC38 9CAB C2C4 F25D 8600 D0D0 0393 969D 2D76 0850
--
To unsubscribe from this list: send the line "unsubscribe linux-block" in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html


[PATCH 1/5] blk-throttle: Move three assignments for the variable "ret" in tg_set_max()

2017-01-22 Thread SF Markus Elfring
From: Markus Elfring 
Date: Sat, 21 Jan 2017 21:23:06 +0100

A local variable was set to an error code before a concrete error situation
was detected. Thus move the corresponding assignments into if branches
to indicate a software failure there.

Signed-off-by: Markus Elfring 
---
 block/blk-throttle.c | 23 +--
 1 file changed, 13 insertions(+), 10 deletions(-)

diff --git a/block/blk-throttle.c b/block/blk-throttle.c
index 6f4c96e5f86b..51d112deb02e 100644
--- a/block/blk-throttle.c
+++ b/block/blk-throttle.c
@@ -1327,27 +1327,30 @@ static ssize_t tg_set_max(struct kernfs_open_file *of,
break;
ctx.body += len;
 
-   ret = -EINVAL;
p = tok;
strsep(, "=");
-   if (!p || (sscanf(p, "%llu", ) != 1 && strcmp(p, "max")))
+   if (!p || (sscanf(p, "%llu", ) != 1 && strcmp(p, "max"))) {
+   ret = -EINVAL;
goto out_finish;
+   }
 
-   ret = -ERANGE;
-   if (!val)
+   if (!val) {
+   ret = -ERANGE;
goto out_finish;
+   }
 
-   ret = -EINVAL;
-   if (!strcmp(tok, "rbps"))
+   if (!strcmp(tok, "rbps")) {
v[0] = val;
-   else if (!strcmp(tok, "wbps"))
+   } else if (!strcmp(tok, "wbps")) {
v[1] = val;
-   else if (!strcmp(tok, "riops"))
+   } else if (!strcmp(tok, "riops")) {
v[2] = min_t(u64, val, UINT_MAX);
-   else if (!strcmp(tok, "wiops"))
+   } else if (!strcmp(tok, "wiops")) {
v[3] = min_t(u64, val, UINT_MAX);
-   else
+   } else {
+   ret = -EINVAL;
goto out_finish;
+   }
}
 
tg->bps[READ] = v[0];
-- 
2.11.0

--
To unsubscribe from this list: send the line "unsubscribe linux-block" in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html