[PATCH V3] btrfs: Print Warning only if ENOSPC_DEBUG is enabled

2016-03-11 Thread Ashish Samant
Dont print warning for ENOSPC error unless ENOSPC_DEBUG is enabled. Use btrfs_debug if it is enabled. Signed-off-by: Ashish Samant V3: - Use btrfs_debug() instead of WARN() per David Sterba's comment. V2: - Add a commit message. --- fs/btrfs/delayed-inode.c | 5

Re: The *right* algorithm for determining the amount of free space

2016-03-11 Thread Hugo Mills
On Fri, Mar 11, 2016 at 10:17:03PM +, Hugo Mills wrote: >I know I promised this a while ago and didn't get round to it, but > Henk's tinkering reminded me of it. I note specifically that the > algorithm used to give the free space to plain old df gives incorrect > results -- probably

The *right* algorithm for determining the amount of free space

2016-03-11 Thread Hugo Mills
I know I promised this a while ago and didn't get round to it, but Henk's tinkering reminded me of it. I note specifically that the algorithm used to give the free space to plain old df gives incorrect results -- probably because it's not using the algorithm below. There is an algorithm

Re: [PATCH 2/2] btrfs: do not write corrupted metadata blocks to disk

2016-03-11 Thread Nicholas D Steeves
On 10 March 2016 at 06:10, Alex Lyakas wrote: > csum_dirty_buffer was issuing a warning in case the extent buffer > did not look alright, but was still returning success. > Let's return error in this case, and also add an additional sanity > check on the extent buffer

Re: [PATCH 00/15] Device delete by id

2016-03-11 Thread Anand Jain
On 02/26/2016 01:59 AM, David Sterba wrote: On Mon, Feb 15, 2016 at 06:33:56PM +0100, David Sterba wrote: this patchset extends the ioctl arugments to take an id so we can delete a device by it. It reuses the existing structure btrfs_ioctl_vol_args_v2 and extends it in na backward-compatible

Re: dstat shows unexpected result for two disk RAID1

2016-03-11 Thread Chris Murphy
On Fri, Mar 11, 2016 at 5:10 PM, Nicholas D Steeves wrote: > P.S. Rather than parity, I mean instead of distributing into stripes, do a > copy! raid56 by definition are parity based, so I'd say no that's confusing to turn it into something it's not. -- Chris Murphy -- To

Re: dstat shows unexpected result for two disk RAID1

2016-03-11 Thread Nicholas D Steeves
On 9 March 2016 at 23:06, Duncan <1i5t5.dun...@cox.net> wrote: > > Meanwhile, while parity-raid (aka raid56) isn't as bad as it was when > first nominally completed in 3.19, as of 4.4 (and I think 4.5 as I've not > seen a full trace yet, let alone a fix), there's still at least one known > bug

Re: dstat shows unexpected result for two disk RAID1

2016-03-11 Thread Nicholas D Steeves
P.S. Rather than parity, I mean instead of distributing into stripes, do a copy! -- To unsubscribe from this list: send the line "unsubscribe linux-btrfs" in the body of a message to majord...@vger.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.html

Re: [PATCH v2] btrfs-progs: btrfs-debug-tree: show the compression method string

2016-03-11 Thread David Sterba
On Fri, Mar 11, 2016 at 01:09:02PM +0800, Xiaoguang Wang wrote: > From: Wang Xiaoguang > > Signed-off-by: Wang Xiaoguang Aplied with minor changes, thanks. -- To unsubscribe from this list: send the line "unsubscribe linux-btrfs" in the

Re: [PATCH v7 01/20] btrfs: dedup: Introduce dedup framework and its header

2016-03-11 Thread David Sterba
On Thu, Mar 10, 2016 at 08:57:12AM +0800, Qu Wenruo wrote: > > The ioctl FIDEDUPERANGE and the tool duperemove both use "dupe". > > It would be nice if we could be consistent and all use the same > > abbreviation. > > Yes, current kernel VFS level offline dedup uses the name "dedupe". > But on

Re: [PATCH] btrfs-progs: Dont' stop scanning of devices at first failed device

2016-03-11 Thread David Sterba
On Thu, Mar 10, 2016 at 04:04:35PM -0800, Yauhen Kharuzhy wrote: > When 'btrfs device scan' command is invoked, it scans all devices, > check them for btrfs superblock and add devices with btrfs to a list. > > Next, each device from the list is passed to kernel where it is handled > in the

Re: [PATCH] btrfs-progs: Fix device scan to interpret its argument properly

2016-03-11 Thread David Sterba
On Fri, Mar 11, 2016 at 09:26:13AM +0900, Satoru Takeuchi wrote: > Fix the following bug. > > > # btrfs device scan -- /dev/sdb > ERROR: not a block device: -- > > > It should work as follow. > >

RAID10 filesystem and device usage

2016-03-11 Thread Henk Slager
Hi all, since I use RAID10 (half a year now), I see that Unallocated: numbers in btrfs fi/de us are not what I expect and probably more is not fully correct. I once made a simple change to the code (see patch below) but the I got unsure how people would like to interpret the output of the

[patch] btrfs: scrub: silence an uninitialized variable warning

2016-03-11 Thread Dan Carpenter
It's basically harmless if "ref_level" isn't initialized since it's only used for an error message, but it causes a static checker warning. Signed-off-by: Dan Carpenter diff --git a/fs/btrfs/scrub.c b/fs/btrfs/scrub.c index e42aa27..39dbdcb 100644 ---

[PATCH 1/2] btrfs-progs: copy btrfs-calc-size to inspect-internal tree-stats

2016-03-11 Thread Alexander Fougner
Signed-off-by: Alexander Fougner --- Makefile.in | 3 +- btrfs-calc-size.c | 482 +-- cmds-inspect-tree-stats.c | 506 ++ cmds-inspect-tree-stats.h | 26 +++

[PATCH 2/2] btrfs-progs: update docs and completion for tree-stats

2016-03-11 Thread Alexander Fougner
Signed-off-by: Alexander Fougner --- Documentation/btrfs-inspect-internal.asciidoc | 10 ++ btrfs-completion | 2 +- 2 files changed, 11 insertions(+), 1 deletion(-) diff --git a/Documentation/btrfs-inspect-internal.asciidoc

Re: [PATCH] btrfs: Fix misspellings in comments.

2016-03-11 Thread David Sterba
On Fri, Mar 04, 2016 at 11:23:12AM -0800, Adam Buchbinder wrote: > Signed-off-by: Adam Buchbinder Acked-by: David Sterba -- To unsubscribe from this list: send the line "unsubscribe linux-btrfs" in the body of a message to majord...@vger.kernel.org

Re: [PATCH] btrfs: Output more info for enospc_debug mount option

2016-03-11 Thread David Sterba
On Tue, Mar 01, 2016 at 04:08:21PM +0800, Qu Wenruo wrote: > As one user in mail list report reproducible balance ENOSPC error, it's > better to add more debug info for enospc_debug mount option. > > Reported-by: Marc Haber > Signed-off-by: Qu Wenruo

Re: [PATCH v3] Btrfs: Show a warning message if one of objectid reaches its highest value

2016-03-11 Thread David Sterba
On Wed, Mar 09, 2016 at 03:18:57PM +0900, Satoru Takeuchi wrote: > It's better to show a warning message for the exceptional case > that one of objectid (in most case, inode number) reaches its > highest value. For example, if inode cache is off and this event > happens, we can't create any file

Re: [PATCH V2] btrfs: Print Warning only if ENOSPC_DEBUG is enabled

2016-03-11 Thread David Sterba
On Mon, Nov 02, 2015 at 01:55:10PM -0800, Ashish Samant wrote: > Dont call WARN_ON for ENOSPC error unless ENOSPC_DEBUG is enabled. > > Signed-off-by : Ashish Samant > --- > fs/btrfs/delayed-inode.c | 6 +- > 1 file changed, 5 insertions(+), 1 deletion(-) > > diff

Re: [PATCH] btrfs: rename btrfs_print_info to btrfs_print_mod_info

2016-03-11 Thread David Sterba
On Thu, Mar 10, 2016 at 12:49:14PM +0800, Anand Jain wrote: > So that it indicates what it does. > > Signed-off-by: Anand Jain Reviewed-by: David Sterba -- To unsubscribe from this list: send the line "unsubscribe linux-btrfs" in the body of a message

Re: [PATCH v2] btrfs: move btrfs_compression_type to compression.h

2016-03-11 Thread David Sterba
On Thu, Mar 10, 2016 at 05:26:59PM +0800, Anand Jain wrote: > So that its better organized. > > Signed-off-by: Anand Jain Reviewed-by: David Sterba -- To unsubscribe from this list: send the line "unsubscribe linux-btrfs" in the body of a message to

Re: [patch] btrfs: scrub: silence an uninitialized variable warning

2016-03-11 Thread David Sterba
On Fri, Mar 11, 2016 at 11:08:56AM +0300, Dan Carpenter wrote: > It's basically harmless if "ref_level" isn't initialized since it's only > used for an error message, but it causes a static checker warning. > > Signed-off-by: Dan Carpenter Reviewed-by: David Sterba

Snapshots slowing system

2016-03-11 Thread Pete
I though I would post this in case it was useful info for the list. No help needed as I have a fix (sort of). I've an PC with a 3 core Phenom 720 CPU, 8GB of RAM. / is in a RAID0 SSD btrfs file system and data, home directories, various bits of data etc, on 2x3TB disks at btrfs RAID1. The data