Re: 40TB volume taking over 16 hours to mount, any ideas?

2014-08-09 Thread Andy Smith
Hello, On Sat, Aug 09, 2014 at 01:38:34PM +1000, Russell Coker wrote: On Fri, 8 Aug 2014 16:35:29 Jose Ildefonso Camargo Tolosa wrote: Then, after reading here and there, decided to try to use a newer kernel, tried 3.15.8. Well, it is still mounting after ~16 hours, and I got messages

Is this normal? Should I use scrub?

2015-04-01 Thread Andy Smith
Hello, I have a 6 device RAID-1 filesystem: $ sudo btrfs fi df /srv/tank Data, RAID1: total=1.24TiB, used=1.24TiB System, RAID1: total=32.00MiB, used=184.00KiB Metadata, RAID1: total=3.00GiB, used=1.65GiB unknown, single: total=512.00MiB, used=0.00 $ sudo btrfs fi sh /srv/tank Label: 'tank'

Re: Is this normal? Should I use scrub?

2015-04-02 Thread Andy Smith
Hi Hugo, Thanks for your help. On Wed, Apr 01, 2015 at 03:42:02PM +, Hugo Mills wrote: On Wed, Apr 01, 2015 at 03:11:14PM +, Andy Smith wrote: Should I run a scrub as well? Yes. The output you've had so far will be just the pieces that the FS has tried to read, and where

Re: Problems with "btrfs dev remove" of dead disk

2016-02-14 Thread Andy Smith
Hi Chris, On Sun, Feb 14, 2016 at 04:49:29PM -0700, Chris Murphy wrote: > On Sun, Feb 14, 2016 at 2:55 PM, Andy Smith <a...@strugglers.net> wrote: > > $ sudo btrfs dev remove /dev/sdh /srv/tank > > ERROR: not a block device: /dev/sdh > > > Since now it's a missing

Problems with "btrfs dev remove" of dead disk

2016-02-14 Thread Andy Smith
Hi, One of my drives died earlier in a fairly emphatic way in that not only did it show IO errors and got removed as a device by the kernel, but it was also making audible grinding/screeching noises until I hot unplugged it. Feb 14 18:29:36 specialbrew kernel: [27576156.070961] ata6.15: SATA