[PATCH] crypto: add .gitignore for crypto/*.-asn1.[ch] files

2015-06-25 Thread Alexander Kuleshov
There are two generated files: crypto/rsakey-asn1.c and crypto/raskey-asn1.h, after the cfc2bb32b31371d6bffc6bf2da3548f20ad48c83 commit. Let's add .gitignore to ignore *-asn1.[ch] files. Signed-off-by: Alexander Kuleshov kuleshovm...@gmail.com --- crypto/.gitignore | 1 + 1 file changed, 1

Re: [PATCH 02/13] dmaengine: Introduce dma_request_slave_channel_compat_reason()

2015-06-25 Thread Arnd Bergmann
On Wednesday 24 June 2015 21:54:01 Vinod Koul wrote: It would be nice to find another name for the dma_request_slave_channel_compat() so with the new name we could have chance to rearrange the parameters: (dev, name, mask, fn, fn_param) We would end up with the following APIs, all

akcipher use

2015-06-25 Thread Stephan Mueller
Hi Tadeusz, I do have a few questions around the akcipher API. The API offers access to the raw asym encryption and decryption operations. The normal use of asym ciphers is the hybrid mode. That opens the following questions: - how would a hardware implementation offering only a hybrid asym

[PATCH] crypto: add .gitignore for crypto/*.-asn1.[ch] files

2015-06-25 Thread Alexander Kuleshov
There are two generated files: crypto/rsakey-asn1.c and crypto/raskey-asn1.h, after the cfc2bb32b31371d6bffc6bf2da3548f20ad48c83 commit. Let's add .gitignore for it. Signed-off-by: Alexander Kuleshov kuleshovm...@gmail.com --- crypto/.gitignore | 1 + 1 file changed, 1 insertion(+) create mode

Re: [PATCH] crypto: aesni - fix failing setkey for rfc4106-gcm-aesni

2015-06-25 Thread Herbert Xu
On Wed, Jun 24, 2015 at 07:14:21AM -0700, Tadeusz Struk wrote: rfc4106(gcm(aes)) uses cbc(aes) to generate hash key. cbc(aes) needs chainiv, but the chainiv gets initialized after aesni_intel when both are statically linked so the setkey fails. This patch forces aesni_intel to be initialized

Re: [PATCH] crypto: mv_cesa - fix up for of_get_named_gen_pool() rename

2015-06-25 Thread Herbert Xu
On Thu, Jun 25, 2015 at 10:37:50AM +0200, Simon Guinot wrote: This patch fixes the following build error: drivers/crypto/mv_cesa.c: In function 'mv_cesa_get_sram': drivers/crypto/mv_cesa.c:1037: error: implicit declaration of function 'of_get_named_gen_pool' drivers/crypto/mv_cesa.c:1038:

Re: testmgr in user space

2015-06-25 Thread Herbert Xu
On Wed, Jun 24, 2015 at 07:34:34AM +0200, Stephan Mueller wrote: While we are at it: wouldn't it make sense to move the tcrypt.c out to the tools/ directory? tcrypt is currently a kernel module so it would be difficult to move in its current form. Please see my response to Linus with regards

Re: [PATCH v2] crypto: testmgr - don't print info about missing test for gcm-aes-aesni

2015-06-25 Thread Herbert Xu
On Wed, Jun 24, 2015 at 09:01:30AM -0700, Tadeusz Struk wrote: Don't print info about missing test for the internal helper __driver-gcm-aes-aesni changes in v2: - marked test as fips allowed Signed-off-by: Tadeusz Struk tadeusz.st...@intel.com Applied. -- Email: Herbert Xu

Re: [PATCH] crypto: add .gitignore for crypto/*.-asn1.[ch] files

2015-06-25 Thread Herbert Xu
On Thu, Jun 25, 2015 at 04:18:03PM +0600, Alexander Kuleshov wrote: There are two generated files: crypto/rsakey-asn1.c and crypto/raskey-asn1.h, after the cfc2bb32b31371d6bffc6bf2da3548f20ad48c83 commit. Let's add .gitignore to ignore *-asn1.[ch] files. Signed-off-by: Alexander Kuleshov

Re: [PATCH] keys: Use non-conflicting variable name

2015-06-25 Thread Herbert Xu
On Wed, Jun 24, 2015 at 03:27:01PM -0700, Guenter Roeck wrote: arm64:allmodconfig fails to build as follows. In file included from include/acpi/platform/aclinux.h:74:0, from include/acpi/platform/acenv.h:173, from include/acpi/acpi.h:56,

Re: [PATCH] crypto: mv_cesa - fix up for of_get_named_gen_pool() rename

2015-06-25 Thread Paul Gortmaker
On Thu, Jun 25, 2015 at 11:30 AM, Herbert Xu herb...@gondor.apana.org.au wrote: On Thu, Jun 25, 2015 at 10:37:50AM +0200, Simon Guinot wrote: This patch fixes the following build error: drivers/crypto/mv_cesa.c: In function 'mv_cesa_get_sram': drivers/crypto/mv_cesa.c:1037: error: implicit

Re: [PATCH] crypto-jitterentropy: Delete unnecessary checks before the function call kzfree

2015-06-25 Thread Herbert Xu
On Tue, Jun 23, 2015 at 11:20:21PM +0200, SF Markus Elfring wrote: From: Markus Elfring elfr...@users.sourceforge.net Date: Tue, 23 Jun 2015 22:30:21 +0200 The kzfree() function tests whether its argument is NULL and then returns immediately. Thus the test around the call is not needed.

RESEND: Performance loss due to commit 37c3185 ([NET]: Added GSO toggle)

2015-06-25 Thread leroy christophe
Hello Herbert, In commit [NET]: Added GSO toggle 37c3185a02d4b85fbe134bf5204535405dd2c957, you force NETIF_F_HW_CSUM if GSO feature is selected. By default, SW GSO is active as soon as a network board has NETIF_F_SG feature. This means that function sk_setup_caps() forces NETIF_F_HW_CSUM for

Re: [PATCH] crypto: jitterentropy - avoid compiler warnings

2015-06-25 Thread Herbert Xu
On Tue, Jun 23, 2015 at 04:18:54PM +0200, Stephan Mueller wrote: Hi Geert, Guenter, may I ask that you check that the following patch compiles without errors or warnings on your systems? Though, when I test that patch with the AVR32 cross compiler, I get a warning about the code being

Re: [PATCH] crypto: akcipher - fix spelling cihper - cipher

2015-06-25 Thread Herbert Xu
On Tue, Jun 23, 2015 at 10:18:53AM -0700, Tadeusz Struk wrote: Signed-off-by: Tadeusz Struk tadeusz.st...@intel.com Applied. -- Email: Herbert Xu herb...@gondor.apana.org.au Home Page: http://gondor.apana.org.au/~herbert/ PGP Key: http://gondor.apana.org.au/~herbert/pubkey.txt -- To unsubscribe

Re: [PATCH] crypto: mv_cesa - fix up for of_get_named_gen_pool() rename

2015-06-25 Thread Simon Guinot
On Thu, Jun 25, 2015 at 11:30:06PM +0800, Herbert Xu wrote: On Thu, Jun 25, 2015 at 10:37:50AM +0200, Simon Guinot wrote: This patch fixes the following build error: drivers/crypto/mv_cesa.c: In function 'mv_cesa_get_sram': drivers/crypto/mv_cesa.c:1037: error: implicit declaration of

Re: [PATCH] crypto: aesni - fix failing setkey for rfc4106-gcm-aesni

2015-06-25 Thread Tadeusz Struk
On 06/25/2015 07:25 AM, Herbert Xu wrote: On Wed, Jun 24, 2015 at 07:14:21AM -0700, Tadeusz Struk wrote: rfc4106(gcm(aes)) uses cbc(aes) to generate hash key. cbc(aes) needs chainiv, but the chainiv gets initialized after aesni_intel when both are statically linked so the setkey fails. This

Re: akcipher use

2015-06-25 Thread Tadeusz Struk
On 06/25/2015 04:58 AM, Stephan Mueller wrote: Hi Tadeusz, I do have a few questions around the akcipher API. The API offers access to the raw asym encryption and decryption operations. The normal use of asym ciphers is the hybrid mode. That opens the following questions: - how

Re: [PATCH] crypto: aesni - fix failing setkey for rfc4106-gcm-aesni

2015-06-25 Thread Linus Torvalds
On Thu, Jun 25, 2015 at 7:25 AM, Herbert Xu herb...@gondor.apana.org.au wrote: Linus, could you confirm that you have AESNI built into the kernel and not as a module? Yes, confirmed. Linus -- To unsubscribe from this list: send the line unsubscribe linux-crypto in the body of

[PATCH] crypto: mv_cesa - fix up for of_get_named_gen_pool() rename

2015-06-25 Thread Simon Guinot
This patch fixes the following build error: drivers/crypto/mv_cesa.c: In function 'mv_cesa_get_sram': drivers/crypto/mv_cesa.c:1037: error: implicit declaration of function 'of_get_named_gen_pool' drivers/crypto/mv_cesa.c:1038: warning: assignment makes pointer from integer without a cast