Re: [PATCH] treewide: remove duplicate includes

2017-12-03 Thread Greg KH
On Mon, Dec 04, 2017 at 03:19:39AM +0530, Pravin Shedge wrote: > These duplicate includes have been found with scripts/checkincludes.pl but > they have been removed manually to avoid removing false positives. > > Unit Testing: > > - build successful > - LTP testsuite passes. > - checkpatch.pl

Re: [PATCH] treewide: remove duplicate includes

2017-12-03 Thread Joe Perches
On Mon, 2017-12-04 at 03:19 +0530, Pravin Shedge wrote: > These duplicate includes have been found with scripts/checkincludes.pl but > they have been removed manually to avoid removing false positives. Can you list the duplicates that were not removed as well please?

Re: [PATCH] treewide: remove duplicate includes

2017-12-03 Thread Luis R. Rodriguez
On Mon, Dec 04, 2017 at 03:19:39AM +0530, Pravin Shedge wrote: > These duplicate includes have been found with scripts/checkincludes.pl but > they have been removed manually to avoid removing false positives. > > Unit Testing: > > - build successful > - LTP testsuite passes. > - checkpatch.pl

[PATCH] treewide: remove duplicate includes

2017-12-03 Thread Pravin Shedge
These duplicate includes have been found with scripts/checkincludes.pl but they have been removed manually to avoid removing false positives. Unit Testing: - build successful - LTP testsuite passes. - checkpatch.pl passes Signed-off-by: Pravin Shedge ---

Re: BUG: unable to handle kernel paging request in crypto_chacha20_crypt

2017-12-03 Thread Eric Biggers
On Sun, Dec 03, 2017 at 06:24:02AM -0800, syzbot wrote: > Hello, > > syzkaller hit the following crash on > dbf9f9124937139e6fcd3f6c64154a699408b481 > git://git.cmpxchg.org/linux-mmots.git/master > compiler: gcc (GCC) 7.1.1 20170620 > .config is attached > Raw console output is attached. > >

[PATCH 04/10] staging: ccree: fix indentation of var assignment

2017-12-03 Thread Gilad Ben-Yossef
Fix indentation of var assignment split across lines for better readability. Signed-off-by: Gilad Ben-Yossef --- drivers/staging/ccree/ssi_aead.c | 4 ++-- 1 file changed, 2 insertions(+), 2 deletions(-) diff --git a/drivers/staging/ccree/ssi_aead.c

[PATCH 03/10] staging: ccree: remove more unnecessary parentheses

2017-12-03 Thread Gilad Ben-Yossef
The removal of likely/unlikely unearthed some more unnecessary parentheses. Remove them for better readability. Signed-off-by: Gilad Ben-Yossef --- drivers/staging/ccree/ssi_buffer_mgr.c | 4 ++-- drivers/staging/ccree/ssi_driver.c | 6 +++---

[PATCH 05/10] staging: ccree: remove braces for single statement blocks

2017-12-03 Thread Gilad Ben-Yossef
Remove braces from single statement if clause. Signed-off-by: Gilad Ben-Yossef --- drivers/staging/ccree/ssi_request_mgr.c | 3 +-- 1 file changed, 1 insertion(+), 2 deletions(-) diff --git a/drivers/staging/ccree/ssi_request_mgr.c

[PATCH 10/10] staging: ccree: amend aead func def for readability

2017-12-03 Thread Gilad Ben-Yossef
Func definitions in the aead implementation were did not adhere to coding style. Fix them for better readability. Signed-off-by: Gilad Ben-Yossef --- drivers/staging/ccree/ssi_aead.c | 141 ++- 1 file changed, 51 insertions(+), 90

[PATCH 06/10] staging: ccree: remove interim DT docs

2017-12-03 Thread Gilad Ben-Yossef
As proper DT bindings doc where submitted and ACKed, remove the interim one. Signed-off-by: Gilad Ben-Yossef --- .../devicetree/bindings/crypto/arm-cryptocell.txt | 27 -- 1 file changed, 27 deletions(-) delete mode 100644

[PATCH 08/10] staging: ccree: NULLify backup_info when unused

2017-12-03 Thread Gilad Ben-Yossef
backup_info field is only allocated for decrypt code path. The field was not nullified when not used causing a kfree in an error handling path to attempt to free random addresses as uncovered in stress testing. Fixes: 737aed947f9b ("staging: ccree: save ciphertext for CTS IV") Cc:

[PATCH 09/10] staging: ccree: fix AEAD func naming convention

2017-12-03 Thread Gilad Ben-Yossef
The aead files was using a func naming convention which was inconsistent (ssi vs. cc), included a useless prefix (ssi_aead) and often used too long function names producing monster func names such as ssi_aead_gcm_setup_ghash_desc() that made the call site code hard to read. Make the code more

[PATCH 07/10] staging: ccree: update TODO list

2017-12-03 Thread Gilad Ben-Yossef
Update the ccree staging TODO list in light of recent work. Signed-off-by: Gilad Ben-Yossef --- drivers/staging/ccree/TODO | 23 ++- 1 file changed, 2 insertions(+), 21 deletions(-) diff --git a/drivers/staging/ccree/TODO b/drivers/staging/ccree/TODO

[PATCH 01/10] staging: ccree: remove inline qualifiers

2017-12-03 Thread Gilad Ben-Yossef
The ccree drivers was marking a lot of big functions in C file as static inline for no good reason. Remove the inline qualifier from any but the few truly single line functions. Signed-off-by: Gilad Ben-Yossef --- drivers/staging/ccree/ssi_aead.c| 40

[PATCH 02/10] staging: ccree: remove unproven likely/unlikely

2017-12-03 Thread Gilad Ben-Yossef
The ccree code made a lot of use of likely/unlikely qualifiers without proven measurements showing any benefits. Remove them all until we see what is justified and what is not. Signed-off-by: Gilad Ben-Yossef --- drivers/staging/ccree/ssi_aead.c| 57 ++--

[PATCH 00/10] staging: ccree: cleanups & fixes

2017-12-03 Thread Gilad Ben-Yossef
Another batch of ccree work. Includes the usual mix of mostly cleanups and one fix. Also includes an updated TODO to reflect recent progress and removal of interim documentation of device tree strings as the official string and documentation thereof got blessed into the crypto tree. Gilad