For code readability, the probe() function uses 'dev' variable instead
of '&pdev->dev', so update remaining places.

Signed-off-by: Krzysztof Kozlowski <krzysztof.kozlow...@canonical.com>
---
 drivers/crypto/s5p-sss.c | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/drivers/crypto/s5p-sss.c b/drivers/crypto/s5p-sss.c
index 8c310816deab..55aa3a71169b 100644
--- a/drivers/crypto/s5p-sss.c
+++ b/drivers/crypto/s5p-sss.c
@@ -2186,14 +2186,14 @@ static int s5p_aes_probe(struct platform_device *pdev)
        }
 
        pdata->res = res;
-       pdata->ioaddr = devm_ioremap_resource(&pdev->dev, res);
+       pdata->ioaddr = devm_ioremap_resource(dev, res);
        if (IS_ERR(pdata->ioaddr)) {
                if (!pdata->use_hash)
                        return PTR_ERR(pdata->ioaddr);
                /* try AES without HASH */
                res->end -= 0x300;
                pdata->use_hash = false;
-               pdata->ioaddr = devm_ioremap_resource(&pdev->dev, res);
+               pdata->ioaddr = devm_ioremap_resource(dev, res);
                if (IS_ERR(pdata->ioaddr))
                        return PTR_ERR(pdata->ioaddr);
        }
-- 
2.25.1

Reply via email to