Re: [PATCHv2 1/2] arch: Move CONFIG_DEBUG_RODATA and CONFIG_SET_MODULE_RONX to be common

2017-02-06 Thread Pavel Machek
On Mon 2017-02-06 10:47:45, Laura Abbott wrote: > On 02/03/2017 01:08 PM, Kees Cook wrote: > > On Fri, Feb 3, 2017 at 12:29 PM, Russell King - ARM Linux > > wrote: > >> On Fri, Feb 03, 2017 at 11:45:56AM -0800, Kees Cook wrote: > >>> On Fri, Feb 3, 2017 at 9:52 AM, Laura

Re: [PATCHv3 1/2] arch: Move CONFIG_DEBUG_RODATA and CONFIG_SET_MODULE_RONX to be common

2017-02-06 Thread Ingo Molnar
* Laura Abbott wrote: > > There are multiple architectures that support CONFIG_DEBUG_RODATA and > CONFIG_SET_MODULE_RONX. These options also now have the ability to be > turned off at runtime. Move these to an architecture independent > location and make these options

Re: [PATCH 1/2] kconfig/mconf: add jumping tip in title of search result textbox

2017-02-06 Thread Du, Changbin
On Mon, Feb 06, 2017 at 02:00:51PM +0200, Jani Nikula wrote: > On Mon, 06 Feb 2017, changbin...@intel.com wrote: > > From: Changbin Du > > > > Prompt user how to quickly jump to the item he/she is interested in. > > :o > > All these years. I... I didn't know. Thanks! >

Re: [PATCH 2/2] Documentation/kconfig: add search jump feature description

2017-02-06 Thread Du, Changbin
On Mon, Feb 06, 2017 at 07:42:11AM -0700, Jim Davis wrote: > On Mon, Feb 6, 2017 at 12:46 AM, wrote: > > From: Changbin Du > > > > Kernel menuconfig support direct jumping function from the search > > result. This is a very convenient feature but

[PATCHv3 2/2] arch: Rename CONFIG_DEBUG_RODATA and CONFIG_DEBUG_MODULE_RONX

2017-02-06 Thread Laura Abbott
Both of these options are poorly named. The features they provide are necessary for system security and should not be considered debug only. Change the names to CONFIG_STRICT_KERNEL_RWX and CONFIG_STRICT_MODULE_RWX to better describe what these options do. Signed-off-by: Laura Abbott

[PATCHv3 0/2] Hardening configs refactor/rename

2017-02-06 Thread Laura Abbott
Hi, This is v3 of my series to rename/refactor CONFIG_DEBUG_RODATA and CONFIG_DEBUG_SET_MODULE_RONX. Among other objections, there shouldn't be 'debug' in the name since these provide necessary kernel protection. v3 mostly focuses on changing how the Kconfig dependencies work for the refactor.

[PATCHv3 1/2] arch: Move CONFIG_DEBUG_RODATA and CONFIG_SET_MODULE_RONX to be common

2017-02-06 Thread Laura Abbott
There are multiple architectures that support CONFIG_DEBUG_RODATA and CONFIG_SET_MODULE_RONX. These options also now have the ability to be turned off at runtime. Move these to an architecture independent location and make these options def_bool y for almost all of those arches. Signed-off-by:

Re: [PATCH linux v6 1/6] hwmon: Add core On-Chip Controller support for POWER CPUs

2017-02-06 Thread kbuild test robot
Hi Edward, [auto build test WARNING on hwmon/hwmon-next] [also build test WARNING on v4.10-rc7 next-20170206] [cannot apply to linux/master] [if your patch is applied to the wrong git tree, please drop us a note to help improve the system] url: https://github.com/0day-ci/linux/commits

Re: [PATCH v8 07/12] dt-bindings: i2c: i2c-mux-simple: document i2c-mux-simple bindings

2017-02-06 Thread Rob Herring
On Fri, Feb 3, 2017 at 2:25 AM, Peter Rosin wrote: > On 2017-02-02 17:08, Rob Herring wrote: >> On Tue, Jan 31, 2017 at 1:36 AM, Peter Rosin wrote: >>> If you see this new driver as something that is superseding the existing >>> i2c-mux-gpio driver, I'm sad to

Re: [PATCH 0/3 v2] PM / docs: linux/pm.h kerneldocs update and conversion of two docs to reST

2017-02-06 Thread Rafael J. Wysocki
On Mon, Feb 6, 2017 at 7:28 PM, Jonathan Corbet wrote: > On Thu, 02 Feb 2017 01:30:08 +0100 > "Rafael J. Wysocki" wrote: > >> This is a new (and hopefully final) iteration of the series of patches >> starting >> the conversion of power management driver API

[PATCH linux v6 2/6] hwmon: occ: Add sysfs interface

2017-02-06 Thread eajames
From: "Edward A. James" Add a generic mechanism to expose the sensors provided by the OCC in sysfs. Signed-off-by: Edward A. James Signed-off-by: Andrew Jeffery --- Documentation/hwmon/occ | 62 +++

[PATCH linux v6 4/6] hwmon: occ: Add callbacks for parsing P8 OCC datastructures

2017-02-06 Thread eajames
From: "Edward A. James" Add functions to parse the data structures that are specific to the OCC on the POWER8 processor. These are the sensor data structures, including temperature, frequency, power, and "caps." Signed-off-by: Edward A. James

[PATCH linux v6 6/6] hwmon: occ: Add callbacks for parsing P9 OCC datastructures

2017-02-06 Thread eajames
From: "Edward A. James" Add functions to parse the data structures that are specific to the OCC on the POWER9 processor. These are the sensor data structures, including temperature, frequency, power, and "caps." Signed-off-by: Edward A. James

[PATCH linux v6 3/6] hwmon: occ: Add I2C transport implementation for SCOM operations

2017-02-06 Thread eajames
From: "Edward A. James" Add functions to send SCOM operations over I2C bus. The BMC can communicate with the Power8 host processor over I2C, but needs to use SCOM operations in order to access the OCC register space. Signed-off-by: Edward A. James

[PATCH linux v6 0/6] drivers: hwmon: Add On-Chip Controller driver

2017-02-06 Thread eajames
From: "Edward A. James" This patchset adds a hwmon driver to support the OCC (On-Chip Controller) on the IBM POWER8 and POWER9 processors, from a BMC (Baseboard Management Controller). The OCC is an embedded processor that provides real time power and thermal monitoring. The

[PATCH linux v6 5/6] hwmon: occ: Add hwmon implementation for the P8 OCC

2017-02-06 Thread eajames
From: "Edward A. James" Add code to tie the hwmon sysfs code and the POWER8 OCC code together, as well as probe the entire driver from the I2C bus. I2C is the communication method between the BMC and the P8 OCC. Signed-off-by: Edward A. James

[PATCH linux v6 1/6] hwmon: Add core On-Chip Controller support for POWER CPUs

2017-02-06 Thread eajames
From: "Edward A. James" Add core support for polling the OCC for it's sensor data and parsing that data into sensor-specific information. Signed-off-by: Edward A. James Signed-off-by: Andrew Jeffery --- Documentation/hwmon/occ| 40

Re: [PATCHv2 2/2] arch: Rename CONFIG_DEBUG_RODATA and CONFIG_DEBUG_MODULE_RONX

2017-02-06 Thread Kees Cook
On Mon, Feb 6, 2017 at 10:49 AM, Laura Abbott wrote: > On 02/03/2017 12:03 PM, Kees Cook wrote: >> On Fri, Feb 3, 2017 at 9:52 AM, Laura Abbott wrote: >>> >>> Both of these options are poorly named. The features they provide are >>> necessary for system

Re: [PATCHv2 2/2] arch: Rename CONFIG_DEBUG_RODATA and CONFIG_DEBUG_MODULE_RONX

2017-02-06 Thread Laura Abbott
On 02/03/2017 12:03 PM, Kees Cook wrote: > On Fri, Feb 3, 2017 at 9:52 AM, Laura Abbott wrote: >> >> Both of these options are poorly named. The features they provide are >> necessary for system security and should not be considered debug only. >> Change the name to something

Re: [PATCHv2 1/2] arch: Move CONFIG_DEBUG_RODATA and CONFIG_SET_MODULE_RONX to be common

2017-02-06 Thread Laura Abbott
On 02/03/2017 01:08 PM, Kees Cook wrote: > On Fri, Feb 3, 2017 at 12:29 PM, Russell King - ARM Linux > wrote: >> On Fri, Feb 03, 2017 at 11:45:56AM -0800, Kees Cook wrote: >>> On Fri, Feb 3, 2017 at 9:52 AM, Laura Abbott wrote: diff --git

Re: [PATCH 0/3 v2] PM / docs: linux/pm.h kerneldocs update and conversion of two docs to reST

2017-02-06 Thread Jonathan Corbet
On Thu, 02 Feb 2017 01:30:08 +0100 "Rafael J. Wysocki" wrote: > This is a new (and hopefully final) iteration of the series of patches > starting > the conversion of power management driver API documentation. > > Patch [1/3] updates kerneldoc comments in include/linux/pm.h

Re: [PATCH 2/3] doc-rst: Delete output of failed dot-SVG conversion

2017-02-06 Thread Jonathan Corbet
On Sat, 04 Feb 2017 17:18:43 +0100 Ben Hutchings wrote: > I've now tested this, and found that dot still touches the output file > even if it fails. So changing to -o doesn't fix anything. > > Please apply the original patch. That has now been done. Thanks, jon -- To

Re: [PATCH linux v5 1/6] hwmon: Add core On-Chip Controller support for POWER CPUs

2017-02-06 Thread eajames
On 2017-02-04 17:30, Guenter Roeck wrote: On 01/31/2017 07:43 AM, eaja...@linux.vnet.ibm.com wrote: From: "Edward A. James" Add core support for polling the OCC for it's sensor data and parsing that data into sensor-specific information. Signed-off-by: Edward A. James

Re: [PATCH 2/2] Documentation/kconfig: add search jump feature description

2017-02-06 Thread Jim Davis
On Mon, Feb 6, 2017 at 12:46 AM, wrote: > From: Changbin Du > > Kernel menuconfig support direct jumping function from the search > result. This is a very convenient feature but not documented. So > add a short description to the kconfig

Re: [PATCH 4/4] KVM: MIPS: Implement console output hypercall

2017-02-06 Thread James Hogan
On Mon, Feb 06, 2017 at 02:25:59PM +0100, Paolo Bonzini wrote: > > > On 06/02/2017 11:46, James Hogan wrote: > > Documentation/virtual/kvm/api.txt seems to suggest that > > KVM_EXIT_HYPERCALL is obsolete. When it suggests using KVM_EXIT_MMIO, > > does it simply mean the guest should use MMIO to

Re: [PATCH 4/4] KVM: MIPS: Implement console output hypercall

2017-02-06 Thread Paolo Bonzini
On 06/02/2017 11:46, James Hogan wrote: > Documentation/virtual/kvm/api.txt seems to suggest that > KVM_EXIT_HYPERCALL is obsolete. When it suggests using KVM_EXIT_MMIO, > does it simply mean the guest should use MMIO to some virtio device of > some sort rather than using hypercalls, or that the

Re: [PATCH 2/3] doc-rst: Delete output of failed dot-SVG conversion

2017-02-06 Thread Jani Nikula
On Sat, 04 Feb 2017, Ben Hutchings wrote: > On Wed, 2017-02-01 at 13:20 -0700, Jonathan Corbet wrote: >> On Tue, 31 Jan 2017 15:37:50 + >> Ben Hutchings wrote: >> >> > > I'd just use dot -o.   >> > >> > That does make more sense.  I looked for

Re: [PATCH 1/2] kconfig/mconf: add jumping tip in title of search result textbox

2017-02-06 Thread Jani Nikula
On Mon, 06 Feb 2017, changbin...@intel.com wrote: > From: Changbin Du > > Prompt user how to quickly jump to the item he/she is interested in. :o All these years. I... I didn't know. Thanks! > Signed-off-by: Changbin Du > --- >

[PATCH 3/4] KVM: MIPS: Implement EXIT_VM hypercall

2017-02-06 Thread James Hogan
Implement the MIPS EXIT_VM hypercall used by paravirtual guest kernels. When the guest performs this hypercall, the request is passed to userland in the form of a KVM_EXIT_SYSTEM_EVENT exit reason with system event type KVM_SYSTEM_EVENT_SHUTDOWN. We also document the hypercall along with the

[PATCH 0/4] KVM: MIPS: Hypercalls

2017-02-06 Thread James Hogan
This series implements some basic hypercalls for MIPS KVM, as used by the MIPS paravirtual platform support in Linux and provided by Cavium's VZ KVM implementation. - Patch 1 hooks up trap & emulate to some minimal hypercall infrastructure without any hypercalls implemented yet. VZ support when

[PATCH 1/4] KVM: MIPS: Implement HYPCALL emulation

2017-02-06 Thread James Hogan
Emulate the HYPCALL instruction added in the VZ ASE and used by the MIPS paravirtualised guest support that is already merged. The new hypcall.c handles arguments and the return value, and will handle the individual hypercalls in upcoming commits. Non-zero HYPCALL codes are not handled. We also

[PATCH 2/4] KVM: MIPS: Implement GET_CLOCK_FREQ hypercall

2017-02-06 Thread James Hogan
Implement the MIPS GET_CLOCK_FREQ hypercall used by paravirtual guest kernels. When the guest performs this hypercall, the value of count_hz is returned, which is the current rate of the CP0_Count register. We also document the hypercall along with the others as the documentation was never added.

[PATCH 4/4] KVM: MIPS: Implement console output hypercall

2017-02-06 Thread James Hogan
Implement console output hypercall by exiting back to userland with KVM_EXIT_HYPERCALL, and setting the return value on next KVM_RUN. We also document the hypercall along with the others as the documentation was never added Signed-off-by: James Hogan Cc: Paolo Bonzini